<html>
<head>
<title>2015 Draft:  DE OWAmagbe Odighizua and FS M. Thompson | Big Blue Interactive </title>

<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">
<meta name="keywords" content="ndglbqfkxx">

<meta name="description" content="OWA basically missed the bulk of his rookie year due to injury.  He came in this year and flashed a superb first step.  I thought "hey, this kid might just be a super inside pass rusher and eventually a starting DE" but he hasn't performed.  

What are your thoughts on him coming up large in his 3rd year?  Or do you see him as a backup only type?

M. Thompson flashed at times but he's been IR'd two straight years.  I wonder if the Giants bring him to camp even?  My guess is they will since you need 90 guys.

What are your thoughts on him coming up large in his 3rd year?  Or do you see him as a backup only type?  Do you think he is now healthy? 

"/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="website" />
<meta property="og:description" content="OWA basically missed the bulk of his rookie year due to injury.  He came in this year and flashed a superb first step.  I thought "hey, this kid might just be a super inside pass rusher and eventually a starting DE" but he hasn't performed.  

What are your thoughts on him coming up large in his 3rd year?  Or do you see him as a backup only type?

M. Thompson flashed at times but he's been IR'd two straight years.  I wonder if the Giants bring him to camp even?  My guess is they will since you need 90 guys.

What are your thoughts on him coming up large in his 3rd year?  Or do you see him as a backup only type?  Do you think he is now healthy? 

" /> 
<meta property="og:title" content="2015 Draft:  DE OWAmagbe Odighizua and FS M. Thompson" /> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif" /> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css" />

<link rel="stylesheet" type="text/css" href="anylink.css" />


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}

html, body {
overflow-x: hidden;
}

div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" />

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type="text/javascript"><!--
//<![CDATA[
(function() {
var useSSL = 'https:' == document.location.protocol;
var src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
//]]>
//--></script>
<script type='text/javascript' src='http://img.bnqt.com/lib/js/sdpdfphelper.js'></script>
<script type="text/javascript">
googletag.pubads().enableSyncRendering();
googletag.pubads().setTargeting("title", sdpTargeting.title)
                  .setTargeting('targetPaths', sdpTargeting.targetPaths)
                  .setTargeting('fullPath', sdpTargeting.fullPath)
                  .setTargeting('queryStr', sdpTargeting.queryStr)
                  .setTargeting('domainName', sdpTargeting.domainName);       
</script>
<script type="text/javascript">
window._UrlSegment = window._UrlSegment || ''; 
window._SitePage = window._SitePage || ''; 
_UrlSegment = window.location.toString().replace(/http:\/\//, '').split('/'); 
_SitePage = _UrlSegment[1].match(/^$|^(index.php)+$/i) ? 'main' : 'general'; 
</script>
<!-- End DFP SETUP -->  

<!-- End USA Today Code -->


</head>


<body bgcolor="ffffff">



<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"></a> <img src="images/xpete.gif" alt="The Corner Forum">

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic -->&nbsp;

<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->

<div id="usmg_ad_nfl.general_football_sports_728x90_1a" style="margin:auto;">
<script type='text/javascript'>
googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_nfl.general_football_sports_728x90_1a').addService(googletag.pubads());
googletag.enableServices();
googletag.display('usmg_ad_nfl.general_football_sports_728x90_1a');
</script>
</div>

</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://astore.amazon.com/bigblueintera-20">Books/DVDs</a>
<a href="http://www.shareasale.com/r.cfm?b=277504&u=723646&m=29078&urllink=&afftrack=">Apparel</a>
<a href="http://www.amazon.com/?_encoding=UTF8&camp=1789&creative=9325&linkCode=ur2&tag=bigblueintera-20">Amazon.com</a>
<a href="http://www.ticketmonster.com/New-York-Giants-Tickets?aid=16418">Tickets</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-photo-archive/">Historical Photo Archive</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW" >Standings (NFL.com)</a>
<a href="http://www.nfl.com/teams/newyorkgiants/statistics?team=NYG" target="_NEW" >Statistics (NFL.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/" >Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'home_view_menu')">Home</a>  
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'forum_view_menu')">Corner Forum</a>
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'gameday_view_menu')">Gameday</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_view_menu')">Team</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_building_view_menu')">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info &amp; History</a> -->
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_info_view_menu')">Giants Info &amp; History</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'infolinks_view_menu')">Info/Links</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'shop_view_menu')">BBI Shop</a>
<li><a href="/index.php?mode=10" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'login_menu')">Log In</a>
</ul>

</div><div id="infoline"> </div>

<a name="END"><a href="index.php"><div style="padding-top:20px; padding-bottom:25px;"><img src="/images/back_corner.gif" width="150" height="23" alt="Back to the Corner" border="0"></a></div></a><div id="ad_pad_box"> &nbsp; </div><div class="thread_body" ><div class="thread_main" ><div class="thread_post_header" >  <h1 style="font-size:18px;">2015 Draft:  DE OWAmagbe Odighizua and FS M. Thompson </h1><div class="thread_info"><a href="index.php?mode=5&handle=SGMen"> SGMen </a>  : 12:06 pm</div></div><div class="thread_post_body" > OWA basically missed the bulk of his rookie year due to injury.  He came in this year and flashed a superb first step.  I thought "hey, this kid might just be a super inside pass rusher and eventually a starting DE" but he hasn't performed.  <br />
<br />
What are your thoughts on him coming up large in his 3rd year?  Or do you see him as a backup only type?<br />
<br />
M. Thompson flashed at times but he's been IR'd two straight years.  I wonder if the Giants bring him to camp even?  My guess is they will since you need 90 guys.<br />
<br />
What are your thoughts on him coming up large in his 3rd year?  Or do you see him as a backup only type?  Do you think he is now healthy? <br />
<br />
 </div></div></div><div class="thread_post"><div class="thread_post_header"><b>Owa has been healthy pretty </b><a name="13295579">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jon+in+NYC"> Jon in NYC </a>  : 12:08 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295579">link</a>   </div></div><div class="thread_post_body"> much all year and has been passed over by Okwara and Wynn. If it was going to happen, it would have happened.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Owa has been healthy pretty </b><a name="13295584">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=SGMen"> SGMen </a>  : 12:13 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295584">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=547161&show_all=1#13295579" target="_blank">13295579</a> Jon in NYC said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> much all year and has been passed over by Okwara and Wynn. If it was going to happen, it would have happened. </td>
                                </tr>
                           </table>That was my thinking too.  But I hold out hope that OWA can have a strong off-season and be a pass rush force net year.  Kerry Wynn is a solid run defender and Romeo Okwara is the surprise UDFA along with FS Adams.<br />
<br />
We have four UDFA's on our 53 man roster.  That is amazing.  2 are starting:  Adams and Romeo.</div></div><div class="thread_post"><div class="thread_post_header"><b>it's a great question </b><a name="13295590">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=area+junc"> area junc </a>  : 12:20 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295590">link</a>   </div></div><div class="thread_post_body"> Spags made some ominous comments about him during camp even when he was productive during preseason games. Reading between the lines he is not a smart football player. He was never going to get many DE reps with JPP + OV on the team but the fact he hasn't been called upon with JPP going down is telling. If he had game he'd at least be working in with Okwara and Wynn. <br />
<br />
The real kick in the balls with Owa is missing out on DE Danielle Hunter and RB David Johnson later in the round. There was a pass rushing DE from our favorite school and we took the UCLA kid instead. <br />
<br />
Mykkele Thompson I like as a FS but he seems made of glass. He would've been great to have after DT went down, he got to the sideline from deep middle easily and was a good tackler.</div></div><div class="thread_post"><div class="thread_post_header"><b>I wonder what percent of players </b><a name="13295591">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Hades07"> Hades07 </a>  : 12:20 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295591">link</a>   </div></div><div class="thread_post_body"> On NFL rosters came into the league as UDFA.</div></div><div class="thread_post"><div class="thread_post_header"><b>I don't have any hope for Owa. </b><a name="13295598">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=yatqb"> yatqb </a>  : 12:22 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295598">link</a>   </div></div><div class="thread_post_body"> I just haven't seen anything from him.</div></div><div class="thread_post"><div class="thread_post_header"><b>Owa's </b><a name="13295599">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=PEEJ"> PEEJ </a>  : 12:25 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295599">link</a>   </div></div><div class="thread_post_body"> been dealing on and off with a knee</div></div><div class="thread_post"><div class="thread_post_header"><b>Sy'56  </b><a name="13295607">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=est1986"> est1986 </a>  : 12:32 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295607">link</a>   </div></div><div class="thread_post_body"> Your thoughts on Odighizua ?</div></div><div class="thread_post"><div class="thread_post_header"><b>Owa's More of a 3-4 end/Special Teams guy than a 4-3 end at this point </b><a name="13295608">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JohnF"> JohnF </a>  : 12:33 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295608">link</a>   </div></div><div class="thread_post_body"> Good against the run, limited pass rushing skills (can't leverage outside rush). Reminds me a bit of Gary Jeter, who played a 3-4 end for Parcells. He'd probably do well in New England. Here, not so much.<br />
<br />
So far, he's fit his <a href="http://www.nfl.com/draft/2015/profiles/owamagbe-odighizuwa?id=2552275" target="_blank">NFL scouting report</a>...see below. And I haven't seen any signs he's developing.<br />
<br />
<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">WEAKNESSES Not skilled as a pass rusher. Won't win around the edge often and must prove he can counter back inside. Has dealt with two surgeries on his hip and missed all of 2013 because of it. Lateral agility is limited. Range in pursuit in question. Could be mismatched if forced to cover in space. More unit fit than talented player.<br />
<br />
SOURCES TELL US "He's not Courtney Upshaw, but he could be used kind of like that. I can see him playing in both 4-3 or 3-4, but he can't be counted on as a pass rusher and you have to know that he will be limited to just being a run stopper." -- AFC national scout<br />
<br />
NFL COMPARISON Sam Acho<br />
<br />
BOTTOM LINE Odighizuwa has some scheme versatility, but he's not necessarily a versatile player. Some scouts believe that he could open some eyes with his straight-line speed in his workout, but his marginal pass-rush skills and average athleticism could stunt his draft stock.</td>
                                </tr>
                           </table><br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>After reading that </b><a name="13295628">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=jtfuoco"> jtfuoco </a>  : 12:47 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295628">link</a>   </div></div><div class="thread_post_body"> Yuck and he was a 3rd round pick you would think he is not a Reese type player reading that scouting report</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I wonder what percent of players </b><a name="13295636">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jesse+B"> Jesse B </a>  : 12:56 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295636">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=547161&show_all=1#13295591" target="_blank">13295591</a> Hades07 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> On NFL rosters came into the league as UDFA. </td>
                                </tr>
                           </table><br />
<br />
More than you'd think. <br />
<br />
I bet second contracts for UDFA are better than 4th through 7th round picks but too lazy to try and figure it out</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I don't have any hope for Owa. </b><a name="13295639">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=SGMen"> SGMen </a>  : 12:59 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295639">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=547161&show_all=1#13295598" target="_blank">13295598</a> yatqb said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I just haven't seen anything from him. </td>
                                </tr>
                           </table>Me either.  <br />
<br />
We drafted back-to-back 3rd round DL's and neither of them inspire.<br />
<br />
I wouldn't be shocked if OWA was cut next year in the final cuts of preseason.  I mean, if you can't do more than stop the run occasionally and you have a draft pick with potential for DE you pull the trigger.</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="13295641">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> : 1:01 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295641">link</a>   </div></div><div class="thread_post_body"> This is a REAL head-scratcher. The Giants were really talking up Odighizuwa during his rookie season, even with his injury issues. It sounded like they were thrilled with what they saw on the practice field.</div></div><div class="thread_post"><div class="thread_post_header"><b>Based On Players In The Recent Past With Multiple Injuries  </b><a name="13295647">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Trainmaster"> Trainmaster </a>  : 1:06 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295647">link</a>   </div></div><div class="thread_post_body"> Time to move on from these guys and start planning to replace them on the roster.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: ... </b><a name="13295648">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=SGMen"> SGMen </a>  : 1:06 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295648">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=547161&show_all=1#13295641" target="_blank">13295641</a> Eric from BBI said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> This is a REAL head-scratcher. The Giants were really talking up Odighizuwa during his rookie season, even with his injury issues. It sounded like they were thrilled with what they saw on the practice field. </td>
                                </tr>
                           </table>Assuming I recall correctly, OWA sports a very quick first step.  That is critical in pass rushing.  But I'm guessing the rest hasn't been put "together" yet (technique, lack of pure athleticism) and we'll need to see him through another off-season and camp before we can say "WASTED PICK".<br />
<br />
And DT Bromley has been below average overall as well.<br />
<br />
Not good 3rd round picks.</div></div><div class="thread_post"><div class="thread_post_header"><b>If Okwara and Wynn are playing well </b><a name="13295649">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Giants2012"> Giants2012 </a>  : 1:09 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295649">link</a>   </div></div><div class="thread_post_body"> doesn't necessarily mean Owa is bad.  From what i recall, the Giants thought Owa was a Tuck like player.  Remember, Tuck didn't replace Strahan or Osi, they moved him inside to DT.  With the D-Tackles playing well, where do you put Owa?  <br />
<br />
Maybe it's a plethora of talent. <br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: If Okwara and Wynn are playing well </b><a name="13295655">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=SGMen"> SGMen </a>  : 1:13 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295655">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=547161&show_all=1#13295649" target="_blank">13295649</a> Giants2012 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> doesn't necessarily mean Owa is bad.  From what i recall, the Giants thought Owa was a Tuck like player.  Remember, Tuck didn't replace Strahan or Osi, they moved him inside to DT.  With the D-Tackles playing well, where do you put Owa?  <br />
<br />
Maybe it's a plethora of talent.  </td>
                                </tr>
                           </table>Maybe there is a little merit to the "talent" ahead of OWA.  Maybe,just maybe, some merit.</div></div><div class="thread_post"><div class="thread_post_header"><b>I still have hopes for Odighizuwa </b><a name="13295659">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Anakim"> Anakim </a>  : 1:15 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295659">link</a>   </div></div><div class="thread_post_body"> But he needs to remain healthy. No nagging injuries.</div></div><div class="thread_post"><div class="thread_post_header"><b>Okwara has struggled. </b><a name="13295662">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=area+junc"> area junc </a>  : 1:18 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295662">link</a>   </div></div><div class="thread_post_body"> Don't let the hype fool you. He had nice stats against the Cowboys but they made attacking him their top priority and had some success although it didn't amount to anything. I think last week we saw him get his doors blown off by Lane Johnson. <br />
<br />
He's reasonably managed to maintain the integrity of the defense but beyond that, let's be realistic. I don't think Okwara's great play is keeping Owa from otherwise getting reps.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Okwara has struggled. </b><a name="13295666">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=SGMen"> SGMen </a>  : 1:21 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295666">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=547161&show_all=1#13295662" target="_blank">13295662</a> area junc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Don't let the hype fool you. He had nice stats against the Cowboys but they made attacking him their top priority and had some success although it didn't amount to anything. I think last week we saw him get his doors blown off by Lane Johnson. <br />
<br />
He's reasonably managed to maintain the integrity of the defense but beyond that, let's be realistic. I don't think Okwara's great play is keeping Owa from otherwise getting reps. </td>
                                </tr>
                           </table>Lane Johnson is a top OT and was in shape (surprised me) after being out 10 weeks.  He did dominate Romeo Okwara.  I fully expect he'll be run on this week as well.<br />
<br />
We will miss JPP this game and for the first WC for sure.  Hope we do just enough on defense and offense to get W's.</div></div><div class="thread_post"><div class="thread_post_header"><b>2015 was a really tough year for drafting 4-3 DEs. </b><a name="13295700">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+Blogger"> Big Blue Blogger </a>  : 1:53 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295700">link</a>   </div></div><div class="thread_post_body"> See the link below, to Sy'56's position preview.  Odighizuwa was his third-ranked DE, behind Dante Fowler and Shane Ray.  How many guys on the whole list are two-way starting DEs in a 4-3?  Fowler plays a lot after missing his rookie season, but even he has only one career start.  Ray is an edge-rushing linebacker.  The Patriots made a nice pick in Trey Flowers, who seems to be a good fit for Belichick after a redshirt rookie year.<br />
<br />
Another notable thing about Sy's list is the number of players who have spent at least part of a season on IR since being drafted last spring.<br><a href="http://corner.bigblueinteractive.com/index.php?mode=2&thread=513506"> 2015 NFL Draft Preview - DE/Edge (from Sy'56) </a> - (<a href="http://corner.bigblueinteractive.com/index.php?mode=2&thread=513506" target="_NEW"> New Window </a>)</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: 2015 was a really tough year for drafting 4-3 DEs. </b><a name="13295705">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=SGMen"> SGMen </a>  : 1:58 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295705">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=547161&show_all=1#13295700" target="_blank">13295700</a> Big Blue Blogger said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> See the link below, to Sy'56's position preview.  Odighizuwa was his third-ranked DE, behind Dante Fowler and Shane Ray.  How many guys on the whole list are two-way starting DEs in a 4-3?  Fowler plays a lot after missing his rookie season, but even he has only one career start.  Ray is an edge-rushing linebacker.  The Patriots made a nice pick in Trey Flowers, who seems to be a good fit for Belichick after a redshirt rookie year.<br />
<br />
Another notable thing about Sy's list is the number of players who have spent at least part of a season on IR since being drafted last spring. 2015 NFL Draft Preview - DE/Edge (from Sy'56)  - ( New Window ) </td>
                                </tr>
                           </table>Just shows you what a crap shoot a draft is regardless of position or study.<br />
<br />
As a NY Giants fan, I'm hoping DT Bromley, DE OWA and DE Romeo Okwara all come on strong from here on out.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I still have hopes for Odighizuwa </b><a name="13295707">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  : 1:59 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295707">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=547161&show_all=1#13295659" target="_blank">13295659</a> Anakim said:<br />
<br />
unfortunately he is trending to where hope is all there is...</div></div><div class="thread_post"><div class="thread_post_header"><b>Owa  </b><a name="13295710">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=dancing+blue+bear"> dancing blue bear </a>  : 2:02 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295710">link</a>   </div></div><div class="thread_post_body"> It seems like he is just not going to put it together.  He is def a "specimen" type guy, and IIRC raw and somewhat new to football.  Thing is he didn't even flash to me in the pre season, which is def not a good sign.  Not saying he is garbage or can't take the next step.  <br />
Also, I don't know if he was "passed" by Wynn, but KW is def. ahead of him, and Romeo has passed them both.  I hope the G-Men re-sign JPP.  If so, his roster spot COULD be in jeopardy next year, though it would be surprising to see him cut.  If the G-men draft another DE or find another UDFA DE it is possible.<br />
<br />
Thompson is another story.  I don't think anyone knows what he can do. He has a nice skill set, but  He has been injured so much.  Reminds me of Ole' Cooper Taylor.  Because of Adams, and hopefully Darian T. his roster spot might be in jeopardy next year as well depending on draft / UDFA<br />
<br />
As much as we all might be annoyed that these draft picks are "wasted" consider this...If they are pushed off the roster by UDFA (who are younger and cheaper) you gotta consider it to be the price of poker, and a NET WIN for the Gmen.  <br />
<br />
They can't all be winners, kid<br />
<br />
I don't know if it was TC, lack of depth, or JR, but in the past we seemed to hang on to draft picks just because we drafted them and they would contribute nothing for 4 years and then disappear from the NFL.  That is not a winning recipe</div></div><div class="thread_post"><div class="thread_post_header"><b>Tuck had 1 sack through his first two seasons </b><a name="13295711">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Giants2012"> Giants2012 </a>  : 2:02 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295711">link</a>   </div></div><div class="thread_post_body"> so there is hope for any player no killing it by season 2.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Both </b><a name="13295717">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=AcidTest"> AcidTest </a>  : 2:13 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295717">link</a>   </div></div><div class="thread_post_body"> OO and M. Thompson will come to camp. They've had a rocky start, but we've all seen players start to produce in year three.</div></div><div class="thread_post"><div class="thread_post_header"><b>Third round </b><a name="13295718">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=XBRONX"> XBRONX </a>  : 2:13 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295718">link</a>   </div></div><div class="thread_post_body"> Reese pick says it all.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Owa  </b><a name="13295727">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=mrvax"> mrvax </a>  : 2:23 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295727">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=547161&show_all=1#13295710" target="_blank">13295710</a> dancing blue bear said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br />
I don't know if it was TC, lack of depth, or JR, but in the past we seemed to hang on to draft picks just because we drafted them and they would contribute nothing for 4 years and then disappear from the NFL.  That is not a winning recipe </td>
                                </tr>
                           </table><br />
<br />
I suspect Reese. He has the most to lose for admitting a draft mistake. In their credit, they did shit-can Marvin Austin rather quickly.<br />
<br />
Adrian Robinson was here 2 years too many.</div></div><div class="thread_post"><div class="thread_post_header"><b>How about giving the guy </b><a name="13295731">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=KWALL2"> KWALL2 </a>  : 2:28 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295731">link</a>   </div></div><div class="thread_post_body"> More than 100 career snaps before writing him off?<br />
<br />
He has shown some things.  He just needs more time and he'll get it if he stays healthy.</div></div><div class="thread_post"><div class="thread_post_header"><b>Owa and Bromley have not impressed </b><a name="13295736">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Bluesbreaker"> Bluesbreaker </a>  : 2:33 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295736">link</a>   </div></div><div class="thread_post_body"> Ijuries or not M. Thompson Is made of glass and I was never<br />
big on the pick as it was ...<br />
Okwara seems to have the tools but Lane Johnson made him<br />
look really bad . Owa has made like 2 plays in his career <br />
as Eric said head scratcher .<br />
Bromley has.t shown a whole heck of a lot either it's not<br />
the fact that we drafted them its where we drafted them .<br />
You have to have starters or down the road starters in the<br />
first three rounds if you don't especially when a good<br />
portion of the misses are totally out of football before<br />
there rookie contract is up . We bit the bullet and got<br />
the three best players money can buy on the Defense .<br />
I am unsure of how much we can add in free agency for<br />
the putrid offense but were gonna have to .</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: How about giving the guy </b><a name="13295742">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=est1986"> est1986 </a>  : 2:41 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295742">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=547161&show_all=1#13295731" target="_blank">13295731</a> KWALL2 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> More than 100 career snaps before writing him off?<br />
<br />
He has shown some things.  He just needs more time and he'll get it if he stays healthy. </td>
                                </tr>
                           </table><br />
<br />
2 Years and you can't get on the field for 100 snaps? Not good any way you try to cut it.</div></div><div class="thread_post"><div class="thread_post_header"><b>Try and cut it? </b><a name="13295758">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=KWALL2"> KWALL2 </a>  : 2:48 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295758">link</a>   </div></div><div class="thread_post_body"> He was injured and lostt year 1.<br />
<br />
They drafted him for a reason.  This year he has shown some of the skills that got him drafted.  It's foolish to dismiss the injury in year 1, look at it as "only 100 snaps in 2 years" and write him off.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Try and cut it? </b><a name="13295760">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+%2756"> Big Blue '56 </a>  : 2:49 pm   : <a href="index.php?mode=2&thread=547161&show_all=1#13295760">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=547161&show_all=1#13295758" target="_blank">13295758</a> KWALL2 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> He was injured and lostt year 1.<br />
<br />
They drafted him for a reason.  This year he has shown some of the skills that got him drafted.  It's foolish to dismiss the injury in year 1, look at it as "only 100 snaps in 2 years" and write him off. </td>
                                </tr>
                           </table><br />
<br />
But they will anyway..Surprised?</div></div><a name="END"><a href="index.php"><div style="padding-top:25px; padding-bottom:20px;"><img src="/images/back_corner.gif" width="150" height="23" alt="Back to the Corner" border="0"></a></div></a><div id="ad_side_box">
<div style="height:260px;width:300px;margin:auto;">

<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id="usmg_ad_nfl.general_football_sports_300x250_1a">
<script type='text/javascript'>
googletag.defineSlot('/7103/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250]], 'usmg_ad_nfl.general_football_sports_300x250_1a').addService(googletag.pubads());
googletag.enableServices();
googletag.display('usmg_ad_nfl.general_football_sports_300x250_1a');
</script>
</div>

</div>
<div style="height:260px;width:300px;margin-auto;">

<!-- BEGIN Google Adsense CODE -->

<script type="text/javascript"><!--
google_ad_client = "ca-pub-1566320450447229";
/* Corner Forum - Lower 300x250 Box */
google_ad_slot = "3213469993";
google_ad_width = 300;
google_ad_height = 250;
//-->
</script>
<script type="text/javascript"
src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>

<!-- END Google Adsense CODE -->


</div>
</div>




<div class="footer">


<p style="width:400px;float:left;"><b>Part of the USA Today Sports Media Group</b><br>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</P>
<P  style="width:400px;float:right; text-align:right;">
All contents (unless otherwise specified) copyright &copy;  1995 - 2016<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br>Site Managed by <a href="http://www.arribus.com/" target="new">Arribus Web Development</a>
</P>
<br clear="all">
<div style="float:right;">
<script
    src="https://sucuri.net/monitoring/badge.js"
    data-s="19"
    id="sucuri-s"
    data-i="7b1b29ae50ae6574f2af3875935246e4fa8a805b26"
    data-p="o" - position - l(left) or r(right) or o(relative)
    data-c="l"
    data-t="t"
    ></script>
</div>

</div>


<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->

</body>
</html>
