<html>
<head>
<title>Trubisky and the 23rd pick | Big Blue Interactive </title>

<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">
<meta name="keywords" content="ndglbqfkxx">

<meta name="description" content="Let me start with I am an Eli Manning apologist.  The day he retires will be a sad day for all Giant fans. And I understand we are in 'win now' mode because of Eli's impending twilight years.  But if a NFL caliber QB is available at the 23rd pick like Mitch Trubisky, I would not hesitate to pull the trigger for a number of reasons.

A) Watch Trubisky in the pocket.  A shotgun QB with truly exceptional ball skills with regards to play action.  He is better now than Eli has ever been at faking play action.  Truth is, Eli is terrible at it and always has been.  Sometimes, I wonder if he is Peyton's brother, at all.  Peyton's ball fake skills were amazing.  Eli's?  Meh, not so much.  And that is a big part of freezing the opposing LBs and secondary so that the advantage goes to the WRs/TEs/RBs in pass patterns.

B) His completion percentage was 68.2% last year.  30 TDs with 6 picks.  He spreads the ball around and plays taller than his advertised 6'3" in the pocket.  Can make all the throws.  Quick throwing motion.  Little wasted time in delivering the ball.

C) Big and athletic enough to break tackle here and there and run for a first down here and there.  Has a good internal clock.  Needs to learn to slide.  He won't be trucking LBs in the NFL.

D) Cost control for the cap in upcoming years and the ability to learn from a two time Super Bowl MVP whilst on the job.  Seattle built that team because they had Wilson on a rookie contract for three years.  Cost controlling the QB position helps tremendously.

He is not 6'3" as stated and probably closer to 6'1".  But he plays tall and has good feel.  BTW, Arrogant Rodgers is about 6'0".  He is a one year starter and his throws on the move need work.  That is the one part of his game that seems erratic, at times, to me.

I really don't think he falls to 23 with so many QB needy teams, but, if he did, would you consider him at #23?  I wouldn't hesitate.
 Mitch Trubisky ||    - ( New Window )"/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="website" />
<meta property="og:description" content="Let me start with I am an Eli Manning apologist.  The day he retires will be a sad day for all Giant fans. And I understand we are in 'win now' mode because of Eli's impending twilight years.  But if a NFL caliber QB is available at the 23rd pick like Mitch Trubisky, I would not hesitate to pull the trigger for a number of reasons.

A) Watch Trubisky in the pocket.  A shotgun QB with truly exceptional ball skills with regards to play action.  He is better now than Eli has ever been at faking play action.  Truth is, Eli is terrible at it and always has been.  Sometimes, I wonder if he is Peyton's brother, at all.  Peyton's ball fake skills were amazing.  Eli's?  Meh, not so much.  And that is a big part of freezing the opposing LBs and secondary so that the advantage goes to the WRs/TEs/RBs in pass patterns.

B) His completion percentage was 68.2% last year.  30 TDs with 6 picks.  He spreads the ball around and plays taller than his advertised 6'3" in the pocket.  Can make all the throws.  Quick throwing motion.  Little wasted time in delivering the ball.

C) Big and athletic enough to break tackle here and there and run for a first down here and there.  Has a good internal clock.  Needs to learn to slide.  He won't be trucking LBs in the NFL.

D) Cost control for the cap in upcoming years and the ability to learn from a two time Super Bowl MVP whilst on the job.  Seattle built that team because they had Wilson on a rookie contract for three years.  Cost controlling the QB position helps tremendously.

He is not 6'3" as stated and probably closer to 6'1".  But he plays tall and has good feel.  BTW, Arrogant Rodgers is about 6'0".  He is a one year starter and his throws on the move need work.  That is the one part of his game that seems erratic, at times, to me.

I really don't think he falls to 23 with so many QB needy teams, but, if he did, would you consider him at #23?  I wouldn't hesitate.
 Mitch Trubisky ||    - ( New Window )" /> 
<meta property="og:title" content="Trubisky and the 23rd pick" /> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif" /> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css" />

<link rel="stylesheet" type="text/css" href="anylink.css" />


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}

html, body {
overflow-x: hidden;
}

div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" />

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type="text/javascript"><!--
//<![CDATA[
(function() {
var useSSL = 'https:' == document.location.protocol;
var src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
//]]>
//--></script>
<script type='text/javascript' src='http://img.bnqt.com/lib/js/sdpdfphelper.js'></script>
<script type="text/javascript">
googletag.pubads().enableSyncRendering();
googletag.pubads().setTargeting("title", sdpTargeting.title)
                  .setTargeting('targetPaths', sdpTargeting.targetPaths)
                  .setTargeting('fullPath', sdpTargeting.fullPath)
                  .setTargeting('queryStr', sdpTargeting.queryStr)
                  .setTargeting('domainName', sdpTargeting.domainName);       
</script>
<script type="text/javascript">
window._UrlSegment = window._UrlSegment || ''; 
window._SitePage = window._SitePage || ''; 
_UrlSegment = window.location.toString().replace(/http:\/\//, '').split('/'); 
_SitePage = _UrlSegment[1].match(/^$|^(index.php)+$/i) ? 'main' : 'general'; 
</script>
<!-- End DFP SETUP -->  

<!-- End USA Today Code -->


</head>


<body bgcolor="ffffff">



<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"></a> <img src="images/xpete.gif" alt="The Corner Forum">

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic -->&nbsp;

<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->

<div id="usmg_ad_nfl.general_football_sports_728x90_1a" style="margin:auto;">
<script type='text/javascript'>
googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_nfl.general_football_sports_728x90_1a').addService(googletag.pubads());
googletag.enableServices();
googletag.display('usmg_ad_nfl.general_football_sports_728x90_1a');
</script>
</div>

</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://astore.amazon.com/bigblueintera-20">Books/DVDs</a>
<a href="http://www.shareasale.com/r.cfm?b=277504&u=723646&m=29078&urllink=&afftrack=">Apparel</a>
<a href="http://www.amazon.com/?_encoding=UTF8&camp=1789&creative=9325&linkCode=ur2&tag=bigblueintera-20">Amazon.com</a>
<a href="http://www.ticketmonster.com/New-York-Giants-Tickets?aid=16418">Tickets</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-photo-archive/">Historical Photo Archive</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW" >Standings (NFL.com)</a>
<a href="http://www.nfl.com/teams/newyorkgiants/statistics?team=NYG" target="_NEW" >Statistics (NFL.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/" >Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'home_view_menu')">Home</a>  
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'forum_view_menu')">Corner Forum</a>
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'gameday_view_menu')">Gameday</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_view_menu')">Team</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_building_view_menu')">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info &amp; History</a> -->
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_info_view_menu')">Giants Info &amp; History</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'infolinks_view_menu')">Info/Links</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'shop_view_menu')">BBI Shop</a>
<li><a href="/index.php?mode=10" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'login_menu')">Log In</a>
</ul>

</div><div id="infoline"> </div>

<a name="END"><a href="index.php"><div style="padding-top:20px; padding-bottom:25px;"><img src="/images/back_corner.gif" width="150" height="23" alt="Back to the Corner" border="0"></a></div></a><div id="ad_pad_box"> &nbsp; </div><div class="thread_body" ><div class="thread_main" ><div class="thread_post_header" >  <h1 style="font-size:18px;">Trubisky and the 23rd pick </h1><div class="thread_info"><a href="index.php?mode=5&handle=TheGhostofBlueGuy"> TheGhostofBlueGuy </a>  :  2/18/2017  12:42 am</div></div><div class="thread_post_body" > Let me start with I am an Eli Manning apologist.  The day he retires will be a sad day for all Giant fans. And I understand we are in 'win now' mode because of Eli's impending twilight years.  But if a NFL caliber QB is available at the 23rd pick like Mitch Trubisky, I would not hesitate to pull the trigger for a number of reasons.<br />
<br />
A) Watch Trubisky in the pocket.  A shotgun QB with truly exceptional ball skills with regards to play action.  He is better now than Eli has ever been at faking play action.  Truth is, Eli is terrible at it and always has been.  Sometimes, I wonder if he is Peyton's brother, at all.  Peyton's ball fake skills were amazing.  Eli's?  Meh, not so much.  And that is a big part of freezing the opposing LBs and secondary so that the advantage goes to the WRs/TEs/RBs in pass patterns.<br />
<br />
B) His completion percentage was 68.2% last year.  30 TDs with 6 picks.  He spreads the ball around and plays taller than his advertised 6'3" in the pocket.  Can make all the throws.  Quick throwing motion.  Little wasted time in delivering the ball.<br />
<br />
C) Big and athletic enough to break tackle here and there and run for a first down here and there.  Has a good internal clock.  Needs to learn to slide.  He won't be trucking LBs in the NFL.<br />
<br />
D) Cost control for the cap in upcoming years and the ability to learn from a two time Super Bowl MVP whilst on the job.  Seattle built that team because they had Wilson on a rookie contract for three years.  Cost controlling the QB position helps tremendously.<br />
<br />
He is not 6'3" as stated and probably closer to 6'1".  But he plays tall and has good feel.  BTW, Arrogant Rodgers is about 6'0".  He is a one year starter and his throws on the move need work.  That is the one part of his game that seems erratic, at times, to me.<br />
<br />
I really don't think he falls to 23 with so many QB needy teams, but, if he did, would you consider him at #23?  I wouldn't hesitate.<br />
<br><a href="https://www.youtube.com/watch?v=F1gDmgx5O7M"> Mitch Trubisky ||  </a>  - (<a href="https://www.youtube.com/watch?v=F1gDmgx5O7M" target="_NEW"> New Window </a>) </div></div></div><div class="thread_post"><div class="thread_post_header"><b>No </b><a name="13364760">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JohnF"> JohnF </a>  :  2/18/2017  12:57 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364760">link</a>   </div></div><div class="thread_post_body"> 1) Eli just turned 36. He very well could play till 40...no major injuries.<br />
<br />
2) If you draft Trubisky, you're going to have a draft choice sit on the bench for at least 3 years and possibly 5. That would put Trubisky behind the eight ball...he'd be rusty beyond belief.<br />
<br />
3) If they did draft a QB #1, the expectation would be that the drafted QB would be starting in two years or less. That's the way the NFL works today. Trubisky would likely be out of here after his rookie contract, and the team would have gotten no production out of a #1 draft choice. That's not an option.<br />
<br />
4) You would be likely giving up the season. Even with all our draft choices, we are going to have trouble filling up all the holes. And rookie QB's don't win Super Bowls.<br />
<br />
This ONLY works if you're going to trade Eli. Not going to happen...you don't trade a franchise QB who has won two Super Bowls and is healthy unless you're 100% sure the guy replacing him can compete for a championship.<br />
<br />
If Eli was 38, I could see this happening. Not at 36. <br />
<br />
History proves this. San Diego traded Drew Brees, as they were convinced recently drafted Philip Rivers would lead them to a Championship. Remember how that ended?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: No </b><a name="13364761">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=TheGhostofBlueGuy"> TheGhostofBlueGuy </a>  :  2/18/2017  1:05 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364761">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13364760" target="_blank">13364760</a> JohnF said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> 1) Eli just turned 36. He very well could play till 40...no major injuries.<br />
<br />
2) If you draft Trubisky, you're going to have a draft choice sit on the bench for at least 3 years and possibly 5. That would put Trubisky behind the eight ball...he'd be rusty beyond belief.<br />
<br />
3) If they did draft a QB #1, the expectation would be that the drafted QB would be starting in two years or less. That's the way the NFL works today. Trubisky would likely be out of here after his rookie contract, and the team would have gotten no production out of a #1 draft choice. That's not an option.<br />
<br />
4) You would be likely giving up the season. Even with all our draft choices, we are going to have trouble filling up all the holes. And rookie QB's don't win Super Bowls.<br />
<br />
This ONLY works if you're going to trade Eli. Not going to happen...you don't trade a franchise QB who has won two Super Bowls and is healthy unless you're 100% sure the guy replacing him can compete for a championship.<br />
<br />
If Eli was 38, I could see this happening. Not at 36. <br />
<br />
History proves this. San Diego traded Drew Brees, as they were convinced recently drafted Philip Rivers would lead them to a Championship. Remember how that ended? </td>
                                </tr>
                           </table><br />
<br />
Fair points, John.  But Eli won't be getting another contract after this one.  He'll be 38 after this contract expires.  Failing to prepare is preparing to fail.  Better to address this sooner than later and not with a 5th round pick (see Rhett Bomar).<br />
<br />
Giving up the season is a bit alarmist.  Not every draft pick will start nor should they.<br />
<br />
History also proves that grooming a QB can work and often times does.  Farve/Rodgers.  Montana/Young.  And so on.<br />
<br />
No one is asking a rookie QB to win a SB.  You're missing the point.  Who said anything about trading Eli?<br />
<br />
And San Diego gave up on a HOF QB.  Not exactly an equal comparison.</div></div><div class="thread_post"><div class="thread_post_header"><b>Only if they have a firm conviction that this is going to be the guy. </b><a name="13364765">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=SB+42+and+46+and+%3F"> SB 42 and 46 and ? </a>  :  2/18/2017  1:42 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364765">link</a>   </div></div><div class="thread_post_body"> Transitioning to your next quarterback is hard and if you screw it up you could go three or four or more years with no acceptable quarterback and no chance of winning.<br />
<br />
It would be nice to get our guy next draft or the year after that, but the guy may not be available that year. Can't pass up a someone you really see as a replacement because it's a year or two early.<br />
<br />
If he develops and looks like he ready to take over in 2018 or 2019, then just show Eli the door a year or two before his contract is up. Jerry had no problem doing that to others of his key players, like Tuck.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Only if they have a firm conviction that this is going to be the guy. </b><a name="13364766">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=TheGhostofBlueGuy"> TheGhostofBlueGuy </a>  :  2/18/2017  1:52 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364766">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13364765" target="_blank">13364765</a> SB 42 and 46 and ? said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Transitioning to your next quarterback is hard and if you screw it up you could go three or four or more years with no acceptable quarterback and no chance of winning.<br />
<br />
It would be nice to get our guy next draft or the year after that, but the guy may not be available that year. Can't pass up a someone you really see as a replacement because it's a year or two early.<br />
<br />
If he develops and looks like he ready to take over in 2018 or 2019, then just show Eli the door a year or two before his contract is up. Jerry had no problem doing that to others of his key players, like Tuck. </td>
                                </tr>
                           </table><br />
<br />
This. ^</div></div><div class="thread_post"><div class="thread_post_header"><b>The whole conversation is for naught </b><a name="13364768">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=allstarjim"> allstarjim </a>  :  2/18/2017  2:00 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364768">link</a>   </div></div><div class="thread_post_body"> There is zero chance Trubisky will be available after the 12th pick of the draft, and I would say less than a 20% chance he gets out of the top 5 picks.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: The whole conversation is for naught </b><a name="13364769">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=TheGhostofBlueGuy"> TheGhostofBlueGuy </a>  :  2/18/2017  2:28 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364769">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13364768" target="_blank">13364768</a> allstarjim said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> There is zero chance Trubisky will be available after the 12th pick of the draft, and I would say less than a 20% chance he gets out of the top 5 picks. </td>
                                </tr>
                           </table><br />
<br />
That's what they said about Aaron Rodgers.</div></div><div class="thread_post"><div class="thread_post_header"><b>If you can get a franchise QB </b><a name="13364782">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Mike+from+Ohio"> Mike from Ohio </a>  :  2/18/2017  7:54 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364782">link</a>   </div></div><div class="thread_post_body"> You take him.  Full stop.  You can't look down the road and pick a year and say "We'll draft our guy in 2018" because then you are forced to take who is there.  If he sits for an extra year or two, so be it.<br />
<br />
Now I know nothing about Trubisky so I am not saying they should draft him.  But if the front office believes him - or any other QB in this draft is a franchise guy - you get him if you can and then worry about how long he sits and what you do with Eli.<br />
<br />
I love Eli and hope he plays another 5 years, but the Packers model is the right one.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: No </b><a name="13364783">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LakeGeorgeGiant"> LakeGeorgeGiant </a>  :  2/18/2017  7:57 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364783">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13364760" target="_blank">13364760</a> JohnF said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> 1) Eli just turned 36. He very well could play till 40...no major injuries.<br />
<br />
2) If you draft Trubisky, you're going to have a draft choice sit on the bench for at least 3 years and possibly 5. That would put Trubisky behind the eight ball...he'd be rusty beyond belief.<br />
<br />
3) If they did draft a QB #1, the expectation would be that the drafted QB would be starting in two years or less. That's the way the NFL works today. Trubisky would likely be out of here after his rookie contract, and the team would have gotten no production out of a #1 draft choice. That's not an option.<br />
<br />
4) You would be likely giving up the season. Even with all our draft choices, we are going to have trouble filling up all the holes. And rookie QB's don't win Super Bowls.<br />
<br />
This ONLY works if you're going to trade Eli. Not going to happen...you don't trade a franchise QB who has won two Super Bowls and is healthy unless you're 100% sure the guy replacing him can compete for a championship.<br />
<br />
If Eli was 38, I could see this happening. Not at 36. <br />
<br />
History proves this. San Diego traded Drew Brees, as they were convinced recently drafted Philip Rivers would lead them to a Championship. Remember how that ended? </td>
                                </tr>
                           </table><br />
<br />
Two points: <br />
<br />
First, the draft is for the future. FA is for filling needs. If you need your draft picks to emerge as immediate, quality starters you aren't a Superbowl team anyhow.<br />
<br />
Second, they can't assume that Eli is going to play until he is 40. Father time catches us all. Eli might play until he is 40, or he might get an injury next year that he never fully rebounds from.<br />
<br />
If they see their QB they will take him. IF.</div></div><div class="thread_post"><div class="thread_post_header"><b>I prefer Kizer,  </b><a name="13364789">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=SFGFNCGiantsFan"> SFGFNCGiantsFan </a>  :  2/18/2017  8:30 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364789">link</a>   </div></div><div class="thread_post_body"> though Trubisky is more accurate of the two.</div></div><div class="thread_post"><div class="thread_post_header"><b>I tend to agree that Kizer has more franchise QB traits </b><a name="13364790">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bigblue12"> bigblue12 </a>  :  2/18/2017  8:34 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364790">link</a>   </div></div><div class="thread_post_body"> But if they have a conviction that they found the QB of the future, take him<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: No </b><a name="13364794">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=USAF+NYG+Fan"> USAF NYG Fan </a>  :  2/18/2017  8:44 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364794">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13364761" target="_blank">13364761</a> TheGhostofBlueGuy said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br />
History also proves that grooming a QB can work and often times does.  Farve/Rodgers.  Montana/Young.  And so on.<br />
</td>
                                </tr>
                           </table><br />
Here's my problem with this statement.  You can't name the 2 rare occasions that prove your argument correct and ignore the far greater amount of times that it failed.  History does not in fact prove that grooming a QB can work and "OFTEN" times does.  It's very much the opposite.  You mentioned the two times it worked in 50 years (SB era).  There's a far greater number of times that an heir apparent QB was "groomed" behind a great QB and failed.  The reason nobody thinks about them is because they weren't worth remembering.  Also, I don't see the "And so on" either.  What other great QBs were 'groomed' behind other great veteran QBs besides the two mentioned?  Might come up with 1 or 2 debatable ones but the level of failures still greatly outweighs the successes.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: No </b><a name="13364798">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Carson53"> Carson53 </a>  :  2/18/2017  9:00 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364798">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13364761" target="_blank">13364761</a> TheGhostofBlueGuy said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13364760 JohnF said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     1) Eli just turned 36. He very well could play till 40...no major injuries.<br />
<br />
2) If you draft Trubisky, you're going to have a draft choice sit on the bench for at least 3 years and possibly 5. That would put Trubisky behind the eight ball...he'd be rusty beyond belief.<br />
<br />
3) If they did draft a QB #1, the expectation would be that the drafted QB would be starting in two years or less. That's the way the NFL works today. Trubisky would likely be out of here after his rookie contract, and the team would have gotten no production out of a #1 draft choice. That's not an option.<br />
<br />
4) You would be likely giving up the season. Even with all our draft choices, we are going to have trouble filling up all the holes. And rookie QB's don't win Super Bowls.<br />
<br />
This ONLY works if you're going to trade Eli. Not going to happen...you don't trade a franchise QB who has won two Super Bowls and is healthy unless you're 100% sure the guy replacing him can compete for a championship.<br />
<br />
If Eli was 38, I could see this happening. Not at 36. <br />
<br />
History proves this. San Diego traded Drew Brees, as they were convinced recently drafted Philip Rivers would lead them to a Championship. Remember how that ended? <br />
                                <br />
                           <br />
<br />
Fair points, John.  But Eli won't be getting another contract after this one.  He'll be 38 after this contract expires.  Failing to prepare is preparing to fail.  Better to address this sooner than later and not with a 5th round pick (see Rhett Bomar).<br />
<br />
Giving up the season is a bit alarmist.  Not every draft pick will start nor should they.<br />
<br />
History also proves that grooming a QB can work and often times does.  Farve/Rodgers.  Montana/Young.  And so on.<br />
<br />
No one is asking a rookie QB to win a SB.  You're missing the point.  Who said anything about trading Eli?<br />
<br />
And San Diego gave up on a HOF QB.  Not exactly an equal comparison. </td>
                                </tr>
                           </table><br />
<br />
Brady will still be playing when Eli retires, and he is almost 40. With that said, I would wait until next year<br />
to draft a QB. I certainly would not in the first round <br />
this year, when you need OL and DL.</div></div><div class="thread_post"><div class="thread_post_header"><b>If the team hopes to get another  </b><a name="13364799">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Beer+Man"> Beer Man </a>  :  2/18/2017  9:04 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364799">link</a>   </div></div><div class="thread_post_body"> SB with Eli, they need to use the 1st pick elsewhere. Also,  there will be a number of interesting QB prospects entering the draft in 2018.</div></div><div class="thread_post"><div class="thread_post_header"><b>IF the Giants feel Trubisky is a potential franchise QB </b><a name="13364801">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jay+on+the+Island"> Jay on the Island </a>  :  2/18/2017  9:10 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364801">link</a>   </div></div><div class="thread_post_body"> Then I would be happy with him at 23.  With that said I am not sure Trubisky has that upside.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Only if they have a firm conviction that this is going to be the guy. </b><a name="13364802">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=AcidTest"> AcidTest </a>  :  2/18/2017  9:12 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364802">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13364766" target="_blank">13364766</a> TheGhostofBlueGuy said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13364765 SB 42 and 46 and ? said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Transitioning to your next quarterback is hard and if you screw it up you could go three or four or more years with no acceptable quarterback and no chance of winning.<br />
<br />
It would be nice to get our guy next draft or the year after that, but the guy may not be available that year. Can't pass up a someone you really see as a replacement because it's a year or two early.<br />
<br />
If he develops and looks like he ready to take over in 2018 or 2019, then just show Eli the door a year or two before his contract is up. Jerry had no problem doing that to others of his key players, like Tuck. <br />
                                <br />
                           <br />
<br />
This. ^ </td>
                                </tr>
                           </table><br />
<br />
+2. But I agree that the discussion is moot, because there is zero chance Trubisky is available at #23. Zero point zero.</div></div><div class="thread_post"><div class="thread_post_header"><b>If there is someone </b><a name="13364804">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Carson53"> Carson53 </a>  :  2/18/2017  9:12 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364804">link</a>   </div></div><div class="thread_post_body"> like the kid from Cal available in the 5th, that's a bit different scenario. You don't have to rush him.<br />
I am not saying they should draft him either, just an example.</div></div><div class="thread_post"><div class="thread_post_header"><b>In regards to  </b><a name="13364812">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Beer+Man"> Beer Man </a>  :  2/18/2017  9:24 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364812">link</a>   </div></div><div class="thread_post_body"> Even if the team doesn't extend Eli, you won't see that for the next few seasons.  Eli's contract is listed as one of the worst in the league in terms of cap implications.<br />
<br />
Year____Cap Hit____Dead Money   <br />
2017---- $19.7M ---- $18.6M<br />
<br />
2018---- $22.2M ---- $12.4M<br />
<br />
2019---- $23.2M ---- $6.2M</div></div><div class="thread_post"><div class="thread_post_header"><b>Remember the Alamo? </b><a name="13364814">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Doomster"> Doomster </a>  :  2/18/2017  9:26 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364814">link</a>   </div></div><div class="thread_post_body"> Remember Marino...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: If you can get a franchise QB </b><a name="13364816">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=mrvax"> mrvax </a>  :  2/18/2017  9:28 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364816">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13364782" target="_blank">13364782</a> Mike from Ohio said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> You take him.  Full stop.  You can't look down the road and pick a year and say "We'll draft our guy in 2018" because then you are forced to take who is there.  If he sits for an extra year or two, so be it.<br />
<br />
Now I know nothing about Trubisky so I am not saying they should draft him.  But if the front office believes him - or any other QB in this draft is a franchise guy - you get him if you can and then worry about how long he sits and what you do with Eli.<br />
<br />
I love Eli and hope he plays another 5 years, but the Packers model is the right one. </td>
                                </tr>
                           </table><br />
<br />
Thanks, Mike. You are spot on here.</div></div><div class="thread_post"><div class="thread_post_header"><b>I'm fundamentally against using any premium draft picks on a QB </b><a name="13364817">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Torrag"> Torrag </a>  :  2/18/2017  9:29 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364817">link</a>   </div></div><div class="thread_post_body"> Any and all team resources should be focused on a single goal. Putting another Lombardi Trophy in that case at the stadium.<br />
<br />
If we use a pick on a developmental type in the 4th or 5th round looking to strike gold I get it. That's as far as I would go.</div></div><div class="thread_post"><div class="thread_post_header"><b>^^ 'I'm fundamentally against using any premium draft picks on a QB'   </b><a name="13364825">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Torrag"> Torrag </a>  :  2/18/2017  9:41 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364825">link</a>   </div></div><div class="thread_post_body"> ...this applies to while we have Eli and a team capable of winning a title(which I believe we have right now)...of course.</div></div><div class="thread_post"><div class="thread_post_header"><b>Trubisky </b><a name="13364832">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=AcidTest"> AcidTest </a>  :  2/18/2017  9:47 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364832">link</a>   </div></div><div class="thread_post_body"> is barely 6'2". I'm not sure that's disqualifying, but it is a consideration. Along with the fact that he only has 13 starts.</div></div><div class="thread_post"><div class="thread_post_header"><b>These straw man hypotheticals are silly </b><a name="13364834">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Milton"> Milton </a>  :  2/18/2017  9:48 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364834">link</a>   </div></div><div class="thread_post_body"> If a great player last until a pick that great players normally don't last to, would you select him?<br />
<br />
If all the QB-needy teams don't think he is so great, what makes you think the Giants scouts will see it differently? Are the Giants scouts that much smarter than the scouts for the QB-needy teams? Are you that much smarter than them?<br />
<br />
Unless the Giants have a crystal ball that we don't know about, they won't be taking a QB with the 23rd pick because there won't be a QB prospect worth the 23rd pick when the Giants are on the clock. Period. If there are QB prospects worthy of the 23rd pick, they will be gone by the time the 23rd pick rolls around.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Aaron Rodgers is listed at 6' 2". If Trubisky is 6' 1", he better be </b><a name="13364843">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Ivan15"> Ivan15 </a>  :  2/18/2017  10:00 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364843">link</a>   </div></div><div class="thread_post_body"> very mobile because Rodgers would be a failure as a pocket QB.<br />
<br />
If not for the absence of JPP and the injury to DRC, the Giants would have buried the Packers in the playoffs. The game was already headed in that direction when DRC went out.</div></div><div class="thread_post"><div class="thread_post_header"><b>You lost me here... </b><a name="13364844">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JCin332"> JCin332 </a>  :  2/18/2017  10:02 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364844">link</a>   </div></div><div class="thread_post_body"> <table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">He is better now than Eli has ever been at faking play action. Truth is, Eli is terrible at it and always has been. Sometimes, I wonder if he is Peyton's brother, at all. Peyton's ball fake skills were amazing. Eli's? Meh, not so much. And that is a big part of freezing the opposing LBs and secondary so that the advantage goes to the WRs/TEs/RBs in pass patterns.</td>
                                </tr>
                           </table><br />
<br />
You do realize you need a threat of a running game to make play action effective...if you have been as bad rushing the ball as the Giants have been the last 4 years it wouldn't matter if you had Harry Houdini back there...<br />
<br />
His play action fakes were dynamite when he had an OL and Tiki, Jacobs, Bradshaw and Ware...</div></div><div class="thread_post"><div class="thread_post_header"><b>Aaron Rodgers is listed at 6' 2". If Trubisky is 6' 1", he better be </b><a name="13364845">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Ivan15"> Ivan15 </a>  :  2/18/2017  10:02 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364845">link</a>   </div></div><div class="thread_post_body"> very mobile because Rodgers would be a failure as a pocket QB.<br />
<br />
If not for the absence of JPP and the injury to DRC, the Giants would have buried the Packers in the playoffs. The game was already headed in that direction when DRC went out.</div></div><div class="thread_post"><div class="thread_post_header"><b>Milton, that's a reasonable point. </b><a name="13364850">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=yatqb"> yatqb </a>  :  2/18/2017  10:14 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364850">link</a>   </div></div><div class="thread_post_body"> It's a rare case when you are able to land a prospective franchise QB at #23.  But if the opportunity is there and you have a conviction about a QB at #23 you've got to take him.  It's the single most important position in sports, and if you have a chance to firm that up for a decade or more you do it, and hope you've accomplished some of your biggest goals in FA.  <br />
<br />
I may be overly optimistic, but if we were to re-sign our defensive players and pick up Whitworth, the draft could still add a lot to the team, and taking a QB wouldn't exclude our ability to compete for a SB.  <br />
<br />
Why can't we get a TE, RB, slot CB, and depth WR in this draft even without a #1?  For example: Zay Jones, Leggett, Kareem Hunt and any of the dozens of CBs in this draft (Kazee, Stribling, Elder for example).<br />
<br />
And it's not like our #1 is necessarily going to make a huge impact in year one.  Often those guys take a while to contribute themselves.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: These straw man hypotheticals are silly </b><a name="13364853">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jay+on+the+Island"> Jay on the Island </a>  :  2/18/2017  10:26 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364853">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13364834" target="_blank">13364834</a> Milton said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> If a great player last until a pick that great players normally don't last to, would you select him?<br />
<br />
If all the QB-needy teams don't think he is so great, what makes you think the Giants scouts will see it differently? Are the Giants scouts that much smarter than the scouts for the QB-needy teams? Are you that much smarter than them?<br />
<br />
Unless the Giants have a crystal ball that we don't know about, they won't be taking a QB with the 23rd pick because there won't be a QB prospect worth the 23rd pick when the Giants are on the clock. Period. If there are QB prospects worthy of the 23rd pick, they will be gone by the time the 23rd pick rolls around.<br />
 </td>
                                </tr>
                           </table><br />
To counter your argument why did Aaron Rodgers fall to the 25th pick?  Why did every team pass on Derek Carr allowing the Raiders to get him in the 2nd round?  I agree with anyone who feels that the Giants should wait to draft Eli's replacement for at least another year unless of course they feel any of these QB's have franchise potential.  Personally I would draft a developmental QB in the mid to late rounds and just solidify the rest of the roster.</div></div><div class="thread_post"><div class="thread_post_header"><b>I don't think it's a bad idea </b><a name="13364854">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=pjcas18"> pjcas18 </a>  :  2/18/2017  10:29 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364854">link</a>   </div></div><div class="thread_post_body"> in this draft to try for a "Tom Brady Miracle" or even make a Nassib-like play, but you simply can't use pick 23 on a QB in this draft.<br />
<br />
Roster building in the NFL pretty much dictates you cannot allocate that many premium resources (Cap $$ and 1st round picks) to that one position and not get production from that position (a 1st round pick QB sitting on the bench for at least a year or two).  The new CBA is different.<br />
<br />
you need production from your premium picks or you have to get production elsewhere and the Giants just have not gotten production elsewhere.<br />
<br />
The only way you do this is if you don't plan to contend this year.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Trubisky </b><a name="13364855">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BigBlueDownTheShore"> BigBlueDownTheShore </a>  :  2/18/2017  10:31 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364855">link</a>   </div></div><div class="thread_post_body"> Should be the first QB off the board l, so it doubtful he lasts that long.  If he did last to 23 you should take him, since most QBs in college are playing the spread and need development to run a pro style.</div></div><div class="thread_post"><div class="thread_post_header"><b>yatqb... </b><a name="13364874">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Milton"> Milton </a>  :  2/18/2017  10:57 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364874">link</a>   </div></div><div class="thread_post_body"> <table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">It's a rare case when you are able to land a prospective franchise QB at #23. But if the opportunity is there and you have a conviction about a QB at #23 you've got to take him.</td>
                                </tr>
                           </table>It depends on what you mean by a conviction. My point is that if the Giants--with a franchise QB already in place and under contract for three more years--have a conviction on the guy, chances are the QB-needy teams are going to have a conviction as well. And you can bet they will pounce on the franchise quality prospect long before he reaches the 23rd pick.<br />
<br />
<span class="bold">Jay...</span><table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">To counter your argument why did Aaron Rodgers fall to the 25th pick?</td>
                                </tr>
                           </table>Rodgers was a unique situation. He was the second QB chosen in the draft that year but lasted all the way to the 25th pick after the first overall pick was Alex Smith. The year before that four QB's had gone in the first round and Matt Schaub (who the Giants had a first round grade on) went in the 3rd round. The stars were aligned in such a way that a QB with a first round grade would last until the 25th pick. And when I say a first round grade, I separate that from a franchise QB grade. At the time the word on the street was that neither Smith nor Rodgers compared to Eli, Rivers, and Roethlisberg of the year before.<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">Why did every team pass on Derek Carr allowing the Raiders to get him in the 2nd round?</td>
                                </tr>
                           </table>Because Derek Carr was not viewed as a franchise QB and the jury is still out on him. Derek Carr is no Eli Manning. The Raiders were a QB-needy team that passed on Carr with their first pick because Mack was the clearly better prospect. Which says a lot right there. A QB-needy team would not pass on a QB with a franchise QB grade no matter how highly regarded the pass-rusher was. Which is a similar dilemma to what Cleveland faces this year with the first pick. You can bet they wouldn't be taking Garrett over Trubitsky if they had a franchise QB grade on him.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>p.s. </b><a name="13364877">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Milton"> Milton </a>  :  2/18/2017  11:06 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364877">link</a>   </div></div><div class="thread_post_body"> It's not like Belichick knew Brady was going to be a franchise QB but waited until the 6th round to select him because he was that much smarter than everyone else. Belichick had a franchise QB already in place (Drew Bledsoe) at the time, so when the 6th round rolled around he rolled the dice on a QB he had a good grade on.<br />
<br />
It's not like Walsh knew Montana was going to be a franchise QB but waited until the 3rd round to select him because he was that much smarter than everybody else. In fact, Walsh was planning on taking Phil Simms with his first round pick. So Walsh preferred the relative unknown from Morehead State to the QB from Notre Dame who had just won a national title!<br />
<br />
Any QB can turn into a franchise QB. Look at Kurt Warner. But that doesn't mean they were a franchise QB quality prospect at the time of the draft. It just means somebody got lucky.</div></div><div class="thread_post"><div class="thread_post_header"><b>I kind of always listen to Milton when it comes to QBs </b><a name="13364880">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Reb8thVA"> Reb8thVA </a>  :  2/18/2017  11:19 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364880">link</a>   </div></div><div class="thread_post_body"> And the draft. In 2004 he was all over the need to grab a QB and the possibility of getting Eli when most of us were all arguing whether we should draft Gallery, Sean Taylor, or Kellen Winslow because we had Collins</div></div><div class="thread_post"><div class="thread_post_header"><b>you also have  </b><a name="13364881">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=area+junc"> area junc </a>  :  2/18/2017  11:21 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364881">link</a>   </div></div><div class="thread_post_body"> to wonder how Eli's current level of play factors in.</div></div><div class="thread_post"><div class="thread_post_header"><b>He will be long gone </b><a name="13364884">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=jc+in+c-ville"> jc in c-ville </a>  :  2/18/2017  11:26 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364884">link</a>   </div></div><div class="thread_post_body"> And good riddance. Let somebody reach for an inconsistent QB that started for one year.<br />
<br />
I would offer NE a #2 for Jimmy G or perhaps a #3 or #4 for AJ McCarron as at least these guys are somewhat proven.</div></div><div class="thread_post"><div class="thread_post_header"><b>Derek Carr may be no Eli Manning in your opinion </b><a name="13364886">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=pjcas18"> pjcas18 </a>  :  2/18/2017  11:27 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364886">link</a>   </div></div><div class="thread_post_body"> but I'd bet a poll of 32 GM's of who they'd want as their QB today going forward Eli or Derek Carr, nearly all, if not all, would take Carr.<br />
<br />
If people can't acknowledge Eli today is not Eli of old they have blinders on.  And that's not putting the offense's failures last year all on Eli or saying he can't be successful another couple years, it's my observation from watching games.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: These straw man hypotheticals are silly </b><a name="13364887">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=mrvax"> mrvax </a>  :  2/18/2017  11:28 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364887">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13364834" target="_blank">13364834</a> Milton said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> If a great player last until a pick that great players normally don't last to, would you select him?<br />
<br />
If all the QB-needy teams don't think he is so great, what makes you think the Giants scouts will see it differently? Are the Giants scouts that much smarter than the scouts for the QB-needy teams? Are you that much smarter than them?<br />
<br />
Unless the Giants have a crystal ball that we don't know about, they won't be taking a QB with the 23rd pick because there won't be a QB prospect worth the 23rd pick when the Giants are on the clock. Period. If there are QB prospects worthy of the 23rd pick, they will be gone by the time the 23rd pick rolls around.<br />
 </td>
                                </tr>
                           </table><br />
<br />
In that case you just pick the straw man.</div></div><div class="thread_post"><div class="thread_post_header"><b>Milton, what you say is usually true.   </b><a name="13364888">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=yatqb"> yatqb </a>  :  2/18/2017  11:29 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364888">link</a>   </div></div><div class="thread_post_body"> No argument from me on that.</div></div><div class="thread_post"><div class="thread_post_header"><b>Gil Brandt said about an hour ago that Trubisky </b><a name="13364889">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+%2756"> Big Blue '56 </a>  :  2/18/2017  11:29 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364889">link</a>   </div></div><div class="thread_post_body"> sat behind a guy for two years who wsn't even drafted by the NFL..He said Trubisky could turn out to be a great QB, you never know, but his recommendation? BUYER BEWARE..<br />
<br />
That's enough of a valuable and knowledgeable opinion to pass nog time on this guy at 23</div></div><div class="thread_post"><div class="thread_post_header"><b>IF </b><a name="13364890">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=old+man"> old man </a>  :  2/18/2017  11:30 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364890">link</a>   </div></div><div class="thread_post_body"> They are convinced MT is the best QB in this or, of the current college QBs will be, in upcoming drafts short term, particularly for Bens O, presuming Ben is their guy for at least 5 years,And they can get a released B. Albert,R. Clady,maybe K. Dunlap, Plus any 3 of Rieff,Leary,Whitworth,Warmack,Zeitler and a couple of other FA OL very very cheaply along with EF to fight it out as starters and have good reserves, along with any FA TE and top WR also below market,As well as Resigning JPP JH KRobinson? to friendly contracts,Yet finally, MT being willing to sit for a at least 2 and up to 4 years a la Rodgers before Possibly being the starter, then OK.<br />
I'm leaning towards NO ;-).</div></div><div class="thread_post"><div class="thread_post_header"><b>Myles Garrett and the 23rd pick </b><a name="13364891">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=est1986"> est1986 </a>  :  2/18/2017  11:31 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364891">link</a>   </div></div><div class="thread_post_body"> .</div></div><div class="thread_post"><div class="thread_post_header"><b>Is rather use a 3rd rounder on Webb or Mahomes if one slips. </b><a name="13364894">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=est1986"> est1986 </a>  :  2/18/2017  11:34 am   : <a href="index.php?mode=2&thread=549402&show_all=1#13364894">link</a>   </div></div><div class="thread_post_body"> Or an even later round  pick on Chad Kelly.</div></div><div class="thread_post"><div class="thread_post_header"><b>I would say the only way the Giants pick Trubisky </b><a name="13364912">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Simms11"> Simms11 </a>  :  2/18/2017  12:10 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13364912">link</a>   </div></div><div class="thread_post_body"> at 23 would be if he was the Best Available Player at that time. Giants are not forcing a pick in the first round. There's no need to force a pick for a QB this year. Supposedly next year will be a much better year to draft a QB anyway. If the GIants are looking to get back to a Super Bowl in Eli's last few years, then this pick is very critical to our near-term success too. I think the GIants will go BPA and if JPP leaves, look no farther then drafting a DE or Edge Rusher there.</div></div><div class="thread_post"><div class="thread_post_header"><b>I'm  </b><a name="13364913">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=King+Quis"> King Quis </a>  :  2/18/2017  12:19 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13364913">link</a>   </div></div><div class="thread_post_body"> &#128175; with drafting Trubisky at 23. That gives us a 5th Year option on him and a great insurance policy going forward. I am an Eli supporter but wouldn't want to squander that opportunity for the franchise if it fell in our lap.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Gil Brandt said about an hour ago that Trubisky </b><a name="13364920">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=AcidTest"> AcidTest </a>  :  2/18/2017  12:23 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13364920">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13364889" target="_blank">13364889</a> Big Blue '56 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> sat behind a guy for two years who wsn't even drafted by the NFL..He said Trubisky could turn out to be a great QB, you never know, but his recommendation? BUYER BEWARE..<br />
<br />
That's enough of a valuable and knowledgeable opinion to pass nog time on this guy at 23 </td>
                                </tr>
                           </table><br />
<br />
That is a problem to be sure, and one that few are talking about. I'd like to know more about why that happened.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Gil Brandt said about an hour ago that Trubisky </b><a name="13364923">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+%2756"> Big Blue '56 </a>  :  2/18/2017  12:24 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13364923">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13364920" target="_blank">13364920</a> AcidTest said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13364889 Big Blue '56 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     sat behind a guy for two years who wsn't even drafted by the NFL..He said Trubisky could turn out to be a great QB, you never know, but his recommendation? BUYER BEWARE..<br />
<br />
That's enough of a valuable and knowledgeable opinion to pass nog time on this guy at 23 <br />
                                <br />
                           <br />
<br />
That is a problem to be sure, and one that few are talking about. I'd like to know more about why that happened. </td>
                                </tr>
                           </table><br />
<br />
That's what Gil said</div></div><div class="thread_post"><div class="thread_post_header"><b>No. Just no. </b><a name="13364926">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Red+Dog"> Red Dog </a>  :  2/18/2017  12:27 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13364926">link</a>   </div></div><div class="thread_post_body"> For way too many reasons to list here. <br />
<br />
Remember what happened with Dave Brown over Phil Simms? <br />
<br />
I'll go with Eli to the bitter end and deal with it then.</div></div><div class="thread_post"><div class="thread_post_header"><b>I'm not a Trubisky fan at all. </b><a name="13364930">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Section331"> Section331 </a>  :  2/18/2017  12:32 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13364930">link</a>   </div></div><div class="thread_post_body"> He certainly has potential - very good athlete with an exceptional arm - but he locks on to receivers and has poor pocket awareness.  First of all, I doubt he even makes it to 23, but I still wouldn't use a 1st rounder on him.  Draft a QB in the middle rounds and see if he can be coached up.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: The whole conversation is for naught </b><a name="13364949">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=allstarjim"> allstarjim </a>  :  2/18/2017  2:07 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13364949">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13364769" target="_blank">13364769</a> TheGhostofBlueGuy said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13364768 allstarjim said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     There is zero chance Trubisky will be available after the 12th pick of the draft, and I would say less than a 20% chance he gets out of the top 5 picks. <br />
                                <br />
                           <br />
<br />
That's what they said about Aaron Rodgers. </td>
                                </tr>
                           </table><br />
<br />
"They" are wrong all the time.  I'm not.</div></div><div class="thread_post"><div class="thread_post_header"><b>Using the cost controlled "perk" is a huge reach  </b><a name="13364968">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=djm"> djm </a>  :  2/18/2017  3:08 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13364968">link</a>   </div></div><div class="thread_post_body"> While he's cost controlled he will be on the bench doing nothing. And he will making first round pick money which isn't exactly cheap. I'm not against taking a qb high but the cost controlled thing is weak to say the least. It simply doesn't exist. By the time he's ready to play he will be due for a new and expensive contract. <br />
<br />
You also called the guy a shotgun qb with great play fake skills. kind of meaningless since the pro game typically doesn't utilize shotgun on every play. That's just splitting hairs tho.<br />
<br />
Take the qb if you love him but the cost controlled aspects don't apply. If anything it's not a cost effective move in the least. It's a pricey and costly long term investment.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: No. Just no. </b><a name="13364972">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=djm"> djm </a>  :  2/18/2017  3:14 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13364972">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13364926" target="_blank">13364926</a> Red Dog said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> For way too many reasons to list here. <br />
<br />
Remember what happened with Dave Brown over Phil Simms? <br />
<br />
I'll go with Eli to the bitter end and deal with it then. </td>
                                </tr>
                           </table><br />
<br />
Lol wut. Yes let's just ignore the 800 LB gorilla in the room even when Eli is 40 because Dave brown sat behind Simms for a year or two and inevitably sucked.<br />
<br />
No.</div></div><div class="thread_post"><div class="thread_post_header"><b>Even if Trubisky falls QB is not </b><a name="13364976">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Ryan+in+Albany"> Ryan in Albany </a>  :  2/18/2017  3:16 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13364976">link</a>   </div></div><div class="thread_post_body"> not the priority and after our 1st trip back to the playoffs, it would be a monumental failure not addressing immediate glaring needs over a pick that may play or may be the next Nassib.</div></div><div class="thread_post"><div class="thread_post_header"><b>I stoped reading at Eli isn't good at play action  </b><a name="13364981">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Tuckrule"> Tuckrule </a>  :  2/18/2017  3:30 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13364981">link</a>   </div></div><div class="thread_post_body"> Your insane if you believe that</div></div><div class="thread_post"><div class="thread_post_header"><b>Next year I could see it </b><a name="13364988">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Ron+Johnson+30"> Ron Johnson 30 </a>  :  2/18/2017  3:49 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13364988">link</a>   </div></div><div class="thread_post_body"> This year I expect they'll take a pass rusher in round 1 and a QB on day 2</div></div><div class="thread_post"><div class="thread_post_header"><b>^ </b><a name="13364989">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=SHO%27NUFF"> SHO'NUFF </a>  :  2/18/2017  3:52 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13364989">link</a>   </div></div><div class="thread_post_body"> THIS.</div></div><div class="thread_post"><div class="thread_post_header"><b>Bill Walsh </b><a name="13365009">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=jacob12"> jacob12 </a>  :  2/18/2017  5:01 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13365009">link</a>   </div></div><div class="thread_post_body"> Scouts in the 49ers draft room said that Bill Walsh did not want to draft Joe Montana.He wanted to draft Steve Dils,who played quarterback for him at Stanford.Walsh lied about this for decades.I have heard scouts say Walsh had nothing to do with drafting Montana.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Bill Walsh </b><a name="13365019">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+%2756"> Big Blue '56 </a>  :  2/18/2017  5:11 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13365019">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13365009" target="_blank">13365009</a> jacob12 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Scouts in the 49ers draft room said that Bill Walsh did not want to draft Joe Montana.He wanted to draft Steve Dils,who played quarterback for him at Stanford.Walsh lied about this for decades.I have heard scouts say Walsh had nothing to do with drafting Montana. </td>
                                </tr>
                           </table><br />
<br />
He wanted Simms over both</div></div><div class="thread_post"><div class="thread_post_header"><b>Good Lord... </b><a name="13365026">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JohnF"> JohnF </a>  :  2/18/2017  5:47 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13365026">link</a>   </div></div><div class="thread_post_body"> Uh, if I polled 32 NFL GM's, I doubt seriously they would take Carr over Eli if they wanted to win a championship in 2017 or 2018.<br />
<br />
First, Eli has done it. Twice. Carr has not. Lots of QB's have great regular seasons. Carson Palmer has been great in the regular season for most of his time with the Cardinals. Not so great in the Playoffs. Andy Dalton, is great in the regular season. Wake me up when he wins a playoff game.<br />
<br />
Everyone's HOF QB, Aaron Rodgers had a season for the ages in 2011. Who beat him? Oh, that guy in NY...<br />
<br />
The only reason GM's would pick Carr over Eli is age. And yes, Carr would the choice to QB your team the next 10 years..though we don't know what the impact of that injury will be, till he heals up. Oh, that's right, Carr was on the injured list. Unlike the guy in NY, who plays every game.<br />
<br />
As far as "tutoring" a draft choice QB, you know that's a joke, right? The backup QB gets few reps in practice, parts of a playoff game, and normally does not play in the regular season. QB's improve and learn by playing, not sitting the bench.<br />
<br />
Young and Montana didn't like each other (I'm sure Ninester has more info on that). Joe was rooting for the Chargers to win the SuperBowl in '94, which ticked his former team mates off. Young was no rookie, either...he was playing in the USFL with the Houston Gamblers, then went to the Tampa Bay Bucs before he was traded to SF. There was hardly any "understudy" going on there.<br />
<br />
The Favre/Rodgers feud makes Young/Montana look like best buddies, though...even today (check out this <a href="http://www.si.com/nfl/video/2016/10/26/feud-aaron-rodgers-brett-favre" target="_blank">SI video</a> talking about the dislike between the two.) Favre did not do anything to help Rodgers out, and I'm sure Aaron would have left the team if Lord Favre stayed, instead of going to the Jets/Vikings.<br />
<br />
Transitions normally suck hard (remember when Simms left?). I'd rather go for the Gold now, while we have a franchise guy in place, and wait until we suck to draft a replacement QB. Easier when we're drafting in the top 3-5 slots...</div></div><div class="thread_post"><div class="thread_post_header"><b>A year away from considering drafting a QB  in first or second round </b><a name="13365027">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Rick+in+Dallas"> Rick in Dallas </a>  :  2/18/2017  5:48 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13365027">link</a>   </div></div><div class="thread_post_body"> I think this is just an average year for QB prospects in the draft.  With only 2 years remaining for Eli in 2018 and 2019 next year's draft would be the year to draft our next QB high in the draft.<br />
We have way too many holes on offense this year on OL, TE, RB and WR to draft a QB.</div></div><div class="thread_post"><div class="thread_post_header"><b>I'd like to see us grab Webb from Cal in Rd 3 </b><a name="13365034">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=PatersonPlank"> PatersonPlank </a>  :  2/18/2017  6:04 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13365034">link</a>   </div></div><div class="thread_post_body"> I think he could be the real deal, and we can get him later in the draft.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Good Lord... </b><a name="13365042">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=rocco8112"> rocco8112 </a>  :  2/18/2017  6:33 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13365042">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13365026" target="_blank">13365026</a> JohnF said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Uh, if I polled 32 NFL GM's, I doubt seriously they would take Carr over Eli if they wanted to win a championship in 2017 or 2018.<br />
<br />
First, Eli has done it. Twice. Carr has not. Lots of QB's have great regular seasons. Carson Palmer has been great in the regular season for most of his time with the Cardinals. Not so great in the Playoffs. Andy Dalton, is great in the regular season. Wake me up when he wins a playoff game.<br />
<br />
Everyone's HOF QB, Aaron Rodgers had a season for the ages in 2011. Who beat him? Oh, that guy in NY...<br />
<br />
The only reason GM's would pick Carr over Eli is age. And yes, Carr would the choice to QB your team the next 10 years..though we don't know what the impact of that injury will be, till he heals up. Oh, that's right, Carr was on the injured list. Unlike the guy in NY, who plays every game.<br />
<br />
As far as "tutoring" a draft choice QB, you know that's a joke, right? The backup QB gets few reps in practice, parts of a playoff game, and normally does not play in the regular season. QB's improve and learn by playing, not sitting the bench.<br />
<br />
Young and Montana didn't like each other (I'm sure Ninester has more info on that). Joe was rooting for the Chargers to win the SuperBowl in '94, which ticked his former team mates off. Young was no rookie, either...he was playing in the USFL with the Houston Gamblers, then went to the Tampa Bay Bucs before he was traded to SF. There was hardly any "understudy" going on there.<br />
<br />
The Favre/Rodgers feud makes Young/Montana look like best buddies, though...even today (check out this SI video talking about the dislike between the two.) Favre did not do anything to help Rodgers out, and I'm sure Aaron would have left the team if Lord Favre stayed, instead of going to the Jets/Vikings.<br />
<br />
Transitions normally suck hard (remember when Simms left?). I'd rather go for the Gold now, while we have a franchise guy in place, and wait until we suck to draft a replacement QB. Easier when we're drafting in the top 3-5 slots... </td>
                                </tr>
                           </table><br />
<br />
great post<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Good lord is right, it's like some of you don't watch </b><a name="13365043">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=pjcas18"> pjcas18 </a>  :  2/18/2017  6:34 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13365043">link</a>   </div></div><div class="thread_post_body"> football other than the Giants or if you do, you struggle with blatant homerism.<br />
<br />
I'm not an Eli basher, I like him, I think he's had a good career and could wind up in the HOF.  He might even have another SB in him with the right surrounding cast.<br />
<br />
But Derek Carr is better than Eli right now.  Today.  a GM needing to field a team in 2017 will take Derek Carr over Eli probably 32 times out of 32.  Even Reese.  long term is obviously laughable since Carr is 10 years younger.<br />
<br />
the fact Eli has won 2 Super Bowls is part of what makes him great and a possible hall-of-famer, but it means literally zero when faced with that choice.<br />
<br />
Of course this us purely hypothetical and my opinion, but my opinion is likely shared by the people who get paid to make these decisions and the "good lord" response is likely shared by homeric Giants fans and only homeric Giants fans.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I'm fundamentally against using any premium draft picks on a QB </b><a name="13365128">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=TheGhostofBlueGuy"> TheGhostofBlueGuy </a>  :  2/18/2017  10:51 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13365128">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13364817" target="_blank">13364817</a> Torrag said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Any and all team resources should be focused on a single goal. Putting another Lombardi Trophy in that case at the stadium.<br />
<br />
If we use a pick on a developmental type in the 4th or 5th round looking to strike gold I get it. That's as far as I would go. </td>
                                </tr>
                           </table><br />
<br />
Torrag:  There is a reason these guys go in the 4th and 5th rounds.  They just aren't good.  The Tom Brady flukes are just that.  Perfect storms. <br />
<br />
And I want to win this year, as well.  But ignoring the future puts us where Dallas is now.  Cap hell.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Milton, that's a reasonable point. </b><a name="13365129">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=TheGhostofBlueGuy"> TheGhostofBlueGuy </a>  :  2/18/2017  10:53 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13365129">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13364850" target="_blank">13364850</a> yatqb said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> It's a rare case when you are able to land a prospective franchise QB at #23.  But if the opportunity is there and you have a conviction about a QB at #23 you've got to take him.  It's the single most important position in sports, and if you have a chance to firm that up for a decade or more you do it, and hope you've accomplished some of your biggest goals in FA.  <br />
<br />
I may be overly optimistic, but if we were to re-sign our defensive players and pick up Whitworth, the draft could still add a lot to the team, and taking a QB wouldn't exclude our ability to compete for a SB.  <br />
<br />
Why can't we get a TE, RB, slot CB, and depth WR in this draft even without a #1?  For example: Zay Jones, Leggett, Kareem Hunt and any of the dozens of CBs in this draft (Kazee, Stribling, Elder for example).<br />
<br />
And it's not like our #1 is necessarily going to make a huge impact in year one.  Often those guys take a while to contribute themselves. </td>
                                </tr>
                           </table><br />
<br />
That's exactly what I'm saying.  We've got to remember that these are still kids and that there impact, while important, will not make or break our SB run.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: These straw man hypotheticals are silly </b><a name="13365130">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=TheGhostofBlueGuy"> TheGhostofBlueGuy </a>  :  2/18/2017  10:56 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13365130">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13364853" target="_blank">13364853</a> Jay on the Island said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13364834 Milton said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     If a great player last until a pick that great players normally don't last to, would you select him?<br />
<br />
If all the QB-needy teams don't think he is so great, what makes you think the Giants scouts will see it differently? Are the Giants scouts that much smarter than the scouts for the QB-needy teams? Are you that much smarter than them?<br />
<br />
Unless the Giants have a crystal ball that we don't know about, they won't be taking a QB with the 23rd pick because there won't be a QB prospect worth the 23rd pick when the Giants are on the clock. Period. If there are QB prospects worthy of the 23rd pick, they will be gone by the time the 23rd pick rolls around.<br />
 <br />
                                <br />
                           <br />
To counter your argument why did Aaron Rodgers fall to the 25th pick?  Why did every team pass on Derek Carr allowing the Raiders to get him in the 2nd round?  I agree with anyone who feels that the Giants should wait to draft Eli's replacement for at least another year unless of course they feel any of these QB's have franchise potential.  Personally I would draft a developmental QB in the mid to late rounds and just solidify the rest of the roster. </td>
                                </tr>
                           </table><br />
<br />
Why did all these teams pass?  Well, some had their QBs.  Jimmy Haslam had a boner for Manziel which, frankly, shocked the hell out of me.  The Carr name also scared some off.  They thought he'd be David.  But they ignored the tape and the hunger in this kid.  Plus, his brother gave him a wealth of knowledge that the other QBs didn't have.  Bridgewater's injury was unfortunate, but his slight build scared me off.  He reminded me to much of RG3.  Look how that turned out.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: yatqb... </b><a name="13365131">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=TheGhostofBlueGuy"> TheGhostofBlueGuy </a>  :  2/18/2017  10:58 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13365131">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13364874" target="_blank">13364874</a> Milton said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                    It's a rare case when you are able to land a prospective franchise QB at #23. But if the opportunity is there and you have a conviction about a QB at #23 you've got to take him.<br />
                                <br />
                           It depends on what you mean by a conviction. My point is that if the Giants--with a franchise QB already in place and under contract for three more years--have a conviction on the guy, chances are the QB-needy teams are going to have a conviction as well. And you can bet they will pounce on the franchise quality prospect long before he reaches the 23rd pick.<br />
<br />
Jay...<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                    To counter your argument why did Aaron Rodgers fall to the 25th pick?<br />
                                <br />
                           Rodgers was a unique situation. He was the second QB chosen in the draft that year but lasted all the way to the 25th pick after the first overall pick was Alex Smith. The year before that four QB's had gone in the first round and Matt Schaub (who the Giants had a first round grade on) went in the 3rd round. The stars were aligned in such a way that a QB with a first round grade would last until the 25th pick. And when I say a first round grade, I separate that from a franchise QB grade. At the time the word on the street was that neither Smith nor Rodgers compared to Eli, Rivers, and Roethlisberg of the year before.<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                    Why did every team pass on Derek Carr allowing the Raiders to get him in the 2nd round?<br />
                                <br />
                           Because Derek Carr was not viewed as a franchise QB and the jury is still out on him. Derek Carr is no Eli Manning. The Raiders were a QB-needy team that passed on Carr with their first pick because Mack was the clearly better prospect. Which says a lot right there. A QB-needy team would not pass on a QB with a franchise QB grade no matter how highly regarded the pass-rusher was. Which is a similar dilemma to what Cleveland faces this year with the first pick. You can bet they wouldn't be taking Garrett over Trubitsky if they had a franchise QB grade on him. </td>
                                </tr>
                           </table><br />
<br />
"Because Derek Carr was not viewed as a franchise QB and the jury is still out on him."  <br />
<br />
Wut?  He was ballin' until he broke his leg.  The jury has reached it's verdict.  The kid is a star.  Not sure what games you saw.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Gil Brandt said about an hour ago that Trubisky </b><a name="13365132">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=TheGhostofBlueGuy"> TheGhostofBlueGuy </a>  :  2/18/2017  11:03 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13365132">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13364889" target="_blank">13364889</a> Big Blue '56 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> sat behind a guy for two years who wsn't even drafted by the NFL..He said Trubisky could turn out to be a great QB, you never know, but his recommendation? BUYER BEWARE..<br />
<br />
That's enough of a valuable and knowledgeable opinion to pass nog time on this guy at 23 </td>
                                </tr>
                           </table><br />
<br />
Brandt is a Cowboy shill.  Careful with his prognostications.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I stoped reading at Eli isn't good at play action  </b><a name="13365133">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=TheGhostofBlueGuy"> TheGhostofBlueGuy </a>  :  2/18/2017  11:04 pm   : <a href="index.php?mode=2&thread=549402&show_all=1#13365133">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=549402&show_all=1#13364981" target="_blank">13364981</a> Tuckrule said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Your insane if you believe that </td>
                                </tr>
                           </table><br />
<br />
Watch the tape, bub.</div></div><a name="END"><a href="index.php"><div style="padding-top:25px; padding-bottom:20px;"><img src="/images/back_corner.gif" width="150" height="23" alt="Back to the Corner" border="0"></a></div></a><div id="ad_side_box">
<div style="height:260px;width:300px;margin:auto;">

<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id="usmg_ad_nfl.general_football_sports_300x250_1a">
<script type='text/javascript'>
googletag.defineSlot('/7103/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250]], 'usmg_ad_nfl.general_football_sports_300x250_1a').addService(googletag.pubads());
googletag.enableServices();
googletag.display('usmg_ad_nfl.general_football_sports_300x250_1a');
</script>
</div>

</div>
<div style="height:260px;width:300px;margin-auto;">

<!-- BEGIN Google Adsense CODE -->

<script type="text/javascript"><!--
google_ad_client = "ca-pub-1566320450447229";
/* Corner Forum - Lower 300x250 Box */
google_ad_slot = "3213469993";
google_ad_width = 300;
google_ad_height = 250;
//-->
</script>
<script type="text/javascript"
src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>

<!-- END Google Adsense CODE -->


</div>
</div>




<div class="footer">


<p style="width:400px;float:left;"><b>Part of the USA Today Sports Media Group</b><br>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</P>
<P  style="width:400px;float:right; text-align:right;">
All contents (unless otherwise specified) copyright &copy;  1995 - 2017<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Support</a>
</P>
<br clear="all">
<div style="float:right;">
<script
    src="https://sucuri.net/monitoring/badge.js"
    data-s="19"
    id="sucuri-s"
    data-i="7b1b29ae50ae6574f2af3875935246e4fa8a805b26"
    data-p="o" - position - l(left) or r(right) or o(relative)
    data-c="l"
    data-t="t"
    ></script>
</div>

</div>


<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->

</body>
</html>
