<html>
<head>
<title>PfT: Giants have some interest in Nick Mangold | Big Blue Interactive </title>

<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">
<meta name="keywords" content="ndglbqfkxx">

<meta name="description" content="
                                
                                     Quote:
                                
                                
                                    According to Pat Leonard of the New York Daily News, the Giants have expressed interest in bringing former Jets center Nick Mangold to the blue side of the stadium.
                                
                            Link   - ( New Window )"/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="website" />
<meta property="og:description" content="
                                
                                     Quote:
                                
                                
                                    According to Pat Leonard of the New York Daily News, the Giants have expressed interest in bringing former Jets center Nick Mangold to the blue side of the stadium.
                                
                            Link   - ( New Window )" /> 
<meta property="og:title" content="PfT: Giants have some interest in Nick Mangold" /> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif" /> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css" />

<link rel="stylesheet" type="text/css" href="anylink.css" />


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}

html, body {
overflow-x: hidden;
}

div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" />

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type="text/javascript"><!--
//<![CDATA[
(function() {
var useSSL = 'https:' == document.location.protocol;
var src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
//]]>
//--></script>
<script type='text/javascript' src='http://img.bnqt.com/lib/js/sdpdfphelper.js'></script>
<script type="text/javascript">
googletag.pubads().enableSyncRendering();
googletag.pubads().setTargeting("title", sdpTargeting.title)
                  .setTargeting('targetPaths', sdpTargeting.targetPaths)
                  .setTargeting('fullPath', sdpTargeting.fullPath)
                  .setTargeting('queryStr', sdpTargeting.queryStr)
                  .setTargeting('domainName', sdpTargeting.domainName);       
</script>
<script type="text/javascript">
window._UrlSegment = window._UrlSegment || ''; 
window._SitePage = window._SitePage || ''; 
_UrlSegment = window.location.toString().replace(/http:\/\//, '').split('/'); 
_SitePage = _UrlSegment[1].match(/^$|^(index.php)+$/i) ? 'main' : 'general'; 
</script>
<!-- End DFP SETUP -->  

<!-- End USA Today Code -->


</head>


<body bgcolor="ffffff">



<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"></a> <img src="images/xpete.gif" alt="The Corner Forum">

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic -->&nbsp;

<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->

<div id="usmg_ad_nfl.general_football_sports_728x90_1a" style="margin:auto;">
<script type='text/javascript'>
googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_nfl.general_football_sports_728x90_1a').addService(googletag.pubads());
googletag.enableServices();
googletag.display('usmg_ad_nfl.general_football_sports_728x90_1a');
</script>
</div>

</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://astore.amazon.com/bigblueintera-20">Books/DVDs</a>
<a href="http://www.shareasale.com/r.cfm?b=277504&u=723646&m=29078&urllink=&afftrack=">Apparel</a>
<a href="http://www.amazon.com/?_encoding=UTF8&camp=1789&creative=9325&linkCode=ur2&tag=bigblueintera-20">Amazon.com</a>
<a href="http://www.ticketmonster.com/New-York-Giants-Tickets?aid=16418">Tickets</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-photo-archive/">Historical Photo Archive</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW" >Standings (NFL.com)</a>
<a href="http://www.nfl.com/teams/newyorkgiants/statistics?team=NYG" target="_NEW" >Statistics (NFL.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/" >Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'home_view_menu')">Home</a>  
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'forum_view_menu')">Corner Forum</a>
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'gameday_view_menu')">Gameday</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_view_menu')">Team</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_building_view_menu')">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info &amp; History</a> -->
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_info_view_menu')">Giants Info &amp; History</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'infolinks_view_menu')">Info/Links</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'shop_view_menu')">BBI Shop</a>
<li><a href="/index.php?mode=10" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'login_menu')">Log In</a>
</ul>

</div><div id="infoline"> </div>

<a name="END"><a href="index.php"><div style="padding-top:20px; padding-bottom:25px;"><img src="/images/back_corner.gif" width="150" height="23" alt="Back to the Corner" border="0"></a></div></a><div id="ad_pad_box"> &nbsp; </div><div class="thread_body" ><div class="thread_main" ><div class="thread_post_header" >  <h1 style="font-size:18px;">PfT: Giants have some interest in Nick Mangold </h1><div class="thread_info"><a href="index.php?mode=5&handle=EddieNYG"> EddieNYG </a>  :  3/27/2017  1:59 pm</div></div><div class="thread_post_body" > <table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">According to Pat Leonard of the New York Daily News, the Giants have expressed interest in bringing former Jets center Nick Mangold to the blue side of the stadium.</td>
                                </tr>
                           </table><br><a href="http://profootballtalk.nbcsports.com/2017/03/27/report-giants-have-some-interest-in-former-jet-nick-mangold/"> Link </a>  - (<a href="http://profootballtalk.nbcsports.com/2017/03/27/report-giants-have-some-interest-in-former-jet-nick-mangold/" target="_NEW"> New Window </a>) </div></div></div><div class="thread_post"><div class="thread_post_header"><b>I wouldn't be opposed to it </b><a name="13408046">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=UConn4523"> UConn4523 </a>  :  3/27/2017  2:00 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408046">link</a>   </div></div><div class="thread_post_body"> and I can't pretend to know whether or not he can play Guard but the depth will certainly be an asset (at C or G).</div></div><div class="thread_post"><div class="thread_post_header"><b>backup center </b><a name="13408047">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BigBlueDownTheShore"> BigBlueDownTheShore </a>  :  3/27/2017  2:00 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408047">link</a>   </div></div><div class="thread_post_body"> maybe a RG starter of LG backup.  Bring him in for the right price.</div></div><div class="thread_post"><div class="thread_post_header"><b>Is This Steagles 2.0? </b><a name="13408048">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Trainmaster"> Trainmaster </a>  :  3/27/2017  2:01 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408048">link</a>   </div></div><div class="thread_post_body"> NY Jiants?<br />
<br />
NY Gets?<br />
<br />
<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">The Steagles were the team created by the temporary merger of two National Football League (NFL) teams, the Pittsburgh Steelers and the Philadelphia Eagles, during the 1943 season.</td>
                                </tr>
                           </table><br><a href="https://en.wikipedia.org/wiki/Steagles"> Steagles </a> - (<a href="https://en.wikipedia.org/wiki/Steagles" target="_NEW"> New Window </a>)</div></div><div class="thread_post"><div class="thread_post_header"><b>could not hurt </b><a name="13408065">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=TommyWiseau"> TommyWiseau </a>  :  3/27/2017  2:11 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408065">link</a>   </div></div><div class="thread_post_body"> to bring him in to camp as backup C/Guard</div></div><div class="thread_post"><div class="thread_post_header"><b>You </b><a name="13408076">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=TyreeHelmet"> TyreeHelmet </a>  :  3/27/2017  2:16 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408076">link</a>   </div></div><div class="thread_post_body"> have to think Mangold would want this too. Not having to move or uproot his family is a big perk...</div></div><div class="thread_post"><div class="thread_post_header"><b>Prove it deal </b><a name="13408079">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JonC"> JonC </a>  :  3/27/2017  2:19 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408079">link</a>   </div></div><div class="thread_post_body"> see if his body has anything left, has been a warrior for a long time, could use the interior depth.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Isn't this old news </b><a name="13408082">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=jeff57"> jeff57 </a>  :  3/27/2017  2:20 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408082">link</a>   </div></div><div class="thread_post_body"> Wasn't there a similar story last week?</div></div><div class="thread_post"><div class="thread_post_header"><b>As they... </b><a name="13408083">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Johnny5"> Johnny5 </a>  :  3/27/2017  2:20 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408083">link</a>   </div></div><div class="thread_post_body"> ... should.</div></div><div class="thread_post"><div class="thread_post_header"><b>Interior depth? </b><a name="13408084">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Emlen%27sGremlins"> Emlen'sGremlins </a>  :  3/27/2017  2:21 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408084">link</a>   </div></div><div class="thread_post_body"> If he's healthy Richburg can't carry his jock.</div></div><div class="thread_post"><div class="thread_post_header"><b>Dont hate this at all </b><a name="13408089">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=gmen9892"> gmen9892 </a>  :  3/27/2017  2:24 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408089">link</a>   </div></div><div class="thread_post_body"> Especially if its at a low salary, which I assume it is since hes really gotten no interest anywhere else.<br />
<br />
Good leader that has a mean streak.  Can't be worse than Brett Jones (and I dont think he is that bad).</div></div><div class="thread_post"><div class="thread_post_header"><b>Unlikely an aging player, even of Mangold's past stature </b><a name="13408095">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JonC"> JonC </a>  :  3/27/2017  2:28 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408095">link</a>   </div></div><div class="thread_post_body"> wins a starting gig, given his recent leg injuries and how big the team is on OL youth and continuity.  He's being considered for depth.</div></div><div class="thread_post"><div class="thread_post_header"><b>Vetern Leadership </b><a name="13408098">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Vegas+Steve"> Vegas Steve </a>  :  3/27/2017  2:30 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408098">link</a>   </div></div><div class="thread_post_body"> is something that can't be measured.<br />
<br />
7 time pro bowler... Yes! of course, if he's got some gas left in the tank and he's affordable, no reason not to sign him. <br />
<br />
Dwight Freeney is someone also to consider.</div></div><div class="thread_post"><div class="thread_post_header"><b>Freeney's toast </b><a name="13408101">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JonC"> JonC </a>  :  3/27/2017  2:31 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408101">link</a>   </div></div><div class="thread_post_body"> and often a liability versus the run.<br />
<br />
NYG has an opening at RG, if Mangold is motivated enough to work for it.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Rather his sister </b><a name="13408104">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Renton"> Renton </a>  :  3/27/2017  2:33 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408104">link</a>   </div></div><div class="thread_post_body"> at this point.</div></div><div class="thread_post"><div class="thread_post_header"><b>Back up Center ? </b><a name="13408108">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=averagejoe"> averagejoe </a>  :  3/27/2017  2:35 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408108">link</a>   </div></div><div class="thread_post_body"> He may still be a better center than Richburg. I am OK with brining him to camp.</div></div><div class="thread_post"><div class="thread_post_header"><b>I think he's shot.  </b><a name="13408113">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=arcarsenal"> arcarsenal </a>  :  3/27/2017  2:37 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408113">link</a>   </div></div><div class="thread_post_body"> But if its cheap, why not.</div></div><div class="thread_post"><div class="thread_post_header"><b>I'd </b><a name="13408116">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=AcidTest"> AcidTest </a>  :  3/27/2017  2:38 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408116">link</a>   </div></div><div class="thread_post_body"> probably pass given his age and injury history.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Interior depth? </b><a name="13408120">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=81_Great_Dane"> 81_Great_Dane </a>  :  3/27/2017  2:40 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408120">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=550928&show_all=1#13408084" target="_blank">13408084</a> Emlen'sGremlins said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> If he's healthy Richburg can't carry his jock. </td>
                                </tr>
                           </table>Missed 8 games last year, so his health is a big question mark.</div></div><div class="thread_post"><div class="thread_post_header"><b>He had an ankle </b><a name="13408126">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=mrvax"> mrvax </a>  :  3/27/2017  2:45 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408126">link</a>   </div></div><div class="thread_post_body"> last year that he re-injured. If he's good to go, he'd likely replace the Canadian kid.<br />
<br />
Pretty sure Mangold at 33 has played only center since 2006. If he's going to start, that moves Richburg to guard. Not sure if this is a good idea.<br />
<br />
Would he sign for backup pay?<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Mangold at guard  </b><a name="13408131">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=nygnyy274"> nygnyy274 </a>  :  3/27/2017  2:48 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408131">link</a>   </div></div><div class="thread_post_body"> Mangold&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt; John Jerry.</div></div><div class="thread_post"><div class="thread_post_header"><b>Our OL could be </b><a name="13408132">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GiantsRage2007"> GiantsRage2007 </a>  :  3/27/2017  2:49 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408132">link</a>   </div></div><div class="thread_post_body"> 2 Tackles and 8 Guards. Perfect. LOL <br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Mangold at guard  </b><a name="13408133">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=mrvax"> mrvax </a>  :  3/27/2017  2:49 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408133">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=550928&show_all=1#13408131" target="_blank">13408131</a> nygnyy274 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Mangold&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt;&gt; John Jerry. </td>
                                </tr>
                           </table><br />
<br />
<br />
Have no idea if Mangold would be able to pass pro from guard.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Rather his sister </b><a name="13408134">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Diver_Down"> Diver_Down </a>  :  3/27/2017  2:49 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408134">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=550928&show_all=1#13408104" target="_blank">13408104</a> Renton said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> at this point. </td>
                                </tr>
                           </table><br />
<br />
She actually can play and I bet SheLovesNYCSports. <br />
 <img src="https://s-media-cache-ak0.pinimg.com/736x/1a/96/d3/1a96d30f58f81dfe67f2953f5268aa60.jpg"></div></div><div class="thread_post"><div class="thread_post_header"><b>Has Mangold </b><a name="13408143">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=kash94"> kash94 </a>  :  3/27/2017  2:55 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408143">link</a>   </div></div><div class="thread_post_body"> ever even played a game at guard? I'm definitely good with signing him though. Even as a backup C it can't hurt. Richburg had some injuries here and there last year.</div></div><div class="thread_post"><div class="thread_post_header"><b>Offensive Linemen </b><a name="13408146">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=mavric"> mavric </a>  :  3/27/2017  2:56 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408146">link</a>   </div></div><div class="thread_post_body"> are the only positional players outside of QB that tend to have longer NFL careers and are still solid in their early 30's. If has no injuries and he's healthy and stayed in shape during the off season, he'd be a plus to the offensive line as a mentor as well as competing for a guard position and backing up Richburg, Pugh, and whoever ends up playing RG. If he's low cost and healthy, it would be a nice windfall for the Giants in an area that welcomes a windfall. I would have more confidence in him spelling the starters than Jones, Halapio, and Gettis. And if fact, would be a good mentor to the backups so show them what they have to do to become starter material</div></div><div class="thread_post"><div class="thread_post_header"><b>I'm not a fan of this potential move </b><a name="13408167">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=The_Boss"> The_Boss </a>  :  3/27/2017  3:04 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408167">link</a>   </div></div><div class="thread_post_body"> But Francesa right now is loving the idea.</div></div><div class="thread_post"><div class="thread_post_header"><b>Are </b><a name="13408185">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Toth029"> Toth029 </a>  :  3/27/2017  3:13 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408185">link</a>   </div></div><div class="thread_post_body"> We even sure he's a NFL starter at RG at this point? They have Jerry plus Brett Jones who looked good when given an opportunity last season. I wouldn't oppose a camp battle and an incentive based deal (he starts and plays x amount of games, earn more), otherwise it's a waste of resources.</div></div><div class="thread_post"><div class="thread_post_header"><b>Perfect Vet Backup Center  </b><a name="13408187">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=shelovesnycsports"> shelovesnycsports </a>  :  3/27/2017  3:15 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408187">link</a>   </div></div><div class="thread_post_body"> And could come in on short yardage and goal line plays. <br /></div></div><div class="thread_post"><div class="thread_post_header"><b>listening to that too. I disagree with Mike and these hyper callers.  </b><a name="13408191">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Victor+in+CT"> Victor in CT </a>  :  3/27/2017  3:16 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408191">link</a>   </div></div><div class="thread_post_body"> 1) Mangold is pretty beat up. And can he even move enough to play guard.<br />
2) If Mangold IS healthy enough to play C, you would want him to play there. Richburg to me is a big ? at C, but that makes Richburg a backup, because he was a horrid guard.<br />
3) Richburg is as big a ? as Flowers. Loads of people here shit on Flowers, and he has struggled, but too many act as if Richburg is the answer at C. I don't think he is. Too weak physically</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Rather his sister </b><a name="13408192">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=shelovesnycsports"> shelovesnycsports </a>  :  3/27/2017  3:16 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408192">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=550928&show_all=1#13408134" target="_blank">13408134</a> Diver_Down said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13408104 Renton said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     at this point. <br />
                                <br />
                           <br />
<br />
She actually can play and I bet SheLovesNYCSports. <br />
  </td>
                                </tr>
                           </table><br />
God Bless her. she is living her dream and excelling at life.  unlike others.</div></div><div class="thread_post"><div class="thread_post_header"><b>I reported this last week  </b><a name="13408203">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=dk+in+TX"> dk in TX </a>  :  3/27/2017  3:19 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408203">link</a>   </div></div><div class="thread_post_body"> .<br><a href="http://corner.bigblueinteractive.com/index.php?mode=2&thread=550591"> Mangold Thread  </a> - (<a href="http://corner.bigblueinteractive.com/index.php?mode=2&thread=550591" target="_NEW"> New Window </a>)</div></div><div class="thread_post"><div class="thread_post_header"><b>If his ankle injury recovery checks out, then great depth signing </b><a name="13408208">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=NYG27"> NYG27 </a>  :  3/27/2017  3:21 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408208">link</a>   </div></div><div class="thread_post_body"> Anything else would be pure gravy at this point.  Would be nice insurance at all the interior O-Line positions.<br />
<br />
Not to mention, good backup option at LG in case we need to kick Justin Pugh over to Left Tackle.......if Ereck Flowers gets injured or doesn't improve over his play from last year.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: He had an ankle </b><a name="13408252">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=giantsfan44ab"> giantsfan44ab </a>  :  3/27/2017  3:42 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408252">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=550928&show_all=1#13408126" target="_blank">13408126</a> mrvax said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> last year that he re-injured. If he's good to go, he'd likely replace the Canadian kid.<br />
<br />
Pretty sure Mangold at 33 has played only center since 2006. If he's going to start, that moves Richburg to guard. Not sure if this is a good idea.<br />
<br />
Would he sign for backup pay?<br />
 </td>
                                </tr>
                           </table><br />
<br />
I'd hope he has an ankle this year as well.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: He had an ankle </b><a name="13408255">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=mrvax"> mrvax </a>  :  3/27/2017  3:45 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408255">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=550928&show_all=1#13408252" target="_blank">13408252</a> giantsfan44ab said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"><br />
I'd hope he has an ankle this year as well. </td>
                                </tr>
                           </table><br />
<br />
It's a Tom Coughlin expression when questioned about a player's health.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: He had an ankle </b><a name="13408263">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=giantsfan44ab"> giantsfan44ab </a>  :  3/27/2017  3:57 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408263">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=550928&show_all=1#13408255" target="_blank">13408255</a> mrvax said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13408252 giantsfan44ab said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                    <br />
I'd hope he has an ankle this year as well. <br />
                                <br />
                           <br />
<br />
It's a Tom Coughlin expression when questioned about a player's health. </td>
                                </tr>
                           </table><br />
<br />
Haha I know. It's spread everywhere now, it seems, with more leniency taken on how it's used. Sportscenter would say something like "he had an ankle last year" and leave it at that.</div></div><div class="thread_post"><div class="thread_post_header"><b>Really </b><a name="13408266">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=mrvax"> mrvax </a>  :  3/27/2017  3:59 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408266">link</a>   </div></div><div class="thread_post_body"> Sportscenter? Now that's funny.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Freeney's toast </b><a name="13408267">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GreenKey111"> GreenKey111 </a>  :  3/27/2017  3:59 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408267">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=550928&show_all=1#13408101" target="_blank">13408101</a> JonC said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> and often a liability versus the run.<br />
<br />
NYG has an opening at RG, if Mangold is motivated enough to work for it. </td>
                                </tr>
                           </table><br />
<br />
Since when do NYG have an opening at RG?<br />
<br />
They already have a guy there who's started 86 games in his career, was resigned after starting all 17 in 2016, and had his salary doubled (literally)</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Freeney's toast </b><a name="13408270">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Klaatu"> Klaatu </a>  :  3/27/2017  4:03 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408270">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=550928&show_all=1#13408267" target="_blank">13408267</a> GreenKey111 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13408101 JonC said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     and often a liability versus the run.<br />
<br />
NYG has an opening at RG, if Mangold is motivated enough to work for it. <br />
                                <br />
                           <br />
<br />
Since when do NYG have an opening at RG?<br />
<br />
They already have a guy there who's started 86 games in his career, was resigned after starting all 17 in 2016, and had his salary doubled (literally) </td>
                                </tr>
                           </table><br />
<br />
<img src="http://www.snopes.com/movies/graphics/orourke.jpg"><br />
<br />
<span class="italics"><span class="bold"><span style="font-size: 20px">He's baaack!</span></span></span></div></div><div class="thread_post"><div class="thread_post_header"><b>At what cost??? </b><a name="13408274">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=rasbutant"> rasbutant </a>  :  3/27/2017  4:04 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408274">link</a>   </div></div><div class="thread_post_body"> Hard to have an opinion without knowing the cost.  Would love to have him though if his mind is in the right place.  Willing to come in and be a back up and battle for a starting job.  Teach Richburg, would be great for his development.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Freeney's toast </b><a name="13408295">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=larryflower37"> larryflower37 </a>  :  3/27/2017  4:13 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408295">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=550928&show_all=1#13408267" target="_blank">13408267</a> GreenKey111 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13408101 JonC said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     and often a liability versus the run.<br />
<br />
NYG has an opening at RG, if Mangold is motivated enough to work for it. <br />
                                <br />
                           <br />
<br />
Since when do NYG have an opening at RG?<br />
<br />
They already have a guy there who's started 86 games in his career, was resigned after starting all 17 in 2016, and had his salary doubled (literally) </td>
                                </tr>
                           </table><br />
<br />
<br />
You must say he is resilient. <br />
Jerry should sign him as a PR director. <br />
How long before he is kicked again?<br />
<br />
<br />
<img src="http://www3.pictures.zimbio.com/gi/John+Jerry+New+York+Giants+v+Tennessee+Titans+10LrPsrk9oll.jpg"></div></div><div class="thread_post"><div class="thread_post_header"><b>i'm not convinced Mangold has anything left </b><a name="13408302">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=djm"> djm </a>  :  3/27/2017  4:18 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408302">link</a>   </div></div><div class="thread_post_body"> but on the cheap? And I have to choose between air or Mangold? I'd take a shot. But I still think he will be on the shelf by December. IF we signed him here I just hope he doesn't come in and kick ass at guard for a few weeks only to go down and sort of ruin the cohesion. But why not take a shot...<br />
<br />
He will come cheap or not at all.</div></div><div class="thread_post"><div class="thread_post_header"><b>Jerry is upgradeable and replaceable </b><a name="13408306">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JonC"> JonC </a>  :  3/27/2017  4:20 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408306">link</a>   </div></div><div class="thread_post_body"> of that there is virtually no doubt.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Mangold </b><a name="13408311">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JerseyCityJoe"> JerseyCityJoe </a>  :  3/27/2017  4:21 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408311">link</a>   </div></div><div class="thread_post_body"> Always loved his play. You line up next to him your going to have your hands full. Tough as they come.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I'm not a fan of this potential move </b><a name="13408313">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=djm"> djm </a>  :  3/27/2017  4:22 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408313">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=550928&show_all=1#13408167" target="_blank">13408167</a> The_Boss said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> But Francesa right now is loving the idea. </td>
                                </tr>
                           </table><br />
<br />
God he's so superficial now with NY sports, especially the Giants. He likes this move because it would allow the Giants to move Fluker to LT? WTF is he talking about. Fluker won't sniff LT. He also suggested Mangold replace Richburg, who would move to guard. No Mike.<br />
<br />
Francesa is a good listen but he definitely doesn't know the players.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: i'm not convinced Mangold has anything left </b><a name="13408341">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Johnny5"> Johnny5 </a>  :  3/27/2017  4:49 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408341">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=550928&show_all=1#13408302" target="_blank">13408302</a> djm said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> but on the cheap? And I have to choose between air or Mangold? I'd take a shot. But I still think he will be on the shelf by December. IF we signed him here I just hope he doesn't come in and kick ass at guard for a few weeks only to go down and sort of ruin the cohesion. But why not take a shot...<br />
<br />
He will come cheap or not at all. </td>
                                </tr>
                           </table><br />
I think he still has some gas left.  He was indestructible and playing well until he hurt that ankle last year.  I really think this was a cap move for the Jets.  The question is, how is that ankle?</div></div><div class="thread_post"><div class="thread_post_header"><b>The question is </b><a name="13408344">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=area+junc"> area junc </a>  :  3/27/2017  4:51 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408344">link</a>   </div></div><div class="thread_post_body"> Is he done? Or was he just hurt last year and has reasonably recovered? <br />
<br />
If it's the latter, maybe it's Flowers - Mangold - Richburg - Jerry - Pugh <br />
<br />
I don't think they're afraid to utilize Pugh's versatility. Like Diehl - he plays where the team needs him to play. I don't see a player of Mangold's character signing to be a backup. He can either play, or he retires.</div></div><div class="thread_post"><div class="thread_post_header"><b>Maybe as 3rd or 4th string depth </b><a name="13408353">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=micky"> micky </a>  :  3/27/2017  4:58 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408353">link</a>   </div></div><div class="thread_post_body"> At Vet minimum..otherwise..find one in draft</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Jerry is upgradeable and replaceable </b><a name="13408361">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GreenKey111"> GreenKey111 </a>  :  3/27/2017  5:02 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408361">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=550928&show_all=1#13408306" target="_blank">13408306</a> JonC said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> of that there is virtually no doubt. </td>
                                </tr>
                           </table><br />
<br />
Yet, the Giants can never do so.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I'm not a fan of this potential move </b><a name="13408364">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=drkenneth"> drkenneth </a>  :  3/27/2017  5:03 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408364">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=550928&show_all=1#13408313" target="_blank">13408313</a> djm said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13408167 The_Boss said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     But Francesa right now is loving the idea. <br />
                                <br />
                           <br />
<br />
God he's so superficial now with NY sports, especially the Giants. He likes this move because it would allow the Giants to move Fluker to LT? WTF is he talking about. Fluker won't sniff LT. He also suggested Mangold replace Richburg, who would move to guard. No Mike.<br />
<br />
Francesa is a good listen but he definitely doesn't know the players. </td>
                                </tr>
                           </table><br />
<br />
Yup. Mike hasn't tried in years. Rex gave him plenty to talk about, so it didn't matter he didn't know the team.<br />
<br />
He's basically "Giants good, Jets bad" not much more than that. I always say it, but the best is when called asks about the draft. He has no clue, doesn't even try.</div></div><div class="thread_post"><div class="thread_post_header"><b>Mangold  </b><a name="13408366">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Rory"> Rory </a>  :  3/27/2017  5:04 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408366">link</a>   </div></div><div class="thread_post_body"> Is not coming to NYG as a backup. Be real with yourself <br />
<br />
All those that say he's old and injured were probably the same posters who said the same about Mack last year</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: The question is </b><a name="13408371">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Klaatu"> Klaatu </a>  :  3/27/2017  5:06 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408371">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=550928&show_all=1#13408344" target="_blank">13408344</a> area junc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Is he done? Or was he just hurt last year and has reasonably recovered? <br />
<br />
If it's the latter, maybe it's Flowers - Mangold - Richburg - Jerry - Pugh <br />
<br />
I don't think they're afraid to utilize Pugh's versatility. Like Diehl - he plays where the team needs him to play. I don't see a player of Mangold's character signing to be a backup. He can either play, or he retires. </td>
                                </tr>
                           </table><br />
<br />
So, you're going to have a guy who's never played any other position than Center in either college or the pros  step in at Left Guard at 33 years-old.<br />
<br />
Got it.</div></div><div class="thread_post"><div class="thread_post_header"><b>Makes no sense for an 11-5 team </b><a name="13408418">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Bob+in+Newburgh"> Bob in Newburgh </a>  :  3/27/2017  5:40 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408418">link</a>   </div></div><div class="thread_post_body"> and a guy who has made 5+ million each year for a number of years now.<br />
<br />
Also, considering his experience at the position, he might make Jerry look like the greatest RG the world has ever seen in comparison.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: The question is </b><a name="13408426">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=mrvax"> mrvax </a>  :  3/27/2017  5:48 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408426">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=550928&show_all=1#13408344" target="_blank">13408344</a> area junc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Is he done? Or was he just hurt last year and has reasonably recovered? <br />
<br />
If it's the latter, maybe it's Flowers - Mangold - Richburg - Jerry - Pugh <br />
<br />
I don't think they're afraid to utilize Pugh's versatility. Like Diehl - he plays where the team needs him to play. I don't see a player of Mangold's character signing to be a backup. He can either play, or he retires. </td>
                                </tr>
                           </table><br />
<br />
I would imagine that the Giants would be best suited to have Fluker play RT if he can do it.<br />
<br />
I doubt Mangold suddenly plays guard. I could see Richburg at guard but he didn't do well there his rookie year, Camp will sort it out.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Makes no sense for an 11-5 team </b><a name="13408431">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=mrvax"> mrvax </a>  :  3/27/2017  5:51 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408431">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=550928&show_all=1#13408418" target="_blank">13408418</a> Bob in Newburgh said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> and a guy who has made 5+ million each year for a number of years now.<br />
<br />
Also, considering his experience at the position, he might make Jerry look like the greatest RG the world has ever seen in comparison. </td>
                                </tr>
                           </table><br />
<br />
Mangold made $8.6M last year and was due a total of $9M in 2017. He's going to cost a lot to sign, methinks.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>I'm always </b><a name="13408453">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=joeinpa"> joeinpa </a>  :  3/27/2017  6:15 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408453">link</a>   </div></div><div class="thread_post_body"> a sucker for these kind of moves.</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="13408491">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=gidiefor"> gidiefor </a> : <b style="background:darkred;color:white;">Mod</b> :  3/27/2017  7:05 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408491">link</a>   </div></div><div class="thread_post_body"> <table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">Geoff Schwartz&#8207; @geoffschwartz<br />
<br />
This is just an agent trying to stir up some interest. Mangold isn't going to the Giants to start at C.</td>
                                </tr>
                           </table></div></div><div class="thread_post"><div class="thread_post_header"><b>Sorta has the same vibe as when The Giants signed Schwartz </b><a name="13408494">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=lono801"> lono801 </a>  :  3/27/2017  7:06 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408494">link</a>   </div></div><div class="thread_post_body"> Looked good on paper...<br />
<br />
I'm all for bringing in ' The Best Player Available' via F.A.<br />
<br />
You never know....Right?</div></div><div class="thread_post"><div class="thread_post_header"><b>It makes less sense for Mangold than it does for the Giants tbh. </b><a name="13408496">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Ten+Ton+Hammer"> Ten Ton Hammer </a>  :  3/27/2017  7:08 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408496">link</a>   </div></div><div class="thread_post_body"> .</div></div><div class="thread_post"><div class="thread_post_header"><b>Mangold is probably a better center than Richburg </b><a name="13408504">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Vanzetti"> Vanzetti </a>  :  3/27/2017  7:19 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408504">link</a>   </div></div><div class="thread_post_body"> Even though he has some age, one of the best to play the position<br />
<br />
Richburg show d signs his second year but took a big step back last year. Probably not the Solution longterm <br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>If they sign him </b><a name="13408526">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=RetroJint"> RetroJint </a>  :  3/27/2017  7:43 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408526">link</a>   </div></div><div class="thread_post_body"> & I doubt they will, they would do it with the  intention of having him start. At Center.  I doubt Mangold wants to be a utility man.   His entire football life, when his offense has taken  the field, he gas been  the pivot , when he's been healthy . <br />
<br />
This whole line is basically a rental. Jerry's deal is really one-year disguised as a multi-year contract.  What's adding another with Nick?  Richburg got pushed around a little. It might serve him to watch a real talent play the position. But I don't think so.</div></div><div class="thread_post"><div class="thread_post_header"><b>Mangold on his worst day is better </b><a name="13408528">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Stan+in+LA"> Stan in LA </a>  :  3/27/2017  7:44 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408528">link</a>   </div></div><div class="thread_post_body"> Than Richburg on his best day.  If he signs and is healthy he's the starter.</div></div><div class="thread_post"><div class="thread_post_header"><b>It really just doesn't make a whole lot of sense.  </b><a name="13408530">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=arcarsenal"> arcarsenal </a>  :  3/27/2017  7:47 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408530">link</a>   </div></div><div class="thread_post_body"> .</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: It really just doesn't make a whole lot of sense.  </b><a name="13408579">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=mrvax"> mrvax </a>  :  3/27/2017  8:29 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408579">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=550928&show_all=1#13408530" target="_blank">13408530</a> arcarsenal said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> . </td>
                                </tr>
                           </table><br />
<br />
Arc, I agree. Doesn't make sense as Schwartz tweeted. And... we do have a backup center who did OK when Richburg got kicked out of a game (dumbass).<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Mangold on his worst day is better </b><a name="13408697">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=djm"> djm </a>  :  3/27/2017  11:54 pm   : <a href="index.php?mode=2&thread=550928&show_all=1#13408697">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=550928&show_all=1#13408528" target="_blank">13408528</a> Stan in LA said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Than Richburg on his best day.  If he signs and is healthy he's the starter. </td>
                                </tr>
                           </table><br />
<br />
This is nonsense.<br />
<br />
The latest crap here is richburg took a huge step back last year. One or two posters say it and now nearly everyone is saying it. Huge step backwards? Try again. Richburg was fine last year even if he wasn't great and he got better as the season progressed.<br />
<br />
The Giants arent bringing mangold in to start over richburg get a fricking grip.<br />
<br />
Oh and the guy who took a huge step backward last year was mangold. That's why he's still on the street looking for a job. He wasn't only hurt he wasn't as good as year's past. Watch the games.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Rather his sister </b><a name="13408723">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=David+in+LA"> David in LA </a>  : 2:48 am   : <a href="index.php?mode=2&thread=550928&show_all=1#13408723">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=550928&show_all=1#13408134" target="_blank">13408134</a> Diver_Down said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13408104 Renton said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     at this point. <br />
                                <br />
                           <br />
<br />
She actually can play and I bet SheLovesNYCSports. <br />
  </td>
                                </tr>
                           </table><br />
<br />
LMFAO!</div></div><div class="thread_post"><div class="thread_post_header"><b>Eli Manning has a finite window. </b><a name="13408788">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Beezer"> Beezer </a>  : 8:17 am   : <a href="index.php?mode=2&thread=550928&show_all=1#13408788">link</a>   </div></div><div class="thread_post_body"> If Mangold would sign for a reasonable salary, I see absolutely no downside. It's a veteran, he may still have something to offer (those saying they KNOW he does or doesn't ... humorous).<br />
<br />
3rd or 4th string? lol Comparing Mangold, even on one leg, to a mid-round draft pick right now, is seriously braindead.</div></div><div class="thread_post"><div class="thread_post_header"><b>Whaaaaaaaaat??? </b><a name="13408791">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Beezer"> Beezer </a>  : 8:21 am   : <a href="index.php?mode=2&thread=550928&show_all=1#13408791">link</a>   </div></div><div class="thread_post_body"> <br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">This whole line is basically a rental.</td>
                                </tr>
                           </table></div></div><div class="thread_post"><div class="thread_post_header"><b>if Reese really meant it when he said </b><a name="13409001">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jersey55"> Jersey55 </a>  : 10:54 am   : <a href="index.php?mode=2&thread=550928&show_all=1#13409001">link</a>   </div></div><div class="thread_post_body"> "anytime you have a chance to improve your team you do it"  then he hast find a way to sign Mangold...</div></div><a name="END"><a href="index.php"><div style="padding-top:25px; padding-bottom:20px;"><img src="/images/back_corner.gif" width="150" height="23" alt="Back to the Corner" border="0"></a></div></a><div id="ad_side_box">
<div style="height:260px;width:300px;margin:auto;">

<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id="usmg_ad_nfl.general_football_sports_300x250_1a">
<script type='text/javascript'>
googletag.defineSlot('/7103/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250]], 'usmg_ad_nfl.general_football_sports_300x250_1a').addService(googletag.pubads());
googletag.enableServices();
googletag.display('usmg_ad_nfl.general_football_sports_300x250_1a');
</script>
</div>

</div>
<div style="height:260px;width:300px;margin-auto;">

<!-- BEGIN Google Adsense CODE -->

<script type="text/javascript"><!--
google_ad_client = "ca-pub-1566320450447229";
/* Corner Forum - Lower 300x250 Box */
google_ad_slot = "3213469993";
google_ad_width = 300;
google_ad_height = 250;
//-->
</script>
<script type="text/javascript"
src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>

<!-- END Google Adsense CODE -->


</div>
</div>




<div class="footer">


<p style="width:400px;float:left;"><b>Part of the USA Today Sports Media Group</b><br>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</P>
<P  style="width:400px;float:right; text-align:right;">
All contents (unless otherwise specified) copyright &copy;  1995 - 2017<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Support</a>
</P>
<br clear="all">
<div style="float:right;">
<script
    src="https://sucuri.net/monitoring/badge.js"
    data-s="19"
    id="sucuri-s"
    data-i="7b1b29ae50ae6574f2af3875935246e4fa8a805b26"
    data-p="o" - position - l(left) or r(right) or o(relative)
    data-c="l"
    data-t="t"
    ></script>
</div>

</div>


<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->

</body>
</html>
