<html>
<head>
<title>Roger Lewis OVI | Big Blue Interactive </title>

<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">
<meta name="keywords" content="ndglbqfkxx">

<meta name="description" content="per TMZ, odor of weed on him

http://www.tmz.com/2017/06/05/new-york-giants-roger-lewis-arrested-for-ovi/"/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="website" />
<meta property="og:description" content="per TMZ, odor of weed on him

http://www.tmz.com/2017/06/05/new-york-giants-roger-lewis-arrested-for-ovi/" /> 
<meta property="og:title" content="Roger Lewis OVI" /> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif" /> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css" />

<link rel="stylesheet" type="text/css" href="anylink.css" />


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}

html, body {
overflow-x: hidden;
}

div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" />

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type="text/javascript"><!--
//<![CDATA[
(function() {
var useSSL = 'https:' == document.location.protocol;
var src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
//]]>
//--></script>
<script type='text/javascript' src='http://img.bnqt.com/lib/js/sdpdfphelper.js'></script>
<script type="text/javascript">
googletag.pubads().enableSyncRendering();
googletag.pubads().setTargeting("title", sdpTargeting.title)
                  .setTargeting('targetPaths', sdpTargeting.targetPaths)
                  .setTargeting('fullPath', sdpTargeting.fullPath)
                  .setTargeting('queryStr', sdpTargeting.queryStr)
                  .setTargeting('domainName', sdpTargeting.domainName);       
</script>
<script type="text/javascript">
window._UrlSegment = window._UrlSegment || ''; 
window._SitePage = window._SitePage || ''; 
_UrlSegment = window.location.toString().replace(/http:\/\//, '').split('/'); 
_SitePage = _UrlSegment[1].match(/^$|^(index.php)+$/i) ? 'main' : 'general'; 
</script>
<!-- End DFP SETUP -->  

<!-- End USA Today Code -->


</head>


<body bgcolor="ffffff">



<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"></a> <img src="images/xpete.gif" alt="The Corner Forum">

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic -->&nbsp;

<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->

<div id="usmg_ad_nfl.general_football_sports_728x90_1a" style="margin:auto;">
<script type='text/javascript'>
googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_nfl.general_football_sports_728x90_1a').addService(googletag.pubads());
googletag.enableServices();
googletag.display('usmg_ad_nfl.general_football_sports_728x90_1a');
</script>
</div>

</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://astore.amazon.com/bigblueintera-20">Books/DVDs</a>
<a href="http://www.shareasale.com/r.cfm?b=277504&u=723646&m=29078&urllink=&afftrack=">Apparel</a>
<a href="http://www.amazon.com/?_encoding=UTF8&camp=1789&creative=9325&linkCode=ur2&tag=bigblueintera-20">Amazon.com</a>
<a href="http://www.ticketmonster.com/New-York-Giants-Tickets?aid=16418">Tickets</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-photo-archive/">Historical Photo Archive</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW" >Standings (NFL.com)</a>
<a href="http://www.nfl.com/teams/newyorkgiants/statistics?team=NYG" target="_NEW" >Statistics (NFL.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/" >Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'home_view_menu')">Home</a>  
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'forum_view_menu')">Corner Forum</a>
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'gameday_view_menu')">Gameday</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_view_menu')">Team</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_building_view_menu')">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info &amp; History</a> -->
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_info_view_menu')">Giants Info &amp; History</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'infolinks_view_menu')">Info/Links</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'shop_view_menu')">BBI Shop</a>
<li><a href="/index.php?mode=10" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'login_menu')">Log In</a>
</ul>

</div><div id="infoline"> </div>

<a name="END"><a href="index.php"><div style="padding-top:20px; padding-bottom:25px;"><img src="/images/back_corner.gif" width="150" height="23" alt="Back to the Corner" border="0"></a></div></a><div id="ad_pad_box"> &nbsp; </div><div class="thread_body" ><div class="thread_main" ><div class="thread_post_header" >  <h1 style="font-size:18px;">Roger Lewis OVI </h1><div class="thread_info"><a href="index.php?mode=5&handle=moaltch"> moaltch </a>  :  6/5/2017  11:03 am</div></div><div class="thread_post_body" > per TMZ, odor of weed on him<br />
<br />
http://www.tmz.com/2017/06/05/new-york-giants-roger-lewis-arrested-for-ovi/ </div></div></div><div class="thread_post"><div class="thread_post_header"><b>Ugh </b><a name="13490562">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Saos1n"> Saos1n </a>  :  6/5/2017  11:06 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490562">link</a>   </div></div><div class="thread_post_body"> Strike 1</div></div><div class="thread_post"><div class="thread_post_header"><b>dumb ass </b><a name="13490564">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=AnnapolisMike"> AnnapolisMike </a>  :  6/5/2017  11:09 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490564">link</a>   </div></div><div class="thread_post_body"> that will knock his ass right off the bubble.</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="13490573">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  6/5/2017  11:15 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490573">link</a>   </div></div><div class="thread_post_body"> Dumb ass.</div></div><div class="thread_post"><div class="thread_post_header"><b>Here </b><a name="13490575">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  6/5/2017  11:16 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490575">link</a>   </div></div><div class="thread_post_body"> is link...<br><a href="http://www.tmz.com/2017/06/05/new-york-giants-roger-lewis-arrested-for-ovi/">  NY Giants' Roger Lewis Arrested For OVI ... Cops Smell Weed </a> - (<a href="http://www.tmz.com/2017/06/05/new-york-giants-roger-lewis-arrested-for-ovi/" target="_NEW"> New Window </a>)</div></div><div class="thread_post"><div class="thread_post_header"><b>I  Had To Look Up OVI </b><a name="13490576">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Trainmaster"> Trainmaster </a>  :  6/5/2017  11:18 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490576">link</a>   </div></div><div class="thread_post_body"> any different than DUI?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Ugh </b><a name="13490578">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+Blogger"> Big Blue Blogger </a>  :  6/5/2017  11:18 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490578">link</a>   </div></div><div class="thread_post_body"> Saos1n said:<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Strike 1 </td>
                                </tr>
                           </table>One strike and he's out, considering his past issues.<br />
<br />
Of all the vets on the roster, Lewis might be the one who could least afford a false step.  Carrying him was a risk all along, and only worth it if he kept completely clean.</div></div><div class="thread_post"><div class="thread_post_header"><b>One of the boat party guys... </b><a name="13490579">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Chris684"> Chris684 </a>  :  6/5/2017  11:20 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490579">link</a>   </div></div><div class="thread_post_body"> This comes as a big shock!<br />
<br />
Have fun trying to resurrect your career elsewhere Roger.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Ugh </b><a name="13490586">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Saos1n"> Saos1n </a>  :  6/5/2017  11:23 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490586">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490578" target="_blank">13490578</a> Big Blue Blogger said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Saos1n said:<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Strike 1 <br />
                                <br />
                           One strike and he's out, considering his past issues.<br />
<br />
Of all the vets on the roster, Lewis might be the one who could least afford a false step.  Carrying him was a risk all along, and only worth it if he kept completely clean. </td>
                                </tr>
                           </table><br />
<br />
Trye, but this staff has shown a history of giving extra chances if the talent is there...<br />
And they obviously see a lot of promise considering the signing bonus they gave him last year... he also flashed quite a bit last year...</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="13490587">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  6/5/2017  11:23 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490587">link</a>   </div></div><div class="thread_post_body"> I know a lot of people on BBI don't like Lewis as a receiver, but I felt he had a real shot to surprise. <br />
<br />
How stupid do you have to be when you know you are on the bubble?</div></div><div class="thread_post"><div class="thread_post_header"><b>Nothing good happens when an athlete is out and about </b><a name="13490588">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=est1986"> est1986 </a>  :  6/5/2017  11:23 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490588">link</a>   </div></div><div class="thread_post_body"> At 4am.. Unless they are waking up to work out. This is dumb, very dumb.</div></div><div class="thread_post"><div class="thread_post_header"><b>Operating Vehicle Impaired </b><a name="13490591">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BigBlueDownTheShore"> BigBlueDownTheShore </a>  :  6/5/2017  11:25 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490591">link</a>   </div></div><div class="thread_post_body"> is what it stands for.  Means for Alcohol or Drug Abuse.</div></div><div class="thread_post"><div class="thread_post_header"><b>I really  </b><a name="13490593">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jon+in+NYC"> Jon in NYC </a>  :  6/5/2017  11:25 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490593">link</a>   </div></div><div class="thread_post_body"> don't think he was all that good.</div></div><div class="thread_post"><div class="thread_post_header"><b>The obvious beneficiaries are Darius Powe and Tavarres King. </b><a name="13490594">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+Blogger"> Big Blue Blogger </a>  :  6/5/2017  11:26 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490594">link</a>   </div></div><div class="thread_post_body"> Don't overlook Travis Rudolph, one of only two Giant UDFAs to receive any guaranteed cash.  Or, assuming Lewis is eventually dropped, the Giants could use that roster spot on the oft-discussed fourth TE.</div></div><div class="thread_post"><div class="thread_post_header"><b>Eric: You're not alone on Lewis's potential. </b><a name="13490599">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+Blogger"> Big Blue Blogger </a>  :  6/5/2017  11:27 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490599">link</a>   </div></div><div class="thread_post_body"> Eric from BBI said:<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I know a lot of people on BBI don't like Lewis as a receiver, but I felt he had a real shot to surprise. </td>
                                </tr>
                           </table>He seemed to get open, and if he had held onto a couple of drops, he probably would have seen a lot of targets.</div></div><div class="thread_post"><div class="thread_post_header"><b>Eric... </b><a name="13490603">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Chris684"> Chris684 </a>  :  6/5/2017  11:30 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490603">link</a>   </div></div><div class="thread_post_body"> Lewis has talent but the Giants have enough to worry about in the WR room trying to keep Beckham sane. Hopefully Marshall will help.<br />
<br />
Anyway, this is great news for King who know has a clear advantage in hanging on to his roster spot.<br />
<br />
Beckham, Marshall, Shep, Harris, King..<br />
<br />
And I'm now officially rooting for the kid Rudolph from FSU to take the last spot. Easy guy to root for.</div></div><div class="thread_post"><div class="thread_post_header"><b>Rudolph  </b><a name="13490605">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=River"> River </a>  :  6/5/2017  11:31 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490605">link</a>   </div></div><div class="thread_post_body"> Has a real shot now</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: One of the boat party guys... </b><a name="13490613">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Devon"> Devon </a>  :  6/5/2017  11:38 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490613">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490579" target="_blank">13490579</a> Chris684 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> This comes as a big shock!<br />
<br />
Have fun trying to resurrect your career elsewhere Roger. </td>
                                </tr>
                           </table><br />
<br />
The constant bringing up the boat is so damn tired. Was David Diehl on a boat before he drunkenly plowed through other cars?<br />
<br />
The only thing the "boat party guys" did differently than players have been doing for a very long time was be dumb enough to involve social media. Let it go.</div></div><div class="thread_post"><div class="thread_post_header"><b>Never liked this guy... </b><a name="13490614">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BC+Eagles94"> BC Eagles94 </a>  :  6/5/2017  11:40 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490614">link</a>   </div></div><div class="thread_post_body"> He was accused of two separate rapes in high school. He didn't make the grades out of HS for Ohio State and ended up at Bowling Green.  He was on the boat trip, even though he had accomplished nothing in NFL yet.  And he appears close with OBJ, and not the type of guy I want around OBJ. <br />
 Good riddance.  King has always looked better than him IMO anyway.</div></div><div class="thread_post"><div class="thread_post_header"><b>Let it go? Why? </b><a name="13490619">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Chris684"> Chris684 </a>  :  6/5/2017  11:44 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490619">link</a>   </div></div><div class="thread_post_body"> Because you don't like it?<br />
<br />
One of the guys who was partying on a boat with celebrities while pretty much everyone else was doing drugs is now...in trouble for drugs and people can't make a connection?<br />
<br />
This is a team issue, as in it now weakens camp competition at the WR spot. <br />
<br />
But let's not bring up the boat stuff...has nothing to do with any of this.</div></div><div class="thread_post"><div class="thread_post_header"><b>Another </b><a name="13490622">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=River"> River </a>  :  6/5/2017  11:45 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490622">link</a>   </div></div><div class="thread_post_body"> Will Hill type. The saddest thing is wasted talent.</div></div><div class="thread_post"><div class="thread_post_header"><b>I thought there was a good chance they kept only five WRs... </b><a name="13490623">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Milton"> Milton </a>  :  6/5/2017  11:46 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490623">link</a>   </div></div><div class="thread_post_body"> ...before this happened. Now it is even more likely.</div></div><div class="thread_post"><div class="thread_post_header"><b>It has nothing to do with this. I'm glad we agree. </b><a name="13490624">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Devon"> Devon </a>  :  6/5/2017  11:46 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490624">link</a>   </div></div><div class="thread_post_body"> .</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Let it go? Why? </b><a name="13490639">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=arcarsenal"> arcarsenal </a>  :  6/5/2017  11:57 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13490639">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490619" target="_blank">13490619</a> Chris684 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Because you don't like it?<br />
<br />
One of the guys who was partying on a boat with celebrities while pretty much everyone else was doing drugs is now...in trouble for drugs and people can't make a connection?<br />
<br />
This is a team issue, as in it now weakens camp competition at the WR spot. <br />
<br />
But let's not bring up the boat stuff...has nothing to do with any of this. </td>
                                </tr>
                           </table><br />
<br />
It doesn't. <br />
<br />
Feel free to continue bringing it up, though. Let's see if we can keep beating this dead horse all the way into the 2017 season!</div></div><div class="thread_post"><div class="thread_post_header"><b>Some of you are either dumb </b><a name="13490649">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Chris684"> Chris684 </a>  :  6/5/2017  12:05 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490649">link</a>   </div></div><div class="thread_post_body"> or just so hyper-sensitive to all things regarding Beckham that you can't even see straight. I'm guessing in this case it's the latter.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>another genius </b><a name="13490650">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Victor+in+CT"> Victor in CT </a>  :  6/5/2017  12:06 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490650">link</a>   </div></div><div class="thread_post_body"> sadly he was more impactful than Cruz was last year</div></div><div class="thread_post"><div class="thread_post_header"><b>According to the article </b><a name="13490651">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Beer+Man"> Beer Man </a>  :  6/5/2017  12:07 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490651">link</a>   </div></div><div class="thread_post_body"> the cops smelled weed in the car.  What are the going odds that his days as a Giant are numbered?</div></div><div class="thread_post"><div class="thread_post_header"><b>. </b><a name="13490652">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=arcarsenal"> arcarsenal </a>  :  6/5/2017  12:07 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490652">link</a>   </div></div><div class="thread_post_body"> How does this have anything to do with Beckham?</div></div><div class="thread_post"><div class="thread_post_header"><b>More snaps  </b><a name="13490656">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ChicagoMarty"> ChicagoMarty </a>  :  6/5/2017  12:10 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490656">link</a>   </div></div><div class="thread_post_body"> for my favorite long shot Snead<br />
<br />
You can't teach speed!!!!!!!<br />
<br />
Snead needs lots and lots of work but his speed would serve as a terrific complement to the rest of the receiving corps</div></div><div class="thread_post"><div class="thread_post_header"><b>Thats why </b><a name="13490658">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=larryinnewhaven"> larryinnewhaven </a>  :  6/5/2017  12:11 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490658">link</a>   </div></div><div class="thread_post_body"> I keep my mouth shut when people on here mock the Cowboys when they get a player pinched.  We are blind if we think our players are not out there doing the same thing.   Its just a matter if you get caught. What a dumb dumb.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Bye, Rog. </b><a name="13490659">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Ryan+in+Albany"> Ryan in Albany </a>  :  6/5/2017  12:12 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490659">link</a>   </div></div><div class="thread_post_body"> .</div></div><div class="thread_post"><div class="thread_post_header"><b>According to this SB Nation ... </b><a name="13490663">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Beer+Man"> Beer Man </a>  :  6/5/2017  12:15 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490663">link</a>   </div></div><div class="thread_post_body"> He could receive a 2-game suspension for a DUI, it says nothing about an OVI (i'm guessing the same).  But is also says the NFL has relaxed its Marijuana discipline for a first time offense, which now lands a player in the substance abuse program without a suspension.<br><a href="http://www.sbnation.com/nfl/2014/9/19/6559533/nfl-new-drug-policy-details-nflpa"> SB Nation </a> - (<a href="http://www.sbnation.com/nfl/2014/9/19/6559533/nfl-new-drug-policy-details-nflpa" target="_NEW"> New Window </a>)</div></div><div class="thread_post"><div class="thread_post_header"><b>Most of the Beckham can do no wrong crowd </b><a name="13490664">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Chris684"> Chris684 </a>  :  6/5/2017  12:15 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490664">link</a>   </div></div><div class="thread_post_body"> refuses to acknowledge that the boat trip was a big deal or even a mistake.<br />
<br />
I simply implied that given Lewis's presence on that trip and on that boat, it's hardly a shock that the guy basically threw his Giants career away due to drugs.<br />
<br />
Now what I'm also saying is that if you are denying that simple connection, you are either dumb or an over-sensitive blind Beckham fanboy (there are a lot of them here) once again downplaying the decision that he and the other WRs made in going there.</div></div><div class="thread_post"><div class="thread_post_header"><b>. </b><a name="13490669">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=arcarsenal"> arcarsenal </a>  :  6/5/2017  12:18 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490669">link</a>   </div></div><div class="thread_post_body"> Because it wasn't a big deal. <br />
<br />
The only mistake they made was putting it out there on social media and letting the vultures pick it apart. <br />
<br />
If you think NFL players spend all of their free time watching tape or studying plays, you probably shouldn't be calling other people dumb.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: According to the article </b><a name="13490679">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=mac+attack"> mac attack </a>  :  6/5/2017  12:23 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490679">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490651" target="_blank">13490651</a> Beer Man said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> the cops smelled weed in the car.  What are the going odds that his days as a Giant are numbered? </td>
                                </tr>
                           </table><br />
<br />
Did they find any weed tho?</div></div><div class="thread_post"><div class="thread_post_header"><b>Well, there is a whole world  </b><a name="13490680">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Chris684"> Chris684 </a>  :  6/5/2017  12:24 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490680">link</a>   </div></div><div class="thread_post_body"> in between "watching tape and studying plays" as you put it (even though that's probably what the majority of successful veteran players would be doing the Monday before a playoff game)<br />
<br />
AND<br />
<br />
Creating a mess of a PR situation by posting "look at me" videos to your social media on a boat full of drugs with other celebrity deadbeats.<br />
<br />
Defend the boat all you want. Doesn't change at all the fact that I originally said this comes as no surprise.<br />
<br />
There is nothing to debate.</div></div><div class="thread_post"><div class="thread_post_header"><b>That's why a lot of  guys with red flags  </b><a name="13490681">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ZogZerg"> ZogZerg </a>  :  6/5/2017  12:24 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490681">link</a>   </div></div><div class="thread_post_body"> Don't get drafted. <br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Let him catch on elsewhere now </b><a name="13490683">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Carson53"> Carson53 </a>  :  6/5/2017  12:27 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490683">link</a>   </div></div><div class="thread_post_body"> he had red flags coming into the league, bye Roger.</div></div><div class="thread_post"><div class="thread_post_header"><b>odor of weed on him doesn't make him guilty </b><a name="13490688">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=gtt350"> gtt350 </a>  :  6/5/2017  12:30 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490688">link</a>   </div></div><div class="thread_post_body"> I remember as a non smoker coming home from clubs back in the day and reeking of cigarette smoke</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Thats why </b><a name="13490691">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Ten+Ton+Hammer"> Ten Ton Hammer </a>  :  6/5/2017  12:31 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490691">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490658" target="_blank">13490658</a> larryinnewhaven said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I keep my mouth shut when people on here mock the Cowboys when they get a player pinched.  We are blind if we think our players are not out there doing the same thing.   Its just a matter if you get caught. What a dumb dumb. </td>
                                </tr>
                           </table><br />
<br />
Getting caught is the point of distinction. You have to be really dumb to get caught. There's a very good chance many of the top players in the league partake. They're not so dumb as to get caught.</div></div><div class="thread_post"><div class="thread_post_header"><b>Lewis was in legal trouble before he even came here.  </b><a name="13490692">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=arcarsenal"> arcarsenal </a>  :  6/5/2017  12:31 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490692">link</a>   </div></div><div class="thread_post_body"> He didn't become a different guy because he went on a boat. <br />
<br />
So, again...  this is completely unrelated to the boat or Odell Beckham, but guys like you, who have trouble letting things go or moving past things, will keep clinging to it.</div></div><div class="thread_post"><div class="thread_post_header"><b>I never liked Lewis. </b><a name="13490694">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Mr.+Bungle"> Mr. Bungle </a>  :  6/5/2017  12:33 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490694">link</a>   </div></div><div class="thread_post_body"> This won't help me like him more.<br />
<br />
Tavarres King deserves to be the #4 going into camp anyway. The guy has actually made big plays in huge spots for the Giants.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: One of the boat party guys... </b><a name="13490696">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JohnB"> JohnB </a>  :  6/5/2017  12:34 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490696">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490613" target="_blank">13490613</a> Devon said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13490579 Chris684 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     This comes as a big shock!<br />
<br />
Have fun trying to resurrect your career elsewhere Roger. <br />
                                <br />
                           <br />
<br />
The constant bringing up the boat is so damn tired. Was David Diehl on a boat before he drunkenly plowed through other cars?<br />
<br />
The only thing the "boat party guys" did differently than players have been doing for a very long time was be dumb enough to involve social media. Let it go. </td>
                                </tr>
                           </table><br />
<br />
The thing that WAS different about the "boat party guys" was that they, as a group, failed to have even a decent game the upcoming playoff game. Eli played very well and the WR, as a group, let the Giants down. When you fail on a large stage, you open up yourself to second guessing. <br />
<br />
If they had preformed, no one would have said a single thing. But they FAILED!</div></div><div class="thread_post"><div class="thread_post_header"><b>It does open you up to second guessing </b><a name="13490698">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Ten+Ton+Hammer"> Ten Ton Hammer </a>  :  6/5/2017  12:37 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490698">link</a>   </div></div><div class="thread_post_body"> but it's not carte blanche for the person doing the second-guessing to not use their brain at all.</div></div><div class="thread_post"><div class="thread_post_header"><b>can we wait until the full story  </b><a name="13490699">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Rory"> Rory </a>  :  6/5/2017  12:37 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490699">link</a>   </div></div><div class="thread_post_body"> comes out before killing the kid? <br />
<br />
I hope most of you hold yourselves to the same level of accountability as you hold on to others. JFC</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Let it go? Why? </b><a name="13490703">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Ten+Ton+Hammer"> Ten Ton Hammer </a>  :  6/5/2017  12:39 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490703">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490619" target="_blank">13490619</a> Chris684 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Because you don't like it?<br />
<br />
One of the guys who was partying on a boat with celebrities while pretty much everyone else was doing drugs is now...in trouble for drugs and people can't make a connection?<br />
<br />
This is a team issue, as in it now weakens camp competition at the WR spot. <br />
<br />
But let's not bring up the boat stuff...has nothing to do with any of this. </td>
                                </tr>
                           </table><br />
<br />
Roger Lewis Jr had character red flags and sex crime allegations pre-draft.<br />
<br />
But yes, Odell Beckham going on a day trip 7 days before a game is poisoning the younger part of the roster.</div></div><div class="thread_post"><div class="thread_post_header"><b>I didnt say that... </b><a name="13490706">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Chris684"> Chris684 </a>  :  6/5/2017  12:43 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490706">link</a>   </div></div><div class="thread_post_body"> You guys are not understanding.<br />
<br />
What I said was that it's not surprising that one of the guys on the boat is now in trouble with drugs.<br />
<br />
Seems to make plenty of sense.<br />
<br />
The rah-rah Beckham crowd (presumably) told me that there is nothing to see there and move on.<br />
<br />
The over protection of Odell Beckham on BBI is very funny. I did not say anything about him as it relates to Roger Lewis.</div></div><div class="thread_post"><div class="thread_post_header"><b>. </b><a name="13490712">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=arcarsenal"> arcarsenal </a>  :  6/5/2017  12:47 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490712">link</a>   </div></div><div class="thread_post_body"> So, to be clear..   what you're saying is that the boat is to blame for Roger Lewis getting into trouble with weed? <br />
<br />
You don't think he had ever been around it before then or couldn't possibly have decided to be around it afterwards?<br />
<br />
I mean.. there's reaching, and there's... this.</div></div><div class="thread_post"><div class="thread_post_header"><b>Opens the door for Darius Powe </b><a name="13490714">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=giant24"> giant24 </a>  :  6/5/2017  12:49 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490714">link</a>   </div></div><div class="thread_post_body"> Needed some experience but at 6-3 220 another huge receiver.</div></div><div class="thread_post"><div class="thread_post_header"><b>The NYG boat party may be the single greatest cause-effect incident </b><a name="13490715">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  6/5/2017  12:50 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490715">link</a>   </div></div><div class="thread_post_body"> since the assassination of Archduke Ferdinand of Austria in 1914 resulting in outbreak of World War I...</div></div><div class="thread_post"><div class="thread_post_header"><b>Dumb Move But </b><a name="13490721">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Samiam"> Samiam </a>  :  6/5/2017  12:53 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490721">link</a>   </div></div><div class="thread_post_body"> He was on the bubble before and still is.  His big problem last year was the drops which (hopefully) presumably he worked on in the off season.  He seemed to get open regularly but dropped too many balls. That is correctable.  Also, he's a very good ST player which is a requirement for your 4, 5th WR.  And, I don't remember if Dwayne Harris took a pay cut but even if he did, I think the team would get rid of him if others would pick up the slack and Lewis could help in that role. This is a stupid move by Lewis but maybe it'll be a wake up call.  I don't think it'll affect his chances of making the team; he'll have to step up his game to do that anyway.</div></div><div class="thread_post"><div class="thread_post_header"><b>No... </b><a name="13490723">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Chris684"> Chris684 </a>  :  6/5/2017  12:53 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490723">link</a>   </div></div><div class="thread_post_body"> Why is this so difficult for you?<br />
<br />
Of all the players on the roster as of today that could have gotten pinched for drugs, I'm least surprised by the fact it's one of the few guys who decided to put themselves in that position just a few short months ago.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I didnt say that... </b><a name="13490724">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Ten+Ton+Hammer"> Ten Ton Hammer </a>  :  6/5/2017  12:54 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490724">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490706" target="_blank">13490706</a> Chris684 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> You guys are not understanding.<br />
<br />
What I said was that it's not surprising that one of the guys on the boat is now in trouble with drugs.<br />
<br />
Seems to make plenty of sense.<br />
<br />
The rah-rah Beckham crowd (presumably) told me that there is nothing to see there and move on.<br />
<br />
The over protection of Odell Beckham on BBI is very funny. I did not say anything about him as it relates to Roger Lewis. </td>
                                </tr>
                           </table><br />
The only reason for Beckham to even be mentioned here is to try to manufacture a narrative. You didn't have to say it.</div></div><div class="thread_post"><div class="thread_post_header"><b>Well, you see your honor, </b><a name="13490725">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Doomster"> Doomster </a>  :  6/5/2017  12:55 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490725">link</a>   </div></div><div class="thread_post_body"> odor of weed on him doesn't make him guilty  <br />
gtt350 : 12:30 pm : link : reply<br />
I remember as a non smoker coming home from clubs back in the day and reeking of cigarette smoke<br />
<br />
I was smoking, but I didn't inhale.....<br />
<br />
You can easily get high from secondary MJ smoking, in close quarters, without actually smoking.....everyone knows that....a player can always cop out by saying he didn't smoke, but he knows the effect of being in a place that where everyone is smoking MJ.....<br />
<br />
Many years ago, a friend of mine, who doesn't smoke at all, went to bachelor party, that was pretty wild, and he came home higher than a kite(they had to drive him home), and his wife wouldn't believe him, that he wasn't smoking MJ....especially after he raided the 'fridge.....</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: No... </b><a name="13490732">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=arcarsenal"> arcarsenal </a>  :  6/5/2017  1:01 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490732">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490723" target="_blank">13490723</a> Chris684 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Why is this so difficult for you?<br />
<br />
Of all the players on the roster as of today that could have gotten pinched for drugs, I'm least surprised by the fact it's one of the few guys who decided to put themselves in that position just a few short months ago.<br />
 </td>
                                </tr>
                           </table><br />
<br />
You could just say... "hey, it's not that surprising that a guy that had a few red flags before he got here is in hot water again"...<br />
<br />
The boat has nothing to do with this. You brought it up. <br />
<br />
Beckham, Cruz, and Shepard were all there too..  doesn't seem like any of them have had any issues with drugs since. Maybe Roger Lewis is just not the smartest dude and wasn't well before the boat trip ever happened? <br />
<br />
Crazy thought!</div></div><div class="thread_post"><div class="thread_post_header"><b>I could have  </b><a name="13490736">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Chris684"> Chris684 </a>  :  6/5/2017  1:03 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490736">link</a>   </div></div><div class="thread_post_body"> but I didnt. AND guess what? It doesnt mean that what I said is off base.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Rudolph  </b><a name="13490739">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=santacruzom"> santacruzom </a>  :  6/5/2017  1:04 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490739">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490605" target="_blank">13490605</a> River said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Has a real shot now </td>
                                </tr>
                           </table><br />
<br />
And if Rudolph were ever found on the streets at 4 am, it would probably be because he's delivering groceries to impaired old ladies.  That guy's the off-field opposite of Lewis.</div></div><div class="thread_post"><div class="thread_post_header"><b>Police Report says officer found .2 grams of marijuana </b><a name="13490749">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=gidiefor"> gidiefor </a> : <b style="background:darkred;color:white;">Mod</b> :  6/5/2017  1:11 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490749">link</a>   </div></div><div class="thread_post_body"> in Lewis' vehicle<br><a href="https://twitter.com/art_stapleton/status/871771551590469632"> Link </a> - (<a href="https://twitter.com/art_stapleton/status/871771551590469632" target="_NEW"> New Window </a>)</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I could have  </b><a name="13490755">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=David+in+LA"> David in LA </a>  :  6/5/2017  1:16 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490755">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490736" target="_blank">13490736</a> Chris684 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> but I didnt. AND guess what? It doesnt mean that what I said is off base. </td>
                                </tr>
                           </table><br />
<br />
You don't strike me as a bright guy.  If Sterling Shepard got pulled over, was it because he was in a boat too?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: another genius </b><a name="13490757">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=FJ"> FJ </a>  :  6/5/2017  1:17 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490757">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490650" target="_blank">13490650</a> Victor in CT said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> sadly he was more impactful than Cruz was last year </td>
                                </tr>
                           </table><br />
Ummm...no, he wasn't.<br />
<br />
Cruz:  72 targets, 39 receptions, 586 yards, 1 TD, 15.0 YPR, long of 48 yards, 54.2 catch%<br />
Lewis:  19 targets, 7 receptions, 97 yards, 2 TD, 13.9 YPR, long of 30 yards, 36.8 catch%</div></div><div class="thread_post"><div class="thread_post_header"><b>Get his ass out of here, </b><a name="13490762">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Marine+One"> Marine One </a>  :  6/5/2017  1:23 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490762">link</a>   </div></div><div class="thread_post_body"> he knew what he had at stake with limited reps and performance last year and pulls this amateur horseshit. Being an alum, I was pulling for the kid and believed he could have contributed. Not now, you're an idiot Lewis knowing what was at stake and being part of that gig in Florida. Now you can bullshit your way through life on $400,000 with no degree and a hand full of pictures to keep you company. Don't spend it all in one place.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: The NYG boat party may be the single greatest cause-effect incident </b><a name="13490766">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=shockeyisthebest8056"> shockeyisthebest8056 </a>  :  6/5/2017  1:25 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490766">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490715" target="_blank">13490715</a> Jimmy Googs said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> since the assassination of Archduke Ferdinand of Austria in 1914 resulting in outbreak of World War I... </td>
                                </tr>
                           </table><br />
<br />
Hehehe.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: According to the article </b><a name="13490768">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Beer+Man"> Beer Man </a>  :  6/5/2017  1:26 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490768">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490679" target="_blank">13490679</a> mac attack said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13490651 Beer Man said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     the cops smelled weed in the car.  What are the going odds that his days as a Giant are numbered? <br />
                                <br />
                           <br />
<br />
Did they find any weed tho? </td>
                                </tr>
                           </table>It has been reported since that the found a little.  It doesn't really matter though, because the NFL will drug test him now; marijuana supposedly stays in you system for several weeks.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: another genius </b><a name="13490769">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Victor+in+CT"> Victor in CT </a>  :  6/5/2017  1:26 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490769">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490757" target="_blank">13490757</a> FJ said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13490650 Victor in CT said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     sadly he was more impactful than Cruz was last year <br />
                                <br />
                           <br />
Ummm...no, he wasn't.<br />
<br />
Cruz:  72 targets, 39 receptions, 586 yards, 1 TD, 15.0 YPR, long of 48 yards, 54.2 catch%<br />
Lewis:  19 targets, 7 receptions, 97 yards, 2 TD, 13.9 YPR, long of 30 yards, 36.8 catch% </td>
                                </tr>
                           </table><br />
<br />
Ummm, yeah he was. We they started giving him more of Cruz's snaps in the last 1/4 of the season and int he playoffs, he helped open up the middle of the field because he was able to get deep down the seam and stretch the field. Cruz  couldn't and they had nowhere to throw but into traffic. Christ this is NOT fucking fantasy football.</div></div><div class="thread_post"><div class="thread_post_header"><b>It could be getting worse for Lewis </b><a name="13490774">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Beer+Man"> Beer Man </a>  :  6/5/2017  1:34 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490774">link</a>   </div></div><div class="thread_post_body"> Someone on BBWC is reporting "There was marijuana and an unknown still to be tested liquid".</div></div><div class="thread_post"><div class="thread_post_header"><b>Here's where the logic.. </b><a name="13490775">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=FatMan+in+Charlotte"> FatMan in Charlotte </a>  :  6/5/2017  1:34 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490775">link</a>   </div></div><div class="thread_post_body"> breaks down:<br />
<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">What I said was that it's not surprising that one of the guys on the boat is now in trouble with drugs.<br />
<br />
Seems to make plenty of sense.</td>
                                </tr>
                           </table><br />
<br />
If a defender gets suspended are you going to tie it back to hanging around Landon Collins and partying the same time the boat party was going on?<br />
<br />
Don't worry - it's rhetorical. The same people who are making boat gate out to be a "huge" issue conveniently overlook that the defense had a larger party, reportedly with a lot of substances floating around, yet because they didn't do it with a rapper in Miami and have pictures circulating, they were ultra-focused and the WR's are a shit show.<br />
<br />
Then, you have people talking about Odell's drops in the playoff game and nary a word about the defense giving up 38 points. There are two narratives there and both are idiotic and useless to further.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Tavares king passed him on the depth chart last season </b><a name="13490779">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Torrag"> Torrag </a>  :  6/5/2017  1:38 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490779">link</a>   </div></div><div class="thread_post_body"> Lewis was fighting a losing battle and imo he knew it and it possibly contributed to what happened last night.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: . </b><a name="13490783">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=jvm52106"> jvm52106 </a>  :  6/5/2017  1:41 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490783">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490669" target="_blank">13490669</a> arcarsenal said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Because it wasn't a big deal. <br />
<br />
The only mistake they made was putting it out there on social media and letting the vultures pick it apart. <br />
<br />
If you think NFL players spend all of their free time watching tape or studying plays, you probably shouldn't be calling other people dumb. </td>
                                </tr>
                           </table><br />
<br />
OMG, you can say what you want about that trip but the fact is they did it and played like shit! Maybe not related but kind of hard to ignore though.</div></div><div class="thread_post"><div class="thread_post_header"><b>I'm calling it right now </b><a name="13490787">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=River"> River </a>  :  6/5/2017  1:44 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490787">link</a>   </div></div><div class="thread_post_body"> Lewis will not be on the team this year. Don't need distractions when you are making a Super Bowl run.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: . </b><a name="13490799">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=arcarsenal"> arcarsenal </a>  :  6/5/2017  1:50 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490799">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490783" target="_blank">13490783</a> jvm52106 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13490669 arcarsenal said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Because it wasn't a big deal. <br />
<br />
The only mistake they made was putting it out there on social media and letting the vultures pick it apart. <br />
<br />
If you think NFL players spend all of their free time watching tape or studying plays, you probably shouldn't be calling other people dumb. <br />
                                <br />
                           <br />
<br />
OMG, you can say what you want about that trip but the fact is they did it and played like shit! Maybe not related but kind of hard to ignore though. </td>
                                </tr>
                           </table><br />
<br />
OMG! <br />
<br />
So... I <span class="italics">did</span> say what I wanted about that trip. <br />
<br />
I don't think it had anything to do with what happened nearly a week later. It's like going out to dinner on a Saturday night and saying you are too full to eat because you overdid it @ breakfast on Monday morning.</div></div><div class="thread_post"><div class="thread_post_header"><b>Hmm... </b><a name="13490804">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=FatMan+in+Charlotte"> FatMan in Charlotte </a>  :  6/5/2017  1:53 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490804">link</a>   </div></div><div class="thread_post_body"> <table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">OMG, you can say what you want about that trip but the fact is they did it and played like shit! Maybe not related but kind of hard to ignore though.</td>
                                </tr>
                           </table><br />
<br />
But yet, it is quite easy to ignore the defense's party, right? <br />
<br />
Because ignorance is bliss. On so many different levels....</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Opens the door for Darius Powe </b><a name="13490805">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Tom+in+NY"> Tom in NY </a>  :  6/5/2017  1:54 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490805">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490714" target="_blank">13490714</a> giant24 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Needed some experience but at 6-3 220 another huge receiver. </td>
                                </tr>
                           </table><br />
<br />
YES -- this is the exact thing that needs to happen.<br />
<br />
Cut Lewis to send a message to the rest of the team.  No character issues  needed...football is your job, winning championships is the focus.</div></div><div class="thread_post"><div class="thread_post_header"><b>The best scenario for this kid is... </b><a name="13490814">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=EricJ"> EricJ </a>  :  6/5/2017  2:03 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490814">link</a>   </div></div><div class="thread_post_body"> that he was hanging around with his friends and they were all getting high without him. Says a lot about his judgement. <br />
<br />
It could only get worse from there. Lets just hope it was second hand smoke for his sake.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Let it go? Why? </b><a name="13490817">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=section125"> section125 </a>  :  6/5/2017  2:08 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490817">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490619" target="_blank">13490619</a> Chris684 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Because you don't like it?<br />
<br />
One of the guys who was partying on a boat with celebrities while pretty much everyone else was doing drugs is now...in trouble for drugs and people can't make a connection?<br />
<br />
This is a team issue, as in it now weakens camp competition at the WR spot. <br />
<br />
But let's not bring up the boat stuff...has nothing to do with any of this. </td>
                                </tr>
                           </table><br />
<br />
I'll say it plainly - you are a jackass.</div></div><div class="thread_post"><div class="thread_post_header"><b>"Stupid </b><a name="13490821">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=AcidTest"> AcidTest </a>  :  6/5/2017  2:13 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490821">link</a>   </div></div><div class="thread_post_body"> is as stupid does."<br />
<br />
I agree with Torrag that King had passed him on the depth chart, but Lewis looked good in OTAs FWIW.<br />
<br />
The Giants will wait for the "dust to settle" before deciding what to do. But he's a "bubble" player, and they are still smarting from the "Will Hill" fiasco.<br />
<br />
Lewis being released is most likely to help Powe, Tye, or LaCosse, but it could easily be someone less obvious who plays completely different position.</div></div><div class="thread_post"><div class="thread_post_header"><b>I thought it </b><a name="13490822">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=area+junc"> area junc </a>  :  6/5/2017  2:13 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490822">link</a>   </div></div><div class="thread_post_body"> was weird he (and Cruz) were playing ahead of King last year. <br />
<br />
King dominated in preseason and deserved to play, as he showed when he finally got a chance.</div></div><div class="thread_post"><div class="thread_post_header"><b>He smoked weed in the offseason </b><a name="13490825">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=WillieYoung"> WillieYoung </a>  :  6/5/2017  2:16 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490825">link</a>   </div></div><div class="thread_post_body"> Hang him!<br />
<br />
What nonsense.</div></div><div class="thread_post"><div class="thread_post_header"><b>It's time for Mutiny on the SS Bonehead </b><a name="13490827">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ghost718"> ghost718 </a>  :  6/5/2017  2:20 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490827">link</a>   </div></div><div class="thread_post_body"> Start paddling dummy</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: He smoked weed in the offseason </b><a name="13490832">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=j_rud"> j_rud </a>  :  6/5/2017  2:27 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490832">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490825" target="_blank">13490825</a> WillieYoung said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Hang him!<br />
<br />
What nonsense. </td>
                                </tr>
                           </table><br />
<br />
Choosing to smoke and getting yourself arrested for driving high are two separate things, no? I know you'd like to chalk this up to The Man trampling on the rights of the poor, persecuted pot smoker but that's not really the case here. I absolutely believe people should have the freedom to choose when it comes to weed. I don't believe they should be reckless jackasses who can endanger the lives of others. If you can't discern the difference you might wanna put down the bong for a few days.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: He smoked weed in the offseason </b><a name="13490834">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Beer+Man"> Beer Man </a>  :  6/5/2017  2:27 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490834">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490825" target="_blank">13490825</a> WillieYoung said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Hang him!<br />
<br />
What nonsense. </td>
                                </tr>
                           </table>No one wants to hang Lewis for smoking weed.  But as the team learned with Will Hill, it doesn't matter how talented a player is, they are of no use if the team cannot rely on them to be available to play on game day; particularly when it is their own behavior that is preventing them from seeing the field.</div></div><div class="thread_post"><div class="thread_post_header"><b>LOL </b><a name="13490873">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=WillVAB"> WillVAB </a>  :  6/5/2017  3:16 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490873">link</a>   </div></div><div class="thread_post_body"> So according to BBI, the boat trip from 6 months ago is now a gateway drug.  <br />
<br />
Maybe this thread should be consolidated with the opiod crisis thread.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: LOL </b><a name="13490883">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Ten+Ton+Hammer"> Ten Ton Hammer </a>  :  6/5/2017  3:25 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490883">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490873" target="_blank">13490873</a> WillVAB said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> So according to BBI, the boat trip from 6 months ago is now a gateway drug.  <br />
<br />
Maybe this thread should be consolidated with the opiod crisis thread. </td>
                                </tr>
                           </table><br />
<br />
Please don't lump us all in with the lunatic crew.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: another genius </b><a name="13490885">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=chopperhatch"> chopperhatch </a>  :  6/5/2017  3:26 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490885">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490757" target="_blank">13490757</a> FJ said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13490650 Victor in CT said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     sadly he was more impactful than Cruz was last year <br />
                                <br />
                           <br />
Ummm...no, he wasn't.<br />
<br />
Cruz:  72 targets, 39 receptions, 586 yards, 1 TD, 15.0 YPR, long of 48 yards, 54.2 catch%<br />
Lewis:  19 targets, 7 receptions, 97 yards, 2 TD, 13.9 YPR, long of 30 yards, 36.8 catch% </td>
                                </tr>
                           </table><br />
<br />
Victor and Carl in CT....keeping BBI dumb....again.</div></div><div class="thread_post"><div class="thread_post_header"><b>Isn't marijuana  </b><a name="13490895">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Giants"> Giants </a>  :  6/5/2017  3:33 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490895">link</a>   </div></div><div class="thread_post_body"> Good for CTE and Alzheimer. Might be time to let these guys have a little</div></div><div class="thread_post"><div class="thread_post_header"><b>Only .2 grams? </b><a name="13490900">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=adamg"> adamg </a>  :  6/5/2017  3:38 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490900">link</a>   </div></div><div class="thread_post_body"> What a lightweight. Cut him for being a frugal toker. We don't need that Nancy shit.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: LOL </b><a name="13490906">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=arcarsenal"> arcarsenal </a>  :  6/5/2017  3:41 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490906">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490873" target="_blank">13490873</a> WillVAB said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> So according to BBI, the boat trip from 6 months ago is now a gateway drug.  <br />
<br />
Maybe this thread should be consolidated with the opiod crisis thread. </td>
                                </tr>
                           </table><br />
<br />
Yeah, and you're either a Beckham fanboy or just flat out dumb if you don't realize it.</div></div><div class="thread_post"><div class="thread_post_header"><b>Chris684 </b><a name="13490910">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BigBlueShock"> BigBlueShock </a>  :  6/5/2017  3:47 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490910">link</a>   </div></div><div class="thread_post_body"> Doesn't seem very bright.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Only .2 grams? </b><a name="13490916">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=mgreenie03"> mgreenie03 </a>  :  6/5/2017  3:53 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490916">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490900" target="_blank">13490900</a> adamg said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> What a lightweight. Cut him for being a frugal toker. We don't need that Nancy shit. </td>
                                </tr>
                           </table><br />
Right!! .2 grams is basically dust. That has to be 2grams and not .2</div></div><div class="thread_post"><div class="thread_post_header"><b>Yea, a bunch of idiots </b><a name="13490938">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Chris684"> Chris684 </a>  :  6/5/2017  4:13 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490938">link</a>   </div></div><div class="thread_post_body"> patting each other on the back convincing each other you're smarter than someone you disagree with and I'm not bright?<br />
<br />
Ok?<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>.2 grams? </b><a name="13490949">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Shepherdsam"> Shepherdsam </a>  :  6/5/2017  4:23 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490949">link</a>   </div></div><div class="thread_post_body"> Hahahahahaha!<br />
<br />
-David Tyree<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>I don't agree with Chris </b><a name="13490956">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jules+Winnfield"> Jules Winnfield </a>  :  6/5/2017  4:29 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490956">link</a>   </div></div><div class="thread_post_body"> but many of you are misinterpreting his comments. It doesn't sound like he's claiming a causal relationship (that <span class="italics">because</span> someone was on the boat, they're now more likely to smoke weed).<br />
<br />
Rather, it sounds like it doesn't surprise him that a player who would put themselves in a position to have pictures taken of him while others were smoking weed would also put himself in his current position.<br />
<br />
Sounds like it would be more surprising to Chris if, say, OVI reports of King were surfacing today.</div></div><div class="thread_post"><div class="thread_post_header"><b>Yea, that's pretty much it Jules.. </b><a name="13490966">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Chris684"> Chris684 </a>  :  6/5/2017  4:37 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13490966">link</a>   </div></div><div class="thread_post_body"> My comment, which was meant as a throw away, was pretty reasonable and logical after all. Even if you don't agree with it.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I don't agree with Chris </b><a name="13491011">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=therealmf"> therealmf </a>  :  6/5/2017  5:31 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13491011">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490956" target="_blank">13490956</a> Jules Winnfield said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> but many of you are misinterpreting his comments. It doesn't sound like he's claiming a causal relationship (that because someone was on the boat, they're now more likely to smoke weed).<br />
<br />
Rather, it sounds like it doesn't surprise him that a player who would put themselves in a position to have pictures taken of him while others were smoking weed would also put himself in his current position.<br />
<br />
Sounds like it would be more surprising to Chris if, say, OVI reports of King were surfacing today. </td>
                                </tr>
                           </table><br />
<br />
Right.  Because the average 22-25 year old has never had exposure to marijuana.  Never saw it, smoked it, saw it smoked and in fact had no friends who used it.  <br />
<br />
Lewis was stupid.  For smoking for driving impaired and to be carry any illegal substance.  Of this there is little doubt.<br />
<br />
It has nothing to do with the boat. I my eyes Chris684 was stirring a little shit.  It was noticed and returned.  His comment should be taken as shit stirring and not be defended.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>The reports say they think he was drunk </b><a name="13491016">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=PatersonPlank"> PatersonPlank </a>  :  6/5/2017  5:39 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13491016">link</a>   </div></div><div class="thread_post_body"> The weed thing was just something they found after pulling him over.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: The reports say they think he was drunk </b><a name="13491021">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=therealmf"> therealmf </a>  :  6/5/2017  5:42 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13491021">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13491016" target="_blank">13491016</a> PatersonPlank said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> The weed thing was just something they found after pulling him over. </td>
                                </tr>
                           </table><br />
He was still stupid to have it.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I don't agree with Chris </b><a name="13491025">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=arcarsenal"> arcarsenal </a>  :  6/5/2017  5:44 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13491025">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490956" target="_blank">13490956</a> Jules Winnfield said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> but many of you are misinterpreting his comments. It doesn't sound like he's claiming a causal relationship (that because someone was on the boat, they're now more likely to smoke weed).<br />
<br />
Rather, it sounds like it doesn't surprise him that a player who would put themselves in a position to have pictures taken of him while others were smoking weed would also put himself in his current position.<br />
<br />
Sounds like it would be more surprising to Chris if, say, OVI reports of King were surfacing today. </td>
                                </tr>
                           </table><br />
<br />
Or, it could just be that he was so ridiculously bothered by the entire boat thing (as some fans are), and is still reaching for ways to blame it for anything negative that has gone on since. <br />
<br />
Sterling Shepard "put himself in a position to have pictures taken of him while others were smoking weed" too, but Sterling Shepard hasn't gotten into any legal trouble since because maybe he's just smart enough to not do anything that would get him into legal trouble? Ditto Cruz or Beckham. <br />
<br />
It would have been much easier to simply cite that RLJr had some red flags before he came here and may not have the strongest character or best restraint and thus, say that it's not too surprising that this happened. Instead, this guy decided to blame the fucking boat again.</div></div><div class="thread_post"><div class="thread_post_header"><b>Arc telling me now what I should and should not </b><a name="13491031">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Chris684"> Chris684 </a>  :  6/5/2017  5:51 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13491031">link</a>   </div></div><div class="thread_post_body"> have said while at the same time still missing the point. <br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Arc telling me now what I should and should not </b><a name="13491041">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=arcarsenal"> arcarsenal </a>  :  6/5/2017  6:13 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13491041">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13491031" target="_blank">13491031</a> Chris684 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> have said while at the same time still missing the point.  </td>
                                </tr>
                           </table><br />
<br />
I'm not missing the point, I'm illustrating how much you're reaching to try and make one.</div></div><div class="thread_post"><div class="thread_post_header"><b>im just glad </b><a name="13491045">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BlackburnBalledOut"> BlackburnBalledOut </a>  :  6/5/2017  6:16 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13491045">link</a>   </div></div><div class="thread_post_body"> its some bum receiver. <br />
<br />
 i do hope this doesnt wreck his career.<br />
 buuuuut i would issue him his walking papers</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: LOL </b><a name="13491051">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gregorio"> Gregorio </a>  :  6/5/2017  6:20 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13491051">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490873" target="_blank">13490873</a> WillVAB said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> So according to BBI, the boat trip from 6 months ago is now a gateway drug.  <br />
</td>
                                </tr>
                           </table><br />
<br />
Way to lump the entire membership of BBI into one bucket.  That's not how I saw it, and if you asked most BBIers, probably not how they saw it either.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Police Report says officer found .2 grams of marijuana </b><a name="13491065">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=santacruzom"> santacruzom </a>  :  6/5/2017  6:35 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13491065">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13490749" target="_blank">13490749</a> gidiefor said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> in Lewis' vehicle Link  - ( New Window ) </td>
                                </tr>
                           </table><br />
<br />
.2 grams???<br />
<br />
Was he rolling a joint for a hamster?</div></div><div class="thread_post"><div class="thread_post_header"><b>Good riddance....... </b><a name="13491078">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Dry+Lightning"> Dry Lightning </a>  :  6/5/2017  6:52 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13491078">link</a>   </div></div><div class="thread_post_body"> Maybe keep him around in case we have injuries, but when last cut down comes, if all is well........get out! Actually, looked a little too nervous, dropped passes. Was not that impressive, and with his background, it is time to leave.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Police Report says officer found .2 grams of marijuana </b><a name="13491085">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Milton"> Milton </a>  :  6/5/2017  7:05 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13491085">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13491065" target="_blank">13491065</a> santacruzom said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13490749 gidiefor said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     in Lewis' vehicle Link  - ( New Window ) <br />
                                <br />
                           <br />
<br />
.2 grams???<br />
<br />
Was he rolling a joint for a hamster? </td>
                                </tr>
                           </table>He probably found a roach in the ashtray.</div></div><div class="thread_post"><div class="thread_post_header"><b>How is this guy going to make the team? </b><a name="13491114">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=DavidinBMNY"> DavidinBMNY </a>  :  6/5/2017  7:54 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13491114">link</a>   </div></div><div class="thread_post_body"> He didn't have an amazing year.  He's not a star player. He has talent, but he's no sure thing.<br />
<br />
Also, don't discount the handling of the Josh Brown incident last year, and how the failure to act early led to a massive public backlash.  Of course that topic was an order of magnitude worse.  The implications of hurting other people vs. just hurting yourself (Lewis in this case), but the sting of that may impact how this is thought of. If I'm the coaching staff at a minimum he dropped on the depth chart.    <br />
<br />
They might cut Lewis straight away. <br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>I don't think they're going to cut him over weed </b><a name="13491125">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Ten+Ton+Hammer"> Ten Ton Hammer </a>  :  6/5/2017  8:27 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13491125">link</a>   </div></div><div class="thread_post_body"> While there's a vast difference in the quality of the player, think about how many chances Will Hill got before the front office decided that the trouble wasn't worth the talent, and he was such a knucklehead they put up with multiple suspensions.<br />
<br />
I think he was about as good as you could expect for a late rookie, but the WR roster is pretty full of guys underneath the top 3 that are just begging for more snaps.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Dude had what 7 catches </b><a name="13491181">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=blueblood"> blueblood </a>  :  6/5/2017  9:20 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13491181">link</a>   </div></div><div class="thread_post_body"> they can cut him and not miss a beat</div></div><div class="thread_post"><div class="thread_post_header"><b>I think he should go </b><a name="13491225">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Joey+in+VA"> Joey in VA </a>  :  6/5/2017  11:04 pm   : <a href="index.php?mode=2&thread=553461&show_all=1#13491225">link</a>   </div></div><div class="thread_post_body"> In camp, he's not as explosive as King, won't unseat anyone ahead of him and he doesn't do much on specials.  I don't see very much out of him athletically, he's a fringe roster guy at best.</div></div><div class="thread_post"><div class="thread_post_header"><b>I'd take a report like this with a grain of salt. </b><a name="13491246">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=eclipz928"> eclipz928 </a>  : 12:02 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13491246">link</a>   </div></div><div class="thread_post_body"> Not saying that Lewis couldn't have been guilty of smoking weed, but I've known cops to use that line about the "smell of weed" as justification to search a car without reasonable cause.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Police Report says officer found .2 grams of marijuana </b><a name="13491249">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=David+in+LA"> David in LA </a>  : 12:10 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13491249">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=553461&show_all=1#13491065" target="_blank">13491065</a> santacruzom said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13490749 gidiefor said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     in Lewis' vehicle Link  - ( New Window ) <br />
                                <br />
                           <br />
<br />
.2 grams???<br />
<br />
Was he rolling a joint for a hamster? </td>
                                </tr>
                           </table><br />
<br />
What was he getting high on?  His imagination?</div></div><div class="thread_post"><div class="thread_post_header"><b>Yep...must be the cops fault... </b><a name="13491250">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LarmerTJR"> LarmerTJR </a>  : 12:11 am   : <a href="index.php?mode=2&thread=553461&show_all=1#13491250">link</a>   </div></div><div class="thread_post_body"> Not the dumb ass, but the cops....</div></div><a name="END"><a href="index.php"><div style="padding-top:25px; padding-bottom:20px;"><img src="/images/back_corner.gif" width="150" height="23" alt="Back to the Corner" border="0"></a></div></a><div id="ad_side_box">
<div style="height:260px;width:300px;margin:auto;">

<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id="usmg_ad_nfl.general_football_sports_300x250_1a">
<script type='text/javascript'>
googletag.defineSlot('/7103/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250]], 'usmg_ad_nfl.general_football_sports_300x250_1a').addService(googletag.pubads());
googletag.enableServices();
googletag.display('usmg_ad_nfl.general_football_sports_300x250_1a');
</script>
</div>

</div>
<div style="height:260px;width:300px;margin-auto;">

<!-- BEGIN Google Adsense CODE -->

<script type="text/javascript"><!--
google_ad_client = "ca-pub-1566320450447229";
/* Corner Forum - Lower 300x250 Box */
google_ad_slot = "3213469993";
google_ad_width = 300;
google_ad_height = 250;
//-->
</script>
<script type="text/javascript"
src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>

<!-- END Google Adsense CODE -->


</div>
</div>




<div class="footer">


<p style="width:400px;float:left;"><b>Part of the USA Today Sports Media Group</b><br>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</P>
<P  style="width:400px;float:right; text-align:right;">
All contents (unless otherwise specified) copyright &copy;  1995 - 2017<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Support</a>
</P>
<br clear="all">
<div style="float:right;">
<script
    src="https://sucuri.net/monitoring/badge.js"
    data-s="19"
    id="sucuri-s"
    data-i="7b1b29ae50ae6574f2af3875935246e4fa8a805b26"
    data-p="o" - position - l(left) or r(right) or o(relative)
    data-c="l"
    data-t="t"
    ></script>
</div>

</div>


<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->

</body>
</html>
