<html>
<head>
<title>Who are we rooting for? | Big Blue Interactive </title>

<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">
<meta name="keywords" content="ndglbqfkxx">

<meta name="description" content="There are a number of battles going on at the end of quite a few units.  Who are we rooting for?

I'm hoping for...

Geno Smith over Josh Johnson.  He's simply more talented.

Shane Smith over Josh Huesman.  I want a mauler.  

Darius Powe over Roger Lewis/Travis Rudolph.  Love having another tall target if Marshall goes down.  He also seems to be getting open and has the best hands.

Devin Taylor over ?.  Like having a tall DE with experience as a rotational player.  We have so much talent at DE a good player or two is going to get cut.

Stansly Maponga over JT Thomas.  Enough is enough with Thomas.  Time for new blood.  

Donte Deyon over Valentino Blake.  Sy had Deyon as one of the only CB that could stick with Odel in camp.  He might not be great returning the ball on specials but with Harris that shouldn't be an issue.  

Aldrick Rosas over Mike NUgent.  Rooting for the kid with the big leg.

Who are you rooting for?  "/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="website" />
<meta property="og:description" content="There are a number of battles going on at the end of quite a few units.  Who are we rooting for?

I'm hoping for...

Geno Smith over Josh Johnson.  He's simply more talented.

Shane Smith over Josh Huesman.  I want a mauler.  

Darius Powe over Roger Lewis/Travis Rudolph.  Love having another tall target if Marshall goes down.  He also seems to be getting open and has the best hands.

Devin Taylor over ?.  Like having a tall DE with experience as a rotational player.  We have so much talent at DE a good player or two is going to get cut.

Stansly Maponga over JT Thomas.  Enough is enough with Thomas.  Time for new blood.  

Donte Deyon over Valentino Blake.  Sy had Deyon as one of the only CB that could stick with Odel in camp.  He might not be great returning the ball on specials but with Harris that shouldn't be an issue.  

Aldrick Rosas over Mike NUgent.  Rooting for the kid with the big leg.

Who are you rooting for?  " /> 
<meta property="og:title" content="Who are we rooting for?" /> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif" /> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css" />

<link rel="stylesheet" type="text/css" href="anylink.css" />


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}

html, body {
overflow-x: hidden;
}

div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" />

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type="text/javascript"><!--
//<![CDATA[
(function() {
var useSSL = 'https:' == document.location.protocol;
var src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
//]]>
//--></script>
<script type='text/javascript' src='http://img.bnqt.com/lib/js/sdpdfphelper.js'></script>
<script type="text/javascript">
googletag.pubads().enableSyncRendering();
googletag.pubads().setTargeting("title", sdpTargeting.title)
                  .setTargeting('targetPaths', sdpTargeting.targetPaths)
                  .setTargeting('fullPath', sdpTargeting.fullPath)
                  .setTargeting('queryStr', sdpTargeting.queryStr)
                  .setTargeting('domainName', sdpTargeting.domainName);       
</script>
<script type="text/javascript">
window._UrlSegment = window._UrlSegment || ''; 
window._SitePage = window._SitePage || ''; 
_UrlSegment = window.location.toString().replace(/http:\/\//, '').split('/'); 
_SitePage = _UrlSegment[1].match(/^$|^(index.php)+$/i) ? 'main' : 'general'; 
</script>
<!-- End DFP SETUP -->  

<!-- End USA Today Code -->


</head>


<body bgcolor="ffffff">



<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"></a> <img src="images/xpete.gif" alt="The Corner Forum">

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic -->&nbsp;

<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->

<div id="usmg_ad_nfl.general_football_sports_728x90_1a" style="margin:auto;">
<script type='text/javascript'>
googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_nfl.general_football_sports_728x90_1a').addService(googletag.pubads());
googletag.enableServices();
googletag.display('usmg_ad_nfl.general_football_sports_728x90_1a');
</script>
</div>

</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://astore.amazon.com/bigblueintera-20">Books/DVDs</a>
<a href="http://www.shareasale.com/r.cfm?b=277504&u=723646&m=29078&urllink=&afftrack=">Apparel</a>
<a href="http://www.amazon.com/?_encoding=UTF8&camp=1789&creative=9325&linkCode=ur2&tag=bigblueintera-20">Amazon.com</a>
<a href="http://www.ticketmonster.com/New-York-Giants-Tickets?aid=16418">Tickets</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-photo-archive/">Historical Photo Archive</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW" >Standings (NFL.com)</a>
<a href="http://www.nfl.com/teams/newyorkgiants/statistics?team=NYG" target="_NEW" >Statistics (NFL.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/" >Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'home_view_menu')">Home</a>  
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'forum_view_menu')">Corner Forum</a>
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'gameday_view_menu')">Gameday</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_view_menu')">Team</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_building_view_menu')">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info &amp; History</a> -->
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_info_view_menu')">Giants Info &amp; History</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'infolinks_view_menu')">Info/Links</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'shop_view_menu')">BBI Shop</a>
<li><a href="/index.php?mode=10" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'login_menu')">Log In</a>
</ul>

</div><div id="infoline"> </div>

<a name="END"><a href="index.php"><div style="padding-top:20px; padding-bottom:25px;"><img src="/images/back_corner.gif" width="150" height="23" alt="Back to the Corner" border="0"></a></div></a><div id="ad_pad_box"> &nbsp; </div><div class="thread_body" ><div class="thread_main" ><div class="thread_post_header" >  <h1 style="font-size:18px;">Who are we rooting for? </h1><div class="thread_info"><a href="index.php?mode=5&handle=ZGiants98"> ZGiants98 </a>  :  8/13/2017  12:56 pm</div></div><div class="thread_post_body" > There are a number of battles going on at the end of quite a few units.  Who are we rooting for?<br />
<br />
I'm hoping for...<br />
<br />
Geno Smith over Josh Johnson.  He's simply more talented.<br />
<br />
Shane Smith over Josh Huesman.  I want a mauler.  <br />
<br />
Darius Powe over Roger Lewis/Travis Rudolph.  Love having another tall target if Marshall goes down.  He also seems to be getting open and has the best hands.<br />
<br />
Devin Taylor over ?.  Like having a tall DE with experience as a rotational player.  We have so much talent at DE a good player or two is going to get cut.<br />
<br />
Stansly Maponga over JT Thomas.  Enough is enough with Thomas.  Time for new blood.  <br />
<br />
Donte Deyon over Valentino Blake.  Sy had Deyon as one of the only CB that could stick with Odel in camp.  He might not be great returning the ball on specials but with Harris that shouldn't be an issue.  <br />
<br />
Aldrick Rosas over Mike NUgent.  Rooting for the kid with the big leg.<br />
<br />
Who are you rooting for?   </div></div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="13558821">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  8/13/2017  1:01 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558821">link</a>   </div></div><div class="thread_post_body"> Please no Valentino Blake.</div></div><div class="thread_post"><div class="thread_post_header"><b>obviously </b><a name="13558829">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  8/13/2017  1:11 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558829">link</a>   </div></div><div class="thread_post_body"> the ideal scenario would be for Rosas to prove he can do it... but we just don't know yet.<br />
<br />
That said, that 52-yard kick in the rain was impressive.</div></div><div class="thread_post"><div class="thread_post_header"><b>I've just studied the first Quarter --  </b><a name="13558831">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=gidiefor"> gidiefor </a> : <b style="background:darkred;color:white;">Mod</b> :  8/13/2017  1:16 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558831">link</a>   </div></div><div class="thread_post_body"> I don't think Josh Johnson was all that bad --</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I've just studied the first Quarter --  </b><a name="13558835">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=chopperhatch"> chopperhatch </a>  :  8/13/2017  1:26 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558835">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558831" target="_blank">13558831</a> gidiefor said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I don't think Josh Johnson was all that bad -- </td>
                                </tr>
                           </table><br />
<br />
Wow really? I thought he was horrendous. He was super jittery in the pocket...didnt do his line any favors. He probably had more to do with the sacks than the blocking and his lack of poise allowed him to miss Powe who Was all alone in the end zone four a good 7 seconds. The "jump pass" to Perkins was awful. If he repositiins himself to get him the ball, Perkins has a first.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I've just studied the first Quarter --  </b><a name="13558837">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ZGiants98"> ZGiants98 </a>  :  8/13/2017  1:28 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558837">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558831" target="_blank">13558831</a> gidiefor said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I don't think Josh Johnson was all that bad -- </td>
                                </tr>
                           </table><br />
<br />
You know. I've said there needs to be some context when evaluating him.  Johnson was up against the Steelers starting defense.  Geno was facing 2s and 3s.  Webb was facing absolute scrubs.  I'd like to see how the QBs performed if the roles were reversed.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I've just studied the first Quarter --  </b><a name="13558838">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=gidiefor"> gidiefor </a> : <b style="background:darkred;color:white;">Mod</b> :  8/13/2017  1:30 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558838">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558835" target="_blank">13558835</a> chopperhatch said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13558831 gidiefor said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     I don't think Josh Johnson was all that bad -- <br />
                                <br />
                           <br />
<br />
Wow really? I thought he was horrendous. He was super jittery in the pocket...didnt do his line any favors. He probably had more to do with the sacks than the blocking and his lack of poise allowed him to miss Powe who Was all alone in the end zone four a good 7 seconds. The "jump pass" to Perkins was awful. If he repositiins himself to get him the ball, Perkins has a first. </td>
                                </tr>
                           </table><br />
<br />
Geno gave up an interception that led to a TD by Pittsburgh and then looked terrible -- he did not recover from it -- a lot of Johnson's problems were caused by poor assignments - he did not make any major errors.<br />
<br />
The Giants should have scored a touchdown after Blake's interception and this wasn't on Johnson</div></div><div class="thread_post"><div class="thread_post_header"><b>As a few of you have already suggested </b><a name="13558840">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=mfsd"> mfsd </a>  :  8/13/2017  1:31 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558840">link</a>   </div></div><div class="thread_post_body"> I suspect our 5th CB and/or another S may not yet be on the roster<br />
<br />
That said, the Giants are clearly favoring guys who can play a big role on specials...which may be why Blake and Pinkins have a leg up right now<br />
<br />
I'm rooting for Smith, and rooting for us to keep a true FB, not just a hybrid TE. Even in a small sample size, we saw the value with the 4th and 1 conversion and the swing pass to Smith Friday night<br />
<br />
Also rooting for Munson, looks like he's got a good shot</div></div><div class="thread_post"><div class="thread_post_header"><b>What good player is getting </b><a name="13558842">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=XBRONX"> XBRONX </a>  :  8/13/2017  1:32 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558842">link</a>   </div></div><div class="thread_post_body"> cut at DE?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: What good player is getting </b><a name="13558844">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  8/13/2017  1:36 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558844">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558842" target="_blank">13558842</a> XBRONX said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> cut at DE? </td>
                                </tr>
                           </table><br />
<br />
There are lots of DE's in this league who can't play the run or pass. We have quite a few that can play the run.</div></div><div class="thread_post"><div class="thread_post_header"><b>hopefully we can make a trade </b><a name="13558846">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Chip"> Chip </a>  :  8/13/2017  1:37 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558846">link</a>   </div></div><div class="thread_post_body"> with a DE anybody for an OL</div></div><div class="thread_post"><div class="thread_post_header"><b>Who is the odd man </b><a name="13558847">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=XBRONX"> XBRONX </a>  :  8/13/2017  1:39 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558847">link</a>   </div></div><div class="thread_post_body"> out at DE that anyone would trade for? Dont tell me OO.</div></div><div class="thread_post"><div class="thread_post_header"><b>Should have added </b><a name="13558848">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ZGiants98"> ZGiants98 </a>  :  8/13/2017  1:41 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558848">link</a>   </div></div><div class="thread_post_body"> that Im rooting for LaCosse over Tye.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Who is the odd man </b><a name="13558850">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ZGiants98"> ZGiants98 </a>  :  8/13/2017  1:42 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558850">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558847" target="_blank">13558847</a> XBRONX said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> out at DE that anyone would trade for? Dont tell me OO. </td>
                                </tr>
                           </table><br />
<br />
Wynn?  Even without OO, we still have 6 DE.  If you count OO, we have 7.</div></div><div class="thread_post"><div class="thread_post_header"><b>I know it's unrealistic </b><a name="13558851">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=pjcas18"> pjcas18 </a>  :  8/13/2017  1:44 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558851">link</a>   </div></div><div class="thread_post_body"> but I'm hoping for Davis over Smith and Johnson.  Johnson was absolutely brutal, and hasn't thrown a pass in a regular season NFL game since 2011 - no shit his last NFL game pass attempt 2011.  No clue how he's still hanging around the league.<br />
<br />
Smith was light years better than Johnson, but I believe if Eli goes down the Giants are unlikely to win with Geno.<br />
<br />
So instead of losing two DE's who maybe have upside for a washed up QB, stick with Davis as the backup and keep the lottery tickets.<br />
<br />
Guys like McCants and Gillbery who get let go to keep 3rd QB's (even though Gillbery wasn't let go for a QB) don't make sense to me even if they don't pan out.<br />
<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>I want the better, healthier players ... </b><a name="13558854">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=George+from+PA"> George from PA </a>  :  8/13/2017  1:46 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558854">link</a>   </div></div><div class="thread_post_body"> I am not sure I am rooting for anyone....<br />
<br />
do the Giants control Rosa for several years? <br />
<br />
I rather keep only Webb...then part with decent depth</div></div><div class="thread_post"><div class="thread_post_header"><b>Wynn </b><a name="13558855">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=XBRONX"> XBRONX </a>  :  8/13/2017  1:47 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558855">link</a>   </div></div><div class="thread_post_body"> is lock to make the team. I think OO is a lock to get cut.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: I've just studied the first Quarter --  </b><a name="13558857">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=chopperhatch"> chopperhatch </a>  :  8/13/2017  1:51 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558857">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558838" target="_blank">13558838</a> gidiefor said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13558835 chopperhatch said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     In comment 13558831 gidiefor said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     I don't think Josh Johnson was all that bad -- <br />
                                <br />
                           <br />
<br />
Wow really? I thought he was horrendous. He was super jittery in the pocket...didnt do his line any favors. He probably had more to do with the sacks than the blocking and his lack of poise allowed him to miss Powe who Was all alone in the end zone four a good 7 seconds. The "jump pass" to Perkins was awful. If he repositiins himself to get him the ball, Perkins has a first. <br />
                                <br />
                           <br />
<br />
Geno gave up an interception that led to a TD by Pittsburgh and then looked terrible -- he did not recover from it -- a lot of Johnson's problems were caused by poor assignments - he did not make any major errors.<br />
<br />
The Giants should have scored a touchdown after Blake's interception and this wasn't on Johnson </td>
                                </tr>
                           </table><br />
<br />
The pick where Geno didnt see the Pitt defender was bad no doubt. But he looked a lot more comfortable going through his progressions than JJ.<br />
<br />
And was the TD the Giants "shpuld have scored" the one where he tried scrambling around and got sacked? Yea, thats the play I was talking about. JJ zeroed in on ONE side of the field and missed Powe jumping up and down waving his arms wide open in the end zone. Pretty sure the next play, Johnson went right to his first read a guy that had defenders draped all over him at the 8 yard line.<br />
<br />
I will gladly take Geno and his warts because he will actually give himself a chance to succeed.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: As a few of you have already suggested </b><a name="13558860">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=chopperhatch"> chopperhatch </a>  :  8/13/2017  1:57 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558860">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558840" target="_blank">13558840</a> mfsd said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Even in a small sample size, we saw the value with the 4th and 1 conversion and the swing pass to Smith Friday night</td>
                                </tr>
                           </table><br />
<br />
And again, this was another one of JJ's screw ups. He threw that ball to the inside of Smith when he was running to the sideline, forcing Smith to stop his momentum and allow the defender to gain more ground and stop him short of the first. Yes, we got it anyways later, but that could have been interesting if Smith had gotten past that LB and started rumbling towards DBs.</div></div><div class="thread_post"><div class="thread_post_header"><b>Agree on Geno </b><a name="13558862">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=XBRONX"> XBRONX </a>  :  8/13/2017  1:57 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558862">link</a>   </div></div><div class="thread_post_body"> If I was the Giants I would not waste another preseason game snap for Johnson.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Wynn </b><a name="13558863">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ZGiants98"> ZGiants98 </a>  :  8/13/2017  1:57 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558863">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558855" target="_blank">13558855</a> XBRONX said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> is lock to make the team. I think OO is a lock to get cut. </td>
                                </tr>
                           </table><br />
<br />
So you're saying the Giants will carry 6 DE?</div></div><div class="thread_post"><div class="thread_post_header"><b>I guess so- </b><a name="13558867">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=XBRONX"> XBRONX </a>  :  8/13/2017  2:00 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558867">link</a>   </div></div><div class="thread_post_body"> Moss will get the automatic draftee spot, no matter how bad he looks in practice or preseason.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Who is the odd man </b><a name="13558868">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=chopperhatch"> chopperhatch </a>  :  8/13/2017  2:00 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558868">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558847" target="_blank">13558847</a> XBRONX said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> out at DE that anyone would trade for? Dont tell me OO. </td>
                                </tr>
                           </table><br />
<br />
I dont know what you want to hear then. OO cant stay on the field and is as blah as they come in a pass rush. Wynn works his ass off, is always battling and can play specials. He reminds me a lot of Dave Tollefson(sp?). DT had more pass rush, but Wynn is better against the run.</div></div><div class="thread_post"><div class="thread_post_header"><b>Shane Smith isn't competing against Josh Huesman. </b><a name="13558869">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BillT"> BillT </a>  :  8/13/2017  2:02 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558869">link</a>   </div></div><div class="thread_post_body"> He's competing against LaCrosse (4 TE or 3 TE, 1 FB).  Devin Taylor over a 10th DB.  Either 10 DL (4 DT, 6 DE) or 10 DB (5th S)</div></div><div class="thread_post"><div class="thread_post_header"><b>Wynn </b><a name="13558871">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=XBRONX"> XBRONX </a>  :  8/13/2017  2:02 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558871">link</a>   </div></div><div class="thread_post_body"> is a very steady player versus the run.</div></div><div class="thread_post"><div class="thread_post_header"><b>The Geno Smith you saw </b><a name="13558873">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=gidiefor"> gidiefor </a> : <b style="background:darkred;color:white;">Mod</b> :  8/13/2017  2:05 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558873">link</a>   </div></div><div class="thread_post_body"> is the Geno Smith you get -- he did the same stuff with the Jets -- brilliant for a period then throws the ball up for grabs and the game proceeds to get out of control.<br />
<br />
Johnson had a few bad plays -- but he did enough to get a TD and a field goal in his 1 and a half quarters and made no major game changing mistakes<br />
<br />
Johnson is a much better game manager right now than either Smith or Davis -- Davis was not under center by the way for one snap -- he's a work in progress.  Right now you can not turn the team over to him -- you only do that if Eli's career is over.</div></div><div class="thread_post"><div class="thread_post_header"><b>I would love for them to only keep Webb behind Eli at QB </b><a name="13558874">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Lawrence_Taylor_56"> Lawrence_Taylor_56 </a>  :  8/13/2017  2:07 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558874">link</a>   </div></div><div class="thread_post_body"> Johnson and Smith likely bounce around as 3rd QBs or FAs most of the season. If Eli goes down you can find one of them on the waiver wire is my guess.</div></div><div class="thread_post"><div class="thread_post_header"><b>You CAN </b><a name="13558878">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=pjcas18"> pjcas18 </a>  :  8/13/2017  2:12 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558878">link</a>   </div></div><div class="thread_post_body"> turn the team over to Webb, but it's unlikely the Giants would.<br />
<br />
The Patriots turned their team over to 3rd round rookie Jacoby Brissett last year for a couple games last year.<br />
<br />
For me, what it boils down to is can you win with Geno (I have already concluded you cannot win with Johnson), and if the answer is yes then the Giants hold on to him while Webb develops, if the answer is probably not (like I think it is) then it's a waste of a roster spot (one that the Giants are likely to use on him though).<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Shane Smith isn't competing against Josh Huesman. </b><a name="13558880">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ZGiants98"> ZGiants98 </a>  :  8/13/2017  2:17 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558880">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558869" target="_blank">13558869</a> BillT said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> He's competing against LaCrosse (4 TE or 3 TE, 1 FB).  Devin Taylor over a 10th DB.  Either 10 DL (4 DT, 6 DE) or 10 DB (5th S) </td>
                                </tr>
                           </table><br />
<br />
lol.  He's clearly competing against both.  They are the only two FB on the roster so yes, they are absolutely competing against each other. They are also competing against many other players for a FB making the roster at all, I get that.</div></div><div class="thread_post"><div class="thread_post_header"><b>pj the thing is you are overlooking the way </b><a name="13558882">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=gidiefor"> gidiefor </a> : <b style="background:darkred;color:white;">Mod</b> :  8/13/2017  2:23 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558882">link</a>   </div></div><div class="thread_post_body"> Coach likes to manage the game -- he doesn't want any turnovers.  He wants to manage the Duke.  He plays for field position and appreciates conservative play if the rythym is not working.<br />
<br />
That's Josh Johnson to a tee -- and I think Coach would much rather see a guy that's going to manage the game as opposed to giving the game a way -- which is Geno's MO<br />
<br />
Think about it -- Johnson has at least 4 plays in the first quarter where there were serious blown assignments and does not turn the ball over -- does not lose his cool at all -- continues to play fairly steady -- further more -- one of the blown assignments would have been a touchdown -- (Lewis steps out of the end zone and then makes the catch)<br />
<br />
Geno's first opportunity to deal with a blown assignment is an interception - then things went south after that - he lost command of the team and everyone seemed tentative after that.<br />
<br />
Webb also lost it after he made an error.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Giants may decide to go with 5 WRs, </b><a name="13558884">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Simms11"> Simms11 </a>  :  8/13/2017  2:26 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558884">link</a>   </div></div><div class="thread_post_body"> 4 TEs and the 1 FB. Engram is listed as a TE, but let's face it, he's both a TE and a big WR.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: pj the thing is you are overlooking the way </b><a name="13558886">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=pjcas18"> pjcas18 </a>  :  8/13/2017  2:29 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558886">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558882" target="_blank">13558882</a> gidiefor said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Coach likes to manage the game -- he doesn't want any turnovers.  He wants to manage the Duke.  He plays for field position and appreciates conservative play if the rythym is not working.<br />
<br />
That's Josh Johnson to a tee -- and I think Coach would much rather see a guy that's going to manage the game as opposed to giving the game a way -- which is Geno's MO<br />
<br />
Think about it -- Johnson has at least 4 plays in the first quarter where there were serious blown assignments and does not turn the ball over -- does not lose his cool at all -- continues to play fairly steady -- further more -- one of the blown assignments would have been a touchdown -- (Lewis steps out of the end zone and then makes the catch)<br />
<br />
Geno's first opportunity to deal with a blown assignment is an interception - then things went south after that - he lost command of the team and everyone seemed tentative after that.<br />
<br />
Webb also lost it after he made an error.<br />
 </td>
                                </tr>
                           </table><br />
<br />
I can see that approach with the Giants defense, if it's playing still at an elite level, you just need someone to keep you in the game, but if Josh Johnson is such an accomplished game manager why didn't QB desperate teams like Denver or Houston with all-world defenses give him a chance.<br />
<br />
I wasn't exaggerating, Josh Johnson has not thrown a regular season NFL game pass in 6 years.  2011 is the last season he threw a pass.  He hasn't been on an NFL active roster since 2013.<br />
<br />
I think you are overrating Josh Johnson.<br />
<br />
<br />
And I agree about Geno, his MO was on full display against the Steelers.  That's what he does.<br />
<br />
Which is why I think the door is open for Webb if he can get some training camp reps.<br />
<br />
My point is if the Giants can't win with Johnson or Smith or Webb, then you keep Webb.<br />
<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>look -- I have found Johnson underwhelming to this point </b><a name="13558890">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=gidiefor"> gidiefor </a> : <b style="background:darkred;color:white;">Mod</b> :  8/13/2017  2:35 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558890">link</a>   </div></div><div class="thread_post_body"> until I took a very close look at the first quarter.  His play was really underrated in the first quarter, and if you add up the miscues he played well enough to win, and well enough to be trusted with the ball.<br />
<br />
If Marshall, OBJ and Sheppard are in the game -- I think you get different results than what happened -- and he used Ellison and Smith very effectively</div></div><div class="thread_post"><div class="thread_post_header"><b>At this point, I'm hoping for 26 defensive players on the initial 53. </b><a name="13558897">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+Blogger"> Big Blue Blogger </a>  :  8/13/2017  2:57 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558897">link</a>   </div></div><div class="thread_post_body"> I think the practice squad can serve as an extension to the offensive side of the roster, because guys like Chad Wheeler, Matt LaCosse, Shane Smith, Darius Powe and Travis Rudolph are unlikely to get claimed off waivers unless they do something notable in the remaining preseason games. If you cut a Devin Taylor or Kerry Wynn, that's it: they are gone for good. Even Owa Odighizuwa, who is subject to waivers, would probably get claimed by a team that liked his college tape. (How many chances has Damontre Moore had?)<br />
<br />
The easiest path to 24 on offense is two QBs; I understand the reluctance there. I wouldn't rule out eight OL, though nine is likely.  And obviously there are a lot of possible permutations in the RB/FB/TE area.</div></div><div class="thread_post"><div class="thread_post_header"><b>I also don't know why you say </b><a name="13558898">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=pjcas18"> pjcas18 </a>  :  8/13/2017  2:58 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558898">link</a>   </div></div><div class="thread_post_body"> Josh Johnson won't turn the ball over.<br />
<br />
In his entire career he has 5 TD's 10 INT and 10 fumbles.  Not exactly a portrait of "taking care of the duke" why do you think he's safer for some reason?<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I also don't know why you say </b><a name="13558899">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=gidiefor"> gidiefor </a> : <b style="background:darkred;color:white;">Mod</b> :  8/13/2017  3:03 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558899">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558898" target="_blank">13558898</a> pjcas18 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Josh Johnson won't turn the ball over.<br />
<br />
In his entire career he has 5 TD's 10 INT and 10 fumbles.  Not exactly a portrait of "taking care of the duke" why do you think he's safer for some reason?<br />
 </td>
                                </tr>
                           </table><br />
<br />
all I'm saying is that on Friday -- he played safer and in a way I trust better than Geno or Webb</div></div><div class="thread_post"><div class="thread_post_header"><b>Johnson absolutely did not keep his cool </b><a name="13558904">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=chopperhatch"> chopperhatch </a>  :  8/13/2017  3:10 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558904">link</a>   </div></div><div class="thread_post_body"> He was frantic in the pocket and start scatting around at the first signs of the pocket shifting. He would look dow field for two reads, run around and MAYBE try and take another peek downfield. But at that point, all his receivers are watching where he was planning to go so they could bblock for him.<br />
<br />
Smith looked more than competent his furst drive. Yes, that was an extraordinarily bad pick he threw. Our starter also happens to do that a ton. Geno is at least decisive and throws a pretty n8ce deep ball. <br />
<br />
Josh Johnson has not thrown an nfl pass since 2011 as pj said....let that sink in for a minute.<br />
<br />
If no improvement is shown by either I am all in favor for just keeping Webb on the roster.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I also don't know why you say </b><a name="13558905">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=pjcas18"> pjcas18 </a>  :  8/13/2017  3:12 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558905">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558899" target="_blank">13558899</a> gidiefor said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13558898 pjcas18 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Josh Johnson won't turn the ball over.<br />
<br />
In his entire career he has 5 TD's 10 INT and 10 fumbles.  Not exactly a portrait of "taking care of the duke" why do you think he's safer for some reason?<br />
 <br />
                                <br />
                           <br />
<br />
all I'm saying is that on Friday -- he played safer and in a way I trust better than Geno or Webb </td>
                                </tr>
                           </table><br />
<br />
Sure, but I was looking for different things from all of them and had different expectations.<br />
<br />
you can say Smith went against the Steeler's 2's or Webb went against guys who will be on practice squads, but conversely Geno played with the Giants 2's and 3's and Webb played with guys who will appear on practice squads.<br />
<br />
So it's all relative.<br />
<br />
All I can tell you is in watching the three QB's Johnson gave me the least confidence he can move the team.  when you say he's a game manager I don't even really know what that means, to me game manager QB's are on teams with great defenses (check) and strong running games (no check) so if that's all Johnson is, he doesn't have a role with the Giants, maybe the Chiefs can sign him to back up Alex Smith.<br />
<br />
Geno looked better, but locked on to his primary receiver almost exclusively (seemed to at least, I don't re-watch pre-season games normally) and turned the ball over, and Webb showed a strong arm, poise that I didn't expect, quick release, and quick decision making.<br />
<br />
Webb reminded me of a young Kerry Collins.  Geno has talent, can the Giants control it?  Johnson should be a camp body until they don't need camp bodies.<br />
<br />
IMO.  I respect yours, but disagree with it.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: At this point, I'm hoping for 26 defensive players on the initial 53. </b><a name="13558907">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Milton"> Milton </a>  :  8/13/2017  3:13 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558907">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558897" target="_blank">13558897</a> Big Blue Blogger said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> If you cut a Devin Taylor or Kerry Wynn, that's it: they are gone for good. </td>
                                </tr>
                           </table>And then they would be stuck with only five DE's, tragedy!<br />
<br />
I think it's more likely they keep 26 offensive players than 26 defensive players. Chad Wheeler and Matt LaCosse are more likely to become future starters in the NFL than whoever would be the 6th DE, 6th LB, or 10th DB.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I also don't know why you say </b><a name="13558908">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=chopperhatch"> chopperhatch </a>  :  8/13/2017  3:14 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558908">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558899" target="_blank">13558899</a> gidiefor said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13558898 pjcas18 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Josh Johnson won't turn the ball over.<br />
<br />
In his entire career he has 5 TD's 10 INT and 10 fumbles.  Not exactly a portrait of "taking care of the duke" why do you think he's safer for some reason?<br />
 <br />
                                <br />
                           <br />
<br />
all I'm saying is that on Friday -- he played safer and in a way I trust better than Geno or Webb </td>
                                </tr>
                           </table><br />
<br />
If by "safer" ypu mean won't go downfield and let the receiver try and make a play and if thats what you want if Eli goes down, then sure.<br />
<br />
I guess if its a game or two against a weak team with a weak D, MAYBE I could see your point. <br />
<br />
But also keep in mimd Geno was playing his first live action in a new system with mostly back ups.<br />
<br />
Either way, I dont think we have seen enough of either.</div></div><div class="thread_post"><div class="thread_post_header"><b>OP pretty much nailed it </b><a name="13558909">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Reale01"> Reale01 </a>  :  8/13/2017  3:14 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558909">link</a>   </div></div><div class="thread_post_body"> Except - Munson at LB<br />
<br />
I would like to see Smith kept and Lacosse on PS<br />
DD over Blake<br />
Trade a DE<br />
Lewis not on team<br />
Pinkins to make team<br />
<br />
Possibly 6 LB, 10 DL, 5 CB and 4 safeties (cut Berle)<br />
LB = Castillas, Kennard, Goodson, Munson, Robinson, Herz<br />
DE = OV, JPP, Okwara, Wynn, Moss, Taylor</div></div><div class="thread_post"><div class="thread_post_header"><b>. </b><a name="13558918">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Ira"> Ira </a>  :  8/13/2017  3:24 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558918">link</a>   </div></div><div class="thread_post_body"> <br />
Geno Smith  <br />
<br />
Shane Smith - Josh Huesman. About equal<br />
<br />
Darius Powe - Good size and speed.  Seems to have learned how to play wr.<br />
<br />
Devin Taylor  <br />
<br />
JT Thomas<br />
<br />
Donte Deyon <br />
<br />
Aldrick Rosas <br />
<br />
Keep three tight ends (the choices are obvious) and a fullback.  Put a te on the practice squad.</div></div><div class="thread_post"><div class="thread_post_header"><b>Johnson didn't get to play  </b><a name="13558921">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ZGiants98"> ZGiants98 </a>  :  8/13/2017  3:27 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558921">link</a>   </div></div><div class="thread_post_body"> "with 1s" either unless you count Marshall for exactly 2 plays.  Odel and Shepard were out.  Seems like both QB got to play with Ellison and Engram. O line is the only difference but the starting o line is a question mark anyway.  <br />
<br />
Playing against the Steelers starting defense, which is generally one of the best defenses in football, is significant IMO.</div></div><div class="thread_post"><div class="thread_post_header"><b>Here's my 53 </b><a name="13558924">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Milton"> Milton </a>  :  8/13/2017  3:33 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558924">link</a>   </div></div><div class="thread_post_body"> Eli, Geno, Webb<br />
Perkins, Gallman, Darkwa, Vereen, Smith (FB)<br />
OBJ, Marshall, Shepard, Harris, Rudolph<br />
Ellison, Engram, LaCosse, Adams<br />
Flowers, Pugh, Richburg, Jerry, Hart, Fluker, Jones, Wheeler, Bisnowaty<br />
JPP, Vernon, Okwara, Wynn, Moss<br />
Harrison, Bromley, Thomas, Tomlinson<br />
Casillas, Goodson, Kennard, Robinson, Herzlich, Munson<br />
Collins, Thompson, Adams, Berhe<br />
Jenkins, Apple, DRC, Hunter, Blake<br />
Wing, Rosas, DeOssie<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Now that Im looking... </b><a name="13558936">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ZGiants98"> ZGiants98 </a>  :  8/13/2017  3:46 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558936">link</a>   </div></div><div class="thread_post_body"> I dont think Munson makes it...<br />
<br />
My 53<br />
<br />
Eli, Geno, Webb<br />
Perkins, Gallman, Darkwa, Vereen, Smith (FB)<br />
OBJ, Marshall, Shepard, Harris, King, Powe<br />
Ellison, Engram, LaCosse, Adams<br />
Flowers, Pugh, Richburg, Jerry, Hart, Fluker, Jones, Bisnowaty<br />
JPP, Vernon, Okwara, Wynn, Moss, Taylor<br />
Harrison, Bromley, Thomas, Tomlinson<br />
Casillas, Goodson, Kennard, Robinson, Herzlich<br />
Collins, Thompson, Adams, Berhe<br />
Jenkins, Apple, DRC, Hunter, Deyon<br />
Wing, Rosas, DeOssie<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I've just studied the first Quarter --  </b><a name="13558938">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=djm"> djm </a>  :  8/13/2017  3:49 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558938">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558831" target="_blank">13558831</a> gidiefor said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I don't think Josh Johnson was all that bad -- </td>
                                </tr>
                           </table><br />
<br />
I think much is being made for a few bad mistakes in the first preseason game. I can all but guarantee the Giants aren't saying bye bye birdie to Johnson just yet despite BBI saying bye bye birdie.<br />
<br />
Plus, Geno got worse as the game progressed. I also don't understand bbi's hope that geno wins the job. He scares the shit out of me. He should scare the shit out of everyone. If he makes it good for him but I'd rather not see him playing football in big moments here.</div></div><div class="thread_post"><div class="thread_post_header"><b>Rooting for </b><a name="13558941">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BlackburnBalledOut"> BlackburnBalledOut </a>  :  8/13/2017  3:53 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558941">link</a>   </div></div><div class="thread_post_body"> Geno (yikes) over Johnson-- Johnsons's performance the other night was possibly the worst qb play ive ever seen.<br />
<br />
Darkwa over Draughn & Abdullah---Always been a Darkwa fan, runs hard, falls forward. Draughn is hurt and Abdullah sucked in scrub time. <br />
<br />
Smith at FB<br />
<br />
Lewis Jr to get cut.Anyone over him. <br />
<br />
Adams and Lacosse for the 3&4? TE spot<br />
<br />
Wynn to be the DL rotational guy (DT/DE)<br />
<br />
Tomlinson to start over Bromley. Id like them to have Wynn at DT and not waste a roster spot on Thomas. <br />
<br />
Deayon or someone else over Blake<br />
<br />
Im actually rooting for Andrew Adams to start over Darian Thompson. Adams earned it last year, even if he doesnt "start" they wont be able to keep him off the field. I want Thompson to play but I think Adams has shown more, to this point.  <br />
<br />
Rosas over Nugent just bc id like to have a long(er) term solution at K<br />
<br />
<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I would love for them to only keep Webb behind Eli at QB </b><a name="13558956">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=shockeyisthebest8056"> shockeyisthebest8056 </a>  :  8/13/2017  4:14 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558956">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558874" target="_blank">13558874</a> Lawrence_Taylor_56 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Johnson and Smith likely bounce around as 3rd QBs or FAs most of the season. If Eli goes down you can find one of them on the waiver wire is my guess. </td>
                                </tr>
                           </table><br />
<br />
Me too.  I'd rather use that roster spot to hold onto our collection of DEs or TEs.  But that depends on them giving Webb a legitimate shot to impress.  I have zero faith in Johnson or Smith winning a game or 2 if (GOD forbid) Eli was out for a short time, even with our defense.  In addition, I doubt these guys would get any offers outside of teams trying to ply info from them.</div></div><div class="thread_post"><div class="thread_post_header"><b>Berhe </b><a name="13558958">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=XBRONX"> XBRONX </a>  :  8/13/2017  4:16 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558958">link</a>   </div></div><div class="thread_post_body"> based on what? Injury prone and stinks in coverage.</div></div><div class="thread_post"><div class="thread_post_header"><b>Webb didn't even get reps today </b><a name="13558961">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ZGiants98"> ZGiants98 </a>  :  8/13/2017  4:18 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558961">link</a>   </div></div><div class="thread_post_body"> in practice.  There is no chance in a million years they are rolling with him as the only backup QB.  It's just not happening.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Berhe </b><a name="13558963">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Milton"> Milton </a>  :  8/13/2017  4:21 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558963">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558958" target="_blank">13558958</a> XBRONX said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> based on what? Injury prone and stinks in coverage. </td>
                                </tr>
                           </table>Based on lack of competition. Safety could be a position in which we add a veteran cut from another team. Same thing goes for the 6th LB and 5th CB. If I were a betting man, I would bet that at least one of the 53 to make the final roster will be someone who is not on the 90-man roster today.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Webb didn't even get reps today </b><a name="13558971">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=shockeyisthebest8056"> shockeyisthebest8056 </a>  :  8/13/2017  4:28 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558971">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558961" target="_blank">13558961</a> ZGiants98 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> in practice.  There is no chance in a million years they are rolling with him as the only backup QB.  It's just not happening. </td>
                                </tr>
                           </table><br />
<br />
I don't disagree with what you're saying... they're obviously not giving Webb a legitimate chance to compete.  It's just that neither of these guys (Johnson or Geno) is Matt Hasselback or Jon Kitna.  Holding a roster spot for a guy who can't reasonably be expected to win a game isn't optimal roster usage.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I've just studied the first Quarter --  </b><a name="13558980">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Larry+in+Pencilvania"> Larry in Pencilvania </a>  :  8/13/2017  4:39 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558980">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558831" target="_blank">13558831</a> gidiefor said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I don't think Josh Johnson was all that bad -- </td>
                                </tr>
                           </table><br />
<br />
Want to borrow my glasses? Fail</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Webb didn't even get reps today </b><a name="13558983">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ZGiants98"> ZGiants98 </a>  :  8/13/2017  4:42 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558983">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558971" target="_blank">13558971</a> shockeyisthebest8056 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13558961 ZGiants98 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     in practice.  There is no chance in a million years they are rolling with him as the only backup QB.  It's just not happening. <br />
                                <br />
                           <br />
<br />
I don't disagree with what you're saying... they're obviously not giving Webb a legitimate chance to compete.  It's just that neither of these guys (Johnson or Geno) is Matt Hasselback or Jon Kitna.  Holding a roster spot for a guy who can't reasonably be expected to win a game isn't optimal roster usage. </td>
                                </tr>
                           </table><br />
<br />
Yup.  I still think there is an advantage of having a vet though.  If Eli is lost for the year, we are done.  However, if Eli gets a high ankle sprain and has to miss a month, I want a veteran that isn't going to have deer in the headlights.  Johnson hasn't played in years.  Geno might be a bit of a gun slinger but I'll still take that over the current options.  Maybe he has a big game or maybe he kills us but at least there is a chance we split those games until Eli returns.</div></div><div class="thread_post"><div class="thread_post_header"><b>Am I the only one who thought Webb's mechanics were awful on Friday? </b><a name="13558990">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Milton"> Milton </a>  :  8/13/2017  4:49 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13558990">link</a>   </div></div><div class="thread_post_body"> He missed an open receiver by a wide margin on his first throw and most of his other throws were off his back foot. At least that's what I was thinking watching it in real time. I haven't revisited it so my memory could be off.</div></div><div class="thread_post"><div class="thread_post_header"><b>My 53 + 10 man PS in ( ) </b><a name="13559002">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GeorgeAdams33"> GeorgeAdams33 </a>  :  8/13/2017  5:16 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559002">link</a>   </div></div><div class="thread_post_body"> Manning, Smith, Webb<br />
<br />
Perkins, Darkwa, Vereen, Gallman, (Abdullah)<br />
<br />
Smith<br />
<br />
Ellison, Engram, Adams, LaCosse, (Thompson)<br />
<br />
Beckham, Marshall, Shepard, King, Harris, Powe, (Johnson)<br />
<br />
Flowers, Pugh, Richburg, Bowie, Fluker, Jones, Bisnowaty, (Gettis), (Wheeler)<br />
<br />
Harrison, Bromley, Thomas, Tomlinson, (Jones)<br />
<br />
JPP, Vernon, Okwara, Moss, Wynn, Taylor, (Williams)<br />
<br />
Casillas, Robinson, Goodson, Kennard, Maponga, Munson, (Skinner)<br />
<br />
Collins, Pinkins <br />
<br />
Adams, Thompson, (Robinson)<br />
<br />
Jenkins, DRC, Apple, Hunter, DD, (Tribune)     <br />
<br />
<br />
Deossie, WIng, Rosas</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Webb didn't even get reps today </b><a name="13559003">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=pjcas18"> pjcas18 </a>  :  8/13/2017  5:22 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559003">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558961" target="_blank">13558961</a> ZGiants98 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> in practice.  There is no chance in a million years they are rolling with him as the only backup QB.  It's just not happening. </td>
                                </tr>
                           </table><br />
<br />
I know, but you said who are we rooting for, backup QB was the only area I had a disagreement, unlikely, but best case IMO.<br />
<br />
I hate 3 QBs on the roster.<br />
<br />
It's often been said of Belichick's patriots that roster spots 1 - 22 are comparable to other teams but 23 - 53 is where he wins.  Because he can coach.<br />
<br />
I hate to give up the potential Matthew McCants or Wallace Gillbery's for Geno Smith.<br />
<br />
though, acknowledging the flaws in this argument sometimes the Matthew McCant's or Wallace Gillbery's are Corey Washington or Ramses Barden and get held too long.<br />
<br />
so it's not a strong feeling, just my preference.</div></div><div class="thread_post"><div class="thread_post_header"><b>George... </b><a name="13559004">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ZGiants98"> ZGiants98 </a>  :  8/13/2017  5:23 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559004">link</a>   </div></div><div class="thread_post_body"> You have Jerry and Hart missing from your roster.  Not happening.  Agree with most of the rest though.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Webb didn't even get reps today </b><a name="13559005">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ZGiants98"> ZGiants98 </a>  :  8/13/2017  5:24 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559005">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13559003" target="_blank">13559003</a> pjcas18 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13558961 ZGiants98 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     in practice.  There is no chance in a million years they are rolling with him as the only backup QB.  It's just not happening. <br />
                                <br />
                           <br />
<br />
I know, but you said who are we rooting for, backup QB was the only area I had a disagreement, unlikely, but best case IMO.<br />
<br />
I hate 3 QBs on the roster.<br />
<br />
It's often been said of Belichick's patriots that roster spots 1 - 22 are comparable to other teams but 23 - 53 is where he wins.  Because he can coach.<br />
<br />
I hate to give up the potential Matthew McCants or Wallace Gillbery's for Geno Smith.<br />
<br />
though, acknowledging the flaws in this argument sometimes the Matthew McCant's or Wallace Gillbery's are Corey Washington or Ramses Barden and get held too long.<br />
<br />
so it's not a strong feeling, just my preference. </td>
                                </tr>
                           </table><br />
<br />
I gotcha. I mostly agree as well.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: The Geno Smith you saw </b><a name="13559007">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  :  8/13/2017  5:26 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559007">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558873" target="_blank">13558873</a> gidiefor said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> is the Geno Smith you get -- he did the same stuff with the Jets -- brilliant for a period then throws the ball up for grabs and the game proceeds to get out of control.<br />
<br />
Johnson had a few bad plays -- but he did enough to get a TD and a field goal in his 1 and a half quarters and made no major game changing mistakes<br />
<br />
Johnson is a much better game manager right now than either Smith or Davis -- Davis was not under center by the way for one snap -- he's a work in progress.  Right now you can not turn the team over to him -- you only do that if Eli's career is over. </td>
                                </tr>
                           </table><br />
<br />
Um, how do you know that was Geno's fault? To me, it very easily could have been that the WR ran the wrong route. It looked like it was suppose to be a comeback of some sort but the receiver ran deep.</div></div><div class="thread_post"><div class="thread_post_header"><b>I am rooting for a trade </b><a name="13559009">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Steve+in+South+Jersey"> Steve in South Jersey </a>  :  8/13/2017  5:29 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559009">link</a>   </div></div><div class="thread_post_body"> I don't feel good about the RB behind this OL.  If a better RB can make it work then I would pursue a trade.  Doubt they could trade for an OL that would be more than depth this year.  A trade for a safety maybe.  Feel good about the team as a whole.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Am I the only one who thought Webb's mechanics were awful on Friday? </b><a name="13559015">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  :  8/13/2017  5:34 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559015">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558990" target="_blank">13558990</a> Milton said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> He missed an open receiver by a wide margin on his first throw and most of his other throws were off his back foot. At least that's what I was thinking watching it in real time. I haven't revisited it so my memory could be off. </td>
                                </tr>
                           </table><br />
<br />
Milton, it was his first real life NFL game experience. You can tell he was trying to get a feel out there especially on his first play. He settled down and was hitting his spots. I was impressed with how he battled back. Can you really be critical of a rookie on his first attempt ever after barely getting any reps in practice? Nobody is saying he is great or deserves the number 2 spot. However, what I am saying is that Geno and Josh don't inspire much of anything so why not give the rookie more of a chance?</div></div><div class="thread_post"><div class="thread_post_header"><b>Keep Hart </b><a name="13559019">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GeorgeAdams33"> GeorgeAdams33 </a>  :  8/13/2017  5:38 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559019">link</a>   </div></div><div class="thread_post_body"> Cut Taylor or Wynn</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Keep Hart </b><a name="13559021">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ZGiants98"> ZGiants98 </a>  :  8/13/2017  5:41 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559021">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13559019" target="_blank">13559019</a> GeorgeAdams33 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Cut Taylor or Wynn </td>
                                </tr>
                           </table><br />
<br />
And still no Jerry?  You're missing Herzlich too. Anything's possible but that doesn't sound realistic.</div></div><div class="thread_post"><div class="thread_post_header"><b>Donte Deayon is a curious case </b><a name="13559025">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Milton"> Milton </a>  :  8/13/2017  5:51 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559025">link</a>   </div></div><div class="thread_post_body"> A cornerback's primary job is to cover and Deayon appears to be good at that, especially as regards those quicker, shiftier receivers. But he also needs to support the run and--if he's not a starter--play on special teams. And that's where he is lacking.<br />
<br />
So if you're keeping only five cornerbacks and Deayon is the 5th best cover corner (and maybe even the 4th best when it comes to covering the likes of DeSean Jackson and Cole Beasley) but useless on specials and a liability versus the run, does he make your 53 man roster?<br />
<br />
Disclaimer: This is just a hypothetical based on assorted camp reports. I don't have a strong opinion about the guy one way or another.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I've just studied the first Quarter --  </b><a name="13559030">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  8/13/2017  6:13 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559030">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13558938" target="_blank">13558938</a> djm said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13558831 gidiefor said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     I don't think Josh Johnson was all that bad -- <br />
                                <br />
                           <br />
<br />
I think much is being made for a few bad mistakes in the first preseason game. I can all but guarantee the Giants aren't saying bye bye birdie to Johnson just yet despite BBI saying bye bye birdie.<br />
<br />
Plus, Geno got worse as the game progressed. I also don't understand bbi's hope that geno wins the job. He scares the shit out of me. He should scare the shit out of everyone. If he makes it good for him but I'd rather not see him playing football in big moments here. </td>
                                </tr>
                           </table><br />
<br />
No.  There is no exact science with regards to QB development, but anybody can see Johnson doesn't have the right stuff in the way he commanded the field on plays that required his involvement.  He was panicky, missed open receivers, ran when he need to stay, etc.  Overall lack of poise.  And this isn't a rookie which is why the Giants are staying with him.  <br />
<br />
Move on.  I don't know if Geno or Webb are going to be the guy, but Johnson is not...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Donte Deayon is a curious case </b><a name="13559032">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ZGiants98"> ZGiants98 </a>  :  8/13/2017  6:19 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559032">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13559025" target="_blank">13559025</a> Milton said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> A cornerback's primary job is to cover and Deayon appears to be good at that, especially as regards those quicker, shiftier receivers. But he also needs to support the run and--if he's not a starter--play on special teams. And that's where he is lacking.<br />
<br />
So if you're keeping only five cornerbacks and Deayon is the 5th best cover corner (and maybe even the 4th best when it comes to covering the likes of DeSean Jackson and Cole Beasley) but useless on specials and a liability versus the run, does he make your 53 man roster?<br />
<br />
Disclaimer: This is just a hypothetical based on assorted camp reports. I don't have a strong opinion about the guy one way or another. </td>
                                </tr>
                           </table><br />
<br />
How sure are we he can't play on specials?  He might suck returning the ball but that doesn't mean he can't be a gunner or contribute in other ways.  Harris should return kicks but after him I'm sure there are still many options (Darkwa, King, Gallman, ect.)</div></div><div class="thread_post"><div class="thread_post_header"><b>If Jerry isn't a starter </b><a name="13559036">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GeorgeAdams33"> GeorgeAdams33 </a>  :  8/13/2017  6:27 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559036">link</a>   </div></div><div class="thread_post_body"> I'm in favor of younger back-ups<br />
<br />
As far as DD is concerned I remember a pre-season game at night against the Patriots back in 89' when David Meggett lost two or three punts in the lights and looked like just another wasted 5th round pick.  If not DD then the 5th corner might not be on the roster.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Am I the only one who thought Webb's mechanics were awful on Friday? </b><a name="13559037">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Milton"> Milton </a>  :  8/13/2017  6:28 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559037">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13559015" target="_blank">13559015</a> robbieballs2003 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13558990 Milton said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                    <span class="italics"> He missed an open receiver by a wide margin on his first throw and most of his other throws were off his back foot. At least that's what I was thinking watching it in real time. I haven't revisited it so my memory could be off</span>. <br />
                                <br />
                           <br />
<br />
Milton, it was his first real life NFL game experience. You can tell he was trying to get a feel out there especially on his first play. He settled down and was hitting his spots. I was impressed with how he battled back. Can you really be critical of a rookie on his first attempt ever after barely getting any reps in practice? Nobody is saying he is great or deserves the number 2 spot. However, what I am saying is that Geno and Josh don't inspire much of anything so why not give the rookie more of a chance? </td>
                                </tr>
                           </table>I agree with you for the most part, particularly when it comes to Geno and Josh; and it's not like I came away discouraged by Webb's performance. There's a lot to like. But I think mechanics and accuracy were two issues pointed out in pre-draft scouting reports. I think the Giants have made the decision that what's best for his development is to spend a year focused almost solely on improving his mechanics. It's as if they're going out of their way to send the message to the media and fans: don't even think about Webb being anything more than the 3rd string QB. They will sell no wine before its time.</div></div><div class="thread_post"><div class="thread_post_header"><b>Accuracy problem? </b><a name="13559048">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=XBRONX"> XBRONX </a>  :  8/13/2017  6:45 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559048">link</a>   </div></div><div class="thread_post_body"> He was at almost 62% completion rate last year. I know he is not Colt Brennan</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Donte Deayon is a curious case </b><a name="13559051">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Steve+in+South+Jersey"> Steve in South Jersey </a>  :  8/13/2017  6:51 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559051">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13559032" target="_blank">13559032</a> ZGiants98 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13559025 Milton said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     A cornerback's primary job is to cover and Deayon appears to be good at that, especially as regards those quicker, shiftier receivers. But he also needs to support the run and--if he's not a starter--play on special teams. And that's where he is lacking.<br />
<br />
So if you're keeping only five cornerbacks and Deayon is the 5th best cover corner (and maybe even the 4th best when it comes to covering the likes of DeSean Jackson and Cole Beasley) but useless on specials and a liability versus the run, does he make your 53 man roster?<br />
<br />
Disclaimer: This is just a hypothetical based on assorted camp reports. I don't have a strong opinion about the guy one way or another. <br />
                                <br />
                           <br />
<br />
How sure are we he can't play on specials?  He might suck returning the ball but that doesn't mean he can't be a gunner or contribute in other ways.  Harris should return kicks but after him I'm sure there are still many options (Darkwa, King, Gallman, ect.) </td>
                                </tr>
                           </table><br />
<br />
Can he be a gunner at his size?  I have concerns about that but maybe other players his size have made it work.  I think he has to be a returner or he won't contribute to special teams.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Donte Deayon is a curious case </b><a name="13559052">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Milton"> Milton </a>  :  8/13/2017  6:51 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559052">link</a>   </div></div><div class="thread_post_body"> In comment <a href="index.php?mode=2&thread=555540&show_all=1#13559032" target="_blank">13559032</a> ZGiants98 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 13559025 Milton said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                  <span class="italics">   A cornerback's primary job is to cover and Deayon appears to be good at that, especially as regards those quicker, shiftier receivers. But he also needs to support the run and--if he's not a starter--play on special teams. And that's where he is lacking.<br />
<br />
So if you're keeping only five cornerbacks and Deayon is the 5th best cover corner (and maybe even the 4th best when it comes to covering the likes of DeSean Jackson and Cole Beasley) but useless on specials and a liability versus the run, does he make your 53 man roster?<br />
<br />
Disclaimer: This is just a hypothetical based on assorted camp reports. I don't have a strong opinion about the guy one way or another.</span> <br />
                                <br />
                           <br />
<br />
How sure are we he can't play on specials?  He might suck returning the ball but that doesn't mean he can't be a gunner or contribute in other ways. </td>
                                </tr>
                           </table>I'm not sure at all. I'm guessing his size makes him less than ideal even for a gunner, but I could easily be wrong.</div></div><div class="thread_post"><div class="thread_post_header"><b>I might be in the minority </b><a name="13559056">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jay+on+the+Island"> Jay on the Island </a>  :  8/13/2017  7:05 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559056">link</a>   </div></div><div class="thread_post_body"> but I don't want to keep a FB.  I want the Giants to keep 4 TE's and preferably 9 offensive linemen.  Ellison, Adams, LaCosse, and Engram can all line up in the backfield as an H-back and serve as the lead blocker in the run game while also creating more problems for defenses having to account for a player who is a threat in the receiving game.  Imagine a defense having to contend with Engram at Hback with Adams or Ellison at TE with Beckham, Marshall, and Shepard at WR.  Engram would often be lined up versus a linebacker which is a clear mismatch.</div></div><div class="thread_post"><div class="thread_post_header"><b>Could Giants afford to carry Donte Deayon as a healthy scratch </b><a name="13559063">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Steve+in+South+Jersey"> Steve in South Jersey </a>  :  8/13/2017  7:12 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559063">link</a>   </div></div><div class="thread_post_body"> not dressing for a game unless DRC is injured or if playing a dangerous small & quick slot receiver.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Could Giants afford to carry Donte Deayon as a healthy scratch </b><a name="13559070">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+Blogger"> Big Blue Blogger </a>  :  8/13/2017  7:24 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559070">link</a>   </div></div><div class="thread_post_body"> Steve in South Jersey said:<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> not dressing for a game unless DRC is injured or if playing a dangerous small & quick slot receiver. </td>
                                </tr>
                           </table>Yes.  If they don't need the fifth CB to contribute on specials (e.g. if both gunners are WRs, etc.), he can be a coverage specialist who only dresses when needed on defense.  On the other hand, why use a roster spot on Deayon in that scenario?  He will almost certainly clear waivers, and he provides just as much utility on the practice squad as he would as a healthy scratch.</div></div><div class="thread_post"><div class="thread_post_header"><b>As a QB you have to find the open receiver </b><a name="13559085">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Giant+John"> Giant John </a>  :  8/13/2017  7:46 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559085">link</a>   </div></div><div class="thread_post_body"> It appeared Josh was not able to do that. He was critiqued for being bad with his check downs and after watching him I agree. Don't think he deserves to be on the team based on what I saw of his play. He missed a lot of open receivers.</div></div><div class="thread_post"><div class="thread_post_header"><b>D.Deyon </b><a name="13559110">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=annexOPR"> annexOPR </a>  :  8/13/2017  8:22 pm   : <a href="index.php?mode=2&thread=555540&show_all=1#13559110">link</a>   </div></div><div class="thread_post_body"> can play - and would be an ideal 4/5th corner<br />
<br />
Rosas at kicker ... huge leg, looked great Friday, and let's just lock in a kicker for the next decade instead of watching solid young kickers go to Denver/Pitt for "solid vets"<br />
<br />
Worried about kicking the FG? Score a f'ing TD and its irrelevant.</div></div><a name="END"><a href="index.php"><div style="padding-top:25px; padding-bottom:20px;"><img src="/images/back_corner.gif" width="150" height="23" alt="Back to the Corner" border="0"></a></div></a><div id="ad_side_box">
<div style="height:260px;width:300px;margin:auto;">

<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id="usmg_ad_nfl.general_football_sports_300x250_1a">
<script type='text/javascript'>
googletag.defineSlot('/7103/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250]], 'usmg_ad_nfl.general_football_sports_300x250_1a').addService(googletag.pubads());
googletag.enableServices();
googletag.display('usmg_ad_nfl.general_football_sports_300x250_1a');
</script>
</div>

</div>
<div style="height:260px;width:300px;margin-auto;">

<!-- BEGIN Google Adsense CODE -->

<script type="text/javascript"><!--
google_ad_client = "ca-pub-1566320450447229";
/* Corner Forum - Lower 300x250 Box */
google_ad_slot = "3213469993";
google_ad_width = 300;
google_ad_height = 250;
//-->
</script>
<script type="text/javascript"
src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>

<!-- END Google Adsense CODE -->


</div>
</div>




<div class="footer">


<p style="width:400px;float:left;"><b>Part of the USA Today Sports Media Group</b><br>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</P>
<P  style="width:400px;float:right; text-align:right;">
All contents (unless otherwise specified) copyright &copy;  1995 - 2017<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Support</a>
</P>
<br clear="all">
<div style="float:right;">
<script
    src="https://sucuri.net/monitoring/badge.js"
    data-s="19"
    id="sucuri-s"
    data-i="7b1b29ae50ae6574f2af3875935246e4fa8a805b26"
    data-p="o" - position - l(left) or r(right) or o(relative)
    data-c="l"
    data-t="t"
    ></script>
</div>

</div>


<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->

</body>
</html>
