<!DOCTYPE html>
<html lang="en">
<head><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=function(){var u=[],i="/porpoiseant/army.gif";function t(e,i,t,_,d,o,n){if(__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var r=parseInt(__ez.dot.getTargeting(e,"ap")),a=__ez.dot.getSlotIID(e),s=__ez.dot.getAdUnit(e),p=parseInt(__ez.dot.getTargeting(e,"compid")),z=0,f=0,g=function(e){if("undefined"==typeof _ezim_d)return!1;var i=__ez.dot.getAdUnitPath(e).split("/").pop();if("object"==typeof _ezim_d&&_ezim_d.hasOwnProperty(i))return _ezim_d[i];for(var t in _ezim_d)if(t.split("/").pop()===i)return _ezim_d[t];return!1}(e);"object"==typeof g&&(void 0!==g.creative_id&&(f=g.creative_id),void 0!==g.line_item_id&&(z=g.line_item_id)),__ez.dot.isDefined(a,s)&&__ez.dot.isValid(i)&&u.push({type:"impression",impression_id:a,domain_id:__ez.dot.getDID(),unit:s,t_epoch:__ez.dot.getEpoch(0),revenue:t,est_revenue:_,ad_position:r,ad_size:"",bid_floor_filled:d,bid_floor_prev:o,stat_source_id:n,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:p,line_item_id:z,creative_id:f,data:__ez.dot.dataToStr(i)})}}function _(){if(void 0===document.visibilityState||"prerender"!==document.visibilityState){if(__ez.dot.isDefined(u)&&0<u.length){var e=__ez.dot.getURL(i)+"?orig="+(!0===__ez.template.isOrig?1:0)+"&sts="+btoa(JSON.stringify(u));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(e+="&visit_uuid="+_ezaq.visit_uuid),(new Image).src=e}u=[]}}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),_()},AddById:function(e,i){var t=e.split("/");if(__ez.dot.isDefined(e)&&3===t.length&&__ez.dot.isValid(i)){var _=t[0],d=t[2];u.push({type:"impression",impression_id:d,domain_id:__ez.dot.getDID(),unit:_,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(i)})}},Fire:_,GetPixels:function(){return u}}}();var EzoicPixel=function(){this.pixels=[],this.pixelUrl="/ezoic/e.gif",("undefined"!=typeof ezJsu&&!0===ezJsu||"undefined"!=typeof _ez_sa&&!0===_ez_sa||void 0!==window.isAmp&&!0===isAmp||"undefined"!=typeof ezWp&&!0===ezWp)&&(this.pixelUrl="//g.ezoic.net"+this.pixelUrl),this.tEpoch=0,"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("t_epoch")&&(this.tEpoch=_ezaq.t_epoch)},EzoicPixelData=function(e,i){this.name=e,this.val=i};EzoicPixel.prototype={constructor:EzoicPixel,AddAndFireImpPixel:function(e,i){this.AddImpPixel(e,i,0,0,0,0,0),this.FirePixels()},AddAndFirePVPixel:function(e,i){this.AddPVPixel(e,i),this.FirePixels()},AddImpPixel:function(e,i,t,n,o,a,d){if(0!=__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var s=parseInt(__ez.dot.getTargeting(e,"ap")),r=__ez.dot.getSizes(e)[0],_=r.l.toString()+"x"+r.j.toString(),p="0",l="XX";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(p=_ezaq.domain_id.toString()),"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("country")&&(l=_ezaq.country);var h=__ez.dot.getSlotIID(e),c=__ez.dot.getSlotElementId(e);__ez.dot.isDefined(h,c)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:h,domain_id:p,unit:c,t_epoch:this.tEpoch,revenue:t,est_revenue:n,ad_position:s,ad_size:_,bid_floor_filled:o,bid_floor_prev:a,stat_source_id:d,country_code:l,data:i}))}},AddImpPixelById:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString());var n=e.split("/");if(__ez.dot.isDefined(e)&&3===n.length&&this.validateData(i)){var o=n[0],a=n[2];i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:a,domain_id:t,unit:o,t_epoch:this.tEpoch,data:i})}},AddPVPixel:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString()),__ez.dot.isDefined(e)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"pageview",pageview_id:e,domain_id:t,t_epoch:this.tEpoch,data:i}))},FirePixels:function(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(this.pixels)&&0<this.pixels.length&&((new Image).src=this.pixelUrl+"?orig="+(!0===__ez.template.isOrig?1:0)+"&pixels="+encodeURIComponent(JSON.stringify(this.pixels))),this.pixels=[])},NewData:function(e,i){return new EzoicPixelData(e,i)},convertDataToStr:function(e){if(void 0===e)return[];try{for(var i in e)e[i].val=e[i].val+""}catch(e){}return e},validateData:function(e){for(var i=0;i<e.length;i++)if(e[i]instanceof EzoicPixelData==!1)return console.error("Invalid pixelData. ",e[i]),!1;return!0}};</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">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</script>
<title>Giants: Alternative Approach to Free Agency | Big Blue Interactive </title>


<meta name="keywords" content="ndglbqfkxx">

<meta name="description" content="They've got tons of cap space so they will use it. But is it wise to do so? Here's an alternative approach: (1) Spend very little (if any) and preserve their cap space for the future; (2) Rely almost exclusively on the Draft and allow young players to grow up with one another in the locker room and on the field; (3) There's a significant benefit to foregoing the additional wins this season brought about by adding high end free agents: future high Draft selections; (4) Once the team has a solid core in place (2022?), and is knocking on the playoff door, THEN blow the big bucks on high-performing free agents. (5) But to bring them in this season, won't build the base we need for the long term."/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="website" />
<meta property="og:description" content="They've got tons of cap space so they will use it. But is it wise to do so? Here's an alternative approach: (1) Spend very little (if any) and preserve their cap space for the future; (2) Rely almost exclusively on the Draft and allow young players to grow up with one another in the locker room and on the field; (3) There's a significant benefit to foregoing the additional wins this season brought about by adding high end free agents: future high Draft selections; (4) Once the team has a solid core in place (2022?), and is knocking on the playoff door, THEN blow the big bucks on high-performing free agents. (5) But to bring them in this season, won't build the base we need for the long term." /> 
<meta property="og:title" content="Giants: Alternative Approach to Free Agency" /> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif" /> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css?v=20200217" />

<link rel="stylesheet" type="text/css" href="anylink.css" />


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}


div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" alt="for display only">

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type='text/javascript'>
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type='text/javascript' src='https://img.bnqt.com/lib/js/sdpdfphelper.js'></script>
<script type='text/javascript'>
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>


<!-- End DFP SETUP -->  

<!-- End USA Today Code -->





<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-131124163-7";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-131124163-7']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'bigblueinteractive.com']);
_gaq.push(['f._setDomainName', 'bigblueinteractive.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod95',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','bigblueinteractive.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://corner.bigblueinteractive.com/index.php?mode=2&thread=595508&show_all=1"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"e89021e4-0d22-4703-5e43-1df1c2e4e47f","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":316,"serverid":"34.232.64.253:8725","state":"VA","t_epoch":1583686157,"template_id":126,"time_on_site_visit":0,"url":"https://corner.bigblueinteractive.com/index.php?mode=2\u0026thread=595508\u0026show_all=1","user_id":0,"word_count":5838,"worst_bad_word_level":1};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=188-0&v=8" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|e89021e4-0d22-4703-5e43-1df1c2e4e47f|false; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head>


<body>




<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"></a> <img src="images/xpete.gif" alt="The Corner Forum">

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic -->&nbsp;


<!-- Nov 2019 Leaderboard -->

<!-- Ezoic - Forum Leaderboard (USAT) - top_of_page -->
<div id="ezoic-pub-ad-placeholder-118">
<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->
<div id='usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general'>
     <script type='text/javascript'>
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general');
         });
     </script>
</div>
</div>
<!-- End Ezoic - Forum Leaderboard (USAT) - top_of_page -->



</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://www.shareasale.com/r.cfm?b=277504&u=723646&m=29078&urllink=&afftrack=">Apparel</a>
<a href="http://www.amazon.com/?_encoding=UTF8&camp=1789&creative=9325&linkCode=ur2&tag=bigblueintera-20">Amazon.com</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW" >Standings (NFL.com)</a>
<a href="http://www.nfl.com/teams/newyorkgiants/statistics?team=NYG" target="_NEW" >Statistics (NFL.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/" >Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'home_view_menu')">Home</a>  
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'forum_view_menu')">Corner Forum</a>
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'gameday_view_menu')">Gameday</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_view_menu')">Team</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_building_view_menu')">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info &amp; History</a> -->
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_info_view_menu')">Giants Info &amp; History</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'infolinks_view_menu')">Info/Links</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'shop_view_menu')">BBI Shop</a>
<li><a href="/index.php?mode=10" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'login_menu')">Log In</a>
</ul>

</div><div id="infoline"> </div>

<a name="END"><a href="index.php"><div style="padding-top:20px; padding-bottom:25px;"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"></a></div></a><div class="thread_container"><div class="thread_left"><div class="thread_body" ><div class="thread_main" ><div class="thread_post_header" >  <h1 style="font-size:18px;">Giants: Alternative Approach to Free Agency </h1><div class="thread_info"><a href="index.php?mode=5&handle=M.S."> M.S. </a>  :  3/7/2020  7:26 am</div></div><div class="thread_post_body" > They've got tons of cap space so they will use it.<br />
<br />
But is it wise to do so?<br />
<br />
Here's an alternative approach:<br />
<br />
(1) Spend very little (if any) and preserve their cap space for the future;<br />
<br />
(2) Rely almost exclusively on the Draft and allow young players to grow up with one another in the locker room and on the field;<br />
<br />
(3) There's a significant benefit to foregoing the additional wins this season brought about by adding high end free agents: future high Draft selections;<br />
<br />
(4) Once the team has a solid core in place (2022?), and is knocking on the playoff door, THEN blow the big bucks on high-performing free agents.<br />
<br />
(5) But to bring them in this season, won't build the base we need for the long term. </div></div></div></div><div class="thread_right"><div id="ad_side_box">


<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id='usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general'>
     <script type='text/javascript'>
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general');
         });
     </script>
</div>




</div></div><div class="thread_comment_container"><div class="thread_post"><div class="thread_post_header"><b>Sounds great in theory </b><a name="14828655">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=UConn4523"> UConn4523 </a>  :  3/7/2020  7:32 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828655">link</a>   </div></div><div class="thread_post_body">but you’ve got an entire franchise that wants to win again as fast as possible and they are going to need to draft wisely and spend wisely in order to do so.<br />
<br />
Why can’t we spend money now and in 2022? If we don’t spend now is it not possible we are in this same position in 2022?<br />
<br />
Spend wisely, the rest is just noise.</div></div><div class="thread_post"><div class="thread_post_header"><b>Don’t the teams have to spend a minimum amount on players  </b><a name="14828656">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Judgment+Day"> Judgment Day </a>  :  3/7/2020  7:35 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828656">link</a>   </div></div><div class="thread_post_body">Each year per the cba?</div></div><div class="thread_post"><div class="thread_post_header"><b>Many here say we’re at least a year or two away (I don’t agree). </b><a name="14828657">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+%2756"> Big Blue '56 </a>  :  3/7/2020  7:35 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828657">link</a>   </div></div><div class="thread_post_body">Yet, Pay for and bring in higher priced guys in their 30s. Contenders do that. According to many here, we’re not contenders.<br />
<br />
Spend on FAs who are young if you really covet them. Big contract details are up to Abrams. Draft well. Not Rocket science</div></div><div class="thread_post"><div class="thread_post_header"><b>Who running the Giants think this </b><a name="14828658">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=George+from+PA"> George from PA </a>  :  3/7/2020  7:36 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828658">link</a>   </div></div><div class="thread_post_body">(3) There's a significant benefit to foregoing the additional wins this season brought about by adding high end free agents: future high Draft selections;<br />
<br />
Is a good idea?<br />
<br />
Answer: no one<br />
<br />
The Giants will do what they think is best for Giants.<br />
<br />
Also, with new cba pending....one could argue to draft as many FA this year.....as they will all be "bargains" after the addition in cap with new cba.</div></div><div class="thread_post"><div class="thread_post_header"><b>Gettleman wants to save his job.... </b><a name="14828659">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GFAN52"> GFAN52 </a>  :  3/7/2020  7:36 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828659">link</a>   </div></div><div class="thread_post_body">he'll spend freely.</div></div><div class="thread_post"><div class="thread_post_header"><b>You can’t buy draft picks. This team needs more quality players than </b><a name="14828660">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Ivan15"> Ivan15 </a>  :  3/7/2020  7:38 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828660">link</a>   </div></div><div class="thread_post_body">can be acquired in a draft. The talent gap has to be filled with free agents.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Don’t the teams have to spend a minimum amount on players  </b><a name="14828661">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=DonQuixote"> DonQuixote </a>  :  3/7/2020  7:38 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828661">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828656" target="_blank">14828656</a> Judgment Day said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Each year per the cba? </td>
                                </tr>
                           </table><br />
<br />
Yes I think it’s 88.8% of the cap. You can’t just bank salaries.</div></div><div class="thread_post"><div class="thread_post_header"><b>I think the Alternate approach is to bypass </b><a name="14828663">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ZogZerg"> ZogZerg </a>  :  3/7/2020  7:40 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828663">link</a>   </div></div><div class="thread_post_body">the top tier FAs and grab some mid tier guys to address Roster needs.  Or maybe grab ONE top tier guy, as long as he is still "young".<br />
<br />
I don't want the Giants going after multiple "top tier" (expensive) FAs this year.  Look what it did for the Jets last year.  They spent like drunken sailors and sucked.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I think the Alternate approach is to bypass </b><a name="14828669">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LakeGeorgeGiant"> LakeGeorgeGiant </a>  :  3/7/2020  7:49 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828669">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828663" target="_blank">14828663</a> ZogZerg said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> the top tier FAs and grab some mid tier guys to address Roster needs.  Or maybe grab ONE top tier guy, as long as he is still "young".<br />
<br />
I don't want the Giants going after multiple "top tier" (expensive) FAs this year.  Look what it did for the Jets last year.  They spent like drunken sailors and sucked.<br />
 </td>
                                </tr>
                           </table><br />
<br />
This is probably the best approach for any team with cap space.<br />
<br />
I'm ok with one big contract guy, but choose wisely.<br />
<br />
<br />
<br />
Also, there is no such thing as "3 years away" in this league. That's defeatist nonsense. The right players in the right roles and some improved coaching can make this team competitive, then you look for the next step.</div></div><div class="thread_post"><div class="thread_post_header"><b>I should say </b><a name="14828670">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LakeGeorgeGiant"> LakeGeorgeGiant </a>  :  3/7/2020  7:51 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828670">link</a>   </div></div><div class="thread_post_body">a few of the right players</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I should say </b><a name="14828674">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+%2756"> Big Blue '56 </a>  :  3/7/2020  7:59 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828674">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828670" target="_blank">14828670</a> LakeGeorgeGiant said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> a few of the right players </td>
                                </tr>
                           </table><br />
<br />
We’re on the same page re turnarounds</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I should say </b><a name="14828675">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=M.S."> M.S. </a>  :  3/7/2020  8:01 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828675">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828670" target="_blank">14828670</a> LakeGeorgeGiant said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> a few of the right players </td>
                                </tr>
                           </table><br />
Kinda feels like more than 3 years away:<br />
<br />
2013: 7-9<br />
2014: 6-10<br />
2015: 6-10<br />
2016: 11-5<br />
2017: 3-13<br />
2018: 5-11<br />
2019: 4-12</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I should say </b><a name="14828676">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+%2756"> Big Blue '56 </a>  :  3/7/2020  8:04 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828676">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828675" target="_blank">14828675</a> M.S. said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14828670 LakeGeorgeGiant said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     a few of the right players <br />
                                <br />
                           <br />
Kinda feels like more than 3 years away:<br />
<br />
2013: 7-9<br />
2014: 6-10<br />
2015: 6-10<br />
2016: 11-5<br />
2017: 3-13<br />
2018: 5-11<br />
2019: 4-12 </td>
                                </tr>
                           </table><br />
<br />
New regime. Hopefully we finally hit the jackpot.</div></div><div class="thread_post"><div class="thread_post_header"><b>So we will field the same OL as last year? </b><a name="14828691">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BillT"> BillT </a>  :  3/7/2020  8:47 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828691">link</a>   </div></div><div class="thread_post_body">Minus Remmers and maybe minus Halapio.  Good plan.</div></div><div class="thread_post"><div class="thread_post_header"><b>One or two years away? </b><a name="14828695">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  :  3/7/2020  8:50 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828695">link</a>   </div></div><div class="thread_post_body">Maybe in dog years.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: So we will field the same OL as last year? </b><a name="14828706">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=M.S."> M.S. </a>  :  3/7/2020  8:57 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828706">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828691" target="_blank">14828691</a> BillT said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Minus Remmers and maybe minus Halapio.  Good plan. </td>
                                </tr>
                           </table><br />
If nothing else, I sure hope Halapio is not our Center. Maybe this year's draft choice in Round two?</div></div><div class="thread_post"><div class="thread_post_header"><b>So just continue losing games for the next year or two </b><a name="14828707">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Mike+from+Ohio"> Mike from Ohio </a>  :  3/7/2020  8:57 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828707">link</a>   </div></div><div class="thread_post_body">While young guys get experience, and then splurge for a run?  I can’t think of a worse plan, unless it is just to lose forever.<br />
<br />
While it is lovely to imagine this multi-year rebuild done primarily with draft picks, this is still a results oriented business.  This organization has played losing football for years now.  Any plan that extends that - by design - is a non-starter.  Build smartly, yes, but this team needs to start showing improvement in the W-L column now.  It is also not feasible to start dropping money on FA players at the same time Jones and Barkley are reaching the end of their rookie deals.<br />
<br />
I am not suggesting signing guys for a run this year.  But the goal needs to be to put a much better team on the field in 2020, not 2022.</div></div><div class="thread_post"><div class="thread_post_header"><b>BB56 post above </b><a name="14828710">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  :  3/7/2020  9:00 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828710">link</a>   </div></div><div class="thread_post_body">is it.</div></div><div class="thread_post"><div class="thread_post_header"><b>The FA class this year looks deep </b><a name="14828717">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Danny+Dimes"> Danny Dimes </a>  :  3/7/2020  9:10 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828717">link</a>   </div></div><div class="thread_post_body">Theres like at least 10+ quality pass rushers. Im liking the idea of getting two pass rushers for 10-15mill each verses one for 23mill. Having depth is just better especially if one gets injured</div></div><div class="thread_post"><div class="thread_post_header"><b>Then what happens in 2023? </b><a name="14828719">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=sems"> sems </a>  :  3/7/2020  9:11 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828719">link</a>   </div></div><div class="thread_post_body">You know, we have to re-sign draft picks at some point...</div></div><div class="thread_post"><div class="thread_post_header"><b>I’d like to see them win </b><a name="14828727">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GiantsRage2007"> GiantsRage2007 </a>  :  3/7/2020  9:23 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828727">link</a>   </div></div><div class="thread_post_body">We have $$. Spend it. Try to win.</div></div><div class="thread_post"><div class="thread_post_header"><b>Target young free agents but don't over spend </b><a name="14828730">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Ira"> Ira </a>  :  3/7/2020  9:26 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828730">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I think the Alternate approach is to bypass </b><a name="14828737">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=micky"> micky </a>  :  3/7/2020  9:36 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828737">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828669" target="_blank">14828669</a> LakeGeorgeGiant said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14828663 ZogZerg said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     the top tier FAs and grab some mid tier guys to address Roster needs.  Or maybe grab ONE top tier guy, as long as he is still "young".<br />
<br />
I don't want the Giants going after multiple "top tier" (expensive) FAs this year.  Look what it did for the Jets last year.  They spent like drunken sailors and sucked.<br />
 <br />
                                <br />
                           <br />
<br />
This is probably the best approach for any team with cap space.<br />
<br />
I'm ok with one big contract guy, but choose wisely.<br />
<br />
<br />
<br />
Also, there is no such thing as "3 years away" in this league. That's defeatist nonsense. The right players in the right roles and some improved coaching can make this team competitive, then you look for the next step. </td>
                                </tr>
                           </table><br />
<br />
"No three years away" and how many years have the giants been?? Lol..ok</div></div><div class="thread_post"><div class="thread_post_header"><b>It doesn’t make sense not to spend on rookie qb contract </b><a name="14828738">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=aGiantGuy"> aGiantGuy </a>  :  3/7/2020  9:37 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828738">link</a>   </div></div><div class="thread_post_body">That 2016 team had everything it needed to make a run besides a slot corner and a true tailback, it wasn’t a bad approach.<br />
It’s hard enough to win in the NFL, you don’t hamstring yourself by essentially bowing out of free agency. <br />
The Rams were big spenders and got to the bowl, 49ers were big spenders and got to the bowl. If you wanna take the Green Bay approach and only field home grown talent... well even Aaron Rodgers isn’t good enough to reward that philosophy with a Super Bowl.</div></div><div class="thread_post"><div class="thread_post_header"><b>They are going to spend </b><a name="14828751">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=MeadowlandsMike"> MeadowlandsMike </a>  :  3/7/2020  9:52 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828751">link</a>   </div></div><div class="thread_post_body">Unless the get Knicks'd in Free Agency</div></div><div class="thread_post"><div class="thread_post_header"><b>Hate the idea. Think it's awful  </b><a name="14828765">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=giantstock"> giantstock </a>  :  3/7/2020  10:01 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828765">link</a>   </div></div><div class="thread_post_body">The acceptance that it is okay to lose is just plain awful. Glad to read most on here think the OP's suggestion is a terrible idea. The OP has just been worn down by the losing and is now okay with it. Sad frankly for a fan.  <br />
<br />
Then the poster should add -- "Trade Barkley" too.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I think the Alternate approach is to bypass </b><a name="14828769">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BigBlueDownTheShore"> BigBlueDownTheShore </a>  :  3/7/2020  10:10 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828769">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828663" target="_blank">14828663</a> ZogZerg said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> the top tier FAs and grab some mid tier guys to address Roster needs.  Or maybe grab ONE top tier guy, as long as he is still "young".<br />
<br />
I don't want the Giants going after multiple "top tier" (expensive) FAs this year.  Look what it did for the Jets last year.  They spent like drunken sailors and sucked.<br />
 </td>
                                </tr>
                           </table><br />
<br />
I’m fine with this approach.  Don’t hand out the largest FA contracts ever ala Solder.  Spend wisely.</div></div><div class="thread_post"><div class="thread_post_header"><b>Giants are in trouble </b><a name="14828773">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Lines+of+Scrimmage"> Lines of Scrimmage </a>  :  3/7/2020  10:13 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828773">link</a>   </div></div><div class="thread_post_body">if Judge does not expect to compete for the Division.<br />
<br />
Eagles:  Aging team, always hurt WR's, DL not what is was, weak secondary, QB can't stay healthy with many fans against him....<br />
<br />
Dallas:  The myth of a powerhouse with a new coach who already seems like Jerry is working him over with decisions.  OL while good has several members who have a scary injury background.  Can Dak carry them if the running game faulters?<br />
<br />
Washington:  Mess in the secondary, QB who is a unknown, old running back and one who can't stay healthy, New Coach.<br />
<br />
I hope they spend but spend smartly.  Good draft, couple FA additions, better coaching, development of young players and big improvement from Jones....why not the Giants?</div></div><div class="thread_post"><div class="thread_post_header"><b>Giants are going to spend for Judge. </b><a name="14828775">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=MeadowlandsMike"> MeadowlandsMike </a>  :  3/7/2020  10:14 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828775">link</a>   </div></div><div class="thread_post_body">23 mill invested on D right now. Thats crazy. That's going to shift. <br />
<br />
<br />
Rough take on what we could see:<br />
<br />
<br />
Van Noy 8 Mill AAV (4.5 Mill cap hit 2020)<br />
Jones 18 Mill AAV (12 mill cap hit 2020)<br />
LW 16 Mill AAV (10 mill cap 2020)<br />
Golden 15 Mill AAV (9 mill cap 2020)<br />
Vet FS (Love maybe slotted for this so I dont know if we go top tier) 8 mill (4 mill 2020 hit)<br />
<br />
39.5 mill total 2020 cap hit for Defense<br />
<br />
74 Mill (Bethea 2.75+ Ellison 5) = 81.75 Mill available - 39.5 on D = 42.25 left to spend not counting Solder's likely paycut (which he publicly said he'd take to remain here)<br />
<br />
*Cap expected to take a sizeable jump with CBA teams may try to backload slightly more with more guaranteed money upfront.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Giants are going to spend for Judge. </b><a name="14828782">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jon+in+NYC"> Jon in NYC </a>  :  3/7/2020  10:27 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828782">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828775" target="_blank">14828775</a> MeadowlandsMike said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> 23 mill invested on D right now. Thats crazy. That's going to shift. <br />
<br />
<br />
Rough take on what we could see:<br />
<br />
<br />
Van Noy 8 Mill AAV (4.5 Mill cap hit 2020)<br />
Jones 18 Mill AAV (12 mill cap hit 2020)<br />
LW 16 Mill AAV (10 mill cap 2020)<br />
Golden 15 Mill AAV (9 mill cap 2020)<br />
Vet FS (Love maybe slotted for this so I dont know if we go top tier) 8 mill (4 mill 2020 hit)<br />
<br />
39.5 mill total 2020 cap hit for Defense<br />
<br />
74 Mill (Bethea 2.75+ Ellison 5) = 81.75 Mill available - 39.5 on D = 42.25 left to spend not counting Solder's likely paycut (which he publicly said he'd take to remain here)<br />
<br />
*Cap expected to take a sizeable jump with CBA teams may try to backload slightly more with more guaranteed money upfront. </td>
                                </tr>
                           </table><br />
<br />
I like this all except for Golden. 15 mil for a player on the back end of his career with really 2 good seasons and one major injury in between seems like a poor allocation of resources.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: So just continue losing games for the next year or two </b><a name="14828787">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+%2756"> Big Blue '56 </a>  :  3/7/2020  10:30 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828787">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828707" target="_blank">14828707</a> Mike from Ohio said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> While young guys get experience, and then splurge for a run?  I can’t think of a worse plan, unless it is just to lose forever.<br />
<br />
While it is lovely to imagine this multi-year rebuild done primarily with draft picks, this is still a results oriented business.  This organization has played losing football for years now.  Any plan that extends that - by design - is a non-starter.  Build smartly, yes, but this team needs to start showing improvement in the W-L column now.  It is also not feasible to start dropping money on FA players at the same time Jones and Barkley are reaching the end of their rookie deals.<br />
<br />
I am not suggesting signing guys for a run this year.  But the goal needs to be to put a much better team on the field in 2020, not 2022. </td>
                                </tr>
                           </table><br />
<br />
Certainly nothing wrong with this line of thinking. I just don’t want to waste cap space on aging vets unless it’s near the vet minimum or <br />
slightly above</div></div><div class="thread_post"><div class="thread_post_header"><b>An aging vet is only “wasted cap space” </b><a name="14828793">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=UConn4523"> UConn4523 </a>  :  3/7/2020  10:42 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828793">link</a>   </div></div><div class="thread_post_body">if they don’t live up to the contract handed to them. Nothing wrong with signing vets even when you aren’t yet a contender.<br />
<br />
We need to get better. Playing better leads to good things happening. There’s no reason not to bring in good players right now. Sure, don’t give $22m out to Yannick, but we absolutely need to spend money.</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="14828797">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=christian"> christian </a>  :  3/7/2020  10:43 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828797">link</a>   </div></div><div class="thread_post_body">Players who were drafted are only "better" for the 3-5 years they are cheap. After that, it's total nonsense to value them over free agents.<br />
<br />
If you let a guy walk because you replace him with a better player or you use that money to upgrade a different position, that's great.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: An aging vet is only “wasted cap space” </b><a name="14828801">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+%2756"> Big Blue '56 </a>  :  3/7/2020  10:46 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828801">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828793" target="_blank">14828793</a> UConn4523 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> if they don’t live up to the contract handed to them. Nothing wrong with signing vets even when you aren’t yet a contender.<br />
<br />
We need to get better. Playing better leads to good things happening. There’s no reason not to bring in good players right now. Sure, don’t give $22m out to Yannick, but we absolutely need to spend money. </td>
                                </tr>
                           </table><br />
<br />
So what’s an acceptable age to spend bigger bucks on? 28? Fine. 32? Not so fine</div></div><div class="thread_post"><div class="thread_post_header"><b>hilary's two rules </b><a name="14828802">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Hilary"> Hilary </a>  :  3/7/2020  10:46 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828802">link</a>   </div></div><div class="thread_post_body">good young players such as Van Noy (mentioned in another post) at a fair price.<br />
<br />
Old guys such as Jason Peter's or Sean Lee on one year contracts that do make next year or the year after more difficult to manage.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Hate the idea. Think it's awful  </b><a name="14828805">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=M.S."> M.S. </a>  :  3/7/2020  10:47 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828805">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828765" target="_blank">14828765</a> giantstock said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> The acceptance that it is okay to lose is just plain awful. Glad to read most on here think the OP's suggestion is a terrible idea. The OP has just been worn down by the losing and is now okay with it. Sad frankly for a fan.  <br />
<br />
Then the poster should add -- "Trade Barkley" too. </td>
                                </tr>
                           </table><br />
<br />
For what it's worth (zero), I was against the Saquon Barkley pick at #2, but now that this fantastic running back is on our team, he's definitely one of the young players (not to mention a major building block) to build around.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: hilary's two rules </b><a name="14828806">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+%2756"> Big Blue '56 </a>  :  3/7/2020  10:48 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828806">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828802" target="_blank">14828802</a> Hilary said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> good young players such as Van Noy (mentioned in another post) at a fair price.<br />
<br />
Old guys such as Jason Peter's or Sean Lee on one year contracts that do make next year or the year after more difficult to manage. </td>
                                </tr>
                           </table><br />
<br />
Even at 1 year, both those guys are damaged goods at this point. Do we really expect Sean Lee to play most of the season reasonably healthy?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: An aging vet is only “wasted cap space” </b><a name="14828815">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=christian"> christian </a>  :  3/7/2020  10:52 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828815">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828801" target="_blank">14828801</a> Big Blue '56 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">So what’s an acceptable age to spend bigger bucks on? 28? Fine. 32? Not so fine </td>
                                </tr>
                           </table><br />
<br />
I'd argue it's more important base it off 1) number of years in the league 2) the number of injuries incurred projected to impact medium term health.<br />
<br />
If a player has 4-5 in the league and has avoided structural injuries, that's probably the sweet spot.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: An aging vet is only “wasted cap space” </b><a name="14828817">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+%2756"> Big Blue '56 </a>  :  3/7/2020  10:56 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828817">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828815" target="_blank">14828815</a> christian said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14828801 Big Blue '56 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                    So what’s an acceptable age to spend bigger bucks on? 28? Fine. 32? Not so fine <br />
                                <br />
                           <br />
<br />
I'd argue it's more important base it off 1) number of years in the league 2) the number of injuries incurred projected to impact medium term health.<br />
<br />
If a player has 4-5 in the league and has avoided structural injuries, that's probably the sweet spot. </td>
                                </tr>
                           </table><br />
<br />
I’m in</div></div><div class="thread_post"><div class="thread_post_header"><b>Can’t they do both? </b><a name="14828826">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Philu916"> Philu916 </a>  :  3/7/2020  11:05 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828826">link</a>   </div></div><div class="thread_post_body">Give Byron Jones 4-5 years, sign Peters on a 1 year deal that may be a little cheaper, and maybe 3-4 year deal for a Martinez type?</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="14828827">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=christian"> christian </a>  :  3/7/2020  11:06 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828827">link</a>   </div></div><div class="thread_post_body">One interesting data point I'd be after if I worked in data for the Giants -- what impact do college years have on the body and the downstream effect on pro career length.<br />
<br />
You take a guy like Eli Apple, he's got 6 total years of college and pro football on his body. He's also just 24. <br />
<br />
If his maturity level increases, he's the kind of guy I could see having a really nice middle to his career.</div></div><div class="thread_post"><div class="thread_post_header"><b>I’m not big on drawing arbitrary lines in the sand </b><a name="14828845">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=UConn4523"> UConn4523 </a>  :  3/7/2020  11:30 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828845">link</a>   </div></div><div class="thread_post_body">yes, most of the time I won’t want to pay big money to a 32 year old but there’s always exceptions. We also don’t even know what these guys will be signing for so saying “nope, too old” doesn’t make any sense.<br />
<br />
We should spend wisely, that’s the only thing that matters.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: An aging vet is only “wasted cap space” </b><a name="14828849">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=UConn4523"> UConn4523 </a>  :  3/7/2020  11:32 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828849">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828817" target="_blank">14828817</a> Big Blue '56 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14828815 christian said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     In comment 14828801 Big Blue '56 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                    So what’s an acceptable age to spend bigger bucks on? 28? Fine. 32? Not so fine <br />
                                <br />
                           <br />
<br />
I'd argue it's more important base it off 1) number of years in the league 2) the number of injuries incurred projected to impact medium term health.<br />
<br />
If a player has 4-5 in the league and has avoided structural injuries, that's probably the sweet spot. <br />
                                <br />
                           <br />
<br />
I’m in </td>
                                </tr>
                           </table><br />
<br />
And everyone else will be in too - these guys are rare. So usually it’s on to plan B and C, that’s where GMs swim or sink.</div></div><div class="thread_post"><div class="thread_post_header"><b>No </b><a name="14828854">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=djm"> djm </a>  :  3/7/2020  11:37 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828854">link</a>   </div></div><div class="thread_post_body">We’ve been building through the draft for 3 straight years now. Wtf are some of you waiting for? The perfect time to strike? By 2020 the young core won’t be young anymore and half this place won’t wan to spend money to re-sign those 26 year olds.<br />
<br />
Just spend money on the right players. Build a winning team. You’re over thinking things.</div></div><div class="thread_post"><div class="thread_post_header"><b>By 2022 the young core won’t be so young  </b><a name="14828855">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=djm"> djm </a>  :  3/7/2020  11:40 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828855">link</a>   </div></div><div class="thread_post_body">..<br />
<br />
And I swear some of you just refuse to acknowledge any history with positive results. You only remember the bad contracts and even then there’s a slanted POV. <br />
<br />
The Oliver Vernon and jackrabbit contracts didn’t sink this franchise in 2017-2018 more than poor coaching and leadership and prior draft mistakes did. <br />
<br />
There’s an epidemic on BBI and it isn’t fucking corona. It’s a fear of paying players and it has reached levels for ridiculousness.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Giants are going to spend for Judge. </b><a name="14828856">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=MeadowlandsMike"> MeadowlandsMike </a>  :  3/7/2020  11:40 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828856">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828782" target="_blank">14828782</a> Jon in NYC said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14828775 MeadowlandsMike said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     23 mill invested on D right now. Thats crazy. That's going to shift. <br />
<br />
<br />
Rough take on what we could see:<br />
<br />
<br />
Van Noy 8 Mill AAV (4.5 Mill cap hit 2020)<br />
Jones 18 Mill AAV (12 mill cap hit 2020)<br />
LW 16 Mill AAV (10 mill cap 2020)<br />
Golden 15 Mill AAV (9 mill cap 2020)<br />
Vet FS (Love maybe slotted for this so I dont know if we go top tier) 8 mill (4 mill 2020 hit)<br />
<br />
39.5 mill total 2020 cap hit for Defense<br />
<br />
74 Mill (Bethea 2.75+ Ellison 5) = 81.75 Mill available - 39.5 on D = 42.25 left to spend not counting Solder's likely paycut (which he publicly said he'd take to remain here)<br />
<br />
*Cap expected to take a sizeable jump with CBA teams may try to backload slightly more with more guaranteed money upfront. <br />
                                <br />
                           <br />
<br />
I like this all except for Golden. 15 mil for a player on the back end of his career with really 2 good seasons and one major injury in between seems like a poor allocation of resources. </td>
                                </tr>
                           </table><br />
<br />
Personally I think Golden's coming back. Still young, fully recovered from injury,a known quantity to the organization. Should continue to be a double digit sack guy.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Gettleman wants to save his job.... </b><a name="14828859">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=djm"> djm </a>  :  3/7/2020  11:45 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828859">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828659" target="_blank">14828659</a> GFAN52 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> he'll spend freely. </td>
                                </tr>
                           </table><br />
<br />
Probably untrue. This is the same guy that traded every vet worth a shit for future young assets and drafted a young QB that he knew would draw heat.<br />
<br />
Reese was another story. I don’t think DG is in that same class despite what the reports might indicate.</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="14828860">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=christian"> christian </a>  :  3/7/2020  11:45 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828860">link</a>   </div></div><div class="thread_post_body">This is where a value index is so important.<br />
<br />
The top tier should command the highest resources, and then the curve decreases downward in compensation from there.<br />
<br />
The top tier is a rare commodity -- young, experienced, healthy, productive, available. Those are the guys you should set the market for. In my view the only time you should break that rule is if you have a need and project to be in a window to compete for a championship.</div></div><div class="thread_post"><div class="thread_post_header"><b>I keep saying it  </b><a name="14828866">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=djm"> djm </a>  :  3/7/2020  11:52 am   : <a href="index.php?mode=2&thread=595508&show_all=1#14828866">link</a>   </div></div><div class="thread_post_body">But this all or nothing mentality by fans lately is tough to take and will ultimately leave those fans disappointed in the end. Super bowl title team or bust. Either he excellent or don’t bother. Be elite or might as well be on the bottom building with high draft picks. There’s nothing worse then being “pretty good with no shot to win” — yeah, that’s bullshit. Why? Because the only want to become great is to become good. You need to build. Learn to walk before flying and really, I’m sorry, but I’d kill for a pretty fun and consistent 9-10 win team, sort of like the titans, and hope we can break through one year, like WE did in the 2000s, twice.<br />
<br />
I get wanted super bowl titles or bust, but it’s a pie in the sky belief. We need to win 9 games again. Let’s try that first.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Gettleman wants to save his job.... </b><a name="14828882">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GFAN52"> GFAN52 </a>  :  3/7/2020  12:16 pm   : <a href="index.php?mode=2&thread=595508&show_all=1#14828882">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828859" target="_blank">14828859</a> djm said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14828659 GFAN52 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     he'll spend freely. <br />
                                <br />
                           <br />
<br />
Probably untrue. This is the same guy that traded every vet worth a shit for future young assets and drafted a young QB that he knew would draw heat.<br />
<br />
Reese was another story. I don’t think DG is in that same class despite what the reports might indicate. </td>
                                </tr>
                           </table><br />
<br />
Drafting in the top 5 three years in a row would probably put his job in jeopardy.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Giants are going to spend for Judge. </b><a name="14828884">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Rjanyg"> Rjanyg </a>  :  3/7/2020  12:23 pm   : <a href="index.php?mode=2&thread=595508&show_all=1#14828884">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828775" target="_blank">14828775</a> MeadowlandsMike said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> 23 mill invested on D right now. Thats crazy. That's going to shift. <br />
<br />
<br />
Rough take on what we could see:<br />
<br />
<br />
Van Noy 8 Mill AAV (4.5 Mill cap hit 2020)<br />
Jones 18 Mill AAV (12 mill cap hit 2020)<br />
LW 16 Mill AAV (10 mill cap 2020)<br />
Golden 15 Mill AAV (9 mill cap 2020)<br />
Vet FS (Love maybe slotted for this so I dont know if we go top tier) 8 mill (4 mill 2020 hit)<br />
<br />
39.5 mill total 2020 cap hit for Defense<br />
<br />
74 Mill (Bethea 2.75+ Ellison 5) = 81.75 Mill available - 39.5 on D = 42.25 left to spend not counting Solder's likely paycut (which he publicly said he'd take to remain here)<br />
<br />
*Cap expected to take a sizeable jump with CBA teams may try to backload slightly more with more guaranteed money upfront. </td>
                                </tr>
                           </table><br />
<br />
Sub out Fowler for Golden, for offense sign McGovern and Williams at RT and that would be a hell of an off season.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Sounds great in theory </b><a name="14828890">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=WillVAB"> WillVAB </a>  :  3/7/2020  12:28 pm   : <a href="index.php?mode=2&thread=595508&show_all=1#14828890">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828655" target="_blank">14828655</a> UConn4523 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> but you’ve got an entire franchise that wants to win again as fast as possible and they are going to need to draft wisely and spend wisely in order to do so.<br />
<br />
Why can’t we spend money now and in 2022? If we don’t spend now is it not possible we are in this same position in 2022?<br />
<br />
Spend wisely, the rest is just noise. </td>
                                </tr>
                           </table><br />
<br />
This.  Doesn’t matter if the Giants spend on 1 player or 6 players.  Just get quality producers.  Don’t spend just to spend.</div></div><div class="thread_post"><div class="thread_post_header"><b>Contender status </b><a name="14828892">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=mittenedman"> mittenedman </a>  :  3/7/2020  12:38 pm   : <a href="index.php?mode=2&thread=595508&show_all=1#14828892">link</a>   </div></div><div class="thread_post_body">Much rides on Jones. I've been a big supporter but he needs to take a step forward this year or it won't be good enough. <br />
<br />
How good Jones is will largely determine whether the Giants are a contender or not. He is a tireless worker who cares a lot about the game. Let's see what happens here.<br />
<br />
If Jones steps up, cleans up the mistakes and begins to cement himself as a top shelf QB, a cavalry of good UFA's could make us an interesting team right away. A la 2016.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Gettleman wants to save his job.... </b><a name="14828900">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  :  3/7/2020  1:02 pm   : <a href="index.php?mode=2&thread=595508&show_all=1#14828900">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828859" target="_blank">14828859</a> djm said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14828659 GFAN52 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     he'll spend freely. <br />
                                <br />
                           <br />
<br />
Probably untrue. This is the same guy that traded every vet worth a shit for future young assets and drafted a young QB that he knew would draw heat.<br />
<br />
Reese was another story. I don’t think DG is in that same class despite what the reports might indicate. </td>
                                </tr>
                           </table><br />
<br />
Those vets and Eli performed about the same as the young assets and QB.  Hopefully that decision wasn't to hard on him to see.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I think the Alternate approach is to bypass </b><a name="14828904">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=TommyWiseau"> TommyWiseau </a>  :  3/7/2020  1:21 pm   : <a href="index.php?mode=2&thread=595508&show_all=1#14828904">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828663" target="_blank">14828663</a> ZogZerg said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> the top tier FAs and grab some mid tier guys to address Roster needs.  Or maybe grab ONE top tier guy, as long as he is still "young".<br />
<br />
I don't want the Giants going after multiple "top tier" (expensive) FAs this year.  Look what it did for the Jets last year.  They spent like drunken sailors and sucked.<br />
 </td>
                                </tr>
                           </table><br />
<br />
We have been doing that and it has not worked. Bethea, Kareem Martin, Omameh etc. Build your depth through the draft (cheap depth) and hopefully hit on a few players. Sign a top tier guy or two, someone who will produce</div></div><div class="thread_post"><div class="thread_post_header"><b>Sigh- when you are bad  </b><a name="14828908">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Dave+on+the+UWS"> Dave on the UWS </a>  :  3/7/2020  1:23 pm   : <a href="index.php?mode=2&thread=595508&show_all=1#14828908">link</a>   </div></div><div class="thread_post_body">it’s because your drafting sucked. So, you have to spend more on FA to plug holes. Using the draft this way, is how perpetual losing teams stay losing. To break the cycle, you have to make better FA choices. The NFL stands for “not for long”. You can’t build a team just on the draft when you stink. Also, everyone here has to understand that Judge’s evaluation on this roster will be very different than ours. There’s a LOT of talent on this roster, NOT a lot of complete players. If they do what they are Intending, and utilize ALL the skills on the roster, this team will be better than expected.</div></div><div class="thread_post"><div class="thread_post_header"><b>'future high Draft selections' </b><a name="14828910">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Torrag"> Torrag </a>  :  3/7/2020  1:28 pm   : <a href="index.php?mode=2&thread=595508&show_all=1#14828910">link</a>   </div></div><div class="thread_post_body">Bwahahahaha we just had the 2nd, 6th and 4th overall in consecutive Drafts. That's rare suckitude. I think it's time to actually sign Tier 1 or at least tier 2 Free Agents. Not the business as usual bottom feeding we typically get.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: 'future high Draft selections' </b><a name="14828916">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=TommyWiseau"> TommyWiseau </a>  :  3/7/2020  1:37 pm   : <a href="index.php?mode=2&thread=595508&show_all=1#14828916">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828910" target="_blank">14828910</a> Torrag said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Bwahahahaha we just had the 2nd, 6th and 4th overall in consecutive Drafts. That's rare suckitude. I think it's time to actually sign Tier 1 or at least tier 2 Free Agents. Not the business as usual bottom feeding we typically get. </td>
                                </tr>
                           </table><br />
<br />
Agreed. And we finally have the money to do so</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Hate the idea. Think it's awful  </b><a name="14828918">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=giantstock"> giantstock </a>  :  3/7/2020  1:39 pm   : <a href="index.php?mode=2&thread=595508&show_all=1#14828918">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828805" target="_blank">14828805</a> M.S. said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14828765 giantstock said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     The acceptance that it is okay to lose is just plain awful. Glad to read most on here think the OP's suggestion is a terrible idea. The OP has just been worn down by the losing and is now okay with it. Sad frankly for a fan.  <br />
<br />
Then the poster should add -- "Trade Barkley" too. <br />
                                <br />
                           <br />
<br />
For what it's worth (zero), I was against the Saquon Barkley pick at #2, but now that this fantastic running back is on our team, he's definitely one of the young players (not to mention a major building block) to build around. </td>
                                </tr>
                           </table><br />
<br />
In 2022 when you are projecting "winning time" - it will be Barkley's 5th year in the NFL. How long do you expect him to be a peak player and for the 1st 4 years what good is he if you aren't trying to win.</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="14828924">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=christian"> christian </a>  :  3/7/2020  1:58 pm   : <a href="index.php?mode=2&thread=595508&show_all=1#14828924">link</a>   </div></div><div class="thread_post_body">The Giants have been bad at acquiring talent -- both in the draft and free agency. They've also had bad coaching. That's how you lose double digit games in 5 of 6 seasons.<br />
<br />
All facets of their program need to improve. Hopefully Judge is a better coach than Coughlin at the end, MacAdoo, and Shurmur.<br />
<br />
Hopefully several of the draft picks from 2018 and 2019 materialize into good players. Hopefully the the acquisitions in UFA this year can play up to their contracts and be good players.<br />
<br />
The problems with the Giants have been deep and broad. There aren't simple solutions.</div></div><div class="thread_post"><div class="thread_post_header"><b>Get a medley of short-long, mid-high price range guys </b><a name="14828929">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Coach+Red+Beaulieu"> Coach Red Beaulieu </a>  :  3/7/2020  2:12 pm   : <a href="index.php?mode=2&thread=595508&show_all=1#14828929">link</a>   </div></div><div class="thread_post_body">so contracts come off the cap year by year.  Even overpaying a guy for a short term/franchise tag is ok.  You don't win anything by having a lot of cap space.<br />
<br />
Don't sign a bunch of players to high long term contracts like Reese, that's mistake number 1 for a GM.</div></div><div class="thread_post"><div class="thread_post_header"><b>Bad Team Can Turn It Around Quickly </b><a name="14829028">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Samiam"> Samiam </a>  :  3/7/2020  5:25 pm   : <a href="index.php?mode=2&thread=595508&show_all=1#14829028">link</a>   </div></div><div class="thread_post_body">I question whether a team with a coach who has never been a HC before can, and more importantly, I don’t think with Gettleman running the team can.  I know I’m beating a dead horse here but I can’t understand how a rookie GM (Jets) can fleece an experienced GM who has a bad team in a deep draft.  Gettleman might draft ok.  I’m not convinced after 2 drafts he’s anything to brag about (although last years looks good).  His trades and free agent signings are meh to bad.  I dont want him commits the team to long term contracts; I don’t trust him.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Hate the idea. Think it's awful  </b><a name="14829088">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gman11"> Gman11 </a>  :  3/7/2020  7:48 pm   : <a href="index.php?mode=2&thread=595508&show_all=1#14829088">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=595508&show_all=1#14828765" target="_blank">14828765</a> giantstock said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> The acceptance that it is okay to lose is just plain awful. Glad to read most on here think the OP's suggestion is a terrible idea. The OP has just been worn down by the losing and is now okay with it. Sad frankly for a fan.  <br />
<br />
Then the poster should add -- "Trade Barkley" too. </td>
                                </tr>
                           </table><br />
<br />
Simply ridiculous. Why so called fans would want their team to be bad is pretty goofy.</div></div><a name="END"><a href="index.php"><div style="padding-top:25px; padding-bottom:20px;"><img src="/images/back_corner.gif" class="thread_link"  alt="Back to the Corner" border="0"></a></div></a></div>
<div class="thread_sidebar_2">

<!-- Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-102">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Corner Forum - Lower 300x250 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1566320450447229"
     data-ad-slot="4189314539"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->

</div>

</div>




<div class="footer">


<p style="width:400px;float:left;"><b>Part of the USA Today Sports Media Group</b><br>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</P>
<P  style="width:400px;float:right; text-align:right;">
All contents (unless otherwise specified) copyright &copy;  1995 - 2020<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Solutions</a>
</P>
<br clear="all">
<div style="float:right;">
<script
    src="https://sucuri.net/monitoring/badge.js"
    data-s="19"
    id="sucuri-s"
    data-i="7b1b29ae50ae6574f2af3875935246e4fa8a805b26"
    data-p="o" - position - l(left) or r(right) or o(relative)
    data-c="l"
    data-t="t"
    ></script>
</div>

</div>


<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->

<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=32', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=32', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=188-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'>(function(){function b(g,c){for(var e=0;e<c.length;e++){var d=c[e];if(0==d.complete||"undefined"!=typeof d.readyState&&4>d.readyState){var f=d.getAttribute("src")||d.currentSrc;"undefined"!=typeof d.readyState&&0==d.readyState?d.addEventListener("loadstart",function(h){var k=h.getAttribute("src")||h.currentSrc;window.ezorqs(h,k)}):(f=d.getAttribute("src")||d.currentSrc,window.ezorqs(d,f));d.addEventListener("load",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,
k)});d.addEventListener("loadeddata",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,k)});d.addEventListener("error",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,k)})}}}function a(g){for(var c=0;c<document.styleSheets.length;c++)if(document.styleSheets[c].href==g)return!0;return!1}b("img",document.querySelectorAll("img"));b("video",document.querySelectorAll("video"));b("audio",document.querySelectorAll("audio"));
(function(g){for(var c=0;c<g.length;c++){var e=g[c];if(("preload"==e.getAttribute("rel")||"stylesheet"==e.getAttribute("rel"))&&null!=e.getAttribute("href")&&a(e.getAttribute("href"))){window.ezorqs(e,e.getAttribute("href"));var d=document.createElement("img");d.onerror=function(f){"undefined"!=typeof f.path&&"undefined"!=typeof f.path[0].currentSrc?window.ezorqe(e,f.path[0].currentSrc):"undefined"!=typeof f.srcElement&&"undefined"!=typeof f.srcElement.href&&window.ezorqe(e,f.srcElement.href)};d.src=
e.getAttribute("href")}}})(document.querySelectorAll("link"));"undefined"!=typeof window.__ez.ssaf&&-1<window.__ez.ssaf.indexOf(16)&&"undefined"!==typeof window.__ez.sshsdef&&!1===window.__ez.sshsdef&&Element.prototype.addEventListener&&("function"==typeof window.onload&&(window.addEventListener("load",window.onload),window.onload=null),"function"==typeof document.onload&&(document.addEventListener.addEventListener("load",document.onload),document.onload=null))})();</script></body>
</html>
