<!DOCTYPE html>
<html lang="en">
<head><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=function(){var u=[],i="/porpoiseant/army.gif";function t(e,i,t,_,d,o,n){if(__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var r=parseInt(__ez.dot.getTargeting(e,"ap")),a=__ez.dot.getSlotIID(e),s=__ez.dot.getAdUnit(e),p=parseInt(__ez.dot.getTargeting(e,"compid")),z=0,f=0,g=function(e){if("undefined"==typeof _ezim_d)return!1;var i=__ez.dot.getAdUnitPath(e).split("/").pop();if("object"==typeof _ezim_d&&_ezim_d.hasOwnProperty(i))return _ezim_d[i];for(var t in _ezim_d)if(t.split("/").pop()===i)return _ezim_d[t];return!1}(e);"object"==typeof g&&(void 0!==g.creative_id&&(f=g.creative_id),void 0!==g.line_item_id&&(z=g.line_item_id)),__ez.dot.isDefined(a,s)&&__ez.dot.isValid(i)&&u.push({type:"impression",impression_id:a,domain_id:__ez.dot.getDID(),unit:s,t_epoch:__ez.dot.getEpoch(0),revenue:t,est_revenue:_,ad_position:r,ad_size:"",bid_floor_filled:d,bid_floor_prev:o,stat_source_id:n,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:p,line_item_id:z,creative_id:f,data:__ez.dot.dataToStr(i)})}}function _(){if(void 0===document.visibilityState||"prerender"!==document.visibilityState){if(__ez.dot.isDefined(u)&&0<u.length){var e=__ez.dot.getURL(i)+"?orig="+(!0===__ez.template.isOrig?1:0)+"&sts="+btoa(JSON.stringify(u));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(e+="&visit_uuid="+_ezaq.visit_uuid),(new Image).src=e}u=[]}}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),_()},AddById:function(e,i){var t=e.split("/");if(__ez.dot.isDefined(e)&&3===t.length&&__ez.dot.isValid(i)){var _=t[0],d=t[2];u.push({type:"impression",impression_id:d,domain_id:__ez.dot.getDID(),unit:_,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(i)})}},Fire:_,GetPixels:function(){return u}}}();var EzoicPixel=function(){this.pixels=[],this.pixelUrl="/ezoic/e.gif",("undefined"!=typeof ezJsu&&!0===ezJsu||"undefined"!=typeof _ez_sa&&!0===_ez_sa||void 0!==window.isAmp&&!0===isAmp||"undefined"!=typeof ezWp&&!0===ezWp)&&(this.pixelUrl="//g.ezoic.net"+this.pixelUrl),this.tEpoch=0,"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("t_epoch")&&(this.tEpoch=_ezaq.t_epoch)},EzoicPixelData=function(e,i){this.name=e,this.val=i};EzoicPixel.prototype={constructor:EzoicPixel,AddAndFireImpPixel:function(e,i){this.AddImpPixel(e,i,0,0,0,0,0),this.FirePixels()},AddAndFirePVPixel:function(e,i){this.AddPVPixel(e,i),this.FirePixels()},AddImpPixel:function(e,i,t,n,o,a,d){if(0!=__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var s=parseInt(__ez.dot.getTargeting(e,"ap")),r=__ez.dot.getSizes(e)[0],_=r.l.toString()+"x"+r.j.toString(),p="0",l="XX";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(p=_ezaq.domain_id.toString()),"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("country")&&(l=_ezaq.country);var h=__ez.dot.getSlotIID(e),c=__ez.dot.getSlotElementId(e);__ez.dot.isDefined(h,c)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:h,domain_id:p,unit:c,t_epoch:this.tEpoch,revenue:t,est_revenue:n,ad_position:s,ad_size:_,bid_floor_filled:o,bid_floor_prev:a,stat_source_id:d,country_code:l,data:i}))}},AddImpPixelById:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString());var n=e.split("/");if(__ez.dot.isDefined(e)&&3===n.length&&this.validateData(i)){var o=n[0],a=n[2];i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:a,domain_id:t,unit:o,t_epoch:this.tEpoch,data:i})}},AddPVPixel:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString()),__ez.dot.isDefined(e)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"pageview",pageview_id:e,domain_id:t,t_epoch:this.tEpoch,data:i}))},FirePixels:function(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(this.pixels)&&0<this.pixels.length&&((new Image).src=this.pixelUrl+"?orig="+(!0===__ez.template.isOrig?1:0)+"&pixels="+encodeURIComponent(JSON.stringify(this.pixels))),this.pixels=[])},NewData:function(e,i){return new EzoicPixelData(e,i)},convertDataToStr:function(e){if(void 0===e)return[];try{for(var i in e)e[i].val=e[i].val+""}catch(e){}return e},validateData:function(e){for(var i=0;i<e.length;i++)if(e[i]instanceof EzoicPixelData==!1)return console.error("Invalid pixelData. ",e[i]),!1;return!0}};</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">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</script>
<title>2020 NFL Draft Preview - Offensive Tackle | Big Blue Interactive </title>


<meta name="keywords" content="ndglbqfkxx">

<meta name="description" content="OFFENSIVE TACKLE Format includes a quick position overview, my grading scale and what the number means, the summary and final grade from my final report on my top 15, a quick additional note on the player, and my ranks 16-25 with grades only. *I AM NOT DOING NFL COMPARISONS Quick Position Overview Dave Gettleman got aggressive in 2018, signing Nate Solder from NE to a 4 year  $62 million contract.  It was a move that put former top 10 pick Ereck Flowers at right tackle.  Fast forward two seasons and Flowers is now a guard on the Dolphins after playing the 2019 season with the Redskins and Nate Solder grades out as one of the bottom third left tackles in the game despite having the third highest contract in the league.  One has to assume they will move forward in 2020 with Solder on the left side but his $20.5 Million cap hit next year leads me to the notion he will not be playing for NYG beyond this season. Mike Remmers left for KC in free agency to be a backup, which leaves the right side up to the winner of Nick Gates and the newly signed Cameron Fleming.  Fleming has started 6 games over the past 2 seasons for Dallas and in fact has never started more than 7 games in his career.  Gates saw three starts in 2019 and played both inside and outside.  He showed promise but remember, the bar has been set so low here in regard to the offensive line and Gates would be best suited for a 6th or 7th blocker role.  Chad Slade and Eric Smith are training camp bodies that can compete for a roster spot respectively.  All in, the lack of quality both short term and long term at this position is incredibly weak. GRADING SCALE 90+ All Pro Projection 85+: Pro Bowl Projection
81-84: First rounder – should be able to play right away
79-80: 2nd Rounder – Should be able to rotate right away – Year 2 starter
77-78: 3rd rounder – Should be able to rotate by end of rookie year – Year 2/3 starter
74-76: Early Day 3 – Special Teams – Future backup/possible starter
71-73: Mid Day 3 – Special Teams – Future backup / gamble starter
68-70: Late Day 3 -  Back end of roster / Practice Squad / Development guy
65-67: Preferred UDFA
60-64: Undrafted FA TOP 15 GRADES AND ANALYSIS 1.	Tristan Wirfs / Iowa / 6’5 – 320 Grade: 86 Summary: Junior entry and three year starter from Mount Vernon, Iowa.  After a record setting high school shot put and discuss career, Wirfs stepped in as a starting right and left tackle as a true freshman in 2017.  He settled in on the right side as the Hawkeyes have another future NFL prospect manning the left side, Alaric Jackson.  Wirfs is a physical freak in the weight room and keeping that in mind with his background as a thrower, it was a sight to see as his football skill set and performance started to catch up with his upside in 2019.  The foot-quickness, hand-striking, and easy knee bend gives him the look of a franchise offensive tackle.  There are multiple inconsistencies that remain, however.  He overextends too often and the speed/power combination of NFL edge rushers can eat that up for breakfast if it isn’t fixed.  The just-turned 21 year old has work in front of him to do but if he can correct the very correctable issues, he can be a star. *Another really interesting pre-draft study here that I spent a ton of time on.  Wirfs has shutdown ability.  What I mean by that is no matter what kind of pass rusher he is up against, Wirfs has the physical ability to dominate.  Against power he can anchor, re-anchor, and keep his hands locked inside.  Against pure speed he can beat the defender to the meeting point without losing the width of his feet.  Against quickness, he can adjust inside and out while keeping his hands in the right place and maintaining his knee bend.  All of these skills and tools are there, but the snap to snap consistency isn’t there when it comes to balance and timing.  That is the reason why he doesn’t approach the 90-point mark.  With that said, we are talking about correctable issues here, not physical shortcomings.  Wirfs is a dominant run blocker right now, he can project to both right and left tackle, and he is a week 1 starter on this team.  Because of where the NYG situation resides and because I think we are looking at a Pro Bowl tackle, Wirfs gets my vote for who NYG should take at #4 unless Young somehow falls in to their lap. 2.	Jedrick Wills / Alabama / 6’4 – 312 Grade: 85 Summary: Junior entry from Lexington, Kentucky.  A two-year starter at right tackle that earned 1st Team All SEC and 2nd Team All American honors in 2019.  Wills was the most physical blocker on the Crimson Tide offensive line but also turned heads with his quality, consistent performance as a pass blocker.  It can be hard to locate a true dent in his armor outside of the fact he can get out-reached by longer defenders.  His footwork and hands are as sure as it gets and he plays with an ever-present competitive streak that every team wants in the trenches.  He has the look of a first-year starter that could move inside if the situation he is drafted in to doesn’t initially demand a new face at tackle. *Wills grew on me more and more as the scouting process got under way.  Initially, he doesn’t have the traditional tackle body.  He is a little light in the pants, he is a little short, and there isn’t a great reach-game.  For those reasons I don’t see Gettleman considering him at #4, as he just doesn’t fit the profile.  However, for me, I think Wills is probably the most polished and NFL ready tackle in the group.  If these tackles all start in 2020, I bet Wills has the best rookie season.  While he isn’t a road grader in the running game, he plays with some good fire and he can translate speed in to power.   He will be fine there.  My question long term with him is stoutness against the ends that really bull rush under the blocker’s pads.  All that in mind, I see a David Bakhtiari type tackle here, who is very good. 3.	Andrew Thomas / Georgia / 6’5 – 315 Grade: 83 Summary: Junior entry from Lithonia, Ga.  A three year starter with experience at both tackle positions and a two-time 1st Team All SEC and All American.  Thomas has the tools and more than enough quality tape over three years to sell himself as an elite left tackle prospect.  The issue, however, is the amount of inconsistencies he shows in pass protection when it comes to technique.  He doesn’t maximize those tools and has gotten used to playing catch-up football which will be much more difficult to do against NFL edge players.  Thomas will be a plus-run blocker right away but whatever team ends up with him will need to be patient in his development as a pass blocker. *When I look at who Dave Gettleman has drafted in the past at the offensive tackle position, Thomas looks like that guy.  Big, thick, long-armed and really physical.  He is a really fun player to watch when he’s pissed off.  He moves guys in to another zip code as a run blocker, he really gets after guys in space, and he finishes.  The issues here are two-fold.  His effort isn’t consistent and that is the number one red flag.  In the intense moments, big games…etc Thomas gets after it.  But too many times throughout the past two seasons I saw a guy that simply tried to get by on talent.  The second issue, he looks like a train wreck in pass protection at times.  He struggles to reach his point against speed and he shows his numbers to the ground too often.  While his power and reach can partially make up for it, he simply needs to get better there or he will get eaten alive by the top end pass rushers.  I’ll end with this: Thomas at his absolute best is better than Wirfs and Wills.  But do you want to gamble on his work ethic and lack of athletic ability?  More power to you if you do, but I only want him if it meant NYG traded down and the two guys above were off the board. 4.	Mekhi Becton / Louisville / 6’8 – 364 Grade: 82 Summary: Junior entry and three year starter from Highland Springs, Virginia.  First team All ACC in 2019 as the team’s starting left tackle.  Becton has played on both sides of the line and could project to either in the NFL.  His game very much depends on the elite length and upper body explosion that can take over a one on one battle right away.  Becton is rare physical force that gets movement at both the point of attack and in space the second he comes in contact with the defender.  His issues are partially technique-based which, in theory, can be corrected but there are also movement issues.  It can be hard for a player at his height to adjust with balance and precision and even his length can’t hide those issues in pass protection.  His sometimes-inaccurate hands aren’t backed up by other physical attributes and techniques which gives him a rather large buyer-beware label.  Boom or bust prospect that turns 21 just days prior to the draft. *I don’t expect a guy this big to move like Tyron Smith from DAL, I get it.  Yes, guys with this kind of length and width can get away with movement issues.  Yes, I have been wrong a couple of times in recent years about mammoth tackles.  All that in mind, I am placing a first round grade on Becton but I don’t think he is a top 10 pick for NYG, certainly not the guy I want at 4.  Do I see NYG pursuing him? Sure.  He is huge and explosive, he can be a dominant force in the running game, and he isn’t even 21 years old yet. There are a couple medical red flags that need to check out however.  If a guy that weights 360-380 pounds comes in to the league with any injury red flag, I would be more worried than usual.  Throw in some more red flags centering around his willingness to work and grind, I just don’t want to take the risk but I can see why some wouldn’t mind going for it.  This is a rare specimen that has some quality tape. 5.	Ezra Cleveland / Boise State / 6’6 – 311 Grade: 79 Summary: Fourth year junior from Spanaway, Washington.  A three year starter that earned Honorable Mention All Mountain West honors in 2017, and 1st Team honors in 2018 and 2019 respectively.  Cleveland has a wrestling background and it shows on tape.  His body control and balance are noteworthy, as he never seems to lose his feet and you rarely find him lunging for a defender or wind up on the ground.  His techniques with his hand and feet create the notion that his learning curve in the NFL won’t be as steep as some others.  The question for him will center around length and lockout and whether or not that makes him move inside.  He could likely be a quality backup at both spots and a starter once he adds more strength and power to his arsenal. *A huge part of my offensive tackle evaluation is balance and body control.  If I had to rank which tackle in this class had the best of both, it is Cleveland.  I am not comparing him to Joe Thomas, but that is how he moves.  Just smooth and easy, movement across the line never seems to disrupt his approach.  The issue?  He has short arms, lacks a true power game, and his body may not be ready in year one.  I can’t use a first rounder on someone like that and I don’t think he is in play at #36.  If NYG ends up with an early third or late second somehow, then we can talk. 6.	Josh Jones / Houston / 6’5 – 319 Grade: 79 Summary: Fifth year senior from Richmond, Texas.  A four year starter that earned 2nd Team All AAC honors in 2019.  Jones put together a really solid season and earned an invite to the Senior Bowl where he performed well all week against the stiffest competition he faced.  His length and power game are small red flags but he has the foot speed and techniques that can hide them.  He is a really smooth operator that knows and trusts himself.  He doesn’t over-set like most tackles do, he doesn’t abandon techniques when he doesn’t win the initial battle like most tackles do, and he still has ton of attainable upside to go before he is a finished product.  If he can improve his power game and continue to progress his skill set, he can be a longtime starter in the league.  With that said, he should be thrown in to the fire right away. *I know a scout in the league that has Jones on the same tier as the top tackles in the draft.  While I don’t think that is a common opinion, I’m sure he isn’t the only one.  Jones is a really fluid and easy athlete on the outside that simply needs a key to the weight room.  I do think he can handle snaps right away, but I would prefer to him to wait at least half a season if possible.  Power guys are going to beat him up pretty good.  If he does enhance how own power game, he is a definite starter. 7.	Isaiah Wilson / Georgia / 6’6 – 350 Grade: 78 Summary: Redshirt sophomore entry from Brooklyn, New York.  Two year starter that missed 2 games in 2019 with an ankle injury.  2nd Team All SEC in 2019.  Wilson is a tools-rich tackle that still has a lot to learn and put in to practice.  He needs to take in NFL coaching so that his footwork can become second nature.  He has a lot of ugly tape in that department but when he does line things up, his combination of length and power can be dominant.  He is a high-upside prospect that shouldn’t be rushed in to action. *For all the talk Becton gets about his size, I’m surprised Wilson isn’t more talked up.  He actually has a wider frame and the 350 pound mark is where I think Becton will come down to.  Wilson also has top-shelf length and hand power.  He is sloppy though, there is no denying it.  Wilson’s hands get really wide and he loses track of the width of his base at times.  However when he’s on, there isn’t a huge gap between him and Thomas and I mean that.  I wouldn’t be surprised to see him go in the top 40, but I would want to wait until the top of round 3 to take him.  I bet he’s gone by that point. 8.	Lucas Niang / TCU / 6’6 – 315 Grade: 76 Summary: Senior entry from New Canaan, Connecticut.  Three year starter that missed the second half of 2019 with a hip labrum injury that needed surgery.  Earned 2nd Team All Big 12 in 2018, the only season he started every game.  Niang’s size looks excellent on paper but he has work to do on his body.  As he continues to rehab from his surgery, Niang is going to need a sleeping bag in the weight room.  He doesn’t play an aggressive game and will too often try to catch defenders rather than impose his will.  There is a lot of natural talent to work with however, as he moves very well and produced based on athletic ability and size.  If he can combine that with more consistent footwork and effort, he has starter-potential.  He simply needs to apply himself in the weight room for a year and clean other areas up. *This is an interesting prospect.  I had a hard time getting information on his hip injury and how much it impacted his play early in 2019.  He didn’t look like the same guy as I saw in 2018.  I had some really positive notes from his 2018 tape but it just didn’t match up.  There is a chance somebody is going to get a starting caliber right tackle here at the end of round 3 or early round 4.  You also have to account for the recovery from the hip injury, however.  A lot of things to consider in his evaluation but if NYG doesn’t address tackle with their first three picks and he is there at the start of round 4, it would be tough to pass on. 9.	Austin Jackson / USC / 6’5 – 322 Grade: 75 Summary: Junior entry.  Two year starter from Phoenix, Arizona.  Grandson of Melvin, a five-year NFL lineman.  First team All Pac 12 in 2019.  Jackson has the tools and initial movement off the snap with an aggressive playing style and hustle that will get coaches excited about working with him.  He can create solid torque and pop off the ball and he has enough athletic ability to play outside.  However a deeper look in to his game and there are several warts that absolutely need to be ironed out.  He needs a lot of core strength and balance work before he can be asked to handle NFL pass rushers.  His toughest opponents in college made him look silly at times, out of his league.  This is an upside-based prospect that will need a couple years. *Jackson is impressive initially.  He has a good body and plays with good explosion off the snap.  He can really get on top of a guy and gain the initial advantage.  But when it comes to the secondary stuff, he was woefully inconsistent.  I really didn’t like him against his toughest competition.  Jackson has more reachable upside than a typical 4th/5th round grade, I will give him that.  However the natural imbalance just sticks to my memory too hard. 10.	Matt Peart / Connecticut / 6’7 – 318 Grade: 75 Summary: Fifth year senior from Kingston, Jamaica.  A four year starter who never missed a game.  1st Team All AAC honors as a senior.  Peart is relatively new to the game, as he didn’t play football until he started high school.  He is a physically gifted player that, when his feet are in the right place, showed dominant traits.  He has incredibly strong hands with long arms and an athletic base, he simply just needs to hammer away at his lower body mechanics until they become more natural and consistent.  If and when that happens, he is a starting caliber player. *I did a quick recap of who Gettleman selected in his career as GM along the offensive line.  One glaring tendency was his desire for length at tackle.  Well, here you go.  Peart has the longest arms in the class and the widest frame.  Throw in the fact that he has a decently athletic lower body, and there is a chance he is going to hear his name called in round 2.  NYG is going to like him, I’m sure of it.  How much?  Not sure.  I personally see a guy that won’t be a factor in year one and he is going to need to really hammer away at lower body mechanics and power.  I couldn’t get past the 4th/5th round tier but I can see why some are higher on him because of the ceiling. 11.	Trey Adams / Washington / 6’8 – 318 Grade: 72 Summary: Fifth year senior entry from Wenatchee, Washington.  Four year starter that began his career on a high note.  Adams was a 1st Team All Pac 12 and 2nd Team All American as a sophomore in 2016.  However a back injury suffered in 2017 forced him to miss the second half of the year and the entire 2018 regular season.  Adams was once viewed as a no-doubt first round pick but questions surrounding his back injury and inconsistent play since he’s come back has made the outlook cloudy.  Adams is a plus-athlete with good size and aggression that plays smart and aware.  He has enough athletic ability to play tackle in the pros, but the medical screening and how it relates to his potential to add strength and power will mean a lot for his final grade.  He is going to need a year at least before he can be counted on as a starter. *Adams was on his way toward being a sure-thing first round pick.  But the back injury that kept him out so long is going to knock is grade down a bug chunk, maybe even make him undraftable to some.  For me?  If you are sitting there in round 5 or 6 and you need a young tackle to try and develop, I pull the trigger on him.  He is a really feisty, nasty, aggressive blocker.  It will be considered lucky to see him get completely over the injury but one has to take chances late in the draft at times.  And to build a quality offensive line, you have to get lucky once or twice. 12.	Charlie Heck / North Carolina / 6’8 – 311 Grade: 71 Summary: Fifth year senior from Kansas City, Missouri.  A three year starter that finished his career as a 2nd Team All ACC tackle.  Heck has plenty of experience on both sides and shows the intelligence and natural ability to play on both sides in the NFL.  The son of Kansas City Chiefs offensive line coach, Andy Heck, Charlie has the look of an eventual starter once he can enhance his staying power and core strength.  He is outstanding off the ball but simply needs to clean up his hand placement and footwork that usually stems from his inconsistent pad level.  Once he cleans that up, there is starter-potential and in the mean time, he is a solid swing tackle for a team needing to add depth. *I almost went 3 or 4 points higher on Heck.  I liked him a lot down the stretch and he was the best blocker at Shrine week.  There is a plus-athlete here and you know he understands the ins and outs of the game as well as anybody.  Heck’s height, like a couple others in this class, is a bit of an issue.  He doesn’t have a powerful base and its just hard for him to play with consistent knee bend and pad level.  That is a problem unless you have elite traits elsewhere, which he does not. 13.	Colton McKivitz / West Virginia / 6’6 – 306 Grade: 71 Summary: Fifth year senior from Jacobsburg, Ohio.  A four year starter that has played both tackle positions.  Two time Honorable Mention All Big 12 before being named 2nd Team in 2019.  Was also named 3rd Team All American as a senior.  McKivitz has average size and power that will need to be developed over the course of a year or two, but the former all state high school basketball player has light and quick feet with plus-balance.  Combine that with a strong will to win the one on one battles that doesn’t have an off switch, a case can be made he is one of the top tackles that will be available day three.  He won’t be ready right away, as he needs to improve his lower body power and hand strength, but if he can tidy those areas up he is proficient everywhere else.  Swing tackle candidate. *McKivitz is an intriguing athlete that simply didn’t lose much in college.  He has plenty of work ahead to get his power presence up to par, but for a team that can stash him away for a year or two, there is a high ceiling. 14.	Yasir Durant / Missouri / 6’6 – 331 Grade: 71 Summary: Senior entry from Philadelphia, Pennsylvania.  Three year starter for Missouri that spent a season at Arizona Western Community College where he played guard and tackle.  Durant took over the left tackle job four weeks in to 2017 and never looked back.  He is going to cause a second look based on his size alone, as he is as wide as he is long.  This kind of blocker doesn’t need to be the most twitched up, fastest player on the field.  He is a tough guy to get around because of how well he stays within himself, how far his blocking radius extends to, and hoe powerful his punch can be.  He may not be a year one guy, as there are some lower body techniques that must be cleaned up, but Durant has a potential starter label on him at either tackle spot. *Durant is really interesting.  It is widely known that he is going to struggle athletically, he is just a really heavy mover and the bend doesn’t come natural to him.  But you know what?  There aren’t many tackles that had higher graded tape, he just didn’t lose much.  I noticed how patient he works at Shrine week.  He just sits and waits, lets the defender make his move, and then calmly and powerfully reacts.  I think there is something to this kid. 15.	Robert Hunt / Louisiana-Lafayette / 6’5 – 323 Grade: 71 Summary: Fifth year senior entry from Burkeville, Texas.  Four year starter that has started games at left guard, left tackle, and right tackle.  Was named 2nd Team All Sun Belt in 2018, 1st Team in 2019 despite missing games with a groin injury.  Hunt projects to both tackle and guard at the next level.  He was a good high school basketball player and that kind of foot-speed and quickness shows up on the gridiron with his attractive, moldable frame.  He may not be ready for NFL action right away, as he has some footwork issues to clean up and lower body strength to pack on.  Depending on where he is drafted, however, he has the look of an eventual starter inside or outside.  It is hard to find guys with this kind of size, athletic ability, and body control capabilities.  His best tape came against his toughest competition, a good sign in relation to his long term projection. *I originally had a 3rd round grade on Hunt as a tackle, but because of a medical, had to bring him down to round 5/6 region.  Good kid though and I am hoping for the best.  On the field, Hunt has the feet to play outside but some question his length.  Personally, I don’t see the move to guard because he plays too high and he isn’t stout enough.  If he clears the medical stage, I like him as a versatile backup that may need to sit for a year and enhance his strength. 16.	Tyre Phillips / Mississippi State: 70
17.	 Aaron McKinney / TCU: 69
18.	 Terence Steele / Texas Tech: 67
19.	Darrin Paulo / Utah: 67
20.	 Carter O’Donnell /Alberta: 66
21.	Matt Womack / Alabama: 66
22.	Alex Taylor / South Carolina State: 65
23.	Drew Richmond / USC: 64
24.	Jake Benzinger / Wake Forest: 63
25.	Brandon Bowen / Ohio State: 61 NYG APPROACH It isn’t the sexy pick.  It isn’t the name you are going to see in the box score or the highlight reel.  You’re rarely going to walk away from a Giants win and talk about how good the tackles played.  All of that said, this team isn’t going anywhere unless this offensive line improves on the outside.  It would be one thing if they already had a solid piece on the left or right side.  It would be one thing if they already had an up and coming stud that was in the development stages.  The Giants have neither nor are they even close. What is the point of drafting a Saquon Barkley #2 overall if you can’t get anyone up front to keep defenders out of the backfield?  Quite literally he is getting contacted by defenders before he takes his third step with the ball as much as any back in the league!  Daniel Jones was selected #6 overall and I have always believed the number one task to aid the maturation of a young quarterback is building the group up front.  Keep him upright.  Keep him confident.  Make it easier for him to hold on to the football! Credible and respectful arguments can be made to take defense, namely Simmons or Okudah, at #4.  I disagree that it is the best path.  While I am fully aware the NYG defense needs work, I think the offensive line is more important and NYG is absolutely hopeless at tackle right now.  Throw in the fact that I have a Pro Bowl projection on Wirfs and Wills, the decision is even easier.  Only a godsend like Chase Young being available will change my mind.
"/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="website" />
<meta property="og:description" content="OFFENSIVE TACKLE Format includes a quick position overview, my grading scale and what the number means, the summary and final grade from my final report on my top 15, a quick additional note on the player, and my ranks 16-25 with grades only. *I AM NOT DOING NFL COMPARISONS Quick Position Overview Dave Gettleman got aggressive in 2018, signing Nate Solder from NE to a 4 year  $62 million contract.  It was a move that put former top 10 pick Ereck Flowers at right tackle.  Fast forward two seasons and Flowers is now a guard on the Dolphins after playing the 2019 season with the Redskins and Nate Solder grades out as one of the bottom third left tackles in the game despite having the third highest contract in the league.  One has to assume they will move forward in 2020 with Solder on the left side but his $20.5 Million cap hit next year leads me to the notion he will not be playing for NYG beyond this season. Mike Remmers left for KC in free agency to be a backup, which leaves the right side up to the winner of Nick Gates and the newly signed Cameron Fleming.  Fleming has started 6 games over the past 2 seasons for Dallas and in fact has never started more than 7 games in his career.  Gates saw three starts in 2019 and played both inside and outside.  He showed promise but remember, the bar has been set so low here in regard to the offensive line and Gates would be best suited for a 6th or 7th blocker role.  Chad Slade and Eric Smith are training camp bodies that can compete for a roster spot respectively.  All in, the lack of quality both short term and long term at this position is incredibly weak. GRADING SCALE 90+ All Pro Projection 85+: Pro Bowl Projection
81-84: First rounder – should be able to play right away
79-80: 2nd Rounder – Should be able to rotate right away – Year 2 starter
77-78: 3rd rounder – Should be able to rotate by end of rookie year – Year 2/3 starter
74-76: Early Day 3 – Special Teams – Future backup/possible starter
71-73: Mid Day 3 – Special Teams – Future backup / gamble starter
68-70: Late Day 3 -  Back end of roster / Practice Squad / Development guy
65-67: Preferred UDFA
60-64: Undrafted FA TOP 15 GRADES AND ANALYSIS 1.	Tristan Wirfs / Iowa / 6’5 – 320 Grade: 86 Summary: Junior entry and three year starter from Mount Vernon, Iowa.  After a record setting high school shot put and discuss career, Wirfs stepped in as a starting right and left tackle as a true freshman in 2017.  He settled in on the right side as the Hawkeyes have another future NFL prospect manning the left side, Alaric Jackson.  Wirfs is a physical freak in the weight room and keeping that in mind with his background as a thrower, it was a sight to see as his football skill set and performance started to catch up with his upside in 2019.  The foot-quickness, hand-striking, and easy knee bend gives him the look of a franchise offensive tackle.  There are multiple inconsistencies that remain, however.  He overextends too often and the speed/power combination of NFL edge rushers can eat that up for breakfast if it isn’t fixed.  The just-turned 21 year old has work in front of him to do but if he can correct the very correctable issues, he can be a star. *Another really interesting pre-draft study here that I spent a ton of time on.  Wirfs has shutdown ability.  What I mean by that is no matter what kind of pass rusher he is up against, Wirfs has the physical ability to dominate.  Against power he can anchor, re-anchor, and keep his hands locked inside.  Against pure speed he can beat the defender to the meeting point without losing the width of his feet.  Against quickness, he can adjust inside and out while keeping his hands in the right place and maintaining his knee bend.  All of these skills and tools are there, but the snap to snap consistency isn’t there when it comes to balance and timing.  That is the reason why he doesn’t approach the 90-point mark.  With that said, we are talking about correctable issues here, not physical shortcomings.  Wirfs is a dominant run blocker right now, he can project to both right and left tackle, and he is a week 1 starter on this team.  Because of where the NYG situation resides and because I think we are looking at a Pro Bowl tackle, Wirfs gets my vote for who NYG should take at #4 unless Young somehow falls in to their lap. 2.	Jedrick Wills / Alabama / 6’4 – 312 Grade: 85 Summary: Junior entry from Lexington, Kentucky.  A two-year starter at right tackle that earned 1st Team All SEC and 2nd Team All American honors in 2019.  Wills was the most physical blocker on the Crimson Tide offensive line but also turned heads with his quality, consistent performance as a pass blocker.  It can be hard to locate a true dent in his armor outside of the fact he can get out-reached by longer defenders.  His footwork and hands are as sure as it gets and he plays with an ever-present competitive streak that every team wants in the trenches.  He has the look of a first-year starter that could move inside if the situation he is drafted in to doesn’t initially demand a new face at tackle. *Wills grew on me more and more as the scouting process got under way.  Initially, he doesn’t have the traditional tackle body.  He is a little light in the pants, he is a little short, and there isn’t a great reach-game.  For those reasons I don’t see Gettleman considering him at #4, as he just doesn’t fit the profile.  However, for me, I think Wills is probably the most polished and NFL ready tackle in the group.  If these tackles all start in 2020, I bet Wills has the best rookie season.  While he isn’t a road grader in the running game, he plays with some good fire and he can translate speed in to power.   He will be fine there.  My question long term with him is stoutness against the ends that really bull rush under the blocker’s pads.  All that in mind, I see a David Bakhtiari type tackle here, who is very good. 3.	Andrew Thomas / Georgia / 6’5 – 315 Grade: 83 Summary: Junior entry from Lithonia, Ga.  A three year starter with experience at both tackle positions and a two-time 1st Team All SEC and All American.  Thomas has the tools and more than enough quality tape over three years to sell himself as an elite left tackle prospect.  The issue, however, is the amount of inconsistencies he shows in pass protection when it comes to technique.  He doesn’t maximize those tools and has gotten used to playing catch-up football which will be much more difficult to do against NFL edge players.  Thomas will be a plus-run blocker right away but whatever team ends up with him will need to be patient in his development as a pass blocker. *When I look at who Dave Gettleman has drafted in the past at the offensive tackle position, Thomas looks like that guy.  Big, thick, long-armed and really physical.  He is a really fun player to watch when he’s pissed off.  He moves guys in to another zip code as a run blocker, he really gets after guys in space, and he finishes.  The issues here are two-fold.  His effort isn’t consistent and that is the number one red flag.  In the intense moments, big games…etc Thomas gets after it.  But too many times throughout the past two seasons I saw a guy that simply tried to get by on talent.  The second issue, he looks like a train wreck in pass protection at times.  He struggles to reach his point against speed and he shows his numbers to the ground too often.  While his power and reach can partially make up for it, he simply needs to get better there or he will get eaten alive by the top end pass rushers.  I’ll end with this: Thomas at his absolute best is better than Wirfs and Wills.  But do you want to gamble on his work ethic and lack of athletic ability?  More power to you if you do, but I only want him if it meant NYG traded down and the two guys above were off the board. 4.	Mekhi Becton / Louisville / 6’8 – 364 Grade: 82 Summary: Junior entry and three year starter from Highland Springs, Virginia.  First team All ACC in 2019 as the team’s starting left tackle.  Becton has played on both sides of the line and could project to either in the NFL.  His game very much depends on the elite length and upper body explosion that can take over a one on one battle right away.  Becton is rare physical force that gets movement at both the point of attack and in space the second he comes in contact with the defender.  His issues are partially technique-based which, in theory, can be corrected but there are also movement issues.  It can be hard for a player at his height to adjust with balance and precision and even his length can’t hide those issues in pass protection.  His sometimes-inaccurate hands aren’t backed up by other physical attributes and techniques which gives him a rather large buyer-beware label.  Boom or bust prospect that turns 21 just days prior to the draft. *I don’t expect a guy this big to move like Tyron Smith from DAL, I get it.  Yes, guys with this kind of length and width can get away with movement issues.  Yes, I have been wrong a couple of times in recent years about mammoth tackles.  All that in mind, I am placing a first round grade on Becton but I don’t think he is a top 10 pick for NYG, certainly not the guy I want at 4.  Do I see NYG pursuing him? Sure.  He is huge and explosive, he can be a dominant force in the running game, and he isn’t even 21 years old yet. There are a couple medical red flags that need to check out however.  If a guy that weights 360-380 pounds comes in to the league with any injury red flag, I would be more worried than usual.  Throw in some more red flags centering around his willingness to work and grind, I just don’t want to take the risk but I can see why some wouldn’t mind going for it.  This is a rare specimen that has some quality tape. 5.	Ezra Cleveland / Boise State / 6’6 – 311 Grade: 79 Summary: Fourth year junior from Spanaway, Washington.  A three year starter that earned Honorable Mention All Mountain West honors in 2017, and 1st Team honors in 2018 and 2019 respectively.  Cleveland has a wrestling background and it shows on tape.  His body control and balance are noteworthy, as he never seems to lose his feet and you rarely find him lunging for a defender or wind up on the ground.  His techniques with his hand and feet create the notion that his learning curve in the NFL won’t be as steep as some others.  The question for him will center around length and lockout and whether or not that makes him move inside.  He could likely be a quality backup at both spots and a starter once he adds more strength and power to his arsenal. *A huge part of my offensive tackle evaluation is balance and body control.  If I had to rank which tackle in this class had the best of both, it is Cleveland.  I am not comparing him to Joe Thomas, but that is how he moves.  Just smooth and easy, movement across the line never seems to disrupt his approach.  The issue?  He has short arms, lacks a true power game, and his body may not be ready in year one.  I can’t use a first rounder on someone like that and I don’t think he is in play at #36.  If NYG ends up with an early third or late second somehow, then we can talk. 6.	Josh Jones / Houston / 6’5 – 319 Grade: 79 Summary: Fifth year senior from Richmond, Texas.  A four year starter that earned 2nd Team All AAC honors in 2019.  Jones put together a really solid season and earned an invite to the Senior Bowl where he performed well all week against the stiffest competition he faced.  His length and power game are small red flags but he has the foot speed and techniques that can hide them.  He is a really smooth operator that knows and trusts himself.  He doesn’t over-set like most tackles do, he doesn’t abandon techniques when he doesn’t win the initial battle like most tackles do, and he still has ton of attainable upside to go before he is a finished product.  If he can improve his power game and continue to progress his skill set, he can be a longtime starter in the league.  With that said, he should be thrown in to the fire right away. *I know a scout in the league that has Jones on the same tier as the top tackles in the draft.  While I don’t think that is a common opinion, I’m sure he isn’t the only one.  Jones is a really fluid and easy athlete on the outside that simply needs a key to the weight room.  I do think he can handle snaps right away, but I would prefer to him to wait at least half a season if possible.  Power guys are going to beat him up pretty good.  If he does enhance how own power game, he is a definite starter. 7.	Isaiah Wilson / Georgia / 6’6 – 350 Grade: 78 Summary: Redshirt sophomore entry from Brooklyn, New York.  Two year starter that missed 2 games in 2019 with an ankle injury.  2nd Team All SEC in 2019.  Wilson is a tools-rich tackle that still has a lot to learn and put in to practice.  He needs to take in NFL coaching so that his footwork can become second nature.  He has a lot of ugly tape in that department but when he does line things up, his combination of length and power can be dominant.  He is a high-upside prospect that shouldn’t be rushed in to action. *For all the talk Becton gets about his size, I’m surprised Wilson isn’t more talked up.  He actually has a wider frame and the 350 pound mark is where I think Becton will come down to.  Wilson also has top-shelf length and hand power.  He is sloppy though, there is no denying it.  Wilson’s hands get really wide and he loses track of the width of his base at times.  However when he’s on, there isn’t a huge gap between him and Thomas and I mean that.  I wouldn’t be surprised to see him go in the top 40, but I would want to wait until the top of round 3 to take him.  I bet he’s gone by that point. 8.	Lucas Niang / TCU / 6’6 – 315 Grade: 76 Summary: Senior entry from New Canaan, Connecticut.  Three year starter that missed the second half of 2019 with a hip labrum injury that needed surgery.  Earned 2nd Team All Big 12 in 2018, the only season he started every game.  Niang’s size looks excellent on paper but he has work to do on his body.  As he continues to rehab from his surgery, Niang is going to need a sleeping bag in the weight room.  He doesn’t play an aggressive game and will too often try to catch defenders rather than impose his will.  There is a lot of natural talent to work with however, as he moves very well and produced based on athletic ability and size.  If he can combine that with more consistent footwork and effort, he has starter-potential.  He simply needs to apply himself in the weight room for a year and clean other areas up. *This is an interesting prospect.  I had a hard time getting information on his hip injury and how much it impacted his play early in 2019.  He didn’t look like the same guy as I saw in 2018.  I had some really positive notes from his 2018 tape but it just didn’t match up.  There is a chance somebody is going to get a starting caliber right tackle here at the end of round 3 or early round 4.  You also have to account for the recovery from the hip injury, however.  A lot of things to consider in his evaluation but if NYG doesn’t address tackle with their first three picks and he is there at the start of round 4, it would be tough to pass on. 9.	Austin Jackson / USC / 6’5 – 322 Grade: 75 Summary: Junior entry.  Two year starter from Phoenix, Arizona.  Grandson of Melvin, a five-year NFL lineman.  First team All Pac 12 in 2019.  Jackson has the tools and initial movement off the snap with an aggressive playing style and hustle that will get coaches excited about working with him.  He can create solid torque and pop off the ball and he has enough athletic ability to play outside.  However a deeper look in to his game and there are several warts that absolutely need to be ironed out.  He needs a lot of core strength and balance work before he can be asked to handle NFL pass rushers.  His toughest opponents in college made him look silly at times, out of his league.  This is an upside-based prospect that will need a couple years. *Jackson is impressive initially.  He has a good body and plays with good explosion off the snap.  He can really get on top of a guy and gain the initial advantage.  But when it comes to the secondary stuff, he was woefully inconsistent.  I really didn’t like him against his toughest competition.  Jackson has more reachable upside than a typical 4th/5th round grade, I will give him that.  However the natural imbalance just sticks to my memory too hard. 10.	Matt Peart / Connecticut / 6’7 – 318 Grade: 75 Summary: Fifth year senior from Kingston, Jamaica.  A four year starter who never missed a game.  1st Team All AAC honors as a senior.  Peart is relatively new to the game, as he didn’t play football until he started high school.  He is a physically gifted player that, when his feet are in the right place, showed dominant traits.  He has incredibly strong hands with long arms and an athletic base, he simply just needs to hammer away at his lower body mechanics until they become more natural and consistent.  If and when that happens, he is a starting caliber player. *I did a quick recap of who Gettleman selected in his career as GM along the offensive line.  One glaring tendency was his desire for length at tackle.  Well, here you go.  Peart has the longest arms in the class and the widest frame.  Throw in the fact that he has a decently athletic lower body, and there is a chance he is going to hear his name called in round 2.  NYG is going to like him, I’m sure of it.  How much?  Not sure.  I personally see a guy that won’t be a factor in year one and he is going to need to really hammer away at lower body mechanics and power.  I couldn’t get past the 4th/5th round tier but I can see why some are higher on him because of the ceiling. 11.	Trey Adams / Washington / 6’8 – 318 Grade: 72 Summary: Fifth year senior entry from Wenatchee, Washington.  Four year starter that began his career on a high note.  Adams was a 1st Team All Pac 12 and 2nd Team All American as a sophomore in 2016.  However a back injury suffered in 2017 forced him to miss the second half of the year and the entire 2018 regular season.  Adams was once viewed as a no-doubt first round pick but questions surrounding his back injury and inconsistent play since he’s come back has made the outlook cloudy.  Adams is a plus-athlete with good size and aggression that plays smart and aware.  He has enough athletic ability to play tackle in the pros, but the medical screening and how it relates to his potential to add strength and power will mean a lot for his final grade.  He is going to need a year at least before he can be counted on as a starter. *Adams was on his way toward being a sure-thing first round pick.  But the back injury that kept him out so long is going to knock is grade down a bug chunk, maybe even make him undraftable to some.  For me?  If you are sitting there in round 5 or 6 and you need a young tackle to try and develop, I pull the trigger on him.  He is a really feisty, nasty, aggressive blocker.  It will be considered lucky to see him get completely over the injury but one has to take chances late in the draft at times.  And to build a quality offensive line, you have to get lucky once or twice. 12.	Charlie Heck / North Carolina / 6’8 – 311 Grade: 71 Summary: Fifth year senior from Kansas City, Missouri.  A three year starter that finished his career as a 2nd Team All ACC tackle.  Heck has plenty of experience on both sides and shows the intelligence and natural ability to play on both sides in the NFL.  The son of Kansas City Chiefs offensive line coach, Andy Heck, Charlie has the look of an eventual starter once he can enhance his staying power and core strength.  He is outstanding off the ball but simply needs to clean up his hand placement and footwork that usually stems from his inconsistent pad level.  Once he cleans that up, there is starter-potential and in the mean time, he is a solid swing tackle for a team needing to add depth. *I almost went 3 or 4 points higher on Heck.  I liked him a lot down the stretch and he was the best blocker at Shrine week.  There is a plus-athlete here and you know he understands the ins and outs of the game as well as anybody.  Heck’s height, like a couple others in this class, is a bit of an issue.  He doesn’t have a powerful base and its just hard for him to play with consistent knee bend and pad level.  That is a problem unless you have elite traits elsewhere, which he does not. 13.	Colton McKivitz / West Virginia / 6’6 – 306 Grade: 71 Summary: Fifth year senior from Jacobsburg, Ohio.  A four year starter that has played both tackle positions.  Two time Honorable Mention All Big 12 before being named 2nd Team in 2019.  Was also named 3rd Team All American as a senior.  McKivitz has average size and power that will need to be developed over the course of a year or two, but the former all state high school basketball player has light and quick feet with plus-balance.  Combine that with a strong will to win the one on one battles that doesn’t have an off switch, a case can be made he is one of the top tackles that will be available day three.  He won’t be ready right away, as he needs to improve his lower body power and hand strength, but if he can tidy those areas up he is proficient everywhere else.  Swing tackle candidate. *McKivitz is an intriguing athlete that simply didn’t lose much in college.  He has plenty of work ahead to get his power presence up to par, but for a team that can stash him away for a year or two, there is a high ceiling. 14.	Yasir Durant / Missouri / 6’6 – 331 Grade: 71 Summary: Senior entry from Philadelphia, Pennsylvania.  Three year starter for Missouri that spent a season at Arizona Western Community College where he played guard and tackle.  Durant took over the left tackle job four weeks in to 2017 and never looked back.  He is going to cause a second look based on his size alone, as he is as wide as he is long.  This kind of blocker doesn’t need to be the most twitched up, fastest player on the field.  He is a tough guy to get around because of how well he stays within himself, how far his blocking radius extends to, and hoe powerful his punch can be.  He may not be a year one guy, as there are some lower body techniques that must be cleaned up, but Durant has a potential starter label on him at either tackle spot. *Durant is really interesting.  It is widely known that he is going to struggle athletically, he is just a really heavy mover and the bend doesn’t come natural to him.  But you know what?  There aren’t many tackles that had higher graded tape, he just didn’t lose much.  I noticed how patient he works at Shrine week.  He just sits and waits, lets the defender make his move, and then calmly and powerfully reacts.  I think there is something to this kid. 15.	Robert Hunt / Louisiana-Lafayette / 6’5 – 323 Grade: 71 Summary: Fifth year senior entry from Burkeville, Texas.  Four year starter that has started games at left guard, left tackle, and right tackle.  Was named 2nd Team All Sun Belt in 2018, 1st Team in 2019 despite missing games with a groin injury.  Hunt projects to both tackle and guard at the next level.  He was a good high school basketball player and that kind of foot-speed and quickness shows up on the gridiron with his attractive, moldable frame.  He may not be ready for NFL action right away, as he has some footwork issues to clean up and lower body strength to pack on.  Depending on where he is drafted, however, he has the look of an eventual starter inside or outside.  It is hard to find guys with this kind of size, athletic ability, and body control capabilities.  His best tape came against his toughest competition, a good sign in relation to his long term projection. *I originally had a 3rd round grade on Hunt as a tackle, but because of a medical, had to bring him down to round 5/6 region.  Good kid though and I am hoping for the best.  On the field, Hunt has the feet to play outside but some question his length.  Personally, I don’t see the move to guard because he plays too high and he isn’t stout enough.  If he clears the medical stage, I like him as a versatile backup that may need to sit for a year and enhance his strength. 16.	Tyre Phillips / Mississippi State: 70
17.	 Aaron McKinney / TCU: 69
18.	 Terence Steele / Texas Tech: 67
19.	Darrin Paulo / Utah: 67
20.	 Carter O’Donnell /Alberta: 66
21.	Matt Womack / Alabama: 66
22.	Alex Taylor / South Carolina State: 65
23.	Drew Richmond / USC: 64
24.	Jake Benzinger / Wake Forest: 63
25.	Brandon Bowen / Ohio State: 61 NYG APPROACH It isn’t the sexy pick.  It isn’t the name you are going to see in the box score or the highlight reel.  You’re rarely going to walk away from a Giants win and talk about how good the tackles played.  All of that said, this team isn’t going anywhere unless this offensive line improves on the outside.  It would be one thing if they already had a solid piece on the left or right side.  It would be one thing if they already had an up and coming stud that was in the development stages.  The Giants have neither nor are they even close. What is the point of drafting a Saquon Barkley #2 overall if you can’t get anyone up front to keep defenders out of the backfield?  Quite literally he is getting contacted by defenders before he takes his third step with the ball as much as any back in the league!  Daniel Jones was selected #6 overall and I have always believed the number one task to aid the maturation of a young quarterback is building the group up front.  Keep him upright.  Keep him confident.  Make it easier for him to hold on to the football! Credible and respectful arguments can be made to take defense, namely Simmons or Okudah, at #4.  I disagree that it is the best path.  While I am fully aware the NYG defense needs work, I think the offensive line is more important and NYG is absolutely hopeless at tackle right now.  Throw in the fact that I have a Pro Bowl projection on Wirfs and Wills, the decision is even easier.  Only a godsend like Chase Young being available will change my mind.
" /> 
<meta property="og:title" content="2020 NFL Draft Preview - Offensive Tackle" /> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif" /> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css?v=20200217" />

<link rel="stylesheet" type="text/css" href="anylink.css" />


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}


div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" alt="for display only">

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type='text/javascript'>
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type='text/javascript' src='https://img.bnqt.com/lib/js/sdpdfphelper.js'></script>
<script type='text/javascript'>
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>


<!-- End DFP SETUP -->  

<!-- End USA Today Code -->





<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-131124163-7";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-131124163-7']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'bigblueinteractive.com']);
_gaq.push(['f._setDomainName', 'bigblueinteractive.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod71',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','bigblueinteractive.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://corner.bigblueinteractive.com/index.php?mode=2&thread=596887&show_all=1"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"8b57721e-ee37-4aba-5567-9eb67e64e639","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":326,"serverid":"34.201.107.90:27303","state":"VA","t_epoch":1586751670,"template_id":126,"time_on_site_visit":0,"url":"https://corner.bigblueinteractive.com/index.php?mode=2\u0026thread=596887\u0026show_all=1","user_id":0,"word_count":18230,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=188-0&v=8" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|8b57721e-ee37-4aba-5567-9eb67e64e639|false; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head>


<body>




<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"></a> <img src="images/xpete.gif" alt="The Corner Forum">

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic -->&nbsp;


<!-- Nov 2019 Leaderboard -->

<!-- Ezoic - Forum Leaderboard (USAT) - top_of_page -->
<div id="ezoic-pub-ad-placeholder-118">
<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->
<div id='usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general'>
     <script type='text/javascript'>
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general');
         });
     </script>
</div>
</div>
<!-- End Ezoic - Forum Leaderboard (USAT) - top_of_page -->



</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://www.shareasale.com/r.cfm?b=277504&u=723646&m=29078&urllink=&afftrack=">Apparel</a>
<a href="http://www.amazon.com/?_encoding=UTF8&camp=1789&creative=9325&linkCode=ur2&tag=bigblueintera-20">Amazon.com</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW" >Standings (NFL.com)</a>
<a href="http://www.nfl.com/teams/newyorkgiants/statistics?team=NYG" target="_NEW" >Statistics (NFL.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/" >Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'home_view_menu')">Home</a>  
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'forum_view_menu')">Corner Forum</a>
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'gameday_view_menu')">Gameday</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_view_menu')">Team</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_building_view_menu')">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info &amp; History</a> -->
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_info_view_menu')">Giants Info &amp; History</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'infolinks_view_menu')">Info/Links</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'shop_view_menu')">BBI Shop</a>
<li><a href="/index.php?mode=10" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'login_menu')">Log In</a>
</ul>

</div><div id="infoline"> </div>

<a name="END"><a href="index.php"><div style="padding-top:20px; padding-bottom:25px;"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"></a></div></a><div class="thread_container"><div class="thread_left"><div class="thread_body" ><div class="thread_main" ><div class="thread_post_header" >  <h1 style="font-size:18px;">2020 NFL Draft Preview - Offensive Tackle </h1><div class="thread_info"><a href="index.php?mode=5&handle=Sy'56"> Sy'56 </a>  :  4/12/2020  8:34 am</div></div><div class="thread_post_body" > <span class="bold">OFFENSIVE TACKLE</span><br />
<br />
Format includes a quick position overview, my grading scale and what the number means, the summary and final grade from my final report on my top 15, a quick additional note on the player, and my ranks 16-25 with grades only.<br />
<br />
*I AM NOT DOING NFL COMPARISONS<br />
<br />
<span class="bold">Quick Position Overview</span><br />
<br />
Dave Gettleman got aggressive in 2018, signing Nate Solder from NE to a 4 year  $62 million contract.  It was a move that put former top 10 pick Ereck Flowers at right tackle.  Fast forward two seasons and Flowers is now a guard on the Dolphins after playing the 2019 season with the Redskins and Nate Solder grades out as one of the bottom third left tackles in the game despite having the third highest contract in the league.  One has to assume they will move forward in 2020 with Solder on the left side but his $20.5 Million cap hit next year leads me to the notion he will not be playing for NYG beyond this season.<br />
<br />
Mike Remmers left for KC in free agency to be a backup, which leaves the right side up to the winner of Nick Gates and the newly signed Cameron Fleming.  Fleming has started 6 games over the past 2 seasons for Dallas and in fact has never started more than 7 games in his career.  Gates saw three starts in 2019 and played both inside and outside.  He showed promise but remember, the bar has been set so low here in regard to the offensive line and Gates would be best suited for a 6th or 7th blocker role.  Chad Slade and Eric Smith are training camp bodies that can compete for a roster spot respectively.  All in, the lack of quality both short term and long term at this position is incredibly weak.<br />
<br />
<span class="italics">GRADING SCALE<br />
<br />
90+ All Pro Projection <br />
85+: Pro Bowl Projection<br />
81-84: First rounder – should be able to play right away<br />
79-80: 2nd Rounder – Should be able to rotate right away – Year 2 starter<br />
77-78: 3rd rounder – Should be able to rotate by end of rookie year – Year 2/3 starter<br />
74-76: Early Day 3 – Special Teams – Future backup/possible starter<br />
71-73: Mid Day 3 – Special Teams – Future backup / gamble starter<br />
68-70: Late Day 3 -  Back end of roster / Practice Squad / Development guy<br />
65-67: Preferred UDFA<br />
60-64: Undrafted FA</span><br />
<br />
<br />
<span class="bold">TOP 15 GRADES AND ANALYSIS<br />
<br />
1.	Tristan Wirfs / Iowa / 6’5 – 320<br />
<br />
Grade: 86</span><br />
<br />
Summary: Junior entry and three year starter from Mount Vernon, Iowa.  After a record setting high school shot put and discuss career, Wirfs stepped in as a starting right and left tackle as a true freshman in 2017.  He settled in on the right side as the Hawkeyes have another future NFL prospect manning the left side, Alaric Jackson.  Wirfs is a physical freak in the weight room and keeping that in mind with his background as a thrower, it was a sight to see as his football skill set and performance started to catch up with his upside in 2019.  The foot-quickness, hand-striking, and easy knee bend gives him the look of a franchise offensive tackle.  There are multiple inconsistencies that remain, however.  He overextends too often and the speed/power combination of NFL edge rushers can eat that up for breakfast if it isn’t fixed.  The just-turned 21 year old has work in front of him to do but if he can correct the very correctable issues, he can be a star.<br />
<br />
<span class="italics">*Another really interesting pre-draft study here that I spent a ton of time on.  Wirfs has shutdown ability.  What I mean by that is no matter what kind of pass rusher he is up against, Wirfs has the physical ability to dominate.  Against power he can anchor, re-anchor, and keep his hands locked inside.  Against pure speed he can beat the defender to the meeting point without losing the width of his feet.  Against quickness, he can adjust inside and out while keeping his hands in the right place and maintaining his knee bend.  All of these skills and tools are there, but the snap to snap consistency isn’t there when it comes to balance and timing.  That is the reason why he doesn’t approach the 90-point mark.  With that said, we are talking about correctable issues here, not physical shortcomings.  Wirfs is a dominant run blocker right now, he can project to both right and left tackle, and he is a week 1 starter on this team.  Because of where the NYG situation resides and because I think we are looking at a Pro Bowl tackle, Wirfs gets my vote for who NYG should take at #4 unless Young somehow falls in to their lap.</span><br />
<br />
<span class="bold">2.	Jedrick Wills / Alabama / 6’4 – 312<br />
<br />
Grade: 85</span><br />
<br />
Summary: Junior entry from Lexington, Kentucky.  A two-year starter at right tackle that earned 1st Team All SEC and 2nd Team All American honors in 2019.  Wills was the most physical blocker on the Crimson Tide offensive line but also turned heads with his quality, consistent performance as a pass blocker.  It can be hard to locate a true dent in his armor outside of the fact he can get out-reached by longer defenders.  His footwork and hands are as sure as it gets and he plays with an ever-present competitive streak that every team wants in the trenches.  He has the look of a first-year starter that could move inside if the situation he is drafted in to doesn’t initially demand a new face at tackle.<br />
<br />
<span class="italics">*Wills grew on me more and more as the scouting process got under way.  Initially, he doesn’t have the traditional tackle body.  He is a little light in the pants, he is a little short, and there isn’t a great reach-game.  For those reasons I don’t see Gettleman considering him at #4, as he just doesn’t fit the profile.  However, for me, I think Wills is probably the most polished and NFL ready tackle in the group.  If these tackles all start in 2020, I bet Wills has the best rookie season.  While he isn’t a road grader in the running game, he plays with some good fire and he can translate speed in to power.   He will be fine there.  My question long term with him is stoutness against the ends that really bull rush under the blocker’s pads.  All that in mind, I see a David Bakhtiari type tackle here, who is very good.</span><br />
<br />
<span class="bold">3.	Andrew Thomas / Georgia / 6’5 – 315<br />
<br />
Grade: 83</span><br />
<br />
Summary: Junior entry from Lithonia, Ga.  A three year starter with experience at both tackle positions and a two-time 1st Team All SEC and All American.  Thomas has the tools and more than enough quality tape over three years to sell himself as an elite left tackle prospect.  The issue, however, is the amount of inconsistencies he shows in pass protection when it comes to technique.  He doesn’t maximize those tools and has gotten used to playing catch-up football which will be much more difficult to do against NFL edge players.  Thomas will be a plus-run blocker right away but whatever team ends up with him will need to be patient in his development as a pass blocker.<br />
<br />
<span class="italics">*When I look at who Dave Gettleman has drafted in the past at the offensive tackle position, Thomas looks like that guy.  Big, thick, long-armed and really physical.  He is a really fun player to watch when he’s pissed off.  He moves guys in to another zip code as a run blocker, he really gets after guys in space, and he finishes.  The issues here are two-fold.  His effort isn’t consistent and that is the number one red flag.  In the intense moments, big games…etc Thomas gets after it.  But too many times throughout the past two seasons I saw a guy that simply tried to get by on talent.  The second issue, he looks like a train wreck in pass protection at times.  He struggles to reach his point against speed and he shows his numbers to the ground too often.  While his power and reach can partially make up for it, he simply needs to get better there or he will get eaten alive by the top end pass rushers.  I’ll end with this: Thomas at his absolute best is better than Wirfs and Wills.  But do you want to gamble on his work ethic and lack of athletic ability?  More power to you if you do, but I only want him if it meant NYG traded down and the two guys above were off the board.</span><br />
<br />
<span class="bold">4.	Mekhi Becton / Louisville / 6’8 – 364<br />
<br />
Grade: 82</span><br />
<br />
Summary: Junior entry and three year starter from Highland Springs, Virginia.  First team All ACC in 2019 as the team’s starting left tackle.  Becton has played on both sides of the line and could project to either in the NFL.  His game very much depends on the elite length and upper body explosion that can take over a one on one battle right away.  Becton is rare physical force that gets movement at both the point of attack and in space the second he comes in contact with the defender.  His issues are partially technique-based which, in theory, can be corrected but there are also movement issues.  It can be hard for a player at his height to adjust with balance and precision and even his length can’t hide those issues in pass protection.  His sometimes-inaccurate hands aren’t backed up by other physical attributes and techniques which gives him a rather large buyer-beware label.  Boom or bust prospect that turns 21 just days prior to the draft.<br />
<br />
<span class="italics">*I don’t expect a guy this big to move like Tyron Smith from DAL, I get it.  Yes, guys with this kind of length and width can get away with movement issues.  Yes, I have been wrong a couple of times in recent years about mammoth tackles.  All that in mind, I am placing a first round grade on Becton but I don’t think he is a top 10 pick for NYG, certainly not the guy I want at 4.  Do I see NYG pursuing him? Sure.  He is huge and explosive, he can be a dominant force in the running game, and he isn’t even 21 years old yet. There are a couple medical red flags that need to check out however.  If a guy that weights 360-380 pounds comes in to the league with any injury red flag, I would be more worried than usual.  Throw in some more red flags centering around his willingness to work and grind, I just don’t want to take the risk but I can see why some wouldn’t mind going for it.  This is a rare specimen that has some quality tape.</span><br />
<br />
<span class="bold">5.	Ezra Cleveland / Boise State / 6’6 – 311<br />
<br />
Grade: 79</span><br />
<br />
Summary: Fourth year junior from Spanaway, Washington.  A three year starter that earned Honorable Mention All Mountain West honors in 2017, and 1st Team honors in 2018 and 2019 respectively.  Cleveland has a wrestling background and it shows on tape.  His body control and balance are noteworthy, as he never seems to lose his feet and you rarely find him lunging for a defender or wind up on the ground.  His techniques with his hand and feet create the notion that his learning curve in the NFL won’t be as steep as some others.  The question for him will center around length and lockout and whether or not that makes him move inside.  He could likely be a quality backup at both spots and a starter once he adds more strength and power to his arsenal.<br />
<br />
<span class="italics">*A huge part of my offensive tackle evaluation is balance and body control.  If I had to rank which tackle in this class had the best of both, it is Cleveland.  I am not comparing him to Joe Thomas, but that is how he moves.  Just smooth and easy, movement across the line never seems to disrupt his approach.  The issue?  He has short arms, lacks a true power game, and his body may not be ready in year one.  I can’t use a first rounder on someone like that and I don’t think he is in play at #36.  If NYG ends up with an early third or late second somehow, then we can talk.</span><br />
<br />
<span class="bold">6.	Josh Jones / Houston / 6’5 – 319<br />
<br />
Grade: 79</span><br />
<br />
Summary: Fifth year senior from Richmond, Texas.  A four year starter that earned 2nd Team All AAC honors in 2019.  Jones put together a really solid season and earned an invite to the Senior Bowl where he performed well all week against the stiffest competition he faced.  His length and power game are small red flags but he has the foot speed and techniques that can hide them.  He is a really smooth operator that knows and trusts himself.  He doesn’t over-set like most tackles do, he doesn’t abandon techniques when he doesn’t win the initial battle like most tackles do, and he still has ton of attainable upside to go before he is a finished product.  If he can improve his power game and continue to progress his skill set, he can be a longtime starter in the league.  With that said, he should be thrown in to the fire right away.<br />
<br />
<span class="italics">*I know a scout in the league that has Jones on the same tier as the top tackles in the draft.  While I don’t think that is a common opinion, I’m sure he isn’t the only one.  Jones is a really fluid and easy athlete on the outside that simply needs a key to the weight room.  I do think he can handle snaps right away, but I would prefer to him to wait at least half a season if possible.  Power guys are going to beat him up pretty good.  If he does enhance how own power game, he is a definite starter.</span><br />
<br />
<span class="bold">7.	Isaiah Wilson / Georgia / 6’6 – 350<br />
<br />
Grade: 78</span><br />
<br />
Summary: Redshirt sophomore entry from Brooklyn, New York.  Two year starter that missed 2 games in 2019 with an ankle injury.  2nd Team All SEC in 2019.  Wilson is a tools-rich tackle that still has a lot to learn and put in to practice.  He needs to take in NFL coaching so that his footwork can become second nature.  He has a lot of ugly tape in that department but when he does line things up, his combination of length and power can be dominant.  He is a high-upside prospect that shouldn’t be rushed in to action.<br />
<br />
<span class="italics">*For all the talk Becton gets about his size, I’m surprised Wilson isn’t more talked up.  He actually has a wider frame and the 350 pound mark is where I think Becton will come down to.  Wilson also has top-shelf length and hand power.  He is sloppy though, there is no denying it.  Wilson’s hands get really wide and he loses track of the width of his base at times.  However when he’s on, there isn’t a huge gap between him and Thomas and I mean that.  I wouldn’t be surprised to see him go in the top 40, but I would want to wait until the top of round 3 to take him.  I bet he’s gone by that point.</span><br />
<br />
<span class="bold">8.	Lucas Niang / TCU / 6’6 – 315<br />
<br />
Grade: 76</span><br />
<br />
Summary: Senior entry from New Canaan, Connecticut.  Three year starter that missed the second half of 2019 with a hip labrum injury that needed surgery.  Earned 2nd Team All Big 12 in 2018, the only season he started every game.  Niang’s size looks excellent on paper but he has work to do on his body.  As he continues to rehab from his surgery, Niang is going to need a sleeping bag in the weight room.  He doesn’t play an aggressive game and will too often try to catch defenders rather than impose his will.  There is a lot of natural talent to work with however, as he moves very well and produced based on athletic ability and size.  If he can combine that with more consistent footwork and effort, he has starter-potential.  He simply needs to apply himself in the weight room for a year and clean other areas up.<br />
<br />
<span class="italics">*This is an interesting prospect.  I had a hard time getting information on his hip injury and how much it impacted his play early in 2019.  He didn’t look like the same guy as I saw in 2018.  I had some really positive notes from his 2018 tape but it just didn’t match up.  There is a chance somebody is going to get a starting caliber right tackle here at the end of round 3 or early round 4.  You also have to account for the recovery from the hip injury, however.  A lot of things to consider in his evaluation but if NYG doesn’t address tackle with their first three picks and he is there at the start of round 4, it would be tough to pass on.</span><br />
<br />
<span class="bold">9.	Austin Jackson / USC / 6’5 – 322<br />
<br />
Grade: 75</span><br />
<br />
Summary: Junior entry.  Two year starter from Phoenix, Arizona.  Grandson of Melvin, a five-year NFL lineman.  First team All Pac 12 in 2019.  Jackson has the tools and initial movement off the snap with an aggressive playing style and hustle that will get coaches excited about working with him.  He can create solid torque and pop off the ball and he has enough athletic ability to play outside.  However a deeper look in to his game and there are several warts that absolutely need to be ironed out.  He needs a lot of core strength and balance work before he can be asked to handle NFL pass rushers.  His toughest opponents in college made him look silly at times, out of his league.  This is an upside-based prospect that will need a couple years.<br />
<br />
<span class="italics">*Jackson is impressive initially.  He has a good body and plays with good explosion off the snap.  He can really get on top of a guy and gain the initial advantage.  But when it comes to the secondary stuff, he was woefully inconsistent.  I really didn’t like him against his toughest competition.  Jackson has more reachable upside than a typical 4th/5th round grade, I will give him that.  However the natural imbalance just sticks to my memory too hard.</span><br />
<br />
<span class="bold">10.	Matt Peart / Connecticut / 6’7 – 318<br />
<br />
Grade: 75</span><br />
<br />
Summary: Fifth year senior from Kingston, Jamaica.  A four year starter who never missed a game.  1st Team All AAC honors as a senior.  Peart is relatively new to the game, as he didn’t play football until he started high school.  He is a physically gifted player that, when his feet are in the right place, showed dominant traits.  He has incredibly strong hands with long arms and an athletic base, he simply just needs to hammer away at his lower body mechanics until they become more natural and consistent.  If and when that happens, he is a starting caliber player.<br />
<br />
<span class="italics">*I did a quick recap of who Gettleman selected in his career as GM along the offensive line.  One glaring tendency was his desire for length at tackle.  Well, here you go.  Peart has the longest arms in the class and the widest frame.  Throw in the fact that he has a decently athletic lower body, and there is a chance he is going to hear his name called in round 2.  NYG is going to like him, I’m sure of it.  How much?  Not sure.  I personally see a guy that won’t be a factor in year one and he is going to need to really hammer away at lower body mechanics and power.  I couldn’t get past the 4th/5th round tier but I can see why some are higher on him because of the ceiling.</span><br />
<br />
<span class="bold">11.	Trey Adams / Washington / 6’8 – 318<br />
<br />
Grade: 72</span><br />
<br />
Summary: Fifth year senior entry from Wenatchee, Washington.  Four year starter that began his career on a high note.  Adams was a 1st Team All Pac 12 and 2nd Team All American as a sophomore in 2016.  However a back injury suffered in 2017 forced him to miss the second half of the year and the entire 2018 regular season.  Adams was once viewed as a no-doubt first round pick but questions surrounding his back injury and inconsistent play since he’s come back has made the outlook cloudy.  Adams is a plus-athlete with good size and aggression that plays smart and aware.  He has enough athletic ability to play tackle in the pros, but the medical screening and how it relates to his potential to add strength and power will mean a lot for his final grade.  He is going to need a year at least before he can be counted on as a starter.<br />
<br />
<span class="italics">*Adams was on his way toward being a sure-thing first round pick.  But the back injury that kept him out so long is going to knock is grade down a bug chunk, maybe even make him undraftable to some.  For me?  If you are sitting there in round 5 or 6 and you need a young tackle to try and develop, I pull the trigger on him.  He is a really feisty, nasty, aggressive blocker.  It will be considered lucky to see him get completely over the injury but one has to take chances late in the draft at times.  And to build a quality offensive line, you have to get lucky once or twice.</span>  <br />
<br />
<span class="bold">12.	Charlie Heck / North Carolina / 6’8 – 311<br />
<br />
Grade: 71</span><br />
<br />
Summary: Fifth year senior from Kansas City, Missouri.  A three year starter that finished his career as a 2nd Team All ACC tackle.  Heck has plenty of experience on both sides and shows the intelligence and natural ability to play on both sides in the NFL.  The son of Kansas City Chiefs offensive line coach, Andy Heck, Charlie has the look of an eventual starter once he can enhance his staying power and core strength.  He is outstanding off the ball but simply needs to clean up his hand placement and footwork that usually stems from his inconsistent pad level.  Once he cleans that up, there is starter-potential and in the mean time, he is a solid swing tackle for a team needing to add depth.<br />
<br />
<span class="italics">*I almost went 3 or 4 points higher on Heck.  I liked him a lot down the stretch and he was the best blocker at Shrine week.  There is a plus-athlete here and you know he understands the ins and outs of the game as well as anybody.  Heck’s height, like a couple others in this class, is a bit of an issue.  He doesn’t have a powerful base and its just hard for him to play with consistent knee bend and pad level.  That is a problem unless you have elite traits elsewhere, which he does not.</span><br />
<br />
<span class="bold">13.	Colton McKivitz / West Virginia / 6’6 – 306<br />
<br />
Grade: 71</span><br />
<br />
Summary: Fifth year senior from Jacobsburg, Ohio.  A four year starter that has played both tackle positions.  Two time Honorable Mention All Big 12 before being named 2nd Team in 2019.  Was also named 3rd Team All American as a senior.  McKivitz has average size and power that will need to be developed over the course of a year or two, but the former all state high school basketball player has light and quick feet with plus-balance.  Combine that with a strong will to win the one on one battles that doesn’t have an off switch, a case can be made he is one of the top tackles that will be available day three.  He won’t be ready right away, as he needs to improve his lower body power and hand strength, but if he can tidy those areas up he is proficient everywhere else.  Swing tackle candidate. <br />
<br />
<span class="italics">*McKivitz is an intriguing athlete that simply didn’t lose much in college.  He has plenty of work ahead to get his power presence up to par, but for a team that can stash him away for a year or two, there is a high ceiling.</span><br />
<br />
<span class="bold">14.	Yasir Durant / Missouri / 6’6 – 331<br />
<br />
Grade: 71</span><br />
<br />
Summary: Senior entry from Philadelphia, Pennsylvania.  Three year starter for Missouri that spent a season at Arizona Western Community College where he played guard and tackle.  Durant took over the left tackle job four weeks in to 2017 and never looked back.  He is going to cause a second look based on his size alone, as he is as wide as he is long.  This kind of blocker doesn’t need to be the most twitched up, fastest player on the field.  He is a tough guy to get around because of how well he stays within himself, how far his blocking radius extends to, and hoe powerful his punch can be.  He may not be a year one guy, as there are some lower body techniques that must be cleaned up, but Durant has a potential starter label on him at either tackle spot.<br />
<br />
<span class="italics">*Durant is really interesting.  It is widely known that he is going to struggle athletically, he is just a really heavy mover and the bend doesn’t come natural to him.  But you know what?  There aren’t many tackles that had higher graded tape, he just didn’t lose much.  I noticed how patient he works at Shrine week.  He just sits and waits, lets the defender make his move, and then calmly and powerfully reacts.  I think there is something to this kid.</span><br />
<br />
<span class="bold">15.	Robert Hunt / Louisiana-Lafayette / 6’5 – 323<br />
<br />
Grade: 71</span><br />
<br />
Summary: Fifth year senior entry from Burkeville, Texas.  Four year starter that has started games at left guard, left tackle, and right tackle.  Was named 2nd Team All Sun Belt in 2018, 1st Team in 2019 despite missing games with a groin injury.  Hunt projects to both tackle and guard at the next level.  He was a good high school basketball player and that kind of foot-speed and quickness shows up on the gridiron with his attractive, moldable frame.  He may not be ready for NFL action right away, as he has some footwork issues to clean up and lower body strength to pack on.  Depending on where he is drafted, however, he has the look of an eventual starter inside or outside.  It is hard to find guys with this kind of size, athletic ability, and body control capabilities.  His best tape came against his toughest competition, a good sign in relation to his long term projection.<br />
<br />
<span class="italics">*I originally had a 3rd round grade on Hunt as a tackle, but because of a medical, had to bring him down to round 5/6 region.  Good kid though and I am hoping for the best.  On the field, Hunt has the feet to play outside but some question his length.  Personally, I don’t see the move to guard because he plays too high and he isn’t stout enough.  If he clears the medical stage, I like him as a versatile backup that may need to sit for a year and enhance his strength.</span><br />
<br />
<span class="bold">16.	Tyre Phillips / Mississippi State: 70<br />
17.	 Aaron McKinney / TCU: 69<br />
18.	 Terence Steele / Texas Tech: 67<br />
19.	Darrin Paulo / Utah: 67<br />
20.	 Carter O’Donnell /Alberta: 66<br />
21.	Matt Womack / Alabama: 66<br />
22.	Alex Taylor / South Carolina State: 65<br />
23.	Drew Richmond / USC: 64<br />
24.	Jake Benzinger / Wake Forest: 63<br />
25.	Brandon Bowen / Ohio State: 61</span><br />
<br />
<span class="bold">NYG APPROACH</span><br />
<br />
It isn’t the sexy pick.  It isn’t the name you are going to see in the box score or the highlight reel.  You’re rarely going to walk away from a Giants win and talk about how good the tackles played.  All of that said, this team isn’t going anywhere unless this offensive line improves on the outside.  It would be one thing if they already had a solid piece on the left or right side.  It would be one thing if they already had an up and coming stud that was in the development stages.  The Giants have neither nor are they even close.  <br />
<br />
What is the point of drafting a Saquon Barkley #2 overall if you can’t get anyone up front to keep defenders out of the backfield?  Quite literally he is getting contacted by defenders before he takes his third step with the ball as much as any back in the league!  Daniel Jones was selected #6 overall and I have always believed the number one task to aid the maturation of a young quarterback is building the group up front.  Keep him upright.  Keep him confident.  Make it easier for him to hold on to the football!<br />
<br />
Credible and respectful arguments can be made to take defense, namely Simmons or Okudah, at #4.  I disagree that it is the best path.  While I am fully aware the NYG defense needs work, I think the offensive line is more important and NYG is absolutely hopeless at tackle right now.  Throw in the fact that I have a Pro Bowl projection on Wirfs and Wills, the decision is even easier.  Only a godsend like Chase Young being available will change my mind.<br />
 </div></div></div></div><div class="thread_right"><div id="ad_side_box">


<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id='usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general'>
     <script type='text/javascript'>
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general');
         });
     </script>
</div>




</div></div><div class="thread_comment_container"><div class="thread_post"><div class="thread_post_header"><b>Thank you Sy! </b><a name="14865827">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JohnB"> JohnB </a>  :  4/12/2020  8:37 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865827">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>awesome writeup </b><a name="14865828">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Allen+in+CNJ"> Allen in CNJ </a>  :  4/12/2020  8:38 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865828">link</a>   </div></div><div class="thread_post_body">Sy, love it.  You have tremendous credibility here.  I love Simmons, but I'm on the fence about the tackles.  Gotta read this over again and I will try to let you change my mind on Simmons!</div></div><div class="thread_post"><div class="thread_post_header"><b>Sy'56 </b><a name="14865832">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  :  4/12/2020  8:42 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865832">link</a>   </div></div><div class="thread_post_body">Hey, thanks for all the great work and info.<br />
<br />
I have 3 questions:<br />
<br />
1. Do you mind if I put all of these writeups into a spreadsheet to organize everything for all those on BBI? It helps during the draft.<br />
<br />
It is done (at least for the positions you have done so far). If you want to see it before I post a link you can email me. My email is my user name @yahoo.com.<br />
<br />
<br />
2. Would it be possible to get more than 15 writeups from the WR group since we know this is a very special/unique situation with the amount of depth at the position?<br />
<br />
<br />
3.When putting all of your grades together I noticed one school kept popping up outside of the normal ones like Alabama and that was Utah. Was their whole defense eligible for this draft? Were they that good?<br />
<br />
Thanks again.</div></div><div class="thread_post"><div class="thread_post_header"><b>Wirfs it is then </b><a name="14865835">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GFAN52"> GFAN52 </a>  :  4/12/2020  8:44 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865835">link</a>   </div></div><div class="thread_post_body">Would be nice if possible to work a trade with Miami and get him at 5 and pick up a 2nd or 3rd pick in the process.</div></div><div class="thread_post"><div class="thread_post_header"><b>That Yasir Durant evil is really interesting.  </b><a name="14865836">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=cosmicj"> cosmicj </a>  :  4/12/2020  8:45 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865836">link</a>   </div></div><div class="thread_post_body">Sy - I know that conference doesn’t exactly have a rep for stellar defense but care to comment about how Durant did against the better ERs he faced?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Sy'56 </b><a name="14865839">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  8:46 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865839">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865832" target="_blank">14865832</a> robbieballs2003 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Hey, thanks for all the great work and info.<br />
<br />
I have 3 questions:<br />
<br />
1. Do you mind if I put all of these writeups into a spreadsheet to organize everything for all those on BBI? It helps during the draft.<br />
<br />
It is done (at least for the positions you have done so far). If you want to see it before I post a link you can email me. My email is my user name @yahoo.com.<br />
<br />
<br />
2. Would it be possible to get more than 15 writeups from the WR group since we know this is a very special/unique situation with the amount of depth at the position?<br />
<br />
<br />
3.When putting all of your grades together I noticed one school kept popping up outside of the normal ones like Alabama and that was Utah. Was their whole defense eligible for this draft? Were they that good?<br />
<br />
Thanks again. </td>
                                </tr>
                           </table><br />
<br />
1) Fine with me...<br />
<br />
2) I will see how much time I have - few things going on work wise and personally but I can see if I can get 20-25 write ups done at WR.  If not - people can always ask about specific guys and I can post my summary on him.<br />
<br />
3) Utah defense was a popular discussion among scouts.  They may have more defenders drafted than Bama / LSU / Ohio State respectively.  They don't have the top tier guys - but a bunch of day 2 and day 3 picks.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Wirfs it is then </b><a name="14865840">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  8:47 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865840">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865835" target="_blank">14865835</a> GFAN52 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Would be nice if possible to work a trade with Miami and get him at 5 and pick up a 2nd or 3rd pick in the process. </td>
                                </tr>
                           </table><br />
<br />
Ideally yes, a trade down 1-2 spots would be nice if you can still get Wirfs.  Not sure you are getting a day 2 pick for that unless it turns in to a legit bidding war.  Best bet is an extra 4th and then NYG can use that to trade up in 3rd if desired.</div></div><div class="thread_post"><div class="thread_post_header"><b>Had a feeling Sy would rate Wirfs over Wills ever so slightly </b><a name="14865841">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Rick+in+Dallas"> Rick in Dallas </a>  :  4/12/2020  8:48 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865841">link</a>   </div></div><div class="thread_post_body">I really feel DG will pick one of these 2 guys at number 4.<br />
Frank Coyle also has Wirfs rated as the number 1 OT in this draft and he also thinks DG will draft Wirfs at number 4.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: That Yasir Durant evil is really interesting.  </b><a name="14865842">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  8:48 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865842">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865836" target="_blank">14865836</a> cosmicj said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Sy - I know that conference doesn’t exactly have a rep for stellar defense but care to comment about how Durant did against the better ERs he faced? </td>
                                </tr>
                           </table><br />
<br />
Well Missouri is in the SEC now...so he did face some solid competition.  The thing that makes him a tough eval is the fact that offense got the ball out so fast, so often.  All in though, he didn't lose much.</div></div><div class="thread_post"><div class="thread_post_header"><b>Thanks Sy </b><a name="14865843">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Oscar"> Oscar </a>  :  4/12/2020  8:49 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865843">link</a>   </div></div><div class="thread_post_body">I keep going back and forth but I think your logic is sound. If the Giants have a top grade on a tackle they need to make the pick. Simmons might be great but as you said this pick is also about maximizing Barkley and Jones.</div></div><div class="thread_post"><div class="thread_post_header"><b>Thanks Sy </b><a name="14865844">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eli+Wilson"> Eli Wilson </a>  :  4/12/2020  8:50 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865844">link</a>   </div></div><div class="thread_post_body">I've been waiting for this one.</div></div><div class="thread_post"><div class="thread_post_header"><b>Thanks Sy </b><a name="14865846">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Mike+in+NJ"> Mike in NJ </a>  :  4/12/2020  8:52 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865846">link</a>   </div></div><div class="thread_post_body">I have seen a lot of talk that Wirfs projects well as a tackle but would be even better, potential All-Pro caliber, at G. Did you grade him out there as well, how does he compare to the other top inside guys in the draft?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Sy'56 </b><a name="14865849">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  :  4/12/2020  8:53 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865849">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865839" target="_blank">14865839</a> Sy'56 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14865832 robbieballs2003 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Hey, thanks for all the great work and info.<br />
<br />
I have 3 questions:<br />
<br />
1. Do you mind if I put all of these writeups into a spreadsheet to organize everything for all those on BBI? It helps during the draft.<br />
<br />
It is done (at least for the positions you have done so far). If you want to see it before I post a link you can email me. My email is my user name @yahoo.com.<br />
<br />
<br />
2. Would it be possible to get more than 15 writeups from the WR group since we know this is a very special/unique situation with the amount of depth at the position?<br />
<br />
<br />
3.When putting all of your grades together I noticed one school kept popping up outside of the normal ones like Alabama and that was Utah. Was their whole defense eligible for this draft? Were they that good?<br />
<br />
Thanks again. <br />
                                <br />
                           <br />
<br />
1) Fine with me...<br />
<br />
2) I will see how much time I have - few things going on work wise and personally but I can see if I can get 20-25 write ups done at WR.  If not - people can always ask about specific guys and I can post my summary on him.<br />
<br />
3) Utah defense was a popular discussion among scouts.  They may have more defenders drafted than Bama / LSU / Ohio State respectively.  They don't have the top tier guys - but a bunch of day 2 and day 3 picks. </td>
                                </tr>
                           </table><br />
<br />
Awesome. Thanks. I titled it with your name to give you credit and linked Ourlads on the Grade Scale page to give credit where credit is due. If you want anything changed just let me know.<br><a href="https://docs.google.com/spreadsheets/d/1BzoSlGR3zr73bPb_enxT_sRqUdXBZbl-1q25pDlHHDg/edit?usp=sharing"> Link </a> - (<a href="https://docs.google.com/spreadsheets/d/1BzoSlGR3zr73bPb_enxT_sRqUdXBZbl-1q25pDlHHDg/edit?usp=sharing" target="_NEW"> New Window </a>)</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Thanks Sy </b><a name="14865850">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  8:54 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865850">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865846" target="_blank">14865846</a> Mike in NJ said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I have seen a lot of talk that Wirfs projects well as a tackle but would be even better, potential All-Pro caliber, at G. Did you grade him out there as well, how does he compare to the other top inside guys in the draft? </td>
                                </tr>
                           </table><br />
<br />
I didn't bother - only because he didn't have any snaps at OG.  If it didn't work out at tackle and he moved inside and played to a Pro Bowl level there?  Still a successful pick in my eyes.</div></div><div class="thread_post"><div class="thread_post_header"><b>Great writeup Sy.  </b><a name="14865851">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Earl+the+goat"> Earl the goat </a>  :  4/12/2020  8:55 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865851">link</a>   </div></div><div class="thread_post_body">I was willing to bet that you would’ve had Becton first <br />
<br />
If Giants don’t go OT at 4.   I would be happy with Peart or Wilson or Durant in latter rounds hoping one of them takes over for Solder</div></div><div class="thread_post"><div class="thread_post_header"><b>Ok, You convinced me. </b><a name="14865853">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=section125"> section125 </a>  :  4/12/2020  8:56 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865853">link</a>   </div></div><div class="thread_post_body">I was really on the fence between Simmons and OT. Seems that many at BBI got it right between Wirfs/Wills and Thomas/Becton.<br />
<br />
I do have a feeling that DG goes to protect Jones and Barkley this year. With Wirfs and Wills ratings(who knows what the Giants have) I also doubt they move past 6 or 7 if there is a trade back. No way they risk losing Wirfs and Wills. Personally, I like Iowa OL. They seem well taught.<br />
<br />
Also, there looks like there is hope in the 3rd or 4th rounds for projects, guys close to being ready by mid-season or next year.<br />
<br />
Great work as usual Sy. Thanks</div></div><div class="thread_post"><div class="thread_post_header"><b>I have a feeling OLine will still be a must for Giants  </b><a name="14865855">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Earl+the+goat"> Earl the goat </a>  :  4/12/2020  8:57 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865855">link</a>   </div></div><div class="thread_post_body">And Creed Humphreys and the LT for Oregon will be at the top of the list</div></div><div class="thread_post"><div class="thread_post_header"><b>NYG Approach section  </b><a name="14865856">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  :  4/12/2020  8:57 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865856">link</a>   </div></div><div class="thread_post_body">is exactly what I would have written. <br />
<br />
And probably did a few times.  :-)<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>As someone who has leaned taking Simmons.. </b><a name="14865857">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sean"> Sean </a>  :  4/12/2020  8:57 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865857">link</a>   </div></div><div class="thread_post_body">This write up has me excited about the prospect of Wirfs or Wills at 4.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Great writeup Sy.  </b><a name="14865858">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  8:57 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865858">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865851" target="_blank">14865851</a> Earl the goat said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I was willing to bet that you would’ve had Becton first <br />
<br />
If Giants don’t go OT at 4.   I would be happy with Peart or Wilson or Durant in latter rounds hoping one of them takes over for Solder </td>
                                </tr>
                           </table><br />
<br />
I'll say this about Becton<br />
<br />
If he played all year like he did early in the season against Notre Dame and there weren't any medical red flags, he would be up there.<br />
<br />
But his techniques regressed as the year went on, something about that I just don't like.  Relying on talent.  There is absolutely no denying his upside though, there is a lot of "rare" in him</div></div><div class="thread_post"><div class="thread_post_header"><b>Thanks Sy </b><a name="14865860">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=US1+Giants"> US1 Giants </a>  :  4/12/2020  8:59 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865860">link</a>   </div></div><div class="thread_post_body">Great info. I love defense but if the Giants go with a tackle than I can get excited after seeing your rankings.  Would love to add difference maker to the defense though.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Also remember this: </b><a name="14865861">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  8:59 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865861">link</a>   </div></div><div class="thread_post_body">This is what I think NYG should do.<br />
<br />
In relation to what I think Gettleman likes - there isa good chance Andrew Thomas or Becton is his guy.  At 4.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Thanks Sy </b><a name="14865862">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  9:00 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865862">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865860" target="_blank">14865860</a> US1 Giants said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Great info. I love defense but if the Giants go with a tackle than I can get excited after seeing your rankings.  Would love to add difference maker to the defense though. </td>
                                </tr>
                           </table><br />
<br />
Trust me - I know they need a difference maker.  I'm not gonna be flipping any table or "throwing any remotes" if they opt for defense at 4.<br />
<br />
That said, I see a legit difference maker being there at 36.  EDGE or safety, maybe even a CB.</div></div><div class="thread_post"><div class="thread_post_header"><b>Thank You </b><a name="14865863">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=PaulN"> PaulN </a>  :  4/12/2020  9:00 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865863">link</a>   </div></div><div class="thread_post_body">Sy, I love the work and analysis you put in, you make the draft so much more enjoyable.</div></div><div class="thread_post"><div class="thread_post_header"><b>the choice between Simmons and a tackle </b><a name="14865867">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Peter+from+NH+%28formerly+CT%29"> Peter from NH (formerly CT) </a>  :  4/12/2020  9:05 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865867">link</a>   </div></div><div class="thread_post_body">is a really tough one.  Of course, they may not even have that choice at the end of the day.</div></div><div class="thread_post"><div class="thread_post_header"><b>@robbieballs2003 </b><a name="14865869">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eli+Wilson"> Eli Wilson </a>  :  4/12/2020  9:09 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865869">link</a>   </div></div><div class="thread_post_body">Thanks for doing that. Really well done.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Also remember this: </b><a name="14865870">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Doubledeuce22"> Doubledeuce22 </a>  :  4/12/2020  9:10 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865870">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865861" target="_blank">14865861</a> Sy'56 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> This is what I think NYG should do.<br />
<br />
In relation to what I think Gettleman likes - there isa good chance Andrew Thomas or Becton is his guy.  At 4. </td>
                                </tr>
                           </table><br />
<br />
Either of them at 4 would be an absolute remote thrower for me. I’m growing very tired of the fans having a better pulse on drafts than the Giants front office hence why we have been so poor lately. I’m quite confident that Sy would have built a better team in the draft at least over the past 7 years. Let’s hope Wirfs is the pick and that we can pick up some assets by moving down a few spots to get him.</div></div><div class="thread_post"><div class="thread_post_header"><b>Thanks Sy </b><a name="14865871">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=aGiantGuy"> aGiantGuy </a>  :  4/12/2020  9:10 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865871">link</a>   </div></div><div class="thread_post_body">Good insight</div></div><div class="thread_post"><div class="thread_post_header"><b>Sy-question if I may? </b><a name="14865873">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Tom+in+Kzoo"> Tom in Kzoo </a>  :  4/12/2020  9:10 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865873">link</a>   </div></div><div class="thread_post_body">First love your review. Mirrors Daniel Jeramiah's take on team building from the other day, with which I (reluctantly ) concur. <br />
<br />
I've watched several youtube,etc. reviews of the tackles and Wills impressed me the most with his technique. Wirfs, for all his gifts ,scares me with his narrow unbalanced pass sets, and lack of awareness of stunting D linemen.  <br />
<br />
The question: how do you assess which deficiencies are fixable when it comes to recurrent bad O-lineman behavior, and which arew not? I fear some behaviors are ingrained, and shouldn't be expected to change(see Erick Flowers) , but struggle with which are more easily fixable.  <br />
<br />
Thanks. BTW, any small school guys/ sleepers you wish to throw in the mix late in draft?</div></div><div class="thread_post"><div class="thread_post_header"><b>Thanks Sy. </b><a name="14865875">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=johnnyb"> johnnyb </a>  :  4/12/2020  9:11 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865875">link</a>   </div></div><div class="thread_post_body">I have been 8n favor of the Giants taking Wirks over Simmons or Okudah and your write up confirms it. The Giants NEED an OT to maximize Barkley’s talents and keep Jones upright. If the OL is not fixed this team will never compete.<br />
<br />
It starts here at number 4- OT Triston Wirfs.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Also remember this: </b><a name="14865878">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=section125"> section125 </a>  :  4/12/2020  9:15 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865878">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865861" target="_blank">14865861</a> Sy'56 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> This is what I think NYG should do.<br />
<br />
In relation to what I think Gettleman likes - there isa good chance Andrew Thomas or Becton is his guy.  At 4. </td>
                                </tr>
                           </table><br />
<br />
This is where I see Judge "stepping in" and arguing fo a start right now OT. I am by no means a talent evaluator, but it was clear to me Becton relied a little too much on his size and power and seemed to bend a little too much at waist. He will not get away with that in the NFL. Yes absolutely that power and size are enticing. I think they go for a more blemish free tackle. Most likely to not fail even if upside is slightly less - because at that level there isn't that much difference. I think Becton is out unless they get some mega deal to move back past 7th. And if Thomas has a tendency to get lazy I think that will be a red flag for Judge.<br />
IMHO</div></div><div class="thread_post"><div class="thread_post_header"><b>Interesting red flag </b><a name="14865881">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=XBRONX"> XBRONX </a>  :  4/12/2020  9:16 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865881">link</a>   </div></div><div class="thread_post_body">about Becton willingness to work. No thanks big man.</div></div><div class="thread_post"><div class="thread_post_header"><b>I thought there was a rumor out of the combine </b><a name="14865882">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Peter+from+NH+%28formerly+CT%29"> Peter from NH (formerly CT) </a>  :  4/12/2020  9:17 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865882">link</a>   </div></div><div class="thread_post_body">that Gettleman loved Wirfs</div></div><div class="thread_post"><div class="thread_post_header"><b>Thanks SY </b><a name="14865887">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=UGADawgs7"> UGADawgs7 </a>  :  4/12/2020  9:26 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865887">link</a>   </div></div><div class="thread_post_body">Been waiting. You mentioned which many can agree on, is IF somehow Chase Young falls to 4, that’s the only way to pass on an OT at 4 barring a minimal trade down to gain another asset. If he does fall, who do you see as NYG going with at 36 of these tackles?<br />
Cleveland <br />
Wilson<br />
Jones <br />
Jackson<br />
Peart(although you mentioned hopefully this is a project 4/5 round guy) <br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Sy, is this the best OT class in the last 10 years. </b><a name="14865889">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Rick+in+Dallas"> Rick in Dallas </a>  :  4/12/2020  9:30 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865889">link</a>   </div></div><div class="thread_post_body">Thanks for all your hard work.</div></div><div class="thread_post"><div class="thread_post_header"><b>Thanks Sy </b><a name="14865890">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=dune69"> dune69 </a>  :  4/12/2020  9:33 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865890">link</a>   </div></div><div class="thread_post_body">for great info and all the extra work you do for us.<br />
<br />
Robbie; thanks for putting the spreadsheet together from Sy's ratings. This will be a great draft day tool (again).</div></div><div class="thread_post"><div class="thread_post_header"><b>Thanks for this Sy..incredible work.  </b><a name="14865891">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Blue21"> Blue21 </a>  :  4/12/2020  9:33 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865891">link</a>   </div></div><div class="thread_post_body">Based on everything I've been reading, I've been torn between Simmons an OT and tossed around which OT would be best. After this I'm 100% sold on Wirfs at 4. Let's get this Oline built finally.</div></div><div class="thread_post"><div class="thread_post_header"><b>Great breakdown .....but wow, more confused than ever! </b><a name="14865894">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=edavisiii"> edavisiii </a>  :  4/12/2020  9:35 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865894">link</a>   </div></div><div class="thread_post_body">In a perfect world the tackles and stud defensive guys are even and we take the tackle.  But we got Chase Young at 91, Simmons at 89, and Wirfs at 86.  I have heard more than one person say some teams (not the majority, but some) have Simmons as the #1 on the board.  I wish this draft would just get here.  In the end its going to be what is on DG's board!</div></div><div class="thread_post"><div class="thread_post_header"><b>Thank you again, Sy! </b><a name="14865905">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=DonnieD89"> DonnieD89 </a>  :  4/12/2020  9:44 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865905">link</a>   </div></div><div class="thread_post_body">I was one of the people who were on the fence between Simmons and an OT.  Your logic is very sound, convincing and assuring.  I am now in the OT camp. Given what you said, I went through your past grading of OT‘s through the past five years. I only saw one high-grade and you had Erik Fisher at a 90. That is close All Pro level, according to your grading system.  Do you think Tristan Wirfs at LOT could be an All Pro, if he can correct his balance and timing issues?  Another question, analysts have said that Jedrick Wills has maxed out with his potential. I really don’t believe that. What is your opinion?</div></div><div class="thread_post"><div class="thread_post_header"><b>Sy'56 </b><a name="14865921">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=M.S."> M.S. </a>  :  4/12/2020  9:59 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865921">link</a>   </div></div><div class="thread_post_body"><br />
Always a pleasure to read your write-ups!<br />
<br />
Question: Are there any OTs you've reviewed that kinda, sorta, maybe remind you a little of Ereck Flowers and thus may wash out at tackle?<br />
<br />
Thanks again for all your thoughts and insights!</div></div><div class="thread_post"><div class="thread_post_header"><b>Happy Easter and thanks for the write up </b><a name="14865931">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Biteymax22"> Biteymax22 </a>  :  4/12/2020  10:10 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865931">link</a>   </div></div><div class="thread_post_body">Sign me up for Wirfs at 4, a center in the 3rd and a guy like Peart in the 4th.  <br />
<br />
Defense can have the other 7 picks to cluster draft edge rushers, linebackers and a rangy safety.</div></div><div class="thread_post"><div class="thread_post_header"><b>How far down can the Giants trade? </b><a name="14865932">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=US1+Giants"> US1 Giants </a>  :  4/12/2020  10:13 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865932">link</a>   </div></div><div class="thread_post_body">and still get one of the top tackles?</div></div><div class="thread_post"><div class="thread_post_header"><b>I've often seen </b><a name="14865938">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=NYG22"> NYG22 </a>  :  4/12/2020  10:22 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865938">link</a>   </div></div><div class="thread_post_body">Matt Peat and Alex Taylor grouped together as physically gifted, exceptionally long but very raw players....but your write-up shows a major gap. Can you compare and contrast the two please?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: How far down can the Giants trade? </b><a name="14865941">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  4/12/2020  10:26 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865941">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865932" target="_blank">14865932</a> US1 Giants said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> and still get one of the top tackles? </td>
                                </tr>
                           </table><br />
<br />
Nostradamus is dead.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Sy'56 </b><a name="14865943">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=nyjuggernaut2"> nyjuggernaut2 </a>  :  4/12/2020  10:27 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865943">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865921" target="_blank">14865921</a> M.S. said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br />
Always a pleasure to read your write-ups!<br />
<br />
Question: Are there any OTs you've reviewed that kinda, sorta, maybe remind you a little of Ereck Flowers and thus may wash out at tackle?<br />
<br />
Thanks again for all your thoughts and insights! </td>
                                </tr>
                           </table><br />
<br />
Based on his write up I would say Thomas. Inconsistent effort, and struggled to reach his point against speed rushers sounds a lot like Erik Flowers weaknesses.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: How far down can the Giants trade? </b><a name="14865949">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=US1+Giants"> US1 Giants </a>  :  4/12/2020  10:29 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865949">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865941" target="_blank">14865941</a> Eric from BBI said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14865932 US1 Giants said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     and still get one of the top tackles? <br />
                                <br />
                           <br />
<br />
Nostradamus is dead. </td>
                                </tr>
                           </table><br />
<br />
there are 4 top tackles so down to 7 at a minimum and probably more I would guess.  Would definitely like a trade down if taking a tackle with so many top guys available there.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Great work Sy! </b><a name="14865951">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=nyjuggernaut2"> nyjuggernaut2 </a>  :  4/12/2020  10:31 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865951">link</a>   </div></div><div class="thread_post_body">Your write up at the end on the Giants approach is spot on! Building the OL and protecting Daniel Jones is key to both his development and the success of the team moving forward.</div></div><div class="thread_post"><div class="thread_post_header"><b>Damn.  Just when I warming up to the idea of drafting Simmons at #4. </b><a name="14865959">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Klaatu"> Klaatu </a>  :  4/12/2020  10:39 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865959">link</a>   </div></div><div class="thread_post_body">I guess it's back to the drawing board for me.</div></div><div class="thread_post"><div class="thread_post_header"><b>Thanks so much, Sy. </b><a name="14865965">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BigBlueNH"> BigBlueNH </a>  :  4/12/2020  10:42 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865965">link</a>   </div></div><div class="thread_post_body">My eyes told me Wills and Wirfs, well ahead of the other two, and it makes me feel much more comfortable that your more educated eyes see it the same way.  If the Giants take either one, I'll be very happy - happier if it is after a trade down.  Also makes me happy that your grades are high, indicating we would not be "reaching" if we took one of those 2 at #4.</div></div><div class="thread_post"><div class="thread_post_header"><b>Scott Pioli and Francesa both love Wirfs  </b><a name="14865966">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=The_Boss"> The_Boss </a>  :  4/12/2020  10:43 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865966">link</a>   </div></div><div class="thread_post_body">So he’s probably gonna bust....<br />
<br />
<br />
😆</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: How far down can the Giants trade? </b><a name="14865967">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GFAN52"> GFAN52 </a>  :  4/12/2020  10:43 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865967">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865932" target="_blank">14865932</a> US1 Giants said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> and still get one of the top tackles? </td>
                                </tr>
                           </table><br />
<br />
Depends how closely the Giants have the top tackles ranked on their draft board.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Also remember this: </b><a name="14865970">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=The_Boss"> The_Boss </a>  :  4/12/2020  10:46 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865970">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865861" target="_blank">14865861</a> Sy'56 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> This is what I think NYG should do.<br />
<br />
In relation to what I think Gettleman likes - there isa good chance Andrew Thomas or Becton is his guy.  At 4. </td>
                                </tr>
                           </table><br />
<br />
I’ve been feeling for about a week now, not sure why, that Thomas is Dave’s guy in the end.</div></div><div class="thread_post"><div class="thread_post_header"><b>Sy....this is the grouping that interest me the most. TY </b><a name="14865973">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=George+from+PA"> George from PA </a>  :  4/12/2020  10:48 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865973">link</a>   </div></div><div class="thread_post_body">I figured Chase Young or OT. Simmons is another luxury, that the Giants just do have right now.<br />
<br />
But very interested with the tier two guys....as I expect more then one OT drafted....and DG has a reputation of finding mid round gems....</div></div><div class="thread_post"><div class="thread_post_header"><b>General draft question </b><a name="14865975">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=XBRONX"> XBRONX </a>  :  4/12/2020  10:48 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865975">link</a>   </div></div><div class="thread_post_body">Do any teams take input on draft from their position coaches? Would Colombo get any input?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: How far down can the Giants trade? </b><a name="14865976">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  :  4/12/2020  10:49 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865976">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865932" target="_blank">14865932</a> US1 Giants said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> and still get one of the top tackles? </td>
                                </tr>
                           </table><br />
<br />
If you believe the posters that demand an OT, probably around #9. If you follow the folks that can't live without Simmons or Okudah, probably around #36.<br />
<br />
There's your BBI range.</div></div><div class="thread_post"><div class="thread_post_header"><b>DG </b><a name="14865988">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=XBRONX"> XBRONX </a>  :  4/12/2020  10:57 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865988">link</a>   </div></div><div class="thread_post_body">finds mid round gems? You are talking about a third rounder and a fourth rounder,right?</div></div><div class="thread_post"><div class="thread_post_header"><b>This is the position breakdown I was looking forward to the most </b><a name="14865992">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jay+on+the+Island"> Jay on the Island </a>  :  4/12/2020  10:59 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865992">link</a>   </div></div><div class="thread_post_body">All offseason I have wanted the Giants to draft two offensive tackles this year.  One in round 1 or 2 plus a developmental one in the 3-5 round range. Tristan Wirfs in round 1 and then select Matt Peart, Lucas Niang, Trey Adams, or Charlie Heck early on day 3.  <br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: DG </b><a name="14865995">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=The_Boss"> The_Boss </a>  :  4/12/2020  11:01 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865995">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865988" target="_blank">14865988</a> XBRONX said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> finds mid round gems? You are talking about a third rounder and a fourth rounder,right? </td>
                                </tr>
                           </table><br />
<br />
I’ve always thought “mid rounds” to be rounds 4-5.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: DG </b><a name="14865998">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jay+on+the+Island"> Jay on the Island </a>  :  4/12/2020  11:03 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14865998">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865988" target="_blank">14865988</a> XBRONX said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> finds mid round gems? You are talking about a third rounder and a fourth rounder,right? </td>
                                </tr>
                           </table><br />
Gettleman took former all-pro OL G Trai Turner in round 3 and RT Daryl Williams in round 4.  He also signed Andrew Norwell as an UDFA and Mike Remmers off the Rams practice squad.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: DG </b><a name="14866000">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jay+on+the+Island"> Jay on the Island </a>  :  4/12/2020  11:04 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866000">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865995" target="_blank">14865995</a> The_Boss said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14865988 XBRONX said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     finds mid round gems? You are talking about a third rounder and a fourth rounder,right? <br />
                                <br />
                           <br />
<br />
I’ve always thought “mid rounds” to be rounds 4-5. </td>
                                </tr>
                           </table><br />
Same here.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I've often seen </b><a name="14866005">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jay+on+the+Island"> Jay on the Island </a>  :  4/12/2020  11:07 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866005">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865938" target="_blank">14865938</a> NYG22 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Matt Peat and Alex Taylor grouped together as physically gifted, exceptionally long but very raw players....but your write-up shows a major gap. Can you compare and contrast the two please? </td>
                                </tr>
                           </table><br />
Good question.  I liked the idea of adding Alex Taylor on day 3 as a developmental type due to reports of his excellent athleticism but raw technique.  Now that the Giants have added a good offensive line coach I would like to see the Giants give him some talented but raw OL to try to mold them into starters.</div></div><div class="thread_post"><div class="thread_post_header"><b>the irony....and the logic </b><a name="14866007">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ColHowPepper"> ColHowPepper </a>  :  4/12/2020  11:08 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866007">link</a>   </div></div><div class="thread_post_body">Sy', just adding my appreciation and thanks for your work: this is the season that must really get your juices flowing, more than any other time of year, pretty cool!<br />
<br />
Irony: those in the Simmons camp--and there are many reasons to be so--like to cite how many 1st Round picks were used on O, citing specifically the past two years, ergo, it's time to go D<br />
<br />
Logic: those in the OL camp (include myself) urge that the draft capital at key O positions will crash and burn if there are not enabling pieces in front of them. The OL has beggared this team for eight years. Your assessment of the T pieces is inarguable and frightening, can't hide from it.</div></div><div class="thread_post"><div class="thread_post_header"><b>Technically guys... in a 7 round draft </b><a name="14866010">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=90.Cal"> 90.Cal </a>  :  4/12/2020  11:10 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866010">link</a>   </div></div><div class="thread_post_body">The 4th round is "the mid round" as it is in the middle...<br />
<br />
"Mid rounds"... different from "mid round"... would technically mean rounds 3-5 and not just round 4 and 5...<br />
<br />
Your welcome</div></div><div class="thread_post"><div class="thread_post_header"><b>How much better was Jonah Williams than Wills (not just grade #) </b><a name="14866017">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=90.Cal"> 90.Cal </a>  :  4/12/2020  11:15 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866017">link</a>   </div></div><div class="thread_post_body">& what is your thoughts on this OL figuration if Wirfs is the pick.<br />
<br />
<br />
LT - Wirfs - LG - Hernandez - OC Ruiz/Hennessy - RG - Zeitler - RT Solder</div></div><div class="thread_post"><div class="thread_post_header"><b>Interesting that you said Becton didn't have a healthy back </b><a name="14866018">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BigBlueCane"> BigBlueCane </a>  :  4/12/2020  11:16 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866018">link</a>   </div></div><div class="thread_post_body">and then pointed out his technique declined, likely due to his back.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>If they go Becton or Thomas  </b><a name="14866019">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  4/12/2020  11:18 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866019">link</a>   </div></div><div class="thread_post_body">That would be somewhat of a difference from what DG has been doing so far in the drafts in the early rounds. Perhaps Jones was the outlier but he has taken the pro ready character guys that have zero work ethic issues. And guys that are “competitors” through and through. Barkley, Jones, and Lawrence have that...jury is out on Baker. But from the write ups, Thomas and Becton may not have that competitive fire in them. That is just conjecture though....who the hell knows.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: How much better was Jonah Williams than Wills (not just grade #) </b><a name="14866020">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  :  4/12/2020  11:19 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866020">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866017" target="_blank">14866017</a> 90.Cal said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> & what is your thoughts on this OL figuration if Wirfs is the pick.<br />
<br />
<br />
LT - Wirfs - LG - Hernandez - OC Ruiz/Hennessy - RG - Zeitler - RT Solder </td>
                                </tr>
                           </table><br />
<br />
I really don't see that as an option. With Solder still here it doesn't make sense to move him to RT. Moving from one side of the line to the other is harder than going from OT to G. If Wirfs plays LT I would assume that would be in his second year and we have moved on from Solder. <br />
<br />
Also, if you had a rookie OT would you want him next to Hernandez or Zeitler?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Interesting that you said Becton didn't have a healthy back </b><a name="14866025">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jon+in+NYC"> Jon in NYC </a>  :  4/12/2020  11:22 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866025">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866018" target="_blank">14866018</a> BigBlueCane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> and then pointed out his technique declined, likely due to his back.<br />
 </td>
                                </tr>
                           </table><br />
<br />
Unfortunately if you have back problems at 20, they're unlikely to get better as you age. Part of the reason I'd steer clear. Just too large and probably subject to a ton of injury woes.</div></div><div class="thread_post"><div class="thread_post_header"><b>Also </b><a name="14866026">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  :  4/12/2020  11:23 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866026">link</a>   </div></div><div class="thread_post_body">we need to get rid of the mentality that LT is so much more important than RT. They are both extremely important and with the amount of shotgun snaps teams run there really isn't a blindside anymore. If you have a tradition offense where the QB is under center and going through his 3, 5, 7 step drops then yes LT holds more weight. But with defenses moving their best pass rushers all over the place and a lot of times over the RT then both positions are of extreme importance.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: How much better was Jonah Williams than Wills (not just grade #) </b><a name="14866030">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  :  4/12/2020  11:24 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866030">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866017" target="_blank">14866017</a> 90.Cal said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> & what is your thoughts on this OL figuration if Wirfs is the pick.<br />
<br />
<br />
LT - Wirfs - LG - Hernandez - OC Ruiz/Hennessy - RG - Zeitler - RT Solder </td>
                                </tr>
                           </table><br />
<br />
Would suggest that if OT is the pick, they go to right side to begin with unless Solder is a natural at switching over (which is tough to believe).</div></div><div class="thread_post"><div class="thread_post_header"><b>I would </b><a name="14866040">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=TommyWiseau"> TommyWiseau </a>  :  4/12/2020  11:31 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866040">link</a>   </div></div><div class="thread_post_body">be happy with Wirfs or Simmons. Becton scares me a bit</div></div><div class="thread_post"><div class="thread_post_header"><b>Becton would be off the board  </b><a name="14866042">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  4/12/2020  11:33 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866042">link</a>   </div></div><div class="thread_post_body">for me. The way our team is constructed with Jones and Barkley now in their rookie deals, we really don’t need to take a chance on the guy that could be “rare” but could ask struggle with injuries/weight/technique. We need to find the guy that’s gonna just be an awesome tackle for 5 years and put in the work week after week. I think that guy is Wirfs or Wills.</div></div><div class="thread_post"><div class="thread_post_header"><b>And by off the board I  </b><a name="14866043">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  4/12/2020  11:33 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866043">link</a>   </div></div><div class="thread_post_body">mean off the board at 4. You take a pick that doesn’t pan out that high and it is just an absolute roster killer.</div></div><div class="thread_post"><div class="thread_post_header"><b>If you believe the article that Defenderdawg posted, </b><a name="14866045">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Simms11"> Simms11 </a>  :  4/12/2020  11:35 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866045">link</a>   </div></div><div class="thread_post_body">In this mornings reading, it pretty much indicates that Thomas might be the preferred pick at #4, and the safest. Thomas is very versatile, is both good in run and pass blocking and has played on both sides. I know most don’t like PFFs grading, but they think he’s the #1 OT, but there’s others that think he’s the 4th best tackle?! Why such disparity? <br />
<br />
It seems like Sy wouldn’t be surprised if Giants picked Thomas at #4 either, bas3d on DGs preferences.</div></div><div class="thread_post"><div class="thread_post_header"><b>Sy, </b><a name="14866048">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=batman11"> batman11 </a>  :  4/12/2020  11:39 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866048">link</a>   </div></div><div class="thread_post_body">thank you for all your efforts and insights.  These write-ups are great!</div></div><div class="thread_post"><div class="thread_post_header"><b>PFF </b><a name="14866054">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=XBRONX"> XBRONX </a>  :  4/12/2020  11:48 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866054">link</a>   </div></div><div class="thread_post_body">grading claims Thomas gave up nine pressures all season.If true, pretty impressive.</div></div><div class="thread_post"><div class="thread_post_header"><b>PFF </b><a name="14866055">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  4/12/2020  11:50 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866055">link</a>   </div></div><div class="thread_post_body">can’t account for work ethic/willingness to be great. It’s great to give up a low amount of pressures in college. NFL is a whole different animal.</div></div><div class="thread_post"><div class="thread_post_header"><b>Great write up Sy. </b><a name="14866056">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BlueLou%27sBack"> BlueLou'sBack </a>  :  4/12/2020  11:50 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866056">link</a>   </div></div><div class="thread_post_body">Let's hope someone at "hints central" reads this.<br />
<br />
And if DG likes Thomas (as I do) please trade down a bit if the opportunity arises!</div></div><div class="thread_post"><div class="thread_post_header"><b>back issues are a problem </b><a name="14866060">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BigBlueCane"> BigBlueCane </a>  :  4/12/2020  11:53 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866060">link</a>   </div></div><div class="thread_post_body">but that's also why he was reportedly re-shaping his body and putting in a ton of work off the field.<br />
<br />
Again, I wonder if they're talking to Oben about him or not.<br />
<br />
I'd be happy with Wirfs or Becton (or Simmons).</div></div><div class="thread_post"><div class="thread_post_header"><b>Thx Sy really good stuff </b><a name="14866062">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Torrag"> Torrag </a>  :  4/12/2020  11:54 am   : <a href="index.php?mode=2&thread=596887&show_all=1#14866062">link</a>   </div></div><div class="thread_post_body">From your opening comment section "the lack of quality both short term and long term at this position is incredibly weak", to the your candid acknowledgement that Wirfs while physically gifted and oozing tools has to improve his consistency, to Wills being so polished, to favoring OT at #4...<br />
<br />
you flat out nailed it.<br />
<br />
I'll take either guy to the bank at #4 or in a short trade down if that is in the cards this year.<br />
<br />
On the team building philosophy "defense needs work, I think the offensive line is more important".<br />
<br />
Finally..."Only a godsend like Chase Young being available will change my mind."...<br />
<br />
Ditto.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Well Sy agrees that Simmons is the better player </b><a name="14866080">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Giant+John"> Giant John </a>  :  4/12/2020  12:08 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866080">link</a>   </div></div><div class="thread_post_body">As he has Simmons rated 3 points better. So will the Giants draft for need or BPA? If they go Tackle I’d like to see that with a trade down to 7. But NO further.<br />
Let’s see which way Giants decide to play this. Interesting...<br />
Either way we improve the team.</div></div><div class="thread_post"><div class="thread_post_header"><b>Great work, Sy.  Thank you. </b><a name="14866085">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Mike+from+Ohio"> Mike from Ohio </a>  :  4/12/2020  12:14 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866085">link</a>   </div></div><div class="thread_post_body">this issue first year in a while where I feel like I will trust whoever the Giants take with their first pick.  If they go Simmons, I will trust they are salivating at how they can use his rare talents and be ok with it. <br />
<br />
My biggest concern was about whether the OTs were potentially great, or just “good enough.”  Sounds like Wirfs and Wills may be great, and Thomas and Becton are more low floor / high ceiling guys.  If Garrett and Colombo like one of these tackles at #4, I hope that is the pick.<br />
<br />
Based on some of the lower rated guys, a developmental prospect in round 3-5 of Niang or Peart would be ideal.  Take someone with a strong work ethic and good frame who just needs to add some muscle and get them ready to compete for a starting spot in 2021.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Sy-question if I may? </b><a name="14866086">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  12:14 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866086">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865873" target="_blank">14865873</a> Tom in Kzoo said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> First love your review. Mirrors Daniel Jeramiah's take on team building from the other day, with which I (reluctantly ) concur. <br />
<br />
I've watched several youtube,etc. reviews of the tackles and Wills impressed me the most with his technique. Wirfs, for all his gifts ,scares me with his narrow unbalanced pass sets, and lack of awareness of stunting D linemen.  <br />
<br />
The question: how do you assess which deficiencies are fixable when it comes to recurrent bad O-lineman behavior, and which arew not? I fear some behaviors are ingrained, and shouldn't be expected to change(see Erick Flowers) , but struggle with which are more easily fixable.  <br />
<br />
Thanks. BTW, any small school guys/ sleepers you wish to throw in the mix late in draft? </td>
                                </tr>
                           </table><br />
<br />
If there are movement issues - I have to take a look at their athletic ability.  That is where the workouts can come in to play.<br />
<br />
If there are technique issues - you have to discuss with his coaches.  There are different ways to coach OL.  May not be that player's fault.<br />
<br />
If there are balance issues - you have to look at background.  <br />
<br />
Wirfs was a top shelf wrestler in high School from a state that breeds top shelf wrestlers.  He was also an accomplished thrower.  He also has set records within the Iowa strength program.  <br />
<br />
I think his issues step from a lack of confidence as he grows in to his body.  A few OL coaches I get to speak with agree.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Well Sy agrees that Simmons is the better player </b><a name="14866087">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=The_Boss"> The_Boss </a>  :  4/12/2020  12:16 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866087">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866080" target="_blank">14866080</a> Giant John said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> As he has Simmons rated 3 points better. So will the Giants draft for need or BPA? If they go Tackle I’d like to see that with a trade down to 7. But NO further.<br />
Let’s see which way Giants decide to play this. Interesting...<br />
Either way we improve the team. </td>
                                </tr>
                           </table><br />
<br />
Sy has 4 players graded higher than Wirfs’s 86<br />
Young<br />
Simmons<br />
Murray<br />
Okudah <br />
<br />
My guess is Lamb and Burrow are probably going to grade better, making Wirfs the 7th best player per Sy? And if so, when you factor in the need, I guess you can stomach taking Wirfs at 4.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>If Thomas is the guy they should trade down  </b><a name="14866089">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Reale01"> Reale01 </a>  :  4/12/2020  12:17 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866089">link</a>   </div></div><div class="thread_post_body">Most seem to have Wirfs and Wills in front of Thomas. He could get taken but that would still leave the Giants with Wills or Wirfs, who most seem to think to have high floors.<br />
<br />
If Wirfs is your guy you may not be happy with Thomas or Becton.</div></div><div class="thread_post"><div class="thread_post_header"><b>I’d imagine Tua  </b><a name="14866091">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  4/12/2020  12:18 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866091">link</a>   </div></div><div class="thread_post_body">will be rated higher than Wirfs as well</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Thanks SY </b><a name="14866093">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  12:19 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866093">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865887" target="_blank">14865887</a> UGADawgs7 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Been waiting. You mentioned which many can agree on, is IF somehow Chase Young falls to 4, that’s the only way to pass on an OT at 4 barring a minimal trade down to gain another asset. If he does fall, who do you see as NYG going with at 36 of these tackles?<br />
Cleveland <br />
Wilson<br />
Jones <br />
Jackson<br />
Peart(although you mentioned hopefully this is a project 4/5 round guy)  </td>
                                </tr>
                           </table><br />
<br />
Ah yes, the dreamer's guide to the draft.<br />
<br />
If NYG somehow got Young at 4 - The 2nd round list for OT would likely be (in DGs eyes)<br />
<br />
Wilson or an OC<br />
<br />
End of round 3:<br />
<br />
Peart or an OC</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Sy, is this the best OT class in the last 10 years. </b><a name="14866095">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  12:20 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866095">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865889" target="_blank">14865889</a> Rick in Dallas said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Thanks for all your hard work. </td>
                                </tr>
                           </table><br />
<br />
I would say it is above average - but they lack an elite guy and it gets pretty thin after the first 3 rounds.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I’d imagine Tua  </b><a name="14866096">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=The_Boss"> The_Boss </a>  :  4/12/2020  12:21 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866096">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866091" target="_blank">14866091</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> will be rated higher than Wirfs as well </td>
                                </tr>
                           </table><br />
<br />
I’d agree with you if he didn’t have an injury history. A clean Tua is probably at worst the 3rd best player in this draft.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Sy'56 </b><a name="14866105">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  12:25 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866105">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865921" target="_blank">14865921</a> M.S. said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br />
Always a pleasure to read your write-ups!<br />
<br />
Question: Are there any OTs you've reviewed that kinda, sorta, maybe remind you a little of Ereck Flowers and thus may wash out at tackle?<br />
<br />
Thanks again for all your thoughts and insights! </td>
                                </tr>
                           </table><br />
<br />
I don't think so - remember I had Flowers as a round 2/3 talent.  Grade wise have been 7th or 8th on this list.  <br />
<br />
But to answer your question - there are tendencies in Thomas' game that made Flowers struggle.  Lack of true bend in his knees - wild hands - differing effort and urgency levels.</div></div><div class="thread_post"><div class="thread_post_header"><b>I like Wills best </b><a name="14866111">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BillT"> BillT </a>  :  4/12/2020  12:31 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866111">link</a>   </div></div><div class="thread_post_body">But I know that don't really know squat.  But I do think Becton is 4th and I'm glad to see that much confirmed.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I've often seen </b><a name="14866116">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  12:35 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866116">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865938" target="_blank">14865938</a> NYG22 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Matt Peat and Alex Taylor grouped together as physically gifted, exceptionally long but very raw players....but your write-up shows a major gap. Can you compare and contrast the two please? </td>
                                </tr>
                           </table><br />
<br />
Peart has more experience against better competition. He has more thickness throughout his frame.  He looks more natural.  He has a ton more power.<br />
<br />
Taylor is super long and a decent straight line athlete.  But he looks like a baby deer at times, super awkward and off balance.  Doesn't bend well, he got eaten alive at Sr Bowl week</div></div><div class="thread_post"><div class="thread_post_header"><b>And this is why I likw Wills best </b><a name="14866117">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BillT"> BillT </a>  :  4/12/2020  12:37 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866117">link</a>   </div></div><div class="thread_post_body"><span class="italics">"I think Wills is probably the most polished and NFL ready tackle in the group. If these tackles all start in 2020, I bet Wills has the best rookie season."</span>  <br />
<br />
If they like Wirfs then so be it but I'll take this, the 85 grade, and never look back.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: General draft question </b><a name="14866118">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  12:37 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866118">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14865975" target="_blank">14865975</a> XBRONX said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Do any teams take input on draft from their position coaches? Would Colombo get any input? </td>
                                </tr>
                           </table><br />
<br />
Yes plenty teams allow them to give input - especially based on what fits best with the scheme.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: How much better was Jonah Williams than Wills (not just grade #) </b><a name="14866121">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  12:39 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866121">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866017" target="_blank">14866017</a> 90.Cal said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> & what is your thoughts on this OL figuration if Wirfs is the pick.<br />
<br />
<br />
LT - Wirfs - LG - Hernandez - OC Ruiz/Hennessy - RG - Zeitler - RT Solder </td>
                                </tr>
                           </table><br />
<br />
Jonah was cleaner - he was basically flawless when it came to technique.  Wills has a little more size to work with.  Williams was graded slightly higher than both Wills and Wirfs on my board</div></div><div class="thread_post"><div class="thread_post_header"><b>Great </b><a name="14866126">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=AcidTest"> AcidTest </a>  :  4/12/2020  12:44 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866126">link</a>   </div></div><div class="thread_post_body">write up. I think if the Giants go OT, it will be Wirfs. I'd only take an OT after trading down. If forced to pick at #4, I'd take Simmons or Brown. Either are better value at #4 than any of the OT IMO.</div></div><div class="thread_post"><div class="thread_post_header"><b>Sy here's a ? for you - take NYG out of it which group do you prefer? </b><a name="14866135">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+on+Li"> Eric on Li </a>  :  4/12/2020  12:49 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866135">link</a>   </div></div><div class="thread_post_body">so a though experiment on the best 2 player hauls: <br />
<br />
Group 1 - <br />
Wirfs or Wills <br />
Patrick Queen or Zack Baun <br />
<br />
Group 2 - <br />
Simmons or Okudah <br />
Hennessy or Cleveland or Josh Jones <br />
<br />
Interestingly for the NYG I probably lean more towards drafting Simmons or Okudah in round 1, but when I take a step back the combo in group 1 is probably stronger because the fall off with the 2nd player in group 2 seems a little bigger.</div></div><div class="thread_post"><div class="thread_post_header"><b>Sy'56 </b><a name="14866137">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=YANKEE28"> YANKEE28 </a>  :  4/12/2020  12:51 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866137">link</a>   </div></div><div class="thread_post_body">Really glad to see that you have McKinney (its actually Anthony) from TCU on your list.<br />
<br />
No question he's really green and a developmental type. But he is really athletic for someone 6'8" and it would not surprise me if he has the longest wingspan of anyone in this draft.<br />
<br />
He was only at a major college program for two years, but still became their starting left tackle.<br />
<br />
Type of player I would love to lock up late in the 7th and give him some great NFL OL coaching. There's a lot to work with.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>If we walk away with Simmons in RD1 and  </b><a name="14866141">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Metnut"> Metnut </a>  :  4/12/2020  12:52 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866141">link</a>   </div></div><div class="thread_post_body">Cleveland in RD2, I’d be really pumped.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Sy here's a ? for you - take NYG out of it which group do you prefer? </b><a name="14866149">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  12:56 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866149">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866135" target="_blank">14866135</a> Eric on Li said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> so a though experiment on the best 2 player hauls: <br />
<br />
Group 1 - <br />
Wirfs or Wills <br />
Patrick Queen or Zack Baun <br />
<br />
Group 2 - <br />
Simmons or Okudah <br />
Hennessy or Cleveland or Josh Jones <br />
<br />
Interestingly for the NYG I probably lean more towards drafting Simmons or Okudah in round 1, but when I take a step back the combo in group 1 is probably stronger because the fall off with the 2nd player in group 2 seems a little bigger. </td>
                                </tr>
                           </table><br />
<br />
Similar value between those pairs<br />
<br />
I prefer group 1.</div></div><div class="thread_post"><div class="thread_post_header"><b>Sy </b><a name="14866150">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Samiam"> Samiam </a>  :  4/12/2020  12:56 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866150">link</a>   </div></div><div class="thread_post_body">If you rate Williams higher than these guys, and in my inexpert opinion a weaker draft, how do you reconcile him going at 11 yet you think one of these guys should be the pick at 4?  I understand the weakness of the team at OT but to me Simmons would have gone very early last year and is probably a better margin by a big margin.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Sy'56 </b><a name="14866153">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  12:57 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866153">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866137" target="_blank">14866137</a> YANKEE28 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Really glad to see that you have McKinney (its actually Anthony) from TCU on your list.<br />
<br />
No question he's really green and a developmental type. But he is really athletic for someone 6'8" and it would not surprise me if he has the longest wingspan of anyone in this draft.<br />
<br />
He was only at a major college program for two years, but still became their starting left tackle.<br />
<br />
Type of player I would love to lock up late in the 7th and give him some great NFL OL coaching. There's a lot to work with.<br />
 </td>
                                </tr>
                           </table><br />
<br />
I have been talking him up for months - not getting a ton of feedback from my peers but I am looking forward to seeing who scoops him up .</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Sy </b><a name="14866158">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  1:02 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866158">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866150" target="_blank">14866150</a> Samiam said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> If you rate Williams higher than these guys, and in my inexpert opinion a weaker draft, how do you reconcile him going at 11 yet you think one of these guys should be the pick at 4?  I understand the weakness of the team at OT but to me Simmons would have gone very early last year and is probably a better margin by a big margin. </td>
                                </tr>
                           </table><br />
<br />
Grades for me are a guide, not a rule.  That is why I give range-projections and what to expect out of them.  I keep this simple - I see a Pro Bowler in Wirfs, I see a Pro Bowler in Simmons.<br />
<br />
But NYG isn't going anywhere without the OL getting much better.  I do think they can piece together the defense without Simmons.  There may even be better schematic fits in round 2 based on what NYG wants to do.</div></div><div class="thread_post"><div class="thread_post_header"><b>samiam I disagree </b><a name="14866159">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Torrag"> Torrag </a>  :  4/12/2020  1:03 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866159">link</a>   </div></div><div class="thread_post_body">Last years DL class was excellent. I see Bosa/Williams/Allen all going before Simmons. He'd be in the next tier, as he is in this draft, with Ferrell(who Oak overdrafted), White and Oliver. Let's not forget need is a factor and pass rushers and QB if you need them may be the two positions that trump OL.</div></div><div class="thread_post"><div class="thread_post_header"><b>thank you sy - 1 more question for you inspired by a diff thread  </b><a name="14866160">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+on+Li"> Eric on Li </a>  :  4/12/2020  1:03 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866160">link</a>   </div></div><div class="thread_post_body">how would you compare Andrew Thomas and Ronnie Stanley as prospects? <br />
<br />
Stanley has probably ended up the best OT in the last 5 drafts or so, you graded both players exactly the same, and it seems like they may have some similarities in where they were inconsistent at the CFB level (perceived lack of intensity). <br />
<br />
While they are different players they both have prototypical size + length, and had several years of starting experience against good competition. <br />
<br />
(also I completely agree with you that the make up question is huge, so this question is a little more about how you compare their abilities on the field, since the nyg had guys on the UGA staff with thomas I'm somewhat confident they won't pick him if there are any doubts re: makeup)<br />
<br />
thank you again.</div></div><div class="thread_post"><div class="thread_post_header"><b>Eric: "the nyg had guys on the UGA staff with thomas" </b><a name="14866164">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Torrag"> Torrag </a>  :  4/12/2020  1:06 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866164">link</a>   </div></div><div class="thread_post_body">That's interesting...who? We know Judge will have good info on Wills out of Alabama.</div></div><div class="thread_post"><div class="thread_post_header"><b>Thank you Sy </b><a name="14866168">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=jeffusedtobeonwebtv"> jeffusedtobeonwebtv </a>  :  4/12/2020  1:07 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866168">link</a>   </div></div><div class="thread_post_body">I think this was the writeup we were all waiting for.<br />
<br />
One question, can you be more specific about Becton's red flag medical issues?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: thank you sy - 1 more question for you inspired by a diff thread  </b><a name="14866169">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  1:10 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866169">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866160" target="_blank">14866160</a> Eric on Li said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> how would you compare Andrew Thomas and Ronnie Stanley as prospects? <br />
<br />
Stanley has probably ended up the best OT in the last 5 drafts or so, you graded both players exactly the same, and it seems like they may have some similarities in where they were inconsistent at the CFB level (perceived lack of intensity). <br />
<br />
While they are different players they both have prototypical size + length, and had several years of starting experience against good competition. <br />
<br />
(also I completely agree with you that the make up question is huge, so this question is a little more about how you compare their abilities on the field, since the nyg had guys on the UGA staff with thomas I'm somewhat confident they won't pick him if there are any doubts re: makeup)<br />
<br />
thank you again. </td>
                                </tr>
                           </table><br />
<br />
They are fairly comparable as prospects.  Stanley may have been a little smoother in his kick slide to reach the point, little more natural bend.  Thomas was more physical.<br />
<br />
Also of note - Stanley had some work ethic concerns coming out of Notre Dame and he turned out just fine.  BAL coaches have done a good job with him too.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Thank you Sy </b><a name="14866170">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  1:11 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866170">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866168" target="_blank">14866168</a> jeffusedtobeonwebtv said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I think this was the writeup we were all waiting for.<br />
<br />
One question, can you be more specific about Becton's red flag medical issues? </td>
                                </tr>
                           </table><br />
<br />
I cannot, sorry.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Eric:  </b><a name="14866171">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+on+Li"> Eric on Li </a>  :  4/12/2020  1:11 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866171">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866164" target="_blank">14866164</a> Torrag said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> That's interesting...who? We know Judge will have good info on Wills out of Alabama. </td>
                                </tr>
                           </table><br />
<br />
Kevin Sherrer was the OLB coach on UGA from 2014 through 2017. He was hired away by UT in December of 2017. <br />
<br />
Andrew Thomas committed to UGA in July 2016 and enrolled in May 2017 - and then went on to make freshman AA team starting every game at RT in 2017. <br />
<br />
So Sherrer wasn't his direct coach but was likely in meetings and evaluations of Thomas for 2 or 3 years.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: thank you sy - 1 more question for you inspired by a diff thread  </b><a name="14866174">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+on+Li"> Eric on Li </a>  :  4/12/2020  1:15 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866174">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866169" target="_blank">14866169</a> Sy'56 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14866160 Eric on Li said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     how would you compare Andrew Thomas and Ronnie Stanley as prospects? <br />
<br />
                           <br />
<br />
They are fairly comparable as prospects.  Stanley may have been a little smoother in his kick slide to reach the point, little more natural bend.  Thomas was more physical.<br />
<br />
Also of note - Stanley had some work ethic concerns coming out of Notre Dame and he turned out just fine.  BAL coaches have done a good job with him too. </td>
                                </tr>
                           </table><br />
<br />
yeah I think the work ethic thing is difficult to pick up on tape because almost every player i've ever watched looks like they are loafing at some point in college. Very few top talents also play with the "hair on fire", and I think sometimes especially with the top talents it can be a bit of a red herring in CFB because they just get bored. Especially in the games that aren't as juiced up. And they are young. So it's sort of natural to take things more seriously when they get to the pros because it's just more serious all around. If Thomas' makeup impresses I think he ends up higher than expected, but that's certainly an open question. <br />
<br />
Thank you again Sy.</div></div><div class="thread_post"><div class="thread_post_header"><b>Part of the draft process  </b><a name="14866183">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  4/12/2020  1:19 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866183">link</a>   </div></div><div class="thread_post_body">is figuring out what makes guys tick, if they want to reach their full potential. Lotta guys are just fine taking the paycheck and doing the bare minimum. Taking a guy in the top 10, you need a competitive dude who wants to be the best. <br />
<br />
If Thomas is that guy, then great. It’s really not something you can “know” but just have a conviction on. For my money, just the way Wirfs carries himself and the way he speaks and presents himself in person, the way he talks to people...I just think he’s gonna work at being great.</div></div><div class="thread_post"><div class="thread_post_header"><b>I can't even tell you how important the interview / background checks </b><a name="14866186">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  1:20 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866186">link</a>   </div></div><div class="thread_post_body">are to the scouting process.  The tape is most important - yes.  But there is a reason why teams invest a ton of time and money in to the mental checks on these players.<br />
<br />
That is why, myself included, we need to keep that in mind when we evaluate prospects and the evaluate who teams take.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I can't even tell you how important the interview / background checks </b><a name="14866191">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  4/12/2020  1:30 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866191">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866186" target="_blank">14866186</a> Sy'56 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> are to the scouting process.  The tape is most important - yes.  But there is a reason why teams invest a ton of time and money in to the mental checks on these players.<br />
<br />
That is why, myself included, we need to keep that in mind when we evaluate prospects and the evaluate who teams take. </td>
                                </tr>
                           </table><br />
+1000</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Eric:  </b><a name="14866201">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Strahan91"> Strahan91 </a>  :  4/12/2020  1:40 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866201">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866171" target="_blank">14866171</a> Eric on Li said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br />
<br />
Kevin Sherrer was the OLB coach on UGA from 2014 through 2017. He was hired away by UT in December of 2017. <br />
<br />
Andrew Thomas committed to UGA in July 2016 and enrolled in May 2017 - and then went on to make freshman AA team starting every game at RT in 2017. <br />
<br />
So Sherrer wasn't his direct coach but was likely in meetings and evaluations of Thomas for 2 or 3 years. </td>
                                </tr>
                           </table><br />
Possibly more important, Judge, Burns, and Wright were all on the Alabama staff with Kirby Smart. There are also a bunch of ties to Garrett from his time in Miami (most notably Smart and Coley) so their info should be quite good.</div></div><div class="thread_post"><div class="thread_post_header"><b>Sy </b><a name="14866214">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Mark+from+Jersey"> Mark from Jersey </a>  :  4/12/2020  2:10 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866214">link</a>   </div></div><div class="thread_post_body">Thanks again.  I have been looking forward the OTs for awhile now.  I agree you have to take Tackle here unless Young somehow drops to us.  Have to protect our investments (Barkley & Jones).</div></div><div class="thread_post"><div class="thread_post_header"><b>Thanks Sy'56! </b><a name="14866230">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jay+in+Toronto"> Jay in Toronto </a>  :  4/12/2020  2:26 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866230">link</a>   </div></div><div class="thread_post_body">"we are talking about correctable issues here" re Wirfs (and anyone else:<br />
<br />
How up-to-the task is the Giants' OL Coaching crew? In comparison to past years? In comparison to other teams??<br />
<br />
TIA<br />
<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>"the Giants' OL Coaching crew? In comparison to past years?" </b><a name="14866236">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Torrag"> Torrag </a>  :  4/12/2020  2:32 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866236">link</a>   </div></div><div class="thread_post_body">I really liked the Colombo hire and Garrett has a strong track record with the OL in Dallas the past decade. But you have to have talent to work with to be successful. Get them some.</div></div><div class="thread_post"><div class="thread_post_header"><b>I have to think </b><a name="14866239">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=santacruzom"> santacruzom </a>  :  4/12/2020  2:35 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866239">link</a>   </div></div><div class="thread_post_body">Wirfs projects as an intrinsically motivated hard worker, perhaps even the ideal sort who enjoys putting in the work so much that it barely qualifies as work.<br />
<br />
I doubt he would have excelled at multiple disparate sports like like shot putting, wrestling, and football without that mastering-the-details mindset.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Great </b><a name="14866244">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  4/12/2020  2:44 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866244">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866126" target="_blank">14866126</a> AcidTest said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> write up. I think if the Giants go OT, it will be Wirfs. I'd only take an OT after trading down. If forced to pick at #4, I'd take Simmons or Brown. Either are better value at #4 than any of the OT IMO. </td>
                                </tr>
                           </table><br />
As long as you're ok with wasting the value of 2018's #2 overall pick and last year's #6 overall pick, then sure - let's go with max value at #4 this year.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I have to think </b><a name="14866249">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  :  4/12/2020  2:49 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866249">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866239" target="_blank">14866239</a> santacruzom said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Wirfs projects as an intrinsically motivated hard worker, perhaps even the ideal sort who enjoys putting in the work so much that it barely qualifies as work.<br />
<br />
I doubt he would have excelled at multiple disparate sports like like shot putting, wrestling, and football without that mastering-the-details mindset. </td>
                                </tr>
                           </table><br />
<br />
There was a good quote from Defenderdawg's thread the other day where he looks back at all the sacrifices that his mom made for him and doesn't want it to be a waste for her that she paid for all of his equipment and time to do what was in his best interest.</div></div><div class="thread_post"><div class="thread_post_header"><b>I want to say this ... </b><a name="14866258">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  :  4/12/2020  2:59 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866258">link</a>   </div></div><div class="thread_post_body">Look around the league. What is the one area that EVERY team is lacking? The answer is OL. These guys don't grow on trees. Some teams have great LBs. Some teams have a great rotation of DL. Some have great weapons. Not one team loves their OL from top to bottom. Finding 5 guys is hard enough let alone have depth. These guys rarely hit FA and when they do there is a reason outside of a team not having the money. <br />
<br />
On top of that, OL have been very difficult to evaluate coming from college because too many college teams are running spread offenses. They are difficult to evaluate because they are very limited on what they are asked to do. So, when an opportunity comes along where you get to draft an OL from a school like Iowa or another school that has their OL block in many different ways then you cannot be concerned about a couple of points here or there. <br />
<br />
Look at the Cowboys with Zack Martin. Most say don't draft an OL that higher if he is only a G. Same with Indy and Nelson. Do you think either of them are regretting their picks? <br />
<br />
Do you want an OL that is going to be a strength that allows you to open up your whole offense or do you want an OL you are trying to hide and scheme around? The answer is very clear for me. And I am with Sy here in my mentality. The only player that makes me change my mind is Young.</div></div><div class="thread_post"><div class="thread_post_header"><b>Great write ups </b><a name="14866259">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Amtoft"> Amtoft </a>  :  4/12/2020  3:01 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866259">link</a>   </div></div><div class="thread_post_body">I am surprised where you have Austin Jackson but this is great stuff.</div></div><div class="thread_post"><div class="thread_post_header"><b>Sy </b><a name="14866266">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=CromartiesKid21"> CromartiesKid21 </a>  :  4/12/2020  3:10 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866266">link</a>   </div></div><div class="thread_post_body">How would you rank the intelligence of the top 4 tackles?</div></div><div class="thread_post"><div class="thread_post_header"><b>Sy </b><a name="14866281">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=DonnieD89"> DonnieD89 </a>  :  4/12/2020  3:28 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866281">link</a>   </div></div><div class="thread_post_body">Do you believe Tristan Wirfs can be an All Pro left tackle, if he cleans up his balance and timing?  Also, some analysts have stated that Jedrick Wills has maxed out with potential.  Personally, I don’t believe this.  What is your opinion?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I want to say this ... </b><a name="14866288">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=MeadowlandsMike"> MeadowlandsMike </a>  :  4/12/2020  3:36 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866288">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866258" target="_blank">14866258</a> robbieballs2003 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Look around the league. What is the one area that EVERY team is lacking? The answer is OL. These guys don't grow on trees. Some teams have great LBs. Some teams have a great rotation of DL. Some have great weapons. Not one team loves their OL from top to bottom. Finding 5 guys is hard enough let alone have depth. These guys rarely hit FA and when they do there is a reason outside of a team not having the money. <br />
<br />
On top of that, OL have been very difficult to evaluate coming from college because too many college teams are running spread offenses. They are difficult to evaluate because they are very limited on what they are asked to do. So, when an opportunity comes along where you get to draft an OL from a school like Iowa or another school that has their OL block in many different ways then you cannot be concerned about a couple of points here or there. <br />
<br />
Look at the Cowboys with Zack Martin. Most say don't draft an OL that higher if he is only a G. Same with Indy and Nelson. Do you think either of them are regretting their picks? <br />
<br />
Do you want an OL that is going to be a strength that allows you to open up your whole offense or do you want an OL you are trying to hide and scheme around? The answer is very clear for me. And I am with Sy here in my mentality. The only player that makes me change my mind is Young. </td>
                                </tr>
                           </table><br />
<br />
Great points robbie</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Sy </b><a name="14866302">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  3:52 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866302">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866266" target="_blank">14866266</a> CromartiesKid21 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> How would you rank the intelligence of the top 4 tackles? </td>
                                </tr>
                           </table><br />
<br />
Tough to say - I don't have all the information on them in that regard to have a credible opinion.  Yes, I hear things here and there but still, there are a lot of pages in that book I never get to look at.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I want to say this ... </b><a name="14866303">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=AcidTest"> AcidTest </a>  :  4/12/2020  3:52 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866303">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866288" target="_blank">14866288</a> MeadowlandsMike said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14866258 robbieballs2003 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Look around the league. What is the one area that EVERY team is lacking? The answer is OL. These guys don't grow on trees. Some teams have great LBs. Some teams have a great rotation of DL. Some have great weapons. Not one team loves their OL from top to bottom. Finding 5 guys is hard enough let alone have depth. These guys rarely hit FA and when they do there is a reason outside of a team not having the money. <br />
<br />
On top of that, OL have been very difficult to evaluate coming from college because too many college teams are running spread offenses. They are difficult to evaluate because they are very limited on what they are asked to do. So, when an opportunity comes along where you get to draft an OL from a school like Iowa or another school that has their OL block in many different ways then you cannot be concerned about a couple of points here or there. <br />
<br />
Look at the Cowboys with Zack Martin. Most say don't draft an OL that higher if he is only a G. Same with Indy and Nelson. Do you think either of them are regretting their picks? <br />
<br />
Do you want an OL that is going to be a strength that allows you to open up your whole offense or do you want an OL you are trying to hide and scheme around? The answer is very clear for me. And I am with Sy here in my mentality. The only player that makes me change my mind is Young. <br />
                                <br />
                           <br />
<br />
Great points robbie </td>
                                </tr>
                           </table><br />
<br />
+2.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Sy </b><a name="14866306">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  3:56 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866306">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866281" target="_blank">14866281</a> DonnieD89 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Do you believe Tristan Wirfs can be an All Pro left tackle, if he cleans up his balance and timing?  Also, some analysts have stated that Jedrick Wills has maxed out with potential.  Personally, I don’t believe this.  What is your opinion? </td>
                                </tr>
                           </table><br />
<br />
All Pro?  As in one of the best 3 or 4 tackles in the game?  <br />
<br />
Possible?  Yes.<br />
Would I gamble on it?  No.<br />
<br />
Wills may have maxed out his frame, yes.  Maxed out potential?  Not sure I understand that, all these kids will get at least a little better when in the league.  Sounds like a cheap draft parrot-analyst line.</div></div><div class="thread_post"><div class="thread_post_header"><b>Robbie - I think the question is a little different  </b><a name="14866309">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+on+Li"> Eric on Li </a>  :  4/12/2020  3:59 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866309">link</a>   </div></div><div class="thread_post_body">I think for the colts the question isn't whether it was worth it to draft Quentin Nelson, obviously in the binary they would yes because he worked out (same as we would say with Barkley). The question is if both were available, would they choose Nelson or say Darius Leonard? <br />
<br />
And for the Cowboys, would they take Zack Martin or LVE/Jaylon Smith? <br />
<br />
I don't think there's a wrong answer to either of those questions. All pros are all pros, and the degree to which 1 position is worth more than the other is tough to say. All of those guys are important (including Barkley too - who can almost single handedly win games like the Redskin game last year).  <br />
<br />
What you don't want to do though is pass on an all pro and take a non-all pro just to force a different position. So i'd say just pick the highest graded guy (whether it's an OT or defensive player). Get a true difference maker and I don't care what position he plays.</div></div><div class="thread_post"><div class="thread_post_header"><b>Sy </b><a name="14866310">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jay+on+the+Island"> Jay on the Island </a>  :  4/12/2020  4:06 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866310">link</a>   </div></div><div class="thread_post_body">Which developmental OT would you want the Giants to select from round 3 on to compete for the starting RT job in 2021?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Great work, Sy.  Thank you. </b><a name="14866313">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Coach+Red+Beaulieu"> Coach Red Beaulieu </a>  :  4/12/2020  4:10 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866313">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866085" target="_blank">14866085</a> Mike from Ohio said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> this issue first year in a while where I feel like I will trust whoever the Giants take with their first pick.  If they go Simmons, I will trust they are salivating at how they can use his rare talents and be ok with it. <br />
<br />
My biggest concern was about whether the OTs were potentially great, or just “good enough.”  Sounds like Wirfs and Wills may be great, and Thomas and Becton are more low floor / high ceiling guys.  If Garrett and Colombo like one of these tackles at #4, I hope that is the pick.<br />
<br />
Based on some of the lower rated guys, a developmental prospect in round 3-5 of Niang or Peart would be ideal.  Take someone with a strong work ethic and good frame who just needs to add some muscle and get them ready to compete for a starting spot in 2021. </td>
                                </tr>
                           </table><br />
Strength seems easier to "teach" than footwork and nimbleness for an OT.</div></div><div class="thread_post"><div class="thread_post_header"><b>Just have a feeling </b><a name="14866314">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=M.S."> M.S. </a>  :  4/12/2020  4:11 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866314">link</a>   </div></div><div class="thread_post_body"><br />
That Gettleman has confidence in his ability to find good offensive linemen after Round One.<br />
<br />
Translation: Isaiah Simmons is the pick at 4.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Robbie - I think the question is a little different  </b><a name="14866315">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  :  4/12/2020  4:16 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866315">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866309" target="_blank">14866309</a> Eric on Li said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I think for the colts the question isn't whether it was worth it to draft Quentin Nelson, obviously in the binary they would yes because he worked out (same as we would say with Barkley). The question is if both were available, would they choose Nelson or say Darius Leonard? <br />
<br />
And for the Cowboys, would they take Zack Martin or LVE/Jaylon Smith? <br />
<br />
I don't think there's a wrong answer to either of those questions. All pros are all pros, and the degree to which 1 position is worth more than the other is tough to say. All of those guys are important (including Barkley too - who can almost single handedly win games like the Redskin game last year).  <br />
<br />
What you don't want to do though is pass on an all pro and take a non-all pro just to force a different position. So i'd say just pick the highest graded guy (whether it's an OT or defensive player). Get a true difference maker and I don't care what position he plays. </td>
                                </tr>
                           </table><br />
<br />
I agree. When we talk about BPA there has to be a ballpark. Comparing one position to another isn't fair. It might be easier to reach a higher grade at kne position than another because they have different categories they get evaluated on. So, my point is sticking to one number on different grading criteria means there will be room for error. And that is when you have to be a little flexible and start to really put grades with positions. With the scarcity of OL they hold a higher value to me than every other position except maybe QB nowadays. That has changed from the past when pass rushers, corners, and offensive playmakers were higher. The old way of looking at positions and players has changed. <br />
<br />
To me there needs to be a clear cut advantage for a player like Young for me to put them over Wills and now Wirfs after reading Sy's writeup.</div></div><div class="thread_post"><div class="thread_post_header"><b>for me it's very hard to judge whether there's an advantage or not </b><a name="14866340">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+on+Li"> Eric on Li </a>  :  4/12/2020  4:58 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866340">link</a>   </div></div><div class="thread_post_body">in terms of where the D players will be ranked relative to whoever the OT1 is because I can't even parse whoever the OT1 is. On the flip side:<br />
<br />
Simmons is the consensus LB1 and I personally like him more any of the LB's we were considering the past few years (the Devins, Myles Jack, etc). The elite athleticism and coverage abilities are evident and I think he might also be a 10+ sack player if a team turns him loose rushing the passer. In his minimal pass rushing reps he produced and showed he can bend around the corner. Had he been given the Vic Beasley role I think his sack production would have been 2x what it was.<br />
<br />
Okudah is the consensus CB1 and similarly I think he compares favorably with some of the other recent CB1's including both Lattimore and Ward. It's not hard to see a day 1 starter and impact player at a premium position. <br />
<br />
Re: the OT's, credible people say Wirfs may be a better guard like Scherff. Wills moves the best but is a little undersized and has only played RT. Was he just Bama's version of Justin Pugh? Becton's size/power is evident but he is a unicorn - who knows how he translates. Thomas checks the most boxes on paper to me but have definitely seen some bad reps too. <br />
<br />
I don't doubt that the OT1 could be on the level grade wise of the top D players, I just find that personally to be a really hard thing to evaluate without watching like every snap - and I actually have a very healthy confidence that the NYG have the right leadership in place to get this decision right. Gettleman has drafted well and shown that he will take skill players when it's warranted like Barkley, or a hog mollie like Lawrence/Hernandez. And Judge has assembled a staff with direct experience to CFB which adds some real familiarity to the discussion (especially the SEC and big10).</div></div><div class="thread_post"><div class="thread_post_header"><b>RE:  </b><a name="14866344">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jay+in+Toronto"> Jay in Toronto </a>  :  4/12/2020  5:04 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866344">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866236" target="_blank">14866236</a> Torrag said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I really liked the Colombo hire and Garrett has a strong track record with the OL in Dallas the past decade. But you have to have talent to work with to be successful. Get them some. </td>
                                </tr>
                           </table><br />
<br />
Well that quote came from his description of Wirfs -- so that's the talent part.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: How much better was Jonah Williams than Wills (not just grade #) </b><a name="14866374">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=90.Cal"> 90.Cal </a>  :  4/12/2020  6:04 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866374">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866020" target="_blank">14866020</a> robbieballs2003 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14866017 90.Cal said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     & what is your thoughts on this OL figuration if Wirfs is the pick.<br />
<br />
<br />
LT - Wirfs - LG - Hernandez - OC Ruiz/Hennessy - RG - Zeitler - RT Solder <br />
                                <br />
                           <br />
<br />
I really don't see that as an option. With Solder still here it doesn't make sense to move him to RT. Moving from one side of the line to the other is harder than going from OT to G. If Wirfs plays LT I would assume that would be in his second year and we have moved on from Solder. <br />
<br />
Also, if you had a rookie OT would you want him next to Hernandez or Zeitler? </td>
                                </tr>
                           </table><br />
<br />
I hear you but Solder has been sooooo bad at LT its hard to imagine that Wirfs wouldn't be better A. AND B. its even harder to imagine Solder being worse at RT than he is at LT therefore I thought/think it to be  the best configuration if we do bring in Wirfs.</div></div><div class="thread_post"><div class="thread_post_header"><b>It's not like </b><a name="14866375">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=90.Cal"> 90.Cal </a>  :  4/12/2020  6:04 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866375">link</a>   </div></div><div class="thread_post_body">"Solder has been so good on the left, let's not screw it up"</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: It's not like </b><a name="14866380">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GFAN52"> GFAN52 </a>  :  4/12/2020  6:10 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866380">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866375" target="_blank">14866375</a> 90.Cal said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> "Solder has been so good on the left, let's not screw it up" </td>
                                </tr>
                           </table><br />
<br />
With a possible shorter training camp and given Wirfs experience has mostly been at RT, I doubt they switch Solder to RT this season.</div></div><div class="thread_post"><div class="thread_post_header"><b>I'm glad to see that Sy has these guys rated so high </b><a name="14866384">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Rudy5757"> Rudy5757 </a>  :  4/12/2020  6:13 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866384">link</a>   </div></div><div class="thread_post_body">It's a no brainer to take an OT if you stay at 4.  A good one will make the whole team better.  It's now a scoring league and we have enough talent to score if the OL improves.  Young is the only player on D that immediately makes the D better.  Simmons needs to much help to be an impact player.<br />
<br />
Obviously everyone wants a trade down but even if you can't take the OT you like best.  I happen to think Becton will be the best of the bunch but hearing the medical and not being able to have our people look at him is a concern.  I would lean towards Wills, I think he is the most can't miss and the one Judge can get the most info on.<br />
<br />
Yes DG has been able to get some good ones later but we can still do that.  We do need 2 OTs.  Maybe the 2nd one can come in later in the season.  There is no question that we need a starter on the OL from this draft and possibly 2.  This is not a reach its where value meets needs.  With a limited off-season we need plug and play.</div></div><div class="thread_post"><div class="thread_post_header"><b>Thanks Sy56 for your write-ups </b><a name="14866385">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=jsuds"> jsuds </a>  :  4/12/2020  6:15 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866385">link</a>   </div></div><div class="thread_post_body">They are enlightening to fans like me and as much as I would love to bolster this defense with a guy like Simmons, after reading this review you've convinced me. If DG can orchestrate it with a trade down and maybe even get two of your top four I'd be even more excited. A better O-line will open things up for SB, give DJ time, and as Dallas has shown, protect your defense by keeping them off the field. I am all in for Wirfs at #4.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Just have a feeling </b><a name="14866390">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GiantsFan84"> GiantsFan84 </a>  :  4/12/2020  6:22 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866390">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866314" target="_blank">14866314</a> M.S. said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br />
That Gettleman has confidence in his ability to find good offensive linemen after Round One.<br />
<br />
Translation: Isaiah Simmons is the pick at 4. </td>
                                </tr>
                           </table><br />
<br />
i've yet to see that ability as GM of the Giants</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: If we walk away with Simmons in RD1 and  </b><a name="14866391">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=santacruzom"> santacruzom </a>  :  4/12/2020  6:24 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866391">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866141" target="_blank">14866141</a> Metnut said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Cleveland in RD2, I’d be really pumped. </td>
                                </tr>
                           </table><br />
<br />
Me too, but honestly?  I'd probably be equally pumped if we used our first two picks on offensive tackles.<br />
<br />
We are going to need two.</div></div><div class="thread_post"><div class="thread_post_header"><b>Wirfs </b><a name="14866395">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=stretch234"> stretch234 </a>  :  4/12/2020  6:35 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866395">link</a>   </div></div><div class="thread_post_body">My issue with him is that guys that don’t play LT in college do not suddenly come to the NFL able to switch to the left.   The list is long going the other way, but who has done it the other way<br />
<br />
Saying that, in today’s game with quality DE on both sides, you need 2 good tackles. If you draft him play him at RT and have a dominant R side<br />
<br />
You can live helping out 1 side.<br />
<br />
Now regarding C .....</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Sy </b><a name="14866412">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sy%2756"> Sy'56 </a>  :  4/12/2020  7:10 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866412">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866310" target="_blank">14866310</a> Jay on the Island said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Which developmental OT would you want the Giants to select from round 3 on to compete for the starting RT job in 2021? </td>
                                </tr>
                           </table><br />
<br />
Matt Peart is a guy I can see them eyeing at that point</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: It's not like </b><a name="14866414">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=DonnieD89"> DonnieD89 </a>  :  4/12/2020  7:15 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866414">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866380" target="_blank">14866380</a> GFAN52 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14866375 90.Cal said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     "Solder has been so good on the left, let's not screw it up" <br />
                                <br />
                           <br />
<br />
With a possible shorter training camp and given Wirfs experience has mostly been at RT, I doubt they switch Solder to RT this season. </td>
                                </tr>
                           </table><br />
<br />
Sy came up with an interesting point when he was guest speaker in the podcast, Pro Football Talk.  He stated that he believed the reasoning for bringing in the blocking tight end was to protect a starting rookie right tackle.</div></div><div class="thread_post"><div class="thread_post_header"><b>Gettelman's previous picks at the position favor length </b><a name="14866419">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=guineaT"> guineaT </a>  :  4/12/2020  7:21 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866419">link</a>   </div></div><div class="thread_post_body">I could see him loving Thomas. Has the prototype size, agility and length. Can't speak to the intangibles which have been speculated on here but his physical attributes, level of comp and experience are ideal. He checks a lot of boxes.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Wirfs </b><a name="14866429">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=MeadowlandsMike"> MeadowlandsMike </a>  :  4/12/2020  7:44 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866429">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866395" target="_blank">14866395</a> stretch234 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> My issue with him is that guys that don’t play LT in college do not suddenly come to the NFL able to switch to the left.   The list is long going the other way, but who has done it the other way<br />
<br />
Saying that, in today’s game with quality DE on both sides, you need 2 good tackles. If you draft him play him at RT and have a dominant R side<br />
<br />
You can live helping out 1 side.<br />
<br />
Now regarding C ..... </td>
                                </tr>
                           </table><br />
<br />
Small sample size but he apparently played 3 games at LT and the tape is pretty strong considering the in season switch</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Wirfs </b><a name="14866431">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=MeadowlandsMike"> MeadowlandsMike </a>  :  4/12/2020  7:45 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866431">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866429" target="_blank">14866429</a> MeadowlandsMike said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14866395 stretch234 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     My issue with him is that guys that don’t play LT in college do not suddenly come to the NFL able to switch to the left.   The list is long going the other way, but who has done it the other way<br />
<br />
Saying that, in today’s game with quality DE on both sides, you need 2 good tackles. If you draft him play him at RT and have a dominant R side<br />
<br />
You can live helping out 1 side.<br />
<br />
Now regarding C ..... <br />
                                <br />
                           <br />
<br />
Small sample size but he apparently played 3 games at LT and the tape is pretty strong considering the in season switch </td>
                                </tr>
                           </table><br />
<br />
If they saw Scherff as a tackle (which they were wrong about) they most likely would see this kid as one too.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: If we walk away with Simmons in RD1 and  </b><a name="14866457">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Rjanyg"> Rjanyg </a>  :  4/12/2020  8:43 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866457">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866141" target="_blank">14866141</a> Metnut said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Cleveland in RD2, I’d be really pumped. </td>
                                </tr>
                           </table><br />
<br />
Same.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Just have a feeling </b><a name="14866461">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Rjanyg"> Rjanyg </a>  :  4/12/2020  8:46 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866461">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=596887&show_all=1#14866314" target="_blank">14866314</a> M.S. said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br />
That Gettleman has confidence in his ability to find good offensive linemen after Round One.<br />
<br />
Translation: Isaiah Simmons is the pick at 4. </td>
                                </tr>
                           </table><br />
<br />
Same</div></div><div class="thread_post"><div class="thread_post_header"><b>Be a mistake if they don't take an ol at 4 </b><a name="14866526">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=micky"> micky </a>  :  4/12/2020  11:11 pm   : <a href="index.php?mode=2&thread=596887&show_all=1#14866526">link</a>   </div></div><div class="thread_post_body">.</div></div><a name="END"><a href="index.php"><div style="padding-top:25px; padding-bottom:20px;"><img src="/images/back_corner.gif" class="thread_link"  alt="Back to the Corner" border="0"></a></div></a></div>
<div class="thread_sidebar_2">

<!-- Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-102">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Corner Forum - Lower 300x250 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1566320450447229"
     data-ad-slot="4189314539"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->

</div>

</div>




<div class="footer">


<p style="width:400px;float:left;"><b>Part of the USA Today Sports Media Group</b><br>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</P>
<P  style="width:400px;float:right; text-align:right;">
All contents (unless otherwise specified) copyright &copy;  1995 - 2020<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Solutions</a>
</P>
<br clear="all">
<div style="float:right;">
<script
    src="https://sucuri.net/monitoring/badge.js"
    data-s="19"
    id="sucuri-s"
    data-i="7b1b29ae50ae6574f2af3875935246e4fa8a805b26"
    data-p="o" - position - l(left) or r(right) or o(relative)
    data-c="l"
    data-t="t"
    ></script>
</div>

</div>


<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->

<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=32', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=32', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=188-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'>(function(){function b(a){for(var b=0;b<document.styleSheets.length;b++)if(document.styleSheets[b].href==a)return!0;return!1}var a=function(a,b){for(var d=0;d<b.length;d++){var c=b[d];if(0==c.complete||"undefined"!=typeof c.readyState&&4>c.readyState){var g=c.getAttribute("src")||c.currentSrc;"undefined"!=typeof c.readyState&&0==c.readyState?c.addEventListener("loadstart",function(a){var b=a.getAttribute("src")||a.currentSrc;window.ezorqs(a,b)}):(g=c.getAttribute("src")||c.currentSrc,window.ezorqs(c,
	g));c.addEventListener("load",function(a){var b=a.currentTarget.getAttribute("src")||a.srcElement.currentSrc;window.ezorqe(a,b)});c.addEventListener("loadeddata",function(a){var b=a.currentTarget.getAttribute("src")||a.srcElement.currentSrc;window.ezorqe(a,b)});c.addEventListener("error",function(a){var b=a.currentTarget.getAttribute("src")||a.srcElement.currentSrc;window.ezorqe(a,b)})}}};a("img",document.querySelectorAll("img"));a("video",document.querySelectorAll("video"));a("audio",document.querySelectorAll("audio"));
	(function(a){for(var c=0;c<a.length;c++){var d=a[c];if(("preload"==d.getAttribute("rel")||"stylesheet"==d.getAttribute("rel"))&&null!=d.getAttribute("href")&&b(d.getAttribute("href"))){window.ezorqs(d,d.getAttribute("href"));var e=document.createElement("img");e.onerror=function(a){"undefined"!=typeof a.path&&"undefined"!=typeof a.path[0].currentSrc?window.ezorqe(d,a.path[0].currentSrc):"undefined"!=typeof a.srcElement&&"undefined"!=typeof a.srcElement.href&&window.ezorqe(d,a.srcElement.href)};e.src=
	d.getAttribute("href")}}})(document.querySelectorAll("link"));"undefined"!=typeof window.__ez.ssaf&&-1<window.__ez.ssaf.indexOf(16)&&"undefined"!==typeof window.__ez.sshsdef&&!1===window.__ez.sshsdef&&Element.prototype.addEventListener&&("function"==typeof window.onload&&(window.addEventListener("load",window.onload),window.onload=null),"function"==typeof document.onload&&(document.addEventListener.addEventListener("load",document.onload),document.onload=null))})();</script></body>
</html>
