<!DOCTYPE html>
<html lang="en">
<head><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">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</script>
<title>What other RB, past or present is most similar to Barkley? | Big Blue Interactive </title>


<meta name="keywords" content="ndglbqfkxx">

<meta name="description" content="Talking pigskin at work today and we were trying to think of which running back in the NFL was most like Barkley. We came up with Barry Sanders, because he could score anytime he touched the ball from anywhere on the field and Sanders was a terrific receiver. But the body type obvy isn’t the same. The other backs we considered were Walter Payton, which is close but I think Payton was a much more physical runner than Barks has been so far. I was also thinking maybe Eric Dickerson? He was so smooth and he had that get away gear where he just seemed to pull away from the defenders. Ultimately though, none of these seems quite right as a comparison to Saquon. Barkley is so strong and so big and fast and with good hands and smart and great off the field too (which isn’t necessarily part of the comparison but I think Walter Payton was the greatest RB and a great person).  Anyway, what back do you think he’s most like, past or present?"/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="website" />
<meta property="og:description" content="Talking pigskin at work today and we were trying to think of which running back in the NFL was most like Barkley. We came up with Barry Sanders, because he could score anytime he touched the ball from anywhere on the field and Sanders was a terrific receiver. But the body type obvy isn’t the same. The other backs we considered were Walter Payton, which is close but I think Payton was a much more physical runner than Barks has been so far. I was also thinking maybe Eric Dickerson? He was so smooth and he had that get away gear where he just seemed to pull away from the defenders. Ultimately though, none of these seems quite right as a comparison to Saquon. Barkley is so strong and so big and fast and with good hands and smart and great off the field too (which isn’t necessarily part of the comparison but I think Walter Payton was the greatest RB and a great person).  Anyway, what back do you think he’s most like, past or present?" /> 
<meta property="og:title" content="What other RB, past or present is most similar to Barkley?" /> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif" /> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css?v=20200217" />

<link rel="stylesheet" type="text/css" href="anylink.css" />


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}


div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" alt="for display only">

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type='text/javascript'>
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type='text/javascript' src='https://img.bnqt.com/lib/js/sdpdfphelper.js'></script>
<script type='text/javascript'>
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>


<!-- End DFP SETUP -->  

<!-- End USA Today Code -->





<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-131124163-7";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-131124163-7']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'bigblueinteractive.com']);
_gaq.push(['f._setDomainName', 'bigblueinteractive.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod1',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','bigblueinteractive.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://corner.bigblueinteractive.com/index.php?mode=2&thread=598582"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"domain_test_group":20200409,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"3eedc2c7-2a57-4413-5f7a-b328afb1ac9f","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":60,"serverid":"18.232.181.142:27849","state":"VA","t_epoch":1591225202,"template_id":126,"time_on_site_visit":0,"url":"https://corner.bigblueinteractive.com/index.php?mode=2\u0026thread=598582","user_id":0,"word_count":4671,"worst_bad_word_level":3};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=188-0&v=8" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|3eedc2c7-2a57-4413-5f7a-b328afb1ac9f|false; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head>


<body>




<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"></a> <img src="images/xpete.gif" alt="The Corner Forum">

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic -->&nbsp;


<!-- Nov 2019 Leaderboard -->

<!-- Ezoic - Forum Leaderboard (USAT) - top_of_page -->
<div id="ezoic-pub-ad-placeholder-118">
<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->
<div id='usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general'>
     <script type='text/javascript'>
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general');
         });
     </script>
</div>
</div>
<!-- End Ezoic - Forum Leaderboard (USAT) - top_of_page -->



</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://www.shareasale.com/r.cfm?b=277504&u=723646&m=29078&urllink=&afftrack=">Apparel</a>
<a href="http://www.amazon.com/?_encoding=UTF8&camp=1789&creative=9325&linkCode=ur2&tag=bigblueintera-20">Amazon.com</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW" >Standings (NFL.com)</a>
<a href="https://www.giants.com/team/stats/" target="_NEW" >Statistics (Giants.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/" >Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'home_view_menu')">Home</a>  
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'forum_view_menu')">Corner Forum</a>
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'gameday_view_menu')">Gameday</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_view_menu')">Team</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_building_view_menu')">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info &amp; History</a> -->
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_info_view_menu')">Giants Info &amp; History</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'infolinks_view_menu')">Info/Links</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'shop_view_menu')">BBI Shop</a>
<li><a href="/index.php?mode=10" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'login_menu')">Log In</a>
</ul>

</div><div id="infoline"> </div>

<a name="END"><a href="index.php"><div style="padding-top:20px; padding-bottom:25px;"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"></a></div></a><div class="thread_container"><div class="thread_left"><div class="thread_body" ><div class="thread_main" ><div class="thread_post_header" >  <h1 style="font-size:18px;">What other RB, past or present is most similar to Barkley? </h1><div class="thread_info"><a href="index.php?mode=5&handle=trueblueinpw"> trueblueinpw </a>  :  6/2/2020  1:44 pm</div></div><div class="thread_post_body" > Talking pigskin at work today and we were trying to think of which running back in the NFL was most like Barkley. We came up with Barry Sanders, because he could score anytime he touched the ball from anywhere on the field and Sanders was a terrific receiver. But the body type obvy isn’t the same. The other backs we considered were Walter Payton, which is close but I think Payton was a much more physical runner than Barks has been so far. I was also thinking maybe Eric Dickerson? He was so smooth and he had that get away gear where he just seemed to pull away from the defenders.<br />
<br />
Ultimately though, none of these seems quite right as a comparison to Saquon. Barkley is so strong and so big and fast and with good hands and smart and great off the field too (which isn’t necessarily part of the comparison but I think Walter Payton was the greatest RB and a great person).  Anyway, what back do you think he’s most like, past or present? </div></div></div><div style="margin: 10 10 20 50"><span class="top_pages">Pages:  <a href="index.php?mode=2&thread=598582&thread_page=1" >1</a>  <b style="background: darkred;padding: 2px 5px 2px 5px;">2</b>  <a href="index.php?mode=2&thread=598582&thread_page=1" >&lt;&lt;Prev&nbsp;</a>| <a href="index.php?mode=2&thread=598582&show_all=1" title="">Show All</a> | </span></div>
</div><div class="thread_right"><div id="ad_side_box">


<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id='usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general'>
     <script type='text/javascript'>
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general');
         });
     </script>
</div>




</div></div><div class="thread_comment_container"><div class="thread_post"><div class="thread_post_header"><b>he's in his own world </b><a name="14914674">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Osi+Osi+Osi+OyOyOy"> Osi Osi Osi OyOyOy </a>  :  6/2/2020  2:38 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914674">link</a>   </div></div><div class="thread_post_body">Hershel Walker and Bo Jackson were similar to Barkley in terms of size/speed, they were both probably a little bit faster. Barry Sanders was even quicker and explosive at cutting than Barkley, but Barkley has a similar ability.<br />
<br />
The only other guy in NFL history to come close to combining Bo Jackson's size/speed ratio with Barry Sanders' explosive cutting was Jim Brown. Except Brown was also much bigger relative to his era and more willing to run straight through people, imagine Derrick Henry with Barkley's moves. There's a reason Brown's the GOAT.<br />
<br />
He's not really close to Jim Brown's power but he's probably the most complete physical specimen we've seen at the RB position in the last 50 years. <br />
<br />
The only thing keeping him back from being a legend is his tendency to dance too much and questionable vision. By "questionable vision" I mean compared to the greats. Hopefully experience + a better OL helps him reach his potential.</div></div><div class="thread_post"><div class="thread_post_header"><b>Faster more athletic Le'Veon Bell imo </b><a name="14914678">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Belowtheshadows"> Belowtheshadows </a>  :  6/2/2020  2:41 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914678">link</a>   </div></div><div class="thread_post_body">He's almost like a Bell clone to me. Their  style of play and abilities are very similar.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: would still like barkley to not dance aound as much as sanders </b><a name="14914681">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=KDavies"> KDavies </a>  :  6/2/2020  2:50 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914681">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=598582&show_all=1#14914673" target="_blank">14914673</a> UConn4523 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14914667 Payasdaddy said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     could be OLINE   but sometimes 1 cuts and 4 yards works<br />
probably multiple things that cause this <br />
                                <br />
                           <br />
<br />
I'd like that too, but he also breaks 80 yarders because of them so I'll take the good with the bad. I'd also like to see him with a better O-line to see how it effects his patience.<br />
<br />
All things considered he rushed for 5 yards a clip his rookie year, 4.8 pyc overall behind a really bad line. </td>
                                </tr>
                           </table><br />
<br />
Exactly, I loved Barry Sanders and watched him every chance I could get.  It's a catch-22 with those guys.  In a sense, their strength is also a weakness.  Yes, it is frustrating to watch them go 10 carries for 1 yard, and barely getting by the line of scrimmage.<br />
<br />
However, the patience and vision that produces that is also what allows for the 80 yard runs.  An added aspect is that rather than the 4 yards a clip bruisers, I am hopeful Barkley's career will be a bit longer than the average back.<br />
<br />
An improved OL and a mobile QB will be huge for Barkley.  I expect him to reach a whole new level in the next couple of years.</div></div><div class="thread_post"><div class="thread_post_header"><b>To me he’s very close to Faulk  </b><a name="14914683">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=NoGainDayne"> NoGainDayne </a>  :  6/2/2020  2:53 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914683">link</a>   </div></div><div class="thread_post_body">young Faulk was very explosive. He ran a faster 40 than Barkley. I think Barkley accelerates better which is why he can break more big runs IMO, less opportunity to get a hand on him at the line before he gets outside.<br />
<br />
Faulk had better vision though IMO. Barkley sometimes doesn’t see how to take what the defense is giving him. Vision can definitely improve easier than acceleration though</div></div><div class="thread_post"><div class="thread_post_header"><b>Not to signal the analytics freaks </b><a name="14914685">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ron+mexico"> ron mexico </a>  :  6/2/2020  2:58 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914685">link</a>   </div></div><div class="thread_post_body">But is there something like a volatility adjusted average for RBs?<br />
<br />
Something like the sharp ratio for rushing stats. <br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>I see </b><a name="14914686">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ChicagoMarty"> ChicagoMarty </a>  :  6/2/2020  3:02 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914686">link</a>   </div></div><div class="thread_post_body">a lot of Adrian Peterson in his prime in that Pete could break away on any play at any time. He also could fumble at any time but that reminds more of our qb than our rb.</div></div><div class="thread_post"><div class="thread_post_header"><b>Similar to? </b><a name="14914688">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+%2756"> Big Blue '56 </a>  :  6/2/2020  3:09 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914688">link</a>   </div></div><div class="thread_post_body">Most RBs in the later rounds...</div></div><div class="thread_post"><div class="thread_post_header"><b>I think he </b><a name="14914696">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Lines+of+Scrimmage"> Lines of Scrimmage </a>  :  6/2/2020  3:42 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914696">link</a>   </div></div><div class="thread_post_body">has traits of many past greats and the great ones all have a uniqueness.  What I think will define him like a lot of great players is can he stay on the field?  The OL will be better this year and next year it may be a strength so his talent is going to really show imo.<br />
<br />
I remember hearing Jim Brown talk on a show long ago about being the best ever and why he was.  He said something along the lines of having played 9 years and never missed a play.....remarkable.</div></div><div class="thread_post"><div class="thread_post_header"><b>Sanders was the greatest RB ever... </b><a name="14914700">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Milton"> Milton </a>  :  6/2/2020  3:58 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914700">link</a>   </div></div><div class="thread_post_body">...if you're putting together a highlight reel, but if you're putting together an offensive game plan, not so much. He was of very little use in the passing game. Hard to coach 80-yard TD runs sprinkled among three-and-outs.<br />
<br />
I've always said Gale Sayers was the best comparison, but it's far from exact.<br><a href="https://www.youtube.com/watch?v=2Ftn68PZSws"> Gale Sayers </a> - (<a href="https://www.youtube.com/watch?v=2Ftn68PZSws" target="_NEW"> New Window </a>)</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: would still like barkley to not dance aound as much as sanders </b><a name="14914704">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Victor+in+CT"> Victor in CT </a>  :  6/2/2020  4:16 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914704">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=598582&show_all=1#14914673" target="_blank">14914673</a> UConn4523 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14914667 Payasdaddy said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     could be OLINE   but sometimes 1 cuts and 4 yards works<br />
probably multiple things that cause this <br />
                                <br />
                           <br />
<br />
I'd like that too, but he also breaks 80 yarders because of them so I'll take the good with the bad. I'd also like to see him with a better O-line to see how it effects his patience.<br />
<br />
All things considered he rushed for 5 yards a clip his rookie year, 4.8 pyc overall behind a really bad line. </td>
                                </tr>
                           </table><br />
<br />
I think it's more about judgement. THere's a time and place. Emmitt Smith was great about that. When the game situation calls for getting the 3rd and 2 and keeping the ball, get the damn 2 yards, don't dance around. when the big play is more necessary, than go ahead and try for the home run play.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Sanders was the greatest RB ever... </b><a name="14914705">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=OdellBeckhamJr"> OdellBeckhamJr </a>  :  6/2/2020  4:18 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914705">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=598582&show_all=1#14914700" target="_blank">14914700</a> Milton said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> ...if you're putting together a highlight reel, but if you're putting together an offensive game plan, not so much. He was of very little use in the passing game. Hard to coach 80-yard TD runs sprinkled among three-and-outs.<br />
<br />
I've always said Gale Sayers was the best comparison, but it's far from exact. Gale Sayers  - ( New Window ) </td>
                                </tr>
                           </table><br />
<br />
I could see the comparison there.<br />
<br />
I watched an old Bears game not long ago and thought Saquon was similar to Payton.<br />
<br />
I think he's most similar to Thurman Thomas. Just bigger and stronger.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: OJ Simpson </b><a name="14914709">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=flycatcher"> flycatcher </a>  :  6/2/2020  4:25 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914709">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=598582&show_all=1#14914670" target="_blank">14914670</a> Thegratefulhead said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> The Juice could run you over, jump over you or juke you out of your socks. Hopefully SB doesn't have the stab you part of his game. </td>
                                </tr>
                           </table><br />
Great comp</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Sanders was the greatest RB ever... </b><a name="14914712">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=USAF+NYG+Fan"> USAF NYG Fan </a>  :  6/2/2020  4:31 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914712">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=598582&show_all=1#14914700" target="_blank">14914700</a> Milton said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> ...if you're putting together a highlight reel, but if you're putting together an offensive game plan, not so much. He was of very little use in the passing game. Hard to coach 80-yard TD runs sprinkled among three-and-outs.<br />
<br />
I've always said Gale Sayers was the best comparison, but it's far from exact. Gale Sayers  - ( New Window ) </td>
                                </tr>
                           </table><br />
<br />
This.  Running style keeps reminding me of Gale Sayers highlights.  Now Barkley is his own RB that can run agry but the moves though ....</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: would still like barkley to not dance aound as much as sanders </b><a name="14914713">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=averagejoe"> averagejoe </a>  :  6/2/2020  4:32 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914713">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=598582&show_all=1#14914681" target="_blank">14914681</a> KDavies said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14914673 UConn4523 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     In comment 14914667 Payasdaddy said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     could be OLINE   but sometimes 1 cuts and 4 yards works<br />
probably multiple things that cause this <br />
                                <br />
                           <br />
<br />
I'd like that too, but he also breaks 80 yarders because of them so I'll take the good with the bad. I'd also like to see him with a better O-line to see how it effects his patience.<br />
<br />
All things considered he rushed for 5 yards a clip his rookie year, 4.8 pyc overall behind a really bad line. <br />
                                <br />
                           <br />
<br />
Exactly, I loved Barry Sanders and watched him every chance I could get.  It's a catch-22 with those guys.  In a sense, their strength is also a weakness.  Yes, it is frustrating to watch them go 10 carries for 1 yard, and barely getting by the line of scrimmage.<br />
<br />
However, the patience and vision that produces that is also what allows for the 80 yard runs.  An added aspect is that rather than the 4 yards a clip bruisers, I am hopeful Barkley's career will be a bit longer than the average back.<br />
<br />
An improved OL and a mobile QB will be huge for Barkley.  I expect him to reach a whole new level in the next couple of years. </td>
                                </tr>
                           </table><br />
 The problem with Barkley/Sanders is obvious. Giants get ten possessions a game. They break one long spectacular run per game. Everyone is amazed and thrilled. The other nine possessions they have no yards and Giants are punting. That does not really help their teams win. Patience is not a virtue when you are trying to move the chains. He needs to run harder between tackles.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: would still like barkley to not dance aound as much as sanders </b><a name="14914715">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=UConn4523"> UConn4523 </a>  :  6/2/2020  4:43 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914715">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=598582&show_all=1#14914704" target="_blank">14914704</a> Victor in CT said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14914673 UConn4523 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     In comment 14914667 Payasdaddy said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     could be OLINE   but sometimes 1 cuts and 4 yards works<br />
probably multiple things that cause this <br />
                                <br />
                           <br />
<br />
I'd like that too, but he also breaks 80 yarders because of them so I'll take the good with the bad. I'd also like to see him with a better O-line to see how it effects his patience.<br />
<br />
All things considered he rushed for 5 yards a clip his rookie year, 4.8 pyc overall behind a really bad line. <br />
                                <br />
                           <br />
<br />
I think it's more about judgement. THere's a time and place. Emmitt Smith was great about that. When the game situation calls for getting the 3rd and 2 and keeping the ball, get the damn 2 yards, don't dance around. when the big play is more necessary, than go ahead and try for the home run play. </td>
                                </tr>
                           </table><br />
<br />
I don't disagree but we are talking about two pretty opposite end of the spectrum OLines.<br />
<br />
I don't think we know for sure what Barkley will do with a competent OLine in front of him. Maybe he still tries to do too much on occasion, or maybe his awareness is better since he will have more to work with. What I do know is that without him hitting those huge runs we are an even worse football team so I guess we will see.</div></div><div class="thread_post"><div class="thread_post_header"><b>Has Barkley played with a decent OL yet? </b><a name="14914717">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=George+from+PA"> George from PA </a>  :  6/2/2020  4:54 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914717">link</a>   </div></div><div class="thread_post_body">Lets be fair.....he might get caught for a one yard gain.<br />
<br />
But if OL can run block....Barkely with legit holes....watch out</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: would still like barkley to not dance aound as much as sanders </b><a name="14914719">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  :  6/2/2020  5:04 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914719">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=598582&show_all=1#14914713" target="_blank">14914713</a> averagejoe said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">              <br />
                           <br />
 The problem with Barkley/Sanders is obvious. Giants get ten possessions a game. They break one long spectacular run per game. Everyone is amazed and thrilled. The other nine possessions they have no yards and Giants are punting. That does not really help their teams win. Patience is not a virtue when you are trying to move the chains. He needs to run harder between tackles. </td>
                                </tr>
                           </table><br />
<br />
While I am sure Barkley would agree he has things he still needs to develop with his game, him running harder between the tackles is probably #198 on the problems the NY Giants need to concern themselves with.</div></div><div class="thread_post"><div class="thread_post_header"><b>I </b><a name="14914722">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=DG_89"> DG_89 </a>  :  6/2/2020  5:14 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914722">link</a>   </div></div><div class="thread_post_body">was gonna say Edgerrin James or Ahman Green but neither one have Barkley's power. However both guys could run and were damn good receivers</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: OJ Simpson </b><a name="14914726">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Dave"> Dave </a>  :  6/2/2020  5:35 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914726">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=598582&show_all=1#14914670" target="_blank">14914670</a> Thegratefulhead said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> The Juice could run you over, jump over you or juke you out of your socks. Hopefully SB doesn't have the stab you part of his game. </td>
                                </tr>
                           </table><br />
<br />
this is who i think of too</div></div><div class="thread_post"><div class="thread_post_header"><b>one and only.... </b><a name="14914727">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BCD"> BCD </a>  :  6/2/2020  5:41 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914727">link</a>   </div></div><div class="thread_post_body">.....</div></div><div class="thread_post"><div class="thread_post_header"><b>Eric Dickerson.  He had the same combination of great speed and power. </b><a name="14914729">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jack+Stroud"> Jack Stroud </a>  :  6/2/2020  5:51 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914729">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>Saquon is 25 lbs heavier </b><a name="14914731">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Chip"> Chip </a>  :  6/2/2020  5:51 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914731">link</a>   </div></div><div class="thread_post_body">than Simpson, Billy Sims both 210.  As well as Sanders, Tomlinson and Sayers.  He potentially can be better than all of them.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: one and only.... </b><a name="14914732">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=eric2425ny"> eric2425ny </a>  :  6/2/2020  5:58 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914732">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=598582&show_all=1#14914727" target="_blank">14914727</a> BCD said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> ..... </td>
                                </tr>
                           </table><br />
<br />
Agreed, I can’t really find a comparable. He’s like five of these guys rolled into one.  He’s got some Barry Sanders, some OJ, some Dickerson, some Sayers, some Bo Jackson.<br />
<br />
What makes a comparison difficult is the fact that his closest comparable players in terms of size and speed mostly played when RB’s were not really utilized in the passing game.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Saquon is 25 lbs heavier </b><a name="14914740">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Milton"> Milton </a>  :  6/2/2020  6:48 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914740">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=598582&show_all=1#14914731" target="_blank">14914731</a> Chip said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> than Simpson, Billy Sims both 210.  As well as Sanders, Tomlinson and Sayers.  He potentially can be better than all of them. </td>
                                </tr>
                           </table>Everybody is 25 lbs heavier now. Sayers played in the day when 300 pound linemen were few and far between.</div></div><div class="thread_post"><div class="thread_post_header"><b>Twitchier ray rice </b><a name="14914744">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=nyballa0891"> nyballa0891 </a>  :  6/2/2020  7:05 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914744">link</a>   </div></div><div class="thread_post_body">Think body types and skill sets are similar, saquon is just more athletically gifted</div></div><div class="thread_post"><div class="thread_post_header"><b>A stronger Marshall Faulk? </b><a name="14914750">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=sb+from+NYT+Forum"> sb from NYT Forum </a>  :  6/2/2020  7:57 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914750">link</a>   </div></div><div class="thread_post_body">Thurman Thomas maybe?</div></div><div class="thread_post"><div class="thread_post_header"><b>I'm in the Bo Jackson </b><a name="14914777">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Boatie+Warrant"> Boatie Warrant </a>  :  6/2/2020  9:49 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914777">link</a>   </div></div><div class="thread_post_body">Barry Sanders camp.  He can do what they both could.  The question is will he for an entire career and at a high level?</div></div><div class="thread_post"><div class="thread_post_header"><b>Thank you everyone </b><a name="14914781">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=arniefez"> arniefez </a>  :  6/2/2020  10:00 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914781">link</a>   </div></div><div class="thread_post_body">I really needed a good laugh. This thread is hilarious. If BBI is still around someone needs to repost this in about 5 years and we'll see how Barkley compares to the all time greats. In the mean time maybe he can pick up a blitz or two and run over a few guys in between the tackles for a few first downs.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Thank you everyone </b><a name="14914789">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Belowtheshadows"> Belowtheshadows </a>  :  6/2/2020  10:18 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14914789">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=598582&show_all=1#14914781" target="_blank">14914781</a> arniefez said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I really needed a good laugh. This thread is hilarious. If BBI is still around someone needs to repost this in about 5 years and we'll see how Barkley compares to the all time greats. In the mean time maybe he can pick up a blitz or two and run over a few guys in between the tackles for a few first downs. </td>
                                </tr>
                           </table> Man you're hilarious. You must have thought Marshall Faulk was pure shit after his first 3 seasons. Because running over guys is what delineates a great back from a bad back.Yeah he definitely should run through the tackles when the line is creating zero holes.</div></div><div class="thread_post"><div class="thread_post_header"><b>According to SI.com's latest survey of </b><a name="14914803">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BlueLou%27sBack"> BlueLou'sBack </a>  : 12:42 am   : <a href="index.php?mode=2&thread=598582&show_all=1#14914803">link</a>   </div></div><div class="thread_post_body">"NFL scouts", Zeke Elliot is the best RB in the NFC East.<br />
<br />
Must've tabbed Marc Ross for that opinion, and others with similar skills.</div></div><div class="thread_post"><div class="thread_post_header"><b>Belichick called Barkley the best RB in the league </b><a name="14914805">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Milton"> Milton </a>  : 1:24 am   : <a href="index.php?mode=2&thread=598582&show_all=1#14914805">link</a>   </div></div><div class="thread_post_body">Not the obligatory "one of the best" that we generally hear when teams are facing a top RB. He felt safe saying "the best" because he was just stating the obvious.</div></div><div class="thread_post"><div class="thread_post_header"><b>Floyd Little </b><a name="14914806">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=No+Where+Man"> No Where Man </a>  : 1:26 am   : <a href="index.php?mode=2&thread=598582&show_all=1#14914806">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Thank you everyone </b><a name="14914807">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BlueLou%27sBack"> BlueLou'sBack </a>  : 2:12 am   : <a href="index.php?mode=2&thread=598582&show_all=1#14914807">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=598582&show_all=1#14914781" target="_blank">14914781</a> arniefez said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I really needed a good laugh. This thread is hilarious. If BBI is still around someone needs to repost this in about 5 years and we'll see how Barkley compares to the all time greats. In the mean time maybe he can pick up a blitz or two and run over a few guys in between the tackles for a few first downs. </td>
                                </tr>
                           </table><br />
<br />
If BBI is around? I'll bet BBI outlasts arniefez...<br />
<br />
It takes a special kinda Stoopid to hate on Barkley. I can understand "no RB is worth the 2nd overall pick" argument even if I don't buy in, but hating Saquon and professing he lacks talent?<br />
<br />
That takes a sub simian IQ.</div></div><div class="thread_post"><div class="thread_post_header"><b>Walter... </b><a name="14914811">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Brown_Hornet"> Brown_Hornet </a>  : 7:38 am   : <a href="index.php?mode=2&thread=598582&show_all=1#14914811">link</a>   </div></div><div class="thread_post_body">...Payton.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Thank you everyone </b><a name="14914814">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=UConn4523"> UConn4523 </a>  : 8:21 am   : <a href="index.php?mode=2&thread=598582&show_all=1#14914814">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=598582&show_all=1#14914781" target="_blank">14914781</a> arniefez said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I really needed a good laugh. This thread is hilarious. If BBI is still around someone needs to repost this in about 5 years and we'll see how Barkley compares to the all time greats. In the mean time maybe he can pick up a blitz or two and run over a few guys in between the tackles for a few first downs. </td>
                                </tr>
                           </table><br />
<br />
Maybe you can put your money where your mouth is and actually post something that's worth reading on occasion. I don't expect you to bat 1,000 but i'm not sure if you've even gotten on base yet.</div></div><div class="thread_post"><div class="thread_post_header"><b>Saquon Barkley </b><a name="14914824">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=arniefez"> arniefez </a>  : 8:42 am   : <a href="index.php?mode=2&thread=598582&show_all=1#14914824">link</a>   </div></div><div class="thread_post_body">seems like a good person and someone worth rooting for. You don't have to be a SR VP of Player Personnel to see he is insanely talented and has athletic gifts that are rare.<br />
<br />
While being one of the worst teams in the NFL using the 2nd pick in the draft on a RB is one of the biggest of dozens of horrible decisions the Giants have made since Super Bowl 46. <br />
<br />
The horse is dead from explaining the lack of positional value, salary cap implications and lack of supporting talent.<br />
<br />
The Giants record since Barkley was drafted speaks for itself. <br />
<br />
So many of the great RBs that people on this thread are WAY WAY prematurely comparing Barkley to never won a thing. Sanders, OJ, Dickerson, even Payton, who finally won as a passenger at the very end, were sideshows not part of winning teams.<br />
<br />
Barkley is two years in let's see where he is 5 years from now.</div></div><div class="thread_post"><div class="thread_post_header"><b>we get it </b><a name="14914837">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=UConn4523"> UConn4523 </a>  : 9:08 am   : <a href="index.php?mode=2&thread=598582&show_all=1#14914837">link</a>   </div></div><div class="thread_post_body">you let us know every chance you get. Maybe move on?<br />
<br />
The OP asked about the closest comparison in the history of the league, he didn't ask about anything else.</div></div><div class="thread_post"><div class="thread_post_header"><b>and you still don't understand the question </b><a name="14914839">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=UConn4523"> UConn4523 </a>  : 9:09 am   : <a href="index.php?mode=2&thread=598582&show_all=1#14914839">link</a>   </div></div><div class="thread_post_body">no one is comparing careers and the responses have been pretty clear that they are comparing the talent level, running style, etc.<br />
<br />
No one is saying that to date Barkley has equaled Barry Sanders' or Marshall Faulk in career achievements.</div></div><div class="thread_post"><div class="thread_post_header"><b>LOL... </b><a name="14914854">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=FatMan+in+Charlotte"> FatMan in Charlotte </a>  : 9:35 am   : <a href="index.php?mode=2&thread=598582&show_all=1#14914854">link</a>   </div></div><div class="thread_post_body">The rationalization here is funny!<br />
<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">even Payton, who finally won as a passenger at the very end, were sideshows not part of winning teams</td>
                                </tr>
                           </table><br />
<br />
Over 1500 yards and 9 TD's is being a "passenger"?? I like how you didn't mention the RB's who he's compared to who had team success like Brown, Dorsett and Faulk.<br />
<br />
Not only that, it was another way to work in the angle that it is management's fault!!</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Similar to? </b><a name="14914855">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=mfsd"> mfsd </a>  : 9:37 am   : <a href="index.php?mode=2&thread=598582&show_all=1#14914855">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=598582&show_all=1#14914688" target="_blank">14914688</a> Big Blue '56 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Most RBs in the later rounds... </td>
                                </tr>
                           </table><br />
<br />
Haha this is the post of the thread.<br />
<br />
The question is, who is Sam Darnold most similar to?<br />
<br />
I’d say a combo of Brady, Marino and Montana, only better. With the speed of Vick and the size and durability of Big Ben.<br />
<br />
In fact the only real Darnold comp is Superman.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Saquon Barkley </b><a name="14914865">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=KDavies"> KDavies </a>  : 9:46 am   : <a href="index.php?mode=2&thread=598582&show_all=1#14914865">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=598582&show_all=1#14914824" target="_blank">14914824</a> arniefez said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> seems like a good person and someone worth rooting for. You don't have to be a SR VP of Player Personnel to see he is insanely talented and has athletic gifts that are rare.<br />
<br />
While being one of the worst teams in the NFL using the 2nd pick in the draft on a RB is one of the biggest of dozens of horrible decisions the Giants have made since Super Bowl 46. <br />
<br />
The horse is dead from explaining the lack of positional value, salary cap implications and lack of supporting talent.<br />
<br />
The Giants record since Barkley was drafted speaks for itself. <br />
<br />
So many of the great RBs that people on this thread are WAY WAY prematurely comparing Barkley to never won a thing. Sanders, OJ, Dickerson, even Payton, who finally won as a passenger at the very end, were sideshows not part of winning teams.<br />
<br />
Barkley is two years in let's see where he is 5 years from now. </td>
                                </tr>
                           </table><br />
<br />
Um, ok. Those players were hardly sideshows.  Obviously, you need more than just a great RB to win football games.  Big insight there.  <br />
<br />
Are you seriously arguing that there is a correlation to where great RBs lead to losing football?  You conveniently leave out all of the great RBs that have been on winning teams, including some mentioned in this thread (ie. Faulk).<br />
<br />
I can cite Dan Marino and leave out all of the great QBs who have won SBs and say just because you have a great QB, doesn't mean you win.  Genius argument.</div></div><div class="thread_post"><div class="thread_post_header"><b>Sweetness, a passenger? </b><a name="14914871">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=trueblueinpw"> trueblueinpw </a>  : 9:51 am   : <a href="index.php?mode=2&thread=598582&show_all=1#14914871">link</a>   </div></div><div class="thread_post_body">Baha haha!<br />
<br />
In a year of ridiculous statements, that may actually be the most ridiculous. <br />
<br />
But, yeah, thanks for coming out.</div></div><div class="thread_post"><div class="thread_post_header"><b>Bigger, more powerful version of Faulk but a different kind of wiggle </b><a name="14914877">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JonC"> JonC </a>  : 9:58 am   : <a href="index.php?mode=2&thread=598582&show_all=1#14914877">link</a>   </div></div><div class="thread_post_body">He has rare elusiveness especially for 230 lbs and is very hard to tackle for one defender, but I don't see a ton of Sanders in him.  Sanders was unique in that defenders struggled to even lay a hand on him.<br />
<br />
He's got some Bo Jackson in him in how he can get to and capture the edge for breakaway runs, but no back had Bo's blazing straight line speed.<br />
<br />
The only back that reminds me of Dickerson was Ahman Green, with the smooth, silent, pumping high knee sprinter's gate.  Dickerson was next-generation talent in his prime.</div></div><div class="thread_post"><div class="thread_post_header"><b>What would Elway do without that passenger </b><a name="14914878">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=UConn4523"> UConn4523 </a>  : 9:59 am   : <a href="index.php?mode=2&thread=598582&show_all=1#14914878">link</a>   </div></div><div class="thread_post_body">Terrell Davis?</div></div><div class="thread_post"><div class="thread_post_header"><b>Sideshows </b><a name="14914880">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  : 10:04 am   : <a href="index.php?mode=2&thread=598582&show_all=1#14914880">link</a>   </div></div><div class="thread_post_body">Barry Sanders<br />
OJ Simpson<br />
Eric Dickerson<br />
Walter Peyton<br />
<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Tomlinson is a good answer  </b><a name="14914888">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+on+Li"> Eric on Li </a>  : 10:19 am   : <a href="index.php?mode=2&thread=598582&show_all=1#14914888">link</a>   </div></div><div class="thread_post_body">he was probably a little better between the tackles and Barkley a little better home run hitter, but pretty similar. 2 best all around running backs since Marshall Faulk probably (since AP was never as much of a threat as a receiver).  <br />
<br />
Just need to hope Saquon can have the same kind of longevity as those guys. <br />
<br />
Tomlinson had 8 1k seasons, 5 pro bowls, and 3 all pro. <br />
Faulk had 7 1k seasons, 8 pro bowls, and 3 all pro. <br />
<br />
Saquon is 2/2 with 1k seasons and has 1 pro bowl so he is on track if he can have another 5 good years out of the 7 years left in his 20's.</div></div><div class="thread_post"><div class="thread_post_header"><b>Like Barkley </b><a name="14914911">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=blueblood"> blueblood </a>  : 10:51 am   : <a href="index.php?mode=2&thread=598582&show_all=1#14914911">link</a>   </div></div><div class="thread_post_body">hasnt done enough for me yet to give an accurate comparison. Right now Id say Faulk or Edgerrin James.</div></div><div class="thread_post"><div class="thread_post_header"><b>I’m thinking Faulk is the closest... </b><a name="14914932">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=trueblueinpw"> trueblueinpw </a>  : 11:48 am   : <a href="index.php?mode=2&thread=598582&show_all=1#14914932">link</a>   </div></div><div class="thread_post_body">Barks is mid height for a back, so not long and strong like E Dick and Eddie George and AP. Not short and hiding behind the OL before exploding into the second level LBs like Emitt and Barry. Your gonna see Barks coming at you but he’s got that wiggle in the hole, he can run over LBs and he’s got that get away gear in the third level.<br />
<br />
He’s just not physical enough for me to compare him to Sweetness. Sweetness is the second greatest football player I’ve ever seen in my lifetime. And man was he physical. If you could catch him, he’d often make you wish you couldn’t. But body type, raw talent and overall game seem really close. Payton was a great team member, an outstanding human being and he was an amazing worker and everything I read about Barks is similar. <br />
<br />
Faulk seems like the best fit. I’m thinking here again about body type and talent set. Faulk was a terrific route runner and could read the defenses. I’m really hoping Garrett can get DJ8 and Barks some synergy and some great plays. This too though is gonna depend on Barks ability to pass pro. <br />
<br />
And yeah, I know Barks has a lot more to accomplish before he’s in the same room as Faulk and Payton who are two of the all time greatest ever to buckle a chin strap in the NFL. But he’s got the skills and the work ethic. Really looking forward to seeing what he does this season.</div></div><div class="thread_post"><div class="thread_post_header"><b>Passenger </b><a name="14915080">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=crick+n+NC"> crick n NC </a>  : 4:15 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14915080">link</a>   </div></div><div class="thread_post_body"><img src="https://i.ibb.co/TYsVxCR/20200603-161329.jpg"></div></div><div class="thread_post"><div class="thread_post_header"><b>Seeing TD on that list ^ </b><a name="14915092">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=trueblueinpw"> trueblueinpw </a>  : 4:47 pm   : <a href="index.php?mode=2&thread=598582&show_all=1#14915092">link</a>   </div></div><div class="thread_post_body">At 5'11" Dorsett is the same height as Barks but 40 pounds lighter! Barks is a freaking beast man. Speaking of beast's, Saquon is also the same height as Marshawn Lynch who's listed at 215. It's just crazy to think of how Barks can move that much weight the way he does. He could be such a punisher!</div></div><div style="margin: 10 10 20 50"><span class="top_pages">Pages:  <a href="index.php?mode=2&thread=598582&thread_page=1" >1</a>  <b style="background: darkred;padding: 2px 5px 2px 5px;">2</b>  <a href="index.php?mode=2&thread=598582&thread_page=1" >&lt;&lt;Prev&nbsp;</a>| <a href="index.php?mode=2&thread=598582&show_all=1" title="">Show All</a> | </span></div>
<a name="END"><a href="index.php"><div style="padding-top:25px; padding-bottom:20px;"><img src="/images/back_corner.gif" class="thread_link"  alt="Back to the Corner" border="0"></a></div></a></div>
<div class="thread_sidebar_2">

<!-- Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-102">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Corner Forum - Lower 300x250 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1566320450447229"
     data-ad-slot="4189314539"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->

</div>

</div>




<div class="footer">


<p style="width:400px;float:left;"><b>Part of the USA Today Sports Media Group</b><br>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</P>
<P  style="width:400px;float:right; text-align:right;">
All contents (unless otherwise specified) copyright &copy;  1995 - 2020<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Solutions</a>
</P>
<br clear="all">
<div style="float:right;">
<script
    src="https://sucuri.net/monitoring/badge.js"
    data-s="19"
    id="sucuri-s"
    data-i="7b1b29ae50ae6574f2af3875935246e4fa8a805b26"
    data-p="o" - position - l(left) or r(right) or o(relative)
    data-c="l"
    data-t="t"
    ></script>
</div>

</div>


<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->

<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=32', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=32', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=188-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script></body>
</html>
