<!DOCTYPE html>
<html lang="en">
<head><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData)});}}
function AddPixelById(impFullId,pixelData){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData)});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(__ez.template.isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
(new Image()).src=pixelURL;}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '//ezodn.com/detroitchicago/raleigh.js?gcb=188-0&cb=1', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '//ezodn.com/detroitchicago/tampa.js?gcb=188-0&cb=1', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '//ezodn.com/detroitchicago/tulsa.js?gcb=188-0&cb=1', false, [], true, false, true, false);</script>
<title>Giants sign previously-retired PK Chandler Catanzaro | Big Blue Interactive </title>


<meta name="keywords" content="ndglbqfkxx">

<meta name="description" content="Adam Schefter
@AdamSchefter Giants are signing former Jets’ kicker Chandler Catanzaro to a one-year deal, per league source. He retired last August and was released from the Jets’ reserve/left squad list just last week. With the Giants releasing Aldrick Rosas today, Catanzaro steps in."/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="website" />
<meta property="og:description" content="Adam Schefter
@AdamSchefter Giants are signing former Jets’ kicker Chandler Catanzaro to a one-year deal, per league source. He retired last August and was released from the Jets’ reserve/left squad list just last week. With the Giants releasing Aldrick Rosas today, Catanzaro steps in." /> 
<meta property="og:title" content="Giants sign previously-retired PK Chandler Catanzaro" /> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif" /> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css?v=20200217" />

<link rel="stylesheet" type="text/css" href="anylink.css" />


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}


div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" alt="for display only">

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type='text/javascript'>
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type='text/javascript' src='https://img.bnqt.com/lib/js/sdpdfphelper.js'></script>
<script type='text/javascript'>
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>


<!-- End DFP SETUP -->  

<!-- End USA Today Code -->





<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-131124163-7";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-131124163-7']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'bigblueinteractive.com']);
_gaq.push(['f._setDomainName', 'bigblueinteractive.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod28',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','bigblueinteractive.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://corner.bigblueinteractive.com/index.php?mode=2&thread=599517"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"domain_test_group":20200409,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"3b65d72d-69ea-4294-771b-c0e10b9d24a9","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":63,"serverid":"3.87.70.241:5696","state":"VA","t_epoch":1595813949,"template_id":126,"time_on_site_visit":0,"url":"https://corner.bigblueinteractive.com/index.php?mode=2\u0026thread=599517","user_id":0,"word_count":2615,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=188-0&v=9" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["3b65d72d-69ea-4294-771b-c0e10b9d24a9", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>


<body>




<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"></a> <img src="images/xpete.gif" alt="The Corner Forum">

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic -->&nbsp;


<!-- Nov 2019 Leaderboard -->

<!-- Ezoic - Forum Leaderboard (USAT) - top_of_page -->
<div id="ezoic-pub-ad-placeholder-118">
<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->
<div id='usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general'>
     <script type='text/javascript'>
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general');
         });
     </script>
</div>
</div>
<!-- End Ezoic - Forum Leaderboard (USAT) - top_of_page -->



</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://www.shareasale.com/r.cfm?b=277504&u=723646&m=29078&urllink=&afftrack=">Apparel</a>
<a href="http://www.amazon.com/?_encoding=UTF8&camp=1789&creative=9325&linkCode=ur2&tag=bigblueintera-20">Amazon.com</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW" >Standings (NFL.com)</a>
<a href="https://www.giants.com/team/stats/" target="_NEW" >Statistics (Giants.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/" >Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'home_view_menu')">Home</a>  
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'forum_view_menu')">Corner Forum</a>
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'gameday_view_menu')">Gameday</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_view_menu')">Team</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_building_view_menu')">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info &amp; History</a> -->
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_info_view_menu')">Giants Info &amp; History</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'infolinks_view_menu')">Info/Links</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'shop_view_menu')">BBI Shop</a>
<li><a href="/index.php?mode=10" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'login_menu')">Log In</a>
</ul>

</div><div id="infoline"> </div>

<a name="END"><a href="index.php"><div style="padding-top:20px; padding-bottom:25px;"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"></a></div></a><div class="thread_container"><div class="thread_left"><div class="thread_body" ><div class="thread_main" ><div class="thread_post_header" >  <h1 style="font-size:18px;">Giants sign previously-retired PK Chandler Catanzaro </h1><div class="thread_info"><a href="index.php?mode=5&handle=Anakim"> Anakim </a>  : 11:39 am</div></div><div class="thread_post_body" > Adam Schefter<br />
@AdamSchefter<br />
<br />
Giants are signing former Jets’ kicker Chandler Catanzaro to a one-year deal, per league source. He retired last August and was released from the Jets’ reserve/left squad list just last week. With the Giants releasing Aldrick Rosas today, Catanzaro steps in. </div></div></div></div><div class="thread_right"><div id="ad_side_box">


<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id='usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general'>
     <script type='text/javascript'>
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general');
         });
     </script>
</div>




</div></div><div class="thread_comment_container"><div class="thread_post"><div class="thread_post_header"><b>From last August: </b><a name="14938636">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Anakim"> Anakim </a>  : 11:50 am   : <a href="index.php?mode=2&thread=599517&show_all=1#14938636">link</a>   </div></div><div class="thread_post_body">"Catanzaro signed with New York (Jets) during the offseason for a second stint with the team, but struggled with consistency during camp. He then missed two extra points in the Jets’ 31-22 preseason-opening loss to the Giants on Thursday night.<br />
<br />
Apparently, that cemented Catanzaro’s decision."</div></div><div class="thread_post"><div class="thread_post_header"><b>Ehh </b><a name="14938637">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jay+on+the+Island"> Jay on the Island </a>  : 11:51 am   : <a href="index.php?mode=2&thread=599517&show_all=1#14938637">link</a>   </div></div><div class="thread_post_body">I hope they bring in someone to compete with him.</div></div><div class="thread_post"><div class="thread_post_header"><b>Not the move I would have made </b><a name="14938639">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Giants+in+07"> Giants in 07 </a>  : 11:52 am   : <a href="index.php?mode=2&thread=599517&show_all=1#14938639">link</a>   </div></div><div class="thread_post_body">But I guess the team's hands are somewhat tied since they can't bring players in for workouts<br />
<br />
Catanzaro seems like a mental midget from what I am reading and from what I remember from memory.<br />
<br />
Not the best quality for an NFL kicker in my opinion</div></div><div class="thread_post"><div class="thread_post_header"><b>I doubt this guy is the kicker week one </b><a name="14938641">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jay+on+the+Island"> Jay on the Island </a>  : 11:55 am   : <a href="index.php?mode=2&thread=599517&show_all=1#14938641">link</a>   </div></div><div class="thread_post_body">He’s probably a stopgap until the Giants can officially work out other options.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I doubt this guy is the kicker week one </b><a name="14938642">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  : 11:56 am   : <a href="index.php?mode=2&thread=599517&show_all=1#14938642">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599517&show_all=1#14938641" target="_blank">14938641</a> Jay on the Island said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> He’s probably a stopgap until the Giants can officially work out other options. </td>
                                </tr>
                           </table><br />
<br />
I hope so. 🤮</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I doubt this guy is the kicker week one </b><a name="14938646">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=AcidTest"> AcidTest </a>  : 12:04 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938646">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599517&show_all=1#14938641" target="_blank">14938641</a> Jay on the Island said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> He’s probably a stopgap until the Giants can officially work out other options. </td>
                                </tr>
                           </table><br />
<br />
Agreed.</div></div><div class="thread_post"><div class="thread_post_header"><b>Chandler had a 93% FG av his last 2 Clemson seasons </b><a name="14938651">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=KeoweeFan"> KeoweeFan </a>  : 12:13 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938651">link</a>   </div></div><div class="thread_post_body">and holds the school record for most points scored.<br />
Earnie said "never give up on talent". Maybe the ST specialists on the Giants can revive Cantanzaro's confidence. (That was his problem his sophomore year and Swinney used "tough love" to cure him.</div></div><div class="thread_post"><div class="thread_post_header"><b>He also has a 60 yd FG </b><a name="14938654">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=PEEJ"> PEEJ </a>  : 12:18 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938654">link</a>   </div></div><div class="thread_post_body">on his resume.  so, he's got some leg.</div></div><div class="thread_post"><div class="thread_post_header"><b>I see Catanzaro played for the Panthers in 2018 </b><a name="14938655">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Giantsfan79"> Giantsfan79 </a>  : 12:20 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938655">link</a>   </div></div><div class="thread_post_body">was he in the building while DG was still GM there?</div></div><div class="thread_post"><div class="thread_post_header"><b>WTF??? No one else out there??? </b><a name="14938658">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=TheMick7"> TheMick7 </a>  : 12:25 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938658">link</a>   </div></div><div class="thread_post_body">I remember watching him w/the Jets It was hard to watch!</div></div><div class="thread_post"><div class="thread_post_header"><b>Everyone panic! </b><a name="14938659">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Saquads26"> Saquads26 </a>  : 12:27 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938659">link</a>   </div></div><div class="thread_post_body">!!!</div></div><div class="thread_post"><div class="thread_post_header"><b>I'd bring in Gostkowski  </b><a name="14938661">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Breeze_94"> Breeze_94 </a>  : 12:33 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938661">link</a>   </div></div><div class="thread_post_body">he's one of the best kickers of all time statistically and kicked a 62 yarder in 2017</div></div><div class="thread_post"><div class="thread_post_header"><b>Isn't he one of the three Tenors? </b><a name="14938663">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  : 12:36 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938663">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: WTF??? No one else out there??? </b><a name="14938669">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jay+on+the+Island"> Jay on the Island </a>  : 12:42 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938669">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599517&show_all=1#14938658" target="_blank">14938658</a> TheMick7 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I remember watching him w/the Jets It was hard to watch! </td>
                                </tr>
                           </table><br />
Calm down buddy, this is most likely a short term fix just to have a kicker available when they actually begin practicing.  I would be shocked if Catanzaro is the week one kicker. <br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: WTF??? No one else out there??? </b><a name="14938673">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Anakim"> Anakim </a>  : 12:47 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938673">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599517&show_all=1#14938669" target="_blank">14938669</a> Jay on the Island said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14938658 TheMick7 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     I remember watching him w/the Jets It was hard to watch! <br />
                                <br />
                           <br />
Calm down buddy, this is most likely a short term fix just to have a kicker available when they actually begin practicing.  I would be shocked if Catanzaro is the week one kicker. <br />
 </td>
                                </tr>
                           </table><br />
<br />
<br />
Can't say I know a lot about kicking, but Kai Forbath seems like a logical choice. He played last year under Joe Judge (for one game) and Jason Garrett and went 11-11. He's with the Cowboys right now, but there's no chance he beats out Legatron in Dallas, so he's bound to shake loose.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: WTF??? No one else out there??? </b><a name="14938674">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=TheMick7"> TheMick7 </a>  : 12:48 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938674">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599517&show_all=1#14938669" target="_blank">14938669</a> Jay on the Island said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14938658 TheMick7 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     I remember watching him w/the Jets It was hard to watch! <br />
                                <br />
                           <br />
Calm down buddy, this is most likely a short term fix just to have a kicker available when they actually begin practicing.  I would be shocked if Catanzaro is the week one kicker. <br />
 </td>
                                </tr>
                           </table><br />
<br />
Gee thanks for reassuring me! I couldn't have "calmed down' without your steady words! SMH With a new snapper,probably the same holder & a new kicker establishing some semblance of a routine is always a good thing. As someone said above,we do have ST experts on staff,so I'll defer to their thinking,my only concern is CC was SO bad last year that with guys like Gostkowski out there,it seems strange. And,since practices aren't likely to start until mid August,I'm trying to understand the rush to bring someone like him in!</div></div><div class="thread_post"><div class="thread_post_header"><b>this is the first of multiple signings at kicker </b><a name="14938678">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=larryflower37"> larryflower37 </a>  : 12:57 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938678">link</a>   </div></div><div class="thread_post_body">They will probably have 3 or 4 compete for the job.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Isn't he one of the three Tenors? </b><a name="14938681">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ArlingtonMike"> ArlingtonMike </a>  : 1:06 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938681">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599517&show_all=1#14938663" target="_blank">14938663</a> LBH15 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> . </td>
                                </tr>
                           </table><br />
<br />
Lol</div></div><div class="thread_post"><div class="thread_post_header"><b>I don't care how many guys they bring in </b><a name="14938685">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Matt+M."> Matt M. </a>  : 1:09 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938685">link</a>   </div></div><div class="thread_post_body">I don't like this signing. Rosas absolutely sucked 2 years out of 3 and you replace him (even if only short term) with another crappy kicker? I'd rather sign an unknown than someone I know sucks.</div></div><div class="thread_post"><div class="thread_post_header"><b>I think the Cowflops cut Kai Forbath. </b><a name="14938702">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Optimus-NY"> Optimus-NY </a>  : 1:56 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938702">link</a>   </div></div><div class="thread_post_body">No way he beats out Legatron in Dallas. He'll be a FA at that point and can pick his spot. The Giants would be an ideal landing spots for both parties, especially with Garrett here and Forbath's familiarity with the NFC East.</div></div><div class="thread_post"><div class="thread_post_header"><b>This kicker is just fodder. </b><a name="14938703">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Optimus-NY"> Optimus-NY </a>  : 1:57 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938703">link</a>   </div></div><div class="thread_post_body">Roll with it. He won't be the guy come opening night or Game 2 if the Giants are hard up for salary cap money.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: WTF??? No one else out there??? </b><a name="14938707">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jay+on+the+Island"> Jay on the Island </a>  : 2:11 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938707">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599517&show_all=1#14938674" target="_blank">14938674</a> TheMick7 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14938669 Jay on the Island said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     In comment 14938658 TheMick7 said:<br />
Gee thanks for reassuring me! I couldn't have "calmed down' without your steady words! SMH With a new snapper,probably the same holder & a new kicker establishing some semblance of a routine is always a good thing. As someone said above,we do have ST experts on staff,so I'll defer to their thinking,my only concern is CC was SO bad last year that with guys like Gostkowski out there,it seems strange. And,since practices aren't likely to start until mid August,I'm trying to understand the rush to bring someone like him in! </td>
                                </tr>
                           </table><br />
The Giants are more than likely to add another kicker before practices start. I hope it’s another young unknown kicked instead of another Catanzaro type.<br />
<br />
IIRC Rosas had the worst kicking percentage prior to the arrival of McGaughey but then missed just one the following year.  I am not a fan of this signing at all but again I doubt that he is the kicker this season.<br />
<br />
It’s extremely frustrating that Rosas blew this opportunity.  The Giants traded away two young potential long term kickers in McManus and Boswell.  Rosas finally appeared to be the answer but now the Giants are in a familiar position of trying to find another long term answer.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Not the move I would have made </b><a name="14938708">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Fritz"> Fritz </a>  : 2:11 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938708">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599517&show_all=1#14938639" target="_blank">14938639</a> Giants in 07 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> But I guess the team's hands are somewhat tied since they can't bring players in for workouts<br />
<br />
Catanzaro seems like a mental midget from what I am reading and from what I remember from memory.<br />
<br />
Not the best quality for an NFL kicker in my opinion </td>
                                </tr>
                           </table><br />
<br />
I hope they have other options besides this guy.  All I know about Cantanzaro is from highlights of  him missing game winning or tying kicks at the end of games for every team he played for.  Not the kind of kicker I want on the team I root for.</div></div><div class="thread_post"><div class="thread_post_header"><b>Chandler Catanzaro </b><a name="14938710">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=jacob12"> jacob12 </a>  : 2:13 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938710">link</a>   </div></div><div class="thread_post_body">Giants in 07 made an imbecilic comment about Chandler Catanzaros intellect. Chandler is a poor NFL kicker but he is far from a mental midget. He graduated from Clemson with a degree in biological sciences. Catanzaros father is a dermatologist and Chandler is going to medical school after his football career.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Chandler Catanzaro </b><a name="14938715">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Fritz"> Fritz </a>  : 2:21 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938715">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599517&show_all=1#14938710" target="_blank">14938710</a> jacob12 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Giants in 07 made an imbecilic comment about Chandler Catanzaros intellect. Chandler is a poor NFL kicker but he is far from a mental midget. He graduated from Clemson with a degree in biological sciences. Catanzaros father is a dermatologist and Chandler is going to medical school after his football career. </td>
                                </tr>
                           </table><br />
<br />
I don’t think he was referring to his intelligence but more that he’s a perpetual choke artist.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Isn't he one of the three Tenors? </b><a name="14938740">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gman11"> Gman11 </a>  : 3:23 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938740">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599517&show_all=1#14938663" target="_blank">14938663</a> LBH15 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> . </td>
                                </tr>
                           </table> I thought he was a former MLB catcher.</div></div><div class="thread_post"><div class="thread_post_header"><b>It’s worth noting that Catanzaro is a vested veteran. </b><a name="14938744">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+Blogger"> Big Blue Blogger </a>  : 3:32 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938744">link</a>   </div></div><div class="thread_post_body">If he kicks in the opener, he’s probably the kicker for the season, unless he completely sh!ts the bed. I expect him to be replaced before the games start; but replacing him in Week 2 isn’t much of an option. <br />
<br />
As for who the available replacements might be, it’s possible that some teams will use one of the extra roster spots to carry two kickers. So we can’t assume that many promising young legs will hit the waiver wire. Vets are trickier, but Dallas might even keep Forbath. He signed a one-year minimum deal that qualifies for cap relief, so he’s not prohibitively expensive as coronavirus insurance.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: this is the first of multiple signings at kicker </b><a name="14938746">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Matt+M."> Matt M. </a>  : 3:36 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938746">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599517&show_all=1#14938678" target="_blank">14938678</a> larryflower37 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> They will probably have 3 or 4 compete for the job. </td>
                                </tr>
                           </table>With no tryouts and limited roster numbers this year, I don't see that happening. They aren't spending 2,3, or 4 spots on PK.</div></div><div class="thread_post"><div class="thread_post_header"><b>Relax.......i have no doubt Judge will find a decent kicker </b><a name="14938750">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=George+from+PA"> George from PA </a>  : 3:46 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938750">link</a>   </div></div><div class="thread_post_body">Chandler Catanzaro   is still 29</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Isn't he one of the three Tenors? </b><a name="14938773">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=prdave73"> prdave73 </a>  : 4:17 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938773">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599517&show_all=1#14938663" target="_blank">14938663</a> LBH15 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> . </td>
                                </tr>
                           </table><br />
<br />
Lol...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Not the move I would have made </b><a name="14938775">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 4:21 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938775">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599517&show_all=1#14938639" target="_blank">14938639</a> Giants in 07 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> But I guess the team's hands are somewhat tied since they can't bring players in for workouts<br />
<br />
Catanzaro seems like a mental midget from what I am reading and from what I remember from memory.<br />
<br />
Not the best quality for an NFL kicker in my opinion </td>
                                </tr>
                           </table><br />
You're calling someone else a mental midget? You?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I don't care how many guys they bring in </b><a name="14938777">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=DavidinBMNY"> DavidinBMNY </a>  : 4:22 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938777">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599517&show_all=1#14938685" target="_blank">14938685</a> Matt M. said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I don't like this signing. Rosas absolutely sucked 2 years out of 3 and you replace him (even if only short term) with another crappy kicker? I'd rather sign an unknown than someone I know sucks. </td>
                                </tr>
                           </table><br />
<br />
Matt- The kicker they ultimately sign is going to be cut by another NFL team shortly.  There are multiple teams carrying more then 1 kicker.   Giants will get one of those guys.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Chandler Catanzaro </b><a name="14938778">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 4:23 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938778">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599517&show_all=1#14938715" target="_blank">14938715</a> Fritz said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14938710 jacob12 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Giants in 07 made an imbecilic comment about Chandler Catanzaros intellect. Chandler is a poor NFL kicker but he is far from a mental midget. He graduated from Clemson with a degree in biological sciences. Catanzaros father is a dermatologist and Chandler is going to medical school after his football career. <br />
                                <br />
                           <br />
<br />
I don’t think he was referring to his intelligence but more that he’s a perpetual choke artist. </td>
                                </tr>
                           </table><br />
That's not typically what "mental midget" refers to. I don't doubt that Flounder could have misused the term, but that's all the more reason why he shouldn't be calling anyone else a "mental midget."</div></div><div class="thread_post"><div class="thread_post_header"><b>Mind boggling decision  </b><a name="14938780">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=MtDizzle"> MtDizzle </a>  : 4:26 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938780">link</a>   </div></div><div class="thread_post_body">Gostowski is still out there and has plenty of history with Judge. Awful signing.</div></div><div class="thread_post"><div class="thread_post_header"><b>Gostkowski ?  </b><a name="14938781">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=morrison40"> morrison40 </a>  : 4:28 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938781">link</a>   </div></div><div class="thread_post_body">Judge knows him better than anyone here or in the Giants organization and didn’t sign him ...nuff said .</div></div><div class="thread_post"><div class="thread_post_header"><b>Gostkowski is 36 years old </b><a name="14938782">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=George+from+PA"> George from PA </a>  : 4:36 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938782">link</a>   </div></div><div class="thread_post_body">That might have something to do with it</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Chandler Catanzaro </b><a name="14938806">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Giants+in+07"> Giants in 07 </a>  : 5:55 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938806">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599517&show_all=1#14938710" target="_blank">14938710</a> jacob12 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Giants in 07 made an imbecilic comment about Chandler Catanzaros intellect. Chandler is a poor NFL kicker but he is far from a mental midget. He graduated from Clemson with a degree in biological sciences. Catanzaros father is a dermatologist and Chandler is going to medical school after his football career. </td>
                                </tr>
                           </table><br />
<br />
I didn't make a comment about his intellect at all actually. Mental midget is a common term which in this case refers to the moment more often than not getting to his head in big situations, as you see often in kickers around the league.<br />
<br />
I've heard kickers say that the biggest opponent for themselves is their own brain as they try to stay composed as they see that they game is going to be on their leg.<br />
<br />
Gatorade Dunk, not sure if you have an old handle or if I did something to you, but I've noticed that you like to follow my posts with personal attacks against me.<br />
<br />
Do you always live 10 years in the past or only on BBI?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Gostkowski is 36 years old </b><a name="14938852">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Simms11"> Simms11 </a>  : 8:12 pm   : <a href="index.php?mode=2&thread=599517&show_all=1#14938852">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599517&show_all=1#14938782" target="_blank">14938782</a> George from PA said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> That might have something to do with it </td>
                                </tr>
                           </table><br />
<br />
Age doesn't matter as much with Kickers. They can kick into their 40s. Gostkowski was hurt IIRC, maybe he's not healthy. He couldn't possibly be any worse them Cantanzaro!</div></div><a name="END"><a href="index.php"><div style="padding-top:25px; padding-bottom:20px;"><img src="/images/back_corner.gif" class="thread_link"  alt="Back to the Corner" border="0"></a></div></a></div>
<div class="thread_sidebar_2">

<!-- Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-102">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Corner Forum - Lower 300x250 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1566320450447229"
     data-ad-slot="4189314539"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->

</div>

</div>




<div class="footer">


<p style="width:400px;float:left;"><b>Part of the USA Today Sports Media Group</b><br>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</P>
<P  style="width:400px;float:right; text-align:right;">
All contents (unless otherwise specified) copyright &copy;  1995 - 2020<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Solutions</a>
</P>
<br clear="all">
<div style="float:right;">
<script
    src="https://sucuri.net/monitoring/badge.js"
    data-s="19"
    id="sucuri-s"
    data-i="7b1b29ae50ae6574f2af3875935246e4fa8a805b26"
    data-p="o" - position - l(left) or r(right) or o(relative)
    data-c="l"
    data-t="t"
    ></script>
</div>

</div>


<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->

<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=33', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=33', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=188-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script></body>
</html>
