<!DOCTYPE html>
<html lang="en">
<head><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData)});}}
function AddPixelById(impFullId,pixelData){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData)});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){while(pixels.length>0){var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(__ez.template.isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
(new Image()).src=pixelURL;}}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=190-0&cb=1', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=190-0&cb=1', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=190-0&cb=1', false, [], true, false, true, false);</script>
<title>Stapleton: Giants to sign Ross Cockrell | Big Blue Interactive </title>


<meta name="keywords" content="ndglbqfkxx">

<meta name="description" content=" Art Stapleton
⁦‪@art_stapleton‬⁩ I’m told #NYGiants plan to sign CB Ross Cockrell provided he clears camp-entry COVID-19 testing, per source.
Cockrell visited today.
So there’s at least one veteran corner set to come aboard after DeAndre Baker was formally charged + Sam Beal opted out. 8/8/20, 7:28 PM"/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="website" />
<meta property="og:description" content=" Art Stapleton
⁦‪@art_stapleton‬⁩ I’m told #NYGiants plan to sign CB Ross Cockrell provided he clears camp-entry COVID-19 testing, per source.
Cockrell visited today.
So there’s at least one veteran corner set to come aboard after DeAndre Baker was formally charged + Sam Beal opted out. 8/8/20, 7:28 PM" /> 
<meta property="og:title" content="Stapleton: Giants to sign Ross Cockrell" /> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif" /> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css?v=20200217" />

<link rel="stylesheet" type="text/css" href="anylink.css" />


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}


div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" alt="for display only">

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type='text/javascript'>
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type='text/javascript' src='https://img.bnqt.com/lib/js/sdpdfphelper.js'></script>
<script type='text/javascript'>
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>


<!-- End DFP SETUP -->  

<!-- End USA Today Code -->





<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-131124163-7";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-131124163-7']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'bigblueinteractive.com']);
_gaq.push(['f._setDomainName', 'bigblueinteractive.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod1',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','bigblueinteractive.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://corner.bigblueinteractive.com/index.php?mode=2&thread=599799"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"domain_test_group":20200409,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"90590d8f-3cf7-4d40-67db-ae2abf73d995","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":60,"serverid":"3.94.153.191:1787","state":"VA","t_epoch":1597041278,"template_id":126,"time_on_site_visit":0,"url":"https://corner.bigblueinteractive.com/index.php?mode=2\u0026thread=599799","user_id":0,"word_count":4551,"worst_bad_word_level":3};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=190-0&v=9" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["90590d8f-3cf7-4d40-67db-ae2abf73d995", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>


<body>




<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"></a> <img src="images/xpete.gif" alt="The Corner Forum">

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic -->&nbsp;


<!-- Nov 2019 Leaderboard -->

<!-- Ezoic - Forum Leaderboard (USAT) - top_of_page -->
<div id="ezoic-pub-ad-placeholder-118">
<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->
<div id='usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general'>
     <script type='text/javascript'>
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general');
         });
     </script>
</div>
</div>
<!-- End Ezoic - Forum Leaderboard (USAT) - top_of_page -->



</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://www.shareasale.com/r.cfm?b=277504&u=723646&m=29078&urllink=&afftrack=">Apparel</a>
<a href="http://www.amazon.com/?_encoding=UTF8&camp=1789&creative=9325&linkCode=ur2&tag=bigblueintera-20">Amazon.com</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW" >Standings (NFL.com)</a>
<a href="https://www.giants.com/team/stats/" target="_NEW" >Statistics (Giants.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/" >Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'home_view_menu')">Home</a>  
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'forum_view_menu')">Corner Forum</a>
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'gameday_view_menu')">Gameday</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_view_menu')">Team</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_building_view_menu')">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info &amp; History</a> -->
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_info_view_menu')">Giants Info &amp; History</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'infolinks_view_menu')">Info/Links</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'shop_view_menu')">BBI Shop</a>
<li><a href="/index.php?mode=10" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'login_menu')">Log In</a>
</ul>

</div><div id="infoline"> </div>

<a name="END"><a href="index.php"><div style="padding-top:20px; padding-bottom:25px;"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"></a></div></a><div class="thread_container"><div class="thread_left"><div class="thread_body" ><div class="thread_main" ><div class="thread_post_header" >  <h1 style="font-size:18px;">Stapleton: Giants to sign Ross Cockrell </h1><div class="thread_info"><a href="index.php?mode=5&handle=Defenderdawg"> Defenderdawg </a>  :  8/8/2020  7:30 pm</div></div><div class="thread_post_body" >  	<br />
		<br />
Art Stapleton<br />
⁦‪@art_stapleton‬⁩<br />
<br />
<br />
I’m told #NYGiants plan to sign CB Ross Cockrell provided he clears camp-entry COVID-19 testing, per source.<br />
Cockrell visited today.<br />
So there’s at least one veteran corner set to come aboard after DeAndre Baker was formally charged + Sam Beal opted out.<br />
 <br />
8/8/20, 7:28 PM </div></div></div><div style="margin: 10 10 20 50"><span class="top_pages">Pages:  <a href="index.php?mode=2&thread=599799&thread_page=1" >1</a>  <b style="background: darkred;padding: 2px 5px 2px 5px;">2</b>  <a href="index.php?mode=2&thread=599799&thread_page=1" >&lt;&lt;Prev&nbsp;</a>| <a href="index.php?mode=2&thread=599799&show_all=1" title="">Show All</a> | </span></div>
</div><div class="thread_right"><div id="ad_side_box">


<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id='usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general'>
     <script type='text/javascript'>
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general');
         });
     </script>
</div>




</div></div><div class="thread_comment_container"><div class="thread_post"><div class="thread_post_header"><b>RE: too bad we don't have the leonard williams 4th rd pick </b><a name="14946333">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Milton"> Milton </a>  :  8/8/2020  10:20 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946333">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599799&show_all=1#14946254" target="_blank">14946254</a> CMicks3110 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> could use it for a trade. Wonder if we could swap lorenzo carter for someone decent. </td>
                                </tr>
                           </table>We have the Leonard Williams 4th round pick. It's the Leonard Williams 5th round pick that we don't have.</div></div><div class="thread_post"><div class="thread_post_header"><b>Should’ve kept this guy several seasons ago </b><a name="14946340">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  :  8/8/2020  10:31 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946340">link</a>   </div></div><div class="thread_post_body">What are we doing?</div></div><div class="thread_post"><div class="thread_post_header"><b>The Cockman is back. </b><a name="14946345">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Dave+in+Hoboken"> Dave in Hoboken </a>  :  8/8/2020  10:57 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946345">link</a>   </div></div><div class="thread_post_body">I'm okay with this.  Guessing it will be pretty darn cheap.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: The Cockman is back. </b><a name="14946353">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Spider43"> Spider43 </a>  :  8/8/2020  11:43 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946353">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599799&show_all=1#14946345" target="_blank">14946345</a> Dave in Hoboken said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I'm okay with this.  Guessing it will be pretty darn cheap. </td>
                                </tr>
                           </table><br />
<br />
Ditto.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: LOS </b><a name="14946383">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=joeinpa"> joeinpa </a>  :  8/9/2020  8:14 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946383">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599799&show_all=1#14946249" target="_blank">14946249</a> SFGFNCGiantsFan said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I think they'll do their best to plow through, but do they finish? Time will tell. It depends what the country looks like this fall when flu/cold season come back around along with COVID showing no signs of abating. But I think they'll get it off the ground because there's too much $ at stake. </td>
                                </tr>
                           </table><br />
<br />
The coronavirus is here to stay, even with a vaccine.   I have yet to read or hear from any scientist, medical personnel ,  government official, how we learn to live with it, as we do with other contagions, other than the stifling mitigation’s still in place. <br />
<br />
Do we ever do what Sweden did?   The latest CDC shows maybe it is behind them, dear God, I hope so, but we shall see. <br />
<br />
While Sweden s death rate surpassed ours, and their recovery rate was slower than ours during the lock down, it might be behind them now. <br />
<br />
This is a legitimate question, maybe borne of  ignorance, but legit nevertheless. <br />
<br />
Please don’t make it political. I for one am willing to move forward, respect others, but make my own personal choices.</div></div><div class="thread_post"><div class="thread_post_header"><b>Stapleton  </b><a name="14946391">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=CMicks3110"> CMicks3110 </a>  :  8/9/2020  8:23 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946391">link</a>   </div></div><div class="thread_post_body">Said giants to sign the other two players who visited also. Jackson Dennis and Cody White</div></div><div class="thread_post"><div class="thread_post_header"><b>JoePa.....totally agree.....what is the long game? </b><a name="14946393">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=George+from+PA"> George from PA </a>  :  8/9/2020  8:34 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946393">link</a>   </div></div><div class="thread_post_body">It is either eradicate or live with....we seem to be in some weird middle ground.<br />
<br />
I assuming it is waiting game until the vaccine....as<br />
<br />
Heard immunity while protecting the infirm..is only way we move forward. More cases less deaths....is what we need.....as we are well passed eradicating it.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Stapleton  </b><a name="14946397">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Spider56"> Spider56 </a>  :  8/9/2020  8:39 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946397">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599799&show_all=1#14946391" target="_blank">14946391</a> CMicks3110 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Said giants to sign the other two players who visited also. Jackson Dennis and Cody White </td>
                                </tr>
                           </table><br />
<br />
A WR and an OL who have zero chance to make the team ... I wonder if the plan is to bring in numbers that would have some knowledge of the playbook if needed in an emergency later in the season ... fills 2 positions of guys who opted out.</div></div><div class="thread_post"><div class="thread_post_header"><b>To Joe Pa and George Pa above ... keep the faith. </b><a name="14946399">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Spider56"> Spider56 </a>  :  8/9/2020  8:43 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946399">link</a>   </div></div><div class="thread_post_body">Science has, with less sophisticated technology beat far worse illnesses into submission ... and science will again prevail sending those nasty pangolin microbes back into the ground.</div></div><div class="thread_post"><div class="thread_post_header"><b>I suspect stacking the larger practice squad is the plan </b><a name="14946402">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=George+from+PA"> George from PA </a>  :  8/9/2020  8:52 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946402">link</a>   </div></div><div class="thread_post_body">As roster players missing games due.to covid is likely....<br />
<br />
I am sure things will work out....i wish it wasn't so political, but I guess we are in that season.</div></div><div class="thread_post"><div class="thread_post_header"><b>he's prob better than baker and beal </b><a name="14946405">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GiantsFan84"> GiantsFan84 </a>  :  8/9/2020  8:58 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946405">link</a>   </div></div><div class="thread_post_body">the team actually got better in my mind with this</div></div><div class="thread_post"><div class="thread_post_header"><b>He is </b><a name="14946409">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=PaulN"> PaulN </a>  :  8/9/2020  9:13 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946409">link</a>   </div></div><div class="thread_post_body">Better then they will ever become, he is a solid player, has anyone forgot the mess we had last year. There is no longer a mess back there now. I believe McKinney will be good, I think Love will improve greatly, we may actually have a pretty good secondary now, that was not a certainty with Beal or Baker. A lot of people like Holmes to, and we have Peppers. I wanted this guy back, I love this move.</div></div><div class="thread_post"><div class="thread_post_header"><b>He is </b><a name="14946410">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=PaulN"> PaulN </a>  :  8/9/2020  9:14 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946410">link</a>   </div></div><div class="thread_post_body">Better then they will ever become, he is a solid player, has anyone forgot the mess we had last year. There is no longer a mess back there now. I believe McKinney will be good, I think Love will improve greatly, we may actually have a pretty good secondary now, that was not a certainty with Beal or Baker. A lot of people like Holmes to, and we have Peppers. I wanted this guy back, I love this move.</div></div><div class="thread_post"><div class="thread_post_header"><b>Cockrell’s Role Here </b><a name="14946413">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Samiam"> Samiam </a>  :  8/9/2020  9:25 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946413">link</a>   </div></div><div class="thread_post_body">I don’t think he has the athletic ability to play an outside CB.  I think he’s ok at the slot and certainly an upgrade over Haley if he’s healthy.  The plan was to bring in Holmes to play the slot and it’s questionable if he has the size to play the outside.  So, unless Love or somebody else can play the outside CB, I think there’s still a problem.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Cockrell’s Role Here </b><a name="14946424">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  :  8/9/2020  9:57 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946424">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599799&show_all=1#14946413" target="_blank">14946413</a> Samiam said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I don’t think he has the athletic ability to play an outside CB.  I think he’s ok at the slot and certainly an upgrade over Haley if he’s healthy.  The plan was to bring in Holmes to play the slot and it’s questionable if he has the size to play the outside.  So, unless Love or somebody else can play the outside CB, I think there’s still a problem. </td>
                                </tr>
                           </table><br />
<br />
Why do you feel Cockrell can't play on the outside?<br />
<br />
I think everybody should read this. There is a blurb about how the Pats use their guys that I think Graham may implore with us.<br><a href="https://theriotreport.com/its-time-to-change-the-way-we-think-about-cornerbacks/"> Link </a> - (<a href="https://theriotreport.com/its-time-to-change-the-way-we-think-about-cornerbacks/" target="_NEW"> New Window </a>)</div></div><div class="thread_post"><div class="thread_post_header"><b>Snap count  </b><a name="14946425">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  :  8/9/2020  10:00 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946425">link</a>   </div></div><div class="thread_post_body"><table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">Cockrell played 253 snaps in the slot last season and 385 as an outside cornerback, so he offers the Giants both experience and versatility.</td>
                                </tr>
                           </table></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Cockrell’s Role Here </b><a name="14946428">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  :  8/9/2020  10:05 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946428">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599799&show_all=1#14946424" target="_blank">14946424</a> robbieballs2003 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14946413 Samiam said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     I don’t think he has the athletic ability to play an outside CB.  I think he’s ok at the slot and certainly an upgrade over Haley if he’s healthy.  The plan was to bring in Holmes to play the slot and it’s questionable if he has the size to play the outside.  So, unless Love or somebody else can play the outside CB, I think there’s still a problem. <br />
                                <br />
                           <br />
<br />
Why do you feel Cockrell can't play on the outside?<br />
<br />
I think everybody should read this. There is a blurb about how the Pats use their guys that I think Graham may implore with us. Link  - ( New Window ) </td>
                                </tr>
                           </table><br />
<br />
And what athletic ability is he lacking that he cannot play on the outside? <br />
At his Duke pro day, Cockrell ran a 4.40 40-yard dash at 6-feet tall and 190 pounds. He also logged an explosive 39-inch vertical jump and 12 bench press reps at 225 pounds. Entering the 2017 season, Cockrell had never allowed a touchdown in primary coverage, according to PFF.[/quote]<br />
[quote]</div></div><div class="thread_post"><div class="thread_post_header"><b>Cockrell is capable and professional though not at all dynamic  </b><a name="14946440">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+on+Li"> Eric on Li </a>  :  8/9/2020  10:15 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946440">link</a>   </div></div><div class="thread_post_body">he is competent in a few different positions and won't kill you, but he also isn't a guy who teams will be afraid to test.  <br />
<br />
He is however 100% an upgrade over what they got out of both Baker outside and Haley in the slot last year. He makes the team better and in that respect it is a good signing since it's also likely very low cost. He will allow Holmes and Balentine to progress as their own pace and the defense/team to not suffer in the process if they need more time. <br />
<br />
Ryan is a better player with extra versatility and may have been more of a multi-year piece (similar to the Golden Tate signing) but there's also some reason to be concerned his play may be falling off a little so I can understand if their evaluation of him doesn't line up with the price tag he's looking for having come off a pro bowl season.</div></div><div class="thread_post"><div class="thread_post_header"><b>Eric </b><a name="14946443">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  :  8/9/2020  10:17 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946443">link</a>   </div></div><div class="thread_post_body">is Ryan better? When I look up how they have played the last few years I can make the argument that Cockrell has been better.</div></div><div class="thread_post"><div class="thread_post_header"><b>This </b><a name="14946459">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=AcidTest"> AcidTest </a>  :  8/9/2020  10:39 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946459">link</a>   </div></div><div class="thread_post_body">is an excellent signing. As others have noted, he's been effective outside and in the slot. He's also much cheaper than someone like Ryan.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Eric </b><a name="14946465">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+on+Li"> Eric on Li </a>  :  8/9/2020  10:48 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946465">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599799&show_all=1#14946443" target="_blank">14946443</a> robbieballs2003 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> is Ryan better? When I look up how they have played the last few years I can make the argument that Cockrell has been better. </td>
                                </tr>
                           </table><br />
<br />
Ryan was certainly more dynamic if you look at his big play production and he's got 1 extra layer of versatility having played safety before. <br />
<br />
4 ints / 18 passes defensed<br />
4 FF <br />
4.5 sacks<br />
4 TFL's <br />
8 QB hits (which would have been as many as anyone on our roster except LW, MG, and Carter). <br />
<br />
That amount of turnovers and negative offensive plays probably stacks up with any defensive player in football last year.<br />
<br />
Whether the pro bowl alternate/top 100 stuff is more name recognition that goes along with those big plays, or legitimate I don't know. If his tackling and coverage took a step back on the other 99% of snaps he played as PFF says I can understand the hesitation at signing him over the risk that perhaps the big play production was a little flukey.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Eric </b><a name="14946468">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  :  8/9/2020  10:52 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946468">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599799&show_all=1#14946465" target="_blank">14946465</a> Eric on Li said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14946443 robbieballs2003 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     is Ryan better? When I look up how they have played the last few years I can make the argument that Cockrell has been better. <br />
                                <br />
                           <br />
<br />
Ryan was certainly more dynamic if you look at his big play production and he's got 1 extra layer of versatility having played safety before. <br />
<br />
4 ints / 18 passes defensed<br />
4 FF <br />
4.5 sacks<br />
4 TFL's <br />
8 QB hits (which would have been as many as anyone on our roster except LW, MG, and Carter). <br />
<br />
That amount of turnovers and negative offensive plays probably stacks up with any defensive player in football last year.<br />
<br />
Whether the pro bowl alternate/top 100 stuff is more name recognition that goes along with those big plays, or legitimate I don't know. If his tackling and coverage took a step back on the other 99% of snaps he played as PFF says I can understand the hesitation at signing him over the risk that perhaps the big play production was a little flukey. </td>
                                </tr>
                           </table><br />
<br />
Correct. He has a big advantage in big plays but also gave up the most passing yards of any DB and was targeted the most. Great DBs don't get targeted a ton. He had like 20 kissed tackles last year as well.</div></div><div class="thread_post"><div class="thread_post_header"><b>Kissed tackles ... I hope not with covid happening. </b><a name="14946469">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  :  8/9/2020  10:53 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946469">link</a>   </div></div><div class="thread_post_body">lol, obviously missed.</div></div><div class="thread_post"><div class="thread_post_header"><b>some context on those logan ryan numbers  </b><a name="14946470">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+on+Li"> Eric on Li </a>  :  8/9/2020  10:56 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946470">link</a>   </div></div><div class="thread_post_body">among all defensive players last year those numbers qualify as:<br />
<br />
6th most in FF behind just TJ Watt, Barrett, Chandler Jones, Mack, and Ryan Anderson. <br />
13th best in INT (league leaders had 6) <br />
3rd most passes defensed behind Gilmore and Carlton Davis<br />
most QB hits + sacks among DBs<br />
<br />
if you add that all up it amounts to 38 negative plays which like I said is probably highest among all DB's and maybe even all defensive players. <br />
<br />
but there were 1000+ other snaps he played that are a huge part of his evaluation we can't evaluate as easily.</div></div><div class="thread_post"><div class="thread_post_header"><b>no disagreement Robbie - just pointing out Ryan is more dynamic </b><a name="14946472">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+on+Li"> Eric on Li </a>  :  8/9/2020  10:58 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946472">link</a>   </div></div><div class="thread_post_body">which may mean more upside. The missed tackles and poorer coverage grades may also mean more downside to go along with more $ cost. <br />
<br />
I would have understood NYG either way and would have been happy to sign either player (even both) on team friendly contracts.</div></div><div class="thread_post"><div class="thread_post_header"><b>. </b><a name="14946475">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=arcarsenal"> arcarsenal </a>  :  8/9/2020  11:03 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946475">link</a>   </div></div><div class="thread_post_body">Given where we are in the offseason, this is a solid move. Cockrell seemed relatively reliable when he was here in 2017(?) - it's decent depth. <br />
<br />
Obviously it's not Logan Ryan, but it's a vet who has been around and should be able to step in and not be a disaster if we need him. <br />
<br />
If he winds up on the field a lot, that's not a good sign. But, in a pinch, we could do worse.</div></div><div class="thread_post"><div class="thread_post_header"><b>yeah, that is why I said I could make the argument  </b><a name="14946476">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  :  8/9/2020  11:03 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946476">link</a>   </div></div><div class="thread_post_body">and did not flat out say Cockrell is better. If I am running a defense I don't want basically an all or nothing guy in Ryan at this stage especially for the price tag he supposedly wants. If I am Graham I want players doing their job and a lot of time a good DB is like a good OL, if you don't hear their name that is a good thing. Tennessee was 24th in passing YPG last year. I was interested in Ryan but the more I look into it I am happier with Cockrell. He has size, speed, experience, flexibility, and is familiar with us. And the price should be much cheaper than Ryan. I wonder if it is a multi-year deal or not.</div></div><div class="thread_post"><div class="thread_post_header"><b>I don’t understand how anyone can argue against the Cockrell signing. </b><a name="14946481">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Ivan15"> Ivan15 </a>  :  8/9/2020  11:10 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946481">link</a>   </div></div><div class="thread_post_body">On other threads, it has been argued that signing veterans to fill gaps isn’t worth the cap space, and that the Giants should be developing younger players until the team is competitive a couple of years down the road.  At this point, with a lot of 2-year and 3-year players, the team needs to show some improvement, at least to encourage those players to stick around and put out the effort to move forward. We need more than another 4-5 win season. We need a 7-9 win season to show future FAs that this team is going to be a regular playoff caliber team.<br />
 <br />
Cockrell is a very serviceable player, solid depth at worst, who should not cost very much money and is not a long term contract.. Even if he has to be starting on the outside, he is better than some schlub who would be the weak link of the defense, no matter how the scheme tries to hide him.</div></div><div class="thread_post"><div class="thread_post_header"><b>And this is a signing that I feel almost everyone should be happy  </b><a name="14946482">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  :  8/9/2020  11:10 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946482">link</a>   </div></div><div class="thread_post_body">about. This still should not put a big our cap space for the crowd that wants to preserve our cap space for next year. This should be viewed as a positive for those that felt we needed another CB on the roster that is reliable. This also should be viewed as a positive for those that want to allow the young kids to play. If someone like Ballentine steps up then Cockrell should not be blocking (pun intended) him from playing. Same for Holmes. <br />
<br />
I also like that article I posted that states how Belichick doesn't view DBs as starters. He looks at them as players. We have heard Judge and Graham say they will be multiple and part of that means matching up on the backend. It'll be like remember the Titans when the DB couldn't keep up with the WR and they changed players.</div></div><div class="thread_post"><div class="thread_post_header"><b>Cockrell </b><a name="14946491">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  8/9/2020  11:29 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946491">link</a>   </div></div><div class="thread_post_body">actually played pretty darn well for us in 2017.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Wow. This is interesting.  </b><a name="14946500">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=kinard"> kinard </a>  :  8/9/2020  11:35 am   : <a href="index.php?mode=2&thread=599799&show_all=1#14946500">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599799&show_all=1#14946289" target="_blank">14946289</a> robbieballs2003 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                    Daniel Jones and Ross Cockrell both attended Charlotte Latin High School.<br />
<br />
Daniel Jones & Ross Cockrell both are Duke Blue Devils.<br />
<br />
Yes - definitely a noteworthy factoid.<br />
<br />
Daniel Jones & Ross Cockrell are both New York Giants now.<br />
                                <br />
                            </td>
                                </tr>
                           </table></div></div><div class="thread_post"><div class="thread_post_header"><b>Why  </b><a name="14946566">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=larryinnewhaven"> larryinnewhaven </a>  :  8/9/2020  1:28 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946566">link</a>   </div></div><div class="thread_post_body">was this kid on the street?  Everyone needs CB help.</div></div><div class="thread_post"><div class="thread_post_header"><b>Sy's review from the Arizona 2017 game </b><a name="14946584">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  8/9/2020  1:45 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946584">link</a>   </div></div><div class="thread_post_body">Ross Cockrell continues to show he deserves a long term spot on this team, meaning he needs to be on this team in 2018. He brought in 2 interceptions, both of which he showed excellent body control and ball skills, 1 of which was in the end zone. This will be one of the major positives that comes out of the 2017 season; he has played exceptionally well and has steadily improved with the more playing time he got.</div></div><div class="thread_post"><div class="thread_post_header"><b>Sy's review from the 2nd Redskins game in 2017 </b><a name="14946585">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  8/9/2020  1:46 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946585">link</a>   </div></div><div class="thread_post_body">In all honesty with no bias, Ross Cockrell may have played the CB position better than anyone in the NFL over the past 4 weeks. While he hasn’t been overly tested when it comes to quality of his opponent, Cockrell has been dominant. He broke up 4 passes and intercepted another one. He is in the running for a starting job next year and it would be a help when it comes to their approach in FA and the draft if they know he is gonna be the guy.</div></div><div class="thread_post"><div class="thread_post_header"><b>Why wasn't he kept around? </b><a name="14946644">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  :  8/9/2020  2:58 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946644">link</a>   </div></div><div class="thread_post_body">Agree he was one of the few bright spots that 2017 season and its not like the pass defense had too much talent.</div></div><div class="thread_post"><div class="thread_post_header"><b>Robbie - I looked back at NE and MIA snap counts last year </b><a name="14946664">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+on+Li"> Eric on Li </a>  :  8/9/2020  3:29 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946664">link</a>   </div></div><div class="thread_post_body">and both had an immense number of DB's on the field each week. <br />
<br />
Both had 11-12 DBs on the 53 with almost all of them being active each game. Both also had like 8 different players playing significant snaps each game (30-40%+). Graham was playing 5 guys defined as safeties that many snaps each game. <br />
<br />
So for this roster, before any injuries hit, we are probably looking at:<br />
<br />
1. Bradberry (every snap he's healthy for) <br />
2. Peppers (every snap he's healthy for) <br />
3. McKinney (even as a rookie probably every snap he's healthy for)<br />
4. Love (a lot of snaps in some kind of safety role) <br />
5. Holmes (as many CB snaps as he can handle - likely primary nickel) <br />
6. Cockerill (whatever outside or inside snaps 4 & 5 can't handle) <br />
7. Balentine (depth outside snaps) <br />
8. Williamson (depth snaps wherever he fits best) <br />
9. Hartage (seems like a Graham guy so I wouldn't be shocked if he ends up playing more than 7 & 8)<br />
10. Haley (I really hope someone knocks him off the roster) <br />
11. Askew (who knows)<br />
12. Ebner (STs)<br />
<br />
I think there was room for another DB before Baker + Beal went out of the picture since there's always an injury or 2, so once they did a signing like Cockerill was necessary. Had they signed Logan Ryan he'd have had the upside to slot in at #2 or 3 and played every snap he was healthy for. I doubt they go for Ryan after adding Cockerill but another pickup may be necessary depending on their feelings on some of the young guys they've signed. They'd also tried to claim the CB who played with Graham in Miami a few weeks ago so I suspect we will continue to see a little bit of churn with those last couple DB spots.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Why wasn't he kept around? </b><a name="14946667">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Mike+in+NY"> Mike in NY </a>  :  8/9/2020  3:33 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946667">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599799&show_all=1#14946644" target="_blank">14946644</a> LBH15 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Agree he was one of the few bright spots that 2017 season and its not like the pass defense had too much talent. </td>
                                </tr>
                           </table><br />
<br />
I believe he signed as a UFA for more money than the Giants were comfortable paying him.</div></div><div class="thread_post"><div class="thread_post_header"><b>I remember those reviews Eric  </b><a name="14946672">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Dave+on+the+UWS"> Dave on the UWS </a>  :  8/9/2020  3:39 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946672">link</a>   </div></div><div class="thread_post_body">why didn’t they hold onto the guy? Apple being here shouldn’t have been a deterrent.</div></div><div class="thread_post"><div class="thread_post_header"><b>I read that they didn't think he was a fit for Bettcher's </b><a name="14946676">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  :  8/9/2020  3:43 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946676">link</a>   </div></div><div class="thread_post_body">press man system. Haha. If we only knew we'd barely be pressing anyway.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I read that they didn't think he was a fit for Bettcher's </b><a name="14946738">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  :  8/9/2020  4:42 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946738">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599799&show_all=1#14946676" target="_blank">14946676</a> robbieballs2003 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> press man system. Haha. If we only knew we'd barely be pressing anyway. </td>
                                </tr>
                           </table><br />
<br />
Bettcher’s system wasn’t a good fit for the Giants. Unfortunately the last few guys in here haven’t either.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Bettcher was such a disaster  </b><a name="14946739">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+on+Li"> Eric on Li </a>  :  8/9/2020  4:42 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946739">link</a>   </div></div><div class="thread_post_body">at least Shurmur had some positive contribution towards the future the remains with Jones. Bettcher was a turd from beginning to end and literally every guy he brought over from AZ sucked except Golden.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Why wasn't he kept around? </b><a name="14946743">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  :  8/9/2020  4:47 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946743">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599799&show_all=1#14946667" target="_blank">14946667</a> Mike in NY said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14946644 LBH15 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Agree he was one of the few bright spots that 2017 season and its not like the pass defense had too much talent. <br />
                                <br />
                           <br />
<br />
I believe he signed as a UFA for more money than the Giants were comfortable paying him. </td>
                                </tr>
                           </table><br />
<br />
Guys like Jonathan Stewart were the priority back then I guess.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I read that they didn't think he was a fit for Bettcher's </b><a name="14946747">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Mike+in+NY"> Mike in NY </a>  :  8/9/2020  4:53 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946747">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599799&show_all=1#14946738" target="_blank">14946738</a> LBH15 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14946676 robbieballs2003 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     press man system. Haha. If we only knew we'd barely be pressing anyway. <br />
                                <br />
                           <br />
<br />
Bettcher’s system wasn’t a good fit for the Giants. Unfortunately the last few guys in here haven’t either.<br />
 </td>
                                </tr>
                           </table><br />
<br />
I didn't realize Bettcher had a system</div></div><div class="thread_post"><div class="thread_post_header"><b>Bettcher's a mystery  </b><a name="14946748">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bc4life"> bc4life </a>  :  8/9/2020  4:53 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946748">link</a>   </div></div><div class="thread_post_body">real riches to rags story.<br />
<br />
Admittedly, he had some decent talent in AZ, but still his Giant tenure  - lot of confusion, blown coverages, questionable schemes<br />
<br />
failed to retain a talented player in Cockrell and didn't develop the players he retained.  I'd love to hear from the players what went on with that defense</div></div><div class="thread_post"><div class="thread_post_header"><b>Mike in NY </b><a name="14946749">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bc4life"> bc4life </a>  :  8/9/2020  4:54 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946749">link</a>   </div></div><div class="thread_post_body">He had one in Arizona</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: Why wasn't he kept around? </b><a name="14946752">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=christian"> christian </a>  :  8/9/2020  5:08 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946752">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599799&show_all=1#14946743" target="_blank">14946743</a> LBH15 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">Guys like Jonathan Stewart were the priority back then I guess.</td>
                                </tr>
                           </table><br />
<br />
If you take a spin in the time machine, there is a fabulous quote in a Jonathan Stewart thread on the relative value of Cockrell vs. Stewart.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: Why wasn't he kept around? </b><a name="14946754">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  :  8/9/2020  5:17 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946754">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599799&show_all=1#14946752" target="_blank">14946752</a> christian said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14946743 LBH15 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                    Guys like Jonathan Stewart were the priority back then I guess.<br />
                                <br />
                           <br />
<br />
If you take a spin in the time machine, there is a fabulous quote in a Jonathan Stewart thread on the relative value of Cockrell vs. Stewart. </td>
                                </tr>
                           </table><br />
<br />
Fill us in</div></div><div class="thread_post"><div class="thread_post_header"><b>the </b><a name="14946782">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  8/9/2020  6:39 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946782">link</a>   </div></div><div class="thread_post_body">Panthers signed him as UFA to 2-Years, $6.8 million contract.</div></div><div class="thread_post"><div class="thread_post_header"><b>He </b><a name="14946787">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=PaulN"> PaulN </a>  :  8/9/2020  6:46 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946787">link</a>   </div></div><div class="thread_post_body">Has started and played well on the outside, but there idiots here to despute facts, BBI is becoming a breading ground for sport no nothings with no desire to look for facts, when you can bitch and try to sound like you know something by reading other idiots nonsense, Logan Ryan is a slot corner who has played on the outside some, Cockrell an outside corner who has played plenty of slot also, but we are in trouble if he has to play outside, ok then, brilliant, don't let the stats get into your way, follow it up with some Gettleman bashing, must be smart if he is bashing Gettleman.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: Why wasn't he kept around? </b><a name="14946803">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=christian"> christian </a>  :  8/9/2020  7:14 pm   : <a href="index.php?mode=2&thread=599799&show_all=1#14946803">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=599799&show_all=1#14946754" target="_blank">14946754</a> LBH15 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"><br />
If you take a spin in the time machine, there is a fabulous quote in a Jonathan Stewart thread on the relative value of Cockrell vs. Stewart.<br />
                                <br />
Fill us in </td>
                                </tr>
                           </table><br />
<br />
The names have been removed to protect the innocent. As noted Stewart and Cockrell signed nearly identical contracts that offseason.  Both guys ended up on IR for most/all of '18, Cockrell was able to book a respectable year as a part time starter in '19. I think Stewart might be a rapper now?<br />
<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"><br />
Ross Cockerell<br />
-------- : 7/10/2018 4:39 pm : link : reply<br />
signed for the exact same money 2/6.8 million<br />
<br />
I don't see how anyone can seriously argue that Giants are better off with JS than RC.<br />
<br />
Are you kidding me???  <br />
------ -- --------- : 7/11/2018 8:20 am : link<br />
Ross Cockrell makes us a better team? Stewart at least fills a need we've sorely been lacking - a goal line/short yardage runner.<br />
<br />
Exactly what role does Cockrell fill? 4th or 5th CB??</td>
                                </tr>
                           </table></div></div><div style="margin: 10 10 20 50"><span class="top_pages">Pages:  <a href="index.php?mode=2&thread=599799&thread_page=1" >1</a>  <b style="background: darkred;padding: 2px 5px 2px 5px;">2</b>  <a href="index.php?mode=2&thread=599799&thread_page=1" >&lt;&lt;Prev&nbsp;</a>| <a href="index.php?mode=2&thread=599799&show_all=1" title="">Show All</a> | </span></div>
<a name="END"><a href="index.php"><div style="padding-top:25px; padding-bottom:20px;"><img src="/images/back_corner.gif" class="thread_link"  alt="Back to the Corner" border="0"></a></div></a></div>
<div class="thread_sidebar_2">

<!-- Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-102">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Corner Forum - Lower 300x250 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1566320450447229"
     data-ad-slot="4189314539"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->

</div>

</div>




<div class="footer">


<p style="width:400px;float:left;"><b>Part of the USA Today Sports Media Group</b><br>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</P>
<P  style="width:400px;float:right; text-align:right;">
All contents (unless otherwise specified) copyright &copy;  1995 - 2020<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Solutions</a>
</P>
<br clear="all">
<div style="float:right;">
<script
    src="https://sucuri.net/monitoring/badge.js"
    data-s="19"
    id="sucuri-s"
    data-i="7b1b29ae50ae6574f2af3875935246e4fa8a805b26"
    data-p="o" - position - l(left) or r(right) or o(relative)
    data-c="l"
    data-t="t"
    ></script>
</div>

</div>


<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->

<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=33', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=33', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=190-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script></body>
</html>
