<!DOCTYPE html>
<html lang="en">
<head><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData)});}}
function AddPixelById(impFullId,pixelData){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData)});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){while(pixels.length>0){var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(__ez.template.isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
(new Image()).src=pixelURL;}}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=191-0&cb=1', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=191-0&cb=1', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=191-0&cb=2', false, [], true, false, true, false);</script>
<title>The Failure to Fix the Offensive Line is Inexcusable | Big Blue Interactive </title>


<meta name="keywords" content="ndglbqfkxx">

<meta name="description" content="When DG took over three years ago he along with everyone else admitted the fixing offensive line had to be a or the priority to get this mess turned around.  It's probably also the #1 reason Reese was canned. Three years later we've made minimal - if any - progress on fixing the line.  You simply cannot operate an offense with a function offensive line.  How many times do we have to repeat this? Despite a lot of big talk of "hog mollies" DG has simply NOT made it a priority to fix the OL. The most glaring omission IMO was trading three draft picks to move up and take DeAndre Baker.  There were a plethora of highly rated tackles on the board that we could have taken by sitting still with our high 2nd round pick instead of trading up for Baker.  And I felt this way long before Baker turned into a complete bust.   If you make a move like that you're just paying lip service to making the OL your priority. The second unforgivable mistake was not picking up a legit center going into this year.  We knew we had nothing but hopes and dreams at center, and passed on centers in the draft and FA this year.  Why?  Why?  What the hell was the plan for center this year? Play an UDFA who's never played the position before?  Rely on someone as objectively awful as Pulley? Also, after 3 years to try and fix the line we're counting on a journeyman to start at RT?  Really? A guy who could have been picked up by anyone in the league?  That's the fucking plan? Or maybe the plan was to hope that Solder would someone suck less than he had over the past two years while paying him $16M? Say what you will but all lip service to the contrary DG has not made fixing the OL a priority and he needs to be fired ASAP and we need to get someone in here who will make this a priority.  I don't care who the hell we have at WR, RB, or even QB until we get this mess of a line fixed. I don't even care if we have a defense that can't get off the field for now Just fix the fucking offensive line!!!!!!! I can't watch 60% of our plays getting blown up behind the LOS because we can't block anyone.  Enough of this shit. "/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="website" />
<meta property="og:description" content="When DG took over three years ago he along with everyone else admitted the fixing offensive line had to be a or the priority to get this mess turned around.  It's probably also the #1 reason Reese was canned. Three years later we've made minimal - if any - progress on fixing the line.  You simply cannot operate an offense with a function offensive line.  How many times do we have to repeat this? Despite a lot of big talk of "hog mollies" DG has simply NOT made it a priority to fix the OL. The most glaring omission IMO was trading three draft picks to move up and take DeAndre Baker.  There were a plethora of highly rated tackles on the board that we could have taken by sitting still with our high 2nd round pick instead of trading up for Baker.  And I felt this way long before Baker turned into a complete bust.   If you make a move like that you're just paying lip service to making the OL your priority. The second unforgivable mistake was not picking up a legit center going into this year.  We knew we had nothing but hopes and dreams at center, and passed on centers in the draft and FA this year.  Why?  Why?  What the hell was the plan for center this year? Play an UDFA who's never played the position before?  Rely on someone as objectively awful as Pulley? Also, after 3 years to try and fix the line we're counting on a journeyman to start at RT?  Really? A guy who could have been picked up by anyone in the league?  That's the fucking plan? Or maybe the plan was to hope that Solder would someone suck less than he had over the past two years while paying him $16M? Say what you will but all lip service to the contrary DG has not made fixing the OL a priority and he needs to be fired ASAP and we need to get someone in here who will make this a priority.  I don't care who the hell we have at WR, RB, or even QB until we get this mess of a line fixed. I don't even care if we have a defense that can't get off the field for now Just fix the fucking offensive line!!!!!!! I can't watch 60% of our plays getting blown up behind the LOS because we can't block anyone.  Enough of this shit. " /> 
<meta property="og:title" content="The Failure to Fix the Offensive Line is Inexcusable" /> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif" /> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css?v=20200217" />

<link rel="stylesheet" type="text/css" href="anylink.css" />


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}


div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" alt="for display only">

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type='text/javascript'>
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type='text/javascript' src='https://img.bnqt.com/lib/js/sdpdfphelper.js'></script>
<script type='text/javascript'>
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>


<!-- End DFP SETUP -->  

<!-- End USA Today Code -->





<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-131124163-7";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(function(){
	_gat._createTracker('UA-131124163-7', 'e');
});
_gaq.push(function(){
	_gat._createTracker('UA-38339005-1', 'f');
});
_gaq.push(['e._setDomainName', 'bigblueinteractive.com']);
_gaq.push(['f._setDomainName', 'bigblueinteractive.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod68',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','bigblueinteractive.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://corner.bigblueinteractive.com/index.php?mode=2&thread=601266"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"domain_test_group":20200409,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"bbc218bd-4ee2-4d0e-5a68-b00b8c9d9799","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":65,"serverid":"3.238.22.144:2208","state":"VA","t_epoch":1601394381,"template_id":126,"time_on_site_visit":0,"url":"https://corner.bigblueinteractive.com/index.php?mode=2\u0026thread=601266","user_id":0,"word_count":6302,"worst_bad_word_level":1};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=191-0&v=9" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["bbc218bd-4ee2-4d0e-5a68-b00b8c9d9799", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>


<body>




<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"></a> <img src="images/xpete.gif" alt="The Corner Forum">

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic -->&nbsp;


<!-- Nov 2019 Leaderboard -->

<!-- Ezoic - Forum Leaderboard (USAT) - top_of_page -->
<div id="ezoic-pub-ad-placeholder-118">
<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->
<div id='usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general'>
     <script type='text/javascript'>
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general');
         });
     </script>
</div>
</div>
<!-- End Ezoic - Forum Leaderboard (USAT) - top_of_page -->



</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://www.shareasale.com/r.cfm?b=277504&u=723646&m=29078&urllink=&afftrack=">Apparel</a>
<a href="http://www.amazon.com/?_encoding=UTF8&camp=1789&creative=9325&linkCode=ur2&tag=bigblueintera-20">Amazon.com</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW" >Standings (NFL.com)</a>
<a href="https://www.giants.com/team/stats/" target="_NEW" >Statistics (Giants.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/" >Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'home_view_menu')">Home</a>  
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'forum_view_menu')">Corner Forum</a>
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'gameday_view_menu')">Gameday</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_view_menu')">Team</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_building_view_menu')">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info &amp; History</a> -->
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_info_view_menu')">Giants Info &amp; History</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'infolinks_view_menu')">Info/Links</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'shop_view_menu')">BBI Shop</a>
<li><a href="/index.php?mode=10" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'login_menu')">Log In</a>
</ul>

</div><div id="infoline"> </div>

<a name="END"><a href="index.php"><div style="padding-top:20px; padding-bottom:25px;"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"></a></div></a><div class="thread_container"><div class="thread_left"><div class="thread_body" ><div class="thread_main" ><div class="thread_post_header" >  <h1 style="font-size:18px;">The Failure to Fix the Offensive Line is Inexcusable </h1><div class="thread_info"><a href="index.php?mode=5&handle=Tesla"> Tesla </a>  :  9/28/2020  10:05 am</div></div><div class="thread_post_body" > When DG took over three years ago he along with everyone else admitted the fixing offensive line had to be a or the priority to get this mess turned around.  It's probably also the #1 reason Reese was canned.<br />
<br />
Three years later we've made minimal - if any - progress on fixing the line.  You simply cannot operate an offense with a function offensive line.  How many times do we have to repeat this?  <br />
<br />
Despite a lot of big talk of "hog mollies" DG has simply NOT made it a priority to fix the OL. The most glaring omission IMO was trading three draft picks to move up and take DeAndre Baker.  There were a plethora of highly rated tackles on the board that we could have taken by sitting still with our high 2nd round pick instead of trading up for Baker.  And I felt this way long before Baker turned into a complete bust.   If you make a move like that you're just paying lip service to making the OL your priority. <br />
<br />
The second unforgivable mistake was not picking up a legit center going into this year.  We knew we had nothing but hopes and dreams at center, and passed on centers in the draft and FA this year.  Why?  Why?  What the hell was the plan for center this year? Play an UDFA who's never played the position before?  Rely on someone as objectively awful as Pulley?  <br />
<br />
Also, after 3 years to try and fix the line we're counting on a journeyman to start at RT?  Really? A guy who could have been picked up by anyone in the league?  That's the fucking plan? Or maybe the plan was to hope that Solder would someone suck less than he had over the past two years while paying him $16M? <br />
<br />
Say what you will but all lip service to the contrary DG has not made fixing the OL a priority and he needs to be fired ASAP and we need to get someone in here who will make this a priority.  I don't care who the hell we have at WR, RB, or even QB until we get this mess of a line fixed. I don't even care if we have a defense that can't get off the field for now<br />
<br />
Just fix the fucking offensive line!!!!!!! I can't watch 60% of our plays getting blown up behind the LOS because we can't block anyone.  Enough of this shit.  <br />
 </div></div></div><div style="margin: 10 10 20 50"><span class="top_pages">Pages:  <a href="index.php?mode=2&thread=601266&thread_page=1" >1</a>  <b style="background: darkred;padding: 2px 5px 2px 5px;">2</b>  <a href="index.php?mode=2&thread=601266&thread_page=1" >&lt;&lt;Prev&nbsp;</a>| <a href="index.php?mode=2&thread=601266&show_all=1" title="">Show All</a> | </span></div>
</div><div class="thread_right"><div id="ad_side_box">


<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id='usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general'>
     <script type='text/javascript'>
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general');
         });
     </script>
</div>




</div></div><div class="thread_comment_container"><div class="thread_post"><div class="thread_post_header"><b>I'm not convinced that Hernandez is good </b><a name="14987926">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=widmerseyebrow"> widmerseyebrow </a>  :  9/28/2020  10:26 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14987926">link</a>   </div></div><div class="thread_post_body">Although it's harder to tell because we haven't had a center.</div></div><div class="thread_post"><div class="thread_post_header"><b>Did you watch the Saints game last night? On Kamara's amazing TD... </b><a name="14987929">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=sb+from+NYT+Forum"> sb from NYT Forum </a>  :  9/28/2020  10:26 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14987929">link</a>   </div></div><div class="thread_post_body">...McCoy, their Center, motored down the field to block for Kamara.<br />
<br />
The Saints picked McCoy even though they already had Max Unger on the team.  They knew he was that good.  If Gettleman didn't trade up for Baker, he would have been there for the Giants, and he could have kept his 4th and 5th rounder.<br />
<br />
That's the kind of fuck up Gettleman keeps making that results in the OL sucking.<br />
<br /><br><a href="https://www.nfl.com/videos/can-t-miss-play-alvin-kamara-dances-for-unbelievable-52-yard-td"> Kamara 52 yard TD </a> - (<a href="https://www.nfl.com/videos/can-t-miss-play-alvin-kamara-dances-for-unbelievable-52-yard-td" target="_NEW"> New Window </a>)</div></div><div class="thread_post"><div class="thread_post_header"><b>Even if you like the talent and I think it has good potential  </b><a name="14987934">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BillT"> BillT </a>  :  9/28/2020  10:29 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14987934">link</a>   </div></div><div class="thread_post_body">He’s a year behind the curve. We have two developmental/potential starters in Lemieux and Peart on the bench.  “They” needed to be on the bench last year.  And I got killed here for suggesting that we may have “failed”  in FA because we didn’t address center. Too slow in getting the talent on board.</div></div><div class="thread_post"><div class="thread_post_header"><b>sb from NYT </b><a name="14987947">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Tesla"> Tesla </a>  :  9/28/2020  10:34 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14987947">link</a>   </div></div><div class="thread_post_body">That's the thing that drives me crazy.  How the hell to you exchange 3 mid to high round draft picks for a CB when you have gaping holes on your OL????</div></div><div class="thread_post"><div class="thread_post_header"><b>Solder sucking </b><a name="14987952">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=rocco8112"> rocco8112 </a>  :  9/28/2020  10:36 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14987952">link</a>   </div></div><div class="thread_post_body">destroyed the plan.<br />
<br />
Team has no professional center, still</div></div><div class="thread_post"><div class="thread_post_header"><b>Interesting you would start a thread like this </b><a name="14987955">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JCin332"> JCin332 </a>  :  9/28/2020  10:37 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14987955">link</a>   </div></div><div class="thread_post_body">when you have been at the forefront of the "it's the QB's fault crowd" the last several years...<br />
<br />
So now you are just realizing a QB needs a functioning OL to be successful?</div></div><div class="thread_post"><div class="thread_post_header"><b>Yup </b><a name="14987989">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=cosmicj"> cosmicj </a>  :  9/28/2020  10:58 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14987989">link</a>   </div></div><div class="thread_post_body">good post, Tesla.  This is really the #1 reason DG has to go.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Interesting you would start a thread like this </b><a name="14988000">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Tesla"> Tesla </a>  :  9/28/2020  11:02 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988000">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=601266&show_all=1#14987955" target="_blank">14987955</a> JCin332 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> when you have been at the forefront of the "it's the QB's fault crowd" the last several years...<br />
<br />
So now you are just realizing a QB needs a functioning OL to be successful? </td>
                                </tr>
                           </table><br />
<br />
Bullshit.  Acknowledging the Manning was toast does not equate to it all being the QB's fault - which I never said. Go find proof to the contrary.<br />
<br />
But i's nice to see that the Manning for life club will still find a way to bring him into every discussion going forward.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: The net result is you are correct. </b><a name="14988012">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  :  9/28/2020  11:09 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988012">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=601266&show_all=1#14987909" target="_blank">14987909</a> Tom in NY said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Some context to your points, however.<br />
<br />
* Nate Solder opting out really screwed up the team's plan for the Tackle positions.  I believe they were planning on using Fleming as a "Swing Tackle" this year, with Peart in a developmental role, and Solder/Thomas as the starters.<br />
<br />
* DG has spent capital to fix the Oline...he has just not done it in a timely, or frankly good way.   Zeitler was traded for last season, Hernandez was the 34th pick in the '18 draft, he signed Nate Solder to a huge contract, then drafted Thomas, Peart, and Lemieux this year.  Add the Omameh signing....which was a terrible decision, but an attempt to add talent.  <br />
<br />
Nick Gates was DGs college FA signing, and they have developed him into serviceable player.<br />
<br />
I agree that DG has not gotten the job done, mostly by making bad decisions, not because he hasn't made the effort. </td>
                                </tr>
                           </table><br />
<br />
Tend to agree with you Tom.  And those prior bad OL decisions have really hurt because now he had to make this past draft all about the Oline no matter what...and you never want to draft out of desperation.  <br />
<br />
Really needed to pursue a trade down strategy in 2018 or 2019 and add way more to the OL. Or at least not use up so much draft collateral on seemingly additional mistakes in Beal, Baker and LW.</div></div><div class="thread_post"><div class="thread_post_header"><b>Can we focus on the RG position just to illustrate the cluster f*** </b><a name="14988018">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=cosmicj"> cosmicj </a>  :  9/28/2020  11:13 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988018">link</a>   </div></div><div class="thread_post_body">up work here?  <br />
<br />
In 2017, the Giants picked up DJ Fluker, a prominent draft bust. He plays RG, apparently at a decent enough level to start the next two seasons for Pete Carroll on a Seahawks playoff team.  We let him go despite having little OL talent. <br />
<br />
The next season, 2018, the Giants stumbled on to Jamon Brown through a mid-season waiver pickup.  Brown I thought was a serviceable starter at a non-premium position.  This pick-up was a win.  Low cost, no draft capital used up, Brown could likely have improved with seasoning and coaching.  We don't re-sign him even though he was out there on the free agent market for a month or so, if I remember correctly.  He starts the next season for Atlanta.  Now with Philly.<br />
<br />
So on a talent-starved OL where these two players at the very least could have inarguably served as NFL level depth, we just let them go for nothing.<br />
<br />
Instead, we sign Omameh for a fair amount of money.  This is such a disaster and a scouting failure that he is benched and released within a couple of months.  <br />
<br />
Next step is the big trade for Kevin Zeitler.  Zeitler is a good player but he has a lot of tread on his tires.  A LOT.  He had started a total of 103 games in his career when arrived in NY.  103!  This for a rebuilding team.  This trade occurred after DG had started tearing the team apart.  So why acquire such an old player?  <br />
<br />
This is just a trail of incompetence.  As an alternative, we could have simply paid DJ Fluker $2-3mm a year and lived with very average performance.  Instead, we are paying Zeitler a lot more... for very average performance.<br />
<br />
Titled: Why the Giants haven't really improved since the 2017 disaster season.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Coulda, shoulda, woulda..... </b><a name="14988026">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Simms11"> Simms11 </a>  :  9/28/2020  11:17 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988026">link</a>   </div></div><div class="thread_post_body">DG has attempted to fix the Oline prior to this season, but his attempts didn't pan out. I think he hit it this year drafting three linemen with skill. They will, IMHO,  form a solid foundation. Biggest problem I see is his lack of seriously addressing the Center position. Very critical position, as he makes line calls and helps get the run game going and helping create a pocket for the QB. Last thing a QB needs is to have a rush in his face.<br />
<br />
Anyway, I think he's got 4/5ths of the line figured out. Get a real Center in here and put Gates back as a swing tackle or guard. He can now also be a back up at Center now. His versatility is better suited on the bench IMO.</div></div><div class="thread_post"><div class="thread_post_header"><b>In the 2018 Draft Gettleman had two 3rd Round picks </b><a name="14988028">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=sb+from+NYT+Forum"> sb from NYT Forum </a>  :  9/28/2020  11:19 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988028">link</a>   </div></div><div class="thread_post_body">...and Orlando Brown Jr. was sitting there.  <br />
<br />
Orlando Brown Jr. was a <span class="italics">unanimous</span> (AP, AFCA, FWAA, WCFF, TSN, SI, USAT, ESPN, CBS, CFN, Athlon) All-American OT.<br />
<br />
He had a bad combine and that's why he dropped out of the first round.  Was he risk as a 1st rounder based  on his bad combine?  Sure.  But by the third round he was not just a value pick but a steal.<br />
<br />
Gettleman could have picked Bloom with either of this 3rd rounders, instead he picks BJ Hill and Lorenzo Carter.  <br />
<br />
Meanwhile the Ravens pick Bloom who has been their starting RT since his rookie year.</div></div><div class="thread_post"><div class="thread_post_header"><b>Before the season </b><a name="14988029">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Thegratefulhead"> Thegratefulhead </a>  :  9/28/2020  11:19 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988029">link</a>   </div></div><div class="thread_post_body">There was a lot of discussion and multiple threads that queried which position group were you were most concerned about.  There were plenty of people more concerned about other units.  I was shocked.  That said, talk to me in the second half of the year.  Starting this OL meant we were giving up on the season before it began.  This was a rebuild, we know this with certainty based on the very public expectations from the owners.  They are ONLY looking for improvement by year's end.  Why would any fan expect anything different if that is what the players and coaches are being held accountable to by the people cutting the checks?</div></div><div class="thread_post"><div class="thread_post_header"><b>To be honest the biggest whiff </b><a name="14988035">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=jvm52106"> jvm52106 </a>  :  9/28/2020  11:21 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988035">link</a>   </div></div><div class="thread_post_body">came with Barkley. Once again, ignoring two positions on  a team that abosultely have to rely on others in order to achieve the greatness they may be destined for are RB and QB. Two years in a row we draft the STAR position player who needs an OLine to succeed and place them behind a shit show.<br />
<br />
Had we taken Nelson- or traded down just a few spots and taken Nelson, we would see a different team altogether. In all honesty, assuming no injuries etc, who knows what direction we go in for 2019 had we snagged Nelson.</div></div><div class="thread_post"><div class="thread_post_header"><b>I actually think Barkley was DG's plan to fix the OL... </b><a name="14988036">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Tesla"> Tesla </a>  :  9/28/2020  11:21 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988036">link</a>   </div></div><div class="thread_post_body">he thought Barkley was so amazing and special that he wouldn't really need much of an OL to run behind, and then defenses would have to load up to stop the run and that would make our passing game much easier.  <br />
<br />
Otherwise I'm not sure how you draft a RB at #2 overall and then not do everything in your power to give him a solid to great OL to run behind.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Interesting you would start a thread like this </b><a name="14988039">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Amtoft"> Amtoft </a>  :  9/28/2020  11:23 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988039">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=601266&show_all=1#14988000" target="_blank">14988000</a> Tesla said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14987955 JCin332 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     when you have been at the forefront of the "it's the QB's fault crowd" the last several years...<br />
<br />
So now you are just realizing a QB needs a functioning OL to be successful? <br />
                                <br />
                           <br />
<br />
Bullshit.  Acknowledging the Manning was toast does not equate to it all being the QB's fault - which I never said. Go find proof to the contrary.<br />
<br />
But i's nice to see that the Manning for life club will still find a way to bring him into every discussion going forward. </td>
                                </tr>
                           </table><br />
<br />
Wait why isn't everyone in the Manning club for life?  He was the greatest QB we ever had.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: In three years, the Giants have started Halapio, Pulley, and Gates at </b><a name="14988041">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Angel+Eyes"> Angel Eyes </a>  :  9/28/2020  11:23 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988041">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=601266&show_all=1#14987896" target="_blank">14987896</a> M.S. said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14987890 Greg from LI said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     center.  Halapio is a guard who drifted through several organizations without ever getting on the field.  Pulley is a journeyman backup.  Gates is a UDFA tackle.<br />
<br />
It's been basically the same group since Gettleman took over.  He's had three years to find a center and these jokers are still who he has chosen to go with.  It's appalling. <br />
                                <br />
                           <br />
Yep. No Center; no victories. </td>
                                </tr>
                           </table><br />
You can certainly <span class="italics">have</span> a center that's nothing special; the Packers of the mid-1960s, when they won their three NFL Championships in a row, had two guys who were nothing special, Ken Bowman and Bill Curry.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: In the 2018 Draft Gettleman had two 3rd Round picks </b><a name="14988042">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=jvm52106"> jvm52106 </a>  :  9/28/2020  11:24 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988042">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=601266&show_all=1#14988028" target="_blank">14988028</a> sb from NYT Forum said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> ...and Orlando Brown Jr. was sitting there.  <br />
<br />
Orlando Brown Jr. was a unanimous (AP, AFCA, FWAA, WCFF, TSN, SI, USAT, ESPN, CBS, CFN, Athlon) All-American OT.<br />
<br />
He had a bad combine and that's why he dropped out of the first round.  Was he risk as a 1st rounder based  on his bad combine?  Sure.  But by the third round he was not just a value pick but a steal.<br />
<br />
Gettleman could have picked Bloom with either of this 3rd rounders, instead he picks BJ Hill and Lorenzo Carter.  <br />
<br />
Meanwhile the Ravens pick Bloom who has been their starting RT since his rookie year. </td>
                                </tr>
                           </table><br />
<br />
Orlando Brown Jr. was a unanimous (AP, AFCA, FWAA, WCFF, TSN, SI, USAT, ESPN, CBS, CFN, Athlon) All-American OT.- why do I see the Spoof movie Hot Shots here when the Military and jet Contractor are meeting at a boxing matching and one of the boxers is introduced with like a gazillion titles and organizations...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: In three years, the Giants have started Halapio, Pulley, and Gates at </b><a name="14988045">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=jvm52106"> jvm52106 </a>  :  9/28/2020  11:25 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988045">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=601266&show_all=1#14988041" target="_blank">14988041</a> Angel Eyes said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14987896 M.S. said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     In comment 14987890 Greg from LI said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     center.  Halapio is a guard who drifted through several organizations without ever getting on the field.  Pulley is a journeyman backup.  Gates is a UDFA tackle.<br />
<br />
It's been basically the same group since Gettleman took over.  He's had three years to find a center and these jokers are still who he has chosen to go with.  It's appalling. <br />
                                <br />
                           <br />
Yep. No Center; no victories. <br />
                                <br />
                           <br />
You can certainly have a center that's nothing special; the Packers of the mid-1960s, when they won their three NFL Championships in a row, had two guys who were nothing special, Ken Bowman and Bill Curry. </td>
                                </tr>
                           </table><br />
<br />
you are using an example from almost 60 years ago? Hell, the 1930's saw teams with basically no passing games win..<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>This should be a good fight </b><a name="14988053">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Greg+from+LI"> Greg from LI </a>  :  9/28/2020  11:27 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988053">link</a>   </div></div><div class="thread_post_body">Both men work for Don King.</div></div><div class="thread_post"><div class="thread_post_header"><b>Since 2012 </b><a name="14988055">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=exiled"> exiled </a>  :  9/28/2020  11:27 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988055">link</a>   </div></div><div class="thread_post_body">I’ll never understand this.</div></div><div class="thread_post"><div class="thread_post_header"><b>I had high hopes for Hernandez after his rookie season. </b><a name="14988059">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=SFGFNCGiantsFan"> SFGFNCGiantsFan </a>  :  9/28/2020  11:28 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988059">link</a>   </div></div><div class="thread_post_body">But he's completely regressed.</div></div><div class="thread_post"><div class="thread_post_header"><b>Oh, the Packers of the '60s had pedestrian centers? </b><a name="14988062">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Greg+from+LI"> Greg from LI </a>  :  9/28/2020  11:29 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988062">link</a>   </div></div><div class="thread_post_body">You fail to mention that they also had two Hall of Fame linemen in Jerry Kramer and Forrest Gregg.</div></div><div class="thread_post"><div class="thread_post_header"><b>it sucks that </b><a name="14988076">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  9/28/2020  11:36 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988076">link</a>   </div></div><div class="thread_post_body">the OL had to start over again, but the results are what they are. DG will be judged on Thomas/Hernandez/X/X/Peart and if the pieces of the OL don't start to come together by week 8 or so, it's going to get ugly around here.</div></div><div class="thread_post"><div class="thread_post_header"><b>Trading a 3rd for Williams still sucks considering all the talent  </b><a name="14988079">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Danny+Dimes"> Danny Dimes </a>  :  9/28/2020  11:37 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988079">link</a>   </div></div><div class="thread_post_body">Giants still had a chance for Matt Hennessy or Cushenberry at Center 3rd round</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: it sucks that </b><a name="14988082">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Enzo"> Enzo </a>  :  9/28/2020  11:39 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988082">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=601266&show_all=1#14988076" target="_blank">14988076</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> the OL had to start over again, but the results are what they are. DG will be judged on Thomas/Hernandez/X/X/Peart and if the pieces of the OL don't start to come together by week 8 or so, it's going to get ugly around here. </td>
                                </tr>
                           </table><br />
why just judge him on those players? Why can't we judge him on the other guys he's brought in that haven't played well? <br /></div></div><div class="thread_post"><div class="thread_post_header"><b>The Patriots ... </b><a name="14988085">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+from+Katonah"> Jim from Katonah </a>  :  9/28/2020  11:40 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988085">link</a>   </div></div><div class="thread_post_body">... started a 6th round rookie at LG and a journeyman scrub at LT ... and dominated, over 200 yards rushing for their three very average RBs. It’s not like they have game breaking WRs or TEs either to keep the defense honest.  They plug in nobodys and next thing you know, the likes of Rex Burkhead are running wild.<br />
<br />
All of this talk about our lack of OL talent misses the point I think — it’s about getting your guys to execute. Not sure why we can’t, year after year.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Trading a 3rd for Williams still sucks considering all the talent  </b><a name="14988088">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  9/28/2020  11:42 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988088">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=601266&show_all=1#14988079" target="_blank">14988079</a> Danny Dimes said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Giants still had a chance for Matt Hennessy or Cushenberry at Center 3rd round </td>
                                </tr>
                           </table><br />
I get it, but the Center position for the 2020 draft was pretty bad in terms of depth. Upcoming draft seems significantly better with as many as 7 guys who could have 2nd round grades.</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="14988089">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  9/28/2020  11:44 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988089">link</a>   </div></div><div class="thread_post_body">.@giants  it is about techniques and fundamentals at the most basic levels. When enough of these get accomplished you will begin to gain yards on a consistent basis #BaldysBreakdowns<br /><br><a href="https://twitter.com/BaldyNFL/status/1310535252952133637"> https://twitter.com/BaldyNFL/status/1310535252952133637 </a> - (<a href="https://twitter.com/BaldyNFL/status/1310535252952133637" target="_NEW"> New Window </a>)</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="14988090">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  9/28/2020  11:44 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988090">link</a>   </div></div><div class="thread_post_body">.@giants Bad Play/Good Play. When you execute techniques properly you have success in this league. #BaldysBreakdowns<br><a href="https://twitter.com/BaldyNFL/status/1310536720170070021"> https://twitter.com/BaldyNFL/status/1310536720170070021 </a> - (<a href="https://twitter.com/BaldyNFL/status/1310536720170070021" target="_NEW"> New Window </a>)</div></div><div class="thread_post"><div class="thread_post_header"><b>Enzo </b><a name="14988091">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  9/28/2020  11:45 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988091">link</a>   </div></div><div class="thread_post_body">the X and X was supposed to be a part of that judgement. Obviously, C and Zeitler have not worked out either. We've used high draft capital on LT, LG, and RT, and got Zeitler in the trade, so all in all he should be getting the job done and he's not. <br />
<br />
That being said, part of the reason Judge was hired here is because they can no longer do the patchwork bullshit. There needs to be a plan. As they spent a lot of picks on OL in 2020, I imagine there will be more in 2021.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Trading a 3rd for Williams still sucks considering all the talent  </b><a name="14988096">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Tesla"> Tesla </a>  :  9/28/2020  11:48 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14988096">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=601266&show_all=1#14988079" target="_blank">14988079</a> Danny Dimes said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Giants still had a chance for Matt Hennessy or Cushenberry at Center 3rd round </td>
                                </tr>
                           </table><br />
<br />
And you could have had $16M to sign Conklin or another player(s).</div></div><div class="thread_post"><div class="thread_post_header"><b>I know I am repeating myselg here </b><a name="14988120">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=.McL."> .McL. </a>  :  9/28/2020  12:07 pm   : <a href="index.php?mode=2&thread=601266&show_all=1#14988120">link</a>   </div></div><div class="thread_post_body">But I certainly agree that the OL has been the biggest fiasco on this teams for the last 2 FO regimes.<br />
<br />
When DG took over, He immediately replaced 4 of the 5 starters, and move the other from LT to RT and then off the team in short order.  In total there were 7 players replaced that year, all 5 from the previous year were gone, Omameh was a terrible signing and replaced before mid season.  Halapio lasted 1.5 of games turning in league worst center play before being hurt and replaced for the season.  Also the massively expensive FA LT played like a UDFA.  That means that 140% of the line was replaced.  The next season, the only 2 returning starters from the end of the previous year were the underwhelming LT and LG.  Meaning 60% of the line that ended the prior season were replaced.   However we brought back the injured league worst center, so there is that.  And this year, again 60% of the line has been turned over...<br />
<br />
3 things:<br />
1) that shows an incomprehensible lack of evaluation skills<br />
2) if you are going to have that much turnover, you are going to spend A LOT more capital on the position as you spin your wheels.<br />
3) UFA is NOT a good place to spend capital on OL.  OL are becoming rarer, if teams have a decent one, they pay up and don't let them escape to FA.  The available FA are available for a reason.  DG spent on a terrible LT, a terrible RG, and two below average RTs.  I don't consider those moves as spending capital on the position.  They are just wasting time and money.<br />
<br />
To the poster wrote about Fluker and Brown at RG.  I agree 100% and have said the same in the past.  If they had kept one of them, then they could have use the capital they gain from that trade on something like a real center or a real RT.<br />
<br />
Up until this year, he spent only a second round pick and a sixth on OL.  A ridiculously low percentage of draft capital.  And its the draft where you are going to find OL.<br />
<br />
Finally, center is one of the most difficult position to play in football.  My opinion is that they are the 2nd most valuable OL players.  They have to be QB level smart, they have to call the blocking scheme.  THey have to have heightened awareness reading the play on the fly to figure out their assignments.  The best ones are very athletic and are masters at sliding off the double team and moving downfield to block at the 2nd level.  They have to protect the QB from pressure up the middle, often with a monster on their nose.  And they have to handle the ball.  It is a position that should be a priority to fill with excellence, not an after thought to be filled with undrafted journeymen, discard backups, and UDFAs.  Also, its best to not experiment with converting players from other positions.  OLs generally do not function well with poor centers.</div></div><div class="thread_post"><div class="thread_post_header"><b>And they could’ve had Biadasz </b><a name="14988172">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=WillVAB"> WillVAB </a>  :  9/28/2020  12:40 pm   : <a href="index.php?mode=2&thread=601266&show_all=1#14988172">link</a>   </div></div><div class="thread_post_body">Who played yesterday for Dallas and looked better than anything the Giants have had since O’Hara.  But we had to take a smurf slot corner who holds on 3rd and 22.</div></div><div class="thread_post"><div class="thread_post_header"><b>Gettleman refused to sign or draft a C </b><a name="14988208">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=jeff57"> jeff57 </a>  :  9/28/2020  12:57 pm   : <a href="index.php?mode=2&thread=601266&show_all=1#14988208">link</a>   </div></div><div class="thread_post_body">His arrogance is unbelievable</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I actually think Barkley was DG's plan to fix the OL... </b><a name="14988247">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=averagejoe"> averagejoe </a>  :  9/28/2020  1:11 pm   : <a href="index.php?mode=2&thread=601266&show_all=1#14988247">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=601266&show_all=1#14988036" target="_blank">14988036</a> Tesla said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> he thought Barkley was so amazing and special that he wouldn't really need much of an OL to run behind, and then defenses would have to load up to stop the run and that would make our passing game much easier.  <br />
<br />
Otherwise I'm not sure how you draft a RB at #2 overall and then not do everything in your power to give him a solid to great OL to run behind. </td>
                                </tr>
                           </table><br />
<br />
And this is why DG has to be fired. Carlo had to answer for Sonny and DG has to answer for this pick. He had all the cards and lost the hand anyway. This was a huge miss.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: And they could’ve had Biadasz </b><a name="14988276">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  9/28/2020  1:26 pm   : <a href="index.php?mode=2&thread=601266&show_all=1#14988276">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=601266&show_all=1#14988172" target="_blank">14988172</a> WillVAB said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Who played yesterday for Dallas and looked better than anything the Giants have had since O’Hara.  But we had to take a smurf slot corner who holds on 3rd and 22. </td>
                                </tr>
                           </table><br />
if you're going to base your evaluation of Holmes vs Biadasz on one game in week 3 of their rookie seasons, then you really are an idiot.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: This should be a good fight </b><a name="14988293">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=jvm52106"> jvm52106 </a>  :  9/28/2020  1:32 pm   : <a href="index.php?mode=2&thread=601266&show_all=1#14988293">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=601266&show_all=1#14988053" target="_blank">14988053</a> Greg from LI said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Both men work for Don King. </td>
                                </tr>
                           </table><br />
<br />
Ha ha, yes!</div></div><div class="thread_post"><div class="thread_post_header"><b>Nobody wants to consider </b><a name="14988426">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Walker+Gillette"> Walker Gillette </a>  :  9/28/2020  2:19 pm   : <a href="index.php?mode=2&thread=601266&show_all=1#14988426">link</a>   </div></div><div class="thread_post_body">that the lack of any offseason and 14 practices and no preseason games as training camp may have really hurt the OL. The line needed that time to gel and Gates and Thomas badly needed the experience. Yes this is frustrating and demoralizing and a million other awful things, but the pandemic made a very hard situation (new staff, young unexperienced team) a hundred times harder. Hopefully the line shows improvement as these guys learn and they have time to gel together. If there is no tangible improvement shown by the end of the year then lets burn down the Giant's facility and string up Gettleman and the Maras.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Nobody wants to consider </b><a name="14988516">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=sb+from+NYT+Forum"> sb from NYT Forum </a>  :  9/28/2020  3:01 pm   : <a href="index.php?mode=2&thread=601266&show_all=1#14988516">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=601266&show_all=1#14988426" target="_blank">14988426</a> Walker Gillette said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> that the lack of any offseason and 14 practices and no preseason games as training camp may have really hurt the OL. The line needed that time to gel and Gates and Thomas badly needed the experience. Yes this is frustrating and demoralizing and a million other awful things, but the pandemic made a very hard situation (new staff, young unexperienced team) a hundred times harder. Hopefully the line shows improvement as these guys learn and they have time to gel together. If there is no tangible improvement shown by the end of the year then lets burn down the Giant's facility and string up Gettleman and the Maras. </td>
                                </tr>
                           </table><br />
<br />
I would argue that the pandemic is all the more reason that the Giants should have obtained a player with experience at center.  Let's not forget that the pandemic was in full effect during the draft, why not draft Biadasz instead of yet another DB?  Why not sign a FA center and use Gates as a swing OL and develop him at C during a full training camp next year?  Several FA centers were available at modest prices.  Could they be any worse than Gates?<br><a href="https://www.spotrac.com/nfl/free-agents/2020/all/center/"> 2020 Free Agent Centers </a> - (<a href="https://www.spotrac.com/nfl/free-agents/2020/all/center/" target="_NEW"> New Window </a>)</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Nobody wants to consider </b><a name="14988529">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=.McL."> .McL. </a>  :  9/28/2020  3:07 pm   : <a href="index.php?mode=2&thread=601266&show_all=1#14988529">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=601266&show_all=1#14988426" target="_blank">14988426</a> Walker Gillette said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> that the lack of any offseason and 14 practices and no preseason games as training camp may have really hurt the OL. The line needed that time to gel and Gates and Thomas badly needed the experience. Yes this is frustrating and demoralizing and a million other awful things, but the pandemic made a very hard situation (new staff, young unexperienced team) a hundred times harder. Hopefully the line shows improvement as these guys learn and they have time to gel together. If there is no tangible improvement shown by the end of the year then lets burn down the Giant's facility and string up Gettleman and the Maras. </td>
                                </tr>
                           </table><br />
enough with the excuses, we have had a decade of them</div></div><div class="thread_post"><div class="thread_post_header"><b>I don’t think it’s fair to say... </b><a name="14988537">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  9/28/2020  3:10 pm   : <a href="index.php?mode=2&thread=601266&show_all=1#14988537">link</a>   </div></div><div class="thread_post_body">Gettleman hasn’t tried to fix the OL.<br />
<br />
He has. But his efforts have been a tragically poor. For a guy who waddles around claiming this is his specialty, he looks totally incompetent right now.</div></div><div class="thread_post"><div class="thread_post_header"><b>Most likely will be a Joe Judge guy </b><a name="14988545">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=nygiants16"> nygiants16 </a>  :  9/28/2020  3:14 pm   : <a href="index.php?mode=2&thread=601266&show_all=1#14988545">link</a>   </div></div><div class="thread_post_body">Hopefully that guy is a good gm</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I actually think Barkley was DG's plan to fix the OL... </b><a name="14988552">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=giants%231"> giants#1 </a>  :  9/28/2020  3:17 pm   : <a href="index.php?mode=2&thread=601266&show_all=1#14988552">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=601266&show_all=1#14988036" target="_blank">14988036</a> Tesla said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> he thought Barkley was so amazing and special that he wouldn't really need much of an OL to run behind, and then defenses would have to load up to stop the run and that would make our passing game much easier.  <br />
<br />
Otherwise I'm not sure how you draft a RB at #2 overall and then not do everything in your power to give him a solid to great OL to run behind. </td>
                                </tr>
                           </table><br />
<br />
He did do everything to build an OL for SB (and Eli), he just failed:<br />
<br />
- Signed Solder (after Norwell went to Jags)<br />
- Signed Omameh - missed horribly here<br />
- Drafted Hernandez at the top of the 2nd<br />
<br />
That's 3 new OL starters.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I actually think Barkley was DG's plan to fix the OL... </b><a name="14988570">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=.McL."> .McL. </a>  :  9/28/2020  3:26 pm   : <a href="index.php?mode=2&thread=601266&show_all=1#14988570">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=601266&show_all=1#14988552" target="_blank">14988552</a> giants#1 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14988036 Tesla said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     he thought Barkley was so amazing and special that he wouldn't really need much of an OL to run behind, and then defenses would have to load up to stop the run and that would make our passing game much easier.  <br />
<br />
Otherwise I'm not sure how you draft a RB at #2 overall and then not do everything in your power to give him a solid to great OL to run behind. <br />
                                <br />
                           <br />
<br />
He did do everything to build an OL for SB (and Eli), he just failed:<br />
<br />
- Signed Solder (after Norwell went to Jags)<br />
- Signed Omameh - missed horribly here<br />
- Drafted Hernandez at the top of the 2nd<br />
<br />
That's 3 new OL starters. </td>
                                </tr>
                           </table><br />
Problem is, he needed 5 new starters that year...<br />
And looking to FA for OL just doesn't count anymore.  It's no surprise when you miss in FA on OL...  They wouldn't be FA if they were worth a damn.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: In the 2018 Draft Gettleman had two 3rd Round picks </b><a name="14988810">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=VinegarPeppers"> VinegarPeppers </a>  :  9/28/2020  6:07 pm   : <a href="index.php?mode=2&thread=601266&show_all=1#14988810">link</a>   </div></div><div class="thread_post_body">That guy had Erick Flowers written all over him.  Looked lazy as shit. Terrible effort and slow plodding feet with lousy hand placement forever.<br />
<br />
BBI heads would have exploded had we taken him after the combine he had.  Didn't he get like 14 reps on the bench as opposed to the 25 some RBs were getting?<br />
<br />
<br />
In comment <a href="index.php?mode=2&thread=601266&show_all=1#14988028" target="_blank">14988028</a> sb from NYT Forum said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> ...and Orlando Brown Jr. was sitting there.  <br />
<br />
Orlando Brown Jr. was a unanimous (AP, AFCA, FWAA, WCFF, TSN, SI, USAT, ESPN, CBS, CFN, Athlon) All-American OT.<br />
<br />
He had a bad combine and that's why he dropped out of the first round.  Was he risk as a 1st rounder based  on his bad combine?  Sure.  But by the third round he was not just a value pick but a steal.<br />
<br />
Gettleman could have picked Bloom with either of this 3rd rounders, instead he picks BJ Hill and Lorenzo Carter.  <br />
<br />
Meanwhile the Ravens pick Bloom who has been their starting RT since his rookie year. </td>
                                </tr>
                           </table></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: And they could’ve had Biadasz </b><a name="14989116">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=WillVAB"> WillVAB </a>  :  9/28/2020  9:57 pm   : <a href="index.php?mode=2&thread=601266&show_all=1#14989116">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=601266&show_all=1#14988276" target="_blank">14988276</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14988172 WillVAB said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Who played yesterday for Dallas and looked better than anything the Giants have had since O’Hara.  But we had to take a smurf slot corner who holds on 3rd and 22. <br />
                                <br />
                           <br />
if you're going to base your evaluation of Holmes vs Biadasz on one game in week 3 of their rookie seasons, then you really are an idiot. </td>
                                </tr>
                           </table><br />
<br />
Want to bet on who has the better career?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I actually think Barkley was DG's plan to fix the OL... </b><a name="14989122">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=WillVAB"> WillVAB </a>  :  9/28/2020  9:59 pm   : <a href="index.php?mode=2&thread=601266&show_all=1#14989122">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=601266&show_all=1#14988552" target="_blank">14988552</a> giants#1 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 14988036 Tesla said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     he thought Barkley was so amazing and special that he wouldn't really need much of an OL to run behind, and then defenses would have to load up to stop the run and that would make our passing game much easier.  <br />
<br />
Otherwise I'm not sure how you draft a RB at #2 overall and then not do everything in your power to give him a solid to great OL to run behind. <br />
                                <br />
                           <br />
<br />
He did do everything to build an OL for SB (and Eli), he just failed:<br />
<br />
- Signed Solder (after Norwell went to Jags)<br />
- Signed Omameh - missed horribly here<br />
- Drafted Hernandez at the top of the 2nd<br />
<br />
That's 3 new OL starters. </td>
                                </tr>
                           </table><br />
<br />
This is the same shit people used to say about Reese.  Carbon copy.  Throwing shit against the wall doesn’t count as “doing everything.”</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Coulda, shoulda, woulda..... </b><a name="14989288">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=giantstock"> giantstock </a>  : 2:32 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14989288">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=601266&show_all=1#14988026" target="_blank">14988026</a> Simms11 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> DG has attempted to fix the Oline prior to this season, but his attempts didn't pan out. I think he hit it this year drafting three linemen with skill. They will, IMHO,  form a solid foundation. <br />
<br />
Anyway, I think he's got 4/5ths of the line figured out.  </td>
                                </tr>
                           </table><br />
<br />
No offense to you but this is the same broken record we've heard over-and-over since DG has been the GM. Further, how often have we heard in the past after draft day how DG "NAILED IT?" <br />
<br />
How often have we heard the same type of posts you are saying now that's been posted comparing the prior year vs the upcoming year and how each individual player was better only to end up with a same crummy OLINE because even if the a few might have more talent they function miserably? <br />
<br />
There is nothing that indicates what you're saying about the 2 new OL will come true. It's all based on blind hope. Yet we've seen so much incompetence from DG since he became GM. So he has been horrid for the past few years yet NOW - THIS YEAR- ALL OF SUDDEN he is going to "HIT VERY WELL" with a 3rd AND 4th rounder that either this year or next year the OLINE is going to be good? <br />
<br />
We haven't even seen these guys play 1 quarter of pro football with a lousy recent track record we've seen from DG yet you're proclaiming these two guys are going to be good going forward? Your comments are the same broken record we've heard over-and-over.</div></div><div class="thread_post"><div class="thread_post_header"><b>Hernandez is not good. </b><a name="14989293">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Matt+M."> Matt M. </a>  : 3:03 am   : <a href="index.php?mode=2&thread=601266&show_all=1#14989293">link</a>   </div></div><div class="thread_post_body">He hasn't been able to claim that since he was a rookie. It doesn't help that he played next to an inept Solder and has never had a quality OC. But, he doesn't seem to make the right decisions and he doesn't seem capable of handling the guy he engages when he does. <br />
<br />
I blame part of that on the previous coaching staff. He played primarily RG in college and Zeitler played his best football at LG. But, Hernandez was played at LG from day one, likely to put him next to a veteran LT in Solder, as opposed to a dumpster fire in Flowers at RT. If they were flip flopped, would either of them or the OL overall have been any better? Who knows. But it sucks now, and Hernandez, whether you like him or not (and I REALLY want to like him), is a big part of that.<br />
<br />
I would play Lemieux at LG and Peart at RT right now. We literally have nothing to lose. The OL has performed that poorly, especially the guys they would replace.<br />
<br />
As for OC, we don't have a better viable option. So, we continue to take our lumps with Gates and hope he improves. Almost to a man here at BBI, the expectation was that Gates would win the job and anchor the middle of the line. That might have been false hope, which we really needed. If he improves over the course of the season, we may still have something. If not, OC is an immediate need and RG is something we need to start thinking about with Zeitler already 30 and just OK.</div></div><div style="margin: 10 10 20 50"><span class="top_pages">Pages:  <a href="index.php?mode=2&thread=601266&thread_page=1" >1</a>  <b style="background: darkred;padding: 2px 5px 2px 5px;">2</b>  <a href="index.php?mode=2&thread=601266&thread_page=1" >&lt;&lt;Prev&nbsp;</a>| <a href="index.php?mode=2&thread=601266&show_all=1" title="">Show All</a> | </span></div>
<a name="END"><a href="index.php"><div style="padding-top:25px; padding-bottom:20px;"><img src="/images/back_corner.gif" class="thread_link"  alt="Back to the Corner" border="0"></a></div></a></div>
<div class="thread_sidebar_2">

<!-- Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-102">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Corner Forum - Lower 300x250 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1566320450447229"
     data-ad-slot="4189314539"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->

</div>

</div>




<div class="footer">


<p style="width:400px;float:left;"><b>Part of the USA Today Sports Media Group</b><br>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</P>
<P  style="width:400px;float:right; text-align:right;">
All contents (unless otherwise specified) copyright &copy;  1995 - 2020<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Solutions</a>
</P>
<br clear="all">
<div style="float:right;">
<script
    src="https://sucuri.net/monitoring/badge.js"
    data-s="19"
    id="sucuri-s"
    data-i="7b1b29ae50ae6574f2af3875935246e4fa8a805b26"
    data-p="o" - position - l(left) or r(right) or o(relative)
    data-c="l"
    data-t="t"
    ></script>
</div>

</div>


<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->

<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=191-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script></body>
</html>
