<!DOCTYPE html>
<html lang="en">
<head><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
(new Image()).src=pixelURL;}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=191-0&cb=2', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=191-0&cb=1', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=191-0&cb=5', false, [], true, false, true, false);</script>
<title>Daniel Jones poll — what’s the best course of action? | Big Blue Interactive </title>


<meta name="keywords" content="ndglbqfkxx">

<meta name="description" content="Genuinely curious what you gentlemen are thinking concerning Jones. So here is the poll, with two options. (It’d be great if it didn’t devolve into a debate about Eli or DG or why a person’s vote is stupid etc.). Option 1:  Fully commit to Jones for at least another year, and use prime 2021 draft resources and big veteran $ on non-QBs (the “build around” option). Option 2:  Use either a first/second/third rounder on a QB, or sign a big $ starter quality vet, with an eye towards replacing Jones at some point in 2021 (the “he’s not the answer” option). For me, it’s a difficult question. Feels like a big step back to give up so early on a guy who has flashed so many good things, especially in light of the new regime and lack of weapons. But ultimately, I think Jones lacks the natural instincts that all the top QBs have (the ability to see and feel pressure, move within the pocket, and quickly scan the field) — which I don’t think are teachable/attainable with more reps. And for that reason, I’d rather head back out into the market (option 2). Curious what you all think. "/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="website" />
<meta property="og:description" content="Genuinely curious what you gentlemen are thinking concerning Jones. So here is the poll, with two options. (It’d be great if it didn’t devolve into a debate about Eli or DG or why a person’s vote is stupid etc.). Option 1:  Fully commit to Jones for at least another year, and use prime 2021 draft resources and big veteran $ on non-QBs (the “build around” option). Option 2:  Use either a first/second/third rounder on a QB, or sign a big $ starter quality vet, with an eye towards replacing Jones at some point in 2021 (the “he’s not the answer” option). For me, it’s a difficult question. Feels like a big step back to give up so early on a guy who has flashed so many good things, especially in light of the new regime and lack of weapons. But ultimately, I think Jones lacks the natural instincts that all the top QBs have (the ability to see and feel pressure, move within the pocket, and quickly scan the field) — which I don’t think are teachable/attainable with more reps. And for that reason, I’d rather head back out into the market (option 2). Curious what you all think. " /> 
<meta property="og:title" content="Daniel Jones poll — what’s the best course of action?" /> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif" /> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css?v=20200217" />

<link rel="stylesheet" type="text/css" href="anylink.css" />


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}


div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" alt="for display only">

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type='text/javascript'>
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type='text/javascript' src='https://img.bnqt.com/lib/js/sdpdfphelper.js'></script>
<script type='text/javascript'>
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>


<!-- End DFP SETUP -->  

<!-- End USA Today Code -->





<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-131124163-7";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(function(){
	_gat._createTracker('UA-131124163-7', 'e');
});
_gaq.push(function(){
	_gat._createTracker('UA-38339005-1', 'f');
});
_gaq.push(['e._setDomainName', 'bigblueinteractive.com']);
_gaq.push(['f._setDomainName', 'bigblueinteractive.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod21',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','bigblueinteractive.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://corner.bigblueinteractive.com/index.php?mode=2&thread=604160&show_all=1"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"domain_test_group":20200409,"engaged_time_visit":0,"ezcache_level":0,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"538a7f93-7ea0-4c4e-64c8-6a00c53bf141","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":74,"serverid":"34.204.86.52:18134","state":"VA","t_epoch":1608110872,"template_id":126,"time_on_site_visit":0,"url":"https://corner.bigblueinteractive.com/index.php?mode=2\u0026thread=604160\u0026show_all=1","user_id":0,"word_count":25715,"worst_bad_word_level":1};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=191-0&v=9" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["538a7f93-7ea0-4c4e-64c8-6a00c53bf141", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>


<body>




<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"></a> <img src="images/xpete.gif" alt="The Corner Forum">

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic -->&nbsp;


<!-- Nov 2019 Leaderboard -->

<!-- Ezoic - Forum Leaderboard (USAT) - top_of_page -->
<div id="ezoic-pub-ad-placeholder-118">
<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->
<div id='usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general'>
     <script type='text/javascript'>
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general');
         });
     </script>
</div>
</div>
<!-- End Ezoic - Forum Leaderboard (USAT) - top_of_page -->



</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://www.amazon.com/?_encoding=UTF8&camp=1789&creative=9325&linkCode=ur2&tag=bigblueintera-20">Amazon.com</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW" >Standings (NFL.com)</a>
<a href="https://www.giants.com/team/stats/" target="_NEW" >Statistics (Giants.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/" >Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'home_view_menu')">Home</a>  
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'forum_view_menu')">Corner Forum</a>
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'gameday_view_menu')">Gameday</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_view_menu')">Team</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_building_view_menu')">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info &amp; History</a> -->
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_info_view_menu')">Giants Info &amp; History</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'infolinks_view_menu')">Info/Links</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'shop_view_menu')">BBI Shop</a>
<li><a href="/index.php?mode=10" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'login_menu')">Log In</a>
</ul>

</div><div id="infoline"> </div>

<a name="END"><a href="index.php"><div style="padding-top:20px; padding-bottom:25px;"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"></a></div></a><div class="thread_container"><div class="thread_left"><div class="thread_body" ><div class="thread_main" ><div class="thread_post_header" >  <h1 style="font-size:18px;">Daniel Jones poll — what’s the best course of action? </h1><div class="thread_info"><a href="index.php?mode=5&handle=Jim from Katonah"> Jim from Katonah </a>  :  12/14/2020  3:15 pm</div></div><div class="thread_post_body" > Genuinely curious what you gentlemen are thinking concerning Jones. So here is the poll, with two options. (It’d be great if it didn’t devolve into a debate about Eli or DG or why a person’s vote is stupid etc.).<br />
<br />
Option 1:  Fully commit to Jones for at least another year, and use prime 2021 draft resources and big veteran $ on non-QBs (the “build around” option).<br />
<br />
Option 2:  Use either a first/second/third rounder on a QB, or sign a big $ starter quality vet, with an eye towards replacing Jones at some point in 2021 (the “he’s not the answer” option).<br />
<br />
For me, it’s a difficult question. Feels like a big step back to give up so early on a guy who has flashed so many good things, especially in light of the new regime and lack of weapons. But ultimately, I think Jones lacks the natural instincts that all the top QBs have (the ability to see and feel pressure, move within the pocket, and quickly scan the field) — which I don’t think are teachable/attainable with more reps. And for that reason, I’d rather head back out into the market (option 2).<br />
<br />
Curious what you all think.<br />
<br />
<br />
 </div></div></div></div><div class="thread_right"><div id="ad_side_box">


<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id='usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general'>
     <script type='text/javascript'>
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general');
         });
     </script>
</div>




</div></div><div class="thread_comment_container"><div class="thread_post"><div class="thread_post_header"><b>Premature </b><a name="15080044">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Thegratefulhead"> Thegratefulhead </a>  :  12/14/2020  3:19 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080044">link</a>   </div></div><div class="thread_post_body">Ask this question after 3 more games.  If end up with a shot at Fields or Wilson even if we have to give some draft capital I would seriously consider it if we are at 5 or 6 wins for the season.</div></div><div class="thread_post"><div class="thread_post_header"><b>They're not gonna be in position to draft a top qb </b><a name="15080047">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=TDMaker85"> TDMaker85 </a>  :  12/14/2020  3:20 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080047">link</a>   </div></div><div class="thread_post_body">And the light can still very much come on for him in year 3 (ideally with an added weapon or two).  So you commit to DJ.</div></div><div class="thread_post"><div class="thread_post_header"><b>Option A with a caveat: </b><a name="15080048">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=MadMax"> MadMax </a>  :  12/14/2020  3:20 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080048">link</a>   </div></div><div class="thread_post_body">I am very concerned by Jones' ball security but it may be best to give him another year.  The caveat would be to bring in a proven veteran backup (former starter elsewhere) to hedge our bets.</div></div><div class="thread_post"><div class="thread_post_header"><b>. </b><a name="15080050">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GiantEgo"> GiantEgo </a>  :  12/14/2020  3:21 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080050">link</a>   </div></div><div class="thread_post_body">Interesting how we didn't have endless threads on Jones the last 4 weeks.</div></div><div class="thread_post"><div class="thread_post_header"><b>Seriously? </b><a name="15080056">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Don+in+DC"> Don in DC </a>  :  12/14/2020  3:26 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080056">link</a>   </div></div><div class="thread_post_body">Kid comes out to play while gutting it out through an injury and this is the thanks he gets?<br />
<br />
Ridiculous.</div></div><div class="thread_post"><div class="thread_post_header"><b>Get him a consistently good OL </b><a name="15080059">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BillT"> BillT </a>  :  12/14/2020  3:29 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080059">link</a>   </div></div><div class="thread_post_body">And a receiving corps that can regularly get open.   That is all.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Seriously? </b><a name="15080060">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Thegratefulhead"> Thegratefulhead </a>  :  12/14/2020  3:29 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080060">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080056" target="_blank">15080056</a> Don in DC said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Kid comes out to play while gutting it out through an injury and this is the thanks he gets?<br />
<br />
Ridiculous. </td>
                                </tr>
                           </table>If he wants love, he has to stop putting the ball on the turf.  that is the bar.  If he can't get over that bar he needs to get out of the kitchen.  His hamstring didn't pat the ball 5 times before he threw it.</div></div><div class="thread_post"><div class="thread_post_header"><b>Tough question when I don't think he was 100% nor has a top WR Corp </b><a name="15080061">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GiantBlue"> GiantBlue </a>  :  12/14/2020  3:29 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080061">link</a>   </div></div><div class="thread_post_body">I guess my vote is 1.......and let's draft WR's, bring in a prime WR FA and continue to build around our foundation.<br />
<br />
I think he will be fine with a good group around him and WR's to throw to.<br />
<br />
As for another QB...I could live with Colt another year or two.</div></div><div class="thread_post"><div class="thread_post_header"><b>Option 2 </b><a name="15080063">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  12/14/2020  3:30 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080063">link</a>   </div></div><div class="thread_post_body">We shouldn't be "giving" him anything. He should have to take it. The Giants should be trying to improve at every position all the time - how can they not try to improve over Jones?</div></div><div class="thread_post"><div class="thread_post_header"><b>Only option </b><a name="15080064">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Br00klyn"> Br00klyn </a>  :  12/14/2020  3:30 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080064">link</a>   </div></div><div class="thread_post_body">is to put some talent around him at the WR position by using our 1st or 2nd rounder on a WR as well as bring in a vet like Golladay. Im not too high on Jones but the WR's he has been given are not putting him in a position to succeed. He gets one more shot with a good WR core, healthy(hopefully) Saquan, and another year of an improving OL. If he still cant cut it, then hes gone</div></div><div class="thread_post"><div class="thread_post_header"><b>I have not seen enough to bail on him </b><a name="15080068">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=George+from+PA"> George from PA </a>  :  12/14/2020  3:31 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080068">link</a>   </div></div><div class="thread_post_body">I would like a more capable back-up...not to force a return to action too soon.<br />
<br />
But option A from your list</div></div><div class="thread_post"><div class="thread_post_header"><b>I'd give him every opportunity next year </b><a name="15080069">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=jerseygiant"> jerseygiant </a>  :  12/14/2020  3:31 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080069">link</a>   </div></div><div class="thread_post_body">Draft DeVonta Smith or Ja'Marr Chase in the 1st. Sign someone in free agency. Saquon back. Garrett or a new OC, I don't care. And see where we are at half way through the season.  <br />
<br />
If he isn't getting it done, give a rookie QB a shot. Jamie Newman an Desmond Ridder are dynamic guys I'd take a chance on in the 3rd.</div></div><div class="thread_post"><div class="thread_post_header"><b>How about </b><a name="15080070">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Carl+in+CT"> Carl in CT </a>  :  12/14/2020  3:31 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080070">link</a>   </div></div><div class="thread_post_body">Get him some wide receivers and see what he can do.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Seriously? </b><a name="15080071">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=rsjem1979"> rsjem1979 </a>  :  12/14/2020  3:32 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080071">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080056" target="_blank">15080056</a> Don in DC said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Kid comes out to play while gutting it out through an injury and this is the thanks he gets?<br />
<br />
Ridiculous. </td>
                                </tr>
                           </table><br />
<br />
Yes.  Because it's professional football and it's his job, not intramural flag football.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Seriously? </b><a name="15080073">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  12/14/2020  3:32 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080073">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080056" target="_blank">15080056</a> Don in DC said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Kid comes out to play while gutting it out through an injury and this is the thanks he gets?<br />
<br />
Ridiculous. </td>
                                </tr>
                           </table><br />
That's a fair point, and it would be even more valid if the flaws we saw yesterday weren't identical to the ones we've seen from him throughout his short career.<br />
<br />
Are you suggesting that he needs to be at/near 100% physically to not make dumb mental errors?  Because if that's the case, it's not nearly as strong a defense as you think - there are going to be a lot of times over the course of an NFL career that a starting QB is going to be out there at less than 100%.  If gutting out an injury means DJ is considerably more likely to play like shit, that's a pretty significant issue in and of itself.<br />
<br />
I don't think one game alone should signal the death knell for DJ, but I also don't think it's helpful to pretend like it wasn't consistent with what we know his weaknesses to be even when he's healthy.</div></div><div class="thread_post"><div class="thread_post_header"><b>CBS Sports 2021 Current Draft Ranking </b><a name="15080074">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Trainmaster"> Trainmaster </a>  :  12/14/2020  3:34 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080074">link</a>   </div></div><div class="thread_post_body"><table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Player School Year Pos Pos Rk HT WT<br />
1 Trevor Lawrence Clemson Jr QB 1 6-6 220<br />
4 Justin Fields Ohio St. Jr QB 2 6-3 228<br />
11 Trey Lance No Dakota St. Soph QB 3 6-4 226<br />
13 Zach Wilson BYU Jr QB 4 6-3 210</td>
                                </tr>
                           </table><br />
<br />
Assuming the Giants pick around 10th in the first round, Lawrence will be gone and Fields would cost a bundle on a trade up.  Lance and Wilson might either still be available or reachable with a small to medium expense to trade up.<br />
<br />
I'm starting to get worried about Jones, but as my daughter correctly pointed out, we weren't sure about Eli as late as late in 2007 regular season (over 3.5 years and nearly 50 games played).<br />
<br />
I'd say we need to give Jones a full, regular off season, OTAs, MiniCamp, Training Camp and Preseason with Judge and his staff to see if / how he improves.  The fumbling issues HAS to be fixed; it's a killer.<br />
<br />
Let's see how the OL looks over the next 3 games.  Jones needs some weapons.  A good WR or TE should be available at around 10th overall. A hopefully healthy and full recovered Barkley is obviously a huge asset.<br />
<br />
In short, too early to cut bait and move on from Jones.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Right now... </b><a name="15080079">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  12/14/2020  3:36 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080079">link</a>   </div></div><div class="thread_post_body">Option 2 seems the smarter play. <br />
<br />
Hell, I could argue that we draft a QB in round one - say, Wilson - and let him and Jones battle it out. Or do the Cards-Murray-Rosen strategy. I'd take a second rounder for Jones and new blood.<br />
<br />
If Jones finishes these last three games strong and steers the team into the playoffs, then the conversation needs to be revisited.</div></div><div class="thread_post"><div class="thread_post_header"><b>The flaws yesterday were not identical to those from the past. </b><a name="15080080">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Don+in+DC"> Don in DC </a>  :  12/14/2020  3:36 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080080">link</a>   </div></div><div class="thread_post_body">Unlike the prior 20+ games he played, he was a statute in the pocket all day due to his injury, and that was his greatest problem.  As a result he was uncomfortable in the pocket and generally ineffective.<br />
<br />
Note that he looked very good the last three games he played.  Throwing that all out the window because he played badly when injured is stupid and shitty.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: The flaws yesterday were not identical to those from the past. </b><a name="15080084">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Matt+M."> Matt M. </a>  :  12/14/2020  3:39 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080084">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080080" target="_blank">15080080</a> Don in DC said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Unlike the prior 20+ games he played, he was a statute in the pocket all day due to his injury, and that was his greatest problem.  As a result he was uncomfortable in the pocket and generally ineffective.<br />
<br />
Note that he looked very good the last three games he played.  Throwing that all out the window because he played badly when injured is stupid and shitty. </td>
                                </tr>
                           </table>That is fair. But, so is not throwing out all the turnover plagued games that surround those 3 games.</div></div><div class="thread_post"><div class="thread_post_header"><b>...... </b><a name="15080086">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Route+9"> Route 9 </a>  :  12/14/2020  3:39 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080086">link</a>   </div></div><div class="thread_post_body">Why is it too early to cut ties with Jones? The Cardinals did with their Rosen or whatever pick and then took Murray the following year. <br />
<br />
Am I missing something here? What would we be missing without Jones? Eight games this year without a touchdown throw. 600 fumbles. Help me to understand. Hopefully the smart minds of BBI can help me to get this.</div></div><div class="thread_post"><div class="thread_post_header"><b>Option 2 </b><a name="15080088">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sean"> Sean </a>  :  12/14/2020  3:40 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080088">link</a>   </div></div><div class="thread_post_body">I like Jones, he’s easy to root for. It boils down to this:<br />
<br />
Does he make enough explosive plays to overcome his turnovers? The answer is simply no.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: The flaws yesterday were not identical to those from the past. </b><a name="15080091">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Kyle_"> Kyle_ </a>  :  12/14/2020  3:40 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080091">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080080" target="_blank">15080080</a> Don in DC said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Unlike the prior 20+ games he played, he was a statute in the pocket all day due to his injury, and that was his greatest problem.  As a result he was uncomfortable in the pocket and generally ineffective.<br />
<br />
Note that he looked very good the last three games he played.  Throwing that all out the window because he played badly when injured is stupid and shitty. </td>
                                </tr>
                           </table><br />
He didn't look "very good" in the last three games he played prior to injury compared to the league at-large.<br />
<br />
He looked very good compared to his own bad play.<br />
<br />
In the three games he played prior to injury, he was playing decent starting quarterback football. Decent. Average is pejorative for people, because everyone wants something above the average, but he was average.<br />
<br />
It's just that average was a significant improvement for him.</div></div><div class="thread_post"><div class="thread_post_header"><b>Option 2. </b><a name="15080092">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=SFGFNCGiantsFan"> SFGFNCGiantsFan </a>  :  12/14/2020  3:41 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080092">link</a>   </div></div><div class="thread_post_body">At a minimum, we need a legit backup to push him. No more Colt McCoys of the world.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: The flaws yesterday were not identical to those from the past. </b><a name="15080094">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Carson53"> Carson53 </a>  :  12/14/2020  3:41 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080094">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080080" target="_blank">15080080</a> Don in DC said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Unlike the prior 20+ games he played, he was a statute in the pocket all day due to his injury, and that was his greatest problem.  As a result he was uncomfortable in the pocket and generally ineffective.<br />
<br />
Note that he looked very good the last three games he played.  Throwing that all out the window because he played badly when injured is stupid and shitty. </td>
                                </tr>
                           </table>.<br />
<br />
He did put the ball on the ground 3 times, ball security<br />
is an ongoing issue. I blame Judge more for playing him,<br />
when he was neutered and couldn't run.<br />
If Jones is not capable of running RPO's, then he should<br />
not have been playing. He will be nursing that hamstring for the rest of the year, most likely.</div></div><div class="thread_post"><div class="thread_post_header"><b>Meh. This game looked the same as the 49er game.  </b><a name="15080096">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Route+9"> Route 9 </a>  :  12/14/2020  3:42 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080096">link</a>   </div></div><div class="thread_post_body">and Jones could move fine. He stinks.</div></div><div class="thread_post"><div class="thread_post_header"><b>As DG has said in the past </b><a name="15080097">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=US1+Giants"> US1 Giants </a>  :  12/14/2020  3:42 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080097">link</a>   </div></div><div class="thread_post_body">Picking the wrong QB high in the draft is a 5 year mistake.  They have to give him time to prove that he was not a mistake unless he is a complete train wreck.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: The flaws yesterday were not identical to those from the past. </b><a name="15080099">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+from+Katonah"> Jim from Katonah </a>  :  12/14/2020  3:43 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080099">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080080" target="_blank">15080080</a> Don in DC said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Unlike the prior 20+ games he played, he was a statute in the pocket all day due to his injury, and that was his greatest problem.  As a result he was uncomfortable in the pocket and generally ineffective.<br />
<br />
Note that he looked very good the last three games he played.  Throwing that all out the window because he played badly when injured is stupid and shitty. </td>
                                </tr>
                           </table><br />
<br />
Thanks Don!</div></div><div class="thread_post"><div class="thread_post_header"><b>Option #2 </b><a name="15080102">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+in+Tampa"> Jim in Tampa </a>  :  12/14/2020  3:45 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080102">link</a>   </div></div><div class="thread_post_body">I regret to state that, but I have to look at Jones as objectively as I can.<br />
<br />
To my eyes, Jones has not shown an ability to quickly go through his reads and get the ball to the right receiver.<br />
<br />
He also has lousy pocket awareness and sometimes, even when he sees the defender coming and tries to tuck the ball away, he STILL fumbles (as was the case yesterday with fumble #3.)<br />
<br />
Drafting a QB prospect early may seem like a step back for the "program" but staying with the wrong QB hoping that he will improve is an even bigger step back.<br />
<br />
Also, unlike fans who "need more time" to evaluate Jones, my guess is that the Giants' braintrust (coaches/GM/Owners) already know what they have in Jones and they will make a move to another QB if a viable option presents itself.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Option 2 </b><a name="15080103">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Carson53"> Carson53 </a>  :  12/14/2020  3:45 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080103">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080088" target="_blank">15080088</a> Sean said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I like Jones, he’s easy to root for. It boils down to this:<br />
<br />
Does he make enough explosive plays to overcome his turnovers? The answer is simply no. </td>
                                </tr>
                           </table>.<br />
<br />
As far as fumbles, he has 28 in 25 games, 2nd in the <br />
modern era I read somewhere. So since 1966.<br />
The inimitable Tony Banks is the leader in that dubious category, by the way.</div></div><div class="thread_post"><div class="thread_post_header"><b>Option 1. I still haven't given up on him. Tough crowd </b><a name="15080105">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Blue21"> Blue21 </a>  :  12/14/2020  3:45 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080105">link</a>   </div></div><div class="thread_post_body">here but I understand after a very disapointing loss yesterday. Do I have some concern? Sure. But every QB develops differently. I believe if he's here next year as the starter then Judge is convinced he's the man. Last week everyone said we needed him back to have a chance to win. The haters were quiet. This week he plays on a gimpy leg and the haters come out to throw him overboard. I may get to that point but I'm not there yet.</div></div><div class="thread_post"><div class="thread_post_header"><b>...... </b><a name="15080107">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=CoughlinHandsonHips"> CoughlinHandsonHips </a>  :  12/14/2020  3:46 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080107">link</a>   </div></div><div class="thread_post_body">If they go the draft route, they more than likely won't be in the range to draft a day 1 starter.<br />
<br />
I don't know enough about the upcoming free agent class, though I'm guessing it's less than inspiring.<br />
<br />
He gets his shot next year, he'll have every opportunity to stay above a younger player on the depth chart with his play.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>I think he gets another year </b><a name="15080108">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Oscar"> Oscar </a>  :  12/14/2020  3:47 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080108">link</a>   </div></div><div class="thread_post_body">But I would look to bring in a real backup/competitor for the starting job. <br />
<br />
If Darnold can be had for a fourth round pick or later I would bring him in for example.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: The flaws yesterday were not identical to those from the past. </b><a name="15080110">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  12/14/2020  3:48 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080110">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080080" target="_blank">15080080</a> Don in DC said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Unlike the prior 20+ games he played, he was a statute in the pocket all day due to his injury, and that was his greatest problem.  As a result he was uncomfortable in the pocket and generally ineffective.<br />
<br />
Note that he looked very good the last three games he played.  Throwing that all out the window because he played badly when injured is stupid and shitty. </td>
                                </tr>
                           </table><br />
<br />
Very good? Jones threw 1 TD pass in that stretch and the team only averaged 23 PPG. Still about 3 points below the league average.</div></div><div class="thread_post"><div class="thread_post_header"><b>The answer is Option 3 </b><a name="15080112">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Stan+in+LA"> Stan in LA </a>  :  12/14/2020  3:49 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080112">link</a>   </div></div><div class="thread_post_body">Do what the Cardinals did, trade Jones for a 2nd and pick one on the top 5 QB's coming out all of whom seem better than Jones.  Jones' negatives (bad at progressions and lack of pocket presence cannot be coached out.  Fatal flaws.  And that's not counting his turnover machine problems. <br />
<br />
He is not the answer long term</div></div><div class="thread_post"><div class="thread_post_header"><b>Ask me again when the season is over </b><a name="15080115">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=UConn4523"> UConn4523 </a>  :  12/14/2020  3:51 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080115">link</a>   </div></div><div class="thread_post_body">but I stand by the running comment I’ve made before - if he can’t run then it’s going to severely limit his upside. Hopefully this is just a short term injury and can see him move again in 2020 but moving forward that’s how we need to treat him. He’s simply a different QB when he runs 7-10x per game.</div></div><div class="thread_post"><div class="thread_post_header"><b>Option 2 is stupid </b><a name="15080116">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=pjcas18"> pjcas18 </a>  :  12/14/2020  3:51 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080116">link</a>   </div></div><div class="thread_post_body">it's only a 1st round pick, because a 2nd or 3rd round pick isn't likely replacing Jones.<br />
<br />
It can happen of course, a 6th round comp pick may go down as the best QB ever, but odds are you are not getting a franchise QB in the 2nd or 3rd round.<br />
<br />
I think it will depend on the opportunities.<br />
<br />
If the Giants have a chance to draft a QB, and it's one Judge is confident in, I think it would be a bold move to do it.<br />
<br />
I don't think they'll spend on a high priced veteran, that's a move contenders make or a move a team makes who thinks a QB will make them a contender (see the Colts).<br />
<br />
I don't think Jones is the answer.</div></div><div class="thread_post"><div class="thread_post_header"><b>give him year 3 with a healthy </b><a name="15080117">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  12/14/2020  3:52 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080117">link</a>   </div></div><div class="thread_post_body">Barkley and second year in the system. If he's still not showing signs of making a big jump, it's likely time to look at other options.</div></div><div class="thread_post"><div class="thread_post_header"><b>Option 1 </b><a name="15080118">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=PJCdude"> PJCdude </a>  :  12/14/2020  3:53 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080118">link</a>   </div></div><div class="thread_post_body">I’d give him another year with our OL matured and make my number one priority in FA and draft some weapons at WE and TE. <br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Option 2. </b><a name="15080119">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Route+9"> Route 9 </a>  :  12/14/2020  3:53 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080119">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080092" target="_blank">15080092</a> SFGFNCGiantsFan said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> At a minimum, we need a legit backup to push him. No more Colt McCoys of the world. </td>
                                </tr>
                           </table><br />
<br />
Colt McCoy walked off the field as a winner this year. Twice. He's coming for your family next.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: give him year 3 with a healthy </b><a name="15080122">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  12/14/2020  3:54 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080122">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080117" target="_blank">15080117</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Barkley and second year in the system. If he's still not showing signs of making a big jump, it's likely time to look at other options. </td>
                                </tr>
                           </table><br />
<br />
This is the second time you have mentioned Barkley today as if he's going to really ignite the things. It seems whether he plays or not, we basically win at the same rate. So what's his value?</div></div><div class="thread_post"><div class="thread_post_header"><b>Jones is hurt- it pretty obvious </b><a name="15080124">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Paulie+Walnuts"> Paulie Walnuts </a>  :  12/14/2020  3:55 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080124">link</a>   </div></div><div class="thread_post_body">the Golden Hit didnt help things<br />
<br />
He gets another season with more weapons <br />
<br />
the OL is coming together and he needs more time<br />
<br />
build the team around him and if he's not the guy, you get a short term Vet care taker and Judge gets to pick a rookie QB in 2022</div></div><div class="thread_post"><div class="thread_post_header"><b>Using a 2nd or 3rd on a QB makes no sense </b><a name="15080126">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jay+on+the+Island"> Jay on the Island </a>  :  12/14/2020  3:56 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080126">link</a>   </div></div><div class="thread_post_body">If the Giants love a QB at their pick in round 1 then they should take him.  They won’t find a QB in rounds 2 or 3 with the upside of Jones.  I think that the Giants should scout Zach Wilson and Trey Lance closely and if they see star QB in either then they can make that decision.<br />
<br />
If Jones plays well over the remainder of the season then they should give him another season to break out.  I think that they will.</div></div><div class="thread_post"><div class="thread_post_header"><b>Option 1 </b><a name="15080129">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BillKo"> BillKo </a>  :  12/14/2020  3:57 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080129">link</a>   </div></div><div class="thread_post_body">We only have six draft choices this year.....as PJ said, I'm not wasting a 2nd or 3rd that isn't going to probably play versus a guy that can instantly contribute to other areas of need.<br />
<br />
Surround Jones with more talent. <br />
<br />
Second year in the system. Full training camp with games.<br />
<br />
2021 is big for DJ and the Jints.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Option 2 </b><a name="15080131">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=M.S."> M.S. </a>  :  12/14/2020  3:58 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080131">link</a>   </div></div><div class="thread_post_body"><br />
A 5-11 team gets to draft pretty high. Try once again to find our franchise QB because we don’t have one in DaFumbler Jones.**<br />
<br />
**copywrited</div></div><div class="thread_post"><div class="thread_post_header"><b>I could be fine staying with Jones another year </b><a name="15080133">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  :  12/14/2020  3:58 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080133">link</a>   </div></div><div class="thread_post_body">and using the draft to continue to shore up the roster.<br />
<br />
But I certainly would be doing full blown assessments on all the top QBs in the event that you see something that is assuredly an upgrade to Jones and they are available when pick comes around.<br />
<br />
I would not however be solely targeting a QB or moving up to draft anybody, particularly if Gettleman is the one deciding.</div></div><div class="thread_post"><div class="thread_post_header"><b>Amazing the difference </b><a name="15080135">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+%2756"> Big Blue '56 </a>  :  12/14/2020  4:00 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080135">link</a>   </div></div><div class="thread_post_body">1 game makes</div></div><div class="thread_post"><div class="thread_post_header"><b>bw </b><a name="15080137">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  12/14/2020  4:01 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080137">link</a>   </div></div><div class="thread_post_body">i'm not understanding your point. Are you trying to say Saquon Barkley doesn't make a huge difference as to what we can do on offense, and what defenses have to prepare for?<br />
<br />
We are a significantly better offense with him as the running back. Are you actually trying to dispute this?</div></div><div class="thread_post"><div class="thread_post_header"><b>I can see it now </b><a name="15080139">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jay+on+the+Island"> Jay on the Island </a>  :  12/14/2020  4:04 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080139">link</a>   </div></div><div class="thread_post_body">The Giants draft a QB in round 1.  Jones comes to camp and wins the starting job and plays extremely well while cutting out the fumbles.  The posters who demanded that the Giants draft a QB are not blasting the Giants for drafting a QB.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Amazing the difference </b><a name="15080141">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=pjcas18"> pjcas18 </a>  :  12/14/2020  4:04 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080141">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080135" target="_blank">15080135</a> Big Blue '56 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> 1 game makes </td>
                                </tr>
                           </table><br />
<br />
Jones has had 24 starts. He seems to have regressed this year.<br />
<br />
All the things he did well last year, and I hoped he improved on have gotten worse. he latches on to his main receiver, he misses open receivers, he takes sacks after too long, he doesn't control the ball (fumbles) he makes poor decisions.<br />
<br />
this isn't 1 game making a difference it's realizing the Giants are likely picking top 10 again and very possibly DO NOT have their franchise QB on the roster.</div></div><div class="thread_post"><div class="thread_post_header"><b>Let's see what DJ can do next year with a few weapons </b><a name="15080145">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=jsuds"> jsuds </a>  :  12/14/2020  4:06 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080145">link</a>   </div></div><div class="thread_post_body">He has a pretty bare cupboard right now. And two different systems in two years.<br />
<br />
He has shown he can make all the throws. <br />
<br />
He has a lot of pressure on him being the best player on the offense. He basically has to carry the O on his back.<br />
<br />
Way too soon to write the guy off.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Amazing the difference </b><a name="15080147">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  :  12/14/2020  4:06 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080147">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080135" target="_blank">15080135</a> Big Blue '56 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> 1 game makes </td>
                                </tr>
                           </table><br />
<br />
How so...do you think the 4 game winning streak displayed a franchise QB on our hands?</div></div><div class="thread_post"><div class="thread_post_header"><b>dj </b><a name="15080148">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=leinad"> leinad </a>  :  12/14/2020  4:07 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080148">link</a>   </div></div><div class="thread_post_body">i say another year, and how about getting him some offensive weapons and ya might see an improvement in his game.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: ...... </b><a name="15080149">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+from+Katonah"> Jim from Katonah </a>  :  12/14/2020  4:07 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080149">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080086" target="_blank">15080086</a> Route 9 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Why is it too early to cut ties with Jones? The Cardinals did with their Rosen or whatever pick and then took Murray the following year. <br />
<br />
Am I missing something here? What would we be missing without Jones? Eight games this year without a touchdown throw. 600 fumbles. Help me to understand. Hopefully the smart minds of BBI can help me to get this. </td>
                                </tr>
                           </table><br />
<br />
Honored for The Fonz to weigh in!</div></div><div class="thread_post"><div class="thread_post_header"><b>and let's face facts.... </b><a name="15080151">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BillKo"> BillKo </a>  :  12/14/2020  4:08 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080151">link</a>   </div></div><div class="thread_post_body">....every NFL team puts scouts and research into ALL positions, regardless of need and their roster.<br />
<br />
If Judge seems a guy in round 1 and we are picking top 10, then sure the Giants could pull the trigger if Judge really loves someone. <br />
<br />
There is no denying that DJ is butterfingers with the football. It's improved some.....but yesterday was an unfortunate reminder.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Time to move on </b><a name="15080154">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=The+Truth"> The Truth </a>  :  12/14/2020  4:09 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080154">link</a>   </div></div><div class="thread_post_body">Trade for a QB with a prove turnover record. We don't need a great QB to play our football, we just need one that's adverse to turning the ball over. Jones is not that guy, he a turnover machine and that's only getting worse.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I can see it now </b><a name="15080156">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  :  12/14/2020  4:10 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080156">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080139" target="_blank">15080139</a> Jay on the Island said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> The Giants draft a QB in round 1.  Jones comes to camp and wins the starting job and plays extremely well while cutting out the fumbles.  The posters who demanded that the Giants draft a QB are not blasting the Giants for drafting a QB. </td>
                                </tr>
                           </table><br />
<br />
No, I don't think you can see that.  Nor do the Giants draft based on the demands of BBI posters.</div></div><div class="thread_post"><div class="thread_post_header"><b>Question is not difficult </b><a name="15080157">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Lines+of+Scrimmage"> Lines of Scrimmage </a>  :  12/14/2020  4:11 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080157">link</a>   </div></div><div class="thread_post_body">You go with  Option 2 and do what you have to in getting a QB you can win a championship with.  I don't know if that person is in the draft or not or if the Giants will be able to move to get one.  The better your team gets the harder it will be to find one.<br />
<br />
Not sure surrounding Jones with a very good defense, good Ol and weapons will get the Giants through the playoff gauntlet.  At some point I feel he will get exposed when he is most needed.  Hope I am wrong if they continue with him.  This is why it is so hard to win championships in this league.<br />
<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I can see it now </b><a name="15080159">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BillKo"> BillKo </a>  :  12/14/2020  4:11 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080159">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080139" target="_blank">15080139</a> Jay on the Island said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> The Giants draft a QB in round 1.  Jones comes to camp and wins the starting job and plays extremely well while cutting out the fumbles.  The posters who demanded that the Giants draft a QB are not blasting the Giants for drafting a QB. </td>
                                </tr>
                           </table><br />
<br />
Actually the way it works is they root against DJ insistently. <br />
<br />
As George Young said, the backup QB is the most popular in town.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Seriously? </b><a name="15080161">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=joe48"> joe48 </a>  :  12/14/2020  4:11 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080161">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080073" target="_blank">15080073</a> Gatorade Dunk said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15080056 Don in DC said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Kid comes out to play while gutting it out through an injury and this is the thanks he gets?<br />
So if Murray played on one leg yesterday how effective would he have been?<br />
Ridiculous. <br />
                                <br />
                           <br />
That's a fair point, and it would be even more valid if the flaws we saw yesterday weren't identical to the ones we've seen from him throughout his short career.<br />
<br />
Are you suggesting that he needs to be at/near 100% physically to not make dumb mental errors?  Because if that's the case, it's not nearly as strong a defense as you think - there are going to be a lot of times over the course of an NFL career that a starting QB is going to be out there at less than 100%.  If gutting out an injury means DJ is considerably more likely to play like shit, that's a pretty significant issue in and of itself.<br />
<br />
I don't think one game alone should signal the death knell for DJ, but I also don't think it's helpful to pretend like it wasn't consistent with what we know his weaknesses to be even when he's healthy. </td>
                                </tr>
                           </table></div></div><div class="thread_post"><div class="thread_post_header"><b>He’s not the guy </b><a name="15080162">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=trueblueinpw"> trueblueinpw </a>  :  12/14/2020  4:13 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080162">link</a>   </div></div><div class="thread_post_body">Option two. Hope I’m wrong, there’s still time for this guy to become something he’s never been. But, it’s far enough down the road that we should be seeing things as they are and not as we would like them to be. By any objective metric, he’s not the guy.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Seriously? </b><a name="15080165">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=joe48"> joe48 </a>  :  12/14/2020  4:16 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080165">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080073" target="_blank">15080073</a> Gatorade Dunk said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15080056 Don in DC said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Kid comes out to play while gutting it out through an injury and this is the thanks he gets?<br />
So if Murray played on one leg yesterday how effective would he have been?<br />
Ridiculous. <br />
                                <br />
                           <br />
That's a fair point, and it would be even more valid if the flaws we saw yesterday weren't identical to the ones we've seen from him throughout his short career.<br />
<br />
Are you suggesting that he needs to be at/near 100% physically to not make dumb mental errors?  Because if that's the case, it's not nearly as strong a defense as you think - there are going to be a lot of times over the course of an NFL career that a starting QB is going to be out there at less than 100%.  If gutting out an injury means DJ is considerably more likely to play like shit, that's a pretty significant issue in and of itself.<br />
<br />
I don't think one game alone should signal the death knell for DJ, but I also don't think it's helpful to pretend like it wasn't consistent with what we know his weaknesses to be even when he's healthy. </td>
                                </tr>
                           </table></div></div><div class="thread_post"><div class="thread_post_header"><b>Option 1 obviously  </b><a name="15080166">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Saquads26"> Saquads26 </a>  :  12/14/2020  4:16 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080166">link</a>   </div></div><div class="thread_post_body">Option 2 is not an option</div></div><div class="thread_post"><div class="thread_post_header"><b>and as far as the injury........ </b><a name="15080168">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BillKo"> BillKo </a>  :  12/14/2020  4:17 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080168">link</a>   </div></div><div class="thread_post_body">.......do some of "old timers" remember Phil Simms trotting out there with a bad wheel in 1989 and having his game compromised?<br />
<br />
He pratically gifted a game to Philly at Giants Stadium that year.<br />
<br />
It's part of the deal unfortunately.<br />
<br />
Jones never has probably played injured. I hope it registers as a learning experience.</div></div><div class="thread_post"><div class="thread_post_header"><b>Got this text from a friend at 4:01 p.m. yesteday: </b><a name="15080170">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Beezer"> Beezer </a>  :  12/14/2020  4:18 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080170">link</a>   </div></div><div class="thread_post_body"><br />
"Regardless of health, Daniel Jones just isn't good. No way you can actually make a case he is."<br />
<br />
Can't decide which is more ridiculous and knee-jerk. The text of this thread.<br />
<br />
Of course you stick with #8.</div></div><div class="thread_post"><div class="thread_post_header"><b>This is the wrong time to be having this discussion </b><a name="15080171">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BigBlueNH"> BigBlueNH </a>  :  12/14/2020  4:20 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080171">link</a>   </div></div><div class="thread_post_body">after a game where he performed poorly and was clearly hurt.  He has played well enough at times.  He is in his 2nd year, his first in this offense.  And he has no playmakers (with Slayton also playing injured).  I absolutely want to see what he can do next season, when healthy and with a better cast of skill-position players.  We will be in a MUCH better position to evaluate him then.  Thus, I wouldn't draft a QB this year before the 3rd round.</div></div><div class="thread_post"><div class="thread_post_header"><b>*** or this thread. </b><a name="15080173">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Beezer"> Beezer </a>  :  12/14/2020  4:20 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080173">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Amazing the difference </b><a name="15080174">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+from+Katonah"> Jim from Katonah </a>  :  12/14/2020  4:20 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080174">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080147" target="_blank">15080147</a> LBH15 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15080135 Big Blue '56 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     1 game makes <br />
                                <br />
                           <br />
<br />
How so...do you think the 4 game winning streak displayed a franchise QB on our hands? </td>
                                </tr>
                           </table><br />
<br />
(Plus, he only won 3 ... he missed the biggest win the past 4 years plus).</div></div><div class="thread_post"><div class="thread_post_header"><b>Going with Option C </b><a name="15080175">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ghost718"> ghost718 </a>  :  12/14/2020  4:21 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080175">link</a>   </div></div><div class="thread_post_body">Pay off Sam The Sheepdog and let the Wolves do the rest</div></div><div class="thread_post"><div class="thread_post_header"><b>the best course of action is to stop these types of threads </b><a name="15080180">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Victor+in+CT"> Victor in CT </a>  :  12/14/2020  4:24 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080180">link</a>   </div></div><div class="thread_post_body">after every game and just see how he develops. He's not going anywhere for at least another year. And hopefully much more, because that would mean that he worked out and they have their QB.</div></div><div class="thread_post"><div class="thread_post_header"><b>Do not know who screwed up on Markus Golden turnover sack, may be DJ </b><a name="15080183">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Bob+in+Newburgh"> Bob in Newburgh </a>  :  12/14/2020  4:25 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080183">link</a>   </div></div><div class="thread_post_body">I do know that more than half the QBs in the League fumble on that play once it was set in motion.</div></div><div class="thread_post"><div class="thread_post_header"><b>Injury or not </b><a name="15080185">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=crackerjack465"> crackerjack465 </a>  :  12/14/2020  4:28 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080185">link</a>   </div></div><div class="thread_post_body">I just don't think he sees the field very well, regardless of the turnovers.<br />
<br />
Fields and Lawrence are the prizes, but Trey Lance is not a bad consolation prize. He is a legit player.</div></div><div class="thread_post"><div class="thread_post_header"><b>I am too disappointed in the overall team performance from yesterday </b><a name="15080186">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Giants61"> Giants61 </a>  :  12/14/2020  4:29 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080186">link</a>   </div></div><div class="thread_post_body">including coaching to decide on one specific player at this time.  Maybe shut him down until his leg is 100% even it's for the season.  Gun to my head though build around him</div></div><div class="thread_post"><div class="thread_post_header"><b>This is an end of the season thread </b><a name="15080188">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=AnnapolisMike"> AnnapolisMike </a>  :  12/14/2020  4:30 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080188">link</a>   </div></div><div class="thread_post_body">big difference between 5-11 and 8-8....and points in between.  Bad game yesterday.  7 or 8 wins is there really a question?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Ask me again when the season is over </b><a name="15080191">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ColHowPepper"> ColHowPepper </a>  :  12/14/2020  4:33 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080191">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080115" target="_blank">15080115</a> UConn4523 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> but I stand by the running comment I’ve made before - if he can’t run then it’s going to severely limit his upside. Hopefully this is just a short term injury and can see him move again in 2020 but moving forward that’s how we need to treat him. He’s simply a different QB when he runs 7-10x per game. </td>
                                </tr>
                           </table>Issue I have with your comment is the same I have with bw in dc's comment <table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">If Jones finishes these last three games strong and steers the team into the playoffs, then the conversation needs to be revisited.</td>
                                </tr>
                           </table>And that is, imo, I think there is a very good chance Jones does not, cannot, play even 50% of remaining snaps on offense for rest of the season. I think his hammy is cooked, certainly not healed 100% (kanavis' good comment yesterday: no designed runs or rollouts demonstrated that JG and JJ knew he was not fit).<br />
<br />
I have to say, as with many others, yesterday shook my belief and yet it was a fallacious test of Jones: he still has no receivers, but the bust on the Golden sack, where it seems Jones has to have some accountability: wtf--did all those linemen and Gallman muff their assignments?<br />
<br />
There was a telling comment by CCollinsworth last night: last year, Allen's completion % was worst in the league (if I heard it right): Buffalo traded for Diggs and now he's at #3 (cue: the Kinks: Top of the Pops).<br />
<br />
So, I will opt for option 1</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Got this text from a friend at 4:01 p.m. yesteday: </b><a name="15080197">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Route+9"> Route 9 </a>  :  12/14/2020  4:36 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080197">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080170" target="_blank">15080170</a> Beezer said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br />
"Regardless of health, Daniel Jones just isn't good. No way you can actually make a case he is."<br />
<br />
Can't decide which is more ridiculous and knee-jerk. The text of this thread.<br />
<br />
Of course you stick with #8. </td>
                                </tr>
                           </table><br />
<br />
Because you got a text? That is evidence why you stick with a QB? <br />
<br />
Also. How is it knee-jerk? He hasn't been good prior to this Arizona game.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Do not know who screwed up on Markus Golden turnover sack, may be DJ </b><a name="15080199">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+in+Tampa"> Jim in Tampa </a>  :  12/14/2020  4:37 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080199">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080183" target="_blank">15080183</a> Bob in Newburgh said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I do know that more than half the QBs in the League fumble on that play once it was set in motion. </td>
                                </tr>
                           </table><br />
What about his other two fumbles yesterday?<br />
<br />
As pointed out earlier in this thread...28 fumbles in 24 career games for Jones, 2nd all time for a QB since '66.</div></div><div class="thread_post"><div class="thread_post_header"><b>the frustrating thing is he looked better in shurmur's </b><a name="15080201">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=japanhead"> japanhead </a>  :  12/14/2020  4:39 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080201">link</a>   </div></div><div class="thread_post_body">offense his rookie year, despite the horrible fumbling problem, which he looked to have gotten under control before the cardinals game. <br />
<br />
in 2020 in garrett's offense he's looked incredibly shaky. the offense yesterday was barely functional. it's hard to say if the problem is garrett, jones, or both, but he definitely didn't look this marginal last year. he looked like a promising player that needed to fix his fumbling problem.<br />
<br />
not sure what to make of him at this point but he's been a bottom 5 quarterback this year, maybe worse than that.<br />
<br />
some argue that the same was said about eli until 2007 but i remember feeling confident that eli was the guy as early as late 2004, and was convinced by 2005 after the san diego game</div></div><div class="thread_post"><div class="thread_post_header"><b>Eli will be fine </b><a name="15080202">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=kes722"> kes722 </a>  :  12/14/2020  4:40 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080202">link</a>   </div></div><div class="thread_post_body">...Jones, I ment Jones.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Do not know who screwed up on Markus Golden turnover sack, may be DJ </b><a name="15080203">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BillKo"> BillKo </a>  :  12/14/2020  4:41 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080203">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080199" target="_blank">15080199</a> Jim in Tampa said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15080183 Bob in Newburgh said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     I do know that more than half the QBs in the League fumble on that play once it was set in motion. <br />
                                <br />
                           <br />
What about his other two fumbles yesterday?<br />
<br />
As pointed out earlier in this thread...28 fumbles in 24 career games for Jones, 2nd all time for a QB since '66. </td>
                                </tr>
                           </table><br />
<br />
who is first?</div></div><div class="thread_post"><div class="thread_post_header"><b>You can make all the excuses </b><a name="15080205">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=pjcas18"> pjcas18 </a>  :  12/14/2020  4:42 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080205">link</a>   </div></div><div class="thread_post_body">in the world, no QB has a perfect situation with a great OL, pro-bowlers at the skill positions, a good defense, a consistent system and coaching situation, health, etc.<br />
<br />
After being *just* his second year it will be *just* his 3rd year, and I feel like the Giants will still be in this situation.<br />
<br />
at some point it takes more guts to pull the plug then to give it another year.<br />
<br />
I think Judge can't be happy about the turnovers.<br />
<br />
So, IMO if Judge has more influence over personnel and Judge is anything like Belichick they'll be looking for a QB.  Turnovers are a major tenet to the Belichick philosophy.</div></div><div class="thread_post"><div class="thread_post_header"><b>I think context is always important </b><a name="15080208">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Chris684"> Chris684 </a>  :  12/14/2020  4:44 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080208">link</a>   </div></div><div class="thread_post_body">This team was built around Jones and Barkley.<br />
<br />
That's a combination that as of the day Jones got his first start, hasn't consistently been able to stay on the field together. Barkley's high ankle sprain and Jones's late season injury last year and then of course Saquon going down in week 2 2020. The Giants lack offensive playmakers. The fact that we have to hang our hats on the likes of Evan Engram says a lot.<br />
<br />
I love the way Jones runs and he's a fine thrower. His problem is in his progressions, ball security and overall pocket awareness. The latter is holding back the former to some degree.<br />
<br />
As of right now put me in the camp of, Jones has showed me enough good that I'm willing to start 2021 with him, but he's also shown me enough bad that I'm going to have more than just Colt McCoy behind him. I'd have no problem taking a QB through the draft similar to the Eagles taking Hurts this year.</div></div><div class="thread_post"><div class="thread_post_header"><b>according to Sy, </b><a name="15080209">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=fkap"> fkap </a>  :  12/14/2020  4:45 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080209">link</a>   </div></div><div class="thread_post_body">his read and decision making are slow.  Perhaps with time, the game will slow down and he'll be ok in that department.  Perhaps not.<br />
<br />
He has the physical attributes, but IF he needs his running ability to be successful, he doesn't have enough of the mental "IT" factor.<br />
<br />
No need to panic.  If a good prospect falls in our laps, take him.  I doubt the answer is in FA.  It's not that often that castoffs from other teams become the answer.  If you spend big bucks here, it's going to be for a starter.  IF luck tosses a vet starter our way, take him.<br />
<br />
Don't spend too much on a backup.  Maybe upgrade Colt, or maybe just ride it out.  If next year is make or break for DJ, the season will be lost by the time his shot is over, and a decent backup isn't going to save the year.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: You can make all the excuses </b><a name="15080210">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Route+9"> Route 9 </a>  :  12/14/2020  4:45 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080210">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080205" target="_blank">15080205</a> pjcas18 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br />
<br />
After being *just* his second year it will be *just* his 3rd year, and I feel like the Giants will still be in this situation. </td>
                                </tr>
                           </table><br />
<br />
This has been the endless present on BBI for the past eight or nine years. It's not just in connection with Jones failures.</div></div><div class="thread_post"><div class="thread_post_header"><b>Stay the course.  </b><a name="15080211">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Red+Dog"> Red Dog </a>  :  12/14/2020  4:46 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080211">link</a>   </div></div><div class="thread_post_body">They have committed big resources to Jones. Don't throw him away prematurely. He was showing some genuine improvement this season before being trotted out there to play hurt this week. He needs another season of starting to make a final determination. <br />
<br />
Instead, build the team around him. Finish the OL rebuild that is now underway. Get him some WRs that can scare opponents. A couple of TEs that can really block and make a few underneath catches would help, too. So would a back who can really pass protect. <br />
<br />
Drafting another QB this spring will just delay the team's recovery at least two or three more years with no guarantee that the guy is even as good as Jones, let alone any better. <br />
<br />
And George in PA is very right when he says get a better back up. <br />
<br />
As for Route 9's question about why the Cards dumped Rosen, he's garbage, always has been garbage, and they didn't see it until he was in their locker room. No comparison.</div></div><div class="thread_post"><div class="thread_post_header"><b>I've been a DJ fan since they called his name in Nashville </b><a name="15080220">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=kelsto811"> kelsto811 </a>  :  12/14/2020  4:53 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080220">link</a>   </div></div><div class="thread_post_body">and I still am a fan of what he can bring to the table. That said, I am a realist and I'm definitely getting more and more worried with a few things I thought he would fix but hasn't..<br />
<br />
- Ball security (the obvious one)<br />
<br />
- Locking on targets (a few plays he surveys the field like he is supposed to and then a few plays later he just reverts back to locking on. Is it the offense? Maybe sometimes but not every time...)<br />
<br />
- Identifying blitzers/blitz pick up (I may be overreacting but I feel DJ overlooks blitzers A LOT, many times he is unaware there is even a blitzer coming let alone from where) <br />
<br />
Pre-snap reads (DJ is the first in last out type based on all reporting, yet it still seems that extra film time is having little impact on his pre-snap reads and/or is progressing really slowly...or Garret and co are limiting DJ in this role for whatever reason...)<br />
<br />
- Pocket Awareness - there's times I honestly just don't understand how his eyes can possibly miss some of the pass rushers he misses. He continues to struggle feeling pressure...at times it seems him focusing downfield, completely negates his peripheral vision<br />
<br />
<br />
Obviously I don't always say or know the proper football terms. Just a fan who isn't qualified to officially critique anyone, but those are my thoughts. So yea, a little concerned about DJ but also want to point out the entire offense (team) Sunday was atrocious: <br />
<br />
QB: Below Average<br />
RB: Below Average<br />
WR: No Seperation<br />
TE: Non Existent<br />
OL: Below Average</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Do not know who screwed up on Markus Golden turnover sack, may be DJ </b><a name="15080222">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Route+9"> Route 9 </a>  :  12/14/2020  4:54 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080222">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080199" target="_blank">15080199</a> Jim in Tampa said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> As pointed out earlier in this thread...28 fumbles in 24 career games for Jones, 2nd all time for a QB since '66. </td>
                                </tr>
                           </table><br />
<br />
And what's this then? Not garbage? Or because we're Giant fans, we're not allowed to be as candid with our vocabulary?</div></div><div class="thread_post"><div class="thread_post_header"><b>Next year is Jones </b><a name="15080225">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=pjcas18"> pjcas18 </a>  :  12/14/2020  4:56 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080225">link</a>   </div></div><div class="thread_post_body">3rd year, and after it he will be 3/4 of the way through his contract (sans the 5th year option).<br />
<br />
With the new (not so new anymore) CBA and rookie wage scale, the Giants actually have NOT committed massive resources to Jones - other than the draft pick which is obviously big, but that's a sunk cost.<br />
<br />
Consider this is 2020 and Jones contract is for 4 years $25M.<br />
<br />
In 2010 Cam Newton, the first QB to sign a contract under the new CBA signed for 4 years $22M.<br />
<br />
The one before Cam, the last one on the old CBA? Sam Bradford, he signed a 6 year 78M contract (50M guaranteed).<br />
<br />
draft picks should no longer be on scholarship like the old days, the investment (in $$$ terms) should not limit teams maneuverability in any way.</div></div><div class="thread_post"><div class="thread_post_header"><b>Considering a lot of factors </b><a name="15080229">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Rudy5757"> Rudy5757 </a>  :  12/14/2020  4:58 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080229">link</a>   </div></div><div class="thread_post_body">you cant give up on him yet.<br />
<br />
New Coach<br />
The whole Covid schedule<br />
<br />
Its like starting over.  He needs a regular offseason and practice with this staff.  next season is the telling season.  If he bombs then you have to start to look.  Also get the kid some receivers, we do not have any and Engram is not helping his INT rate.</div></div><div class="thread_post"><div class="thread_post_header"><b>Seems like a pretty even split so far ... </b><a name="15080230">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+from+Katonah"> Jim from Katonah </a>  :  12/14/2020  4:59 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080230">link</a>   </div></div><div class="thread_post_body">... which seems reasonable b/c while his record is atrocious (7-17 with 37 turnovers, poor YPA), he’s also been working within a poor team framework. Doesn’t seem like a no-brainer either way.  Hoping Judge gets the final say and the decision isn’t made on the basis of sunk costs.</div></div><div class="thread_post"><div class="thread_post_header"><b>Mitch Trubisky’s stats compare favorably to Jones through 2 years  </b><a name="15080240">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+from+Katonah"> Jim from Katonah </a>  :  12/14/2020  5:08 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080240">link</a>   </div></div><div class="thread_post_body">... a much better W/L record. The Bears were faced with a similar situation going into year 3, and man, they are in a helluva bad place now ... with huge $ tied up in a lot of mediocrity.  I’m not sure of the lesson you can draw from that, other than ... it’s brutal to miss on your first round QB.</div></div><div class="thread_post"><div class="thread_post_header"><b>Ha.  </b><a name="15080241">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Route+9"> Route 9 </a>  :  12/14/2020  5:08 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080241">link</a>   </div></div><div class="thread_post_body">Kind of nice to see Engram getting ripped apart when he's not the main topic of discussion. <br />
<br />
Did he play yesterday?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: You can make all the excuses </b><a name="15080244">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jay+on+the+Island"> Jay on the Island </a>  :  12/14/2020  5:08 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080244">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080205" target="_blank">15080205</a> pjcas18 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br />
I think Judge can't be happy about the turnovers.<br />
<br />
So, IMO if Judge has more influence over personnel and Judge is anything like Belichick they'll be looking for a QB.  Turnovers are a major tenet to the Belichick philosophy. </td>
                                </tr>
                           </table><br />
This is what it will come down to IMO.  If Judge tells Gettleman or the new GM that Jones’ turnovers are too big of a concern then they will scout very closely.  <br />
<br />
I don’t know what happened but Jones just looks far more hesitant and uncomfortable in the pocket than he did last season.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: You can make all the excuses </b><a name="15080248">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+from+Katonah"> Jim from Katonah </a>  :  12/14/2020  5:12 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080248">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080244" target="_blank">15080244</a> Jay on the Island said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15080205 pjcas18 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     <br />
I think Judge can't be happy about the turnovers.<br />
<br />
So, IMO if Judge has more influence over personnel and Judge is anything like Belichick they'll be looking for a QB.  Turnovers are a major tenet to the Belichick philosophy. <br />
                                <br />
                           <br />
This is what it will come down to IMO.  If Judge tells Gettleman or the new GM that Jones’ turnovers are too big of a concern then they will scout very closely.  <br />
<br />
I don’t know what happened but Jones just looks far more hesitant and uncomfortable in the pocket than he did last season. </td>
                                </tr>
                           </table><br />
<br />
Jones has taken some hellacious hits in his first 2 years. They gotta add up.  Maybe that’s the root cause for Wentz’s decline too.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Mitch Trubisky’s stats compare favorably to Jones through 2 years  </b><a name="15080249">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=pjcas18"> pjcas18 </a>  :  12/14/2020  5:12 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080249">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080240" target="_blank">15080240</a> Jim from Katonah said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> ... a much better W/L record. The Bears were faced with a similar situation going into year 3, and man, they are in a helluva bad place now ... with huge $ tied up in a lot of mediocrity.  I’m not sure of the lesson you can draw from that, other than ... it’s brutal to miss on your first round QB. </td>
                                </tr>
                           </table><br />
<br />
It doesn't have to be brutal. Was it brutal for Arizona?<br />
<br />
It becomes more brutal as you bypass opportunities to fix it, but don't.</div></div><div class="thread_post"><div class="thread_post_header"><b>Jones was improving until .. </b><a name="15080258">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=morrison40"> morrison40 </a>  :  12/14/2020  5:17 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080258">link</a>   </div></div><div class="thread_post_body">His hamstring injury, until that heals the team will be competing with a less effective QB, making these next 2 games very tough to win. In 2021 a better younger backup will be needed. Preferably someone with enough potential to push Jones .</div></div><div class="thread_post"><div class="thread_post_header"><b>he's a kid, scare him </b><a name="15080263">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=gtt350"> gtt350 </a>  :  12/14/2020  5:22 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080263">link</a>   </div></div><div class="thread_post_body">Jones will be fine</div></div><div class="thread_post"><div class="thread_post_header"><b>Jones has proven nothing </b><a name="15080264">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Giant4Life"> Giant4Life </a>  :  12/14/2020  5:24 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080264">link</a>   </div></div><div class="thread_post_body">And doesn't deserve the benefit of the doubt.  If a QB is there in Rd 1 or 2 that I had a high conviction about, I'd take him and let them fight it out in training camp and let the best man win.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: bw </b><a name="15080265">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  12/14/2020  5:24 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080265">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080137" target="_blank">15080137</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> i'm not understanding your point. Are you trying to say Saquon Barkley doesn't make a huge difference as to what we can do on offense, and what defenses have to prepare for?<br />
<br />
We are a significantly better offense with him as the running back. Are you actually trying to dispute this? </td>
                                </tr>
                           </table><br />
<br />
This year we are averaging about 2+ point less without Barkley. But we have more wins this year already than last year.<br />
<br />
Further, last year we averaged 105 yards/game rushing with SB. This year? 116.5.<br />
<br />
I totally agree that Barkley is dynamic and fun, especially when he jumps over defenders. But his presence on the field hasn't led to more Ws. <br />
<br />
I'm all ears as to what I'm missing...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Mitch Trubisky’s stats compare favorably to Jones through 2 years  </b><a name="15080268">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  12/14/2020  5:28 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080268">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080249" target="_blank">15080249</a> pjcas18 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15080240 Jim from Katonah said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     ... a much better W/L record. The Bears were faced with a similar situation going into year 3, and man, they are in a helluva bad place now ... with huge $ tied up in a lot of mediocrity.  I’m not sure of the lesson you can draw from that, other than ... it’s brutal to miss on your first round QB. <br />
                                <br />
                           <br />
<br />
It doesn't have to be brutal. Was it brutal for Arizona?<br />
<br />
It becomes more brutal as you bypass opportunities to fix it, but don't. </td>
                                </tr>
                           </table><br />
<br />
Exactly. It's only brutal of you say ridiculous things like "We have to give the kid another year". No we don't. <br />
<br />
Winners aren't finding ways to carry players as passengers. It's on the player to kick the door down and make it impossible for the team to ignore or replace him. <br />
<br />
Stop making excuses, and stop giving the benefit of the doubt. Jones has had over 20 starts to kick the door down and make us stick with him. He hasn't done it.</div></div><div class="thread_post"><div class="thread_post_header"><b>I like Jones. He is our QB. </b><a name="15080278">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Giant+John"> Giant John </a>  :  12/14/2020  5:36 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080278">link</a>   </div></div><div class="thread_post_body">But he is not Eli. I’d draft a backup that could put some pressure on DJ and have a guy that can nove the chains if DJ gets injured again.</div></div><div class="thread_post"><div class="thread_post_header"><b>Jones doesn't seem like a great Joe Judge fit </b><a name="15080281">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=MeanBunny"> MeanBunny </a>  :  12/14/2020  5:38 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080281">link</a>   </div></div><div class="thread_post_body">Jones did better under Shurmer, but that offense was more pass oriented and higher risk(with the obvious consequences of Jones getting more picked off.) I think Judge and Garrett have made the offense a lot more controlled(less risk) but that has led to more losses late and low points. Judge is about being smart, being a quick learn, being flexible. Jones is kind of Dumb, slow on the draw and keeps making the same mistakes. I was shocked when McCoy didn't make his second start...because in DRIVING RAIN, the big bombs and Dimes are harder to catch and throw. So run game is key and checkdowns (Jones missed a lot of short yardage opens.) One thing about Colt-he saw the coverage fine, he was just skittish and rusty. And his delivery was much faster after snap. Shurmer was running a lot of West Coast stuff with lots of mid coverage passes plus Jones was running. Now its hand offs, Jones running or low % passes to meh receivers.</div></div><div class="thread_post"><div class="thread_post_header"><b>Option 1. </b><a name="15080286">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=AcidTest"> AcidTest </a>  :  12/14/2020  5:40 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080286">link</a>   </div></div><div class="thread_post_body">I agree we need to wait until the end of the year, but Jones is hindered by a lack of offensive weapons. So much of our offense is his ability to run, which has been temporarily eliminated by the hamstring injury. A healthy Barkley will also help.</div></div><div class="thread_post"><div class="thread_post_header"><b>_________ </b><a name="15080292">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=I+am+Ninja"> I am Ninja </a>  :  12/14/2020  5:45 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080292">link</a>   </div></div><div class="thread_post_body">You draft a QB from Duke, you get a QB from Duke.</div></div><div class="thread_post"><div class="thread_post_header"><b>Jones has had </b><a name="15080293">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=pjcas18"> pjcas18 </a>  :  12/14/2020  5:46 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080293">link</a>   </div></div><div class="thread_post_body">one start out of 24 starts with a hamstring issue, and the coaches and medical staff say he was fine (or at least medically cleared to play).<br />
<br />
but some fans think that's the reason he's struggled.<br />
<br />
If that doesn't reek of excuse making, not sure what does.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: Do not know who screwed up on Markus Golden turnover sack, may be DJ </b><a name="15080294">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+in+Tampa"> Jim in Tampa </a>  :  12/14/2020  5:46 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080294">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080203" target="_blank">15080203</a> BillKo said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15080199 Jim in Tampa said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     In comment 15080183 Bob in Newburgh said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     I do know that more than half the QBs in the League fumble on that play once it was set in motion. <br />
                                <br />
                           <br />
What about his other two fumbles yesterday?<br />
<br />
As pointed out earlier in this thread...28 fumbles in 24 career games for Jones, 2nd all time for a QB since '66. <br />
                                <br />
                           <br />
<br />
who is first? </td>
                                </tr>
                           </table><br />
Apparently, Tony Banks (Rams).  It was mentioned either on this thread or one of the 10 other Daniel Jones threads.</div></div><div class="thread_post"><div class="thread_post_header"><b>Option 1 without question </b><a name="15080298">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Scuzzlebutt"> Scuzzlebutt </a>  :  12/14/2020  5:51 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080298">link</a>   </div></div><div class="thread_post_body">3rd new offense in 3 years.  Bad OL play and limited weapons for most of his career so far.  He has talent, he is smart, he is tough... give him a chance to get comfortable in the offense, reduce the turnovers (which he was doing before yesterday), and give him some weapons to work with.<br />
<br />
We spent a 6th overall and he has flashed.  He needs another year before we make any rash decisions.</div></div><div class="thread_post"><div class="thread_post_header"><b>Option 1 without a doubt </b><a name="15080301">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=PatersonPlank"> PatersonPlank </a>  :  12/14/2020  5:56 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080301">link</a>   </div></div><div class="thread_post_body">He's shown enough in 2 seasons to warrant a 3rd for sure</div></div><div class="thread_post"><div class="thread_post_header"><b>Commit to Jones </b><a name="15080329">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Vanzetti"> Vanzetti </a>  :  12/14/2020  6:19 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080329">link</a>   </div></div><div class="thread_post_body">Judge should never have played him Sunday. It was obvious from the get-go his mobility was limited and the Cardinals defensive front is filled with speed rushers.<br />
<br />
Just a really bad decision by Judge</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Commit to Jones </b><a name="15080331">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sean"> Sean </a>  :  12/14/2020  6:22 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080331">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080329" target="_blank">15080329</a> Vanzetti said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Judge should never have played him Sunday. It was obvious from the get-go his mobility was limited and the Cardinals defensive front is filled with speed rushers.<br />
<br />
Just a really bad decision by Judge </td>
                                </tr>
                           </table><br />
<br />
I disagree. They felt Jones was healthy enough to defend himself in the pocket and make plays, but he didn’t. I side with Judge here.</div></div><div class="thread_post"><div class="thread_post_header"><b>Agreed Sean </b><a name="15080333">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  :  12/14/2020  6:25 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080333">link</a>   </div></div><div class="thread_post_body">Armchair coaches out in full force today with this "playing Jones" decision.<br />
<br />
A 5-8 team that just lost 26-7 and the issue was the coach should have played his backup QB?  Haha.</div></div><div class="thread_post"><div class="thread_post_header"><b>not even 2 seasons in  </b><a name="15080337">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Rory"> Rory </a>  :  12/14/2020  6:26 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080337">link</a>   </div></div><div class="thread_post_body">the NFL, learning a new offense during covid period, young offensive line and not a true #1 WR. <br />
<br />
If you think none of that matters and still think he needs to be replaced then feel free to go root for another team. <br />
<br />
K thanks.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Commit to Jones </b><a name="15080347">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+from+Katonah"> Jim from Katonah </a>  :  12/14/2020  6:35 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080347">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080331" target="_blank">15080331</a> Sean said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15080329 Vanzetti said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Judge should never have played him Sunday. It was obvious from the get-go his mobility was limited and the Cardinals defensive front is filled with speed rushers.<br />
<br />
Just a really bad decision by Judge <br />
                                <br />
                           <br />
<br />
I disagree. They felt Jones was healthy enough to defend himself in the pocket and make plays, but he didn’t. I side with Judge here. </td>
                                </tr>
                           </table><br />
<br />
Franchise QBs are blessed with a rare natural instinct to see and feel pressure. Jones repeatedly shows he doesn’t have it.  It sets him up for a vicious cycle of injury and turnovers.  Maybe the staff can gerryrig an offense that will work around this deficiency, and Saquon (and a true WR1 like Allen has with Diggs) can take the pressure off — but it looks like a tough road ahead. <br />
<br />
P.S. the reason why there are so many DJ threads is his viability as an eventual playoff caliber QB is THE existential question for this franchise.</div></div><div class="thread_post"><div class="thread_post_header"><b>i love polls, especially when the pollster doesn’t ask a question that </b><a name="15080362">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=plato"> plato </a>  :  12/14/2020  6:50 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080362">link</a>   </div></div><div class="thread_post_body">can be reflected in a poll, and better yet where those polls are as a group inexperienced, untrained in, and without education at the level  which the subject requires.</div></div><div class="thread_post"><div class="thread_post_header"><b>Daniel Jones </b><a name="15080367">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Producer"> Producer </a>  :  12/14/2020  6:54 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080367">link</a>   </div></div><div class="thread_post_body">is not a good NFL QB. In 2020 he is:<br />
<br />
32nd in QB rating<br />
31st in comp pct<br />
18th in QBR<br />
30th in Y/A<br />
30th in Adjusted Y/A<br />
28th in Y/C<br />
26th in Y/G<br />
31st in Net yds/A<br />
32nd in TD %<br />
<br />
He's basically in the bottom 5 or 10 of starting QBs in the league. He is behind Foles, Trubisky, Minshew, Wentz,  Mullens in most of these metrics. What distinguishes this group of QBs? They are all terrible or subpar starting QBs in the NFL. Jones is worse than them. <br />
<br />
If you think Jones is "THE GUY", just know the numbers don't support you. Somebody last week wrote Jones was obviously a top-10 QB for the next ten years. That is an astounding statement. I think he only watched the Giants. <br />
<br />
Of course there is a small chance he can turn it around, but it is highly improbable. I don't know where the Giants should turn next, but his play has been awful and if you think Coach Judge doesn't know it, you are deluding yourself. <br />
<br />
Daniel Jones -- nice kid -- not an NFL QB.</div></div><div class="thread_post"><div class="thread_post_header"><b>While he's not obviously a top ten QB right now.. </b><a name="15080430">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=RAIN"> RAIN </a>  :  12/14/2020  7:33 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080430">link</a>   </div></div><div class="thread_post_body">Ignoring context is sure way to get things wrong.<br />
<br />
I really like what he has shown, but he's been thrown to the wolves. It will serve him long term, getting through the adversity. But what I see is a guy, in his second professional season, with a struggling o-line (most of the year, including yesterday), with receivers not running open. He's throwing some of them open. Whether it be scheme or talent, I haven't seen a whole lot of folks with separation. <br />
<br />
He needs to hold that ball, I will give the naysayers that. But aside from that, I don't see reason to cut bait now. I just hope he is not battered, as he's taken a beating over the past two years from rushers coming untouched. <br />
<br />
Eli had Tiki, Shockey, Toomer, and foundation to work with. Ignoring these things and giving up on DJ at this point, is not wise.<br />
<br />
If we had a shot at Lawrence, I'd say you have an option and fall back position to replace him with better quality. That would be a legit recourse. Reality states, we would have to lose to get a shot at any of Lance or Wilson. <br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>This is what I see....... </b><a name="15080439">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=OX100"> OX100 </a>  :  12/14/2020  7:39 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080439">link</a>   </div></div><div class="thread_post_body">a couple times every game. Jones completely clueless a rusher is right on top of him. He's actually getting ball stolen right out of his hands here, but still looking downfield.  <br />
<br />
<img src="http://luxjo.supermotors.net/FOOTBALL/jones%20jets.jpg">	<br />
<br />
<a href="https://www.youtube.com/watch?v=2PSiP3epjIs" target="_blank">https://www.youtube.com/watch?v=2PSiP3epjIs</a><br /></div></div><div class="thread_post"><div class="thread_post_header"><b>I think he’ll get another year to prove himself..... </b><a name="15080444">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Simms11"> Simms11 </a>  :  12/14/2020  7:43 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080444">link</a>   </div></div><div class="thread_post_body">He’s been hampered by a poor offensive situation; inexperienced Oline, WRs that can’t separate, new offensive scheme, TE that catches like 50% of the balls thrown and ends up turning the ball over when he does. It’s like the perfect storm this year in terms of offensive ineptitude. <br />
<br />
Option 1 is the most likely course of action and I think Giants will see it that way too. I also think Judge will discuss modifying the offense with Garrett. The passing game has been atrocious this year and I’m not so sure the route combinations and scheme are that great. Garrett has to do something about it in the off-season. I also think JG will only get another year to prove himself too!</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Premature </b><a name="15080450">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=couchcoach100"> couchcoach100 </a>  :  12/14/2020  7:52 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080450">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080044" target="_blank">15080044</a> Thegratefulhead said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Ask this question after 3 more games.  If end up with a shot at Fields or Wilson even if we have to give some draft capital I would seriously consider it if we are at 5 or 6 wins for the season. </td>
                                </tr>
                           </table><br />
<br />
My biggest problem with Daniel Jones isnt the turnovers believe it or not.  Alot of those turnovers (FUMBLES) were caused from really BAD o-line play,  when your sacked as much as he has been over the last 2 seasons it pretty inevitable that your gonna turn the ball over and fumble it.  Alot of those fumbles dont happen if he was playing behind a normal oline and wasnt hit pressured and stripped of the ball.  Now Im not saying that he isnt at fault on some of them so please dont get me wrong.<br />
<br />
With that said  Jones's biggest problem is and has been since day 1 is he STARES DOWN HIS #1 option and doesnt go through his progressions.  If his 1st option isnt there he holds on to the ball until he either gets sacked or he throws a really bad pass trying to force it to his first read.  That is stuff you expect from a QB with under 6 games played.  By now he should be going through his progressions very fluidly and he isnt.  I noticed this last season from him and shook it off as he is still learning.  There is ZERO EXCUSES for him doing this at this point and time. But low and behold he is still doing that.  DB's see that and know exactly where the ball is going to go.  I  just have a really bad feeling that this is who he is. I dont think if he doesnt change that aspect of his game and change it NOW that he is going to be destined as a really good Backup QB.  I hate to say that too, he throws a beautiful long ball.  Better than the majority of QB's in this league, but another problem he has is he has problems with the short and intermediate throws, especially the crossingf and slant routes.  He seems to be behind his recievers on the crossing routes and was to far in front of his recievers on the slants.  These issues with him should have been a thing of the past, but yet here we are and he is still making the same mistakes.<br />
<br />
I dont want to give up on him as of yet, but there has to be some major improvements if he is going to be the Franchise QB for the next 10 to 15 years.<br />
<br />
Thats my 2 cents for waht its worth.</div></div><div class="thread_post"><div class="thread_post_header"><b>Some of you think </b><a name="15080456">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=pjcas18"> pjcas18 </a>  :  12/14/2020  8:04 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080456">link</a>   </div></div><div class="thread_post_body">Daniel Jones is under attack like David Carr.<br />
<br />
Yes, Jones has 1 fewer game played than some on here but here are the sacked #'s for the top 12 most sacked QB's.<br />
<br />
And some would argue some of the sacks are on Jones.<br />
<br />
Also, I know there is more than just sacks, like hurries, hits etc. but the plays that bother me most with Jones are those where he's either not pressured and misses an open receiver or creates an "unforced error" and those where he holds the ball way too long and takes a sack (and fumbles or not).<br />
<br />
Wentz: 50 (same # of games as Jones)<br />
Wilson: 40<br />
Watson: 39<br />
Stafford: 37<br />
Jones: 37<br />
Ryan: 33<br />
Burrow: 32 (2 fewer games than Jones)<br />
Cousins: 31<br />
Darnold: 28 (3 fewer games than Jones)<br />
Herbert: 26 (same # of games as Jones)<br />
Allen: 24<br />
Jackson: 24 (2 fewer games than Jones)<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Move On  </b><a name="15080460">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=WillVAB"> WillVAB </a>  :  12/14/2020  8:07 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080460">link</a>   </div></div><div class="thread_post_body">He’s slow making reads.  His pocket awareness sucks.  He drifts into sacks making the OL look worse.  He doesn’t know when to run or throw.  He comes off dumb as a box of rocks.  Not clutch.  Injury prone. <br />
<br />
Everyone should be asking themselves what’s that signature performance Jones has put up to get buy in that he’s the guy?  For all the shit Eli got he at least had flashes early on previewing what he was capable of later in his career.  <br />
<br />
I don’t see any of that with Jones.  I see another Dave Brown.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Premature </b><a name="15080465">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Producer"> Producer </a>  :  12/14/2020  8:11 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080465">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080450" target="_blank">15080450</a> couchcoach100 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15080044 Thegratefulhead said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Ask this question after 3 more games.  If end up with a shot at Fields or Wilson even if we have to give some draft capital I would seriously consider it if we are at 5 or 6 wins for the season. <br />
                                <br />
                           <br />
<br />
My biggest problem with Daniel Jones isnt the turnovers believe it or not.  Alot of those turnovers (FUMBLES) were caused from really BAD o-line play,  when your sacked as much as he has been over the last 2 seasons it pretty inevitable that your gonna turn the ball over and fumble it.  Alot of those fumbles dont happen if he was playing behind a normal oline and wasnt hit pressured and stripped of the ball.  Now Im not saying that he isnt at fault on some of them so please dont get me wrong.<br />
<br />
With that said  Jones's biggest problem is and has been since day 1 is he STARES DOWN HIS #1 option and doesnt go through his progressions.  If his 1st option isnt there he holds on to the ball until he either gets sacked or he throws a really bad pass trying to force it to his first read.  That is stuff you expect from a QB with under 6 games played.  By now he should be going through his progressions very fluidly and he isnt.  I noticed this last season from him and shook it off as he is still learning.  There is ZERO EXCUSES for him doing this at this point and time. But low and behold he is still doing that.  DB's see that and know exactly where the ball is going to go.  I  just have a really bad feeling that this is who he is. I dont think if he doesnt change that aspect of his game and change it NOW that he is going to be destined as a really good Backup QB.  I hate to say that too, he throws a beautiful long ball.  Better than the majority of QB's in this league, but another problem he has is he has problems with the short and intermediate throws, especially the crossingf and slant routes.  He seems to be behind his recievers on the crossing routes and was to far in front of his recievers on the slants.  These issues with him should have been a thing of the past, but yet here we are and he is still making the same mistakes.<br />
<br />
I dont want to give up on him as of yet, but there has to be some major improvements if he is going to be the Franchise QB for the next 10 to 15 years.<br />
<br />
Thats my 2 cents for waht its worth. </td>
                                </tr>
                           </table><br />
<br />
those are both problems, I agree. but for me the biggest problem is Jones' accuracy. He routinely overthrows, underthrows and throws to the wrong side of receivers.</div></div><div class="thread_post"><div class="thread_post_header"><b>Keep him as the starter next year </b><a name="15080467">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=sb+from+NYT+Forum"> sb from NYT Forum </a>  :  12/14/2020  8:13 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080467">link</a>   </div></div><div class="thread_post_body">...it's too hard to assess because the line has been a work in progress and our WRs as unit are below average.  And Engram is, um, unreliable.<br />
<br />
Honestly IMO any assessment now is mostly speculation. Which is fine, fans are entitled.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Move On  </b><a name="15080468">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Saquads26"> Saquads26 </a>  :  12/14/2020  8:13 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080468">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080460" target="_blank">15080460</a> WillVAB said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> He’s slow making reads.  His pocket awareness sucks.  He drifts into sacks making the OL look worse.  He doesn’t know when to run or throw.  He comes off dumb as a box of rocks.  Not clutch.  Injury prone. <br />
<br />
Everyone should be asking themselves what’s that signature performance Jones has put up to get buy in that he’s the guy?  For all the shit Eli got he at least had flashes early on previewing what he was capable of later in his career.  <br />
<br />
I don’t see any of that with Jones.  I see another Dave Brown. </td>
                                </tr>
                           </table><br />
<br />
I think you're dumb as rocks.  Actually dumber.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Move On  </b><a name="15080470">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Thunderstruck27"> Thunderstruck27 </a>  :  12/14/2020  8:15 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080470">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080460" target="_blank">15080460</a> WillVAB said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> He’s slow making reads.  His pocket awareness sucks.  He drifts into sacks making the OL look worse.  He doesn’t know when to run or throw.  He comes off dumb as a box of rocks.  Not clutch.  Injury prone. <br />
<br />
Everyone should be asking themselves what’s that signature performance Jones has put up to get buy in that he’s the guy?  For all the shit Eli got he at least had flashes early on previewing what he was capable of later in his career.  <br />
<br />
I don’t see any of that with Jones.  I see another Dave Brown. </td>
                                </tr>
                           </table><br />
<br />
Jones came in as a rookie against Tampa and played better than Eli had in like 5 years.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Move On  </b><a name="15080472">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=pjcas18"> pjcas18 </a>  :  12/14/2020  8:19 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080472">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080460" target="_blank">15080460</a> WillVAB said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> He’s slow making reads.  His pocket awareness sucks.  He drifts into sacks making the OL look worse.  He doesn’t know when to run or throw.  He comes off dumb as a box of rocks.  Not clutch.  Injury prone. <br />
<br />
Everyone should be asking themselves what’s that signature performance Jones has put up to get buy in that he’s the guy?  For all the shit Eli got he at least had flashes early on previewing what he was capable of later in his career.  <br />
<br />
I don’t see any of that with Jones.  I see another Dave Brown. </td>
                                </tr>
                           </table><br />
<br />
to be fair, I was this harsh on Eli early in his career and I was proven wrong.<br />
<br />
but so far, Jones signature performance is the Eagles game, and being in the clear for a 90 yard would-be-TD run and just falling and almost every Giants fans simultaneous thought "thank god he didn't fumble"<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Move On  </b><a name="15080474">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=WillVAB"> WillVAB </a>  :  12/14/2020  8:21 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080474">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080468" target="_blank">15080468</a> Saquads26 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15080460 WillVAB said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     He’s slow making reads.  His pocket awareness sucks.  He drifts into sacks making the OL look worse.  He doesn’t know when to run or throw.  He comes off dumb as a box of rocks.  Not clutch.  Injury prone. <br />
<br />
Everyone should be asking themselves what’s that signature performance Jones has put up to get buy in that he’s the guy?  For all the shit Eli got he at least had flashes early on previewing what he was capable of later in his career.  <br />
<br />
I don’t see any of that with Jones.  I see another Dave Brown. <br />
                                <br />
                           <br />
<br />
I think you're dumb as rocks.  Actually dumber. </td>
                                </tr>
                           </table><br />
<br />
Cool.  Go watch any of his pressers the last two years and get back to me.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Some of you think </b><a name="15080478">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BrettNYG10"> BrettNYG10 </a>  :  12/14/2020  8:27 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080478">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080456" target="_blank">15080456</a> pjcas18 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Daniel Jones is under attack like David Carr.<br />
<br />
Yes, Jones has 1 fewer game played than some on here but here are the sacked #'s for the top 12 most sacked QB's.<br />
<br />
And some would argue some of the sacks are on Jones.<br />
<br />
Also, I know there is more than just sacks, like hurries, hits etc. but the plays that bother me most with Jones are those where he's either not pressured and misses an open receiver or creates an "unforced error" and those where he holds the ball way too long and takes a sack (and fumbles or not).<br />
<br />
Wentz: 50 (same # of games as Jones)<br />
Wilson: 40<br />
Watson: 39<br />
Stafford: 37<br />
Jones: 37<br />
Ryan: 33<br />
Burrow: 32 (2 fewer games than Jones)<br />
Cousins: 31<br />
Darnold: 28 (3 fewer games than Jones)<br />
Herbert: 26 (same # of games as Jones)<br />
Allen: 24<br />
Jackson: 24 (2 fewer games than Jones) </td>
                                </tr>
                           </table><br />
<br />
I think the quality of OL player league-wide is worse than it was a decade ago. <br />
<br />
Jones isn't behind the 03 Texans or 13 Giants.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Move On  </b><a name="15080480">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=WillVAB"> WillVAB </a>  :  12/14/2020  8:27 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080480">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080472" target="_blank">15080472</a> pjcas18 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15080460 WillVAB said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     He’s slow making reads.  His pocket awareness sucks.  He drifts into sacks making the OL look worse.  He doesn’t know when to run or throw.  He comes off dumb as a box of rocks.  Not clutch.  Injury prone. <br />
<br />
Everyone should be asking themselves what’s that signature performance Jones has put up to get buy in that he’s the guy?  For all the shit Eli got he at least had flashes early on previewing what he was capable of later in his career.  <br />
<br />
I don’t see any of that with Jones.  I see another Dave Brown. <br />
                                <br />
                           <br />
<br />
to be fair, I was this harsh on Eli early in his career and I was proven wrong.<br />
<br />
but so far, Jones signature performance is the Eagles game, and being in the clear for a 90 yard would-be-TD run and just falling and almost every Giants fans simultaneous thought "thank god he didn't fumble"<br />
 </td>
                                </tr>
                           </table><br />
<br />
I want to like Jones.  He can be surgical with his passes and his legs are a weapon.  There’s tools there.  But I just don’t see the qualities right now that championship caliber QBs demonstrate.  He needs to be better mentally in the pocket and that’s not really easy to teach.</div></div><div class="thread_post"><div class="thread_post_header"><b>Same here Will </b><a name="15080487">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=pjcas18"> pjcas18 </a>  :  12/14/2020  8:31 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080487">link</a>   </div></div><div class="thread_post_body">I want Jones to succeed.  what fan wouldn't?<br />
<br />
I just don't see encouraging signs, and if the Giants (Judge specifically) have convictions about a QB in this draft and have the opportunity to draft him, I'd hope they pull the trigger.</div></div><div class="thread_post"><div class="thread_post_header"><b>At this point it's still a judgement call.  I say if you like Wilson  </b><a name="15080500">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+in+Hoboken"> Jim in Hoboken </a>  :  12/14/2020  8:39 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080500">link</a>   </div></div><div class="thread_post_body">enough, draft him.  I just don't see it with Jones.  He may be an average QB with a great surrounding cast, but I don't think we'll ever be elite with him.  <br />
<br />
Whatever they do, I just hope it's not Gettleman making the call.</div></div><div class="thread_post"><div class="thread_post_header"><b>Same story,  different page  </b><a name="15080577">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Simms"> Simms </a>  :  12/14/2020  9:54 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080577">link</a>   </div></div><div class="thread_post_body">RB Below Average<br />
WR: No Seperation<br />
TE: Non Existent<br />
OL: Below Average<br />
<br />
Before Eli faded its the same story. We drafted Barkley but the time we might really be good his contract could be over.<br />
<br />
We drafted RB and a QB high in the draft<br />
 I understand the draft in many ways is q roll of the dice. We cannot reach for first rounders and not have success. <br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Same here Will </b><a name="15080583">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+from+Katonah"> Jim from Katonah </a>  :  12/14/2020  10:05 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080583">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080487" target="_blank">15080487</a> pjcas18 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I want Jones to succeed.  what fan wouldn't?<br />
<br />
I just don't see encouraging signs, and if the Giants (Judge specifically) have convictions about a QB in this draft and have the opportunity to draft him, I'd hope they pull the trigger. </td>
                                </tr>
                           </table><br />
<br />
Was looking into whether Jones also had fumbling issues at Duke  ...  he had 19 fumbles (losing 13) in 3 years as a starter.  Add in his 28 fumbles (16 lost) here in just 1.5 full seasons ... sheesh.</div></div><div class="thread_post"><div class="thread_post_header"><b>Wait and see </b><a name="15080599">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=adamg"> adamg </a>  :  12/14/2020  10:16 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080599">link</a>   </div></div><div class="thread_post_body">Season is not over yet. See if he continues to turn the ball over. If he does draft BOA. If that's a QB so be it. Either way improve upon QB in FA.</div></div><div class="thread_post"><div class="thread_post_header"><b>BOA=BPA </b><a name="15080600">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=adamg"> adamg </a>  :  12/14/2020  10:17 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15080600">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>Lets see how this season plays out </b><a name="15080722">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Breeze_94"> Breeze_94 </a>  :  12/15/2020  12:03 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080722">link</a>   </div></div><div class="thread_post_body">Number of things can happen...<br />
<br />
A.)Jones plays well enough, Giants win east. Keep him for another year and focus on getting him some help at WR. Pick won't be good enough to land an elite QB<br />
<br />
B.)Giants miss playoffs but roll with Jones for one more year<br />
<br />
C.) Giants lose out, Jones continues to struggle. End up with a top 6 pick and Wilson/Fields/Lance are too good to pass up for Judge- who remember, is not tied to Jones at all. If Judge doesn't think he can win with DJ, then it's in his best interest to find a guy he can win with.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: Seriously? </b><a name="15080730">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  12/15/2020  12:40 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080730">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080165" target="_blank">15080165</a> joe48 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15080073 Gatorade Dunk said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     In comment 15080056 Don in DC said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Kid comes out to play while gutting it out through an injury and this is the thanks he gets?<br />
So if Murray played on one leg yesterday how effective would he have been?<br />
Ridiculous. <br />
                                <br />
                           <br />
That's a fair point, and it would be even more valid if the flaws we saw yesterday weren't identical to the ones we've seen from him throughout his short career.<br />
<br />
Are you suggesting that he needs to be at/near 100% physically to not make dumb mental errors?  Because if that's the case, it's not nearly as strong a defense as you think - there are going to be a lot of times over the course of an NFL career that a starting QB is going to be out there at less than 100%.  If gutting out an injury means DJ is considerably more likely to play like shit, that's a pretty significant issue in and of itself.<br />
<br />
I don't think one game alone should signal the death knell for DJ, but I also don't think it's helpful to pretend like it wasn't consistent with what we know his weaknesses to be even when he's healthy. <br />
                                <br />
                            </td>
                                </tr>
                           </table><br />
I'm going to try to decode your reply (helpful hint, reply after the brackets that contain the /quote).<br />
<br />
What does Murray have to do with Jones?  Has Murray demonstrated a tendency to make dumb mental errors?  Has Murray demonstrated a tendency to be a turnover machine?<br />
<br />
Jones has, on both counts.  Unless you think his brain is contained in his thigh, I'm not sure you can pin it entirely on his injury.  And if you can, and you're trying to make the case that he simply cannot be an effective QB if he's less than 100% physically, I'll stand by my point that that he isn't a franchise QB.  <br />
<br />
If he's going to be the guy, he has to be able to take the field a little bit banged up and not turn into the shitty version of himself that we've all seen him be (and he's been that shitty version of himself even when he's purportedly fully healthy, so I'm not sure how anyone can make the case that a turnover-prone QB was somehow ONLY a turnover-prone QB yesterday because his leg was hurt).<br />
<br />
Drop the excuses.  Jones has more to prove and he hasn't done it yet.</div></div><div class="thread_post"><div class="thread_post_header"><b>I think it comes down to what the GM in 2021 and Judge </b><a name="15080749">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=cosmicj"> cosmicj </a>  :  12/15/2020  6:39 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080749">link</a>   </div></div><div class="thread_post_body">Think of Zach Wilson and Kyle Trask.  (There is too little tape on Trey Lance to make such a move.). If you are convinced one of them will become a quality starter, you pick them if they are there and don’t even think twice about it.<br />
<br />
The thing that really bothers me is Jones’ field vision.  He isn’t a dumb guy at all but he plays like it.  Several posts outline the problem, esp coachcooch’s.</div></div><div class="thread_post"><div class="thread_post_header"><b>About Murray, I’m impressed by his field vision. </b><a name="15080750">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=cosmicj"> cosmicj </a>  :  12/15/2020  6:42 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080750">link</a>   </div></div><div class="thread_post_body">He is very good at picking out open receivers and seeing the field.  The Giants kept him in the pocket a lot on Sunday - I’d say that part of the defensive game plan worked - and he played well even with a key part of his game removed.</div></div><div class="thread_post"><div class="thread_post_header"><b>I'm not impressed with the offense. </b><a name="15080754">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gmen703"> Gmen703 </a>  :  12/15/2020  7:22 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080754">link</a>   </div></div><div class="thread_post_body">The first pass is always a damn curl route which the defense just sits on.  I'm waiting for a pick six.<br />
<br />
Jones has shown he can be effective when throwing the ball.  We saw this with Shumurs offense.  When's the last time Jones has thrown for 300 yards? Feels like it's been ages.  Probably the main reason we can't score points.  People talk about the receivers and TEs...We had the same ones last year and Jones was more effective.  He only has 8 passing TDs this year. 8!  Can't win many games unless the defense plays lights out.<br />
<br />
Is Jones the guy long term?  Maybe.  But he's being held back in this offense.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I'm not impressed with the offense. </b><a name="15080759">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gmen703"> Gmen703 </a>  :  12/15/2020  7:33 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080759">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080754" target="_blank">15080754</a> Gmen703 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> The first pass is always a damn curl route which the defense just sits on.  I'm waiting for a pick six.<br />
<br />
Jones has shown he can be effective when throwing the ball.  We saw this with Shumurs offense.  When's the last time Jones has thrown for 300 yards? Feels like it's been ages.  Probably the main reason we can't score points.  People talk about the receivers and TEs...We had the same ones last year and Jones was more effective.  He only has 8 passing TDs this year. 8!  Can't win many games unless the defense plays lights out.<br />
<br />
Is Jones the guy long term?  Maybe.  But he's being held back in this offense. </td>
                                </tr>
                           </table><br />
<br />
600 yards passing less through 12 games when compared to last year (injury probably skewed it) And an astounding 16 less TDs with only 3 ints less.  Yet, he's averaging the same number of sacks taken, same completion percentage, similar yards/completion and yards/attempt.<br />
<br />
It's the offense.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>For the Move On group which QB do you draft in 2021 </b><a name="15080764">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Rick+in+Dallas"> Rick in Dallas </a>  :  12/15/2020  8:03 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080764">link</a>   </div></div><div class="thread_post_body">I believe Trask and Wilson will be long gone before the number 10 selection. You better start doing your homework on Mac Jones of Alabama.<br />
D.Jones is not a David Brown clone but his pocket awareness and ball security this late into his second season are major concerns. <br />
I say we watch him play the last 3 games then trust our coaching staff and DG to make the right decision. If we screw up the QB position we set this rebuild process back another 5 years. I am too old for that to happen.</div></div><div class="thread_post"><div class="thread_post_header"><b>Lots of good thoughts </b><a name="15080794">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Lines+of+Scrimmage"> Lines of Scrimmage </a>  :  12/15/2020  9:15 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080794">link</a>   </div></div><div class="thread_post_body">on this thread.  Certainly this will be a very big question for Judge and the front office.  It will be interesting how it plays out.<br />
<br />
One thing I hope plays out is Judge makes this choice.  Dave will have to retire.  Mara can't force Jones on Judge and you can't keep Dave if you are moving on.  Thank him for his many years and move on.  If Mara sticks his nose in this he is going to create a toxic relationship with Judge imo.<br />
<br />
You don't force yourself to draft a QB though.  They have to be convinced the like one and then try your best to get him.<br />
<br />
If this is not the draft to find a QB then you bring in a better Vet to compete with Jones and go from there.  The downside to this is they may be a better team next year so you are drafting later.  This then becomes potential QB hell as it will be harder to find one.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>In summary, it looks like a pretty even split ... </b><a name="15080863">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+from+Katonah"> Jim from Katonah </a>  :  12/15/2020  10:29 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080863">link</a>   </div></div><div class="thread_post_body">... between those want to build around Jones (giving him at least one more year and the benefit of a second year in the system and better weapons) and those who want to start moving on in 2021.  Some feel strongly about their position, but a lot of folks see this as a tough, close call with a lot of grey area and incomplete data.<br />
<br />
One thing that does seem virtually unanimous ... we want Judge and the coaching staff to have serious input in this decision, not only because they are in the best spot to evaluate whether they believe Jones has the tools to execute the offense and lead them forward ... but also because the Jones pick pre-dated their arrival (and they don’t have ulterior motives to prove it was the correct pick).<br />
<br />
Hopefully Jones heals up enough to have at least 1 or 2 more starts before the end of the season — the more data, the better.</div></div><div class="thread_post"><div class="thread_post_header"><b>I don't believe looking at just stats - I know its the new fantasy  </b><a name="15080870">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=PatersonPlank"> PatersonPlank </a>  :  12/15/2020  10:40 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080870">link</a>   </div></div><div class="thread_post_body">football thing to do, but it doesn't tell the whole picture.<br />
<br />
IMO (this means in my opinion not fact), I think Judge and Garrett (and yes they both collaborate and agree) purposefully put together a more conservative, ball control offensive scheme. They do this to limit turnovers, keep the D off the field so much, and keep the games close. These were all issues un Shurmur when he was here. Doing this gives us a much better chance to win with the current team. The same on D by the way with the "bend don't break" philosophy. As the talent gets better this will change.<br />
<br />
This is what Judge keeps talking about when he says he is playing complementary football. This is also why Jones isn't throwing for the big numbers this season. Its a design, and its not Garrett screwing up, and its not Jones regressing</div></div><div class="thread_post"><div class="thread_post_header"><b>If you feel like </b><a name="15080878">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=pjcas18"> pjcas18 </a>  :  12/15/2020  10:48 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080878">link</a>   </div></div><div class="thread_post_body">this offense is designed to limit turnovers, and Jones performance doesn't concern you, maybe you're not clear on some things.<br />
<br />
Jones has one of he higher interception percentages in the league and combined with his fumbles he is top 5 in most turnovers in the league.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I don't believe looking at just stats - I know its the new fantasy  </b><a name="15080883">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+from+Katonah"> Jim from Katonah </a>  :  12/15/2020  10:54 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080883">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080870" target="_blank">15080870</a> PatersonPlank said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> football thing to do, but it doesn't tell the whole picture.<br />
<br />
IMO (this means in my opinion not fact), I think Judge and Garrett (and yes they both collaborate and agree) purposefully put together a more conservative, ball control offensive scheme. They do this to limit turnovers, keep the D off the field so much, and keep the games close. These were all issues un Shurmur when he was here. Doing this gives us a much better chance to win with the current team. The same on D by the way with the "bend don't break" philosophy. As the talent gets better this will change.<br />
<br />
This is what Judge keeps talking about when he says he is playing complementary football. This is also why Jones isn't throwing for the big numbers this season. Its a design, and its not Garrett screwing up, and its not Jones regressing </td>
                                </tr>
                           </table><br />
<br />
I think you’re right — but if playing conservative/limiting turnovers was their  primary directive, and Jones continued to throw INTs and fumble the ball at an alarming rate (outside of a three game stretch), what does that say about Jones. It’s especially concerning to me that the problems we’ve seen in his 25 appearances are a continuation of what we saw at Duke (19 fumbles).</div></div><div class="thread_post"><div class="thread_post_header"><b>What does it say about Jones.... </b><a name="15080886">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Greg+from+LI"> Greg from LI </a>  :  12/15/2020  10:59 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080886">link</a>   </div></div><div class="thread_post_body">...if the coaches feel compelled, because of his propensity to give the ball away, to implement a very low-risk, conservative scheme that is producing very little offense?<br />
<br />
I mean, if that's what is required to start him and have much of a chance of winning games, perhaps he's not the long-term answer at QB.</div></div><div class="thread_post"><div class="thread_post_header"><b>Or what Jim said </b><a name="15080901">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Greg+from+LI"> Greg from LI </a>  :  12/15/2020  11:09 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080901">link</a>   </div></div><div class="thread_post_body">To put it another way: over the course of 25 games, does anyone think Jones has shown noticeable progress?  Some, perhaps, but not a whole lot.  <br />
<br />
Now, I will agree that he's not been put in a great situation to succeed, and some of his problems are typical of young QBs.  On the other hand, he also received much more advanced coaching under Cutcliffe than most college QBs get.  <br />
<br />
I do think they're at least going to need to find a better backup than Colt McCoy next year.</div></div><div class="thread_post"><div class="thread_post_header"><b>I think the one true </b><a name="15080903">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Dnew15"> Dnew15 </a>  :  12/15/2020  11:10 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080903">link</a>   </div></div><div class="thread_post_body">elite skill that DJ possesses as a QB is his running ability on designed runs.<br />
<br />
That worries me. It's a skill that doesn't age well and it's also a skill that is difficult to design an entire offense around, especially since he has been dinged up two years in a row with injuries that will sap him of his ability.<br />
<br />
I think the Giants are getting dangerously close to the "he is what he is" category.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: What does it say about Jones.... </b><a name="15080904">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sean"> Sean </a>  :  12/15/2020  11:11 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080904">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080886" target="_blank">15080886</a> Greg from LI said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> ...if the coaches feel compelled, because of his propensity to give the ball away, to implement a very low-risk, conservative scheme that is producing very little offense?<br />
<br />
I mean, if that's what is required to start him and have much of a chance of winning games, perhaps he's not the long-term answer at QB. </td>
                                </tr>
                           </table><br />
<br />
It’s Trubisky all over again, he is a game manager. The question is always, “can Jones avoid the turnovers?” That isn’t what I’m looking for at QB.</div></div><div class="thread_post"><div class="thread_post_header"><b>Paterson </b><a name="15080908">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=cosmicj"> cosmicj </a>  :  12/15/2020  11:13 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080908">link</a>   </div></div><div class="thread_post_body">If the conservative play calling is the design, then Jones is killing the plan.  I am ok with the thought that you bring along Jones slowly and have him game manage in a lot of situations.  The problem is that he hasn't been executing that plan, which is worrisome because it's an easier role for him to fill than say what Coughlin put on a young Eli's shoulders.  <br />
<br />
If anything, you're arguing that Jones is a full-on bust.</div></div><div class="thread_post"><div class="thread_post_header"><b>the best course of action </b><a name="15080910">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  12/15/2020  11:14 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080910">link</a>   </div></div><div class="thread_post_body">is to keep building the roster around him and if he doesn't make the big jump in year 3, then move along. <br />
<br />
I'm not making excuses for his poor play, poor decisions and lack of awareness. But there's a difference between doing those things with next to no playmakers and nobody open, and doing those things when you have a full deck. New staff, new scheme, new young OL. It takes time. But if this is still happening in the first quarter of the season in 2021, we will pretty much know.<br />
<br />
He's 23 years old. He's got another full year to put it all together.</div></div><div class="thread_post"><div class="thread_post_header"><b>a healthy Daniel Jones </b><a name="15080915">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  12/15/2020  11:16 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080915">link</a>   </div></div><div class="thread_post_body">is not the reason we have conservative game plans. It's the fact that our receivers can't get open, our tight end seems to not be able to catch every other throw, and one of the most dynamic playmakers in football is out for the season.<br />
<br />
Not sure what you guys are expecting from the offense, but it's going to be a slog without much at WR and Barkley hurt.</div></div><div class="thread_post"><div class="thread_post_header"><b>I'm not sure there's a QB likely to be there when they pick </b><a name="15080918">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Greg+from+LI"> Greg from LI </a>  :  12/15/2020  11:17 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080918">link</a>   </div></div><div class="thread_post_body">that would be an obvious selection so, if I had to guess, Jones will get one more year to show something, and I can live with that.  Hopefully we have a better GM beginning this offseason who can upgrade WR and TE and we can see if Jones can take advantage of that and really stamp the job as his.<br />
<br />
Next year is gonna be it, though.  If he can't show more than we've seen thus far, then it'll be time to move on.</div></div><div class="thread_post"><div class="thread_post_header"><b>Option 4 </b><a name="15080920">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Scyber"> Scyber </a>  :  12/15/2020  11:18 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080920">link</a>   </div></div><div class="thread_post_body">is my choice</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: a healthy Daniel Jones </b><a name="15080921">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Greg+from+LI"> Greg from LI </a>  :  12/15/2020  11:19 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080921">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080915" target="_blank">15080915</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Not sure what you guys are expecting from the offense, but it's going to be a slog without much at WR and Barkley hurt. </td>
                                </tr>
                           </table><br />
<br />
Which is why it baffles me than anyone lauds Gettleman and advocates him retaining the job.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I'm not sure there's a QB likely to be there when they pick </b><a name="15080924">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  12/15/2020  11:22 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080924">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080918" target="_blank">15080918</a> Greg from LI said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> that would be an obvious selection so, if I had to guess, Jones will get one more year to show something, and I can live with that.  Hopefully we have a better GM beginning this offseason who can upgrade WR and TE and we can see if Jones can take advantage of that and really stamp the job as his.<br />
<br />
Next year is gonna be it, though.  If he can't show more than we've seen thus far, then it'll be time to move on. </td>
                                </tr>
                           </table><br />
<br />
FWIW, I think six QBs may go in the first round - Lawrence, Fields, Lance, Wilson, Jones, and Trask. And a reasonably good case can be made that every single one of them is more talented than DJ. This is shaping up to be a very, very interesting class...<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>What do you think Daniel Jones's ceiling is, as QB? </b><a name="15080925">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Kyle_"> Kyle_ </a>  :  12/15/2020  11:23 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080925">link</a>   </div></div><div class="thread_post_body">And then factor the likelihood of him hitting that ceiling. <br />
<br />
I see him play for nearly two full seasons now, I see his skillset, I see his strengths and weaknesses, and I think his best-case scenario is he plays like the 16th best QB in the NFL with consistency. <br />
<br />
Best-case scenario! Average, as a best-case scenario! A guy who doesn't pull the trailer, a guy who is the trailer and needs the supporting cast to pull him along. <br />
<br />
Factor in the likelihood of the best-case scenario coming to fruition isn't super high, and what am I likely looking at with Daniel Jones? A below-median QB, a guy that needs great circumstances to play at a league-average starting QB level.<br />
<br />
Because of this, for the 2021 NFL Draft, I'm quite comfortable throwing him aside for (any) draft compensation and selecting a QB <span class="underline">if</span> there's a QB I think has top 5-8 in the league potential. The kid from BYU intrigues me, but I won't pretend I've got a fully-formed (amateur) opinion on him yet.<br />
<br />
The above is all amateur opinion on Daniel Jones! If I had thought Daniel Jones had 5th-8th best QB in the league potential in his best season(s), I would be excited to keep him. That's the key here. If that's how you see Jones, then your opinion on how to move forward retaining Jones makes sense -- even if I disagree with the evaluation, the logic would be sound.<br />
<br />
If you don't see Daniel Jones as someone with a 5th-8th best QB ceiling, a game-changing player, but are nevertheless excited to keep him as the QB moving forward, you need to consider why you're so willing to accept mediocrity. <br />
<br />
What concerns me is that I have almost-zero faith the Giants will conduct this sort of evaluation of Daniel Jones. "If we get Jones a bunch of help next season, he <span class="underline">could</span> play at a Goff or Bridgewater level" isn't a strong case to just ignore the QBs in 2021.</div></div><div class="thread_post"><div class="thread_post_header"><b>There are reasonable arguments on both sides but notice what the  </b><a name="15080926">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=cosmicj"> cosmicj </a>  :  12/15/2020  11:23 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080926">link</a>   </div></div><div class="thread_post_body">boundaries are here: the optimists argue that Jones can make progress and eventually be a mid-tier starting QB in the league.  The pessimists recognize that he has some talent and see a quality backup QB.  You win championships with the Tom Bradys and Patrick Mahomes of the world.  <br />
<br />
Line of Scrimmage has it right above.  The Giants need to carefully scout the incoming QB class, which is a very good one, and if they have a very positive grade on a player who is there when they pick, select him and see where you go.  If both perform well in training camp, you trade one of them, probably Jones.  <br />
<br />
To me, this situation really is about what to the Giants scouts think of Kyle Trask and Zach Wilson.</div></div><div class="thread_post"><div class="thread_post_header"><b>bw </b><a name="15080927">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=cosmicj"> cosmicj </a>  :  12/15/2020  11:24 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080927">link</a>   </div></div><div class="thread_post_body">We are getting into draft stuff here, but I think picking Trey Lance, with the minimal tape he has out, is foolhardy.  What do you think?</div></div><div class="thread_post"><div class="thread_post_header"><b>Sean </b><a name="15080932">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=cosmicj"> cosmicj </a>  :  12/15/2020  11:26 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080932">link</a>   </div></div><div class="thread_post_body">a good post.  <br />
<br />
"What concerns me is that I have almost-zero faith the Giants will conduct this sort of evaluation of Daniel Jones."<br />
<br />
I am very concerned Mara will get involved in this, because the QB is the "face of the franchise", and botch the whole thing.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I'm not sure there's a QB likely to be there when they pick </b><a name="15080936">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+from+Katonah"> Jim from Katonah </a>  :  12/15/2020  11:28 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080936">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080918" target="_blank">15080918</a> Greg from LI said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> that would be an obvious selection so, if I had to guess, Jones will get one more year to show something, and I can live with that.  Hopefully we have a better GM beginning this offseason who can upgrade WR and TE and we can see if Jones can take advantage of that and really stamp the job as his.<br />
<br />
Next year is gonna be it, though.  If he can't show more than we've seen thus far, then it'll be time to move on. </td>
                                </tr>
                           </table><br />
<br />
Completely reasonable if there are no excellent QB prospects left at 10 or wherever they will pick.</div></div><div class="thread_post"><div class="thread_post_header"><b>The real question this organization  </b><a name="15080939">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Dnew15"> Dnew15 </a>  :  12/15/2020  11:30 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080939">link</a>   </div></div><div class="thread_post_body">should be asking themselves is how likely is it that Daniel Jones develops into a HOF QB?<br />
<br />
There is no better way to ensure that you organization will be in contention to win a Super Bowl than that. There are outliers - sure - but since '92 there have been 4 - that's right 4 - QBs that have won a SB that won't be in the HOF: Foles/Flacco/Brad Johnson/Dilfer.<br />
<br />
That's it.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I'm not sure there's a QB likely to be there when they pick </b><a name="15080943">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+from+Katonah"> Jim from Katonah </a>  :  12/15/2020  11:30 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080943">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080924" target="_blank">15080924</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15080918 Greg from LI said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     that would be an obvious selection so, if I had to guess, Jones will get one more year to show something, and I can live with that.  Hopefully we have a better GM beginning this offseason who can upgrade WR and TE and we can see if Jones can take advantage of that and really stamp the job as his.<br />
<br />
Next year is gonna be it, though.  If he can't show more than we've seen thus far, then it'll be time to move on. <br />
                                <br />
                           <br />
<br />
FWIW, I think six QBs may go in the first round - Lawrence, Fields, Lance, Wilson, Jones, and Trask. And a reasonably good case can be made that every single one of them is more talented than DJ. This is shaping up to be a very, very interesting class...<br />
 </td>
                                </tr>
                           </table><br />
<br />
That answered my next question, thanks!</div></div><div class="thread_post"><div class="thread_post_header"><b>Greg </b><a name="15080946">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  12/15/2020  11:31 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080946">link</a>   </div></div><div class="thread_post_body">i get it but DG made the decision to pass on WR the past few years to focus on the trenches and back 7. Mixed results, but those 2 areas seems to be going in the right direction. Hope he gets the WRs right in the upcoming offseason. <br />
<br />
I'm thinking 1 value signing at WR and a high draft pick. Those two coupled with Shepard and Slayton would be a greatly improved unit, now that the OL depth is somewhat set in stone for next year.</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="15080948">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=christian"> christian </a>  :  12/15/2020  11:31 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080948">link</a>   </div></div><div class="thread_post_body">Jones will be the presumptive starter next year, no question. The most important thing the Giants can do is remove the mystery of plausible deniability. This is general management 101 - isolate the variables until you know the issue:<br />
<br />
1) Upgrade the WR group, specifically replace Golden Tate<br />
 <br />
2) Upgrade the TE group, specifically a 2nd TE who's not bolted to the ground<br />
<br />
3) Upgrade the pass blocking, don't get complacent, if there is someone in the market better than Zeitler or Hernandez, go do it<br />
<br />
4) Sign a back-up at the Nick Mullens or above level, and don't be afraid to learn he's as good or better than Jones</div></div><div class="thread_post"><div class="thread_post_header"><b>For instance JonC </b><a name="15080951">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  12/15/2020  11:33 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080951">link</a>   </div></div><div class="thread_post_body">made the point that DG might have been better suited to go with Claypool or Pittman Jr with our 2nd pick in 2020 instead of McKinney. It's not super apparent yet whether that was the right decision. <br />
<br />
The 2021 WR class is arguably better than 2020, so that's something.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: bw </b><a name="15080962">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  12/15/2020  11:35 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080962">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080927" target="_blank">15080927</a> cosmicj said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> We are getting into draft stuff here, but I think picking Trey Lance, with the minimal tape he has out, is foolhardy.  What do you think? </td>
                                </tr>
                           </table><br />
<br />
Agreed. He's the wildcard. Covid really hurt him as 1-AA football shut down...although they did get a crack at Central Arkansas. But he wasn't impressive. Some scouts, however, love his upside. I'm less sure.<br />
<br />
Everyone else has a lot more data to showcase their skills. And it's a good class with arm talent...</div></div><div class="thread_post"><div class="thread_post_header"><b>I think the idea of a veteran QB is interesting.. </b><a name="15080963">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sean"> Sean </a>  :  12/15/2020  11:35 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080963">link</a>   </div></div><div class="thread_post_body">Let’s say Matt Stafford or Matt Ryan get cut loose, does it make sense to sign either to a 3-4 year type deal and let them be the bridge to whoever the next QB is in a few years?<br />
<br />
The strategy worked with Collins back in 1999, I wonder if Mara is agreeable to something similar.</div></div><div class="thread_post"><div class="thread_post_header"><b>I wouldn't be shocked if </b><a name="15080964">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  12/15/2020  11:36 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080964">link</a>   </div></div><div class="thread_post_body">DaVonta Smith is the pick in round 1. He's an Alabama kid, and the athleticism is off the charts, along with hands and route running. The only reason he wouldn't be a surefire top 10 guy is his size, at only 175 pounds, and it's not a big 175. He just looks and seems small.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I think the idea of a veteran QB is interesting.. </b><a name="15080968">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=christian"> christian </a>  :  12/15/2020  11:38 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080968">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080963" target="_blank">15080963</a> Sean said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Let’s say Matt Stafford or Matt Ryan get cut loose, does it make sense to sign either to a 3-4 year type deal and let them be the bridge to whoever the next QB is in a few years?<br />
<br />
The strategy worked with Collins back in 1999, I wonder if Mara is agreeable to something similar. </td>
                                </tr>
                           </table><br />
<br />
I think that is a 2022 play. I believe they should and will give Jones 2021 to prove he's capable. <br />
<br />
If they can remove the variables I posted above, and his play doesn't dramatically improve, I'd sign a vet.</div></div><div class="thread_post"><div class="thread_post_header"><b>well, if we're playing draft hindsight.... </b><a name="15080970">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Greg+from+LI"> Greg from LI </a>  :  12/15/2020  11:39 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080970">link</a>   </div></div><div class="thread_post_body">Passing on AJ Brown and Deebo Samuel to pick Baker looks terrible in retrospect.</div></div><div class="thread_post"><div class="thread_post_header"><b>I don't want any parts of  </b><a name="15080973">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Dnew15"> Dnew15 </a>  :  12/15/2020  11:43 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080973">link</a>   </div></div><div class="thread_post_body">Stafford or Ryan or any other vet QB to be honest.<br />
<br />
At least right now - if JJ gets all the pieces in place 2 years from now and DJ isn't the guy - then maybe...<br />
<br />
But I'd rather go to the draft sooner than later instead of waiting out DJ.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: well, if we're playing draft hindsight.... </b><a name="15080975">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  12/15/2020  11:44 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080975">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080970" target="_blank">15080970</a> Greg from LI said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Passing on AJ Brown and Deebo Samuel to pick Baker looks terrible in retrospect. </td>
                                </tr>
                           </table><br />
Yes, that's true.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I wouldn't be shocked if </b><a name="15080976">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  12/15/2020  11:44 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080976">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080964" target="_blank">15080964</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> DaVonta Smith is the pick in round 1. He's an Alabama kid, and the athleticism is off the charts, along with hands and route running. The only reason he wouldn't be a surefire top 10 guy is his size, at only 175 pounds, and it's not a big 175. He just looks and seems small. </td>
                                </tr>
                           </table><br />
<br />
But he's tough and like Gumby...just bounces right back up.<br />
<br />
I'm all in on Chris Olave of Ohio State.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I don't want any parts of  </b><a name="15080979">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  12/15/2020  11:47 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080979">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080973" target="_blank">15080973</a> Dnew15 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Stafford or Ryan or any other vet QB to be honest.<br />
<br />
At least right now - if JJ gets all the pieces in place 2 years from now and DJ isn't the guy - then maybe...<br />
<br />
But I'd rather go to the draft sooner than later instead of waiting out DJ. </td>
                                </tr>
                           </table><br />
<br />
I think it will be very interesting if Gruden sticks with Carr. If they let him go, we should really kick his tires...</div></div><div class="thread_post"><div class="thread_post_header"><b>christian </b><a name="15080980">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=cosmicj"> cosmicj </a>  :  12/15/2020  11:48 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080980">link</a>   </div></div><div class="thread_post_body">I don't think you can approach the situation like that.  Scouts' basic job is to break down performance by play and isolate what an individual player is doing right and wrong in a meaningful sample of situations.  I think the Giants need to self-scout and apply this to Jones.  There will be enough plays where the blocking held up to draw a conclusion.  Extrapolating from that conclusion is the difficult part.<br />
<br />
Again, I am concerned about owner meddling.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I think the one true </b><a name="15080988">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=rsjem1979"> rsjem1979 </a>  :  12/15/2020  11:54 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15080988">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080903" target="_blank">15080903</a> Dnew15 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> elite skill that DJ possesses as a QB is his running ability on designed runs.<br />
<br />
That worries me. It's a skill that doesn't age well and it's also a skill that is difficult to design an entire offense around, especially since he has been dinged up two years in a row with injuries that will sap him of his ability.<br />
<br />
I think the Giants are getting dangerously close to the "he is what he is" category. </td>
                                </tr>
                           </table><br />
<br />
You're right, and that's what I don't get about people who want to "protect" him by not using him in the run game.  <br />
<br />
As a pure pocket passer, Jones is mediocre.  His instincts are poor.  His reads are slow.  His decision-making is suspect.  His ball security is awful.  If the plan is to make him a pure pocket QB, it's a terrible plan.</div></div><div class="thread_post"><div class="thread_post_header"><b>Not a fan of management 101 </b><a name="15081015">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Lines+of+Scrimmage"> Lines of Scrimmage </a>  :  12/15/2020  12:17 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081015">link</a>   </div></div><div class="thread_post_body">I believe you can't qualify the unqualified and best to move forward ASAP. <br />
<br />
Circumstances may dictate him starting next year (draft, better option FA, etc.).  In that case you plan and coach around the deficiencies.  Finding a franchise QB is very hard.  There is a reason they get paid what they do.  You can still win a championship but it is much harder and you will need a outstanding team around him which in itself is another huge challenge.  <br />
<br />
I am sure Judge knows what he wants in his QB.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I don't want any parts of  </b><a name="15081027">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Dnew15"> Dnew15 </a>  :  12/15/2020  12:27 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081027">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080979" target="_blank">15080979</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15080973 Dnew15 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Stafford or Ryan or any other vet QB to be honest.<br />
<br />
At least right now - if JJ gets all the pieces in place 2 years from now and DJ isn't the guy - then maybe...<br />
<br />
But I'd rather go to the draft sooner than later instead of waiting out DJ. <br />
                                <br />
                           <br />
<br />
I think it will be very interesting if Gruden sticks with Carr. If they let him go, we should really kick his tires... </td>
                                </tr>
                           </table><br />
<br />
THis offseason is Gruden's chance to unload him. His cap hit is very manageable.<br />
<br />
I'm not sure it's a great idea to invest a lot of cap space in a 30 yr old QB that an offensive guru like Gruden decided couldn't take him to the promised land.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: For the Move On group which QB do you draft in 2021 </b><a name="15081039">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  12/15/2020  12:37 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081039">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080764" target="_blank">15080764</a> Rick in Dallas said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I believe Trask and Wilson will be long gone before the number 10 selection. You better start doing your homework on Mac Jones of Alabama.<br />
D.Jones is not a David Brown clone but his pocket awareness and ball security this late into his second season are major concerns. <br />
I say we watch him play the last 3 games then trust our coaching staff and DG to make the right decision. If we screw up the QB position we set this rebuild process back another 5 years. I am too old for that to happen. </td>
                                </tr>
                           </table><br />
You think four (or possibly five) QBs are going in the top nine picks?<br />
<br />
I suppose that's very possible, but it feels high.  I think we can say pretty definitively that Lawrence and Fields will be long gone.  After that, you have, in some order: Trask, Lance, Wilson, Jones.  I think at least two of those, and probably three of them, are there at #10.<br />
<br />
That's not to say that any of that second tier would necessarily be an upgrade over Jones (although I think Trask would be very attractive to Judge if he is trying to limit turnovers on offense).</div></div><div class="thread_post"><div class="thread_post_header"><b>Play better </b><a name="15081044">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Thegratefulhead"> Thegratefulhead </a>  :  12/15/2020  12:45 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081044">link</a>   </div></div><div class="thread_post_body">I am a results guy.  If we lose enough games that Wilson or Fields are there when we draft, we should draft them.  I like DJ and believe he has some elite talents.  That said, I am not loyal to him, he hasn't won shit.  Win games, don't fumble and he can be the QB of the future.  If he keeps fumbling, draft another QB in round 1 and let them compete. I do not want a FA QB.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: christian </b><a name="15081057">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  12/15/2020  12:59 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081057">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080980" target="_blank">15080980</a> cosmicj said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I don't think you can approach the situation like that.  Scouts' basic job is to break down performance by play and isolate what an individual player is doing right and wrong in a meaningful sample of situations.  I think the Giants need to self-scout and apply this to Jones.  There will be enough plays where the blocking held up to draw a conclusion.  Extrapolating from that conclusion is the difficult part.<br />
<br />
Again, I am concerned about owner meddling. </td>
                                </tr>
                           </table><br />
<br />
The biggest story of the offseason is what Judge's level of influence will now be vs. Gettleman and Mara. What happens with Jones could be the best indicator of that.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I think the idea of a veteran QB is interesting.. </b><a name="15081058">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  :  12/15/2020  1:02 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081058">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080968" target="_blank">15080968</a> christian said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15080963 Sean said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Let’s say Matt Stafford or Matt Ryan get cut loose, does it make sense to sign either to a 3-4 year type deal and let them be the bridge to whoever the next QB is in a few years?<br />
<br />
The strategy worked with Collins back in 1999, I wonder if Mara is agreeable to something similar. <br />
                                <br />
                           <br />
<br />
I think that is a 2022 play. I believe they should and will give Jones 2021 to prove he's capable. <br />
<br />
If they can remove the variables I posted above, and his play doesn't dramatically improve, I'd sign a vet. </td>
                                </tr>
                           </table><br />
<br />
Also a reasonable scenario you do a mix of both. Sign a vet in the offseason but give Jones the starter's job and enough rope to see if he hangs himself. If he improves then we keep going. If he doesn't move onto the experienced vet before midseason.<br />
<br />
Seems like given the poor shape of the division, the Giants shouldn't just give up on 2021 to win it with an experienced backup.</div></div><div class="thread_post"><div class="thread_post_header"><b>QB development is not linear as we have always said </b><a name="15081065">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  :  12/15/2020  1:08 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081065">link</a>   </div></div><div class="thread_post_body">but Jones has got to start showing more than he has to keep his job, just like any other position on the field.<br />
<br />
It's a shame he got hurt, but them's the breaks. Clearly Judge has been forming his opinion on DJ and it's quite possible that these next 3 games are critical in whether he supports him staying under center to begin 2021.</div></div><div class="thread_post"><div class="thread_post_header"><b>About signing a vet to compete with Jones, that’s fine </b><a name="15081076">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=cosmicj"> cosmicj </a>  :  12/15/2020  1:22 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081076">link</a>   </div></div><div class="thread_post_body">But if you see Jones as that vet, he has a reasonable $7mm cap hit.  It’s very disappointing to see a recent #6 pick viewed like that, but leaving aside how he was acquired, he is a cost effective placeholder until we can get a franchise QB.  <br />
<br />
It pains me to write this.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: About signing a vet to compete with Jones, that’s fine </b><a name="15081082">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Dnew15"> Dnew15 </a>  :  12/15/2020  1:24 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081082">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081076" target="_blank">15081076</a> cosmicj said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> But if you see Jones as that vet, he has a reasonable $7mm cap hit.  It’s very disappointing to see a recent #6 pick viewed like that, but leaving aside how he was acquired, he is a cost effective placeholder until we can get a franchise QB.  <br />
<br />
It pains me to write this. </td>
                                </tr>
                           </table><br />
<br />
You're not wrong though....</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: bw </b><a name="15081087">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  12/15/2020  1:32 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081087">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15080137" target="_blank">15080137</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> i'm not understanding your point. Are you trying to say Saquon Barkley doesn't make a huge difference as to what we can do on offense, and what defenses have to prepare for?<br />
<br />
We are a significantly better offense with him as the running back. Are you actually trying to dispute this? </td>
                                </tr>
                           </table><br />
It doesn't seem to be reflected in wins or points, but sure, I guess he makes the highlight reels more exciting.</div></div><div class="thread_post"><div class="thread_post_header"><b>GD </b><a name="15081090">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  12/15/2020  1:36 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081090">link</a>   </div></div><div class="thread_post_body">the defense this year is night and day, so is the OL. The team is better. That is why we have a better record.<br />
<br />
If you don't think Barkley makes our offense significantly better and would have added another win or two, not sure what else to tell you.<br />
<br />
You can't just compare Barkley to this year and last. The team and coaching are completely and utterly different.</div></div><div class="thread_post"><div class="thread_post_header"><b>Did you ever notice that when someone types  </b><a name="15081120">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LBH15"> LBH15 </a>  :  12/15/2020  1:59 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081120">link</a>   </div></div><div class="thread_post_body">"... not sure what else to tell you" in their posts, that there is almost always something else they wind up telling.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>. </b><a name="15081129">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  12/15/2020  2:07 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081129">link</a>   </div></div><div class="thread_post_body">If I were running the Giants I'd be looking to draft another quarterback.  I doubt that happens.  But I don't discount the possibility of them pursuing a veteran who may be looking at a change of scenery this offseason.  Some names to keep in mind are Matt Stafford, Jimmy Garropolo, Derek Carr, Ryan Fitzpatrick, Andy Dalton, and Jameis Winston.  If you look in Spotrac, all of those guys either have a possible out after 2020, or are FAs.<br />
<br />
If they choose to go another direction at QB, I'd expect one of those names to be the direction.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: I think the idea of a veteran QB is interesting.. </b><a name="15081134">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=christian"> christian </a>  :  12/15/2020  2:13 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081134">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081058" target="_blank">15081058</a> LBH15 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">Also a reasonable scenario you do a mix of both. Sign a vet in the offseason but give Jones the starter's job and enough rope to see if he hangs himself. If he improves then we keep going. If he doesn't move onto the experienced vet before midseason.<br />
<br />
Seems like given the poor shape of the division, the Giants shouldn't just give up on 2021 to win it with an experienced backup. </td>
                                </tr>
                           </table><br />
<br />
Oh I agree, I was directly responding to the idea of signing a Stafford/Ryan type to a multiyear deal a la Kerry Collins. Rivers is pulling 25M a year - I don't want any part of that yet.<br />
<br />
I think the Giants should sign a Nick Mullens type vet, who's proven in the right circumstances can be a game manager on a good team. And if Jones isn't better than a dude like that in his 3rd year, you replace him.</div></div><div class="thread_post"><div class="thread_post_header"><b>I'd love to see what Judge could do with  </b><a name="15081136">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=NoGainDayne"> NoGainDayne </a>  :  12/15/2020  2:16 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081136">link</a>   </div></div><div class="thread_post_body">Winston. He seems to have a good blend of authoritarianism and an understanding of modern players that might work well for Winston (normally you have one or the other, I think Tomlin is the best example of a coach that is both) <br />
<br />
I like the idea of Fitzpatrick and taking a flier on Stafford too. Jimmy G and Dalton don't have the upside I'd be looking for. With the Giants roster where it's at IMO you want someone that could be a threat at QB not a game manager.</div></div><div class="thread_post"><div class="thread_post_header"><b>I don't love Winston,  </b><a name="15081160">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  12/15/2020  3:02 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081160">link</a>   </div></div><div class="thread_post_body">but he's an upgrade over Jones in that while he'll turn the ball over he will also put points on the board.  He also would cost next to nothing given his lack of playing time this year.<br />
<br />
I wonder about Garoppolo given the New England connection...he and Judge overlapped in NE for Garoppolo's entire time there (2014-2017).<br />
<br />
I just have a hard time imagining Judge is content with Jones as the sole option in 2021.  Judge's entire mantra has been about improving as the year goes along - Jones did show some improvement but how much was it really when he's created 9 total TDs all season?</div></div><div class="thread_post"><div class="thread_post_header"><b>I just don’t see Judge wanting Winston.. </b><a name="15081166">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sean"> Sean </a>  :  12/15/2020  3:08 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081166">link</a>   </div></div><div class="thread_post_body">The reason Jones would be moved off is because of the turnovers. Judge & the NE philosophy doesn’t not equate to “no risk it, no biscuit” which is the issue we are now seeing with Brady in Tampa.<br />
<br />
I’d imagine Judge wants a QB who can execute the game plan and make minimal mistakes.</div></div><div class="thread_post"><div class="thread_post_header"><b>I think the QB position is the biggest opportunity to  </b><a name="15081179">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=NoGainDayne"> NoGainDayne </a>  :  12/15/2020  3:27 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081179">link</a>   </div></div><div class="thread_post_body">get value on reclamation projects and control for the wins of a team. <br />
<br />
I'd call 5-8 wins the worst zone to be in and while it's perfectly acceptable to shoot higher and end up there, I think making decisions in which you are steering yourself towards mediocrity seems non-ideal. Dalton and Jimmy G seem like that kind of decision to me and IMO won't come cheap relative to their value. <br />
<br />
Not saying it's what the Giants would do. The Giants seem very comfortable building a team that has a realistic ceiling of 7 or 8 wins. I think much like the NBA, the NFL is going in that direction, forecasting on 3-5 year horizons would absolutely favor pure asset accumulation and value oriented contract decisions along these lines. IMO the idea that you have to do everything you can to win is more about owners pride than fans, no one wants to throw games but there is nothing wrong with avoiding FA deals and things like trading draft picks for players until you've at least locked down your QB or have a clear path to a top 5 pick and know there will be QBs you like. <br />
<br />
At the end of the day that's why I'm advocating players with high upside relative to value, that may be one of the only ways we can get out of what might be many mediocre years where we have to either hit on all of our picks or get lucky and snag a top QB not at the top of the draft. <br />
<br />
I think Judge is good enough to raise our floor on his own, which isn't necessarily a good thing as most teams that get out of the floor do so with either numerous elite top of the draft talents (IE 49ers or the top of the draft franchise QB) <br />
<br />
We've had top picks but I wouldn't say at all we've stacked elite talent with them.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I just don’t see Judge wanting Winston.. </b><a name="15081180">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  12/15/2020  3:27 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081180">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081166" target="_blank">15081166</a> Sean said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> The reason Jones would be moved off is because of the turnovers. Judge & the NE philosophy doesn’t not equate to “no risk it, no biscuit” which is the issue we are now seeing with Brady in Tampa.<br />
<br />
I’d imagine Judge wants a QB who can execute the game plan and make minimal mistakes. </td>
                                </tr>
                           </table><br />
<br />
I agree.  The names that jump out to me as most likely are Garoppolo, Carr, and Dalton.  If Barkley is back healthy next year then you figure job one is to throw the ball to him out of the backfield on early downs.  Think James White in NE.</div></div><div class="thread_post"><div class="thread_post_header"><b>I can't figure out Jimmy G </b><a name="15081182">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LG+in+NYC"> LG in NYC </a>  :  12/15/2020  3:35 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081182">link</a>   </div></div><div class="thread_post_body">don't like the others.<br />
<br />
though Stafford is very intriguing. so talented.</div></div><div class="thread_post"><div class="thread_post_header"><b>After what I saw last year, I find it hard to believe that Jones  </b><a name="15081186">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Victor+in+CT"> Victor in CT </a>  :  12/15/2020  3:38 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081186">link</a>   </div></div><div class="thread_post_body">suddenly "can't put points on the board". I think he's still unsure in this scheme, and defense not having to account for Barkley allows them to put extra pressure on the WRs who already have trouble getting free. The scheme of running multiple 5 yd. routes is only helping the defense more.</div></div><div class="thread_post"><div class="thread_post_header"><b>Definitely option 1 IMO. </b><a name="15081190">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BelieveJJ"> BelieveJJ </a>  :  12/15/2020  3:48 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081190">link</a>   </div></div><div class="thread_post_body">If the team is as lacking in overall talent as they looked this past Sunday, I don't think it would be wise to flip QBs, justin order to do so.<br />
<br />
Thus team needs more quality personnel at ER, CB, TE, and WR pretty badly. <br />
<br />
I am now in favor of attacking those needs first, and seeing another year of DJ8.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: After what I saw last year, I find it hard to believe that Jones  </b><a name="15081201">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  12/15/2020  4:03 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081201">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081186" target="_blank">15081186</a> Victor in CT said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> suddenly "can't put points on the board". I think he's still unsure in this scheme, and defense not having to account for Barkley allows them to put extra pressure on the WRs who already have trouble getting free. The scheme of running multiple 5 yd. routes is only helping the defense more. </td>
                                </tr>
                           </table><br />
<br />
The Giants only scored 21.3 ppg last year, well below league average. They scored 21 or fewer in 7 of his 12 starts. <br />
<br />
Jones's rookie year was not something to point to as a positive.</div></div><div class="thread_post"><div class="thread_post_header"><b>Yeah, I'm sure Winston would thrive in this offense </b><a name="15081209">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Thunderstruck27"> Thunderstruck27 </a>  :  12/15/2020  4:09 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081209">link</a>   </div></div><div class="thread_post_body">unlike TB we have a dogshit WR corps and a turd of a TE.  He'd set an interception record here.  Oh wait..</div></div><div class="thread_post"><div class="thread_post_header"><b>Sometimes players mature </b><a name="15081214">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=NoGainDayne"> NoGainDayne </a>  :  12/15/2020  4:14 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081214">link</a>   </div></div><div class="thread_post_body">more often then not they don't. <br />
<br />
Not a lot of people would have bet on Kerry Collins, but that worked out well for us. <br />
<br />
Sports is littered with examples of players figuring it out after being a bit boneheaded when they were younger. Collins problems were worse too IMO. <br />
<br />
Overpaying for limited upside isn't the best from a long term game theory perspective. And Dalton is definitely going to cost more than he's worth. Jimmy G already does, as does Carr.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: After what I saw last year, I find it hard to believe that Jones  </b><a name="15081218">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BelieveJJ"> BelieveJJ </a>  :  12/15/2020  4:20 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081218">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081201" target="_blank">15081201</a> Go Terps said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15081186 Victor in CT said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     suddenly "can't put points on the board". I think he's still unsure in this scheme, and defense not having to account for Barkley allows them to put extra pressure on the WRs who already have trouble getting free. The scheme of running multiple 5 yd. routes is only helping the defense more. <br />
                                <br />
                           <br />
<br />
The Giants only scored 21.3 ppg last year, well below league average. They scored 21 or fewer in 7 of his 12 starts. <br />
<br />
Jones's rookie year was not something to point to as a positive. </td>
                                </tr>
                           </table><br />
<br />
But, and its a huge BUT, the scoring AVG with Jones at QB last year is prolly markedly depressed by his plague level of TOs. Just guessing, but I'd bet his TOs were a -5 PPG factor, somewhere in that vicinity.<br />
<br />
Propensity to TOs is definitely correctable.</div></div><div class="thread_post"><div class="thread_post_header"><b>Bengals and Texans </b><a name="15081257">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Thegratefulhead"> Thegratefulhead </a>  :  12/15/2020  4:59 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081257">link</a>   </div></div><div class="thread_post_body">Wont be drafting a QB.  If we end with only 5 wins a good QB will be on the board.  5 wins means we draft ahead of Dallas I believe. then would need the Eagle and Broncos to win a game.  Not rooting for 5 wins but it could happen.</div></div><div class="thread_post"><div class="thread_post_header"><b>Option 1 </b><a name="15081293">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=DavidinBMNY"> DavidinBMNY </a>  :  12/15/2020  5:58 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081293">link</a>   </div></div><div class="thread_post_body">With draft resources bolster the defense and special teams , and add one weapon early and another Rb late.   I'd he happy if they used 2 picks on offense (WR/RB) and the rest on defense.  <br />
<br />
If Jones doesn't develop in year 3 he gets replaced.</div></div><div class="thread_post"><div class="thread_post_header"><b>I wouldn’t bother with a free agent like Stafford... </b><a name="15081296">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=trueblueinpw"> trueblueinpw </a>  :  12/15/2020  6:11 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081296">link</a>   </div></div><div class="thread_post_body">I would absolutely draft a QB1 prospect to come in and compete with Jones for the starting job. I have no idea why a guy like Colt McCoy is on this team. And don’t tell me he’s good in the room and mentoring Jones because that’s a coaches job. Why don’t more teams have legit competition for the QB spot?<br />
<br />
Anyway, yeah, draft a top QB. Worst case is you stick with Turnover Jones and ask him to be a game manager while your draft pick learns the NFL. I don’t know the QBs in the draft or where we will draft but I know we need to get a QB. As others have pointed out, you’re no where in the NFL without a star QB1. Jones ain’t the guy, go fish.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I don't love Winston,  </b><a name="15081313">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Producer"> Producer </a>  :  12/15/2020  6:51 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081313">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081160" target="_blank">15081160</a> Go Terps said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> but he's an upgrade over Jones in that while he'll turn the ball over he will also put points on the board.  He also would cost next to nothing given his lack of playing time this year.<br />
<br />
I wonder about Garoppolo given the New England connection...he and Judge overlapped in NE for Garoppolo's entire time there (2014-2017).<br />
<br />
I just have a hard time imagining Judge is content with Jones as the sole option in 2021.  Judge's entire mantra has been about improving as the year goes along - Jones did show some improvement but how much was it really when he's created 9 total TDs all season? </td>
                                </tr>
                           </table><br />
<br />
It doesn't matter if Winston is an upgrade over Jones, he's a bust, he's not an NFL QB. We should replace Jones with someone we (Judge and company) believe is an NFL QB.  Until then we can play with our own bust.  Someone will come along - maybe even in this next draft. <br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="15081325">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=christian"> christian </a>  :  12/15/2020  7:16 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081325">link</a>   </div></div><div class="thread_post_body">Sean Payton on Jameis Winston:<br />
<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">Jameis is definitely a starter. He’s performed exceptionally well considering the amount of time we’ve had, or haven’t had, since we’ve signed him ...<br />
<br />
He’s going to have that opportunity (to start in New Orleans) the minute Drew leaves.<br />
<br />
</td>
                                </tr>
                           </table></div></div><div class="thread_post"><div class="thread_post_header"><b>.... </b><a name="15081335">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BrettNYG10"> BrettNYG10 </a>  :  12/15/2020  7:31 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081335">link</a>   </div></div><div class="thread_post_body">I'd rather go with Jones than go with some of the options listed here. <br />
<br />
I'd be fine signing someone like Dalton who could step in after 5 or 6 games if Jones sucks.<br />
<br />
I'd rather be 'sure' Jones isn't the guy next season than go with someone who is assuredly mediocre.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: .... </b><a name="15081339">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=christian"> christian </a>  :  12/15/2020  7:40 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081339">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081335" target="_blank">15081335</a> BrettNYG10 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I'd rather go with Jones than go with some of the options listed here. <br />
<br />
I'd be fine signing someone like Dalton who could step in after 5 or 6 games if Jones sucks.<br />
<br />
I'd rather be 'sure' Jones isn't the guy next season than go with someone who is assuredly mediocre. </td>
                                </tr>
                           </table><br />
<br />
One way to be sure is with Jones is a counter metric -- like "Is Nick Mullens as successful in the same circumstances."<br />
<br />
It's what the Giants should have learned from Geno Smith, but instead got their feelings hurt and put on their Eli Manning jammies with the feet.</div></div><div class="thread_post"><div class="thread_post_header"><b>.... </b><a name="15081351">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BrettNYG10"> BrettNYG10 </a>  :  12/15/2020  7:50 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081351">link</a>   </div></div><div class="thread_post_body">That's a great point, Christian. I'd be happy with a signing like that.</div></div><div class="thread_post"><div class="thread_post_header"><b>...... </b><a name="15081352">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Route+9"> Route 9 </a>  :  12/15/2020  7:50 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081352">link</a>   </div></div><div class="thread_post_body">Weird condescending talk (of course) from christian in connection with Eli Manning who is a Giant legend. Care to do the same for some fumbling machine in his second year? <br />
<br />
Quit comparing the two.</div></div><div class="thread_post"><div class="thread_post_header"><b>Giants will win the NFC East at 7-9 </b><a name="15081353">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=YorkAveGiant"> YorkAveGiant </a>  :  12/15/2020  7:51 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081353">link</a>   </div></div><div class="thread_post_body">and be off to future SuperBowl races with Jones leading the way.</div></div><div class="thread_post"><div class="thread_post_header"><b>Eli matters </b><a name="15081361">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  12/15/2020  8:05 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081361">link</a>   </div></div><div class="thread_post_body">His influence still lingers over the organization's thinking. The desire to reproduce him was always going to be a danger.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Eli matters </b><a name="15081371">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sean"> Sean </a>  :  12/15/2020  8:13 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081371">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081361" target="_blank">15081361</a> Go Terps said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> His influence still lingers over the organization's thinking. The desire to reproduce him was always going to be a danger. </td>
                                </tr>
                           </table><br />
<br />
True, but Daniel Jones is not in the same universe as Eli as a player.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Eli matters </b><a name="15081375">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  12/15/2020  8:17 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081375">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081371" target="_blank">15081371</a> Sean said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15081361 Go Terps said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     His influence still lingers over the organization's thinking. The desire to reproduce him was always going to be a danger. <br />
                                <br />
                           <br />
<br />
True, but Daniel Jones is not in the same universe as Eli as a player. </td>
                                </tr>
                           </table><br />
<br />
Exactly. Not the same level, and not the same skill set. He's an athlete that can throw.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: ...... </b><a name="15081376">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=christian"> christian </a>  :  12/15/2020  8:19 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081376">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081352" target="_blank">15081352</a> Route 9 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Weird condescending talk (of course) from christian in connection with Eli Manning who is a Giant legend. Care to do the same for some fumbling machine in his second year? <br />
<br />
Quit comparing the two. </td>
                                </tr>
                           </table><br />
<br />
Multivariate testing would be wise. It’s what the Giants should have done with Manning. Not a comparison of the players, comparison of the situation.<br />
<br />
My criticism was never of Manning, just the Giants (and their fans).</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Eli matters </b><a name="15081377">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=trueblueinpw"> trueblueinpw </a>  :  12/15/2020  8:20 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081377">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081361" target="_blank">15081361</a> Go Terps said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> His influence still lingers over the organization's thinking. The desire to reproduce him was always going to be a danger. </td>
                                </tr>
                           </table><br />
<br />
Not even kidding, I was just thinking this today. Would a guy with Jones pedigree and accomplishment at Duke, exactly the same numbers on the field, same endorsement from Cutclif and the exact same combine number, etc...But let’s say the guy looks like say Andy Dalton. Would the Giants draft him? And forget about the race thing, I’m not even going there, just the fact that DJ looks so much like Eli. We’ll never know...</div></div><div class="thread_post"><div class="thread_post_header"><b>The other thing about Eli </b><a name="15081378">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  12/15/2020  8:23 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081378">link</a>   </div></div><div class="thread_post_body">His type of quarterback is approaching extinction. College isn't producing the linemen required to keep passers in the pocket exclusively, and the quarterbacks and coaches are adapting. That's why the Garrett hire was questionable.</div></div><div class="thread_post"><div class="thread_post_header"><b>...... </b><a name="15081381">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Route+9"> Route 9 </a>  :  12/15/2020  8:27 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081381">link</a>   </div></div><div class="thread_post_body">Again, it was because the benching was for Geno Smith, who lost. I still don't understand how you geniuses get that, even three years later...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Eli matters </b><a name="15081383">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  12/15/2020  8:29 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081383">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081361" target="_blank">15081361</a> Go Terps said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> His influence still lingers over the organization's thinking. The desire to reproduce him was always going to be a danger. </td>
                                </tr>
                           </table><br />
<br />
Truer words were never spoken.<br />
<br />
Of course, FMiC claims I was trafficking in conspiracy theories with this idea, but just connect all the dots leading into the 2019 draft and you really have to be from the Island of Silly to not conclude Jints Central was looking for Eli 2.0.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: ...... </b><a name="15081385">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=christian"> christian </a>  :  12/15/2020  8:34 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081385">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081381" target="_blank">15081381</a> Route 9 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Again, it was because the benching was for Geno Smith, who lost. I still don't understand how you geniuses get that, even three years later... </td>
                                </tr>
                           </table><br />
<br />
I think you're missing the point. When Geno Smith played roughly the same quality of football as Manning, it should have been obvious to the Giants Manning was out of tread.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Eli matters </b><a name="15081389">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  12/15/2020  8:42 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081389">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081383" target="_blank">15081383</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15081361 Go Terps said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     His influence still lingers over the organization's thinking. The desire to reproduce him was always going to be a danger. <br />
                                <br />
                           <br />
<br />
Truer words were never spoken.<br />
<br />
Of course, FMiC claims I was trafficking in conspiracy theories with this idea, but just connect all the dots leading into the 2019 draft and you really have to be from the Island of Silly to not conclude Jints Central was looking for Eli 2.0. </td>
                                </tr>
                           </table><br />
<br />
I'd bet money that Gettleman didn't have first or second days grades on Lamar Jackson or Kyler Murray. They're not 6'5" pocket QBs. Imagine that.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: Eli matters </b><a name="15081394">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Producer"> Producer </a>  :  12/15/2020  8:56 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081394">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081389" target="_blank">15081389</a> Go Terps said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15081383 bw in dc said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     In comment 15081361 Go Terps said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     His influence still lingers over the organization's thinking. The desire to reproduce him was always going to be a danger. <br />
                                <br />
                           <br />
<br />
Truer words were never spoken.<br />
<br />
Of course, FMiC claims I was trafficking in conspiracy theories with this idea, but just connect all the dots leading into the 2019 draft and you really have to be from the Island of Silly to not conclude Jints Central was looking for Eli 2.0. <br />
                                <br />
                           <br />
<br />
I'd bet money that Gettleman didn't have first or second days grades on Lamar Jackson or Kyler Murray. They're not 6'5" pocket QBs. Imagine that. </td>
                                </tr>
                           </table><br />
<br />
Of course.. you have to design the system around those guys.The Giants have made no effort and no appearance of doing such a thing.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: Eli matters </b><a name="15081397">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  12/15/2020  8:58 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081397">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081389" target="_blank">15081389</a> Go Terps said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br />
I'd bet money that Gettleman didn't have first or second days grades on Lamar Jackson or Kyler Murray. They're not 6'5" pocket QBs. Imagine that. </td>
                                </tr>
                           </table><br />
<br />
Speaking of Murray, and I brought this up the other day, it's really interesting how a guy who is 5'7" - I don't believe he's 5'10" - can scan the field with poise, go through his progressions and deliver strikes all over the field.<br />
<br />
Then there is 6'5" Daniel Jones...</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="15081400">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=christian"> christian </a>  :  12/15/2020  9:02 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081400">link</a>   </div></div><div class="thread_post_body">What’s the Giants design for Jones? Deeply flawed passing blocking line, backs and TEs who struggle in pass pro, and WRs that struggle to separate?</div></div><div class="thread_post"><div class="thread_post_header"><b>Just scattershooting  </b><a name="15081404">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Rick+in+Dallas"> Rick in Dallas </a>  :  12/15/2020  9:05 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081404">link</a>   </div></div><div class="thread_post_body">Can you imagine what BBI would be like if the Giants drafted Dwayne Haskins at QB instead of Jones.<br />
This place would have exploded off the internet.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Just scattershooting  </b><a name="15081407">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Producer"> Producer </a>  :  12/15/2020  9:08 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081407">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081404" target="_blank">15081404</a> Rick in Dallas said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Can you imagine what BBI would be like if the Giants drafted Dwayne Haskins at QB instead of Jones.<br />
This place would have exploded off the internet. </td>
                                </tr>
                           </table><br />
<br />
I have news for you.. Daniel Jones is just as bad as Dwayne Haskins. The only difference is Washington doesn't want to deal with him anymore.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Just scattershooting  </b><a name="15081410">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  12/15/2020  9:13 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081410">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081404" target="_blank">15081404</a> Rick in Dallas said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Can you imagine what BBI would be like if the Giants drafted Dwayne Haskins at QB instead of Jones.<br />
This place would have exploded off the internet. </td>
                                </tr>
                           </table><br />
<br />
And I would have led that charge. Haskins was/is a fraud.<br />
<br />
I didn't like the Jones pick, but at least he wasn't Haskins.</div></div><div class="thread_post"><div class="thread_post_header"><b>Producer your such an idiot  </b><a name="15081411">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Rick+in+Dallas"> Rick in Dallas </a>  :  12/15/2020  9:17 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081411">link</a>   </div></div><div class="thread_post_body">Enough said.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Producer your such an idiot  </b><a name="15081414">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Producer"> Producer </a>  :  12/15/2020  9:23 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081414">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081411" target="_blank">15081411</a> Rick in Dallas said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Enough said. </td>
                                </tr>
                           </table><br />
<br />
just going by the 2020 stats.. that doesn't make me an idiot, but it shows you have a thin skin about the matter.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Producer your such an idiot  </b><a name="15081416">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BrettNYG10"> BrettNYG10 </a>  :  12/15/2020  9:24 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081416">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081411" target="_blank">15081411</a> Rick in Dallas said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Enough said. </td>
                                </tr>
                           </table><br />
<br />
*You're</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: ... </b><a name="15081427">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+from+Katonah"> Jim from Katonah </a>  :  12/15/2020  9:42 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081427">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081400" target="_blank">15081400</a> christian said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> What’s the Giants design for Jones? Deeply flawed passing blocking line, backs and TEs who struggle in pass pro, and WRs that struggle to separate? </td>
                                </tr>
                           </table><br />
<br />
Maybe the design could be conservative/ball control-based — but it keeps getting blown up because Jones can’t see pass rushers or hang onto the ball.  It’s not a one game problem, or bad luck. It’s been a problem in 21 of his 24 career starts (and a continuation of his problems at Duke).</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: ...... </b><a name="15081436">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Route+9"> Route 9 </a>  :  12/15/2020  10:06 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081436">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081385" target="_blank">15081385</a> christian said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I think you're missing the point. When Geno Smith played roughly the same quality of football as Manning, it should have been obvious to the Giants Manning was out of tread. </td>
                                </tr>
                           </table><br />
<br />
The only difference I noticed was Engram put out more of an effort in the Geno game and made catches he wasn't making all year long. Geno fumbled a couple times, didn't he? The big plays were from Evan engram and Sterling Shepard that day. Not Geno.   <br />
<br />
Eli wasn't supposed to be the one carrying the Giants in 2017, that was obvious. It was going to be the defense's mission to win games heading into the season and let's not forget the offense revolved around OBJ being on the field.</div></div><div class="thread_post"><div class="thread_post_header"><b>...... </b><a name="15081441">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Route+9"> Route 9 </a>  :  12/15/2020  10:10 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081441">link</a>   </div></div><div class="thread_post_body">And again, its not the issue with moving on from Eli. It's the benching for Geno Smith that was unnecessary and was idiotic. <br />
<br />
You're pretending it hurt feelings or whatever. <br />
<br />
But I ask are you saying the same with McCoy and Jones? We know that we shouldn't expect anything out of Colt and he did what he had to in Seattle. <br />
<br />
Daniel Jones is a 6th overall pick. There's sort of a justifiable need to be restless when it comes to wanting to see him do something, or not fumble 3 times a game.</div></div><div class="thread_post"><div class="thread_post_header"><b>Never understood the notion about Geno Smith.. </b><a name="15081443">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sean"> Sean </a>  :  12/15/2020  10:19 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081443">link</a>   </div></div><div class="thread_post_body">Why does it matter that he started? He’s still in the NFL as a serviceable backup in Seattle, we never saw him in practice, he was young. Why is it so outrageous that he got the chance to start? He was on the roster.<br />
<br />
I’m on an island with that take, but I’ve felt that was since it happened.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: Eli matters </b><a name="15081446">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Zeke%27s+Alibi"> Zeke's Alibi </a>  :  12/15/2020  10:29 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081446">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081397" target="_blank">15081397</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15081389 Go Terps said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     <br />
I'd bet money that Gettleman didn't have first or second days grades on Lamar Jackson or Kyler Murray. They're not 6'5" pocket QBs. Imagine that. <br />
                                <br />
                           <br />
<br />
Speaking of Murray, and I brought this up the other day, it's really interesting how a guy who is 5'7" - I don't believe he's 5'10" - can scan the field with poise, go through his progressions and deliver strikes all over the field.<br />
<br />
Then there is 6'5" Daniel Jones... </td>
                                </tr>
                           </table><br />
<br />
Kyler Murray is at least 5 9 and it’s not even questionable.  Now I truly know people see whatever they want to see.</div></div><div class="thread_post"><div class="thread_post_header"><b>Fumble Machine </b><a name="15081447">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Daddy"> Big Daddy </a>  :  12/15/2020  10:29 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081447">link</a>   </div></div><div class="thread_post_body">new qb because the machine will keep fumbling. <br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Never understood the notion about Geno Smith.. </b><a name="15081448">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  12/15/2020  10:33 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081448">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081443" target="_blank">15081443</a> Sean said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Why does it matter that he started? He’s still in the NFL as a serviceable backup in Seattle, we never saw him in practice, he was young. Why is it so outrageous that he got the chance to start? He was on the roster.<br />
<br />
I’m on an island with that take, but I’ve felt that was since it happened. </td>
                                </tr>
                           </table><br />
<br />
You're not alone, believe me. <br />
<br />
But it was psychological and showed how fragile the fan base and media were/are. You see, they wanted it to be a romantic transition where the heir apparent took the baton from Eli. Not a journeyman like Smith. That was viewed as the ultimate insult. So all hell broke lose...and the rest was bad history.<br />
<br />
To this day I'm convinced that was the catalyst to giving Eli a second chance; which led to the hiring of the Eli Reclamation Project Crew - Gettleman and Shurmur.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Never understood the notion about Geno Smith.. </b><a name="15081449">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Producer"> Producer </a>  :  12/15/2020  10:39 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081449">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081448" target="_blank">15081448</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15081443 Sean said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Why does it matter that he started? He’s still in the NFL as a serviceable backup in Seattle, we never saw him in practice, he was young. Why is it so outrageous that he got the chance to start? He was on the roster.<br />
<br />
I’m on an island with that take, but I’ve felt that was since it happened. <br />
                                <br />
                           <br />
<br />
You're not alone, believe me. <br />
<br />
But it was psychological and showed how fragile the fan base and media were/are. You see, they wanted it to be a romantic transition where the heir apparent took the baton from Eli. Not a journeyman like Smith. That was viewed as the ultimate insult. So all hell broke lose...and the rest was bad history.<br />
<br />
To this day I'm convinced that was the catalyst to giving Eli a second chance; which led to the hiring of the Eli Reclamation Project Crew - Gettleman and Shurmur.<br />
 </td>
                                </tr>
                           </table><br />
<br />
The problem the Giants had at the time was there were no decent NFL QBs on the roster. Eli, once a near elite QB was a shadow of his former self. And Geno was already shown to be bad in his brief NFL stint. They literally had nobody who could play the position well.</div></div><div class="thread_post"><div class="thread_post_header"><b>...... </b><a name="15081454">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Route+9"> Route 9 </a>  :  12/15/2020  10:52 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081454">link</a>   </div></div><div class="thread_post_body">This weird fragile talk could be said about Daniel Jones and any criticism coming his way. I'm saying the Eli response made some sense because he proved something during his tenure as a Giant. <br />
<br />
Daniel Jones has done .... what?<br />
<br />
This is all a response to someone else bringing up the Eli/Geno saga from three years ago out of nowhere.</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="15081455">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=christian"> christian </a>  :  12/15/2020  10:52 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081455">link</a>   </div></div><div class="thread_post_body">The point isn’t why they benched Manning or for whom.<br />
<br />
The point is a replacement level QB did roughly as well in the same circumstances. They should have kept playing him just to be sure.<br />
<br />
That’s how an experiment works. Given the same circumstances Eli Manning = Geno Smith. And that was evidence to call it, and move on. Instead they just hid in the sand and pretended things would be better.<br />
<br />
If the opportunity to test Jones in the same way presents itself, of course they should.<br />
<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Part of the problem is that there isn't much desire for competition </b><a name="15081459">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  12/15/2020  11:11 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081459">link</a>   </div></div><div class="thread_post_body">Starting quarterback is treated like an elected position; once you have it you don't have to fight to keep it. Who was brought in to challenge Daniel Jones's place as starter? Colt McCoy? It's the same as with Eli in 2017 and 2018...who was brought in to push him and make him feel pressure? Kyle Lauletta?<br />
<br />
That's why I say I worry that Jones is on scholarship. He was drafted to be the heir apparent, so the job is his regardless of performance. <br /></div></div><div class="thread_post"><div class="thread_post_header"><b>...... </b><a name="15081461">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Route+9"> Route 9 </a>  :  12/15/2020  11:18 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081461">link</a>   </div></div><div class="thread_post_body">Ok. Good and fair enough.</div></div><div class="thread_post"><div class="thread_post_header"><b>This upcoming offseason will be very telling of </b><a name="15081464">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=NoGainDayne"> NoGainDayne </a>  :  12/15/2020  11:23 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081464">link</a>   </div></div><div class="thread_post_body">how much Judge moved the overall thinking in the building. IMO there are still too many "Giants way" voices in the way if they don't bring in real competition at QB. <br />
<br />
Even if Daniel Jones finishes strong (unless that strong finish includes a playoff win) he has shown enough downside that you have to get the competition in at this point. <br />
<br />
Failure to do that would absolutely be an indication that they are trying to force this duplication of "Eli's learning curve" onto Jones and while many disagree on the extent, most can agree that the front office and it's relationship to Eli has been a negative impact over the last 3-4 years at least. Would be hard to stomach watching Jones flounder for an extended period on the hopes that he turns into a beautiful Manning butterfly any day now</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Part of the problem is that there isn't much desire for competition </b><a name="15081466">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Route+9"> Route 9 </a>  :  12/15/2020  11:24 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081466">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081459" target="_blank">15081459</a> Go Terps said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Starting quarterback is treated like an elected position; once you have it you don't have to fight to keep it. Who was brought in to challenge Daniel Jones's place as starter? Colt McCoy? It's the same as with Eli in 2017 and 2018...who was brought in to push him and make him feel pressure? Kyle Lauletta?<br />
<br />
That's why I say I worry that Jones is on scholarship. He was drafted to be the heir apparent, so the job is his regardless of performance.  </td>
                                </tr>
                           </table><br />
<br />
Eli was 37 years old or whatever. <br />
<br />
This is a 23 year old who was taken with the 6th overall pick in the draft, in his second season. He shouldn't be worried about feeling pressure. He's the guy, I mean, you took him that early on. Something is wrong if he needs a fire lit under his crotch this early on. <br />
<br />
I'm not a fan of Jones and we obviously aren't missing much with or without him.</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="15081467">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=christian"> christian </a>  :  12/15/2020  11:25 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081467">link</a>   </div></div><div class="thread_post_body">I don’t think the Giants will spend more than 2-3M tops for a backup, so I’m not holding my breath for a fierce competition.<br />
<br />
But I’d like to see the Giants sign a Mullens level guy. And if Mullens can exceed a 3rd year Daniel Jones’s production in the same scenario — that’s all I’d need to know.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Part of the problem is that there isn't much desire for competition </b><a name="15081469">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  12/15/2020  11:30 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081469">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081466" target="_blank">15081466</a> Route 9 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15081459 Go Terps said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Starting quarterback is treated like an elected position; once you have it you don't have to fight to keep it. Who was brought in to challenge Daniel Jones's place as starter? Colt McCoy? It's the same as with Eli in 2017 and 2018...who was brought in to push him and make him feel pressure? Kyle Lauletta?<br />
<br />
That's why I say I worry that Jones is on scholarship. He was drafted to be the heir apparent, so the job is his regardless of performance.  <br />
                                <br />
                           <br />
<br />
Eli was 37 years old or whatever. <br />
<br />
This is a 23 year old who was taken with the 6th overall pick in the draft, in his second season. He shouldn't be worried about feeling pressure. He's the guy, I mean, you took him that early on. Something is wrong if he needs a fire lit under his crotch this early on. <br />
<br />
I'm not a fan of Jones and we obviously aren't missing much with or without him. </td>
                                </tr>
                           </table><br />
<br />
Yes, Eli was 37 off a terrible year and we brought in Lauletta to "challenge" him. So there was no effort to get better at the position. <br />
<br />
And I'm not interested in lighting a fire under Jones. He is not "the guy" just because he was drafted #6. He has to (or at least should have to) earn the right to be the starting quarterback in 2021. <br />
<br />
Can anyone say with a straight face that Jones has earned the 2021 starting QB job? If he were a UDFA and performed like he has in 2020, would we be handing him the job on 2021?<br />
<br />
No. He's only the starter because he was picked #6 overall. That and no other reason. And the problem with that is it doesn't consider the possibility we fucked up with the pick.</div></div><div class="thread_post"><div class="thread_post_header"><b>Yeah. That was a bad pick.  </b><a name="15081470">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Route+9"> Route 9 </a>  :  12/15/2020  11:35 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081470">link</a>   </div></div><div class="thread_post_body">Did not want.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Yeah. That was a bad pick.  </b><a name="15081472">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  12/15/2020  11:40 pm   : <a href="index.php?mode=2&thread=604160&show_all=1#15081472">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081470" target="_blank">15081470</a> Route 9 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Did not want. </td>
                                </tr>
                           </table><br />
<br />
Maybe it wasn't. Maybe Jones will turn it around. But at least make him earn it. Stop populating the quarterback room with guys that don't threaten his job. If he gets beat, then great, you've got him as a viable backup. But make him earn it.</div></div><div class="thread_post"><div class="thread_post_header"><b>...... </b><a name="15081480">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Route+9"> Route 9 </a>  : 12:29 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15081480">link</a>   </div></div><div class="thread_post_body">Whom?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: ...... </b><a name="15081485">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  : 12:42 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15081485">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081480" target="_blank">15081480</a> Route 9 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Whom? </td>
                                </tr>
                           </table><br />
<br />
Jones. I agree that he's almost certainly a very bad pick. But just as bad is that Giants didn't even try to challenge his job this year. They acted like he earned a scholarship in 2019...when he went 3-9 as a starter and played pretty poorly. <br />
<br />
Christ I hope Judge brought significant changes with him.</div></div><div class="thread_post"><div class="thread_post_header"><b>...... </b><a name="15081488">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Route+9"> Route 9 </a>  : 1:06 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15081488">link</a>   </div></div><div class="thread_post_body">I'm asking who would be the ideal backup QB to challenge Jones? Fitzpatrick? Flacco?  just asking who you had your eye on.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: ...... </b><a name="15081490">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  : 1:53 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15081490">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=604160&show_all=1#15081488" target="_blank">15081488</a> Route 9 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I'm asking who would be the ideal backup QB to challenge Jones? Fitzpatrick? Flacco?  just asking who you had your eye on. </td>
                                </tr>
                           </table><br />
<br />
If we're going with a backup to challenge him, and I had to pick one guy, I like Jacoby Brissett. High character guy, good athlete, big arm. Doesn't turn the ball over. That would be my guy to compete with Jones.</div></div><div class="thread_post"><div class="thread_post_header"><b>I think at the absolute least  </b><a name="15081491">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Ned+In+Atlanta"> Ned In Atlanta </a>  : 2:47 am   : <a href="index.php?mode=2&thread=604160&show_all=1#15081491">link</a>   </div></div><div class="thread_post_body">He needs a viable backup who can compete for the job. I worry that if Gettleman returns that his ego will prevent that from happening</div></div><a name="END"><a href="index.php"><div style="padding-top:25px; padding-bottom:20px;"><img src="/images/back_corner.gif" class="thread_link"  alt="Back to the Corner" border="0"></a></div></a></div>
<div class="thread_sidebar_2">

<!-- Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-102">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Corner Forum - Lower 300x250 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1566320450447229"
     data-ad-slot="4189314539"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->

</div>

</div>




<div class="footer">


<p style="width:400px;float:left;"><b>Part of the USA Today Sports Media Group</b><br>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</P>
<P  style="width:400px;float:right; text-align:right;">
All contents (unless otherwise specified) copyright &copy;  1995 - 2020<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Solutions</a>
</P>
<br clear="all">
<div style="float:right;">
<script
    src="https://sucuri.net/monitoring/badge.js"
    data-s="19"
    id="sucuri-s"
    data-i="7b1b29ae50ae6574f2af3875935246e4fa8a805b26"
    data-p="o" - position - l(left) or r(right) or o(relative)
    data-c="l"
    data-t="t"
    ></script>
</div>

</div>


<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->

<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=191-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script></body>
</html>
