<!DOCTYPE html>
<html lang="en">
<head><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
(new Image()).src=pixelURL;}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=191-0&cb=2', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=191-0&cb=1', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=191-0&cb=5', false, [], true, false, true, false);</script>
<title>Mock draft tracker 2.0 is up on Giants.com | Big Blue Interactive </title>


<meta name="keywords" content="ndglbqfkxx">

<meta name="description" content="It is a list of six draft pundits' current projections for whom the Giants will select at 11. Some of the usual suspects of pundits and players are noted. To summarize each listed player's "vote" tally: Rousseau - McShay Pitts - Brugler Smith (2) - CBS, The Draft Network Waddle - PFF Paye - Wilson, CBS The article is linked below. Clearly no one has inside info so they're just projecting need and BPA combos. The more I try to put on my Getty hat to divine Dave's gets... I think it will be Rousseau or Pitts. Gettleman, like Eli Wallach in The Good, The Bad, and The Ugly, likes Big Men. If not for the same reason. Mock draft tracker   - ( New Window )"/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="website" />
<meta property="og:description" content="It is a list of six draft pundits' current projections for whom the Giants will select at 11. Some of the usual suspects of pundits and players are noted. To summarize each listed player's "vote" tally: Rousseau - McShay Pitts - Brugler Smith (2) - CBS, The Draft Network Waddle - PFF Paye - Wilson, CBS The article is linked below. Clearly no one has inside info so they're just projecting need and BPA combos. The more I try to put on my Getty hat to divine Dave's gets... I think it will be Rousseau or Pitts. Gettleman, like Eli Wallach in The Good, The Bad, and The Ugly, likes Big Men. If not for the same reason. Mock draft tracker   - ( New Window )" /> 
<meta property="og:title" content="Mock draft tracker 2.0 is up on Giants.com" /> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif" /> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css?v=20200217" />

<link rel="stylesheet" type="text/css" href="anylink.css" />


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}


div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" alt="for display only">

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type='text/javascript'>
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type='text/javascript' src='https://img.bnqt.com/lib/js/sdpdfphelper.js'></script>
<script type='text/javascript'>
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>


<!-- End DFP SETUP -->  

<!-- End USA Today Code -->





<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-131124163-7";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(function(){
	_gat._createTracker('UA-131124163-7', 'e');
});
_gaq.push(function(){
	_gat._createTracker('UA-38339005-1', 'f');
});
_gaq.push(['e._setDomainName', 'bigblueinteractive.com']);
_gaq.push(['f._setDomainName', 'bigblueinteractive.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod1',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','bigblueinteractive.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://corner.bigblueinteractive.com/index.php?mode=2&thread=605470"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"domain_test_group":20200409,"engaged_time_visit":0,"ezcache_level":0,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"11d0c5b3-8ff3-4f12-6469-1b105187ebdb","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":72600,"response_time_orig":68,"serverid":"54.209.236.125:29142","state":"VA","t_epoch":1611350452,"template_id":126,"time_on_site_visit":0,"url":"https://corner.bigblueinteractive.com/index.php?mode=2\u0026thread=605470","user_id":0,"word_count":4583,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?dcb=191-0&cb=1&v=9" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["11d0c5b3-8ff3-4f12-6469-1b105187ebdb", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>


<body>




<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"></a> <img src="images/xpete.gif" alt="The Corner Forum">

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic -->&nbsp;


<!-- Nov 2019 Leaderboard -->

<!-- Ezoic - Forum Leaderboard (USAT) - top_of_page -->
<div id="ezoic-pub-ad-placeholder-118">
<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->
<div id='usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general'>
     <script type='text/javascript'>
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general');
         });
     </script>
</div>
</div>
<!-- End Ezoic - Forum Leaderboard (USAT) - top_of_page -->



</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://www.amazon.com/?_encoding=UTF8&camp=1789&creative=9325&linkCode=ur2&tag=bigblueintera-20">Amazon.com</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW" >Standings (NFL.com)</a>
<a href="https://www.giants.com/team/stats/" target="_NEW" >Statistics (Giants.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/" >Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'home_view_menu')">Home</a>  
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'forum_view_menu')">Corner Forum</a>
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'gameday_view_menu')">Gameday</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_view_menu')">Team</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_building_view_menu')">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info &amp; History</a> -->
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_info_view_menu')">Giants Info &amp; History</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'infolinks_view_menu')">Info/Links</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'shop_view_menu')">BBI Shop</a>
<li><a href="/index.php?mode=10" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'login_menu')">Log In</a>
</ul>

</div><div id="infoline"> </div>

<a name="END"><a href="index.php"><div style="padding-top:20px; padding-bottom:25px;"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"></a></div></a><div class="thread_container"><div class="thread_left"><div class="thread_body" ><div class="thread_main" ><div class="thread_post_header" >  <h1 style="font-size:18px;">Mock draft tracker 2.0 is up on Giants.com </h1><div class="thread_info"><a href="index.php?mode=5&handle=BelieveJJ"> BelieveJJ </a>  :  1/20/2021  2:01 am</div></div><div class="thread_post_body" > It is a list of six draft pundits' current projections for whom the Giants will select at 11.<br />
<br />
Some of the usual suspects of pundits and players are noted. <br />
<br />
To summarize each listed player's "vote" tally:<br />
<br />
Rousseau - McShay<br />
<br />
Pitts - Brugler<br />
<br />
Smith (2) - CBS, The Draft Network<br />
<br />
Waddle - PFF<br />
<br />
Paye - Wilson, CBS<br />
<br />
The article is linked below.<br />
<br />
Clearly no one has inside info so they're just projecting need and BPA combos.<br />
<br />
The more I try to put on my Getty hat to divine Dave's gets...<br />
<br />
I think it will be Rousseau or Pitts.<br />
<br />
Gettleman, like Eli Wallach in The Good, The Bad, and The Ugly, likes Big Men.<br />
<br />
If not for the same reason.<br />
<br />
<br><a href="https://www.giants.com/news/nfl-mock-draft-order-2021-devonta-smith-alabama-crimson-tide-kyle-pitts-florida"> Mock draft tracker </a>  - (<a href="https://www.giants.com/news/nfl-mock-draft-order-2021-devonta-smith-alabama-crimson-tide-kyle-pitts-florida" target="_NEW"> New Window </a>) </div></div></div></div><div class="thread_right"><div id="ad_side_box">


<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id='usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general'>
     <script type='text/javascript'>
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general');
         });
     </script>
</div>




</div></div><div class="thread_comment_container"><div class="thread_post"><div class="thread_post_header"><b>“Noquads” </b><a name="15128609">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=monstercoo"> monstercoo </a>  :  1/20/2021  2:21 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128609">link</a>   </div></div><div class="thread_post_body"><img src="https://static.clubs.nfl.com/image/private/t_new_photo_album/giants/lfmkdycim6hesmfsf7x4.jpg"><br />
<br />
Wow, Devonta Smith is the total opposite of what Saquan Barkely is. If he gets drafted here, I think they might call him Noquads.</div></div><div class="thread_post"><div class="thread_post_header"><b>LOL. </b><a name="15128611">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BelieveJJ"> BelieveJJ </a>  :  1/20/2021  2:27 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128611">link</a>   </div></div><div class="thread_post_body">The human toothpick. Or what a buddy of mine used to call the dog breed Airdale, the "two dimensional dog." From the head on view, they disappear.</div></div><div class="thread_post"><div class="thread_post_header"><b>Didn’t realize he was that thin! </b><a name="15128621">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Simms11"> Simms11 </a>  :  1/20/2021  6:28 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128621">link</a>   </div></div><div class="thread_post_body">He’d get snapped like a twig in the NFL.</div></div><div class="thread_post"><div class="thread_post_header"><b>Honestly, how could they </b><a name="15128623">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=section125"> section125 </a>  :  1/20/2021  6:41 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128623">link</a>   </div></div><div class="thread_post_body">have a clue until FA?  To me, with the players expected to be at 11 you have to look at one of the CBs, Pitts or one of the WRs. Because of the ankle and the immediate need, I think Waddle is not a realistic choice - see what happened to OBJ after his ankle.</div></div><div class="thread_post"><div class="thread_post_header"><b>I cant believe... </b><a name="15128625">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Capt.+Don"> Capt. Don </a>  :  1/20/2021  6:42 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128625">link</a>   </div></div><div class="thread_post_body">That they found two people who think Smith will last to 11.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I cant believe... </b><a name="15128635">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=M.S."> M.S. </a>  :  1/20/2021  7:17 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128635">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128625" target="_blank">15128625</a> Capt. Don said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> That they found two people who think Smith will last to 11. </td>
                                </tr>
                           </table><br />
Took the words right out of my mouth!</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I cant believe... </b><a name="15128637">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=TommyWiseau"> TommyWiseau </a>  :  1/20/2021  7:31 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128637">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128625" target="_blank">15128625</a> Capt. Don said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> That they found two people who think Smith will last to 11. </td>
                                </tr>
                           </table><br />
<br />
Crazier things have happened but I would not hold my breath</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Honestly, how could they </b><a name="15128641">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+in+Tampa"> Jim in Tampa </a>  :  1/20/2021  7:46 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128641">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128623" target="_blank">15128623</a> section125 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> have a clue until FA?  To me, with the players expected to be at 11 you have to look at one of the CBs, Pitts or one of the WRs. Because of the ankle and the immediate need, I think Waddle is not a realistic choice - see what happened to OBJ after his ankle. </td>
                                </tr>
                           </table><br />
I don't think one can lump all ankle injuries together and come to the conclusion that Waddle won't fully recover, just because of "what happened to OBJ".<br />
<br />
Recovery time for Waddle was supposed to be 10-12 weeks and it's now been just over 12 weeks.  He'll have another 3 months to recover before the draft, which is plenty of time for teams to evaluate him.<br />
<br />
Waddle is actually the player that excites me the most, but if he was gone (or not considered to be fully recovered) I'd be tempted to take a chance on Rousseau.</div></div><div class="thread_post"><div class="thread_post_header"><b>Want no part of Waddle </b><a name="15128644">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=The_Boss"> The_Boss </a>  :  1/20/2021  8:03 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128644">link</a>   </div></div><div class="thread_post_body">I’d take Farley before Paye if Surtain isn’t available. No shot Smith makes it to 11. I’d be fine with Rousseau or Pitts.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Honestly, how could they </b><a name="15128650">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=FranknWeezer"> FranknWeezer </a>  :  1/20/2021  8:18 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128650">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128641" target="_blank">15128641</a> Jim in Tampa said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15128623 section125 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     have a clue until FA?  To me, with the players expected to be at 11 you have to look at one of the CBs, Pitts or one of the WRs. Because of the ankle and the immediate need, I think Waddle is not a realistic choice - see what happened to OBJ after his ankle. <br />
                                <br />
                           <br />
I don't think one can lump all ankle injuries together and come to the conclusion that Waddle won't fully recover, just because of "what happened to OBJ".<br />
<br />
Recovery time for Waddle was supposed to be 10-12 weeks and it's now been just over 12 weeks.  He'll have another 3 months to recover before the draft, which is plenty of time for teams to evaluate him.<br />
<br />
Waddle is actually the player that excites me the most, but if he was gone (or not considered to be fully recovered) I'd be tempted to take a chance on Rousseau. </td>
                                </tr>
                           </table><br />
<br />
Just my take, but I have a hard time seeing this regime (particularly Judge) greenlighting the #11 pick in the draft for a player who opted out this season. Certainly could be wrong.</div></div><div class="thread_post"><div class="thread_post_header"><b>BBI on Smith: </b><a name="15128655">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=81_Great_Dane"> 81_Great_Dane </a>  :  1/20/2021  8:28 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128655">link</a>   </div></div><div class="thread_post_body">Too thin for the NFL, won’t survive the punishment. Also, certain to be a top-10 pick.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I cant believe... </b><a name="15128656">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=KDavies"> KDavies </a>  :  1/20/2021  8:36 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128656">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128625" target="_blank">15128625</a> Capt. Don said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> That they found two people who think Smith will last to 11. </td>
                                </tr>
                           </table><br />
<br />
Believe it or not, I have seen a couple recent mock drafts that had him between 20-25</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: Honestly, how could they </b><a name="15128660">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+in+Tampa"> Jim in Tampa </a>  :  1/20/2021  8:41 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128660">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128650" target="_blank">15128650</a> FranknWeezer said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15128641 Jim in Tampa said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     In comment 15128623 section125 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     have a clue until FA?  To me, with the players expected to be at 11 you have to look at one of the CBs, Pitts or one of the WRs. Because of the ankle and the immediate need, I think Waddle is not a realistic choice - see what happened to OBJ after his ankle. <br />
                                <br />
                           <br />
I don't think one can lump all ankle injuries together and come to the conclusion that Waddle won't fully recover, just because of "what happened to OBJ".<br />
<br />
Recovery time for Waddle was supposed to be 10-12 weeks and it's now been just over 12 weeks.  He'll have another 3 months to recover before the draft, which is plenty of time for teams to evaluate him.<br />
<br />
Waddle is actually the player that excites me the most, but if he was gone (or not considered to be fully recovered) I'd be tempted to take a chance on Rousseau. <br />
                                <br />
                           <br />
<br />
Just my take, but I have a hard time seeing this regime (particularly Judge) greenlighting the #11 pick in the draft for a player who opted out this season. Certainly could be wrong. </td>
                                </tr>
                           </table><br />
Of course none of us know how the Giants feel about the "opt-outs", but we also don't know Rousseau's reason for opting out.  Perhaps he had a close family member with a pre-existing condition that would have put them at high risk.  Maybe he was just concerned about his own health and didn't want to risk his career.<br />
<br />
I would hope that Judge and the Giants don't apply a "quitter" label to the entire group of college players who made what I'm sure was a tough decision to "opt out".<br />
<br />
Remember these are "unpaid" college kids and not slacker pros like Beal, who were still paid.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: Honestly, how could they </b><a name="15128666">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=KDavies"> KDavies </a>  :  1/20/2021  8:49 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128666">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128660" target="_blank">15128660</a> Jim in Tampa said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15128650 FranknWeezer said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     In comment 15128641 Jim in Tampa said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     In comment 15128623 section125 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     have a clue until FA?  To me, with the players expected to be at 11 you have to look at one of the CBs, Pitts or one of the WRs. Because of the ankle and the immediate need, I think Waddle is not a realistic choice - see what happened to OBJ after his ankle. <br />
                                <br />
                           <br />
I don't think one can lump all ankle injuries together and come to the conclusion that Waddle won't fully recover, just because of "what happened to OBJ".<br />
<br />
Recovery time for Waddle was supposed to be 10-12 weeks and it's now been just over 12 weeks.  He'll have another 3 months to recover before the draft, which is plenty of time for teams to evaluate him.<br />
<br />
Waddle is actually the player that excites me the most, but if he was gone (or not considered to be fully recovered) I'd be tempted to take a chance on Rousseau. <br />
                                <br />
                           <br />
<br />
Just my take, but I have a hard time seeing this regime (particularly Judge) greenlighting the #11 pick in the draft for a player who opted out this season. Certainly could be wrong. <br />
                                <br />
                           <br />
Of course none of us know how the Giants feel about the "opt-outs", but we also don't know Rousseau's reason for opting out.  Perhaps he had a close family member with a pre-existing condition that would have put them at high risk.  Maybe he was just concerned about his own health and didn't want to risk his career.<br />
<br />
I would hope that Judge and the Giants don't apply a "quitter" label to the entire group of college players who made what I'm sure was a tough decision to "opt out".<br />
<br />
Remember these are "unpaid" college kids and not slacker pros like Beal, who were still paid. </td>
                                </tr>
                           </table><br />
<br />
So, it's fine to judge Beal harshly for opting out, yet the Giants shouldn't take a college player opting out into consideration?   I disagree with this.<br />
<br />
In reality, Rousseau has a limited track record.  One good season.  By the time he is drafted, it will be more than a year and a half since he played football.  Those are serious considerations a front office has to take into account.</div></div><div class="thread_post"><div class="thread_post_header"><b>Of that list... </b><a name="15128673">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  1/20/2021  8:57 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128673">link</a>   </div></div><div class="thread_post_body">Paye is the remote thrower.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Dan Schneier  </b><a name="15128678">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Ned+In+Atlanta"> Ned In Atlanta </a>  :  1/20/2021  9:00 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128678">link</a>   </div></div><div class="thread_post_body">posted something about how the final four teams are top ranked offenses. I really hope they do go all in on offense this offseason for a variety of reasons. With a few additions and resigning hopefully LW and tomlinson the defense as is can compete. Need to flood resources into offense</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: BBI on Smith: </b><a name="15128683">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Mike+from+Ohio"> Mike from Ohio </a>  :  1/20/2021  9:05 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128683">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128655" target="_blank">15128655</a> 81_Great_Dane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Too thin for the NFL, won’t survive the punishment. Also, certain to be a top-10 pick. </td>
                                </tr>
                           </table><br />
<br />
Haha, I was thinking the same thing.  Interesting that people think they are the only ones who may think about his durability at his size.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I cant believe... </b><a name="15128684">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Capt.+Don"> Capt. Don </a>  :  1/20/2021  9:05 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128684">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128656" target="_blank">15128656</a> KDavies said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15128625 Capt. Don said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     That they found two people who think Smith will last to 11. <br />
                                <br />
                           <br />
<br />
Believe it or not, I have seen a couple recent mock drafts that had him between 20-25 </td>
                                </tr>
                           </table><br />
<br />
I definitely believe that and a I also believe there is no chance of that happening. Absolutely none.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Didn’t realize he was that thin! </b><a name="15128685">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=KDavies"> KDavies </a>  :  1/20/2021  9:05 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128685">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128621" target="_blank">15128621</a> Simms11 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> He’d get snapped like a twig in the NFL. </td>
                                </tr>
                           </table><br />
<br />
Interesting he didn't get snapped like a twig in the SEC, which produces quite a bit of NFL talent.  Saban has praised his toughness and blocking effort.  Our own McKinney has praised his toughness as well.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Didn’t realize he was that thin! </b><a name="15128697">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Capt.+Don"> Capt. Don </a>  :  1/20/2021  9:18 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128697">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128685" target="_blank">15128685</a> KDavies said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15128621 Simms11 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     He’d get snapped like a twig in the NFL. <br />
                                <br />
                           <br />
<br />
Interesting he didn't get snapped like a twig in the SEC, which produces quite a bit of NFL talent.  Saban has praised his toughness and blocking effort.  Our own McKinney has praised his toughness as well. </td>
                                </tr>
                           </table><br />
<br />
This is a good point and I think the weight and durability correlation is often overstated.<br />
<br />
Sy says that he sees Marvin Harrison who I am confident never lifted a weight. Personally, I see Isaac Bruce - same body type and also enjoyed a long NFL career.</div></div><div class="thread_post"><div class="thread_post_header"><b>Smith reminds me of Diggs and Waddle </b><a name="15128705">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=PatersonPlank"> PatersonPlank </a>  :  1/20/2021  9:25 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128705">link</a>   </div></div><div class="thread_post_body">Smith, Surtain, Waddle, and maybe Rousseau would all be strong pick in my opinion. I don't see Pitts personally.</div></div><div class="thread_post"><div class="thread_post_header"><b>Saban quotes </b><a name="15128707">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=KDavies"> KDavies </a>  :  1/20/2021  9:26 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128707">link</a>   </div></div><div class="thread_post_body">Here is the article I was referencing:<br />
<br />
Head coach Nick Saban said as much after last weekend’s game against Western Carolina.<br />
<br />
“Even though he’s a thin-built guy, he’s really not frail, doesn’t play frail, doesn’t play weak. He plays strong,” Saban said. “He’s got a combination of pretty good quickness and pretty good explosive speed and is a very competitive guy, and I think he uses all those things really, really well. But the way he plays -- some guys are bigger than him but they play small.<br />
<br />
“He doesn’t play small at all. I think it’s just who he is as a competitor and as a person, and that’s the way he’s always been and that’s the way he’s always played. He doesn’t have any issues. He doesn’t get pushed around much.”<br><a href="https://247sports.com/college/alabama/Article/Alabama-Football-Thin-built-WR-DeVonta-Smith-plays-with-physicality-toughness-139268795/"> Link </a> - (<a href="https://247sports.com/college/alabama/Article/Alabama-Football-Thin-built-WR-DeVonta-Smith-plays-with-physicality-toughness-139268795/" target="_NEW"> New Window </a>)</div></div><div class="thread_post"><div class="thread_post_header"><b>He has sprinter calves </b><a name="15128741">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Peter+from+NH+%28formerly+CT%29"> Peter from NH (formerly CT) </a>  :  1/20/2021  9:49 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128741">link</a>   </div></div><div class="thread_post_body">Looked at some pictures of Jerry Rice, Marvin Harrison, Isaac Bruce, DeSean Jackson, Stephon Diggs this morning. They weren't a heck of a lot different. Thin lower legs. He is definitely thinner through the core but usually people develop that as they physically mature.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I cant believe... </b><a name="15128765">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gruber"> Gruber </a>  :  1/20/2021  10:04 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128765">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128625" target="_blank">15128625</a> Capt. Don said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> That they found two people who think Smith will last to 11. </td>
                                </tr>
                           </table><br />
<br />
Isiah Simmons a year ago. Remember the fuss?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: BBI on Smith: </b><a name="15128792">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BelieveJJ"> BelieveJJ </a>  :  1/20/2021  10:19 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128792">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128655" target="_blank">15128655</a> 81_Great_Dane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Too thin for the NFL, won’t survive the punishment. Also, certain to be a top-10 pick. </td>
                                </tr>
                           </table><br />
<br />
Dane - we are nothing, if not inconsistent!<br />
<br />
😉</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Of that list... </b><a name="15128799">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BelieveJJ"> BelieveJJ </a>  :  1/20/2021  10:23 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128799">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128673" target="_blank">15128673</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Paye is the remote thrower.<br />
 </td>
                                </tr>
                           </table><br />
<br />
Personally, I'm not buying Paye for a nanosecond. Remember the Rashan Gary to the Giants rumors back when?</div></div><div class="thread_post"><div class="thread_post_header"><b>So is Smith a top 10 pick or too skinny for the NFL </b><a name="15128829">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=George+from+PA"> George from PA </a>  :  1/20/2021  10:39 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128829">link</a>   </div></div><div class="thread_post_body">I can not imagine he is both.<br />
<br />
Or is it...the team drafting him in top 10 is not concern about his build?</div></div><div class="thread_post"><div class="thread_post_header"><b>I would love Waddle but for me its contingent on </b><a name="15128848">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+in+Forest+Hills"> Jim in Forest Hills </a>  :  1/20/2021  10:53 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128848">link</a>   </div></div><div class="thread_post_body">signing the bigger Z guy so Waddle can man the slot.  If they sign Golloday, then I'd love Waddle.  I'd cut Tate and Shep to free up cash.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Didn’t realize he was that thin! </b><a name="15128853">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Dunedin81"> Dunedin81 </a>  :  1/20/2021  10:59 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128853">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128621" target="_blank">15128621</a> Simms11 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> He’d get snapped like a twig in the NFL. </td>
                                </tr>
                           </table><br />
<br />
“Todd Pinkston build” is not meant to be a compliment.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Of that list... </b><a name="15128856">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Zeke%27s+Alibi"> Zeke's Alibi </a>  :  1/20/2021  11:05 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128856">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128673" target="_blank">15128673</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Paye is the remote thrower.<br />
 </td>
                                </tr>
                           </table><br />
<br />
Me too. I don't get worked up about the draft, usually a couple guys I want, most I could live with, and a couple remote throwers. Erik Flowers and Eli Apple in back to back years was brutal.<br />
<br />
Paye and Rosseau are on that list this year.  The only way you could sell me on Rosseau is if his athleticism is off the charts, but that's going to be tough to find out with no combine.  Surtain, Pitts, and Parsons are leading the charge for me this year.  I could live with one of the WR's, but I think they should be attacked in the middle rounds.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Of that list... </b><a name="15128860">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Zeke%27s+Alibi"> Zeke's Alibi </a>  :  1/20/2021  11:09 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128860">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128799" target="_blank">15128799</a> BelieveJJ said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15128673 bw in dc said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Paye is the remote thrower.<br />
 <br />
                                <br />
                           <br />
<br />
Personally, I'm not buying Paye for a nanosecond. Remember the Rashan Gary to the Giants rumors back when? </td>
                                </tr>
                           </table><br />
<br />
Yeah I feel this is a DG likes big powerful 3/5 techniques, so they'll be taking this type of thing, completely forgetting that they still need to qualify as good players.<br />
<br />
<br />
Apparently he put up really good tape last year, so maybe he was hampered by injury this year?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: So is Smith a top 10 pick or too skinny for the NFL </b><a name="15128861">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BelieveJJ"> BelieveJJ </a>  :  1/20/2021  11:10 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128861">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128829" target="_blank">15128829</a> George from PA said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I can not imagine he is both.<br />
<br />
Or is it...the team drafting him in top 10 is not concern about his build? </td>
                                </tr>
                           </table><br />
<br />
Wait for DG to fall full bloom in love with him at the Senior Bowl, where Smith takes the MVP honors after a 2 TD, 150+ yards game on 4-5 catches...</div></div><div class="thread_post"><div class="thread_post_header"><b>Waddle </b><a name="15128888">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Carl+in+CT"> Carl in CT </a>  :  1/20/2021  11:30 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15128888">link</a>   </div></div><div class="thread_post_body">Is a better receiver than Smith.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Didn’t realize he was that thin! </b><a name="15128999">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Simms11"> Simms11 </a>  :  1/20/2021  12:56 pm   : <a href="index.php?mode=2&thread=605470&show_all=1#15128999">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128685" target="_blank">15128685</a> KDavies said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15128621 Simms11 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     He’d get snapped like a twig in the NFL. <br />
                                <br />
                           <br />
<br />
Interesting he didn't get snapped like a twig in the SEC, which produces quite a bit of NFL talent.  Saban has praised his toughness and blocking effort.  Our own McKinney has praised his toughness as well. </td>
                                </tr>
                           </table><br />
<br />
Saban should have good info on these guys for Judge of course. He's thin as a pretzel. College game is different then the pros. Size often does matter.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Of that list... </b><a name="15129184">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=jeff57"> jeff57 </a>  :  1/20/2021  3:16 pm   : <a href="index.php?mode=2&thread=605470&show_all=1#15129184">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128673" target="_blank">15128673</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Paye is the remote thrower.<br />
 </td>
                                </tr>
                           </table><br />
<br />
Paye is a 4-3 end.  Doesn’t fit the Giants current scheme.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: Honestly, how could they </b><a name="15129214">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+in+Tampa"> Jim in Tampa </a>  :  1/20/2021  3:37 pm   : <a href="index.php?mode=2&thread=605470&show_all=1#15129214">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128666" target="_blank">15128666</a> KDavies said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15128660 Jim in Tampa said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     In comment 15128650 FranknWeezer said:<br />
<br />
                                <br />
                                     Quote:<br />
Just my take, but I have a hard time seeing this regime (particularly Judge) greenlighting the #11 pick in the draft for a player who opted out this season. Certainly could be wrong. <br />
                                <br />
                           <br />
Of course none of us know how the Giants feel about the "opt-outs", but we also don't know Rousseau's reason for opting out.  Perhaps he had a close family member with a pre-existing condition that would have put them at high risk.  Maybe he was just concerned about his own health and didn't want to risk his career.<br />
<br />
I would hope that Judge and the Giants don't apply a "quitter" label to the entire group of college players who made what I'm sure was a tough decision to "opt out".<br />
<br />
Remember these are "unpaid" college kids and not slacker pros like Beal, who were still paid. <br />
                                <br />
                           <br />
<br />
So, it's fine to judge Beal harshly for opting out, yet the Giants shouldn't take a college player opting out into consideration?   I disagree with this.<br />
<br />
In reality, Rousseau has a limited track record.  One good season.  By the time he is drafted, it will be more than a year and a half since he played football.  Those are serious considerations a front office has to take into account. </td>
                                </tr>
                           </table><br />
I'm mostly annoyed with Beal that he hasn't been able to get on the field for 3 years.  I do however think that there is a big difference between an NFL player opting out and a college player, since one gets paid and the other doesn't.</div></div><div class="thread_post"><div class="thread_post_header"><b>Listened earlier today to the latest Giants Huddle </b><a name="15129311">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BelieveJJ"> BelieveJJ </a>  :  1/20/2021  4:58 pm   : <a href="index.php?mode=2&thread=605470&show_all=1#15129311">link</a>   </div></div><div class="thread_post_body">podcast, a lengthy interview with Rick Serritella of The Draft Bible, a guide that's been around for 20 years and whose authors get some respect from NFL FOs...<br />
<br />
Serritella had some pretty strong opinions about what players would be off the board by pick 11, and the view he had that ran contrary to the mock draft projections above was about receivers. He thinks both Chase and Smith will be off the board before 11, and he thinks <span class="bold">Pitts is a top 5 draft selection!</span><br />
<br />
<br />
😭</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: Honestly, how could they </b><a name="15129319">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Reale01"> Reale01 </a>  :  1/20/2021  5:08 pm   : <a href="index.php?mode=2&thread=605470&show_all=1#15129319">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128650" target="_blank">15128650</a> FranknWeezer said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15128641 Jim in Tampa said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     In comment 15128623 section125 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     have a clue until FA?  To me, with the players expected to be at 11 you have to look at one of the CBs, Pitts or one of the WRs. Because of the ankle and the immediate need, I think Waddle is not a realistic choice - see what happened to OBJ after his ankle. <br />
                                <br />
                           <br />
I don't think one can lump all ankle injuries together and come to the conclusion that Waddle won't fully recover, just because of "what happened to OBJ".<br />
<br />
Recovery time for Waddle was supposed to be 10-12 weeks and it's now been just over 12 weeks.  He'll have another 3 months to recover before the draft, which is plenty of time for teams to evaluate him.<br />
<br />
Waddle is actually the player that excites me the most, but if he was gone (or not considered to be fully recovered) I'd be tempted to take a chance on Rousseau. <br />
                                <br />
                           <br />
<br />
Just my take, but I have a hard time seeing this regime (particularly Judge) greenlighting the #11 pick in the draft for a player who opted out this season. Certainly could be wrong. </td>
                                </tr>
                           </table><br />
<br />
Also loves to put on the big gold 505 neckless on the sideline. asYellow flag for me.</div></div><div class="thread_post"><div class="thread_post_header"><b>Isn't this necklace a trophy for creating a turnover for the 'Canes? </b><a name="15129368">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BelieveJJ"> BelieveJJ </a>  :  1/20/2021  5:54 pm   : <a href="index.php?mode=2&thread=605470&show_all=1#15129368">link</a>   </div></div><div class="thread_post_body"><table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">Also loves to put on the big gold 505 neckless on the sideline. asYellow flag for me.</td>
                                </tr>
                           </table><br />
<br />
Last thing that should be considered is a "yellow flag."</div></div><div class="thread_post"><div class="thread_post_header"><b>Serritella said that in his opinion the ideal guy  </b><a name="15129372">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BelieveJJ"> BelieveJJ </a>  :  1/20/2021  5:58 pm   : <a href="index.php?mode=2&thread=605470&show_all=1#15129372">link</a>   </div></div><div class="thread_post_body">(for the Giants to draft) who might slide out of the top 10 is Micah Parsons.<br />
<br />
He thinks Parsons will run a 4.5 or even faster 40, and suspects that not having a combine might hurt Parsons more than others because he won't be able to demonstrate his outstanding athleticism.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Of that list... </b><a name="15129458">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  1/20/2021  9:04 pm   : <a href="index.php?mode=2&thread=605470&show_all=1#15129458">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128856" target="_blank">15128856</a> Zeke's Alibi said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15128673 bw in dc said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Paye is the remote thrower.<br />
 <br />
                                <br />
                           <br />
<br />
Me too. I don't get worked up about the draft, usually a couple guys I want, most I could live with, and a couple remote throwers. Erik Flowers and Eli Apple in back to back years was brutal.<br />
<br />
Paye and Rosseau are on that list this year.  The only way you could sell me on Rosseau is if his athleticism is off the charts, but that's going to be tough to find out with no combine.  Surtain, Pitts, and Parsons are leading the charge for me this year.  I could live with one of the WR's, but I think they should be attacked in the middle rounds. </td>
                                </tr>
                           </table><br />
<br />
I can buy Rousseau based on his position flexibility and possible high ceiling. Definitely don’t like the year off, but I’ll stay open minded. I’m sure he’ll have a personal day / U of M day to showcase his athleticism. He should run great...</div></div><div class="thread_post"><div class="thread_post_header"><b>BTW... </b><a name="15129460">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  1/20/2021  9:07 pm   : <a href="index.php?mode=2&thread=605470&show_all=1#15129460">link</a>   </div></div><div class="thread_post_body">Saw a CBS mock today that has us taking Barmore.<br />
<br />
That’s another remote thrower... ; )</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: BTW... </b><a name="15129527">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BelieveJJ"> BelieveJJ </a>  :  1/21/2021  12:24 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15129527">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15129460" target="_blank">15129460</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Saw a CBS mock today that has us taking Barmore.<br />
<br />
That’s another remote thrower... ; ) </td>
                                </tr>
                           </table><br />
<br />
The Draft Bible guy Serritella had a few more original opinions that I have a feeling may become more acknowledged as the draft process wears on: thinks Barmore is a back half of round 1 talent, thinks Surtain and Farely both are over-rated and that SC. cb Jaycee Horn should be the first CB off the board (wait for the remotes to hit the TV when DG grabs Horn at 11, over both Surtain and Farley), thinks Waddle is a slot WR and therefore not worthy of the 11th slot, and most surprisingly to me thinks the best value players to be had around 11 may be the top OTs at that point!!!</div></div><div class="thread_post"><div class="thread_post_header"><b>He said Slater might drop because of not playing in  </b><a name="15129529">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BelieveJJ"> BelieveJJ </a>  :  1/21/2021  12:32 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15129529">link</a>   </div></div><div class="thread_post_body">2020, but also might drop because he doesn't have the requisite arm length (&gt;34 inches) for the OT position in the NFL. He thinks Slateright be there for the Giants even in round 2 at 42...<br />
<br />
HE likes OTs Darrislaw of VT and Cosmi from Texas better.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: BTW... </b><a name="15129534">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=chopperhatch"> chopperhatch </a>  :  1/21/2021  12:42 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15129534">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15129460" target="_blank">15129460</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Saw a CBS mock today that has us taking Barmore.<br />
<br />
That’s another remote thrower... ; ) </td>
                                </tr>
                           </table><br />
<br />
If only your computer would be so lucky...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: LOL. </b><a name="15129710">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  1/21/2021  10:46 am   : <a href="index.php?mode=2&thread=605470&show_all=1#15129710">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15128611" target="_blank">15128611</a> BelieveJJ said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> The human toothpick. Or what a buddy of mine used to call the dog breed Airdale, the "two dimensional dog." From the head on view, they disappear. </td>
                                </tr>
                           </table><br />
Your buddy should learn more about dog breeds. The Airedale is very similar to (but larger than) the Welsh Terrier, and is not especially thin.<br />
<br />
<img src="https://airedalesaustralia.files.wordpress.com/2014/10/airedale-2.jpg?w=449"></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: LOL. </b><a name="15129858">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BelieveJJ"> BelieveJJ </a>  :  1/21/2021  12:08 pm   : <a href="index.php?mode=2&thread=605470&show_all=1#15129858">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605470&show_all=1#15129710" target="_blank">15129710</a> Gatorade Dunk said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15128611 BelieveJJ said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     The human toothpick. Or what a buddy of mine used to call the dog breed Airdale, the "two dimensional dog." From the head on view, they disappear. <br />
                                <br />
                           <br />
Your buddy should learn more about dog breeds. The Airedale is very similar to (but larger than) the Welsh Terrier, and is not especially thin.<br />
<br />
 </td>
                                </tr>
                           </table><br />
<br />
Maybe he meant a Saluki? In all fairness, HE always referred to the neighbor's dog as simply "that 2 dimensional dog". I was the one who.(I gather mistakenly) thought it was an Airdale.<br />
<br />
How ya doin, GD?</div></div><a name="END"><a href="index.php"><div style="padding-top:25px; padding-bottom:20px;"><img src="/images/back_corner.gif" class="thread_link"  alt="Back to the Corner" border="0"></a></div></a></div>
<div class="thread_sidebar_2">

<!-- Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-102">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Corner Forum - Lower 300x250 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1566320450447229"
     data-ad-slot="4189314539"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->

</div>

</div>




<div class="footer">


<p style="width:400px;float:left;"><b>Part of the USA Today Sports Media Group</b><br>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</P>
<P  style="width:400px;float:right; text-align:right;">
All contents (unless otherwise specified) copyright &copy;  1995 - 2020<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Solutions</a>
</P>
<br clear="all">
<div style="float:right;">
<script
    src="https://sucuri.net/monitoring/badge.js"
    data-s="19"
    id="sucuri-s"
    data-i="7b1b29ae50ae6574f2af3875935246e4fa8a805b26"
    data-p="o" - position - l(left) or r(right) or o(relative)
    data-c="l"
    data-t="t"
    ></script>
</div>

</div>


<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->

<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=191-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=0&cb=2', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script></body>
</html>
