<!DOCTYPE html>
<html lang="en">
<head><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
(new Image()).src=pixelURL;}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=192-0&cb=2', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=192-0&cb=1', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=192-0&cb=5', false, [], true, false, true, false);</script>
<title>Raanan: J. Garrett expected back as OC; no Watson for NYG | Big Blue Interactive </title>


<meta name="keywords" content="ndglbqfkxx">

<meta name="description" content=" Quote: Jordan Raanan
@JordanRaanan
Two important items (per sources) in this week’s #BreakingBigBlue. — Jason Garrett is in fact expected to return as OC even though may be changes to staff (new OL coach, possible internal alterations). — No, #Giants WILL NOT be in Deshaun Watson mix. "/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="website" />
<meta property="og:description" content=" Quote: Jordan Raanan
@JordanRaanan
Two important items (per sources) in this week’s #BreakingBigBlue. — Jason Garrett is in fact expected to return as OC even though may be changes to staff (new OL coach, possible internal alterations). — No, #Giants WILL NOT be in Deshaun Watson mix. " /> 
<meta property="og:title" content="Raanan: J. Garrett expected back as OC; no Watson for NYG" /> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif" /> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css?v=20200217" />

<link rel="stylesheet" type="text/css" href="anylink.css" />


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}


div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" alt="for display only">

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type='text/javascript'>
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type='text/javascript' src='https://img.bnqt.com/lib/js/sdpdfphelper.js'></script>
<script type='text/javascript'>
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>


<!-- End DFP SETUP -->  

<!-- End USA Today Code -->




<script type="text/javascript">var ezouid = "1";</script><base href="https://corner.bigblueinteractive.com/index.php?mode=2&thread=605822&show_all=1"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"domain_test_group":20200409,"engaged_time_visit":0,"ezcache_level":0,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"51fe6b84-a54c-49db-7845-37d7122dccb9","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":271370,"response_time_orig":63,"serverid":"18.205.151.91:21631","state":"VA","t_epoch":1612601452,"template_id":126,"time_on_site_visit":0,"url":"https://corner.bigblueinteractive.com/index.php?mode=2\u0026thread=605822\u0026show_all=1","user_id":0,"word_count":22709,"worst_bad_word_level":1};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?dcb=192-0&cb=1&v=9" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["51fe6b84-a54c-49db-7845-37d7122dccb9", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>


<body>




<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"></a> <img src="images/xpete.gif" alt="The Corner Forum">

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic -->&nbsp;


<!-- Nov 2019 Leaderboard -->

<!-- Ezoic - Forum Leaderboard (USAT) - top_of_page -->
<div id="ezoic-pub-ad-placeholder-118">
<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->
<div id='usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general'>
     <script type='text/javascript'>
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general');
         });
     </script>
</div>
</div>
<!-- End Ezoic - Forum Leaderboard (USAT) - top_of_page -->



</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://www.amazon.com/?_encoding=UTF8&camp=1789&creative=9325&linkCode=ur2&tag=bigblueintera-20">Amazon.com</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW" >Standings (NFL.com)</a>
<a href="https://www.giants.com/team/stats/" target="_NEW" >Statistics (Giants.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/" >Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'home_view_menu')">Home</a>  
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'forum_view_menu')">Corner Forum</a>
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'gameday_view_menu')">Gameday</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_view_menu')">Team</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_building_view_menu')">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info &amp; History</a> -->
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_info_view_menu')">Giants Info &amp; History</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'infolinks_view_menu')">Info/Links</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'shop_view_menu')">BBI Shop</a>
<li><a href="/index.php?mode=10" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'login_menu')">Log In</a>
</ul>

</div><div id="infoline"> </div>

<a name="END"><a href="index.php"><div style="padding-top:20px; padding-bottom:25px;"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"></a></div></a><div class="thread_container"><div class="thread_left"><div class="thread_body" ><div class="thread_main" ><div class="thread_post_header" >  <h1 style="font-size:18px;">Raanan: J. Garrett expected back as OC; no Watson for NYG </h1><div class="thread_info"><a href="index.php?mode=5&handle=FranknWeezer"> FranknWeezer </a>  :  2/4/2021  4:56 pm</div></div><div class="thread_post_body" > <table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">Jordan Raanan<br />
@JordanRaanan<br />
Two important items (per sources) in this week’s #BreakingBigBlue. <br />
<br />
— Jason Garrett is in fact expected to return as OC even though may be changes to staff (new OL coach, possible internal alterations). <br />
<br />
— No, #Giants WILL NOT be in Deshaun Watson mix. </td>
                                </tr>
                           </table><br />
 </div></div></div></div><div class="thread_right"><div id="ad_side_box">


<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id='usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general'>
     <script type='text/javascript'>
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general');
         });
     </script>
</div>




</div></div><div class="thread_comment_container"><div class="thread_post"><div class="thread_post_header"><b>Not a huge  </b><a name="15143718">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=eric2425ny"> eric2425ny </a>  :  2/4/2021  4:58 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143718">link</a>   </div></div><div class="thread_post_body">Garrett fan, but better for Jones not to be on his 3rd OC in three years.  As for Watson, thank God.  Like the player, but we would have been screwed from a draft and cap perspective with what we would have had to give up.</div></div><div class="thread_post"><div class="thread_post_header"><b>Lucky us!!! </b><a name="15143719">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Greg+from+LI"> Greg from LI </a>  :  2/4/2021  4:59 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143719">link</a>   </div></div><div class="thread_post_body"><img src="https://media4.giphy.com/media/3o7TKsoVuOCiiw7Zx6/200.gif"></div></div><div class="thread_post"><div class="thread_post_header"><b>They need a passing game coordinator </b><a name="15143720">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=blueblood"> blueblood </a>  :  2/4/2021  4:59 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143720">link</a>   </div></div><div class="thread_post_body">cause Garretts 1978 schemes are bad</div></div><div class="thread_post"><div class="thread_post_header"><b>Item 2 isn't exactly news </b><a name="15143721">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=jvm52106"> jvm52106 </a>  :  2/4/2021  4:59 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143721">link</a>   </div></div><div class="thread_post_body">as there was NOY way we would in the mix regardless of how Jones is viewed by the Giants. We don't have the cap or picks to be in that race.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>If I had to guess... </b><a name="15143725">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  2/4/2021  5:04 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143725">link</a>   </div></div><div class="thread_post_body">Gettleman never even called Cesario/Easterby.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: If I had to guess... </b><a name="15143727">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=section125"> section125 </a>  :  2/4/2021  5:06 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143727">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143725" target="_blank">15143725</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Gettleman never even called Cesario/Easterby. </td>
                                </tr>
                           </table><br />
<br />
So the fuck what?</div></div><div class="thread_post"><div class="thread_post_header"><b>After seeing the cost to acquire Stafford </b><a name="15143729">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jay+on+the+Island"> Jay on the Island </a>  :  2/4/2021  5:10 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143729">link</a>   </div></div><div class="thread_post_body">I want nothing to do with Watson.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: If I had to guess... </b><a name="15143733">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  2/4/2021  5:11 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143733">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143727" target="_blank">15143727</a> section125 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15143725 bw in dc said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Gettleman never even called Cesario/Easterby. <br />
                                <br />
                           <br />
<br />
So the fuck what? </td>
                                </tr>
                           </table><br />
<br />
If you knew that for a fact, that wouldn't bother you?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: If I had to guess... </b><a name="15143735">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=FatMan+in+Charlotte"> FatMan in Charlotte </a>  :  2/4/2021  5:12 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143735">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143725" target="_blank">15143725</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Gettleman never even called Cesario/Easterby. </td>
                                </tr>
                           </table><br />
<br />
And if I had to guess, you'll run with that narrative until the cows come him.<br />
<br />
We still have to hear you chatter like a broken fucking record about McAdoo nearly burning the building down to get Mahomes</div></div><div class="thread_post"><div class="thread_post_header"><b>I'll certainly underscore it... </b><a name="15143742">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  2/4/2021  5:21 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143742">link</a>   </div></div><div class="thread_post_body">if it comes out that Ole Dave never even bothered to call the Texans, yes.<br />
<br />
JonC has confirmed Big Mac went hard for Mahomes, but was thwarted. So it's worthwhile to remind the board when necessary. But I don't overplay the hand...</div></div><div class="thread_post"><div class="thread_post_header"><b>. </b><a name="15143744">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/4/2021  5:24 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143744">link</a>   </div></div><div class="thread_post_body">2020 - Winning in the NFL is about creating points through explosive pass plays. The personnel in the pass game is terrible (Gettleman). The schemes are antiquated (Garrett). The quarterbacking is among the very worst in the NFL (Jones). <br />
<br />
2021 - Let's bring Gettleman, Garrett, and Jones back!<br />
<br />
Mara hopes he wins doing things the Mara way. But turning over every stone to try to win is a bridge too far.</div></div><div class="thread_post"><div class="thread_post_header"><b>Good.. </b><a name="15143747">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Big+Blue+%2756"> Big Blue '56 </a>  :  2/4/2021  5:27 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143747">link</a>   </div></div><div class="thread_post_body">DJ is Judge’s guy, imv...JG won’t be as hamstrung with SB coming back and the WR corps upgraded, imo..<br />
<br />
Save your draft capital and continue to build</div></div><div class="thread_post"><div class="thread_post_header"><b>Next year is an extremely important season.. </b><a name="15143763">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sean"> Sean </a>  :  2/4/2021  5:40 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143763">link</a>   </div></div><div class="thread_post_body">The last three premium draft picks the Giants used have all been on offense:<br />
<br />
Saquon Barkley, RB (2-2018)<br />
Daniel Jones, QB (6-2019)<br />
Andrew Thomas, OT (4-2020)<br />
<br />
Barkley has mostly been hurt in the last season & a half. Jones is entering his third season. Thomas played hurt last year and improved as the season went on. I can understand why Mara didn’t dramatically change course this offseason. But, there needs to be a sizable improvement this year. The offensive players noted above need to all have very good seasons.<br />
<br />
2021 is the fork in the road season with the Gettleman plan, it hasn’t paid off to date, but it needs to next year. The results need to be there. We’ll see.</div></div><div class="thread_post"><div class="thread_post_header"><b>Aside from that Mrs. Lincoln... </b><a name="15143764">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=trueblueinpw"> trueblueinpw </a>  :  2/4/2021  5:42 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143764">link</a>   </div></div><div class="thread_post_body">Did you enjoy the play?</div></div><div class="thread_post"><div class="thread_post_header"><b>Lets be rational for a second. </b><a name="15143772">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  :  2/4/2021  5:48 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143772">link</a>   </div></div><div class="thread_post_body">This news is most likely true. However, if we were interested in Watson why the fuck would that be made public. Yeah, lets show the world we don't believe in our QB. That'll make for a great team dynamic.</div></div><div class="thread_post"><div class="thread_post_header"><b>Garrett was a mistake hire in the moment, it's grown worse </b><a name="15143774">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Kyle_"> Kyle_ </a>  :  2/4/2021  5:51 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143774">link</a>   </div></div><div class="thread_post_body">with a season ticket bear out the results as significantly worse than the mediocre results expected.<br />
<br />
Another way to describe a scheme that's so heavily dependent on players winning one on one matches in their routes as Garrett's is a havingno fucking scheme at all. <br />
<br />
RUN TO A SPOT BE FASTER THAN DEF <br />
I BELIEVE IN YOU<br />
XOXO <br />
-JG<br />
<br />
Daniel Jones doesn't deserve this. We as fans don't either.</div></div><div class="thread_post"><div class="thread_post_header"><b>*season to bear </b><a name="15143775">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Kyle_"> Kyle_ </a>  :  2/4/2021  5:52 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143775">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Lets be rational for a second. </b><a name="15143781">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sean"> Sean </a>  :  2/4/2021  5:57 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143781">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143772" target="_blank">15143772</a> robbieballs2003 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> This news is most likely true. However, if we were interested in Watson why the fuck would that be made public. Yeah, lets show the world we don't believe in our QB. That'll make for a great team dynamic. </td>
                                </tr>
                           </table><br />
<br />
Agree. I’d also add that “Jason Garrett is <span class="bold">expected</span> to return” is strange on 02/04. Getting late in the game to put in a new system. That word still leaves the window open for doubt.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Lets be rational for a second. </b><a name="15143784">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  2/4/2021  6:03 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143784">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143772" target="_blank">15143772</a> robbieballs2003 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> This news is most likely true. However, if we were interested in Watson why the fuck would that be made public. Yeah, lets show the world we don't believe in our QB. That'll make for a great team dynamic. </td>
                                </tr>
                           </table><br />
<br />
Watson is a top 5-7 QB in the NFL. I'm sure Jones would get over it.</div></div><div class="thread_post"><div class="thread_post_header"><b>I like Garrett and I like DJ </b><a name="15143790">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Leg+of+Theismann"> Leg of Theismann </a>  :  2/4/2021  6:10 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143790">link</a>   </div></div><div class="thread_post_body">But I don’t like them together so much. Garrett’s style does not play well to DJ’s strengths. Shurmur’s style was actually more DJ-friendly. Idk. I don’t see why this is hard for some people to see. You can like both guys but not like them for each other.</div></div><div class="thread_post"><div class="thread_post_header"><b>The Giants topped 25 points only twice all year and  </b><a name="15143791">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/4/2021  6:11 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143791">link</a>   </div></div><div class="thread_post_body">scored under 20 points nine times.<br />
<br />
Glad to see they are contemplating possible internal alterations...<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>I’d love to see the list of offensive coordinators  </b><a name="15143797">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Chris684"> Chris684 </a>  :  2/4/2021  6:24 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143797">link</a>   </div></div><div class="thread_post_body">scoring 30+ points per game with the offensive talent NYG played with last year. I’m sure that’s a really long list. <br />
<br />
Just like Gase was a genius without Manning. <br />
<br />
I’m sure the job Bienemy is doing in KC has nothing to do with the video game talent he has all over the offensive side of the ball. <br />
<br />
Some of you are so lost, which is fine, but you act like your mindless mouth breathing is gospel. I’m sure you couldn’t even describe accurately what Garrett’s system is you just don’t like it because “Mara picked him” or “he clapped too much in Dallas” or whatever. <br />
<br />
Let’s see what year 2 brings with some semblance of a normal training camp, Barkley in the fold and increased talent hopefully at TE and WR.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: The Giants topped 25 points only twice all year and  </b><a name="15143798">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=eric2425ny"> eric2425ny </a>  :  2/4/2021  6:24 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143798">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143791" target="_blank">15143791</a> Jimmy Googs said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> scored under 20 points nine times.<br />
<br />
Glad to see they are contemplating possible internal alterations...<br />
 </td>
                                </tr>
                           </table><br />
<br />
No Barkley, no #1 or even #2 receiver (Shepard is a slot guy), no reliable TE, and a line that didn’t start to gel until mid season.  And Jones is a second year QB.  Did you expect them to score 25+ in many games this year?  I didn’t.</div></div><div class="thread_post"><div class="thread_post_header"><b>One thing Garrett and Jones have going for them </b><a name="15143809">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/4/2021  6:37 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143809">link</a>   </div></div><div class="thread_post_body">They set the bar so fucking low with their 2020 that they can only improve in 2021. I look forward to posts this time next year telling us how 21 points per game, while still well in the bottom half of the league, was a big improvement that certainly means great things for 2022.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Not a huge  </b><a name="15143810">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GiantsRage2007"> GiantsRage2007 </a>  :  2/4/2021  6:38 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143810">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143718" target="_blank">15143718</a> eric2425ny said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Garrett fan, but better for Jones not to be on his 3rd OC in three years.  As for Watson, thank God.  Like the player, but we would have been screwed from a draft and cap perspective with what we would have had to give up. </td>
                                </tr>
                           </table><br />
<br />
Why not? A better OC is a better OC. I'd like a better offense not another year in a bad one. The next time we run a play where our scheme gets a guy open will be the first.</div></div><div class="thread_post"><div class="thread_post_header"><b>Terps I gotta say  </b><a name="15143811">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/4/2021  6:40 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143811">link</a>   </div></div><div class="thread_post_body">for all the shit you give posters for being positive, you do the same exact thing except the opposite. You can’t predict the future, you make these statements as if you already know the outcome. <br />
<br />
Just fucking relax. We will see what happens.</div></div><div class="thread_post"><div class="thread_post_header"><b>some of you  </b><a name="15143812">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/4/2021  6:40 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143812">link</a>   </div></div><div class="thread_post_body">can’t separate yourselves from 2018. Time to move on.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: One thing Garrett and Jones have going for them </b><a name="15143813">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=eric2425ny"> eric2425ny </a>  :  2/4/2021  6:41 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143813">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143809" target="_blank">15143809</a> Go Terps said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> They set the bar so fucking low with their 2020 that they can only improve in 2021. I look forward to posts this time next year telling us how 21 points per game, while still well in the bottom half of the league, was a big improvement that certainly means great things for 2022. </td>
                                </tr>
                           </table><br />
<br />
Give it a rest man.  They lost their best offensive weapon at the beginning of the season and have one reliable slot receiver.  I’m not saying Jones is going to be great, but let’s give him someone reliable to throw to.  Do you realize half of his interceptions were due to Reese’s last first round pick Engram, that is supposed to be playing a safety valve position at TE?  I read a statistical analysis recently that estimated Engram cost them at least 35 points this year between drops and turnovers.  That’s probably three more wins when you look at how close many of the games were that we lost.</div></div><div class="thread_post"><div class="thread_post_header"><b>I'd rather not hear people gripe about the beat writers ... </b><a name="15143815">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=DonQuixote"> DonQuixote </a>  :  2/4/2021  6:43 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143815">link</a>   </div></div><div class="thread_post_body">... because many of you bitch about the same things no matter what is written.</div></div><div class="thread_post"><div class="thread_post_header"><b>Let’s say the Giants wanted Watson </b><a name="15143819">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=arniefez"> arniefez </a>  :  2/4/2021  6:47 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143819">link</a>   </div></div><div class="thread_post_body">And the Texans were willing to take Jones and three 1’s. Watson wouldn’t agree to come to the Giants in a million years with this roster and no 1’s until 2024. So of course the Giants didn’t make a call</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: If I had to guess... </b><a name="15143821">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=MtDizzle"> MtDizzle </a>  :  2/4/2021  6:47 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143821">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143727" target="_blank">15143727</a> section125 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15143725 bw in dc said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Gettleman never even called Cesario/Easterby. <br />
                                <br />
                           <br />
<br />
So the fuck what? </td>
                                </tr>
                           </table><br />
<br />
Because it's doing due diligence as the GM of a pro football team. Its sad to see how many of you are complacent with mediocrity.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: some of you  </b><a name="15143822">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sean"> Sean </a>  :  2/4/2021  6:48 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143822">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143812" target="_blank">15143812</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> can’t separate yourselves from 2018. Time to move on. </td>
                                </tr>
                           </table><br />
<br />
I agree that many posters here cannot put a line in the sand with the coaching staff change. Each GM/HC will work differently together. Not to say all the blame lies on Shurmur, it doesn’t. But it’s also possible a Judge/Gettleman collaboration may yield better results.<br />
<br />
Giving Jones a third year is reasonable regardless of what you think of him.</div></div><div class="thread_post"><div class="thread_post_header"><b>If Judge is so bright </b><a name="15143829">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=crick+n+NC"> crick n NC </a>  :  2/4/2021  6:56 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143829">link</a>   </div></div><div class="thread_post_body">And Garrett is awful how can he not fire Garrett?  This doesn't reflect well on Judge.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: If Judge is so bright </b><a name="15143833">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/4/2021  7:07 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143833">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143829" target="_blank">15143829</a> crick n NC said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> And Garrett is awful how can he not fire Garrett?  This doesn't reflect well on Judge. </td>
                                </tr>
                           </table><br />
<br />
Who says it's his call?  The owner and GM already announced their intention to retain Garrett in their fireside chat. They are all in on Jones, and don't want to see him have to switch systems again. <br />
<br />
Maybe they should have given that some thought when they hired Garrett, whose offense couldn't be more different than Shurmur's. But the Maras love Garrett, and that took precedence. <br />
<br />
Garrett's offense + Jones's skillset is a terrible marriage. It's one where Jones's glaring weaknesses are featured. <br />
<br />
In 2020 only one team (LA Rams) over .500 finished in the bottom half of the NFL in scoring. The 16th ranked offense (Atlanta) scored 24.8 PPG. I'd bet a paycheck the 2021 Giants finish under that number and under .500. <br />
<br />
This league is about scoring points, and the Giants aren't going into 2021 with the tools to do that even with a FA WR addition.</div></div><div class="thread_post"><div class="thread_post_header"><b>It doesn't.. </b><a name="15143843">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=FatMan+in+Charlotte"> FatMan in Charlotte </a>  :  2/4/2021  7:16 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143843">link</a>   </div></div><div class="thread_post_body">surprise me the number of posters who recognize that press conferences and end of the season talks are useless for other teams, yet hang on their every word when it comes to this team.<br />
<br />
The term "fireside chat" has been bludgeoned to death here like Go Terps lost his tape of the Yule Log and can't figure out what the fuck to do about it.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: If Judge is so bright </b><a name="15143844">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=eric2425ny"> eric2425ny </a>  :  2/4/2021  7:16 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143844">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143833" target="_blank">15143833</a> Go Terps said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15143829 crick n NC said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     And Garrett is awful how can he not fire Garrett?  This doesn't reflect well on Judge. <br />
                                <br />
                           <br />
<br />
Who says it's his call?  The owner and GM already announced their intention to retain Garrett in their fireside chat. They are all in on Jones, and don't want to see him have to switch systems again. <br />
<br />
Maybe they should have given that some thought when they hired Garrett, whose offense couldn't be more different than Shurmur's. But the Maras love Garrett, and that took precedence. <br />
<br />
Garrett's offense + Jones's skillset is a terrible marriage. It's one where Jones's glaring weaknesses are featured. <br />
<br />
In 2020 only one team (LA Rams) over .500 finished in the bottom half of the NFL in scoring. The 16th ranked offense (Atlanta) scored 24.8 PPG. I'd bet a paycheck the 2021 Giants finish under that number and under .500. <br />
<br />
This league is about scoring points, and the Giants aren't going into 2021 with the tools to do that even with a FA WR addition. </td>
                                </tr>
                           </table><br />
<br />
Disagree with your last statement.  Barkley coming back (even if it’s a slow start), a FA WR like Robinson/Golladay, another WR in the first 4 rounds of the draft and this is a much different offense.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: If Judge is so bright </b><a name="15143851">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=crick+n+NC"> crick n NC </a>  :  2/4/2021  7:23 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143851">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143833" target="_blank">15143833</a> Go Terps said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15143829 crick n NC said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     And Garrett is awful how can he not fire Garrett?  This doesn't reflect well on Judge. <br />
                                <br />
                           <br />
<br />
Who says it's his call?  The owner and GM already announced their intention to retain Garrett in their fireside chat. They are all in on Jones, and don't want to see him have to switch systems again. <br />
<br />
Maybe they should have given that some thought when they hired Garrett, whose offense couldn't be more different than Shurmur's. But the Maras love Garrett, and that took precedence. <br />
<br />
Garrett's offense + Jones's skillset is a terrible marriage. It's one where Jones's glaring weaknesses are featured. <br />
<br />
In 2020 only one team (LA Rams) over .500 finished in the bottom half of the NFL in scoring. The 16th ranked offense (Atlanta) scored 24.8 PPG. I'd bet a paycheck the 2021 Giants finish under that number and under .500. <br />
<br />
This league is about scoring points, and the Giants aren't going into 2021 with the tools to do that even with a FA WR addition. </td>
                                </tr>
                           </table><br />
<br />
It reflects poorly on Judge because it is his coaching staff.  He is tied to them, so when one is as obviously horrible as Garrett and is allowed to stay it makes Judge seem like he is full of doo too.<br />
<br />
Judge signing with a team that controls who he hires and fires doesn't seem like a bright move for a bright guy considering that he had other options.</div></div><div class="thread_post"><div class="thread_post_header"><b>crick </b><a name="15143855">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/4/2021  7:27 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143855">link</a>   </div></div><div class="thread_post_body">A guy with no head coach experience isn't going to be in a position to tell the owner "no" if he wants to name someone on his staff. It's on the owner to have the intelligence not to foist a family friend on his rookie head coach.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I’d love to see the list of offensive coordinators  </b><a name="15143864">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Kyle_"> Kyle_ </a>  :  2/4/2021  7:33 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143864">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143797" target="_blank">15143797</a> Chris684 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> scoring 30+ points per game with the offensive talent NYG played with last year. I’m sure that’s a really long list. <br />
<br />
Just like Gase was a genius without Manning. <br />
<br />
I’m sure the job Bienemy is doing in KC has nothing to do with the video game talent he has all over the offensive side of the ball. <br />
<br />
Some of you are so lost, which is fine, but you act like your mindless mouth breathing is gospel. I’m sure you couldn’t even describe accurately what Garrett’s system is you just don’t like it because “Mara picked him” or “he clapped too much in Dallas” or whatever. <br />
<br />
Let’s see what year 2 brings with some semblance of a normal training camp, Barkley in the fold and increased talent hopefully at TE and WR. </td>
                                </tr>
                           </table><br />
Don't project your ignorance onto the rest of us, friend.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: crick </b><a name="15143866">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=eric2425ny"> eric2425ny </a>  :  2/4/2021  7:34 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143866">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143855" target="_blank">15143855</a> Go Terps said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> A guy with no head coach experience isn't going to be in a position to tell the owner "no" if he wants to name someone on his staff. It's on the owner to have the intelligence not to foist a family friend on his rookie head coach. </td>
                                </tr>
                           </table><br />
<br />
You realize Garrett’s offenses were in the top 10 for several years with the Cowboys right?  I’m not happy about 2020, but he also had very few weapons to work with.  When your featured receiver is Engram you are pretty much fucked.  If they get some weapons this offseason and we are having this same conversation next February you are right.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: crick </b><a name="15143887">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=crick+n+NC"> crick n NC </a>  :  2/4/2021  7:46 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143887">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143855" target="_blank">15143855</a> Go Terps said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> A guy with no head coach experience isn't going to be in a position to tell the owner "no" if he wants to name someone on his staff. It's on the owner to have the intelligence not to foist a family friend on his rookie head coach. </td>
                                </tr>
                           </table><br />
<br />
Then Judge should have gone to Miss. State where he would have the control and be able to hold those accountable for poor results.  Accountability was a big subject in Judges first press conference I believe.  It seems hollow to talk about accountability if he isn't even able to hold his own coaches accountable.</div></div><div class="thread_post"><div class="thread_post_header"><b>crick </b><a name="15143894">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/4/2021  7:53 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143894">link</a>   </div></div><div class="thread_post_body">NFL head coach jobs are very precious and tough to pass up. Mississippi State will be there for Judge in the future if he wants it.</div></div><div class="thread_post"><div class="thread_post_header"><b>Terps </b><a name="15143896">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/4/2021  7:54 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143896">link</a>   </div></div><div class="thread_post_body">context matters. You have an incredibly ability to leave it out of every statement you make.<br />
<br />
Maybe, just maybe, the Giants and Judge are really high on Garrett. And maybe, the reason we had a shitty offense is because our freakishly talented best player tore his knee, and we had a second year QB with almost nobody throwing to him. Yet when everything was clicking, the offense was more than solid.<br />
<br />
Give it some time before you just abandon ship on Garrett. He’s been the head of some really good offenses.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: If I had to guess... </b><a name="15143897">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Milton"> Milton </a>  :  2/4/2021  7:57 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143897">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143725" target="_blank">15143725</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Gettleman never even called Cesario/Easterby. </td>
                                </tr>
                           </table>Why waste the dime?</div></div><div class="thread_post"><div class="thread_post_header"><b>. </b><a name="15143899">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/4/2021  7:59 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143899">link</a>   </div></div><div class="thread_post_body">At no point in the season was the offense more than solid, whatever that means. It was a liability that had to be coached around. <br />
<br />
And for all the greatness Barkley supposedly brings, the Giants have been a shit offensive team since he's been here.<br />
<br />
Instead of pining for Barkley, you may want to ask yourself what they're going to do with him on the many third and longs that Garrett's offense sets up... because keeping him in the backfield to pick up a blitz is not a good option.</div></div><div class="thread_post"><div class="thread_post_header"><b>Terps, not trying to dump on you  </b><a name="15143905">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=eric2425ny"> eric2425ny </a>  :  2/4/2021  8:10 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143905">link</a>   </div></div><div class="thread_post_body">here and you are not the only fan to take this super negative approach but you can’t just scrap everything every year and start over.  This team for the first time in at least 5 years showed some actual signs of life in 2020.  Im excited to see what more weapons on offense does for this team.  Judge looks like the real deal at HC.  Better days are coming.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I’d love to see the list of offensive coordinators  </b><a name="15143907">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/4/2021  8:12 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143907">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143797" target="_blank">15143797</a> Chris684 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> scoring 30+ points per game with the offensive talent NYG played with last year. I’m sure that’s a really long list. <br />
<br />
Just like Gase was a genius without Manning. <br />
<br />
I’m sure the job Bienemy is doing in KC has nothing to do with the video game talent he has all over the offensive side of the ball. <br />
<br />
Some of you are so lost, which is fine, but you act like your mindless mouth breathing is gospel. I’m sure you couldn’t even describe accurately what Garrett’s system is you just don’t like it because “Mara picked him” or “he clapped too much in Dallas” or whatever. <br />
<br />
Let’s see what year 2 brings with some semblance of a normal training camp, Barkley in the fold and increased talent hopefully at TE and WR. </td>
                                </tr>
                           </table><br />
<br />
Awful post.  Come back to reality and stop putting forth excuses and blaming me for expecting a team to put forth a more credible offensive output than the Giants did last year.<br />
<br />
If the talent on the field isn't adequate enough to score a reasonable level of points then send your post to Gettleman, not me.</div></div><div class="thread_post"><div class="thread_post_header"><b>Mara </b><a name="15143908">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=crick+n+NC"> crick n NC </a>  :  2/4/2021  8:13 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143908">link</a>   </div></div><div class="thread_post_body">Required Judge to hire Garrett, Judge says ok.  Garrett says, I only come if Colombo comes, Mara goes back to Judge and says, Garrett said he will only come if he is allowed to bring Colombo as OL coach, Judge says, fine.  Later in the year, Judge decides he wants to bring in an OL consultant, so Judge goes to Mara and says, hey, I think Colombo kinda sucks, so I would like to bring in a constant to help since guy made me hire this guy.  Mara says, fine, but watch your tone with me, Judge says, yes sir.  Judge hires consultant, Colombo finds out, gets roid pissed and wants to fight Judge.  Judge says you're fired, Colombo says, no I am not, because you can't do that.  Judge says, give me five minutes, I'll be back.  Judge goes to Mara and says, Big guy Colombo wants to fight, so I fired him, but then he reminded me that I can't fire coaches, so can I fire Colombo?  Mara says, I guess.  Judge says Thanks!  Judge goes back to Colombo with a permission slip to fire Colombo, Colombo reads it, gets more pissed then calls Garrett, Hey Judge is trying to fire me!  Garrett says, oh hell no! She calls Mara, Mara requests that Garrett not be mad at him for allowing Judge to fire Colombo, Garrett says, I'll just get a job with the chargers next year then!  Mara weeps.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: The Giants topped 25 points only twice all year and  </b><a name="15143910">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/4/2021  8:14 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143910">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143798" target="_blank">15143798</a> eric2425ny said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15143791 Jimmy Googs said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     scored under 20 points nine times.<br />
<br />
Glad to see they are contemplating possible internal alterations...<br />
 <br />
                                <br />
                           <br />
<br />
No Barkley, no #1 or even #2 receiver (Shepard is a slot guy), no reliable TE, and a line that didn’t start to gel until mid season.  And Jones is a second year QB.  Did you expect them to score 25+ in many games this year?  I didn’t. </td>
                                </tr>
                           </table><br />
<br />
Sounds like the offensive roster needs more talent. Or is it the Front Office?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: If Judge is so bright </b><a name="15143912">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/4/2021  8:17 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143912">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143829" target="_blank">15143829</a> crick n NC said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> And Garrett is awful how can he not fire Garrett?  This doesn't reflect well on Judge. </td>
                                </tr>
                           </table><br />
<br />
It very well may not if Garrett isn't get the job done.<br />
<br />
Do you recommend Judge lay down the hammer here or should he insert himself into offensive processes more?  What would be your likely move?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: If Judge is so bright </b><a name="15143914">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Josh+in+the+City"> Josh in the City </a>  :  2/4/2021  8:18 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143914">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143833" target="_blank">15143833</a> Go Terps said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15143829 crick n NC said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     And Garrett is awful how can he not fire Garrett?  This doesn't reflect well on Judge. <br />
                                <br />
                           <br />
<br />
Who says it's his call?  The owner and GM already announced their intention to retain Garrett in their fireside chat. They are all in on Jones, and don't want to see him have to switch systems again. <br />
<br />
Maybe they should have given that some thought when they hired Garrett, whose offense couldn't be more different than Shurmur's. But the Maras love Garrett, and that took precedence. <br />
<br />
Garrett's offense + Jones's skillset is a terrible marriage. It's one where Jones's glaring weaknesses are featured. <br />
<br />
In 2020 only one team (LA Rams) over .500 finished in the bottom half of the NFL in scoring. The 16th ranked offense (Atlanta) scored 24.8 PPG. I'd bet a paycheck the 2021 Giants finish under that number and under .500. <br />
<br />
This league is about scoring points, and the Giants aren't going into 2021 with the tools to do that even with a FA WR addition. </td>
                                </tr>
                           </table><br />
If it’s not the head coach’s call who his OC is then this franchise is even more fucked than I already thought it was. And that’s saying something.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: If I had to guess... </b><a name="15143917">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/4/2021  8:26 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143917">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143897" target="_blank">15143897</a> Milton said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15143725 bw in dc said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Gettleman never even called Cesario/Easterby. <br />
                                <br />
                           Why waste the dime? </td>
                                </tr>
                           </table><br />
<br />
Agreed.  <br />
<br />
This kind of move is likely beyond what our current front office can navigate effectively.  Similar to <br />
why they stood pat at #2 overall and made the easy pick with Barkley.</div></div><div class="thread_post"><div class="thread_post_header"><b>ryanmkeane vs. Terps. </b><a name="15143920">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=SFGFNCGiantsFan"> SFGFNCGiantsFan </a>  :  2/4/2021  8:28 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143920">link</a>   </div></div><div class="thread_post_body">I always know it's going to go the distance. And I love it. Haha.<br />
<br />
As for Garrett...expected as much. Se la vie. For whatever reason-maybe he grew up in Jersey, went to Princeton, was backup QB for us for a couple of seasons, his old man, etc.-Mara obviously thinks highly of him. I don't get it, but that's me. That said, '21 is make or break for him & Jones. They need to show SIGNIFICANT improvement or both shouldn't be in their current positions come '22. We need a major influx of talent on offense, shocking statement I know. I'm not ready to give up on Jones yet, but he really needs to up his game a lot next fall or we're looking for another QB.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: ryanmkeane vs. Terps. </b><a name="15143925">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sean"> Sean </a>  :  2/4/2021  8:36 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143925">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143920" target="_blank">15143920</a> SFGFNCGiantsFan said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I always know it's going to go the distance. And I love it. Haha.<br />
<br />
As for Garrett...expected as much. Se la vie. For whatever reason-maybe he grew up in Jersey, went to Princeton, was backup QB for us for a couple of seasons, his old man, etc.-Mara obviously thinks highly of him. I don't get it, but that's me. That said, '21 is make or break for him & Jones. They need to show SIGNIFICANT improvement or both shouldn't be in their current positions come '22. We need a major influx of talent on offense, shocking statement I know. I'm not ready to give up on Jones yet, but he really needs to up his game a lot next fall or we're looking for another QB. </td>
                                </tr>
                           </table><br />
<br />
Very well put. This is what it boils down to. Everything needs to click next season. Barkley needs to get back to his rookie level of production. Jones needs to have a significant spike in production. Andrew Thomas needs to become an above average LT anchoring the line. It all needs to click. If not, the Giants are staring down the potential of another overhaul next year.</div></div><div class="thread_post"><div class="thread_post_header"><b>Even suggesting everything needs to click </b><a name="15143929">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/4/2021  8:42 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143929">link</a>   </div></div><div class="thread_post_body">is basically you throwing up a Hail Mary in that post.<br />
<br />
When does everything click?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Even suggesting everything needs to click </b><a name="15143933">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sean"> Sean </a>  :  2/4/2021  8:46 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143933">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143929" target="_blank">15143929</a> Jimmy Googs said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> is basically you throwing up a Hail Mary in that post.<br />
<br />
When does everything click? </td>
                                </tr>
                           </table><br />
<br />
Then blow it up? I’m just stating what the Giants thinking is. Next year the plan will need to come through or it will lead to a new GM & QB most likely.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: ryanmkeane vs. Terps. </b><a name="15143956">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Ned+In+Atlanta"> Ned In Atlanta </a>  :  2/4/2021  9:27 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143956">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143920" target="_blank">15143920</a> SFGFNCGiantsFan said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I always know it's going to go the distance. And I love it. Haha.<br />
<br />
As for Garrett...expected as much. Se la vie. For whatever reason-maybe he grew up in Jersey, went to Princeton, was backup QB for us for a couple of seasons, his old man, etc.-Mara obviously thinks highly of him. I don't get it, but that's me. That said, '21 is make or break for him & Jones. They need to show SIGNIFICANT improvement or both shouldn't be in their current positions come '22. We need a major influx of talent on offense, shocking statement I know. I'm not ready to give up on Jones yet, but he really needs to up his game a lot next fall or we're looking for another QB. </td>
                                </tr>
                           </table><br />
<br />
I don’t always agree with Terps, but he’s right here. No matter how badly Mara continues to ruin this franchise, Ryan Keane, FMIC and co will continue to shill for the owner and front office. The team has been an abomination for a decade. People laughing at the idea of trading for Watson because we have Daniel Jones are utterly clueless.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Even suggesting everything needs to click </b><a name="15143961">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/4/2021  9:30 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143961">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143933" target="_blank">15143933</a> Sean said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15143929 Jimmy Googs said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     is basically you throwing up a Hail Mary in that post.<br />
<br />
When does everything click? <br />
                                <br />
                           <br />
<br />
Then blow it up? I’m just stating what the Giants thinking is. Next year the plan will need to come through or it will lead to a new GM & QB most likely. </td>
                                </tr>
                           </table><br />
<br />
What’s come thru?  What’s the ultimatum?</div></div><div class="thread_post"><div class="thread_post_header"><b>The problem is Mara doesn't even know what "clicking" looks like </b><a name="15143962">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/4/2021  9:30 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143962">link</a>   </div></div><div class="thread_post_body">This is a guy who according to reports from asshats didn't even know if he was keeping Gettleman going into the last game.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: ryanmkeane vs. Terps. </b><a name="15143963">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=eric2425ny"> eric2425ny </a>  :  2/4/2021  9:30 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143963">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143956" target="_blank">15143956</a> Ned In Atlanta said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15143920 SFGFNCGiantsFan said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     I always know it's going to go the distance. And I love it. Haha.<br />
<br />
As for Garrett...expected as much. Se la vie. For whatever reason-maybe he grew up in Jersey, went to Princeton, was backup QB for us for a couple of seasons, his old man, etc.-Mara obviously thinks highly of him. I don't get it, but that's me. That said, '21 is make or break for him & Jones. They need to show SIGNIFICANT improvement or both shouldn't be in their current positions come '22. We need a major influx of talent on offense, shocking statement I know. I'm not ready to give up on Jones yet, but he really needs to up his game a lot next fall or we're looking for another QB. <br />
                                <br />
                           <br />
<br />
I don’t always agree with Terps, but he’s right here. No matter how badly Mara continues to ruin this franchise, Ryan Keane, FMIC and co will continue to shill for the owner and front office. The team has been an abomination for a decade. People laughing at the idea of trading for Watson because we have Daniel Jones are utterly clueless. </td>
                                </tr>
                           </table><br />
<br />
People aren’t against trading for Watson because of Jones.  It’s because to get Watson you destroy your salary cap and lose at least three first round picks.  Which means you have an excellent QB and no ability to improve the team around him.  You become the Houston Texans.  And you don’t win anything.</div></div><div class="thread_post"><div class="thread_post_header"><b>Why would anyone want a QB who is unhappy </b><a name="15143987">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Thunderstruck27"> Thunderstruck27 </a>  :  2/4/2021  9:53 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15143987">link</a>   </div></div><div class="thread_post_body">with the team who drafted him and is giving ultimatums like he's actually won something?  You think he'd come to this team and fall in love?  It's moronic.</div></div><div class="thread_post"><div class="thread_post_header"><b>Ned </b><a name="15144000">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/4/2021  10:04 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144000">link</a>   </div></div><div class="thread_post_body">not sure where you’ve been or what you’ve been reading. I said all along I expected 6 wins this year, we did that. I expected improvement in the second half, we went 5-3. I said week 8 on is when the team should start clicking, that’s what happened. I said I expected 9 wins next year and the playoffs, or else Gettleman’s plan will have failed.<br />
<br />
So...no matter what everyone else thinks or says, these are the things I have been saying. I’m not some Mara or DG apologist. I said I think the direction they are going with is the right one, especially since 2019. I said Shurmur was way worse than people thought. I like Daniel Jones, think he’s shown great promise and has obviously struggled more often than not, but you gotta lay the foundation before you can say for sure whether or someone is going to pan out or not.<br />
<br />
And no, Jason Garrett will not be the reason Jones succeeds or fails.</div></div><div class="thread_post"><div class="thread_post_header"><b>Terps  </b><a name="15144003">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/4/2021  10:08 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144003">link</a>   </div></div><div class="thread_post_body">John Mara has 2 Super Bowls as the owner of the Giants. He held on to Coughlin and Reese for too long, but tough to fault him for it. He wasn’t going to let Eli Manning play for another franchise. Say what you want about that, but it’s over with. It looks like he finally got the head coach right after two bad hires. Give the guy a fucking break already.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Let’s say the Giants wanted Watson </b><a name="15144017">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  2/4/2021  10:17 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144017">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143819" target="_blank">15143819</a> arniefez said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> And the Texans were willing to take Jones and three 1’s. Watson wouldn’t agree to come to the Giants in a million years with this roster and no 1’s until 2024. So of course the Giants didn’t make a call </td>
                                </tr>
                           </table><br />
<br />
Can you imagine the dialogue the last week with this brain trust?<br />
<br />
Judge: “What do we think about Watson wanting out of Houston? He’s a great player. If you want, I can reach out to Cesario because I got to know him a little bit in New England...”<br />
<br />
Gettleman: “Nah. I think we’re good with Daniel. I’ve felt as good about him today as I felt two years ago at the Senior Bowl. He’s a real professional quarterback. John? Chris?”<br />
<br />
John: “I agree. I think Jason will get him going like he did with Dak. I still see similarities with a young Eli. Plus, once we sign Saquon long term, we’re set for years...”<br />
<br />
Chris: “And Engram too...”</div></div><div class="thread_post"><div class="thread_post_header"><b>We don't.. </b><a name="15144022">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=FatMan+in+Charlotte"> FatMan in Charlotte </a>  :  2/4/2021  10:21 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144022">link</a>   </div></div><div class="thread_post_body">have to imagine.<br />
<br />
You'll keep posting made up versions of what happened as fact dozens of times this offseason.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Terps  </b><a name="15144033">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/4/2021  10:29 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144033">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144003" target="_blank">15144003</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> John Mara has 2 Super Bowls as the owner of the Giants. He held on to Coughlin and Reese for too long, but tough to fault him for it. He wasn’t going to let Eli Manning play for another franchise. Say what you want about that, but it’s over with. It looks like he finally got the head coach right after two bad hires. Give the guy a fucking break already. </td>
                                </tr>
                           </table><br />
<br />
And he's fucking that head coach with this stupidity.<br />
<br />
If he got the head coach hire right he should let him how his own staff, and replace the buffoon GM with a competent person of Judge's choosing. Then after that's done he should lose his fucking key card.</div></div><div class="thread_post"><div class="thread_post_header"><b>*hire </b><a name="15144034">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/4/2021  10:30 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144034">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>Land of the lost... </b><a name="15144036">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=trueblueinpw"> trueblueinpw </a>  :  2/4/2021  10:30 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144036">link</a>   </div></div><div class="thread_post_body">What’s the point of having a young HC if you’re going to saddle him with an old school O-co and a dinosaur GM? Seriously, the Giants are like the NFL team that time forgot.</div></div><div class="thread_post"><div class="thread_post_header"><b>Lol ok terps </b><a name="15144042">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/4/2021  10:36 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144042">link</a>   </div></div><div class="thread_post_body">maybe you can write a letter to Mara and ask him to turn in his key card as the owner of the team. <br />
<br />
God you are so tiresome.</div></div><div class="thread_post"><div class="thread_post_header"><b>Losing double digits games every year is tiresome </b><a name="15144045">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/4/2021  10:41 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144045">link</a>   </div></div><div class="thread_post_body">Then hearing every year how the arrow is pointing up is doubly tiresome.</div></div><div class="thread_post"><div class="thread_post_header"><b>Idk if Garrett was “forced” on Judge.. </b><a name="15144046">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sean"> Sean </a>  :  2/4/2021  10:42 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144046">link</a>   </div></div><div class="thread_post_body">I don’t think Jones is a good fit for Garrett nor do I think Garrett is a good fit for Jones.<br />
<br />
There is some Saban crossover with Judge/Garrett, but that is it. The rest of the staff does have Judge’s hands all over it though. And if you believe Raanan’s report, he also says that Kitchens & Schuplinski will have increased roles, both are Judge guys.<br />
<br />
I’ve gotta say, I did think Kitchens would be the OC this year and I think he eventually will be at some point.</div></div><div class="thread_post"><div class="thread_post_header"><b>Sean </b><a name="15144050">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/4/2021  10:45 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144050">link</a>   </div></div><div class="thread_post_body">We did hear rumors all year about Judge and Garrett not working well together, and barely speaking. Add on top of that the Colombo situation, the way Mara/Gettleman spoke about Garrett, and there's a lot of smoke there.</div></div><div class="thread_post"><div class="thread_post_header"><b>Judge & Graham are the brains of the staff it seems.. </b><a name="15144054">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sean"> Sean </a>  :  2/4/2021  10:50 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144054">link</a>   </div></div><div class="thread_post_body">Graham got a raise and has the Asst. HC title. From all indications too, Judge & Graham are the two that have been working closely looking at personnel since the season ended.<br />
<br />
I do think if Judge probably would want Kitchens as the OC. That’s just a hunch on my part. Garrett probably is set up to be the next fall guy.</div></div><div class="thread_post"><div class="thread_post_header"><b>Sean </b><a name="15144059">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/4/2021  10:57 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144059">link</a>   </div></div><div class="thread_post_body">I think you're absolutely right. The question is would that save Gettleman and Jones?</div></div><div class="thread_post"><div class="thread_post_header"><b>Terps </b><a name="15144060">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/4/2021  11:05 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144060">link</a>   </div></div><div class="thread_post_body">saying things like “Judge and Garrett were barely speaking” doesn’t make it true. You’re just spouting nonsense.</div></div><div class="thread_post"><div class="thread_post_header"><b>I really struggle with this anti-Garrett... </b><a name="15144064">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  2/4/2021  11:13 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144064">link</a>   </div></div><div class="thread_post_body">sentiment. He's had some terrific offenses. It's not like he's teaching Phil Jackson's "triangle offense".<br />
<br />
It's very likely the problem isn't Garrett. <br />
<br />
But (1) a QB who likely can't be effective in any NFL offense because he struggles with decision making and (2) the offense has leaks because of Gettleman.<br />
<br />
Always a fall guy at Jints Central. Create a distraction over here to take the light off the real problem(s) over there...</div></div><div class="thread_post"><div class="thread_post_header"><b>Good or bad, we must keep Garrett in 2021 </b><a name="15144076">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=CT+Charlie"> CT Charlie </a>  :  2/4/2021  11:32 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144076">link</a>   </div></div><div class="thread_post_body">because we can't force Jones and the team to learn a 3rd offense in 3 years. To those who say Garrett stinks, I ask this: How many offensive players on our team were clearly better than the average NFL player at their position? Only Saquon.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Good or bad, we must keep Garrett in 2021 </b><a name="15144077">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=eric2425ny"> eric2425ny </a>  :  2/4/2021  11:36 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144077">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144076" target="_blank">15144076</a> CT Charlie said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> because we can't force Jones and the team to learn a 3rd offense in 3 years. To those who say Garrett stinks, I ask this: How many offensive players on our team were clearly better than the average NFL player at their position? Only Saquon. </td>
                                </tr>
                           </table><br />
<br />
You’re right, and Saquon barely played this year.  What we are witnessing from Terps and others on this board is frustration with a bad product over the last several years.  It’s not even really about this particular groups of players on the roster now.  The team ended the season 5-3 and it looks like we have a good coach.  We should be excited about the future of the franchise.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Terps </b><a name="15144088">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/5/2021  12:12 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144088">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144060" target="_blank">15144060</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> saying things like “Judge and Garrett were barely speaking” doesn’t make it true. You’re just spouting nonsense. </td>
                                </tr>
                           </table><br />
<br />
That's what we were hearing from asshats that, if I remember correctly, have a good record of reliability here on BBI. <br />
<br />
You know what's actually nonsense? Claiming that Barkley's return will make a difference, or that Jones is showing great signs. <br />
<br />
Utter fiction.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Terps  </b><a name="15144096">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BleedBlue"> BleedBlue </a>  :  2/5/2021  2:20 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144096">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144003" target="_blank">15144003</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> John Mara has 2 Super Bowls as the owner of the Giants. He held on to Coughlin and Reese for too long, but tough to fault him for it. He wasn’t going to let Eli Manning play for another franchise. Say what you want about that, but it’s over with. It looks like he finally got the head coach right after two bad hires. Give the guy a fucking break already. </td>
                                </tr>
                           </table><br />
<br />
<br />
He never wjll. Terps is a fucking unbearable poster. He must get a blow job and complain the entire time</div></div><div class="thread_post"><div class="thread_post_header"><b>Anyone who thought Watson was ever a consideration is fool ish. </b><a name="15144102">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=George+from+PA"> George from PA </a>  :  2/5/2021  3:55 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144102">link</a>   </div></div><div class="thread_post_body">The media leads people around...like brain dead zombies.<br />
<br />
3 1's...with a salary to prevent getting any FA....what a great idea?<br />
<br />
Give Jones DeAndre Hopkins for a year.. remove mistake prone Engram, maybe with less then 4 new comers to OL, bring back our best RB with an embedded coaching staff and let's see what happens...before we venture into a foolhearty trade.<br />
<br />
Everyone killed DG for trading a 3rd and a 5th...for an expensive player....<br />
<br />
Look, I am as disappointed as anyone with the Giants play the past decade....yes, we have seen a ton of mistakes. This offense was pretty lame last year...but Garrett is far from an idiot....<br />
<br />
This coaching staff is entering year 2, not 10.<br />
<br />
Yes, mistakes were made...but this team competed pretty well.<br />
<br />
I am fine giving them a 2nd term.....<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>bw and Terps vs Fatman </b><a name="15144110">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BigBlueCane"> BigBlueCane </a>  :  2/5/2021  5:34 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144110">link</a>   </div></div><div class="thread_post_body">is my favorite feud on BBI.</div></div><div class="thread_post"><div class="thread_post_header"><b>I’m with bw on this </b><a name="15144115">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=cosmicj"> cosmicj </a>  :  2/5/2021  6:32 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144115">link</a>   </div></div><div class="thread_post_body">Garrett has coached some very good offenses.  But suddenly he is incompetent?  What are the variables here?<br />
<br />
1) Do you remember the anonymous insider quote about Garrett calling a brilliant game v Tampa and Jones repeatedly making mistakes to blow the game?  Hmm.  I’m not claiming that Garrett outcoaches everyone he faces, but to go from brilliant to incompetent?  I doubt that’s the case.<br />
<br />
2) A big deal is being made of Garrett resigning his OC duties in Dallas.  But he was an offensive minded HC.  You don’t think he had a lot of input into the play design and play calling in what was a very successful offense?  <br />
<br />
A lot of this anti- Garrett posting strikes me as underinformed fan bitching.  I don’t buy it.  <br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Is there any proof </b><a name="15144120">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Lines+of+Scrimmage"> Lines of Scrimmage </a>  :  2/5/2021  6:52 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144120">link</a>   </div></div><div class="thread_post_body">that Mara forced Garrett on Judge?  At best, I think he may have advised him that he may want to consider him.  For a first time HC not bad having someone who had been in that position (with some success) and who had deep knowledge of the division and from a team who had its way with your organization for several years.<br />
<br />
People like the next hot offensive coordinator or new wrinkle to offense.  The goal is to win championships and most times that still comes to winning on the lines.<br />
<br />
Judge definitely recognized the offense having issues early last year.  He worked with Thomas and his technique so I gather he first went to Garrett and then to Columbo.  I do think Judge will have a little more say in the offseason with giving guidance to Garrett and there will be adjustments next season.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Terps  </b><a name="15144123">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=robbieballs2003"> robbieballs2003 </a>  :  2/5/2021  7:16 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144123">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144096" target="_blank">15144096</a> BleedBlue said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144003 ryanmkeane said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     John Mara has 2 Super Bowls as the owner of the Giants. He held on to Coughlin and Reese for too long, but tough to fault him for it. He wasn’t going to let Eli Manning play for another franchise. Say what you want about that, but it’s over with. It looks like he finally got the head coach right after two bad hires. Give the guy a fucking break already. <br />
                                <br />
                           <br />
<br />
<br />
He never wjll. Terps is a fucking unbearable poster. He must get a blow job and complain the entire time </td>
                                </tr>
                           </table><br />
<br />
Hahaha</div></div><div class="thread_post"><div class="thread_post_header"><b>I think Garrett will get another head coaching job.. </b><a name="15144145">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sean"> Sean </a>  :  2/5/2021  7:55 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144145">link</a>   </div></div><div class="thread_post_body">Did anyone watch Dallas this year and think McCarthy was an upgrade over Garrett?</div></div><div class="thread_post"><div class="thread_post_header"><b>The reactions to this are far more interesting than the news </b><a name="15144147">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BillT"> BillT </a>  :  2/5/2021  8:01 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144147">link</a>   </div></div><div class="thread_post_body">Just saying.</div></div><div class="thread_post"><div class="thread_post_header"><b>What an off-the-rails thread </b><a name="15144157">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=HMunster"> HMunster </a>  :  2/5/2021  8:28 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144157">link</a>   </div></div><div class="thread_post_body">BBI: Garrett should get no credit for his offensive success in Dallas because look at all the great talent that he had to work with.<br />
<br />
Also BBI: Garrett is totally at fault for the Giants' poor offensive performance this past season - ignore the lack of talent that he had to work with.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>I love this thread ... </b><a name="15144160">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Spider56"> Spider56 </a>  :  2/5/2021  8:31 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144160">link</a>   </div></div><div class="thread_post_body">It prompts an immediate response from the consistent whiners.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: If I had to guess... </b><a name="15144174">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=section125"> section125 </a>  :  2/5/2021  8:50 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144174">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143733" target="_blank">15143733</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15143727 section125 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     In comment 15143725 bw in dc said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Gettleman never even called Cesario/Easterby. <br />
                                <br />
                           <br />
<br />
So the fuck what? <br />
                                <br />
                           <br />
<br />
If you knew that for a fact, that wouldn't bother you? </td>
                                </tr>
                           </table><br />
<br />
Why would it bother me? What is the point in stripping the team to get a $40 mill per year player when the team is devoid of offensive talent?<br />
<br />
DG believes in Jones - you don't, I have reservations but can at least see when he has some playmakers he is pretty good (2019 wasn't an illusion)<br />
<br />
Houston wants 3 or 4 1st round picks - great we get a VG QB and will not be able to give him any players to throw to....and to boot the guy is publicly whining. That will go over big in a year or two when he sees that without the 1st round pick they gave away the team still lacks talent. He will start whining again.<br />
<br />
Some of you like circular arguments just to argue.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I’d love to see the list of offensive coordinators  </b><a name="15144175">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  8:51 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144175">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143797" target="_blank">15143797</a> Chris684 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> scoring 30+ points per game with the offensive talent NYG played with last year. I’m sure that’s a really long list. <br />
<br />
Just like Gase was a genius without Manning. <br />
<br />
I’m sure the job Bienemy is doing in KC has nothing to do with the video game talent he has all over the offensive side of the ball. <br />
<br />
Some of you are so lost, which is fine, but you act like your mindless mouth breathing is gospel. I’m sure you couldn’t even describe accurately what Garrett’s system is you just don’t like it because “Mara picked him” or “he clapped too much in Dallas” or whatever. <br />
<br />
Let’s see what year 2 brings with some semblance of a normal training camp, Barkley in the fold and increased talent hopefully at TE and WR. </td>
                                </tr>
                           </table><br />
Other than Barkley's injury, which was obviously huge, most of the offensive "talent" is what Gettleman intended it to be.<br />
<br />
It just feels logically inconsistent to me when fans defend Garrett/Jones due to a lack of offensive talent, but don't then hold Gettleman accountable for... wait for it... a lack of offensive talent.</div></div><div class="thread_post"><div class="thread_post_header"><b>There can be more than one problem with the Giants... </b><a name="15144178">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=trueblueinpw"> trueblueinpw </a>  :  2/5/2021  8:57 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144178">link</a>   </div></div><div class="thread_post_body">I think Garrett is mired in the past and runs an unproductive offensive scheme. He isn’t terrible. But I think he’s from another era of pro football and hasn’t demonstrated much innovation or change. Has JG run some good offenses? He has. Has he run any innovative or over achieving offenses? I do not think so. Again though, he isn’t terrible, he just isn’t particularly promising when considering the future, even a future as limited as just next season. <br />
<br />
I think it’s also true that Jones is, at best, a huge question mark and presents an exceptional challenge for Garrett. The two are not better together. Think about McVay’s work with Goff, McDermit and his staff molding Josh Allen, Roman with LJax, or Reich working with an old Rivers. These are perfect analogues but the point is that the O-co and QB need to compliment each other. I’m not sure that’s happening here with Garrett and Jones. <br />
<br />
It is also true that the Giants offense lacks play makers. To me, this is slightly oversold, it’s true we don’t have great players but some of that has to do with our QB and the scheme of the O-co. We do have 4 1st round picks on offense. That’s not nothing. <br />
<br />
We’re they good picks? Some yes, some no. And that brings us to another problem with the Giants which is Getty who’s absolutely from the NFL way back machine. <br />
<br />
And that of course brings us to the owners who are, in my opinion, conservative to a fault. They took a real chance on a young guy like Judge, and even McAd’oh. That’s to be applauded. But they stuck with Reese way too long. And then they brought in a guy who’s just not the right choice for GM in the 21st century NFL. And while I have no inside proof, I think Garrett is a choice of ownership and GM to try and smooth things out for the young Judge. <br />
<br />
Anyway, it’s a lousy situation. It would be difficult for Jones to have a new O-co. And it is too soon to pull the plug on Jones. Best case scenario is that everything breaks our way and we at least get back to .500 or better football. I don’t see it happening with this current configuration. But I hope I’m wrong.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Terps </b><a name="15144179">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  8:57 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144179">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143896" target="_blank">15143896</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> context matters. You have an incredibly ability to leave it out of every statement you make.<br />
<br />
Maybe, just maybe, the Giants and Judge are really high on Garrett. And maybe, the reason we had a shitty offense is because our freakishly talented best player tore his knee, and we had a second year QB with almost nobody throwing to him. Yet when everything was clicking, the offense was more than solid.<br />
<br />
Give it some time before you just abandon ship on Garrett. He’s been the head of some really good offenses. </td>
                                </tr>
                           </table><br />
If our offense relies on someone throwing the ball to Jones, we've really screwed something up along the way.<br />
<br />
As for "when everything was clicking" - first of all, no it really wasn't "more than solid" and it was so rarely clicking that you can't really make any judgments about it either way due to small sample size. But the "more than solid" part of your statement is just further evidence that you don't actually know a single thing about the NFL outside of the Giants.<br />
<br />
And somehow you accuse Terps of lacking context? I don't think you know what that word means.</div></div><div class="thread_post"><div class="thread_post_header"><b>I’m worried Jones’ 2019 was a mirage created by Shurmur </b><a name="15144186">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=cosmicj"> cosmicj </a>  :  2/5/2021  9:02 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144186">link</a>   </div></div><div class="thread_post_body">Casey Keenum post- Shurmur has been playing at back up level quality.  <br />
<br />
So the conclusion I draw from this is that <br />
<br />
a) The Giants should in fact have hired Shurmur, but as an offensive coordinator.  Critical evaluation mistake and thus falls entirely on Gettleman.    When a very competent guy is hired (Shurmur) but put in the wrong position, that is squarely on his boss.  <br />
<br />
b) This botched execution - which led to Shurmur leaving the organization - has had knock-on effects.  Garrett is very likely a perfectly capable NFL OC but there may be system mismatches with him and the Giants personnel.  <br />
<br />
c) There is the very real possibility that Jones really doesn’t have a ceiling that is a lot higher than Keenum.  <br />
<br />
d) The Giants rebuild in 2018 and 2019 was completely botched at every level.  Drafting, FA signings, coaching selections.  And the guy who ran the show somehow still has his job.  So either John Mara knows this and has a transition plan being executed gradually or he is an idiot.   I vote for the latter.</div></div><div class="thread_post"><div class="thread_post_header"><b>cosmicj  </b><a name="15144191">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sean"> Sean </a>  :  2/5/2021  9:06 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144191">link</a>   </div></div><div class="thread_post_body">There is no way Gettleman had full autonomy on the Shurmur hire. The head coach falls on Mara.</div></div><div class="thread_post"><div class="thread_post_header"><b>Sean </b><a name="15144194">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=cosmicj"> cosmicj </a>  :  2/5/2021  9:09 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144194">link</a>   </div></div><div class="thread_post_body">I wasn’t claiming he did but I think it falls on the GM to tell the owner that he thinks a candidate is good but not for a given position.  That’s a technical judgement I would expect a GM to make and the conversation on the topic with Mara shouldn’t be a very difficult one.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: If I had to guess... </b><a name="15144199">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Harvest+Blend"> Harvest Blend </a>  :  2/5/2021  9:12 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144199">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143725" target="_blank">15143725</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Gettleman never even called Cesario/Easterby. </td>
                                </tr>
                           </table><br />
<br />
lol.  You were a little late that time though.</div></div><div class="thread_post"><div class="thread_post_header"><b>Cosmic - Mostly D.  Possibly some C </b><a name="15144202">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/5/2021  9:16 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144202">link</a>   </div></div><div class="thread_post_body">A and B are irrelevant.</div></div><div class="thread_post"><div class="thread_post_header"><b>The roster isn't ready for a QB to be plugged in </b><a name="15144204">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JonC"> JonC </a>  :  2/5/2021  9:17 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144204">link</a>   </div></div><div class="thread_post_body">which means it doesn't make a ton of sense to burn a pile of precious premium draft assets on the QB position, imo.  They're going to build around Jones and if it fails they'll be picking a new GM and another QB high in the draft in a couple years.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Sean </b><a name="15144208">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sean"> Sean </a>  :  2/5/2021  9:20 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144208">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144194" target="_blank">15144194</a> cosmicj said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I wasn’t claiming he did but I think it falls on the GM to tell the owner that he thinks a candidate is good but not for a given position.  That’s a technical judgement I would expect a GM to make and the conversation on the topic with Mara shouldn’t be a very difficult one. </td>
                                </tr>
                           </table><br />
<br />
I agree. I also never got the sense that Gettleman & Shurmur had the same philosophy on winning football. Always was a strange fit to me.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I’m worried Jones’ 2019 was a mirage created by Shurmur </b><a name="15144214">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=eric2425ny"> eric2425ny </a>  :  2/5/2021  9:28 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144214">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144186" target="_blank">15144186</a> cosmicj said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Casey Keenum post- Shurmur has been playing at back up level quality.  <br />
<br />
So the conclusion I draw from this is that <br />
<br />
a) The Giants should in fact have hired Shurmur, but as an offensive coordinator.  Critical evaluation mistake and thus falls entirely on Gettleman.    When a very competent guy is hired (Shurmur) but put in the wrong position, that is squarely on his boss.  <br />
<br />
b) This botched execution - which led to Shurmur leaving the organization - has had knock-on effects.  Garrett is very likely a perfectly capable NFL OC but there may be system mismatches with him and the Giants personnel.  <br />
<br />
c) There is the very real possibility that Jones really doesn’t have a ceiling that is a lot higher than Keenum.  <br />
<br />
d) The Giants rebuild in 2018 and 2019 was completely botched at every level.  Drafting, FA signings, coaching selections.  And the guy who ran the show somehow still has his job.  So either John Mara knows this and has a transition plan being executed gradually or he is an idiot.   I vote for the latter. </td>
                                </tr>
                           </table><br />
<br />
Shurmur was not leaving Minnesota as an offensive coordinator to come here and be an offensive coordinator.  He had previously been a head coach with the Browns and was looking for his next head coaching opportunity after a very successful season with Minnesota.</div></div><div class="thread_post"><div class="thread_post_header"><b>Neither this surprisging.  </b><a name="15144223">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Saquads26"> Saquads26 </a>  :  2/5/2021  9:33 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144223">link</a>   </div></div><div class="thread_post_body">In Judge we trust. You guys realize Garrett and Jones had little to work with  this year right? There's a reason they want a new OL coach and Gettleman preached playmakers.    <br />
<br />
Oh and Watson was never an option nor should he have been.  Hope he gets traded to the worst team in the league.  Cry baby idiot</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I'll certainly underscore it... </b><a name="15144235">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=EricJ"> EricJ </a>  :  2/5/2021  9:45 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144235">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15143742" target="_blank">15143742</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> if it comes out that Ole Dave never even bothered to call the Texans, yes.<br />
</td>
                                </tr>
                           </table><br />
<br />
Why would he NEED to call the Texans about Watson. It is YOU who thinks it makes sense to mortgage our future for a QB who has not won anything significant in this league.<br />
<br />
If I am DG, I am not calling the Texans about Watson. Not at this point. There is too much time between Feb 5 and the draft. Too many more failed negotiations between the Texans and teams who may actually have serious interest in Watson. Houston needs to see what the true market value is for Watson right now.<br />
<br />
From a pure negotiation standpoint taking the names out of the equation it makes NO sense for the Giants to have called them right now....none.<br />
<br />
You are the one who has a boner for Watson and a stick up your ass about Jones. So.. you think a call should have been made.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Dunk </b><a name="15144239">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  9:49 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144239">link</a>   </div></div><div class="thread_post_body">you are unbearable. Yes - the 6 week period starting with the game at Dallas, the offense was solid and doing alright. Without Barkley, without any receivers, we were moving the ball, scoring around 25 PPG. But again - people seem to forget that this ever happened.</div></div><div class="thread_post"><div class="thread_post_header"><b>Garrett is a smart guy..... </b><a name="15144257">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Simms11"> Simms11 </a>  :  2/5/2021  9:57 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144257">link</a>   </div></div><div class="thread_post_body">He knows what right looks like and should have a better feel for personnel now. Judge indicated that they would look at everything, including schemes, now. I really think the fate of Garrett and Jones will be joined this year. Judge will have more time with a new OC and QB after next TY, if it comes to that, IMHO. Personally I'm rooting for the guy. I really hope the whole offense turns around next year. Having a stable Oline, SB back in the fold and some quality at WR should go a long way in improving this offense, regardless of scheme.</div></div><div class="thread_post"><div class="thread_post_header"><b>Why do people keep saying without any receivers... </b><a name="15144261">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/5/2021  10:00 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144261">link</a>   </div></div><div class="thread_post_body">Did we lose some all-pro receivers from the roster between 2019 and 2020?<br />
<br />
Wasn't everybody the same except for having Engram's availability, albeit that not being a good thing.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Dunk </b><a name="15144278">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  10:13 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144278">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144239" target="_blank">15144239</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> you are unbearable. Yes - the 6 week period starting with the game at Dallas, the offense was solid and doing alright. Without Barkley, without any receivers, we were moving the ball, scoring around 25 PPG. But again - people seem to forget that this ever happened. </td>
                                </tr>
                           </table><br />
You're cherry picking a stretch where 6 of the only 7 games where the Giants even scored 20 points occurred. And in that 6 game stretch, the Giants failed to score even 24 points 4/6 times. Also, two of the games in that 6 game stretch when the offense was supposedly clicking had TDs scored by the defense. The offense scored 22.3 PPG during that supposedly prolific stretch.<br />
<br />
The average weekly scoring output for the other 31 teams in the NFL was 25.0.<br />
<br />
The Giants surpassed that number twice all season.  The offense did not score 30 points in any game all year. There is no honest way to portray that as an offense that was ever clicking. And there's also no honest way to defend the offense as lacking talent while simultaneously defending the GM who built the roster.<br />
<br />
I might be unbearable, but you're a joke.</div></div><div class="thread_post"><div class="thread_post_header"><b>That should be enough </b><a name="15144282">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/5/2021  10:19 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144282">link</a>   </div></div><div class="thread_post_body">context.</div></div><div class="thread_post"><div class="thread_post_header"><b>I don't think Garrett is a bad OC </b><a name="15144284">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=UberAlias"> UberAlias </a>  :  2/5/2021  10:20 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144284">link</a>   </div></div><div class="thread_post_body">He may be, but I'm not so sure.  I'd want to see how the offense looks with some adds at skills or Oline.  <br />
<br />
If we're not seeing Barkley looking like an elite back and improvement on Oline and Jones, DG and JG better be gone.</div></div><div class="thread_post"><div class="thread_post_header"><b>Googs </b><a name="15144287">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  10:23 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144287">link</a>   </div></div><div class="thread_post_body">yeah....it's still not.</div></div><div class="thread_post"><div class="thread_post_header"><b>If the offense still isn't good </b><a name="15144288">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  10:24 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144288">link</a>   </div></div><div class="thread_post_body">with Barkley and more weapons at WR, then we can talk. Until we see it, nobody should be making any definitive statements.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Googs </b><a name="15144291">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/5/2021  10:27 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144291">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144287" target="_blank">15144287</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> yeah....it's still not. </td>
                                </tr>
                           </table><br />
<br />
OK, we tried. <br />
<br />
What's the response to my receiver question?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: If the offense still isn't good </b><a name="15144300">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Greg+from+LI"> Greg from LI </a>  :  2/5/2021  10:37 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144300">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144288" target="_blank">15144288</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> with Barkley and more weapons at WR, then we can talk. Until we see it, nobody should be making any definitive statements. </td>
                                </tr>
                           </table><br />
<br />
That lack of weapons is rough.  Say, whose responsibility is that?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: If the offense still isn't good </b><a name="15144302">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JonC"> JonC </a>  :  2/5/2021  10:38 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144302">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144288" target="_blank">15144288</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> with Barkley and more weapons at WR, then we can talk. Until we see it, nobody should be making any definitive statements. </td>
                                </tr>
                           </table><br />
<br />
Based on this logic, there's no reason to discuss NYG football until after it happens.</div></div><div class="thread_post"><div class="thread_post_header"><b>Jon </b><a name="15144304">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  10:40 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144304">link</a>   </div></div><div class="thread_post_body">nope, there's a reason to discuss it. But if you're building a team, you can't just constantly bitch about it as it's building. <br />
<br />
This goes to my point about how all of BBI wanted to tear it down and start over...and we did that in 2019/2020....and everyone is still bitching.</div></div><div class="thread_post"><div class="thread_post_header"><b>Put it this way </b><a name="15144306">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  10:41 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144306">link</a>   </div></div><div class="thread_post_body">if Barkley doesn't tear is knee, we likely win 7-8 games and make the playoffs, and every single poster on this board is in a way different mood than they are now.<br />
<br />
But it happened, injuries happen. But when it's your BEST PLAYER, that's a problem.</div></div><div class="thread_post"><div class="thread_post_header"><b>Greg </b><a name="15144309">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  10:44 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144309">link</a>   </div></div><div class="thread_post_body">yeah...the lack of weapons is rough. That's on DG. Past two drafts, he focused on the trenches and back 7 and completely disregarded WR. Not great. That being said - I think that changes this offseason.</div></div><div class="thread_post"><div class="thread_post_header"><b>Not sure what you expect </b><a name="15144314">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JonC"> JonC </a>  :  2/5/2021  10:45 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144314">link</a>   </div></div><div class="thread_post_body">from a fan board of a team in the midst of an ugly stretch of losing football.  Every thing will be dissected until the product demonstrates otherwise.  Showing signs of discipline, preparation, and effort on gameday are foundational positives.  But, there's still a ton to fix and talent is one part of it.<br />
<br />
It seems you're unable to deal with doses of realism.  It's the core of why you're getting beaten up often.  There are reasons to hold some optimism here, and also plenty of skepticism at the same time.  They're not mutually exclusive.</div></div><div class="thread_post"><div class="thread_post_header"><b>If you're unable or unwilling to think down more than one path </b><a name="15144315">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JonC"> JonC </a>  :  2/5/2021  10:46 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144315">link</a>   </div></div><div class="thread_post_body">at a time, you're going to continue to get beaten up.</div></div><div class="thread_post"><div class="thread_post_header"><b>Jon </b><a name="15144316">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  10:49 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144316">link</a>   </div></div><div class="thread_post_body">when posters beg and beg the team to rebuild, and then they do it, and then you are pissed that they aren't good....to me that's just bullshit. You can't ask for something and then completely change course when you realize "hey...actually...hmmmm we are probably better than I expected, damn why didn't we make the playoffs this year!!"<br />
<br />
My opinion of the team has not changed. Its others who constantly move the goal posts. We went from a shitty 3 win team, to "we should definitely win the division" to "we suck again" all in one season.<br />
<br />
There is zero patience when it comes tot his new regime, and that's just the way it is. I've accepted it. I'm willing to wait until the end of 2021 season to fully see whether this whole thing has worked...some aren't willing to. That's fine.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Is winning 7-8 games and a playoff spot </b><a name="15144317">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JonC"> JonC </a>  :  2/5/2021  10:50 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144317">link</a>   </div></div><div class="thread_post_body">in an awful NFCE really indicative of a great deal of progress?  It's progress but it's still an awful division and a very average football team, in proper context.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: If you're unable or unwilling to think down more than one path </b><a name="15144318">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  10:51 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144318">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144315" target="_blank">15144315</a> JonC said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> at a time, you're going to continue to get beaten up. </td>
                                </tr>
                           </table><br />
Yeah - are you saying that only applies to me? Look around.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Is winning 7-8 games and a playoff spot </b><a name="15144320">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  10:52 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144320">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144317" target="_blank">15144317</a> JonC said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> in an awful NFCE really indicative of a great deal of progress?  It's progress but it's still an awful division and a very average football team, in proper context. </td>
                                </tr>
                           </table><br />
No, that's where you are putting words in my mouth. It isn't a "great deal of progress" but it would have been a nice progression, and a positive step. Plenty of things happened this year that made me think we are going in the right direction. Plenty of things didn't go well. I'm willing to combine the two and make an opinion considering all of the factors. Some posters look at the record of a first year coach, 2nd year QB, without our best playmaker...and go "we suck." Not the case.</div></div><div class="thread_post"><div class="thread_post_header"><b>They've been awful 8 out of the last 9 years </b><a name="15144321">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Dave+in+Hoboken"> Dave in Hoboken </a>  :  2/5/2021  10:53 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144321">link</a>   </div></div><div class="thread_post_body">and have had the worst record in all of football the past three seasons before this past season.  It's so shocking that people are more on the negative side than the positive.<br />
<br />
Absolutely shocking.</div></div><div class="thread_post"><div class="thread_post_header"><b>.... </b><a name="15144327">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  10:56 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144327">link</a>   </div></div><div class="thread_post_body">we beatle Seattle without our starting QB. We outplayed Tampa and LA for 50 minutes. We swept the winner of our division. We totally revamped the defense and were one of the strongest units in the NFC. Yeah - a lot of things didn't go well including the offense being shitty for the majority of the season. Call me crazy but just maybe...we will get better on offense once Barkley returns, we add a WR or two, and the OL continues to gel. And no, these aren't excuses...just calling it like I see it.</div></div><div class="thread_post"><div class="thread_post_header"><b>I watch and see </b><a name="15144328">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JonC"> JonC </a>  :  2/5/2021  10:56 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144328">link</a>   </div></div><div class="thread_post_body">and try to help others who can use the perspective to see things differently.  Many here are beyond help and you won't get through to them no matter what the topic, got to know how to identify them and when to fold your hand.<br />
<br />
If you tell me 2020 is really something to build off for this offense, I disagree.  On the whole the unit stunk and big questions remain on Jones, Garrett, the scheme's validity, and those are separate considerations from Barkley's knee, the need for upgrades at WR, the very unfinished OL.<br />
<br />
With UFA and draft ramping up, these are vital discussions for now, not during or after the 2021 season.</div></div><div class="thread_post"><div class="thread_post_header"><b>Dave </b><a name="15144329">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  10:57 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144329">link</a>   </div></div><div class="thread_post_body">nope, it's not shocking. I'm just tired of people like you who are comparing this version of the team to 2013-2018.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>We did want a rebuild </b><a name="15144331">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/5/2021  10:59 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144331">link</a>   </div></div><div class="thread_post_body">We just didn't want one that was executed this poorly.</div></div><div class="thread_post"><div class="thread_post_header"><b>Jon </b><a name="15144333">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  11:00 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144333">link</a>   </div></div><div class="thread_post_body">that's the thing...I actually agree with you on the offense that there is a lot up in the air and a lot of skepticism about whether or not it's going to work. But...we just have to see. <br />
<br />
Again, all long, I've said...if it still stinks next year...then yeah obviously it didn't work. Last I checked, Garrett has had 1 full year as the OC with a second year QB, not a ton of weapons including one of the best RBs in football, and a young OL. Let's just give him a few more weeks before we jump ship here.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Is winning 7-8 games and a playoff spot </b><a name="15144334">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JonC"> JonC </a>  :  2/5/2021  11:00 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144334">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144320" target="_blank">15144320</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144317 JonC said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     in an awful NFCE really indicative of a great deal of progress?  It's progress but it's still an awful division and a very average football team, in proper context. <br />
                                <br />
                           <br />
No, that's where you are putting words in my mouth. It isn't a "great deal of progress" but it would have been a nice progression, and a positive step. Plenty of things happened this year that made me think we are going in the right direction. Plenty of things didn't go well. I'm willing to combine the two and make an opinion considering all of the factors. Some posters look at the record of a first year coach, 2nd year QB, without our best playmaker...and go "we suck." Not the case. </td>
                                </tr>
                           </table><br />
<br />
No attempt at putting words, just a question and indicator of how much you success you think was made.  This offense sucked, with or without Barkley and the rest of it.  All you had to do was watch the games and then watch other games around the league to compare.  We're reduced to hoping for more talent to be properly identified, and that the unit will somehow be more like 2019 than 2020, until it's demonstrated on the field.  Hope isn't a plan, it's at the core of the frustration here.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: We did want a rebuild </b><a name="15144335">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  11:00 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144335">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144331" target="_blank">15144331</a> Go Terps said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> We just didn't want one that was executed this poorly. </td>
                                </tr>
                           </table><br />
Well, I guess we will see if it was executed poorly by next year won't we?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: .... </b><a name="15144339">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JonC"> JonC </a>  :  2/5/2021  11:02 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144339">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144327" target="_blank">15144327</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> we beatle Seattle without our starting QB. We outplayed Tampa and LA for 50 minutes. We swept the winner of our division. We totally revamped the defense and were one of the strongest units in the NFC. Yeah - a lot of things didn't go well including the offense being shitty for the majority of the season. Call me crazy but just maybe...we will get better on offense once Barkley returns, we add a WR or two, and the OL continues to gel. And no, these aren't excuses...just calling it like I see it. </td>
                                </tr>
                           </table><br />
<br />
It's a significant list that needs to go correctly.  It's not impossible but so far there's plenty to suggest more mistakes are going to happen along the way.  That's what happens when a team drafts for need, or uses UFA incorrectly, etc.</div></div><div class="thread_post"><div class="thread_post_header"><b>Don't understand the patience & cautious optimism re: Garrett as Giant </b><a name="15144340">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Kyle_"> Kyle_ </a>  :  2/5/2021  11:03 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144340">link</a>   </div></div><div class="thread_post_body">when he was routinely, deservedly mocked in Dallas for serving as a wonderful hard ceiling on that team, including that absolutely fucking loaded offense.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: We did want a rebuild </b><a name="15144351">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/5/2021  11:06 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144351">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144335" target="_blank">15144335</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144331 Go Terps said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     We just didn't want one that was executed this poorly. <br />
                                <br />
                           <br />
Well, I guess we will see if it was executed poorly by next year won't we? </td>
                                </tr>
                           </table><br />
<br />
We can see it now. It's built around a low ceiling QB that's terrible in the pocket and a running back that can't block. And the offense is designed to keep the quarterback in the pocket...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Put it this way </b><a name="15144362">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/5/2021  11:21 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144362">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144306" target="_blank">15144306</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> if Barkley doesn't tear is knee, we likely win 7-8 games and make the playoffs, and every single poster on this board is in a way different mood than they are now.<br />
<br />
But it happened, injuries happen. But when it's your BEST PLAYER, that's a problem. </td>
                                </tr>
                           </table><br />
<br />
I wonder if Dallas or Washington wish their QBs made it thru the season too.  Or didn't that happen?</div></div><div class="thread_post"><div class="thread_post_header"><b>........ </b><a name="15144364">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=CoughlinHandsonHips"> CoughlinHandsonHips </a>  :  2/5/2021  11:21 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144364">link</a>   </div></div><div class="thread_post_body">The rebuild officially started when Eli retired. Before that, it was "win 1 more with Eli," which was a pipe dream.<br />
<br />
Even when they drafted Jones, they paid Eli to be a $20 million dollar backup hoping he could hold of Jones that last year.<br />
<br />
Keep the staff together. Big prove it year for Jones and Barkley.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: We did want a rebuild </b><a name="15144366">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  11:23 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144366">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144335" target="_blank">15144335</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144331 Go Terps said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     We just didn't want one that was executed this poorly. <br />
                                <br />
                           <br />
Well, I guess we will see if it was executed poorly by next year won't we? </td>
                                </tr>
                           </table><br />
We can already see that it's being executed poorly.<br />
<br />
The rebuild started a full year late, included as many misses as hits in the draft, and handed out albatross contracts along the way.  For the third offseason in a row, we're going to watch this team just plug new holes that they created for themselves with poor acquisitions rather than taking a foundation from the year prior and building upon it.<br />
<br />
We'll probably draft a WR in the first round and/or spend big money on one in free agency to give Jones a playmaker, because the WR that DG signed to significant dollars just a couple of years ago (Tate) sucked. Just like we took an OT in the first round last year because the OT that DG signed to big money a few years earlier (Solder) sucked, and just like we spent decent money on a LB in free agency last year because the one that DG traded for a few years earlier (Ogletree) sucked. <br />
<br />
Every time that happens, an opportunity to meaningfully improve the team is wasted as we use impact resources on positions that we've previously (and recently) used impact resources on, but failed. How much better is this team if Solder had been competent enough to use the #4 pick on a different position last year?  How much better is this team if Ogletree had been good enough to use the money spent on Martinez elsewhere last year? What would we be targeting this offseason if Tate had been a viable WR solution? <br />
<br />
We're going into DG's fourth offseason and every single year since his first, the top offseason priority on the shopping list has been at a position that he has previously addressed and gotten wrong. That's why this is taking longer than it takes other teams. That's why fans are growing impatient.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Jon </b><a name="15144370">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/5/2021  11:27 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144370">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144316" target="_blank">15144316</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> when posters beg and beg the team to rebuild, and then they do it, and then you are pissed that they aren't good....to me that's just bullshit. You can't ask for something and then completely change course when you realize "hey...actually...hmmmm we are probably better than I expected, damn why didn't we make the playoffs this year!!"<br />
<br />
 </td>
                                </tr>
                           </table><br />
<br />
Just so you know, posters weren't just begging for a rebuild. They were expecting it to be accomplished in better than a half-ass way.  <br />
<br />
When you show you suck at staying the course and suck at rebuilding too, well there is not much else you can hang your hat on. Hence, why you see the impatience.</div></div><div class="thread_post"><div class="thread_post_header"><b>Dunk </b><a name="15144376">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JonC"> JonC </a>  :  2/5/2021  11:30 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144376">link</a>   </div></div><div class="thread_post_body">good post.</div></div><div class="thread_post"><div class="thread_post_header"><b>2019 was a mirage for DJ... </b><a name="15144382">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Dnew15"> Dnew15 </a>  :  2/5/2021  11:35 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144382">link</a>   </div></div><div class="thread_post_body">that wasn't Shurmur's amazing play design or play calling or offensive mind at work....that was an equally dismal collection of players getting statistically fat on some historically terrible defenses.<br />
<br />
Garrett called the game to keep this team (with all its flaws) close. And for the most part it worked.</div></div><div class="thread_post"><div class="thread_post_header"><b>And to be fair to DJ... </b><a name="15144386">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Dnew15"> Dnew15 </a>  :  2/5/2021  11:40 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144386">link</a>   </div></div><div class="thread_post_body">I think this year was also a mirage.<br />
<br />
The Giants had to face an inordinate number of teams that ranked in the top half defensively of the NFL that suppressed his stats. Add in the fact that he had no SB for the majority of the year and it's the perfect recipe for a disastrous statistical season.<br />
<br />
My guess is that DJ's real statistical mean is somewhere in-between.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Way to go out on a limb.. </b><a name="15144389">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Dnew15"> Dnew15 </a>  :  2/5/2021  11:42 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144389">link</a>   </div></div><div class="thread_post_body">Dnew15..."his statistical mean in somewhere in-between"?<br />
<br />
What an idiot.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I'll certainly underscore it... </b><a name="15144390">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  2/5/2021  11:44 am   : <a href="index.php?mode=2&thread=605822&show_all=1#15144390">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144235" target="_blank">15144235</a> EricJ said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15143742 bw in dc said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     if it comes out that Ole Dave never even bothered to call the Texans, yes.<br />
<br />
                                <br />
                           <br />
<br />
Why would he NEED to call the Texans about Watson. It is YOU who thinks it makes sense to mortgage our future for a QB who has not won anything significant in this league.<br />
<br />
If I am DG, I am not calling the Texans about Watson. Not at this point. There is too much time between Feb 5 and the draft. Too many more failed negotiations between the Texans and teams who may actually have serious interest in Watson. Houston needs to see what the true market value is for Watson right now.<br />
<br />
From a pure negotiation standpoint taking the names out of the equation it makes NO sense for the Giants to have called them right now....none.<br />
<br />
You are the one who has a boner for Watson and a stick up your ass about Jones. So.. you think a call should have been made.<br />
 </td>
                                </tr>
                           </table><br />
<br />
If a great player/QB is available it is absolutely incumbent from any team short of having Rodgers/Mahomes/Wilson/Brady to inquire. And so what if he hasn't won anything yet. Watson is only 25; and he actually led his team to a national championship at Clemson. The pedigree is there. Remind me - what the hell has Jones ever done at any level?<br />
<br />
It's smart business. In fact, it's business 101 across any industry. You always call.<br />
<br />
And here's why - you never know what the other side might be thinking. They may like Jones as a prospect and are willing to create a package that is too good to pass up.<br />
<br />
At the end of the day, this much is clear - Watson play the most critical position in the sport and a helluva lot better than Jones will likely ever play it.<br />
<br />
But, hey, let's stay tethered to Jones because he may someday be better than the game manager he is. <br />
<br />
Super...back in the box we go!</div></div><div class="thread_post"><div class="thread_post_header"><b>Would suggest many teams not solidified at QB </b><a name="15144440">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/5/2021  12:45 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144440">link</a>   </div></div><div class="thread_post_body">should be putting together an offer package for Watson. <br />
<br />
Opportunities of guys like Watson becoming available almost never happen. In the end, the offer may not be competitive but suggesting a phone call shouldn't even be entertained sounds a bit negligent. Particularly when you are talking about a franchise going thru a bit of distress right now.<br />
<br />
Oh, and I meant the Texans on that last part but I guess you can look at it both ways...<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>I don’t think everybody is realizing that what emerged </b><a name="15144445">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=cosmicj"> cosmicj </a>  :  2/5/2021  12:52 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144445">link</a>   </div></div><div class="thread_post_body">This last October and November was disastrous for the Giants franchise.  And I mean disastrous.  <br />
<br />
1) Josh Allen emerges as a star QB.<br />
2) Justin Herbert shows every sign of becoming a star.<br />
3) Daniel Jones performs like a back up level QB.<br />
<br />
Allen and Herbert were there for the Giants to simply draft them - just walk up to the podium and say their name. This is f*****g catastrophic.<br />
<br />
The Saquon injury is almost besides the point.  Maybe Jones will look like he can become an average NFL QB with better play around him.  Big whoop-de-ding-dong.  We can look forward to being bystanders while players like Mahomes, Allen and other elite QB talents lead their teams in key playoff matchups.</div></div><div class="thread_post"><div class="thread_post_header"><b>Yeah.. </b><a name="15144449">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=FatMan+in+Charlotte"> FatMan in Charlotte </a>  :  2/5/2021  12:57 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144449">link</a>   </div></div><div class="thread_post_body">that's not a huge dramatic over-reaction.<br />
<br />
Fuck us.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Yeah.. </b><a name="15144463">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  1:10 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144463">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144449" target="_blank">15144449</a> FatMan in Charlotte said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> that's not a huge dramatic over-reaction.<br />
<br />
Fuck us. </td>
                                </tr>
                           </table><br />
Yay, another agenda-agnostic post from our chief data scientist who absolutely never contorts himself to defend DG.</div></div><div class="thread_post"><div class="thread_post_header"><b>Dunk </b><a name="15144471">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  1:16 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144471">link</a>   </div></div><div class="thread_post_body">we will see if the Giants plan works out next season. If they imrpove, win the division, and make the playoffs, I imagine you'll make up some excuse to say well the division sucks, etc.<br />
<br />
If they don't improve, then DG will be gone, DJ likely gone and everyone will get their wish. And then I'm sure everyone will have nothing to say when a new GM comes in and totally whiffs on a 1st round pick.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Dunk </b><a name="15144475">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/5/2021  1:19 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144475">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144471" target="_blank">15144471</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> we will see if the Giants plan works out next season. If they imrpove, win the division, and make the playoffs, I imagine you'll make up some excuse to say well the division sucks, etc.<br />
<br />
If they don't improve, then DG will be gone, DJ likely gone and everyone will get their wish. And then I'm sure everyone will have nothing to say when a new GM comes in and totally whiffs on a 1st round pick. </td>
                                </tr>
                           </table><br />
<br />
No, we'll have plenty to say. We know what whiffing on first rounders looks like pretty well around here.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Dunk </b><a name="15144486">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  1:25 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144486">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144471" target="_blank">15144471</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> we will see if the Giants plan works out next season. If they imrpove, win the division, and make the playoffs, I imagine you'll make up some excuse to say well the division sucks, etc.<br />
<br />
If they don't improve, then DG will be gone, DJ likely gone and everyone will get their wish. And then I'm sure everyone will have nothing to say when a new GM comes in and totally whiffs on a 1st round pick. </td>
                                </tr>
                           </table><br />
I'm not the one making up excuses.<br />
<br />
They DO suck, and have sucked every year of DG's tenure. And he has contributed to them sucking. Anyone who doesn't acknowledge that is making up excuses. Like you, for example.<br />
<br />
GMs do miss on picks. They do miss on FA signings. And that's why their teams aren't as good as they could be.<br />
<br />
DG took over a team that was in rough shape, but it wasn't as bad as his apologists make it out to be - they won 11 (ELEVEN) games the year before he came in. And he proceeded to take a team that was in nosedive mode and simply flatten the crash landing. <br />
<br />
Every single major move he has made has either been in response to one of his failed moves or required another major move to correct it. You can never build a winner that way - you need to hit on more than 50% of your swings, and you need to not constantly be filling holes that you created for yourself so that you can actually build something up instead of building it back.</div></div><div class="thread_post"><div class="thread_post_header"><b>That is a lot of </b><a name="15144490">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JonC"> JonC </a>  :  2/5/2021  1:25 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144490">link</a>   </div></div><div class="thread_post_body">ifs.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: I'll certainly underscore it... </b><a name="15144497">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=EricJ"> EricJ </a>  :  2/5/2021  1:28 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144497">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144390" target="_blank">15144390</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br />
If a great player/QB is available it is absolutely incumbent from any team short of having Rodgers/Mahomes/Wilson/Brady to inquire.  </td>
                                </tr>
                           </table><br />
<br />
So Watson is "great" now? The fucking guy has won regular season games and that's it. Are we throwing that word around willy-nilly now? How about Generational or HOF?<br />
<br />
Not to say that he cannot be great one day, but it has not been proven that yet. He has had one of the best WRs in the game in Hopkins on his team and they did not get his team deep into the playoffs.<br />
<br />
So you want to bring him here with fewer weapons than what he had in Houston and simultaneously limiting our ability to assemble the pieces around him after giving up everything in draft picks just to get him.<br />
<br />
Stop playing fantasy football. I would not let you babysit my fantasy football team even for 2 min while I go to the bathroom.</div></div><div class="thread_post"><div class="thread_post_header"><b>Dunk </b><a name="15144503">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  1:32 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144503">link</a>   </div></div><div class="thread_post_body">the Giants don't suck. If you think this current version of the team going into 2021 sucks, we are watching different games</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: I'll certainly underscore it... </b><a name="15144504">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  1:32 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144504">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144497" target="_blank">15144497</a> EricJ said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144390 bw in dc said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     <br />
If a great player/QB is available it is absolutely incumbent from any team short of having Rodgers/Mahomes/Wilson/Brady to inquire.  <br />
                                <br />
                           <br />
<br />
So Watson is "great" now? The fucking guy has won regular season games and that's it. Are we throwing that word around willy-nilly now? How about Generational or HOF?<br />
<br />
Not to say that he cannot be great one day, but it has not been proven that yet. He has had one of the best WRs in the game in Hopkins on his team and they did not get his team deep into the playoffs.<br />
<br />
So you want to bring him here with fewer weapons than what he had in Houston and simultaneously limiting our ability to assemble the pieces around him after giving up everything in draft picks just to get him.<br />
<br />
Stop playing fantasy football. I would not let you babysit my fantasy football team even for 2 min while I go to the bathroom. </td>
                                </tr>
                           </table><br />
You do realize that he put up even better numbers without Hopkins than he did WITH Hopkins, right?<br />
<br />
Maybe you were in the shitter when that happened.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Dunk </b><a name="15144510">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  1:35 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144510">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144503" target="_blank">15144503</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> the Giants don't suck. If you think this current version of the team going into 2021 sucks, we are watching different games </td>
                                </tr>
                           </table><br />
LOL, ok.<br />
<br />
They have been in the bottom third of the league since 2017.<br />
<br />
They suck.<br />
<br />
I think it's pretty clear by now that - to steal a reference from Terps - the Giants could trade for a blanket infected with small pox and you'd defend the move.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Dunk </b><a name="15144511">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/5/2021  1:35 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144511">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144503" target="_blank">15144503</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> the Giants don't suck. If you think this current version of the team going into 2021 sucks, we are watching different games </td>
                                </tr>
                           </table><br />
<br />
6-10, 17.5 points per game.<br />
<br />
The Giants sucked in 2020.</div></div><div class="thread_post"><div class="thread_post_header"><b>Stockholm Syndrome  </b><a name="15144512">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+from+Katonah"> Jim from Katonah </a>  :  2/5/2021  1:36 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144512">link</a>   </div></div><div class="thread_post_body">Since 2012, we’ve had one winning season, we are on our 4th head coach, and in a juiced-scoring league where Tyler Heinicke can pop out of grad school for a playoff game and throw for 300 yards vs a Super Bowl defense while we can’t crack 18 points a game ... our front office is like meh, we ain’t interested in working the phones.<br />
<br />
Many of us on this board have been Giants fans forever and wouldn’t be wasting their time on a message board if the stupid team didn’t mean something important to them (for me it’s the continuation of my dad’s love of the team dating back to the 50s). After all the loyal support from their great fan base, is it too much to ask that they turn the front office/scouting into the league’s best? That they work and scratch and claw to gain any possible edge? Does anyone on this board think that they are doing that? Don’t we deserve to have a nimble, technologically advanced front office like the Ravens, a team that could flip on a dime from Flacco to Lamar Jackson? What are we, chopped liver? <br />
<br />
Speaking for myself, my frustration is not about this going on 8 year rebuild that has led us nowhere (what’s the Vegas win total for 2021, maybe 7?), it’s a feeling that the Jints owners and FO are comfortable with business as usual, and we are just laughably behind other organizations in staffing, vision, and hunger.  It’s NY! Pull it together! Bring in the best!  (Yes, I’m screaming at the clouds at this point lol). Oyy.</div></div><div class="thread_post"><div class="thread_post_header"><b>I haven't seen Watson play really since the crappy winless 2018 Giants </b><a name="15144515">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Britt+in+VA"> Britt in VA </a>  :  2/5/2021  1:38 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144515">link</a>   </div></div><div class="thread_post_body">went to Houston with a washed up Eli Manning and beat Watson and the Texans.<br />
<br />
But Watson did throw for almost 400 yards and 2 TD's so that's pretty sweet.</div></div><div class="thread_post"><div class="thread_post_header"><b>Terps </b><a name="15144516">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  1:38 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144516">link</a>   </div></div><div class="thread_post_body">again, you are literally mentioning one side of the team, the offense. You understand defense is a part of the NFL right? Christ, get a clue my dude.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Terps </b><a name="15144522">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/5/2021  1:41 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144522">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144516" target="_blank">15144516</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> again, you are literally mentioning one side of the team, the offense. You understand defense is a part of the NFL right? Christ, get a clue my dude. </td>
                                </tr>
                           </table><br />
<br />
Did you miss the 6-10 part?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Terps </b><a name="15144523">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  1:41 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144523">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144516" target="_blank">15144516</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> again, you are literally mentioning one side of the team, the offense. You understand defense is a part of the NFL right? Christ, get a clue my dude. </td>
                                </tr>
                           </table><br />
You really think you should be the one to tell anyone else to get a clue?<br />
<br />
Your post rate contrasted with your knowledge rate is probably the lowest on the board. You make DG's hit rate look good.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: I'll certainly underscore it... </b><a name="15144527">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=EricJ"> EricJ </a>  :  2/5/2021  1:45 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144527">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144504" target="_blank">15144504</a> Gatorade Dunk said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">        <br />
You do realize that he put up even better numbers without Hopkins than he did WITH Hopkins, right?<br />
<br />
Maybe you were in the shitter when that happened. </td>
                                </tr>
                           </table><br />
<br />
I must have been in the shitter when he captained his team to a championship... or close to one. <br />
<br />
Nobody has proven to me that we are better off giving up the next few years' picks to get this guy. All you can say is Jones sucks. That does not mean trading for Watkins and giving up what will be needed to get him is a smart move.<br />
<br />
Watkins is better than at least 20 other starting QBs in the league right? According to some here, he is top 5 or 7. Why haven't any of the other teams in the league made the trade for him yet? Are they all asleep at the wheel too? Should be a no brainer for the majority of the league. <br />
<br />
The fact that Jax has not made the trade yet tells us they think that a rookie from the same Clemson school is better than Watson. Otherwise, they potentially could have made that deal straight up already.<br />
<br />
How about the Jets? They have more draft capital than the Giants do and people are saying the same thing about Darnold as they are about Jones. Why haven't they made the trade?<br />
<br />
Houston could trade with one of these teams and then draft one of those coveted QBs that BBI thinks we should have tanked for.<br />
<br />
People want us to send Jones to Houston as part of our trade with them. The same people who said Jones sucks. So.. what is Houston going to do for a QB then? Our draft picks are not getting them a top QB in this draft. Jones blows so why would they make a trade like that with us?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I haven't seen Watson play really since the crappy winless 2018 Giants </b><a name="15144528">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  1:45 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144528">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144515" target="_blank">15144515</a> Britt in VA said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> went to Houston with a washed up Eli Manning and beat Watson and the Texans.<br />
<br />
But Watson did throw for almost 400 yards and 2 TD's so that's pretty sweet. </td>
                                </tr>
                           </table><br />
Britt finds a way to weave his mancrush into another thread.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: I'll certainly underscore it... </b><a name="15144529">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/5/2021  1:46 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144529">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144497" target="_blank">15144497</a> EricJ said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144390 bw in dc said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     <br />
If a great player/QB is available it is absolutely incumbent from any team short of having Rodgers/Mahomes/Wilson/Brady to inquire.  <br />
                                <br />
                           <br />
<br />
So Watson is "great" now? The fucking guy has won regular season games and that's it. Are we throwing that word around willy-nilly now? How about Generational or HOF?<br />
<br />
Not to say that he cannot be great one day, but it has not been proven that yet. He has had one of the best WRs in the game in Hopkins on his team and they did not get his team deep into the playoffs.<br />
<br />
So you want to bring him here with fewer weapons than what he had in Houston and simultaneously limiting our ability to assemble the pieces around him after giving up everything in draft picks just to get him.<br />
<br />
Stop playing fantasy football. I would not let you babysit my fantasy football team even for 2 min while I go to the bathroom. </td>
                                </tr>
                           </table><br />
<br />
I think you already did go to the bathroom...with this post.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Dunk </b><a name="15144531">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/5/2021  1:48 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144531">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144511" target="_blank">15144511</a> Go Terps said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144503 ryanmkeane said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     the Giants don't suck. If you think this current version of the team going into 2021 sucks, we are watching different games <br />
                                <br />
                           <br />
<br />
6-10, 17.5 points per game.<br />
<br />
The Giants sucked in 2020. </td>
                                </tr>
                           </table><br />
<br />
Ryan - they didn't suck when you look at the rest of the NFCE.  Other than that though...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: RE: I'll certainly underscore it... </b><a name="15144534">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  1:49 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144534">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144527" target="_blank">15144527</a> EricJ said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144504 Gatorade Dunk said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                            <br />
You do realize that he put up even better numbers without Hopkins than he did WITH Hopkins, right?<br />
<br />
Maybe you were in the shitter when that happened. <br />
                                <br />
                           <br />
<br />
I must have been in the shitter when he captained his team to a championship... or close to one. <br />
<br />
Nobody has proven to me that we are better off giving up the next few years' picks to get this guy. All you can say is Jones sucks. That does not mean trading for Watkins and giving up what will be needed to get him is a smart move.<br />
<br />
Watkins is better than at least 20 other starting QBs in the league right? According to some here, he is top 5 or 7. Why haven't any of the other teams in the league made the trade for him yet? Are they all asleep at the wheel too? Should be a no brainer for the majority of the league. <br />
<br />
The fact that Jax has not made the trade yet tells us they think that a rookie from the same Clemson school is better than Watson. Otherwise, they potentially could have made that deal straight up already.<br />
<br />
How about the Jets? They have more draft capital than the Giants do and people are saying the same thing about Darnold as they are about Jones. Why haven't they made the trade?<br />
<br />
Houston could trade with one of these teams and then draft one of those coveted QBs that BBI thinks we should have tanked for.<br />
<br />
People want us to send Jones to Houston as part of our trade with them. The same people who said Jones sucks. So.. what is Houston going to do for a QB then? Our draft picks are not getting them a top QB in this draft. Jones blows so why would they make a trade like that with us? </td>
                                </tr>
                           </table><br />
I'm not convinced the Giants should trade for Watson, but I do think it's something they should explore. If you take our GM at his word, there's nothing worse in the NFL than building a good roster around a shit QB and then not having an avenue to acquiring the QB that you need to get over the top. <br />
<br />
So what exactly are the Giants doing right now besides satisfying the masturbatory ego of the same GM who defined "QB Hell" for us all? I guess we're supposed to chalk it up to just another press conference soundbite from a mediocre GM who likes to hear himself speak?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I haven't seen Watson play really since the crappy winless 2018 Giants </b><a name="15144541">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/5/2021  1:52 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144541">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144528" target="_blank">15144528</a> Gatorade Dunk said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144515 Britt in VA said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     went to Houston with a washed up Eli Manning and beat Watson and the Texans.<br />
<br />
But Watson did throw for almost 400 yards and 2 TD's so that's pretty sweet. <br />
                                <br />
                           <br />
Britt finds a way to weave his mancrush into another thread. </td>
                                </tr>
                           </table><br />
<br />
If you haven't seen Watson play since three years ago, what's the point of the post?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: I haven't seen Watson play really since the crappy winless 2018 Giants </b><a name="15144553">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  1:57 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144553">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144541" target="_blank">15144541</a> Jimmy Googs said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144528 Gatorade Dunk said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     In comment 15144515 Britt in VA said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     went to Houston with a washed up Eli Manning and beat Watson and the Texans.<br />
<br />
But Watson did throw for almost 400 yards and 2 TD's so that's pretty sweet. <br />
                                <br />
                           <br />
Britt finds a way to weave his mancrush into another thread. <br />
                                <br />
                           <br />
<br />
If you haven't seen Watson play since three years ago, what's the point of the post? </td>
                                </tr>
                           </table><br />
To mention Eli.</div></div><div class="thread_post"><div class="thread_post_header"><b>Great show guys....  loved the setlist..... </b><a name="15144554">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Britt+in+VA"> Britt in VA </a>  :  2/5/2021  1:57 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144554">link</a>   </div></div><div class="thread_post_body">I know it's the millionth time you've played the hits, but man you really have mastered performing them to perfection.  I would think performing the same songs day in/day out would make you tire of them, but man you still bring the energy!  Some say the band hasn't been the same since LBH15 went solo, but I still think you guys are awesome.  Looking forward to the encore performances later today, and the day after that, and the day after that, and the day after that....<br />
<br />
<img src="https://townsquare.media/site/366/files/2012/06/loudwire-band-fail-9.jpg?w=980&q=75"></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Great show guys....  loved the setlist..... </b><a name="15144556">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  1:58 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144556">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144554" target="_blank">15144554</a> Britt in VA said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I know it's the millionth time you've played the hits, but man you really have mastered performing them to perfection.  I would think performing the same songs day in/day out would make you tire of them, but man you still bring the energy!  Some say the band hasn't been the same since LBH15 went solo, but I still think you guys are awesome.  Looking forward to the encore performances later today, and the day after that, and the day after that, and the day after that....<br />
<br />
 </td>
                                </tr>
                           </table><br />
<span class="italics">"I haven't seen that band since Eli won a meaningless game three years ago and I ruined a pair of pants in the process."</span></div></div><div class="thread_post"><div class="thread_post_header"><b>Britt </b><a name="15144559">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/5/2021  2:02 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144559">link</a>   </div></div><div class="thread_post_body">Why would you call anyone else miserable?  I'd rate you as one of the more depressing posters here.  You live in the past, and you're so fatalistic about the Giants you assume that great players around the league would not be great if they played for the Giants.<br />
<br />
The truth is actually simpler than that: the Giants have no great players.  And that includes #26.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Great show guys....  loved the setlist..... </b><a name="15144562">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/5/2021  2:06 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144562">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144556" target="_blank">15144556</a> Gatorade Dunk said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144554 Britt in VA said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     I know it's the millionth time you've played the hits, but man you really have mastered performing them to perfection.  I would think performing the same songs day in/day out would make you tire of them, but man you still bring the energy!  Some say the band hasn't been the same since LBH15 went solo, but I still think you guys are awesome.  Looking forward to the encore performances later today, and the day after that, and the day after that, and the day after that....<br />
<br />
 <br />
                                <br />
                           <br />
"I haven't seen that band since Eli won a meaningless game three years ago and I ruined a pair of pants in the process." </td>
                                </tr>
                           </table><br />
<br />
<br />
<img src="https://i.pinimg.com/originals/f9/30/09/f93009afd529b4f189f08773ac1d1d98.jpg"></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Dave </b><a name="15144564">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Dave+in+Hoboken"> Dave in Hoboken </a>  :  2/5/2021  2:08 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144564">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144329" target="_blank">15144329</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> nope, it's not shocking. I'm just tired of people like you who are comparing this version of the team to 2013-2018.<br />
 </td>
                                </tr>
                           </table><br />
<br />
Well, all of them suck (outside of 2016), so..</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: RE: I'll certainly underscore it... </b><a name="15144575">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  2:15 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144575">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144527" target="_blank">15144527</a> EricJ said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144504 Gatorade Dunk said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                            <br />
You do realize that he put up even better numbers without Hopkins than he did WITH Hopkins, right?<br />
<br />
Maybe you were in the shitter when that happened. <br />
                                <br />
                           <br />
<br />
I must have been in the shitter when he captained his team to a championship... or close to one. <br />
<br />
Nobody has proven to me that we are better off giving up the next few years' picks to get this guy. All you can say is Jones sucks. That does not mean trading for Watkins and giving up what will be needed to get him is a smart move.<br />
<br />
Watkins is better than at least 20 other starting QBs in the league right? According to some here, he is top 5 or 7. Why haven't any of the other teams in the league made the trade for him yet? Are they all asleep at the wheel too? Should be a no brainer for the majority of the league. <br />
<br />
The fact that Jax has not made the trade yet tells us they think that a rookie from the same Clemson school is better than Watson. Otherwise, they potentially could have made that deal straight up already.<br />
<br />
How about the Jets? They have more draft capital than the Giants do and people are saying the same thing about Darnold as they are about Jones. Why haven't they made the trade?<br />
<br />
Houston could trade with one of these teams and then draft one of those coveted QBs that BBI thinks we should have tanked for.<br />
<br />
People want us to send Jones to Houston as part of our trade with them. The same people who said Jones sucks. So.. what is Houston going to do for a QB then? Our draft picks are not getting them a top QB in this draft. Jones blows so why would they make a trade like that with us? </td>
                                </tr>
                           </table><br />
Maybe learn his name before your tirade.<br />
<br />
It's WatSON. Not WatKINS.</div></div><div class="thread_post"><div class="thread_post_header"><b>Terps </b><a name="15144589">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  2:21 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144589">link</a>   </div></div><div class="thread_post_body">serious question....if Barkley isn't a great player, then what running back is? He had the most yards in the entire league his rookie season, behind a shit OL. Then, in 2019, he missed 4 games and was still in the top 15. <br />
<br />
In what world is he not a great football player?</div></div><div class="thread_post"><div class="thread_post_header"><b>Googs </b><a name="15144593">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  2:22 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144593">link</a>   </div></div><div class="thread_post_body">did you miss the Seattle game? Bucs game? Rams game? Did you watch those games....?</div></div><div class="thread_post"><div class="thread_post_header"><b>Barkley was a terrific player in 2018 </b><a name="15144595">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JonC"> JonC </a>  :  2/5/2021  2:24 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144595">link</a>   </div></div><div class="thread_post_body">he needs to re-establish he's still that player.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Terps </b><a name="15144596">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  2:24 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144596">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144589" target="_blank">15144589</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> serious question....if Barkley isn't a great player, then what running back is? He had the most yards in the entire league his rookie season, behind a shit OL. Then, in 2019, he missed 4 games and was still in the top 15. <br />
<br />
In what world is he not a great football player? </td>
                                </tr>
                           </table><br />
He has a bum knee now.<br />
<br />
If you want to use your convoluted logic to define a great RB, let's just put Tiki back in blue and let him get after it.<br />
<br />
Once again, you prove your ineptitude as a fan.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Barkley was a terrific player in 2018 </b><a name="15144597">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  2:24 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144597">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144595" target="_blank">15144595</a> JonC said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> he needs to re-establish he's still that player. </td>
                                </tr>
                           </table><br />
He was terrific in 2019 too.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Googs </b><a name="15144598">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/5/2021  2:25 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144598">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144593" target="_blank">15144593</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> did you miss the Seattle game? Bucs game? Rams game? Did you watch those games....? </td>
                                </tr>
                           </table><br />
<br />
Watched em' all.  <br />
<br />
Are you suggesting if the Giants played in the NFC South or NFC West they would have won more than 6 games?</div></div><div class="thread_post"><div class="thread_post_header"><b>Dunk </b><a name="15144599">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  2:25 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144599">link</a>   </div></div><div class="thread_post_body">oh no an ACL...whatever shall we do? An ACL tear is practically better than a broken ankle at this point.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Googs </b><a name="15144600">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  2:25 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144600">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144593" target="_blank">15144593</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> did you miss the Seattle game? Bucs game? Rams game? Did you watch those games....? </td>
                                </tr>
                           </table><br />
Is this like when you told us all about how the offense was clicking?<br />
<br />
Is there a certain number of times that you need to be proven wrong before you realize that you don't know what you're talking about?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Barkley was a terrific player in 2018 </b><a name="15144602">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JonC"> JonC </a>  :  2/5/2021  2:27 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144602">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144597" target="_blank">15144597</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144595 JonC said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     he needs to re-establish he's still that player. <br />
                                <br />
                           <br />
He was terrific in 2019 too. </td>
                                </tr>
                           </table><br />
<br />
He flashed at times, but 2019 was a step down for him.  And, now the knee ...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Dunk </b><a name="15144603">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  2:27 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144603">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144599" target="_blank">15144599</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> oh no an ACL...whatever shall we do? An ACL tear is practically better than a broken ankle at this point. </td>
                                </tr>
                           </table><br />
We'll see. It's not like SB came roaring back from an ankle sprain.<br />
<br />
His entire game is predicated upon physical explosiveness. You're just wishing on a shooting star like the rest of us that he hasn't lost that.</div></div><div class="thread_post"><div class="thread_post_header"><b>Googs </b><a name="15144605">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  2:28 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144605">link</a>   </div></div><div class="thread_post_body">no....I'm not sure what is so hard to understand about what I said.<br />
<br />
I'm suggesting that the Giants played some good games outside of the NFC East. You guys have selective memory when it comes to this, because we finished 6-10. It's all about the record right?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Dunk </b><a name="15144606">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/5/2021  2:28 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144606">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144599" target="_blank">15144599</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> oh no an ACL...whatever shall we do? An ACL tear is practically better than a broken ankle at this point. </td>
                                </tr>
                           </table><br />
<br />
Yep, just glad he didn't have an ingrown toe nail...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Googs </b><a name="15144610">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  2:31 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144610">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144605" target="_blank">15144605</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> no....I'm not sure what is so hard to understand about what I said.<br />
<br />
I'm suggesting that the Giants played some good games outside of the NFC East. You guys have selective memory when it comes to this, because we finished 6-10. It's all about the record right? </td>
                                </tr>
                           </table><br />
No, it's because they sucked.<br />
<br />
I'm sorry that you're incapable of understanding that. We're not all as naive as you, Ryan.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Googs </b><a name="15144613">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/5/2021  2:32 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144613">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144605" target="_blank">15144605</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> no....I'm not sure what is so hard to understand about what I said.<br />
<br />
I'm suggesting that the Giants played some good games outside of the NFC East. You guys have selective memory when it comes to this, because we finished 6-10. It's all about the record right? </td>
                                </tr>
                           </table><br />
<br />
Not being selective at all.  They did play hard in a number of games.  <br />
<br />
I also recall wishing their roster didn't suck so that we could have won more of them.</div></div><div class="thread_post"><div class="thread_post_header"><b>Barkley is ineffectual </b><a name="15144618">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/5/2021  2:35 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144618">link</a>   </div></div><div class="thread_post_body">Even at his best in 2018 his impact was minimal.  He was a dynamic runner, ineffective receiver, and poor blocker.<br />
<br />
That last part is important and often overlooked.  Barkley is a liability on 3rd down...his presence encourages teams to occupy him with a blitzer, which takes him out as a receiver and endangers the quarterback.<br />
<br />
Barkley's talent (pre-ACL, at least) as an open field runner is undeniable.  It's been his poor fortune that he was drafted by a team that's been clueless on how to use him.  Had he landed with Sean Payton, Andy Reid, Kyle Shanahan, Sean McVay...those types of coaches would have known how to use him.  The Giants though have no idea what they're doing with him.</div></div><div class="thread_post"><div class="thread_post_header"><b>If you think the 2020 Giants </b><a name="15144658">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ajr2456"> ajr2456 </a>  :  2/5/2021  2:54 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144658">link</a>   </div></div><div class="thread_post_body">Were anything other than a bad football team you shouldn’t be telling other people they should get a clue.<br />
<br />
Wins against bad teams really do trick people. Did they show progress from the year before, sure. But this was still a bad football team, all the offensive data proves that to be a fact.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Sean </b><a name="15144663">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Alan+W"> Alan W </a>  :  2/5/2021  2:56 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144663">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144050" target="_blank">15144050</a> Go Terps said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> We did hear rumors all year about Judge and Garrett not working well together, and barely speaking. Add on top of that the Colombo situation, the way Mara/Gettleman spoke about Garrett, and there's a lot of smoke there. </td>
                                </tr>
                           </table><br />
<br />
Where and what "we"?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Sean </b><a name="15144686">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  3:04 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144686">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144663" target="_blank">15144663</a> Alan W said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144050 Go Terps said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     We did hear rumors all year about Judge and Garrett not working well together, and barely speaking. Add on top of that the Colombo situation, the way Mara/Gettleman spoke about Garrett, and there's a lot of smoke there. <br />
                                <br />
                           <br />
<br />
Where and what "we"? </td>
                                </tr>
                           </table><br />
Sorry, Alan. You haven't been here very long.<br />
<br />
Read more, post less, learn who the sources are. THEY did offer inside info.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Sean </b><a name="15144688">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/5/2021  3:05 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144688">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144663" target="_blank">15144663</a> Alan W said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144050 Go Terps said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     We did hear rumors all year about Judge and Garrett not working well together, and barely speaking. Add on top of that the Colombo situation, the way Mara/Gettleman spoke about Garrett, and there's a lot of smoke there. <br />
                                <br />
                           <br />
<br />
Where and what "we"? </td>
                                </tr>
                           </table><br />
<br />
BBI.  There were posts about Judge and Garrett not getting along, and I believe Dan Duggan reported the same.</div></div><div class="thread_post"><div class="thread_post_header"><b>ajr +1 </b><a name="15144694">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JonC"> JonC </a>  :  2/5/2021  3:07 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144694">link</a>   </div></div><div class="thread_post_body">2020 Giants showed some foundational progress, but they still played a lot of below average to bad football.  When they had it teed up to win the NFC they absolutely no-showed, and that in itself is a poor sign.</div></div><div class="thread_post"><div class="thread_post_header"><b>NFCE </b><a name="15144695">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=JonC"> JonC </a>  :  2/5/2021  3:08 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144695">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>I think Garrett was brought back on a short leash.. </b><a name="15144709">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Sean"> Sean </a>  :  2/5/2021  3:16 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144709">link</a>   </div></div><div class="thread_post_body">With Kitchens ready to take over OC duty if the offense doesn’t come out of the gate strong.<br />
<br />
Garrett has a lot at stake here too. He wants another head gig, otherwise this is Fassel in Baltimore all over again.</div></div><div class="thread_post"><div class="thread_post_header"><b>Terps </b><a name="15144714">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  3:18 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144714">link</a>   </div></div><div class="thread_post_body">Barkley had 91 catches for 721 yards and 4 TD in 2018, receiving.<br />
<br />
If that is ineffective, you are seriously delusional.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Terps </b><a name="15144716">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ajr2456"> ajr2456 </a>  :  2/5/2021  3:19 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144716">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144714" target="_blank">15144714</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Barkley had 91 catches for 721 yards and 4 TD in 2018, receiving.<br />
<br />
If that is ineffective, you are seriously delusional. </td>
                                </tr>
                           </table><br />
<br />
How many wins did it lead to? That’s what he meant.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: ajr +1 </b><a name="15144720">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ajr2456"> ajr2456 </a>  :  2/5/2021  3:21 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144720">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144694" target="_blank">15144694</a> JonC said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> 2020 Giants showed some foundational progress, but they still played a lot of below average to bad football.  When they had it teed up to win the NFC they absolutely no-showed, and that in itself is a poor sign. </td>
                                </tr>
                           </table><br />
<br />
Right. The idea that this team if Barkley didn’t get hurt could have been a good team is a fantasy.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: ajr +1 </b><a name="15144724">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ajr2456"> ajr2456 </a>  :  2/5/2021  3:22 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144724">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144694" target="_blank">15144694</a> JonC said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> 2020 Giants showed some foundational progress, but they still played a lot of below average to bad football.  When they had it teed up to win the NFC they absolutely no-showed, and that in itself is a poor sign. </td>
                                </tr>
                           </table><br />
<br />
Right. The idea that this team if Barkley didn’t get hurt could have been a good team is a fantasy.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Terps </b><a name="15144727">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  3:24 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144727">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144714" target="_blank">15144714</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Barkley had 91 catches for 721 yards and 4 TD in 2018, receiving.<br />
<br />
If that is ineffective, you are seriously delusional. </td>
                                </tr>
                           </table><br />
Ask around, dude. You don't get to call anyone delusional.</div></div><div class="thread_post"><div class="thread_post_header"><b>721 yards on 91 catches is indeed ineffective </b><a name="15144729">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/5/2021  3:25 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144729">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: 721 yards on 91 catches is indeed ineffective </b><a name="15144740">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  2/5/2021  3:29 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144740">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144729" target="_blank">15144729</a> Go Terps said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> . </td>
                                </tr>
                           </table><br />
lol</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: I'll certainly underscore it... </b><a name="15144749">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  2/5/2021  3:32 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144749">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144497" target="_blank">15144497</a> EricJ said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144390 bw in dc said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     <br />
If a great player/QB is available it is absolutely incumbent from any team short of having Rodgers/Mahomes/Wilson/Brady to inquire.  <br />
                                <br />
                           <br />
<br />
So Watson is "great" now? The fucking guy has won regular season games and that's it. Are we throwing that word around willy-nilly now? How about Generational or HOF?<br />
<br />
Not to say that he cannot be great one day, but it has not been proven that yet. He has had one of the best WRs in the game in Hopkins on his team and they did not get his team deep into the playoffs.<br />
<br />
So you want to bring him here with fewer weapons than what he had in Houston and simultaneously limiting our ability to assemble the pieces around him after giving up everything in draft picks just to get him.<br />
<br />
Stop playing fantasy football. I would not let you babysit my fantasy football team even for 2 min while I go to the bathroom. </td>
                                </tr>
                           </table><br />
<br />
What about Watson isn't great? <br />
<br />
Seriously, have you even taken the time to look at his performance? Because with some of your comments, I'm getting the sense you haven't.<br />
<br />
From his very first game, and even despite his shortened first season due to injury, Watson has been all-systems-go - TDs, TD/Ints ratio, Completion%, YPA, AYPA, rushing yards, rushing TDs, winning record, good playoff stats, etc.<br />
<br />
And he just turned 25.<br />
<br />
Yes, he has a lucrative contract, but the first year hit isn't that bad for the acquiring team, and the out-years could be re-negotiated.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: 721 yards on 91 catches is indeed ineffective </b><a name="15144751">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  3:33 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144751">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144740" target="_blank">15144740</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144729 Go Terps said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     . <br />
                                <br />
                           <br />
lol </td>
                                </tr>
                           </table><br />
You laughing at anyone else = LOL</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: 721 yards on 91 catches is indeed ineffective </b><a name="15144763">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/5/2021  3:37 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144763">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144740" target="_blank">15144740</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144729 Go Terps said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     . <br />
                                <br />
                           <br />
lol </td>
                                </tr>
                           </table><br />
<br />
Barkley averaged 6.0 yards per target and 7.9 yards per reception in 2018.  You think those are indicative of a dynamic receiving threat?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: 721 yards on 91 catches is indeed ineffective </b><a name="15144773">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ajr2456"> ajr2456 </a>  :  2/5/2021  3:43 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144773">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144763" target="_blank">15144763</a> Go Terps said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144740 ryanmkeane said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     In comment 15144729 Go Terps said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     . <br />
                                <br />
                           <br />
lol <br />
                                <br />
                           <br />
<br />
Barkley averaged 6.0 yards per target and 7.9 yards per reception in 2018.  You think those are indicative of a dynamic receiving threat? </td>
                                </tr>
                           </table><br />
<br />
14th ranked RB in YPC isn’t something I’d brag about.</div></div><div class="thread_post"><div class="thread_post_header"><b>I believe Kyle Juszczyk led all backs in YPC with 10.8 </b><a name="15144789">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/5/2021  3:50 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144789">link</a>   </div></div><div class="thread_post_body">What does that tell us?  Being an effective receiver out of the backfield isn't really about the athleticism of the player...it's about the coaches calling the plays.<br />
<br />
So if that's the case it begs the question - who is dumb enough to use the 2nd pick overall on a running back?<br />
<br />
The New York Football Giants are, that's who.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: If you think the 2020 Giants </b><a name="15144794">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  2/5/2021  3:55 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144794">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144658" target="_blank">15144658</a> ajr2456 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Were anything other than a bad football team you shouldn’t be telling other people they should get a clue.<br />
<br />
Wins against bad teams really do trick people. Did they show progress from the year before, sure. But this was still a bad football team, all the offensive data proves that to be a fact. </td>
                                </tr>
                           </table><br />
<br />
That's partly true. <br />
<br />
Indeed, the offense was putrid.<br />
<br />
But the defense was much improved and very effective. Marching into Seattle against an upper echelon QB, with a back-up QB "leading" our moribund offense, is very impressive...</div></div><div class="thread_post"><div class="thread_post_header"><b>Juszczyk </b><a name="15144796">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=trueblueinpw"> trueblueinpw </a>  :  2/5/2021  3:56 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144796">link</a>   </div></div><div class="thread_post_body">Terrific player. Not the flashy touched by the hand of god future gold jacket home run hitter that many here like to jizz on. But a hell of a football player. (Even if he did go to Harvard). <br />
<br />
And has anyone seen what a contemporary o-co can do with a guy like that?</div></div><div class="thread_post"><div class="thread_post_header"><b>Some of this thread is just pure entertainment </b><a name="15144806">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=chick310"> chick310 </a>  :  2/5/2021  4:06 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144806">link</a>   </div></div><div class="thread_post_body">on slow Friday afternoon. It was like comedy hour from a few of you!</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: If you think the 2020 Giants </b><a name="15144820">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ajr2456"> ajr2456 </a>  :  2/5/2021  4:25 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144820">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144794" target="_blank">15144794</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144658 ajr2456 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     Were anything other than a bad football team you shouldn’t be telling other people they should get a clue.<br />
<br />
Wins against bad teams really do trick people. Did they show progress from the year before, sure. But this was still a bad football team, all the offensive data proves that to be a fact. <br />
                                <br />
                           <br />
<br />
That's partly true. <br />
<br />
Indeed, the offense was putrid.<br />
<br />
But the defense was much improved and very effective. Marching into Seattle against an upper echelon QB, with a back-up QB "leading" our moribund offense, is very impressive... </td>
                                </tr>
                           </table><br />
<br />
The defense definitely was improved but also depended on a handful of guys having career years for that to happen. To improve next year they’ll have to plug some massive holes on that side still (pass rusher, real #2 corner) and bank on Peppers, Williams and Bradberry repeating their career years.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: RE: RE: I'll certainly underscore it... </b><a name="15144822">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=EricJ"> EricJ </a>  :  2/5/2021  4:34 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144822">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144575" target="_blank">15144575</a> Gatorade Dunk said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br />
Maybe learn his name before your tirade.<br />
<br />
It's WatSON. Not WatKINS. </td>
                                </tr>
                           </table><br />
<br />
yeah I had HOPKINS on my mind and had just typed his name moments earlier</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Terps </b><a name="15144842">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=cosmicj"> cosmicj </a>  :  2/5/2021  5:22 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144842">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144714" target="_blank">15144714</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Barkley had 91 catches for 721 yards and 4 TD in 2018, receiving.<br />
<br />
If that is ineffective, you are seriously delusional. </td>
                                </tr>
                           </table>my god, Ryan.  Look, you seem like a nice guy.  But you need to do some more studying.  Seriously.  Learn about the NFL.  Your post indicates you don’t understand what is going on out there.  <br />
<br />
(And, no I am not one of the most knowledgeable fans posting here.  I realize that,  but I would never post that howler.)</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: I'll certainly underscore it... </b><a name="15144862">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jimmy+Googs"> Jimmy Googs </a>  :  2/5/2021  5:45 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144862">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144749" target="_blank">15144749</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144497 EricJ said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     In comment 15144390 bw in dc said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     <br />
If a great player/QB is available it is absolutely incumbent from any team short of having Rodgers/Mahomes/Wilson/Brady to inquire.  <br />
                                <br />
                           <br />
<br />
So Watson is "great" now? The fucking guy has won regular season games and that's it. Are we throwing that word around willy-nilly now? How about Generational or HOF?<br />
<br />
Not to say that he cannot be great one day, but it has not been proven that yet. He has had one of the best WRs in the game in Hopkins on his team and they did not get his team deep into the playoffs.<br />
<br />
So you want to bring him here with fewer weapons than what he had in Houston and simultaneously limiting our ability to assemble the pieces around him after giving up everything in draft picks just to get him.<br />
<br />
Stop playing fantasy football. I would not let you babysit my fantasy football team even for 2 min while I go to the bathroom. <br />
                                <br />
                           <br />
<br />
What about Watson isn't great? <br />
<br />
Seriously, have you even taken the time to look at his performance? Because with some of your comments, I'm getting the sense you haven't.<br />
<br />
 </td>
                                </tr>
                           </table><br />
<br />
Take it easy, he was in the bathroom.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: RE: I'll certainly underscore it... </b><a name="15144866">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  2/5/2021  5:49 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144866">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144862" target="_blank">15144862</a> Jimmy Googs said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144749 bw in dc said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     In comment 15144497 EricJ said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     In comment 15144390 bw in dc said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     <br />
If a great player/QB is available it is absolutely incumbent from any team short of having Rodgers/Mahomes/Wilson/Brady to inquire.  <br />
                                <br />
                           <br />
<br />
So Watson is "great" now? The fucking guy has won regular season games and that's it. Are we throwing that word around willy-nilly now? How about Generational or HOF?<br />
<br />
Not to say that he cannot be great one day, but it has not been proven that yet. He has had one of the best WRs in the game in Hopkins on his team and they did not get his team deep into the playoffs.<br />
<br />
So you want to bring him here with fewer weapons than what he had in Houston and simultaneously limiting our ability to assemble the pieces around him after giving up everything in draft picks just to get him.<br />
<br />
Stop playing fantasy football. I would not let you babysit my fantasy football team even for 2 min while I go to the bathroom. <br />
                                <br />
                           <br />
<br />
What about Watson isn't great? <br />
<br />
Seriously, have you even taken the time to look at his performance? Because with some of your comments, I'm getting the sense you haven't.<br />
<br />
 <br />
                                <br />
                           <br />
<br />
Take it easy, he was in the bathroom. </td>
                                </tr>
                           </table><br />
This is the post of the entire thread, regardless of which side of the aisle you land on.</div></div><div class="thread_post"><div class="thread_post_header"><b>I just want someone here to tell me... </b><a name="15144903">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=EricJ"> EricJ </a>  :  2/5/2021  6:41 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144903">link</a>   </div></div><div class="thread_post_body">with all confidence that if we were to trade for Watson and give up the farm to get him, that we still would have the ability to assemble the remaining pieces needed to win a championship.<br />
<br />
If you feel good about our ability to do that, then okay.<br />
<br />
My thing is we are not just a QB away from being competitive. We need too much and we need the picks now to make that happen.<br />
<br />
If we are able to do a good job of rounding out this roster and getting some offensive weapons and QB is the final piece, then at that point we pull the trigger on a deal for someone.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I just want someone here to tell me... </b><a name="15144917">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  2/5/2021  7:04 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144917">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144903" target="_blank">15144903</a> EricJ said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> with all confidence that if we were to trade for Watson and give up the farm to get him, that we still would have the ability to assemble the remaining pieces needed to win a championship.<br />
<br />
If you feel good about our ability to do that, then okay.<br />
<br />
My thing is we are not just a QB away from being competitive. We need too much and we need the picks now to make that happen.<br />
<br />
If we are able to do a good job of rounding out this roster and getting some offensive weapons and QB is the final piece, then at that point we pull the trigger on a deal for someone. </td>
                                </tr>
                           </table><br />
<br />
Your are indeed right. We aren't a QB away. But we would solve a big unknown solving for QB. <br />
<br />
Because I think most of us can agree we don't know what Jones is as a QB. But we certainly know who Watson is. And I really can't imagine anyone right now saying Jones will ever be better than Jones...at least not without a tremendous amount of imagination.<br />
<br />
I look at this Watson hypothetical two ways...<br />
<br />
1. I can buy the concern about his contract - to a degree - and how that might restrict building out a better roster. I believe a good GM could figure it out. Which, alas, creates another problem because our DG is our GM. But I digress... ;)<br />
<br />
2. Let's say the deal was Jones + three first rounders. I have studied some hit percentages on first rounders, and it's about 50/50 that a firster is even going to be just a good player. And the odds of that first being a pro bowl player is 25%. Doing some simply math, we likely wouldn't draft a pro bowl player and, at best, get 1.5 good players(2). So boiled down to that, I would take Watson any day over Jones and another good player and a half.<br />
<br />
Look, it's not going to happen because we are putting all of our eggs into the Jones basket. So it's Jones or bust right now. And if someone does pull of a Watson deal that we could have matched, and that team shines, there are going to be a lot of question to answer around here...</div></div><div class="thread_post"><div class="thread_post_header"><b>Should be... </b><a name="15144919">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  2/5/2021  7:06 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144919">link</a>   </div></div><div class="thread_post_body">"...Jones will ever be better than Watson..."<br />
<br />
Geesh.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I just want someone here to tell me... </b><a name="15144922">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=EricJ"> EricJ </a>  :  2/5/2021  7:09 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144922">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144917" target="_blank">15144917</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br />
Look, it's not going to happen because we are putting all of our eggs into the Jones basket. So it's Jones or bust right now. And if someone does pull of a Watson deal that we could have matched, and that team shines, there are going to be a lot of question to answer around here... </td>
                                </tr>
                           </table><br />
<br />
We know the Giants are not going to make that trade. What will be telling is whether any team makes a deal for him.<br />
<br />
We can expect that Watson will play reasonably well wherever he goes. We can also expect a shit load of second guessing here as well. It is already happening and Watson is still in Houston. <br />
<br />
I personally do not like drawing conclusions that say a player would have a similar impact or results on one team vs another. Every circumstance is very different. Example.. Brady is in the Superbowl with Tampa. What are the chances he would be in the Superbowl this Sunday if he came to the Giants? Forget that... do we think even the Pats would have made it to the Superbowl with Brady?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: I just want someone here to tell me... </b><a name="15144939">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  2/5/2021  7:33 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144939">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144922" target="_blank">15144922</a> EricJ said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15144917 bw in dc said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     <br />
Look, it's not going to happen because we are putting all of our eggs into the Jones basket. So it's Jones or bust right now. And if someone does pull of a Watson deal that we could have matched, and that team shines, there are going to be a lot of question to answer around here... <br />
                                <br />
                           <br />
<br />
We know the Giants are not going to make that trade. What will be telling is whether any team makes a deal for him.<br />
<br />
We can expect that Watson will play reasonably well wherever he goes. We can also expect a shit load of second guessing here as well. It is already happening and Watson is still in Houston. <br />
<br />
I personally do not like drawing conclusions that say a player would have a similar impact or results on one team vs another. Every circumstance is very different. Example.. Brady is in the Superbowl with Tampa. What are the chances he would be in the Superbowl this Sunday if he came to the Giants? Forget that... do we think even the Pats would have made it to the Superbowl with Brady? </td>
                                </tr>
                           </table><br />
<br />
Brady's situation was very unusual. The most decorated QB in history, now a 43 year old free agent, looking for a situation with "no assembly required...just add water and stir". And playoffs here we come. So he wasn't coming here.<br />
<br />
Watson, on the other hand, is 25 and very likely on the trade block despite what the Texans say. And all but a handful or so of teams could absolutely use him. It's a helluva an opportunity...</div></div><div class="thread_post"><div class="thread_post_header"><b>EricJ </b><a name="15144962">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=trueblueinpw"> trueblueinpw </a>  :  2/5/2021  7:55 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144962">link</a>   </div></div><div class="thread_post_body">The thing is, even if you have all the pieces except the QB, you’re still not gonna compete for a Supe in this NFL. Look at the Rams and the Bucs. If we have a guy like Watson, with the defense we have, I think we are actually a playoff team. I actually think Watson would put us in the hunt.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I just want someone here to tell me... </b><a name="15144970">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Go+Terps"> Go Terps </a>  :  2/5/2021  7:59 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15144970">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144903" target="_blank">15144903</a> EricJ said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> with all confidence that if we were to trade for Watson and give up the farm to get him, that we still would have the ability to assemble the remaining pieces needed to win a championship.</td>
                                </tr>
                           </table><br />
<br />
I wouldn't feel good about that if we didn't make the trade either. We've had five first round picks the last three years, and not one great player to show for it.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Terps </b><a name="15145042">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BleedBlue"> BleedBlue </a>  :  2/5/2021  10:06 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15145042">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144714" target="_blank">15144714</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Barkley had 91 catches for 721 yards and 4 TD in 2018, receiving.<br />
<br />
If that is ineffective, you are seriously delusional. </td>
                                </tr>
                           </table><br />
<br />
<br />
Yea terps is a fucking moron. He just trolls the board. He complains about everything. <br />
<br />
He legit said tge giants have no great players....bradberry? Martinez? They are top 5 at their positions. What do you consider great? Btw, ill bet you bitched about those signings too.<br />
<br />
Youre fuckin cluless but more importantly youre fucking annoying. Im not sure how your friebds dont drown you in a shallow puddle. <br />
<br />
Ryan, you have patience my man and BBI owes you a beer to fight against BBIs three stooges. Terps is the ring leader of a very small, dumb, and annoying clique within BBI. <br />
<br />
The giants arent great, in fact they are average at best BUT the team showed soke fight and judge looks like a solid coach so ill trust his judgement over Terps. Also, i agree ryan, lets see what 2021 is. Jones 3rd year, hopefully qe get some wrs for him and we are off. The defense is pretty damn good. Ive been so negative about the giants but im actually excited for the fall. I think we will compete for division and thats gotta be the goal every year. <br />
<br />
Guys like Terps just complain constantly. Its at the ppint where i hope we hire who he wants and sign and deaft who he wants so he will stop running his cock smoker. <br />
<br />
Nothing wrong with having negative feelings but terps and them make some outlandish comments like "barley was an ineffective receiver in 2018" LOL</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Juszczyk </b><a name="15145058">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=shyster"> shyster </a>  :  2/5/2021  11:30 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15145058">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15144796" target="_blank">15144796</a> trueblueinpw said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Terrific player. Not the flashy touched by the hand of god future gold jacket home run hitter that many here like to jizz on. But a hell of a football player. (Even if he did go to Harvard). <br />
<br />
And has anyone seen what a contemporary o-co can do with a guy like that? </td>
                                </tr>
                           </table><br />
<br />
Juszczyk had a total of 19 receptions and 17 rushes for the entire season, playing 43% of offensive snaps in all 16 games.<br />
<br />
I guess he's supposed to be a good blocker as well, but seems to me if he were such a terrific asset to both the run and pass game, he should stay on the field more.<br />
<br />
Will be interesting to see his market if the Niners let him go to FA.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Terps </b><a name="15145060">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ghost718"> ghost718 </a>  :  2/5/2021  11:40 pm   : <a href="index.php?mode=2&thread=605822&show_all=1#15145060">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=605822&show_all=1#15145042" target="_blank">15145042</a> BleedBlue said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">Guys like Terps just complain constantly. Its at the ppint where i hope we hire who he wants and sign and deaft who he wants so he will stop running his cock smoker. <br />
</td>
                                </tr>
                           </table><br />
<br />
Something tells me that's not gonna happen.If anything, more posts like yours will start to appear.</div></div><a name="END"><a href="index.php"><div style="padding-top:25px; padding-bottom:20px;"><img src="/images/back_corner.gif" class="thread_link"  alt="Back to the Corner" border="0"></a></div></a></div>
<div class="thread_sidebar_2">

<!-- Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-102">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Corner Forum - Lower 300x250 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1566320450447229"
     data-ad-slot="4189314539"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->

</div>

</div>




<div class="footer">


<p style="width:400px;float:left;"><b>Part of the USA Today Sports Media Group</b><br>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</P>
<P  style="width:400px;float:right; text-align:right;">
All contents (unless otherwise specified) copyright &copy;  1995 - 2020<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Solutions</a>
</P>
<br clear="all">
<div style="float:right;">
<script
    src="https://sucuri.net/monitoring/badge.js"
    data-s="19"
    id="sucuri-s"
    data-i="7b1b29ae50ae6574f2af3875935246e4fa8a805b26"
    data-p="o" - position - l(left) or r(right) or o(relative)
    data-c="l"
    data-t="t"
    ></script>
</div>

</div>


<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->

<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=192-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type='text/javascript' data-cfasync='false'></script></body>
</html>
