<!DOCTYPE html>
<html lang="en">
<head><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=194-0&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=194-0&cb=3', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=194-0&cb=5', false, [], true, false, true, false);</script>
<title>2 or 3 of Smith,Waddle,Pitts,Parsons, Slater available at 11 | Big Blue Interactive </title>


<meta name="keywords" content="ndglbqfkxx">

<meta name="description" content="With the draft order reshuffled it presents a very interesting dynamic for Giants: 1) Jaguars - QB Trevor Lawrence
2) Jets - QB Zach Wilson
3) 49ers - QB Trey Lance
4) Falcons - QB Justin Fields
5) Bengals - OT Penei Sewell- blue chip
6) Dolphins - WR Ja'Marr Chase- blue chip
7) Lions - WR Jaylen Waddle, have Hockenson, and lost 2 top WRs
8) Panthers - QB Mac Jones - Rhule all over him at Senior Bowl and said to love him
9) Broncos - Micah Parsons? They have a decent WR corp /Noah Fant, so maybe no Smith or Pitts.
10) Cowboys - Surtain, unlikely to take another offense weapon Best way to look at this is it is a very high likelihood that 2 to 3 of these 5 WILL be available when we pick: Smith,Waddle,Pitts,Parsons, Slater Who do you pick and why? *I did not include Surtain/Farley/Horn because with 30MM invested AAV in our top 2 CBs and Holmes as a promising young slot and a strong supporting cast of safeties, I don't see us going here round 1. "/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="website" />
<meta property="og:description" content="With the draft order reshuffled it presents a very interesting dynamic for Giants: 1) Jaguars - QB Trevor Lawrence
2) Jets - QB Zach Wilson
3) 49ers - QB Trey Lance
4) Falcons - QB Justin Fields
5) Bengals - OT Penei Sewell- blue chip
6) Dolphins - WR Ja'Marr Chase- blue chip
7) Lions - WR Jaylen Waddle, have Hockenson, and lost 2 top WRs
8) Panthers - QB Mac Jones - Rhule all over him at Senior Bowl and said to love him
9) Broncos - Micah Parsons? They have a decent WR corp /Noah Fant, so maybe no Smith or Pitts.
10) Cowboys - Surtain, unlikely to take another offense weapon Best way to look at this is it is a very high likelihood that 2 to 3 of these 5 WILL be available when we pick: Smith,Waddle,Pitts,Parsons, Slater Who do you pick and why? *I did not include Surtain/Farley/Horn because with 30MM invested AAV in our top 2 CBs and Holmes as a promising young slot and a strong supporting cast of safeties, I don't see us going here round 1. " /> 
<meta property="og:title" content="2 or 3 of Smith,Waddle,Pitts,Parsons, Slater available at 11" /> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif" /> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css?v=20200217" />

<link rel="stylesheet" type="text/css" href="anylink.css" />


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}


div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" alt="for display only">

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type='text/javascript'>
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type='text/javascript' src='https://img.bnqt.com/lib/js/sdpdfphelper.js'></script>
<script type='text/javascript'>
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>


<!-- End DFP SETUP -->  

<!-- End USA Today Code -->




<script type="text/javascript">var ezouid = "1";</script><base href="https://corner.bigblueinteractive.com/index.php?mode=2&thread=607439&show_all=1"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"domain_test_group":20210306,"engaged_time_visit":0,"ezcache_level":0,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"30630d8b-9167-4d7f-4d33-daf01a5a481b","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":83433,"response_time_orig":115,"serverid":"54.147.229.134:30089","state":"VA","t_epoch":1617036900,"template_id":126,"time_on_site_visit":0,"url":"https://corner.bigblueinteractive.com/index.php?mode=2\u0026thread=607439\u0026show_all=1","user_id":0,"word_count":5615,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["30630d8b-9167-4d7f-4d33-daf01a5a481b", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>


<body>




<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"></a> <img src="images/xpete.gif" alt="The Corner Forum">

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic -->&nbsp;


<!-- Nov 2019 Leaderboard -->

<!-- Ezoic - Forum Leaderboard (USAT) - top_of_page -->
<div id="ezoic-pub-ad-placeholder-118">
<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->
<div id='usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general'>
     <script type='text/javascript'>
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general');
         });
     </script>
</div>
</div>
<!-- End Ezoic - Forum Leaderboard (USAT) - top_of_page -->



</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://www.amazon.com/?_encoding=UTF8&camp=1789&creative=9325&linkCode=ur2&tag=bigblueintera-20">Amazon.com</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW" >Standings (NFL.com)</a>
<a href="https://www.giants.com/team/stats/" target="_NEW" >Statistics (Giants.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/" >Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'home_view_menu')">Home</a>  
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'forum_view_menu')">Corner Forum</a>
<li><a href="http://corner.bigblueinteractive.com/index.php" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'gameday_view_menu')">Gameday</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_view_menu')">Team</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_building_view_menu')">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info &amp; History</a> -->
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'team_info_view_menu')">Giants Info &amp; History</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'infolinks_view_menu')">Info/Links</a>
<li><a href="" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'shop_view_menu')">BBI Shop</a>
<li><a href="/index.php?mode=10" onClick="return clickreturnvalue()" onMouseover="dropdownmenu(this, event, 'login_menu')">Log In</a>
</ul>

</div><div id="infoline"> </div>

<a name="END"><a href="index.php"><div style="padding-top:20px; padding-bottom:25px;"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"></a></div></a><div class="thread_container"><div class="thread_left"><div class="thread_body" ><div class="thread_main" ><div class="thread_post_header" >  <h1 style="font-size:18px;">2 or 3 of Smith,Waddle,Pitts,Parsons, Slater available at 11 </h1><div class="thread_info"><a href="index.php?mode=5&handle=Judge_and_Jury"> Judge_and_Jury </a>  :  3/27/2021  10:52 am</div></div><div class="thread_post_body" > With the draft order reshuffled it presents a very interesting dynamic for Giants:<br />
<br />
1) Jaguars - QB Trevor Lawrence<br />
2) Jets - QB Zach Wilson<br />
3) 49ers - QB Trey Lance<br />
4) Falcons - QB Justin Fields<br />
5) Bengals - OT Penei Sewell- blue chip<br />
6) Dolphins - WR Ja'Marr Chase- blue chip<br />
7) Lions - WR Jaylen Waddle, have Hockenson, and lost 2 top WRs<br />
8) Panthers - QB Mac Jones - Rhule all over him at Senior Bowl and said to love him<br />
9) Broncos - Micah Parsons? They have a decent WR corp /Noah Fant, so maybe no Smith or Pitts.<br />
10) Cowboys - Surtain, unlikely to take another offense weapon<br />
<br />
<br />
Best way to look at this is it is a very high likelihood that 2 to 3 of these 5 WILL be available when we pick:<br />
<br />
Smith,Waddle,Pitts,Parsons, Slater<br />
<br />
Who do you pick and why? <br />
<br />
*I did not include Surtain/Farley/Horn because with 30MM invested AAV in our top 2 CBs and Holmes as a promising young slot and a strong supporting cast of safeties, I don't see us going here round 1.<br />
<br />
 </div></div></div></div><div class="thread_right"><div id="ad_side_box">


<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id='usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general'>
     <script type='text/javascript'>
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general');
         });
     </script>
</div>




</div></div><div class="thread_comment_container"><div class="thread_post"><div class="thread_post_header"><b>honestly i wouldn't be shocked if dallas took pitts </b><a name="15199713">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GiantsFan84"> GiantsFan84 </a>  :  3/27/2021  11:01 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199713">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>i also think you're going to see atlanta trade down </b><a name="15199714">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GiantsFan84"> GiantsFan84 </a>  :  3/27/2021  11:01 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199714">link</a>   </div></div><div class="thread_post_body">with either carolina or denver</div></div><div class="thread_post"><div class="thread_post_header"><b>I’m running up to the podium (virtual)  </b><a name="15199719">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eman11"> Eman11 </a>  :  3/27/2021  11:05 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199719">link</a>   </div></div><div class="thread_post_body">And taking Smith if he’s there, and then Waddle if Smith is gone.<br />
<br />
Smith to me is a no brainer, and I couldn’t pass on such a talented player. He’s the whole package to me even if a bit light, and  seems like as close to a Joe Judge type player the coach could ask for.</div></div><div class="thread_post"><div class="thread_post_header"><b>_________ </b><a name="15199722">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=I+am+Ninja"> I am Ninja </a>  :  3/27/2021  11:09 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199722">link</a>   </div></div><div class="thread_post_body">Agree w GF84.  You cant ever assume Dal will do what they "should" do.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I’m running up to the podium (virtual)  </b><a name="15199724">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Judge_and_Jury"> Judge_and_Jury </a>  :  3/27/2021  11:10 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199724">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15199719" target="_blank">15199719</a> Eman11 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> And taking Smith if he’s there, and then Waddle if Smith is gone.<br />
<br />
Smith to me is a no brainer, and I couldn’t pass on such a talented player. He’s the whole package to me even if a bit light, and  seems like as close to a Joe Judge type player the coach could ask for. </td>
                                </tr>
                           </table><br />
<br />
The WRs may represent the glaring BPA conundrum. While not nearly the highest need, they may be on a tier of their own. However the other guys on the list mentioned (Slater,Parsons) there is a chance 1 or both may be on the same row as Smith/Pitts/Waddle.</div></div><div class="thread_post"><div class="thread_post_header"><b>Giants will get a good player </b><a name="15199725">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=US1+Giants"> US1 Giants </a>  :  3/27/2021  11:10 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199725">link</a>   </div></div><div class="thread_post_body">Trust the Giants with the pick more than anyone on BBI.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="15199727">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=SFGFNCGiantsFan"> SFGFNCGiantsFan </a>  :  3/27/2021  11:12 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199727">link</a>   </div></div><div class="thread_post_body">Smith, Smith, Smith.</div></div><div class="thread_post"><div class="thread_post_header"><b>My two rd WISH </b><a name="15199728">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GiantSteps"> GiantSteps </a>  :  3/27/2021  11:12 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199728">link</a>   </div></div><div class="thread_post_body">I've been starting to like the idea of Slater or Parsons if either are there.<br />
<br />
Parsons in our defense would just open things up in really interesting ways. I think our defense would-on paper, at least-have the potential to be truly elite with a guy like him.<br />
<br />
Slater, on the other hand, is as versatile as you could ask for, athletic, and would likely be able to handle the vast majority of his assignments. He could be the missing anchor that line has been looking for. <br />
<br />
I'd love to see EE traded with our third rd pick for a high to mid second rd pick. No idea who our trading partner would be, but just sayin. Getting Friermuth, Terrace Marshall, one of the second tier Offensive linemen could all be in play. I know that's lofty thinking and highly unlikely, but April 29th is a long way away, so wtf why not.</div></div><div class="thread_post"><div class="thread_post_header"><b>I Like the Speed and Big Playmaking Abilities... </b><a name="15199731">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jim+in+Tampa"> Jim in Tampa </a>  :  3/27/2021  11:16 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199731">link</a>   </div></div><div class="thread_post_body">of Waddle and Smith and think both are a better fit than Pitts.  (I want speed to compliment Golladay. Pitts is too similar to Golladay and Engram.)<br />
<br />
I'd love it if both Waddle and Smith were available because I trust that the Giants will make the right choice, given JJ's connection to Saban and Alabama.</div></div><div class="thread_post"><div class="thread_post_header"><b>We love Pitts </b><a name="15199732">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Rico"> Rico </a>  :  3/27/2021  11:16 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199732">link</a>   </div></div><div class="thread_post_body">We also love the receivers. I think OL in round 1 is unlikely. And Parsons is not an option.</div></div><div class="thread_post"><div class="thread_post_header"><b>I do not love any of them.......hoping for a trade down </b><a name="15199735">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=George+from+PA"> George from PA </a>  :  3/27/2021  11:17 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199735">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>Pitts for me </b><a name="15199736">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Chip"> Chip </a>  :  3/27/2021  11:17 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199736">link</a>   </div></div><div class="thread_post_body">170 lbs  no thank you unless Pitts is off the board.  I would be happy with either as well as Slater and Parsons.  We are going to get a great player at 11.  so don't trade down.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: honestly i wouldn't be shocked if dallas took pitts </b><a name="15199741">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jay+on+the+Island"> Jay on the Island </a>  :  3/27/2021  11:21 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199741">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15199713" target="_blank">15199713</a> GiantsFan84 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> . </td>
                                </tr>
                           </table><br />
I wouldn't either.  I think Dallas will draft either Pitts or a CB.</div></div><div class="thread_post"><div class="thread_post_header"><b>I'd pick DeVonta Smith </b><a name="15199743">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Jay+on+the+Island"> Jay on the Island </a>  :  3/27/2021  11:22 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199743">link</a>   </div></div><div class="thread_post_body">without a doubt.  He's a great player and a great person off the field as well.  Judge will love this kid.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: We love Pitts </b><a name="15199744">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Judge_and_Jury"> Judge_and_Jury </a>  :  3/27/2021  11:24 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199744">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15199732" target="_blank">15199732</a> Rico said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> We also love the receivers. I think OL in round 1 is unlikely. And Parsons is not an option. </td>
                                </tr>
                           </table><br />
<br />
Rico , with things being fluid how confident are you of this? We may have one of the worst starting tandems of OGs in the NFL right now.</div></div><div class="thread_post"><div class="thread_post_header"><b>Good discussion thread.  Agree with the OP as to the </b><a name="15199746">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=NYGgolfer"> NYGgolfer </a>  :  3/27/2021  11:26 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199746">link</a>   </div></div><div class="thread_post_body">first batch of picks although things start to get hazy around pick #7.  <br />
<br />
Would imagine that one of those top WRs and/or Pitts will be available when the Giants are on the clock.  And it makes a lot of sense to grab one to continue to add playmaking talent to this Offense.<br />
<br />
Offensive line additions are critical too but would go with the above first and address OL on Day 2.</div></div><div class="thread_post"><div class="thread_post_header"><b>Wr please </b><a name="15199747">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GiantsRage2007"> GiantsRage2007 </a>  :  3/27/2021  11:27 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199747">link</a>   </div></div><div class="thread_post_body">I think we need a Shep replacement by next year anyway</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: We love Pitts </b><a name="15199748">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=eric2425ny"> eric2425ny </a>  :  3/27/2021  11:27 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199748">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15199732" target="_blank">15199732</a> Rico said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> We also love the receivers. I think OL in round 1 is unlikely. And Parsons is not an option. </td>
                                </tr>
                           </table><br />
<br />
Interesting.  I’d be happy with any of Pitts, Smith, or Waddle.  I’d prefer Smith.  Still feel like we need one more playmaker on O and need to draft another Guard relatively high as well.</div></div><div class="thread_post"><div class="thread_post_header"><b>Why does everyone predict the Lions </b><a name="15199751">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=beatrixkiddo"> beatrixkiddo </a>  :  3/27/2021  11:29 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199751">link</a>   </div></div><div class="thread_post_body">Taking Waddle? Have they shown a preference of him over Smith? <br />
<br />
Lions are pretty depleated overall, I could see them being candidates to trade down for more picks if Atlanta doesn’t. <br />
<br />
If all those players are available I’d be just about happy with any of them. Would prefer a game changing defensive player but one of the top skill players would be great as well. Pitts would look great and essentially provide another excellent contested catch player to pair with Golladay on the field. We would still have the speed guys in Slayton and Ross to balance things out.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: honestly i wouldn't be shocked if dallas took pitts </b><a name="15199755">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GoDeep13"> GoDeep13 </a>  :  3/27/2021  11:32 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199755">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15199713" target="_blank">15199713</a> GiantsFan84 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> . </td>
                                </tr>
                           </table>Feels like a Jerry move</div></div><div class="thread_post"><div class="thread_post_header"><b>Would not be unhappy with any of those choices. </b><a name="15199757">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Watson"> Watson </a>  :  3/27/2021  11:33 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199757">link</a>   </div></div><div class="thread_post_body">Would prefer Pitts & Waddle.  In that order.   Multiple</div></div><div class="thread_post"><div class="thread_post_header"><b>Don’t think OG makes sense in first round, unless trade down </b><a name="15199759">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Payasdaddy"> Payasdaddy </a>  :  3/27/2021  11:35 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199759">link</a>   </div></div><div class="thread_post_body">Was thinking pats ,but I can see them getting jimmy g for a draft pick so won’t need too<br />
5 qbs May be off board by the time we pick<br />
Pitts.   Not huge on having another TE who can’t block a ton<br />
But basically,he would be an bigger Ee who can actually catch<br />
And is better at contested balls.  A bigger jordan reed.<br />
Definitely need an OG, if we fill it in first 3 rounds I would have more confidence pushing the starters as a rookie.<br />
if we could fit trai turner on roster, may not have to<br />
Just don’t know if they will after Fulton signing( who seems back up material)</div></div><div class="thread_post"><div class="thread_post_header"><b>I'm hacking into the NFL system... </b><a name="15199760">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  3/27/2021  11:36 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199760">link</a>   </div></div><div class="thread_post_body">and overriding the Jints Central card. <br />
<br />
And submitting: Rashawn Slater, any position on the OL, Northwestern.<br />
<br />
Your're welcome, Daniel Jones.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>I’m team DeVonta Smith </b><a name="15199762">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GoDeep13"> GoDeep13 </a>  :  3/27/2021  11:36 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199762">link</a>   </div></div><div class="thread_post_body">All the way. He is the guy I want most at 11. For me it’s.<br />
<br />
1. DeVonta Smith<br />
<br />
2. Slater<br />
3. Vera-Tucker<br />
4. Kyle Pitts<br />
5. Kwity Paye<br />
<br />
<br />
6. Waddle<br />
<br />
<br />
<br />
999. Gregory Rousseau</div></div><div class="thread_post"><div class="thread_post_header"><b>JJ </b><a name="15199763">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Rico"> Rico </a>  :  3/27/2021  11:36 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199763">link</a>   </div></div><div class="thread_post_body">This assessment pre-dates our big FA signings, but I should get more info as the draft gets closer. I did reconfirm that we are not interested in Parsons.</div></div><div class="thread_post"><div class="thread_post_header"><b>Bw </b><a name="15199767">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=cosmicj"> cosmicj </a>  :  3/27/2021  11:38 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199767">link</a>   </div></div><div class="thread_post_body">I think there are some excellent early 2nd round OL prospects available this season and picking one then would be a more efficient use of resources.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: JJ </b><a name="15199769">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=chick310"> chick310 </a>  :  3/27/2021  11:38 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199769">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15199763" target="_blank">15199763</a> Rico said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> This assessment pre-dates our big FA signings, but I should get more info as the draft gets closer. I did reconfirm that we are not interested in Parsons. </td>
                                </tr>
                           </table><br />
<br />
Rico, you are the man.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: We love Pitts </b><a name="15199770">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ColHowPepper"> ColHowPepper </a>  :  3/27/2021  11:38 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199770">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15199732" target="_blank">15199732</a> Rico said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> We also love the receivers. I think OL in round 1 is unlikely. And Parsons is not an option. </td>
                                </tr>
                           </table>OL...gulp? Rico, if so, are JJ/DG def. going to go interior OL Day 2? OL is the Rodney Dang. of this organization</div></div><div class="thread_post"><div class="thread_post_header"><b>Parsons </b><a name="15199772">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=cosmicj"> cosmicj </a>  :  3/27/2021  11:38 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199772">link</a>   </div></div><div class="thread_post_body">I bet that fight with his PSU teammate was just the tip of the iceberg.</div></div><div class="thread_post"><div class="thread_post_header"><b>D Smith .. </b><a name="15199775">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=TrustTheProcess"> TrustTheProcess </a>  :  3/27/2021  11:40 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199775">link</a>   </div></div><div class="thread_post_body">Because he is the best talented person in that list and possibly in the draft. He falls to us you have to take him.</div></div><div class="thread_post"><div class="thread_post_header"><b>Jump for joy of pitts is there </b><a name="15199777">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Bill+L"> Bill L </a>  :  3/27/2021  11:41 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199777">link</a>   </div></div><div class="thread_post_body">And be depressed if no passcatchers are left<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I'm hacking into the NFL system... </b><a name="15199782">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ColHowPepper"> ColHowPepper </a>  :  3/27/2021  11:45 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199782">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15199760" target="_blank">15199760</a> bw in dc said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> and overriding the Jints Central card. <br />
<br />
And submitting: Rashawn Slater, any position on the OL, Northwestern.<br />
Your're welcome, Daniel Jones. </td>
                                </tr>
                           </table>We are, at last, in big time agreement, as this seems a modification of a not very dated assertion of yours, after KG signing: 'no more excuses for DJ'. Nothing could be farther from the truth imo even if some 'excuses' become more attenuated. If it is to be Slater, hope he can come in and compete right away.</div></div><div class="thread_post"><div class="thread_post_header"><b>bw in dc </b><a name="15199784">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BigBlueCane"> BigBlueCane </a>  :  3/27/2021  11:48 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199784">link</a>   </div></div><div class="thread_post_body">I don't think Judge loves Slater, which should say something.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Bw </b><a name="15199785">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  3/27/2021  11:48 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199785">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15199767" target="_blank">15199767</a> cosmicj said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I think there are some excellent early 2nd round OL prospects available this season and picking one then would be a more efficient use of resources. </td>
                                </tr>
                           </table><br />
<br />
If you are suggesting a receiver instead at #11, I could argue the same the other way with quality receivers available on day 2 and 3.<br />
<br />
I've become really fond of the kid out of Stanford - Simi Fehoko. His hands just jump off the screen. He's 6'4", 220 and ran a 4.42 forty. Check him out.</div></div><div class="thread_post"><div class="thread_post_header"><b>Parsons would take care of both needs </b><a name="15199787">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=DonnieD89"> DonnieD89 </a>  :  3/27/2021  11:50 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199787">link</a>   </div></div><div class="thread_post_body">for Edge and LB with the Giants defensive versatility.  Pitts is oozing with talent and would be an upgrade over Engram. I can see them taking Pitts and moving Engram via trade for a third round or fourth round draft pick.  Smith would compliment Golliday with his speed and precise route running.  I also agree with Smith being a good fit with Joe Judges belief in his type of ball players with work ethic and good.  Slater is also a top-tier OLinemen that the Giants desperately need, as he can play guard as well as tackle. Waddle’s foot injury scares me, but if he is healthy, he will complement Golliday just as  Smith would.  I guess my order of preference is Parsons, pets, Smith, Slater, Waddel.</div></div><div class="thread_post"><div class="thread_post_header"><b>If for some reason all these WRs and Pitts are taken already </b><a name="15199788">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=chick310"> chick310 </a>  :  3/27/2021  11:53 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199788">link</a>   </div></div><div class="thread_post_body">then grabbing Slater at #11 would be fine.  But just don't think that they can let one of those pass catchers go by and not continue to add impact players into the Offense.<br />
<br />
Also think the Giants think so too.</div></div><div class="thread_post"><div class="thread_post_header"><b>Let's say the Giants don't draft a WR or TE on Day 1 </b><a name="15199790">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=chick310"> chick310 </a>  :  3/27/2021  11:55 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199790">link</a>   </div></div><div class="thread_post_body">who would be the top guys at those positions to target on Day 2?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: JJ </b><a name="15199791">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Judge_and_Jury"> Judge_and_Jury </a>  :  3/27/2021  11:55 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199791">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15199763" target="_blank">15199763</a> Rico said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> This assessment pre-dates our big FA signings, but I should get more info as the draft gets closer. I did reconfirm that we are not interested in Parsons. </td>
                                </tr>
                           </table><br />
<br />
Good stuff Rico. So Parsons a no go despite our big presence at Penn State which I guess may have been for Oweh and/or Friermuth possibly.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: bw in dc </b><a name="15199794">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  3/27/2021  11:59 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199794">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15199784" target="_blank">15199784</a> BigBlueCane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I don't think Judge loves Slater, which should say something. </td>
                                </tr>
                           </table><br />
<br />
Sounds like Slater isn’t under consideration - true.<br />
<br />
But good, versatile OLs are hard to find these days. If you have a chance to grab one, do it. Good receivers tend to be everywhere in the draft. This year is no exception.</div></div><div class="thread_post"><div class="thread_post_header"><b>The Alabama WRs Scare The Crap Out Of Me </b><a name="15199795">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Trainmaster"> Trainmaster </a>  :  3/27/2021  11:59 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199795">link</a>   </div></div><div class="thread_post_body">due to size and / or injury concerns. <br />
<br />
I’m warming to Pitts, but I think he’ll be gone. <br />
<br />
I also worry about the players who opted out in 2020. <br />
<br />
Surtain might be the safest pick if he makes it past Dallas. <br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Pitts </b><a name="15199796">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Peter+from+NH+%28formerly+CT%29"> Peter from NH (formerly CT) </a>  :  3/27/2021  11:59 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15199796">link</a>   </div></div><div class="thread_post_body">Smith<br />
Waddle<br />
Slater<br />
Parsons <br />
in that order</div></div><div class="thread_post"><div class="thread_post_header"><b>The Giants  </b><a name="15199800">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=SleepyOwl"> SleepyOwl </a>  :  3/27/2021  12:04 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15199800">link</a>   </div></div><div class="thread_post_body">will select the player they want... Daniel Jones and Saquon are prime examples of that. Wouldn’t be surprised to see the Giants pick a guy few people are mentioning.  Players like Ojulari, Vera Tucker, Farley, Paye, Rousseau, are and should be in play at 11.  Can you really be upset if the Giants walked away with Rousseau R1 and Trey Smith R2... Giants should also be looking for life after Engram and Shep so Waddle and Pitts make a ton of sense too.</div></div><div class="thread_post"><div class="thread_post_header"><b>I thought I heard somewhere </b><a name="15199801">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Peter+from+NH+%28formerly+CT%29"> Peter from NH (formerly CT) </a>  :  3/27/2021  12:05 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15199801">link</a>   </div></div><div class="thread_post_body">that Slater made noise that he is a tackle only. I would think Giants would only want him as an interior player. Maybe that is why they are not high on him, to the extent that they aren't.</div></div><div class="thread_post"><div class="thread_post_header"><b>There will be quality OLs available in the 2nd </b><a name="15199809">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BillT"> BillT </a>  :  3/27/2021  12:16 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15199809">link</a>   </div></div><div class="thread_post_body">You take the skill position player with the premium pick. Either of the WRs and as far as I can tell Pitts isn't a WR.</div></div><div class="thread_post"><div class="thread_post_header"><b>If the Giants know enough about Parsons to offset the negatives and </b><a name="15199812">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Ivan15"> Ivan15 </a>  :  3/27/2021  12:17 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15199812">link</a>   </div></div><div class="thread_post_body">The rumors, I think they rate him 4th among the non QBs, behind Sewell, Chase and Pitts and would be the Edge rusher they are needing (even if he hasn’t played outside very much, he played where he was most needed). If the rumors are true and the negatives are valid, they won’t pick him at all and the pick becomes Waddle, Smith or Slater. <br />
<br />
I doubt that they are comfortable with any RG on the roster, so if they don’t sign a real starting RG among the remaining free agents, Slater would be the pick. Smith and Waddle are a toss up. “Beauty in the eye of the beholder” pick.<br />
<br />
Truly unfortunate that so many of the top picks opted out.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: We love Pitts </b><a name="15199844">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=GiantsFan84"> GiantsFan84 </a>  :  3/27/2021  12:45 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15199844">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15199732" target="_blank">15199732</a> Rico said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> We also love the receivers. I think OL in round 1 is unlikely. And Parsons is not an option. </td>
                                </tr>
                           </table><br />
<br />
inject this into my veins</div></div><div class="thread_post"><div class="thread_post_header"><b>Rico </b><a name="15199853">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Professor+Falken"> Professor Falken </a>  :  3/27/2021  12:49 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15199853">link</a>   </div></div><div class="thread_post_body">Any indication which Alabama receiver they like more? Thanks for the info!</div></div><div class="thread_post"><div class="thread_post_header"><b>I expect there will be another trade or 2 in front of us but here’s  </b><a name="15199887">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Spider56"> Spider56 </a>  :  3/27/2021  1:28 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15199887">link</a>   </div></div><div class="thread_post_body">the given ... 4 QBs, Sewell, Chase and Pitts are going as the first 7 ... the next 7 is where the fun begins ... could be:<br />
Mac Jones, Slater, Waddle, Smith, Parsons, Surtain and Horn ... or one of the ERs. <br />
<br />
Frankly, unless Chaos said to stay away from Parsons, I think he’s still the guy ... I’d expect them to blow smoke now to avoid losing him to the Cowboys ... that would be 2 years in a row losing arguably the best defensive player in the draft because they won a meaningless game in week 17. <br />
<br />
If not Parsons or Slater, then I hope they trade down.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I expect there will be another trade or 2 in front of us but here’s  </b><a name="15199889">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Judge_and_Jury"> Judge_and_Jury </a>  :  3/27/2021  1:30 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15199889">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15199887" target="_blank">15199887</a> Spider56 said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> the given ... 4 QBs, Sewell, Chase and Pitts are going as the first 7 ... the next 7 is where the fun begins ... could be:<br />
Mac Jones, Slater, Waddle, Smith, Parsons, Surtain and Horn ... or one of the ERs. <br />
<br />
Frankly, unless Chaos said to stay away from Parsons, I think he’s still the guy ... I’d expect them to blow smoke now to avoid losing him to the Cowboys ... that would be 2 years in a row losing arguably the best defensive player in the draft because they won a meaningless game in week 17. <br />
<br />
If not Parsons or Slater, then I hope they trade down. </td>
                                </tr>
                           </table><br />
<br />
Rico is saying likely no on both.</div></div><div class="thread_post"><div class="thread_post_header"><b>If DG  </b><a name="15199890">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=thevett"> thevett </a>  :  3/27/2021  1:31 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15199890">link</a>   </div></div><div class="thread_post_body">Has all it these possibilities to choose from, he’ll go DT</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I expect there will be another trade or 2 in front of us but here’s  </b><a name="15199900">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Spider56"> Spider56 </a>  :  3/27/2021  1:47 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15199900">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15199889" target="_blank">15199889</a> Judge_and_Jury said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15199887 Spider56 said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     the given ... 4 QBs, Sewell, Chase and Pitts are going as the first 7 ... the next 7 is where the fun begins ... could be:<br />
Mac Jones, Slater, Waddle, Smith, Parsons, Surtain and Horn ... or one of the ERs. <br />
<br />
Frankly, unless Chaos said to stay away from Parsons, I think he’s still the guy ... I’d expect them to blow smoke now to avoid losing him to the Cowboys ... that would be 2 years in a row losing arguably the best defensive player in the draft because they won a meaningless game in week 17. <br />
<br />
If not Parsons or Slater, then I hope they trade down. <br />
                                                         <br />
Rico is saying likely no on both. </td>
                                </tr>
                           </table><br />
<br />
There’s no doubt no one wants another Baker fiasco so if there’s any question on character or work ethic I fully understand ... but what doesn’t make sense is that the Giants under JJ have been very close mouthed on what they’re doing ... why would they Telegraph not being interested in guys 5 weeks before the draft? This makes me wonder.</div></div><div class="thread_post"><div class="thread_post_header"><b>It feels like the Giants are in all in mode </b><a name="15199906">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=AnnapolisMike"> AnnapolisMike </a>  :  3/27/2021  1:49 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15199906">link</a>   </div></div><div class="thread_post_body">WR may not make the most sense given what they did in free agency.  This might be the year the Giants trade down a bit for an extra pick or two if BPA is a WR</div></div><div class="thread_post"><div class="thread_post_header"><b>I'm with George from PA - don't love any of them.  </b><a name="15199925">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Red+Dog"> Red Dog </a>  :  3/27/2021  2:22 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15199925">link</a>   </div></div><div class="thread_post_body">I'd like a trade down to acquire additional choices - plural - and get some more help in multiple areas including OL, DL, LB, CB, RB, and TE if they do the smart thing and trade EE now.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: It feels like the Giants are in all in mode </b><a name="15199926">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=LakeGeorgeGiant"> LakeGeorgeGiant </a>  :  3/27/2021  2:22 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15199926">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15199906" target="_blank">15199906</a> AnnapolisMike said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> WR may not make the most sense given what they did in free agency.  This might be the year the Giants trade down a bit for an extra pick or two if BPA is a WR </td>
                                </tr>
                           </table><br />
<br />
I dont think they will hesitate to pull the trigger on another WR at 11.<br />
<br />
Shep is underwhelming and they have no depth.<br />
<br />
A cost controlled weapon to pair with Golliday seems like a good idea to me.<br />
<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>I see a lot of mocks </b><a name="15199947">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=santacruzom"> santacruzom </a>  :  3/27/2021  2:52 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15199947">link</a>   </div></div><div class="thread_post_body">That link Pitts to the Falcons at 4.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: It feels like the Giants are in all in mode </b><a name="15199979">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=eric2425ny"> eric2425ny </a>  :  3/27/2021  3:36 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15199979">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15199926" target="_blank">15199926</a> LakeGeorgeGiant said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15199906 AnnapolisMike said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     WR may not make the most sense given what they did in free agency.  This might be the year the Giants trade down a bit for an extra pick or two if BPA is a WR <br />
                                <br />
                           <br />
<br />
I dont think they will hesitate to pull the trigger on another WR at 11.<br />
<br />
Shep is underwhelming and they have no depth.<br />
<br />
A cost controlled weapon to pair with Golliday seems like a good idea to me.<br />
 </td>
                                </tr>
                           </table><br />
<br />
I think there’s a good chance Shep is gone after this year if he misses more than a game or two.  He’s a nice player but has a relatively high cap number for the production level.</div></div><div class="thread_post"><div class="thread_post_header"><b>Judge_and_Jury </b><a name="15199989">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=gidiefor"> gidiefor </a> : <b style="background:darkred;color:white;">Mod</b> :  3/27/2021  3:44 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15199989">link</a>   </div></div><div class="thread_post_body">that's a pretty good analysis in my view -- <br />
<br />
and with Ricos input it would seem that Case or Pitts would be the pick. Two very good players. I probably give the nod to Pitts in that scenario mostly because he's more of a Giant, and I'd be on the horn to trade Engram for a 2 or 3rd rd pick to anyone who has expressed interest in him almost immediately</div></div><div class="thread_post"><div class="thread_post_header"><b>This scenario feels like ... </b><a name="15200006">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=FStubbs"> FStubbs </a>  :  3/27/2021  4:16 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15200006">link</a>   </div></div><div class="thread_post_body">2014, when we had a shot at Zach Martin or Aaron Donald and went with Beckham. Which at first looked like a great move, but as time played out, it was proven to be the wrong pick.<br />
<br />
If this is a redo, then I hope the Giants would make the right decision here (in other words, not the WR).<br />
<br />
This draft is deep in WR and we have a functional corps already. 2nd-3rd round feel like the places to get one. I'd rather we get Parsons (if by some absolute miracle Dallas passes on him, though I can't see that happening) or Slater.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: This scenario feels like ... </b><a name="15200011">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Spider56"> Spider56 </a>  :  3/27/2021  4:23 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15200011">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15200006" target="_blank">15200006</a> FStubbs said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> 2014, when we had a shot at Zach Martin or Aaron Donald and went with Beckham. Which at first looked like a great move, but as time played out, it was proven to be the wrong pick.<br />
<br />
If this is a redo, then I hope the Giants would make the right decision here (in other words, not the WR).<br />
<br />
This draft is deep in WR and we have a functional corps already. 2nd-3rd round feel like the places to get one. I'd rather we get Parsons (if by some absolute miracle Dallas passes on him, though I can't see that happening) or Slater. </td>
                                </tr>
                           </table><br />
<br />
+1.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: This scenario feels like ... </b><a name="15200016">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Judge_and_Jury"> Judge_and_Jury </a>  :  3/27/2021  4:45 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15200016">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15200006" target="_blank">15200006</a> FStubbs said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> 2014, when we had a shot at Zach Martin or Aaron Donald and went with Beckham. Which at first looked like a great move, but as time played out, it was proven to be the wrong pick.<br />
<br />
If this is a redo, then I hope the Giants would make the right decision here (in other words, not the WR).<br />
<br />
This draft is deep in WR and we have a functional corps already. 2nd-3rd round feel like the places to get one. I'd rather we get Parsons (if by some absolute miracle Dallas passes on him, though I can't see that happening) or Slater. </td>
                                </tr>
                           </table><br />
<br />
Pitts is almost universally projected as one of the top non QBs in the entire draft. Do you pass him up?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: This scenario feels like ... </b><a name="15200022">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bw+in+dc"> bw in dc </a>  :  3/27/2021  4:57 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15200022">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15200006" target="_blank">15200006</a> FStubbs said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> 2014, when we had a shot at Zach Martin or Aaron Donald and went with Beckham. Which at first looked like a great move, but as time played out, it was proven to be the wrong pick.<br />
<br />
If this is a redo, then I hope the Giants would make the right decision here (in other words, not the WR).<br />
<br />
This draft is deep in WR and we have a functional corps already. 2nd-3rd round feel like the places to get one. I'd rather we get Parsons (if by some absolute miracle Dallas passes on him, though I can't see that happening) or Slater. </td>
                                </tr>
                           </table><br />
<br />
Very good post. Now that we have KG, the key is building a better wall for DJ.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: There will be quality OLs available in the 2nd </b><a name="15200061">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=FStubbs"> FStubbs </a>  :  3/27/2021  5:44 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15200061">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15199809" target="_blank">15199809</a> BillT said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> You take the skill position player with the premium pick. Either of the WRs and as far as I can tell Pitts isn't a WR. </td>
                                </tr>
                           </table><br />
<br />
Like George Young said, there are only a few dancing elephants to go around.<br />
<br />
Shiny hood ornaments can be had later and we just signed one.</div></div><div class="thread_post"><div class="thread_post_header"><b>Unless it's Surtain, or someone totally out of left field (like Late) </b><a name="15200101">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bLiTz+2k"> bLiTz 2k </a>  :  3/27/2021  6:45 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15200101">link</a>   </div></div><div class="thread_post_body">The pick is going to be offense...I would love Waddle because he brings a totally different dynamic than any weapon the Giants have...<br />
<br />
I'd be good with Pitts, or Smith as well. Parsons is nearly a remote thrower.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Unless it's Surtain, or someone totally out of left field (like Late) </b><a name="15200102">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=bLiTz+2k"> bLiTz 2k </a>  :  3/27/2021  6:45 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15200102">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15200101" target="_blank">15200101</a> bLiTz 2k said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> The pick is going to be offense...I would love Waddle because he brings a totally different dynamic than any weapon the Giants have...<br />
<br />
I'd be good with Pitts, or Smith as well. Parsons is nearly a remote thrower. </td>
                                </tr>
                           </table><br />
<br />
Damn autocorrect...PAYE****</div></div><div class="thread_post"><div class="thread_post_header"><b>You go trenches </b><a name="15200105">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=MotownGIANTS"> MotownGIANTS </a>  :  3/27/2021  6:52 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15200105">link</a>   </div></div><div class="thread_post_body">in that scenario .... OL to maximize all your young offensive talent or complete the defense completely. If the plan is to build a complete team you can complete 1 side or make both have enough strategic pieces to have the unfinished product have some balance to have a viable chance to at least compete in the division and get a ticket to the party. <br />
<br />
Meaning next off-season all parts will be obtained especially on the defensive side.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: This scenario feels like ... </b><a name="15200124">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=nyballa0891"> nyballa0891 </a>  :  3/27/2021  7:12 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15200124">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15200006" target="_blank">15200006</a> FStubbs said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> 2014, when we had a shot at Zach Martin or Aaron Donald and went with Beckham. Which at first looked like a great move, but as time played out, it was proven to be the wrong pick.<br />
</td>
                                </tr>
                           </table><br />
<br />
I don’t see an Aaron donald or zack martin in this draft (maybe sewell) but im sure he will be gone by 11.</div></div><div class="thread_post"><div class="thread_post_header"><b>bw in dc </b><a name="15200179">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=BigBlueCane"> BigBlueCane </a>  :  3/27/2021  8:09 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15200179">link</a>   </div></div><div class="thread_post_body">that's probably why they're eyeing the Tennessee kid. Remember we have 2 Vol coaches on staff.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: bw in dc </b><a name="15200181">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Judge_and_Jury"> Judge_and_Jury </a>  :  3/27/2021  8:11 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15200181">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15200179" target="_blank">15200179</a> BigBlueCane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> that's probably why they're eyeing the Tennessee kid. Remember we have 2 Vol coaches on staff. </td>
                                </tr>
                           </table><br />
<br />
Like Trey Smith but would rather have Leatherwood</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="15200182">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=SFGFNCGiantsFan"> SFGFNCGiantsFan </a>  :  3/27/2021  8:11 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15200182">link</a>   </div></div><div class="thread_post_body">We have a 'functional' WR corps? Uh, what? God forbid KG gets injured, we have no one.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: ... </b><a name="15200192">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Judge_and_Jury"> Judge_and_Jury </a>  :  3/27/2021  8:20 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15200192">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15200182" target="_blank">15200182</a> SFGFNCGiantsFan said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> We have a 'functional' WR corps? Uh, what? God forbid KG gets injured, we have no one. </td>
                                </tr>
                           </table><br />
<br />
Rudolph and a potentially healthy Barkley improve the dynamic quite a bit.</div></div><div class="thread_post"><div class="thread_post_header"><b>J&J. </b><a name="15200197">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=SFGFNCGiantsFan"> SFGFNCGiantsFan </a>  :  3/27/2021  8:23 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15200197">link</a>   </div></div><div class="thread_post_body">Well, Rudolph isn't Mr. Health right now & Saquon has missed significant time since his rookie season. <br />
<br />
I want offensive skill player @ 11, preferably Smith.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: J&J. </b><a name="15200225">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Judge_and_Jury"> Judge_and_Jury </a>  :  3/27/2021  8:47 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15200225">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15200197" target="_blank">15200197</a> SFGFNCGiantsFan said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Well, Rudolph isn't Mr. Health right now & Saquon has missed significant time since his rookie season. <br />
<br />
I want offensive skill player @ 11, preferably Smith. </td>
                                </tr>
                           </table><br />
<br />
They may be in their own row as far as grade so it could very well be a WR or Pitts at 11.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: ... </b><a name="15200262">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Eman11"> Eman11 </a>  :  3/27/2021  9:22 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15200262">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15200192" target="_blank">15200192</a> Judge_and_Jury said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15200182 SFGFNCGiantsFan said:<br />
<br />
                                <br />
                                     Quote:<br />
                                <br />
                                <br />
                                     We have a 'functional' WR corps? Uh, what? God forbid KG gets injured, we have no one. <br />
                                <br />
                           <br />
<br />
Rudolph and a potentially healthy Barkley improve the dynamic quite a bit. </td>
                                </tr>
                           </table><br />
<br />
Yes but neither are part of our WR Corp. <br />
<br />
I agree we don’t have much there if KG misses any time.</div></div><div class="thread_post"><div class="thread_post_header"><b>Rico </b><a name="15200350">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  3/27/2021  10:56 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15200350">link</a>   </div></div><div class="thread_post_body">thanks as always.<br />
<br />
Pitts, Smith, Waddle seems like Giants top 3 - they hope 1 is there. If not, take the edge talent- Ojulari could be the backup plan if all are gone assuming Surtain gone as well</div></div><div class="thread_post"><div class="thread_post_header"><b>It is fairly nice to </b><a name="15200370">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=section125"> section125 </a>  :  3/27/2021  11:37 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15200370">link</a>   </div></div><div class="thread_post_body">not to have to pick anyone.<br />
<br />
I cannot see Detroit taking Waddle over Smith if they go WR. However, I have a feeling the Giants go for the impact player. So I think they go WR or CB. Not sure what happens to Farley after he surgery, but presume he drops bigtime.<br />
<br />
I think they take Smith/Waddle or Surtain.<br />
<br />
Oline will be later.<br />
<br />
FWIW, my friend a former Michigan football player says Kwity Paye has all the measurables to be a great player, but absolutely needs the right coach, like a Belichick(or Judge) to develop and push him.<br /></div></div><div class="thread_post"><div class="thread_post_header"><b>Keep in mind  </b><a name="15200388">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  3/28/2021  12:02 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15200388">link</a>   </div></div><div class="thread_post_body">there are surprises every year and this year will be no different. There will be 1-2 players that we aren’t even discussing that will probably get drafted in the top 10</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Keep in mind  </b><a name="15200426">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Judge_and_Jury"> Judge_and_Jury </a>  :  3/28/2021  4:42 am   : <a href="index.php?mode=2&thread=607439&show_all=1#15200426">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15200388" target="_blank">15200388</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> there are surprises every year and this year will be no different. There will be 1-2 players that we aren’t even discussing that will probably get drafted in the top 10 </td>
                                </tr>
                           </table><br />
<br />
It is possible a guy may sneak in but I would doubt 2 guys will sneak in. Half the teams will be going QB and Sewell and Chase are the blue chippers.</div></div><div class="thread_post"><div class="thread_post_header"><b>Judge  </b><a name="15200887">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=ryanmkeane"> ryanmkeane </a>  :  3/28/2021  4:28 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15200887">link</a>   </div></div><div class="thread_post_body">I hear ya. All I’m saying is the media experts mock and rankings are typically quite different than actual NFL teams</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Judge  </b><a name="15201163">&nbsp;</a><div class="thread_info"><a href="index.php?mode=5&handle=Judge_and_Jury"> Judge_and_Jury </a>  :  3/28/2021  11:07 pm   : <a href="index.php?mode=2&thread=607439&show_all=1#15201163">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&thread=607439&show_all=1#15200887" target="_blank">15200887</a> ryanmkeane said:<br />
<table border="0" cellpadding="3" cellspacing="0">
                                <tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I hear ya. All I’m saying is the media experts mock and rankings are typically quite different than actual NFL teams </td>
                                </tr>
                           </table><br />
<br />
Absolutely. Let's see... I'd be a bit surprised though if we got more than 1 unexpected riser.</div></div><a name="END"><a href="index.php"><div style="padding-top:25px; padding-bottom:20px;"><img src="/images/back_corner.gif" class="thread_link"  alt="Back to the Corner" border="0"></a></div></a></div>
<div class="thread_sidebar_2">

<!-- Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-102">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Corner Forum - Lower 300x250 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1566320450447229"
     data-ad-slot="4189314539"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->

</div>

</div>




<div class="footer">


<p style="width:400px;float:left;"><b>Part of the USA Today Sports Media Group</b><br>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</P>
<P  style="width:400px;float:right; text-align:right;">
All contents (unless otherwise specified) copyright &copy;  1995 - 2020<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Solutions</a>
</P>
<br clear="all">
<div style="float:right;">
<script
    src="https://sucuri.net/monitoring/badge.js"
    data-s="19"
    id="sucuri-s"
    data-i="7b1b29ae50ae6574f2af3875935246e4fa8a805b26"
    data-p="o" - position - l(left) or r(right) or o(relative)
    data-c="l"
    data-t="t"
    ></script>
</div>

</div>


<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->

<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=194-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script></body>
</html>
