<!DOCTYPE html><html lang="en"><head><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>!function(){function e(i){return(e="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e})(i)}__ez.pel=function(){var i=[];function t(t,o,_,d,n,r,a,s){if(__ez.dot.isDefined(t)&&0!=__ez.dot.isAnyDefined(t.getSlotElementId,t.ElementId)){var p=parseInt(__ez.dot.getTargeting(t,"ap")),f=__ez.dot.getSlotIID(t),u=__ez.dot.getAdUnit(t,s),g=parseInt(__ez.dot.getTargeting(t,"compid")),c=0,l=0,z=function(i){if("undefined"==typeof _ezim_d)return!1;var t=__ez.dot.getAdUnitPath(i).split("/").pop();if("object"===("undefined"==typeof _ezim_d?"undefined":e(_ezim_d))&&_ezim_d.hasOwnProperty(t))return _ezim_d[t];for(var o in _ezim_d)if(o.split("/").pop()===t)return _ezim_d[o];return!1}(t);"object"==e(z)&&(void 0!==z.creative_id&&(l=z.creative_id),void 0!==z.line_item_id&&(c=z.line_item_id)),__ez.dot.isDefined(f,u)&&__ez.dot.isValid(o)&&i.push({type:"impression",impression_id:f,domain_id:__ez.dot.getDID(),unit:u,t_epoch:__ez.dot.getEpoch(0),revenue:_,est_revenue:d,ad_position:p,ad_size:"",bid_floor_filled:n,bid_floor_prev:r,stat_source_id:a,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:g,line_item_id:c,creative_id:l,data:__ez.dot.dataToStr(o),is_orig:s||__ez.template.isOrig})}}function o(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(i)&&i.length>0&&[i.filter((function(e){return e.is_orig})),i.filter((function(e){return!e.is_orig}))].forEach((function(e){for(;e.length>0;){var i=e[0].is_orig||!1,t=5;t>e.length&&(t=e.length);var o=e.splice(0,t),_=__ez.dot.getURL("/porpoiseant/army.gif")+"?orig="+(!0===i?1:0)+"&sts="+btoa(JSON.stringify(o));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(_+="&visit_uuid="+_ezaq.visit_uuid),__ez.dot.Fire(_)}})),i=[])}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),o()},AddAndFireOrig:function(e,i){t(e,i,0,0,0,0,0,!0),o()},AddById:function(e,t,o){var _=e.split("/");if(__ez.dot.isDefined(e)&&3===_.length&&__ez.dot.isValid(t)){var d=_[0],n=_[2];i.push({type:"impression",impression_id:n,domain_id:__ez.dot.getDID(),unit:d,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(t),is_orig:o||__ez.template.isOrig})}},Fire:o,GetPixels:function(){return i}}}()}();__ez.queue.addFile('/detroitchicago/raleighz.js', '/detroitchicago/raleighz.js?gcb=194-0&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=194-0&cb=3', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=194-0&cb=5', false, [], true, false, true, false);</script>
<title>okay, less than 2 weeks now: State your pick at #11  | Big Blue Interactive </title>

<meta http-equiv="Pragma" content="no-cache"/>
<meta http-equiv="Expires" content="-1"/>

<meta name="keywords" content="ndglbqfkxx"/>

<meta name="description" content="Go on record as to who you think the Giants will pick: State position, Name of pick and afterwards any reasons why"/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="website"/>
<meta property="og:description" content="Go on record as to who you think the Giants will pick: State position, Name of pick and afterwards any reasons why"/> 
<meta property="og:title" content="okay, less than 2 weeks now: State your pick at #11 "/> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif"/> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css?v=20200217"/>

<link rel="stylesheet" type="text/css" href="anylink.css"/>


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}


div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" alt="for display only">

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type="text/javascript">
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type="text/javascript" src="https://img.bnqt.com/lib/js/sdpdfphelper.js"></script>
<script type="text/javascript">
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>


<!-- End DFP SETUP -->  

<!-- End USA Today Code -->




<script type="text/javascript">var ezouid = "1";</script><base href="https://corner.bigblueinteractive.com/index.php?mode=2&thread=608126&show_all=1"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"domain_test_group":20210306,"engaged_time_visit":0,"ezcache_level":0,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"2b1ba5c0-e6aa-470a-4057-643f77469285","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":110831,"response_time_orig":115,"serverid":"3.89.104.228:15217","state":"VA","t_epoch":1618966083,"template_id":126,"time_on_site_visit":0,"url":"https://corner.bigblueinteractive.com/index.php?mode=2\u0026thread=608126\u0026show_all=1","user_id":0,"word_count":7422,"worst_bad_word_level":1};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["2b1ba5c0-e6aa-470a-4057-643f77469285", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>


<body>




<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tbody><tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"/></a> <img src="images/xpete.gif" alt="The Corner Forum"/>

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic --> 


<!-- Nov 2019 Leaderboard -->

<!-- Ezoic - Forum Leaderboard (USAT) - top_of_page -->
<div id="ezoic-pub-ad-placeholder-118">
<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->
<div id="usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general');
         });
     </script>
</div>
</div>
<!-- End Ezoic - Forum Leaderboard (USAT) - top_of_page -->



</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://www.amazon.com/?_encoding=UTF8&amp;camp=1789&amp;creative=9325&amp;linkCode=ur2&amp;tag=bigblueintera-20">Amazon.com</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW">Standings (NFL.com)</a>
<a href="https://www.giants.com/team/stats/" target="_NEW">Statistics (Giants.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/">Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</tbody></table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;home_view_menu&#39;)">Home</a>  
</li><li><a href="http://corner.bigblueinteractive.com/index.php" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;forum_view_menu&#39;)">Corner Forum</a>
</li><li><a href="http://corner.bigblueinteractive.com/index.php" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;gameday_view_menu&#39;)">Gameday</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_view_menu&#39;)">Team</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_building_view_menu&#39;)">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info & History</a> -->
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_info_view_menu&#39;)">Giants Info &amp; History</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;infolinks_view_menu&#39;)">Info/Links</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;shop_view_menu&#39;)">BBI Shop</a>
</li><li><a href="/index.php?mode=10" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;login_menu&#39;)">Log In</a>
</li></ul>

</div><div id="infoline"> </div>

<a name="END"></a><a href="index.php"></a><div style="padding-top:20px; padding-bottom:25px;"><a href="index.php"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"/></a></div><div class="thread_container"><div class="thread_left"><div class="thread_body"><div class="thread_main"><div class="thread_post_header">  <h1 style="font-size:18px;">okay, less than 2 weeks now: State your pick at #11  </h1><div class="thread_info"><a href="index.php?mode=5&amp;handle=gidiefor"> gidiefor </a> : <b style="background:darkred;color:white;">Mod</b> :  4/19/2021  6:29 pm</div></div><div class="thread_post_body"> Go on record as to who you think the Giants will pick: State position, Name of pick and afterwards any reasons why </div></div></div></div><div class="thread_right"><div id="ad_side_box">


<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id="usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general');
         });
     </script>
</div>




</div></div><div class="thread_comment_container"><div class="thread_post"><div class="thread_post_header"><b>LB Micah Parsons </b><a name="15226174"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=HMunster"> HMunster </a>  :  4/19/2021  6:33 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226174">link</a>   </div></div><div class="thread_post_body">Playmaker on defense. Best defensive player in the draft. I&#39;m assuming character issues check out. Draft depth at WR and OL allow us to wait until rounds 2-4 for those positions whereas the drop-off is steep in LB and Edge.</div></div><div class="thread_post"><div class="thread_post_header"><b>Parsons as well </b><a name="15226177"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Chip"> Chip </a>  :  4/19/2021  6:37 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226177">link</a>   </div></div><div class="thread_post_body">I believe drafting small WRs over a LB who is faster than LT and maybe weighs a lb or two more makes sense.  Also with the Golladay signing it is a bigger need.</div></div><div class="thread_post"><div class="thread_post_header"><b>I need 11 more days </b><a name="15226180"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=ZogZerg"> ZogZerg </a>  :  4/19/2021  6:38 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226180">link</a>   </div></div><div class="thread_post_body">;)</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I need 11 more days </b><a name="15226181"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=gidiefor"> gidiefor </a> : <b style="background:darkred;color:white;">Mod</b> :  4/19/2021  6:39 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226181">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226180" target="_blank">15226180</a> ZogZerg said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> ;) </td>
                                </tr>
                           </tbody></table><br/>
come on ZZ man up!</div></div><div class="thread_post"><div class="thread_post_header"><b>WR Jaylen Waddle - Alabama </b><a name="15226182"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=guitarguybs12"> guitarguybs12 </a>  :  4/19/2021  6:40 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226182">link</a>   </div></div><div class="thread_post_body">It&#39;s a passing league so let&#39;s have one of the top WR groups in the entire NFL. Having a stretch the field deep threat would be a perfect pairing opposite Golladay and his contested catch skill-set. Having two outside weapons to have defenses focus on would really open the field up for our multiple middle of the field offensive weapons.</div></div><div class="thread_post"><div class="thread_post_header"><b>Smith </b><a name="15226183"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=jeff57"> jeff57 </a>  :  4/19/2021  6:42 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226183">link</a>   </div></div><div class="thread_post_body">BPA.</div></div><div class="thread_post"><div class="thread_post_header"><b>In </b><a name="15226184"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=AcidTest"> AcidTest </a>  :  4/19/2021  6:42 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226184">link</a>   </div></div><div class="thread_post_body">this order of likelihood:<br/>
<br/>
Smith.<br/>
Trade down, and take Ojulari.<br/>
Paye.</div></div><div class="thread_post"><div class="thread_post_header"><b>Edge Kwity Paye At #15 (Trade Back With New England) </b><a name="15226185"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Trainmaster"> Trainmaster </a>  :  4/19/2021  6:43 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226185">link</a>   </div></div><div class="thread_post_body">I know Gettleman has never traded back, but I&#39;m getting more convinced the Giants are more a &#34;Judge &amp; Co&#34; show.  The Belichick / Judge connection holds for a trade.<br/>
<br/>
There is one of Mac Jones (mostly likely), Trey Lance (possibly) or Justin Fields (unlikely) still available when the Giants are on the clock.  Sewell, Pitts, Chase, Surtain, Parsons and D Smith from among the non-QBs have been picked.  A trade back is worked out with the Patriots, with the Giants sending them 2021 #11 overall and the Giants getting 2021 #15, 2021 #46 overall (14th pick in the 2nd round), plus a 2022 third rounder.<br/>
<br/>
The Giants pick Kwity Paye at #15.  In round 2, they get a WR and an OL.<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>Smith will be there at 11 </b><a name="15226186"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Producer"> Producer </a>  :  4/19/2021  6:43 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226186">link</a>   </div></div><div class="thread_post_body">and that will be the pick.</div></div><div class="thread_post"><div class="thread_post_header"><b>Smith </b><a name="15226187"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Metnut"> Metnut </a>  :  4/19/2021  6:43 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226187">link</a>   </div></div><div class="thread_post_body">Best player in the whole draft and at a position of need.  Would be a true home run pick.<br/>
<br/>
Slater, Phillips, Parsons or Waddle would be ok if he’s off the board.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: In </b><a name="15226188"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  :  4/19/2021  6:43 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226188">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226184" target="_blank">15226184</a> AcidTest said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> this order of likelihood:<br/>
<br/>
Smith.<br/>
Trade down, and take Ojulari.<br/>
Paye. </td>
                                </tr>
                           </tbody></table><br/>
This is probably accurate, though my personal preference would be Paye over Ojulari.</div></div><div class="thread_post"><div class="thread_post_header"><b>Just will say one thing about Parsons </b><a name="15226189"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UGADawgs7"> UGADawgs7 </a>  :  4/19/2021  6:44 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226189">link</a>   </div></div><div class="thread_post_body">Stop believing everything you see. It was NOT a combine, the 40 times are BS! Amazing how this is all of a sudden the fastest draft class in the history by a lot due to no actual combine results. <br/>
The right side of this OL can really cause Jones to get injured yet again. He needs to remain healthy this year. If Slater is available, he’s the pick. Otherwise I’d go Waddle if he falls. Parsons could be this years Simmons. No thank you.</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="15226191"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=SFGFNCGiantsFan"> SFGFNCGiantsFan </a>  :  4/19/2021  6:47 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226191">link</a>   </div></div><div class="thread_post_body">Smith. <br/>
<br/>
&#39;Why the wrench?&#39;<br/>
&#39;Because fuck him, that&#39;s why.&#39;</div></div><div class="thread_post"><div class="thread_post_header"><b>While that may be true that’s really just for fans </b><a name="15226193"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  :  4/19/2021  6:47 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226193">link</a>   </div></div><div class="thread_post_body">scouts know the times and how fast players “look” - they do it for a living.<br/>
<br/>
I’ll go with Parsons as well. I think he’s the highest rated player between the LBers and EDGE prospects and he can give us a pass rush at OLB. Can also learn from and take over for Blake in the middle in a couple years.</div></div><div class="thread_post"><div class="thread_post_header"><b>I think they take </b><a name="15226197"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Des51"> Des51 </a>  :  4/19/2021  6:49 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226197">link</a>   </div></div><div class="thread_post_body">Edge Rusher Kwity Paye, I would prefer T/G Slater but I believe they&#39;ll go defense at 11. Sy has Paye with a higher grade than Parsons thus he&#39;s my choice on defense.</div></div><div class="thread_post"><div class="thread_post_header"><b>Azeez Ojulari trade down to 15 </b><a name="15226200"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=George+from+PA"> George from PA </a>  :  4/19/2021  6:50 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226200">link</a>   </div></div><div class="thread_post_body">.....</div></div><div class="thread_post"><div class="thread_post_header"><b>Smith </b><a name="15226203"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=chick310"> chick310 </a>  :  4/19/2021  6:52 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226203">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>WR Devonta Smith </b><a name="15226208"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gregorio"> Gregorio </a>  :  4/19/2021  6:53 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226208">link</a>   </div></div><div class="thread_post_body">I forget which NYG said it, but their primary focus this  offseason is to get weapons for Jones. K Golladay is one, D Smith would be two.</div></div><div class="thread_post"><div class="thread_post_header"><b>Smith or Paye </b><a name="15226209"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BigBlueCane"> BigBlueCane </a>  :  4/19/2021  6:54 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226209">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>Olijari </b><a name="15226210"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=DonQuixote"> DonQuixote </a>  :  4/19/2021  6:55 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226210">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>The Biants are the *worst* team for picking who I want them to pick </b><a name="15226212"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Bill+L"> Bill L </a>  :  4/19/2021  6:55 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226212">link</a>   </div></div><div class="thread_post_body">And DG doesn’t trade down even when the value is piss poor. So, I predict he will take Paye.  Outside shot at Slater but I just don’t think they view the OL as bad as we do. Either way, it’s a historical overdraft. <br/>
<br/>
My picks are in order of preference and excluding Sewell: Pitts, Smith, Waddle, Parsons.<br/>
<br/>
In order of talent it’s the same except for switching Waddle and Parsons. But the order I listed (my preference) is the order that I think will best help the Giants win in both the now and the future.</div></div><div class="thread_post"><div class="thread_post_header"><b>Kwity Paye, EDGE </b><a name="15226213"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Sean"> Sean </a>  :  4/19/2021  6:56 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226213">link</a>   </div></div><div class="thread_post_body">I think Judge will love his versatility and work ethic. Gettleman always loves bolstering the line.<br/>
<br/>
The surprise will be that they will pass on either Smith or Waddle to make the pick.</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="15226216"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=SFGFNCGiantsFan"> SFGFNCGiantsFan </a>  :  4/19/2021  6:57 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226216">link</a>   </div></div><div class="thread_post_body">If we pass on Smith &amp; he goes off the board the next pick to the Eagles...I will be a little peeved.</div></div><div class="thread_post"><div class="thread_post_header"><b>Smith </b><a name="15226219"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Bricktop"> Bricktop </a>  :  4/19/2021  6:59 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226219">link</a>   </div></div><div class="thread_post_body">If he&#39;s there, you scoop him up. This is a make or break year for Jones and will dictate much of the Giants future for the next decade. This also is Gettleman&#39;s last dance (he&#39;s done after his stint with the Giants) and his ego will not allow anything but the best effort to avoid being seen as a failure in NY. They&#39;re taking their chips and pulling a Fasell. In the middle they go.</div></div><div class="thread_post"><div class="thread_post_header"><b>Waddle  </b><a name="15226230"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BillT"> BillT </a>  :  4/19/2021  7:03 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226230">link</a>   </div></div><div class="thread_post_body">It’s who they’ve avoided being linked to. I think there is a reason for that.</div></div><div class="thread_post"><div class="thread_post_header"><b>Smith </b><a name="15226241"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Blue21"> Blue21 </a>  :  4/19/2021  7:11 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226241">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>One of Waddle/Smith and </b><a name="15226242"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Burt+in+Alameda"> Burt in Alameda </a>  :  4/19/2021  7:11 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226242">link</a>   </div></div><div class="thread_post_body">Slater will be available at No. 11.  My brain says Slater but my heart says Waddle/Smith, who, I think, are the best wideouts to come to the NFL in many years.  Also, I think the Eagles will be all over Waddle/Smith if the Giants take Slater, and he will become a thorn in the Giants side and a knife in their psyche for many years.  So, Gettleman, take the wideout.</div></div><div class="thread_post"><div class="thread_post_header"><b>Slater for RG </b><a name="15226243"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=MarvelousMike"> MarvelousMike </a>  :  4/19/2021  7:12 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226243">link</a>   </div></div><div class="thread_post_body">The need to protect DJ supersedes every other consideration. With Peart now at RT, they can grow together and begin to dominate that side of the OL in years to come.<br/>
<br/>
Alternative choices would be WR Smith or LB Parsons. Cases can be easily made for either one.</div></div><div class="thread_post"><div class="thread_post_header"><b>Devonta Smith </b><a name="15226246"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Danny+Kanell"> Danny Kanell </a>  :  4/19/2021  7:13 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226246">link</a>   </div></div><div class="thread_post_body">will be a Giant.</div></div><div class="thread_post"><div class="thread_post_header"><b>I think two of the three top WRs will be gone </b><a name="15226247"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Simms11"> Simms11 </a>  :  4/19/2021  7:14 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226247">link</a>   </div></div><div class="thread_post_body">and so who will be left standing? I think Waddle, Slater or Parsons would be there for the Giants and so that’s a real tough argument there. I’ll go out on a limb and say Waddle.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Devonta Smith </b><a name="15226249"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=SFGFNCGiantsFan"> SFGFNCGiantsFan </a>  :  4/19/2021  7:15 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226249">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226246" target="_blank">15226246</a> Danny Kanell said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> will be a Giant. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Speak it into existence my man!</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I think two of the three top WRs will be gone </b><a name="15226251"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Simms11"> Simms11 </a>  :  4/19/2021  7:16 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226251">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226247" target="_blank">15226247</a> Simms11 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> and so who will be left standing? I think Waddle, Slater or Parsons would be there for the Giants and so that’s a real tough argument there. I’ll go out on a limb and say Waddle. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Why you ask? Because he’s one of the top three WRs in the entire draft, a position of need still and he’s dynamic. Would make this offense tougher to defend and if Golladay was somehow injured, could add some solid depth to a WR Corp that would be extremely average without him.</div></div><div class="thread_post"><div class="thread_post_header"><b>ok all you who are either making multiple picks  </b><a name="15226254"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=gidiefor"> gidiefor </a> : <b style="background:darkred;color:white;">Mod</b> :  4/19/2021  7:17 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226254">link</a>   </div></div><div class="thread_post_body">or not following the format will not be tallied and your picks will not count</div></div><div class="thread_post"><div class="thread_post_header"><b>Why so many different choices? </b><a name="15226256"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=robbieballs2003"> robbieballs2003 </a>  :  4/19/2021  7:18 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226256">link</a>   </div></div><div class="thread_post_body">I was told this regime makes it known a month in advance who we are drafting.</div></div><div class="thread_post"><div class="thread_post_header"><b>Smith </b><a name="15226258"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Maggot+Brain"> Maggot Brain </a>  :  4/19/2021  7:19 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226258">link</a>   </div></div><div class="thread_post_body">Marvin Harrison clone.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: ok all you who are either making multiple picks  </b><a name="15226259"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Bill+L"> Bill L </a>  :  4/19/2021  7:19 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226259">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226254" target="_blank">15226254</a> gidiefor said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> or not following the format will not be tallied and your picks will not count </td>
                                </tr>
                           </tbody></table><br/>
That’s okay. We all know how this is going to end. BBI is the quintessential overreach for need and then later complain about sucking at value drafting site.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: In </b><a name="15226262"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=chopperhatch"> chopperhatch </a>  :  4/19/2021  7:21 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226262">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226188" target="_blank">15226188</a> Gatorade Dunk said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15226184 AcidTest said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     this order of likelihood:<br/>
<br/>
Smith.<br/>
Trade down, and take Ojulari.<br/>
Paye. <br/>
                                <br/>
                           <br/>
This is probably accurate, though my personal preference would be Paye over Ojulari. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I would put Paye over Smith in terms of likelihood. A person with inside info has dropped plenty of Paye Easter Eggs.<br/>
<br/>
I think the pick is Paye unless there is some world class disinfo happening.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: ok all you who are either making multiple picks  </b><a name="15226266"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=section125"> section125 </a>  :  4/19/2021  7:26 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226266">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226259" target="_blank">15226259</a> Bill L said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15226254 gidiefor said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     or not following the format will not be tallied and your picks will not count <br/>
                                <br/>
                           <br/>
That’s okay. We all know how this is going to end. BBI is the quintessential overreach for need and then later complain about sucking at value drafting site. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Um, yeah that was the last regime...</div></div><div class="thread_post"><div class="thread_post_header"><b>Waddle </b><a name="15226267"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=give66"> give66 </a>  :  4/19/2021  7:27 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226267">link</a>   </div></div><div class="thread_post_body">I think Smith will be gone by 11</div></div><div class="thread_post"><div class="thread_post_header"><b>Jaylen Waddle </b><a name="15226268"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=gogiants"> gogiants </a>  :  4/19/2021  7:28 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226268">link</a>   </div></div><div class="thread_post_body">I feel there are 8 blue chip non-QBs in the draft. My best guess has only Waddle and Parsons of the 8 remaining when the Giants pick. I think the pick would go Waddle in that case.<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>I do not believe it will </b><a name="15226270"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=section125"> section125 </a>  :  4/19/2021  7:29 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226270">link</a>   </div></div><div class="thread_post_body">be OL. That will be at #42<br/>
<br/>
I think it will be either Smith or Waddle. Waddle will be Shepard&#39;s replacement if he is chosen.<br/>
<br/>
Kwity Paye would be the ER if they go that way.<br/>
<br/>
So I think it will be DeVonta Smith...<br/>
<br/>
Final Answer - DeVonta Smith</div></div><div class="thread_post"><div class="thread_post_header"><b>I wouldn’t mind </b><a name="15226272"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Giant+John"> Giant John </a>  :  4/19/2021  7:33 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226272">link</a>   </div></div><div class="thread_post_body">Waddle, Parsons or Smith. So Smith by a nose. Just by a little.</div></div><div class="thread_post"><div class="thread_post_header"><b>I feel sick to my stomach... </b><a name="15226275"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  :  4/19/2021  7:43 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226275">link</a>   </div></div><div class="thread_post_body">but I fear it&#39;s going to be Paye.<br/>
<br/>
&#34;Mr. Almost&#34;</div></div><div class="thread_post"><div class="thread_post_header"><b>WR Smith  BPA future Gold Jacket. </b><a name="15226277"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Blue21"> Blue21 </a>  :  4/19/2021  7:45 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226277">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>With the 11th pick in the 2021 NFL draft </b><a name="15226280"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=beatrixkiddo"> beatrixkiddo </a>  :  4/19/2021  7:49 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226280">link</a>   </div></div><div class="thread_post_body">The NY Giants select....LBer Micah Parsons. <br/>
<br/>
Tough call for me, as I’m torn on Parsons and both the 2 Bama WRs but haven’t gotten to see what Andy thinks of them yet so I am going with Parsons. Think he will provide the best value and I think Graham will have a vision of using him all over, his skillset can really help bring this defense into one of the top defenses in the league. <br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I feel sick to my stomach... </b><a name="15226284"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=chopperhatch"> chopperhatch </a>  :  4/19/2021  7:50 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226284">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226275" target="_blank">15226275</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> but I fear it&#39;s going to be Paye.<br/>
<br/>
&#34;Mr. Almost&#34; </td>
                                </tr>
                           </tbody></table><br/>
<br/>
<br/>
You need to get out more. If a draft prodpect gets you that upset, maybe your priorities are out of whack.<br/>
<br/>
Also Paye is more than a fine prospect.</div></div><div class="thread_post"><div class="thread_post_header"><b>I think it’ll be Paye </b><a name="15226285"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=AcesUp"> AcesUp </a>  :  4/19/2021  7:51 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226285">link</a>   </div></div><div class="thread_post_body">Edge is the biggest need, he’s solid against the run, blue blood program, traits, year 1 starter. We have shown a willingness to start a run at our biggest position of need before as well. Also easy to justify kind of reaching here by saying you can hit your other needs later because of the depth at those positions. Not my choice but I have a feeling he’s the guy.</div></div><div class="thread_post"><div class="thread_post_header"><b>Slater </b><a name="15226288"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Ira"> Ira </a>  :  4/19/2021  7:57 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226288">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I think it’ll be Paye </b><a name="15226290"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=chopperhatch"> chopperhatch </a>  :  4/19/2021  7:58 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226290">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226285" target="_blank">15226285</a> AcesUp said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Edge is the biggest need, he’s solid against the run, blue blood program, traits, year 1 starter. We have shown a willingness to start a run at our biggest position of need before as well. Also easy to justify kind of reaching here by saying you can hit your other needs later because of the depth at those positions. Not my choice but I have a feeling he’s the guy. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
The 3 cone and other measurables along with his apparent feverish work ethic tells me he can learn some pass rush moves. The All 22 breakdown showed technique against the run that he had to learn in order to apply because they were against misdirection and O line schemes. Those are all very good selling points and if he becomes like the player he is compared to (Tuck) that is a great pick for us. Plus, Sy gave him an 85 grade.</div></div><div class="thread_post"><div class="thread_post_header"><b>DeVonta </b><a name="15226292"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Shady+Lurker"> Shady Lurker </a>  :  4/19/2021  7:59 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226292">link</a>   </div></div><div class="thread_post_body">Smith</div></div><div class="thread_post"><div class="thread_post_header"><b>Devonta </b><a name="15226296"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Johnny5"> Johnny5 </a>  :  4/19/2021  8:09 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226296">link</a>   </div></div><div class="thread_post_body">Smith</div></div><div class="thread_post"><div class="thread_post_header"><b>Jaylen Waddle </b><a name="15226300"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BCD"> BCD </a>  :  4/19/2021  8:12 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226300">link</a>   </div></div><div class="thread_post_body">best guy standing at 11 for the Giants needs .....he&#39;s take the top off the D and he&#39;ll run back punts with the giants not in fear of injury because of 3 vets at WR on the roster.</div></div><div class="thread_post"><div class="thread_post_header"><b>Smith </b><a name="15226303"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Peter+from+NH+%28formerly+CT%29"> Peter from NH (formerly CT) </a>  :  4/19/2021  8:17 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226303">link</a>   </div></div><div class="thread_post_body">he justs looks like a JJ guy at every level</div></div><div class="thread_post"><div class="thread_post_header"><b>This team simply isn&#39;t good enough </b><a name="15226308"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Bricktop"> Bricktop </a>  :  4/19/2021  8:20 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226308">link</a>   </div></div><div class="thread_post_body">to NOT have a guy make a noticeable impact come game time - even if it&#39;s a rookie.  To me, if Smith is there, he&#39;s the guy who is the most high leverage player who can make a quicker impact. Even if he just occupies space at times, runs pro routes, blocks on the perimeter and offers a threat to defenses, opening up opportunities for teammates.  I&#39;m fine with that contribution. <br/>
<br/>
Your top skill guys on O are Golladay, Jones and Saquon.  Kenny is a nice piece and SB is coming off a serious knee injury.  The jury is still out on Jones but my gut tells me he&#39;s got the gear to trend up. <br/>
<br/>
Add another weapon - a young, precise route runner who works hard on and off the field - solid pedigree under Saban - he&#39;s the odds on favorite for me. <br/>
<br/>
I&#39;m not drafting a 6&#39;3&#34; 305 pound guy from Northwestern at #11 to play Guard.  And Slater - imo - is a positional blocker who won&#39;t drive you off the ball.  He lacks the size, strength and base to dominate as a Tackle.  He opted out too.  That I don&#39;t like.  Great workouts, but I&#39;m not sold at all.  Draft a guy, change his position and hope he makes an impact on a seriously flawed team?  That&#39;s a no from me, dawg. I&#39;m not saying he&#39;s not going to be a good player in the league.  But not right now for this particular team. <br/>
<br/>
The highest G drafted over the last five years was Quinton Nelson (6&#39;5&#34; and 330) and Slater is NOT that dude. The next draft Guards were 25+ picks later since 2015.</div></div><div class="thread_post"><div class="thread_post_header"><b>Who I want: Parsons </b><a name="15226310"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Rjanyg"> Rjanyg </a>  :  4/19/2021  8:22 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226310">link</a>   </div></div><div class="thread_post_body">Who it might be? Smith, Paye, Ojulari<br/>
<br/>
My pick is Parsons</div></div><div class="thread_post"><div class="thread_post_header"><b>The Giants are ok with the medicals and select  </b><a name="15226311"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dang+Man"> Dang Man </a>  :  4/19/2021  8:24 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226311">link</a>   </div></div><div class="thread_post_body">Jaelen Phillips.</div></div><div class="thread_post"><div class="thread_post_header"><b>Trading down twice </b><a name="15226317"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Earl+the+goat"> Earl the goat </a>  :  4/19/2021  8:31 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226317">link</a>   </div></div><div class="thread_post_body">Once to NE to 15 getting their second rounder <br/>
Then to chicago at 20 getting their second rounder <br/>
<br/>
Giants take Vera Tucker at 20 <br/>
Their three second round picks are <br/>
Oweh or Ossai Edge <br/>
 Elijah Moore WR <br/>
Najee Harris RB <br/>
<br/>
<br/>
Not a bad haul for DG <br/>
Now I just woke up from dreaming</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="15226326"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=ryanmkeane"> ryanmkeane </a>  :  4/19/2021  8:49 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226326">link</a>   </div></div><div class="thread_post_body">DeVonta Smith</div></div><div class="thread_post"><div class="thread_post_header"><b>Paye  </b><a name="15226331"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dankbeerman"> Dankbeerman </a>  :  4/19/2021  8:56 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226331">link</a>   </div></div><div class="thread_post_body">at 11 followed by talk of how he was a top 5 player on their board.<br/>
<br/>
For the record I want Waddle and would be happy with Waddle/Smith/Surtain</div></div><div class="thread_post"><div class="thread_post_header"><b>Devonta Smith </b><a name="15226334"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Finch"> Finch </a>  :  4/19/2021  9:02 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226334">link</a>   </div></div><div class="thread_post_body">They said they want more weapons for Jones. I think they will grab whichever of Smith or Waddle is leftover. And every year teams fall in love for WRs with speed.  My guess is Waddle is gone and Smith will be the pick</div></div><div class="thread_post"><div class="thread_post_header"><b>DeVonta Smith, WR, Alabama </b><a name="15226337"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=MadPlaid"> MadPlaid </a>  :  4/19/2021  9:07 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226337">link</a>   </div></div><div class="thread_post_body">If he is not there, and Slater is, then Slater.  If neither are there, I hope for a trade down if possible.  I don&#39;t want them reaching for someone because he fits a need.  That to me is the worst case scenario.</div></div><div class="thread_post"><div class="thread_post_header"><b>Paye </b><a name="15226338"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=j_rud"> j_rud </a>  :  4/19/2021  9:11 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226338">link</a>   </div></div><div class="thread_post_body">Size, athleticism, versatility, and character/personality, he just seems like a Judge guy. <br/>
<br/>
I think they&#39;d take Smith if he were there and I personally would prefer Parsons. Think both will be gone though, and Paye isn&#39;t an awful consolation.</div></div><div class="thread_post"><div class="thread_post_header"><b>Smith </b><a name="15226339"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Svengali"> Svengali </a>  :  4/19/2021  9:13 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226339">link</a>   </div></div><div class="thread_post_body">BPA.....</div></div><div class="thread_post"><div class="thread_post_header"><b>Ojulari  </b><a name="15226344"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Breeze_94"> Breeze_94 </a>  :  4/19/2021  9:20 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226344">link</a>   </div></div><div class="thread_post_body">I’m predicting Azeez after a trade down with...Vegas.<br/>
<br/>
They jump LAC and MIN to take Oline.</div></div><div class="thread_post"><div class="thread_post_header"><b>Smith </b><a name="15226345"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=JerseyCityJoe"> JerseyCityJoe </a>  :  4/19/2021  9:21 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226345">link</a>   </div></div><div class="thread_post_body">Although I would rather have Parsons.</div></div><div class="thread_post"><div class="thread_post_header"><b>Slater </b><a name="15226359"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=CT+Charlie"> CT Charlie </a>  :  4/19/2021  9:44 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226359">link</a>   </div></div><div class="thread_post_body">The more competition, the better. Plus, Hernandez may want to walk, though I think he&#39;ll play hard for the money this year.</div></div><div class="thread_post"><div class="thread_post_header"><b>Smith or Waddle if there are there.  </b><a name="15226364"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=blueblood"> blueblood </a>  :  4/19/2021  9:46 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226364">link</a>   </div></div><div class="thread_post_body">My preference is Waddle.</div></div><div class="thread_post"><div class="thread_post_header"><b>any of the above mentioned but Ojulari </b><a name="15226365"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=gtt350"> gtt350 </a>  :  4/19/2021  9:48 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226365">link</a>   </div></div><div class="thread_post_body">I just don&#39;t see it, not impressed</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I feel sick to my stomach... </b><a name="15226368"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Bill+L"> Bill L </a>  :  4/19/2021  9:51 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226368">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226284" target="_blank">15226284</a> chopperhatch said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15226275 bw in dc said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     but I fear it&#39;s going to be Paye.<br/>
<br/>
&#34;Mr. Almost&#34; <br/>
                                <br/>
                           <br/>
<br/>
<br/>
You need to get out more. If a draft prodpect gets you that upset, maybe your priorities are out of whack.<br/>
<br/>
Also Paye is more than a fine prospect. </td>
                                </tr>
                           </tbody></table> Sure, if we were picking in the twenties.</div></div><div class="thread_post"><div class="thread_post_header"><b>. </b><a name="15226371"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Go+Terps"> Go Terps </a>  :  4/19/2021  9:55 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226371">link</a>   </div></div><div class="thread_post_body">Want: Surtain or Smith<br/>
<br/>
Expect: Paye</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: . </b><a name="15226372"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Bill+L"> Bill L </a>  :  4/19/2021  9:56 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226372">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226371" target="_blank">15226371</a> Go Terps said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Want: Surtain or Smith<br/>
<br/>
Expect: Paye </td>
                                </tr>
                           </tbody></table><br/>
I can’t believe I’m with you and be in abject pessimism.</div></div><div class="thread_post"><div class="thread_post_header"><b>. </b><a name="15226376"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Go+Terps"> Go Terps </a>  :  4/19/2021  10:00 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226376">link</a>   </div></div><div class="thread_post_body">I don&#39;t know enough to say Paye would be a bad pick. This isn&#39;t me expecting the worst. <br/>
<br/>
The only thing that could really piss me off is if for some reason Lance is there at 11 and we pass.</div></div><div class="thread_post"><div class="thread_post_header"><b>Paye isn’t my first choice.. </b><a name="15226379"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Sean"> Sean </a>  :  4/19/2021  10:02 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226379">link</a>   </div></div><div class="thread_post_body">but, I just get the sense he’ll be the pick. I’d like the pick a lot more if they dropped down a few spots, selected Paye and netted some more mid round picks.</div></div><div class="thread_post"><div class="thread_post_header"><b>Smith cause he will take over games .... </b><a name="15226380"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Manny+in+CA"> Manny in CA </a>  :  4/19/2021  10:07 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226380">link</a>   </div></div><div class="thread_post_body"><br/>
From the slot; just like Steve Sarkasian had him doing it at Alabama.<br/>
<br/>
If he&#39;s gone, gotta go with Kwity Paye; gotta catch those mangy QBs that got away last year.</div></div><div class="thread_post"><div class="thread_post_header"><b>I think it&#39;s Waddle or Smith with the 11th overall pick... </b><a name="15226383"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Milton"> Milton </a>  :  4/19/2021  10:08 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226383">link</a>   </div></div><div class="thread_post_body">I&#39;m just not sure it&#39;s the Giants or the Bengals, Dolphins, or Lions making the selection.</div></div><div class="thread_post"><div class="thread_post_header"><b>just can&#39;t see the Giants selecting offense with  </b><a name="15226387"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Rory"> Rory </a>  :  4/19/2021  10:17 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226387">link</a>   </div></div><div class="thread_post_body">their #1 4 years in a row. <br/>
<br/>
Kwity Paye just passes the eye test, 270lb great speed and is a force on the outside so he is the pick at 11 (no trade down).</div></div><div class="thread_post"><div class="thread_post_header"><b>Mac  </b><a name="15226388"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Chocco"> Chocco </a>  :  4/19/2021  10:18 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226388">link</a>   </div></div><div class="thread_post_body">Jones</div></div><div class="thread_post"><div class="thread_post_header"><b>Smith </b><a name="15226392"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=redwhiteandbigblue"> redwhiteandbigblue </a>  :  4/19/2021  10:25 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226392">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>Kwity Paye </b><a name="15226394"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=PatersonPlank"> PatersonPlank </a>  :  4/19/2021  10:26 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226394">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>At #11 the NYG pick  </b><a name="15226402"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gmanfandan"> Gmanfandan </a>  :  4/19/2021  10:33 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226402">link</a>   </div></div><div class="thread_post_body">Jaycee Horn (tho I wouldnt mind Parsons, Smith or Sewell - I think Sewell is gone I think Smith and Parsons are there - and I think Horn is a terrific pick and a main stay in the secondary for years to come) <br/>
<br/>
I also think it IS going to be the pick</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Paye isn’t my first choice.. </b><a name="15226403"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Go+Terps"> Go Terps </a>  :  4/19/2021  10:33 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226403">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226379" target="_blank">15226379</a> Sean said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> but, I just get the sense he’ll be the pick. I’d like the pick a lot more if they dropped down a few spots, selected Paye and netted some more mid round picks. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I&#39;d really like if they traded down and took Horn, though it sounds like Horn may be moving up.</div></div><div class="thread_post"><div class="thread_post_header"><b>I think it will be Paye or Slater </b><a name="15226404"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Osi+Osi+Osi+OyOyOy"> Osi Osi Osi OyOyOy </a>  :  4/19/2021  10:40 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226404">link</a>   </div></div><div class="thread_post_body">I want Devonta Smith but the closer we get to the draft, the less likely I feel like the Giants go WR.<br/>
<br/>
I’m not the biggest Paye fan but I wouldn’t mind him as the pick.</div></div><div class="thread_post"><div class="thread_post_header"><b>My pick </b><a name="15226406"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Reale01"> Reale01 </a>  :  4/19/2021  10:42 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226406">link</a>   </div></div><div class="thread_post_body">Smith or Slater, Smith if both are there<br/>
If neither are there then someone has dropped<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>Waddle </b><a name="15226409"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=GFAN52"> GFAN52 </a>  :  4/19/2021  10:47 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226409">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>Rashawn Slater </b><a name="15226411"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=compton"> compton </a>  :  4/19/2021  10:48 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226411">link</a>   </div></div><div class="thread_post_body">is the pick at 11.</div></div><div class="thread_post"><div class="thread_post_header"><b>I’m hoping we go.... </b><a name="15226413"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UticaMike"> UticaMike </a>  :  4/19/2021  10:48 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226413">link</a>   </div></div><div class="thread_post_body">1. Slater<br/>
2. Toney<br/>
3. Best pass rusher available <br/>
<br/>
The O-Line must be addressed first. We need to put DJ in the best position possible for success. Peart is not a sure thing. Same with Solder at swing tackle. People seem to keep throwing the “we could do a lot worse at swing tackle” line around when discussing Solder. He was a turnstile the last we saw of him. He’s older and hasn’t played an NFL snap in quite a while. The fact that he may no longer start won’t soothe me if he gets DJ killed. We can’t even guarantee Hernandez assumes a starting guard spot, and the thought of the kid we just picked up from the Texans starting scares me. Slater in Round 1z <br/>
Toney would be a great find in Round 2. <br/>
The Giants were able generate pressure last year by committee, and with a great year by LW. We’re getting Carter and Ximines back from injury. No reason to think we can’t continue to progress in that area from within. Edge Rusher can wait until Round 3.</div></div><div class="thread_post"><div class="thread_post_header"><b>Who do I want: Smith or Parsons </b><a name="15226416"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=GiantsLaw"> GiantsLaw </a>  :  4/19/2021  10:52 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226416">link</a>   </div></div><div class="thread_post_body">Who do I think: Paye</div></div><div class="thread_post"><div class="thread_post_header"><b>Clearly going to be a receiver  </b><a name="15226418"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Jimmy+Googs"> Jimmy Googs </a>  :  4/19/2021  10:54 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226418">link</a>   </div></div><div class="thread_post_body">so either Smith or Waddle.  Pitts will be gone.</div></div><div class="thread_post"><div class="thread_post_header"><b>LB... </b><a name="15226419"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Brown_Hornet"> Brown_Hornet </a>  :  4/19/2021  10:54 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226419">link</a>   </div></div><div class="thread_post_body">...Parsons.<br/>
<br/>
Gettleman and Judge will recognize the this guy, more than any other prospect at 11, had the ability to affect the outcome.<br/>
#11, IMV represents the greatest opportunity to add a special player.</div></div><div class="thread_post"><div class="thread_post_header"><b>Micah </b><a name="15226421"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=No+Where+Man"> No Where Man </a>  :  4/19/2021  10:58 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226421">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>Devonta Smith </b><a name="15226423"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=AdamBrag"> AdamBrag </a>  :  4/19/2021  11:01 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226423">link</a>   </div></div><div class="thread_post_body">Makes too much sense not too happen</div></div><div class="thread_post"><div class="thread_post_header"><b>Smith, then Surtain then Slater </b><a name="15226425"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=sb+from+NYT+Forum"> sb from NYT Forum </a>  :  4/19/2021  11:13 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226425">link</a>   </div></div><div class="thread_post_body">...then Waddle I guess, but his ankle full of screws scares me.</div></div><div class="thread_post"><div class="thread_post_header"><b>Unless this regime has changed its stripes, I&#39;m afraid it&#39;s </b><a name="15226426"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=CMc+in+342"> CMc in 342 </a>  :  4/19/2021  11:16 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226426">link</a>   </div></div><div class="thread_post_body">Ojulari without a trade down at #11.  They&#39;ve had their eyes on him since last year with Crowder. The only solace is that the pick isn&#39;t Paye who is an undersized tweener at a little over 6&#39;2&#34; and 261 lbs.<br/><a href="https://www.detroitnews.com/story/sports/college/university-michigan/2021/03/26/defensive-end-kwity-paye-produces-knockout-numbers-michigan-pro-day/7013240002/"> Paye is 6&#39;2&#34; 261 lbs. </a> - (<a href="https://www.detroitnews.com/story/sports/college/university-michigan/2021/03/26/defensive-end-kwity-paye-produces-knockout-numbers-michigan-pro-day/7013240002/" target="_NEW"> New Window </a>)</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Devonta Smith </b><a name="15226435"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Rory"> Rory </a>  :  4/19/2021  11:47 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226435">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226423" target="_blank">15226423</a> AdamBrag said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Makes too much sense not too happen </td>
                                </tr>
                           </tbody></table><br/>
<br/>
If you take Smith then Slayton never develops further.</div></div><div class="thread_post"><div class="thread_post_header"><b>My best guess would be that the Giants take </b><a name="15226437"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=SirYesSir"> SirYesSir </a>  : 12:11 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226437">link</a>   </div></div><div class="thread_post_body">Jaycee Horn<br/>
<br/>
I&#39;m assuming Surtain will be gone to Dallas.  I know the wr&#39;s and o lineman are tempting, but I think they&#39;ll view these two corners as equal or better prospects at a more valuable position.  It&#39;s a deep draft at those two positions.<br/>
<br/>
Trade down?  I wouldn&#39;t rule it out, but I&#39;m not expecting it to happen.  If they want an edge, I doubt they&#39;d trade back and risk losing him...I&#39;m sure they don&#39;t have all those guys with question marks ranked equally.</div></div><div class="thread_post"><div class="thread_post_header"><b>I have absolutely no idea who the Giants will pick. </b><a name="15226438"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=TC"> TC </a>  : 12:13 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226438">link</a>   </div></div><div class="thread_post_body">My past assumptions have demonstrated the futility of such predictions.<br/>
<br/>
But my top 3 preferences in order are: Pitts, Smith or Paye. (AKA, Pootie Tang) Pitts and Smith likely both gone by #11. And while #11 might be a little early for Paye, and though his floor might not be as high as some edges, MY GAWD, the ceiling! <br/>
<br/>
I wouldn&#39;t cry if Sewell was surprisingly still around at #11 either. In fact, I&#39;d dance a jig. Lots of other decent prospects as well.<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Devonta Smith </b><a name="15226440"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=SirYesSir"> SirYesSir </a>  : 12:16 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226440">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226435" target="_blank">15226435</a> Rory said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15226423 AdamBrag said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Makes too much sense not too happen <br/>
                                <br/>
                           <br/>
<br/>
If you take Smith then Slayton never develops further. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
<br/>
You don&#39;t alter your draft strategy over Slaton, a 5th rounder who had a good rookie year.  If he&#39;s good enough to get on the field, he can develop.  He&#39;s a third-year player now</div></div><div class="thread_post"><div class="thread_post_header"><b>DeVonta Smith </b><a name="15226441"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=tyrik13"> tyrik13 </a>  : 12:22 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226441">link</a>   </div></div><div class="thread_post_body">Aka the Slim Reaper!!</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Devonta Smith </b><a name="15226442"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=tyrik13"> tyrik13 </a>  : 12:24 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226442">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226435" target="_blank">15226435</a> Rory said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15226423 AdamBrag said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Makes too much sense not too happen <br/>
                                <br/>
                           <br/>
<br/>
If you take Smith then Slayton never develops further. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
If you think Shep, Slayton and Ross will prevent them from drafting Smith if he’s there you’ve got a lot to learn about football my friend.</div></div><div class="thread_post"><div class="thread_post_header"><b>Edge- Kwity Paye - at number 11 </b><a name="15226445"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=giantstock"> giantstock </a>  : 12:41 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226445">link</a>   </div></div><div class="thread_post_body">IMO The Giants love high floor guys vs going for “more juice.” The Giants prefer the dependable guy rather than going for that extra juice. And he’ll be a very good run stopper and over the years develop more as a pass rusher. This is the Giants style. A safe pick.<br/>
<br/>
Albeit for me just another example of another underwhelming pick at 11. The 2 WR&#39;s and Slater “have more juice” imo. But Giants will look at these guys as too much risk – <br/>
<br/>
IMO they look at some of the others as --  Slater is not a hog mollie and Smith is too slight and Waddle is small with injury concerns. I might even like Surtain over Paye but haven’t thought about that too much. And Parsons seems to have some bad behind the scenes inuendo. Giants don’t go for that.   <br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Trading down twice </b><a name="15226446"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=giantstock"> giantstock </a>  : 12:49 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226446">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226317" target="_blank">15226317</a> Earl the goat said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Once to NE to 15 getting their second rounder <br/>
Then to chicago at 20 getting their second rounder <br/>
<br/>
Giants take Vera Tucker at 20 <br/>
Their three second round picks are <br/>
Oweh or Ossai Edge <br/>
 Elijah Moore WR <br/>
Najee Harris RB <br/>
<br/>
<br/>
Not a bad haul for DG <br/>
Now I just woke up from dreaming </td>
                                </tr>
                           </tbody></table><br/>
<br/>
For the fun of it-- I went on PFN and was determined to trade down waiting for trade proposals (not doing any. The only thing I did was offer counters if I felt the need.) , wound up with. I lost a 3rd or 4th rd pick in 2022.  <br/>
<br/>
40, 42, 53, 61, 63, 71, 76, 85, 136, 166, 170, and 196.</div></div><div class="thread_post"><div class="thread_post_header"><b>Parsons </b><a name="15226448"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=uconngiant"> uconngiant </a>  : 12:51 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226448">link</a>   </div></div><div class="thread_post_body">That is who I want but think it will be Waddle or Smith</div></div><div class="thread_post"><div class="thread_post_header"><b>WR. Jaylen Waddle </b><a name="15226450"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=90.Cal"> 90.Cal </a>  : 2:14 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226450">link</a>   </div></div><div class="thread_post_body">... because we miss out on Devonta Smith.</div></div><div class="thread_post"><div class="thread_post_header"><b>Parsons </b><a name="15226452"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=OC2.0"> OC2.0 </a>  : 2:43 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226452">link</a>   </div></div><div class="thread_post_body">D goes from pretty good to outstanding</div></div><div class="thread_post"><div class="thread_post_header"><b>Edge </b><a name="15226463"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=pa_giant_fan"> pa_giant_fan </a>  : 5:59 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226463">link</a>   </div></div><div class="thread_post_body">Paye</div></div><div class="thread_post"><div class="thread_post_header"><b>Slater </b><a name="15226467"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Rick+in+Dallas"> Rick in Dallas </a>  : 6:15 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226467">link</a>   </div></div><div class="thread_post_body">Very versatile and I think he starts the year at RT.Which BTW has an immediate impact on the offense.</div></div><div class="thread_post"><div class="thread_post_header"><b>Smith </b><a name="15226479"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bob_in_ec"> bob_in_ec </a>  : 7:02 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226479">link</a>   </div></div><div class="thread_post_body">WR Smith speed kills</div></div><div class="thread_post"><div class="thread_post_header"><b>Mara said they need playmakers.  </b><a name="15226483"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=johnnyb"> johnnyb </a>  : 7:10 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226483">link</a>   </div></div><div class="thread_post_body">The Giants draft DeVonta Smith.</div></div><div class="thread_post"><div class="thread_post_header"><b>Edge, Oweh </b><a name="15226501"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Clearwater+Joe"> Clearwater Joe </a>  : 7:41 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226501">link</a>   </div></div><div class="thread_post_body">just because it is the Giants way</div></div><div class="thread_post"><div class="thread_post_header"><b>WR Devonta Smith </b><a name="15226507"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=gary_from_chester"> gary_from_chester </a>  : 7:49 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226507">link</a>   </div></div><div class="thread_post_body">He will be a GREAT pro</div></div><div class="thread_post"><div class="thread_post_header"><b>Gettleman </b><a name="15226519"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Bones"> Bones </a>  : 8:02 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226519">link</a>   </div></div><div class="thread_post_body">Never trades down, until this year that is.  They take Paye at 18.  Even if he does not become a great pass rusher (which I think he can be) his floor is a great run defender.  Because of the trade down, they can get receiver and WR in second round.</div></div><div class="thread_post"><div class="thread_post_header"><b>Smith or Slater </b><a name="15226535"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=mavric"> mavric </a>  : 8:34 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226535">link</a>   </div></div><div class="thread_post_body">I personally prefer Slater, but my gut tells me the Giants would go for <span class="bold"><span class="underline">Smith</span></span></div></div><div class="thread_post"><div class="thread_post_header"><b>Waddle... </b><a name="15226540"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=KingBlue"> KingBlue </a>  : 8:37 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226540">link</a>   </div></div><div class="thread_post_body">We get lucky and Waddle drops... we run to the podium.</div></div><div class="thread_post"><div class="thread_post_header"><b>I pick Parsons </b><a name="15226545"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=JonC"> JonC </a>  : 8:46 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226545">link</a>   </div></div><div class="thread_post_body">Giants pick Paye</div></div><div class="thread_post"><div class="thread_post_header"><b>Ha! </b><a name="15226549"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=fkap"> fkap </a>  : 8:49 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226549">link</a>   </div></div><div class="thread_post_body">I was just about to delegate my vote to JonC, so...<br/>
<br/>
Paye it is<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I pick Parsons </b><a name="15226550"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Klaatu"> Klaatu </a>  : 8:49 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226550">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226545" target="_blank">15226545</a> JonC said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Giants pick Paye </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Ditto.</div></div><div class="thread_post"><div class="thread_post_header"><b>Two weeks to go </b><a name="15226553"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=JonC"> JonC </a>  : 8:52 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226553">link</a>   </div></div><div class="thread_post_body">let&#39;s see if what info gets out.</div></div><div class="thread_post"><div class="thread_post_header"><b>I&#39;ve heard DG </b><a name="15226563"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=fkap"> fkap </a>  : 8:59 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226563">link</a>   </div></div><div class="thread_post_body">picks based on what would upset bw, so that&#39;s another reason it&#39;ll be Paye.<br/>
<br/>
In fact, put me down as we trade, maybe even twice, up to pick him.</div></div><div class="thread_post"><div class="thread_post_header"><b>If the Giants really want to pick an Edge player why not trade down? </b><a name="15226564"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Rick+in+Dallas"> Rick in Dallas </a>  : 8:59 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226564">link</a>   </div></div><div class="thread_post_body">I just don&#39;t see the value at 11 but that&#39;s just my opinion.I want the Giants to pick Slater but all we heard about was the team getting playmakers for the offense.<br/>
If Smith or Waddle are available they probably pick one of them.</div></div><div class="thread_post"><div class="thread_post_header"><b>I say Devonta Smith at 11 </b><a name="15226568"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=cosmicj"> cosmicj </a>  : 9:03 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226568">link</a>   </div></div><div class="thread_post_body">But I think there is a fair chance the rumors of a trade down with the Patriots has some basis and that will happen if a short group of players are off the board.  That’s when I think Paye or Phillips would be selected, not at 11.<br/>
<br/>
You anti-Paye posters, how do you feel about him at 15?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: The Giants are ok with the medicals and select  </b><a name="15226574"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dr.+D"> Dr. D </a>  : 9:06 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226574">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226311" target="_blank">15226311</a> Dang Man said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Jaelen Phillips. </td>
                                </tr>
                           </tbody></table><br/>
I don&#39;t know how they could possibly be ok with the medicals. How exactly could they be ok with multiple concussions and the fact that he already quit football once? By crossing their fingers? Maybe if he slid, but not at 11.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: WR. Jaylen Waddle </b><a name="15226582"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gfan+in+PA"> Gfan in PA </a>  : 9:10 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226582">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226450" target="_blank">15226450</a> 90.Cal said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> ... because we miss out on Devonta Smith. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I&#39;m with 90 Cal here.  Waddle as the last player in their top row that falls.</div></div><div class="thread_post"><div class="thread_post_header"><b>Slater </b><a name="15226593"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Giantophile"> Giantophile </a>  : 9:21 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226593">link</a>   </div></div><div class="thread_post_body">is my guess.</div></div><div class="thread_post"><div class="thread_post_header"><b>Waddle becomes their choice after Pitts, Chase and Smith </b><a name="15226603"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=NYGgolfer"> NYGgolfer </a>  : 9:31 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226603">link</a>   </div></div><div class="thread_post_body">all find homes before #11.</div></div><div class="thread_post"><div class="thread_post_header"><b>DaVonta Smith </b><a name="15226627"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=trueblueinpw"> trueblueinpw </a>  : 9:42 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226627">link</a>   </div></div><div class="thread_post_body">Rashawn Slater goes to Dallas and that makes Smith our guy at 11. <br/>
<br/>
Bonus soothsaying: Smith proves to be the only Getty Giants pick to get a gold jacket.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I say Devonta Smith at 11 </b><a name="15226630"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Bill+L"> Bill L </a>  : 9:43 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226630">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226568" target="_blank">15226568</a> cosmicj said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> But I think there is a fair chance the rumors of a trade down with the Patriots has some basis and that will happen if a short group of players are off the board.  That’s when I think Paye or Phillips would be selected, not at 11.<br/>
<br/>
You anti-Paye posters, how do you feel about him at 15? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Better, but I still think you can parlay 15 into the early twenties and get a Paye or several equivalents.</div></div><div class="thread_post"><div class="thread_post_header"><b>Thinking Paye </b><a name="15226641"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bc4life"> bc4life </a>  : 9:48 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226641">link</a>   </div></div><div class="thread_post_body">but there are other decent options at edge in R2.  <br/>
<br/>
If  it&#39;s not Paye - I&#39;m thinking Smith.<br/>
<br/>
I&#39;d be okay with either but am concerned about Smith&#39;s size</div></div><div class="thread_post"><div class="thread_post_header"><b>wondering if the Parsons&#39; concerns </b><a name="15226646"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bc4life"> bc4life </a>  : 9:51 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226646">link</a>   </div></div><div class="thread_post_body">are smoke</div></div><div class="thread_post"><div class="thread_post_header"><b>Smith </b><a name="15226655"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eman11"> Eman11 </a>  : 9:58 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226655">link</a>   </div></div><div class="thread_post_body">If he’s there I think the Giants run up to the podium (virtual) and take him.<br/>
<br/>
If he’s gone and Waddle is there, I think they take him. If they’re both gone I don’t have a pick, as I could go a few different ways. <br/>
<br/>
Either way I see them getting a quality step in and help player at 11. Just a matter of how many QBs go in the top ten and seeing more quality top guys drop because of it.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I think it will be Paye or Slater </b><a name="15226685"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Old+Blue"> Old Blue </a>  : 10:14 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226685">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226404" target="_blank">15226404</a> Osi Osi Osi OyOyOy said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I want Devonta Smith but the closer we get to the draft, the less likely I feel like the Giants go WR.<br/>
<br/>
I’m not the biggest Paye fan but I wouldn’t mind him as the pick. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Slater before all the shiny offensive guys.</div></div><div class="thread_post"><div class="thread_post_header"><b>Parsons </b><a name="15226686"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Spider+in+Warwick"> Spider in Warwick </a>  : 10:14 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226686">link</a>   </div></div><div class="thread_post_body">There is no one else like him in the draft. <br/>
Then the Giants can look at Kadarius Toney in the 2nd round, or one of the OL like Dickerson, provided health issues check out.</div></div><div class="thread_post"><div class="thread_post_header"><b>I think the Giants trade up for Pitts if he makes it past 6. </b><a name="15226688"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Britt+in+VA"> Britt in VA </a>  : 10:17 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226688">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>If Smith is there </b><a name="15226715"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=JohnF"> JohnF </a>  : 10:37 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226715">link</a>   </div></div><div class="thread_post_body">He&#39;s the pick, though I think both Alabama WR&#39;s will be gone. If that&#39;s the case, then Parsons.</div></div><div class="thread_post"><div class="thread_post_header"><b>Presumption </b><a name="15226716"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=RetroJint"> RetroJint </a>  : 10:37 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226716">link</a>   </div></div><div class="thread_post_body">DeVonta Smith is taken .  I will go with Allijah Vera-Tucker.  I don’t want Pitts , who has a few of the same problems that have befallen Engram, but I am resigned to the fact that they would draft him at 11, if available .   I red flag Waddle out of the first two rounds .</div></div><div class="thread_post"><div class="thread_post_header"><b>Gut feeling Paye </b><a name="15226741"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bigbluehoya"> bigbluehoya </a>  : 10:55 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226741">link</a>   </div></div><div class="thread_post_body">My 2 preferences - Parsons if defense, Smith if offense. (in my mind, same &#34;tier&#34;)<br/>
<br/>
I&#39;m about as novice as novice gets, but all of the true edge players seem like a need-based reach at 11. <br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>I think Devonta Smith will be the pick  </b><a name="15226743"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Chris684"> Chris684 </a>  : 10:55 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226743">link</a>   </div></div><div class="thread_post_body">unless Surtain is there.<br/>
<br/>
It seems to me that a premium is placed on CB/secondary in this defense above even the typical emphasis placed on the position league-wide. However, it&#39;s mostly likely Surtain is gone and we snatch a Heisman winning playmaker to further supplement the offense.<br/>
<br/>
Judge strikes me as a guy who also really likes to work his relationships, just look at the staff he&#39;s built and last year&#39;s draft class. I believe the other round 1 options are Waddle, Parsons and Ojulari.</div></div><div class="thread_post"><div class="thread_post_header"><b>Slater </b><a name="15226772"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Sec+103"> Sec 103 </a>  : 11:17 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226772">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>WR DeVonta Smith </b><a name="15226775"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=illmatic"> illmatic </a>  : 11:21 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226775">link</a>   </div></div><div class="thread_post_body">if he’s available. He doesn’t come with the injury issue that Waddle has otherwise it would be more of a toss up I think. He’s a superb route runner with great speed and amazing hands and would be another great weapon for Jones. It’s about continuing to help DJ and I feel like he’s a premier playmaker, more so than guys like Slater would be. The WR unit still needs the help too because it Golladay goes down, what are they left with? A unit similar to last year and they would be completely screwed. They’re dying for more quality depth there. He provides that. I think his floor is as a good NFL WR. At his ceiling, if his size isn’t an issue, he can be one of the best WR in the league.</div></div><div class="thread_post"><div class="thread_post_header"><b>Paye </b><a name="15226793"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Thegratefulhead"> Thegratefulhead </a>  : 11:32 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226793">link</a>   </div></div><div class="thread_post_body">Will be picked because he the only one that makes me want to throw up if picked at 11. We need someone that can actually sack the QB.  He couldn&#39;t do that in college, I cannot project it to his pro game.  We already do well against the run.  The game has changed folks.  You have to get to the passer.<br/>
<br/>
Yeah, I&#39;m bitter about the draft.<br/>
<br/>
I want one of pass catcher or Parsons.  I would be happy with one of the corner and accept a lineman.<br/>
<br/>
Paye is hot garbage.</div></div><div class="thread_post"><div class="thread_post_header"><b>Waddle or Smith </b><a name="15226800"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=armstead98"> armstead98 </a>  : 11:37 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226800">link</a>   </div></div><div class="thread_post_body">Would have said Waddle yesterday since I thought he&#39;d be the one available but given the Waddle thread/rumors it sounds like Smith might be the one there.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Paye </b><a name="15226803"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Bill+L"> Bill L </a>  : 11:38 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226803">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226793" target="_blank">15226793</a> Thegratefulhead said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Will be picked because he the only one that makes me want to throw up if picked at 11. We need someone that can actually sack the QB.  He couldn&#39;t do that in college, I cannot project it to his pro game.  We already do well against the run.  The game has changed folks.  You have to get to the passer.<br/>
<br/>
Yeah, I&#39;m bitter about the draft.<br/>
<br/>
I want one of pass catcher or Parsons.  I would be happy with one of the corner and accept a lineman.<br/>
<br/>
Paye is hot garbage. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I don&#39;t know about that.  But, I don&#39;t want him (at 11) because he&#39;s not special. But, we can have him or any of his equivalent edges *plus* several picks if we employ a smart strategy.</div></div><div class="thread_post"><div class="thread_post_header"><b>at 11 my pick is that they trade down  </b><a name="15226804"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  : 11:40 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226804">link</a>   </div></div><div class="thread_post_body">I think there are teams that will be looking to trade up (especially if a QB falls) and I think the NYG will have a bunch of players stacked similarly on their board. It was well known they tried to trade down last year and found no takers (Detroit too). This year I think it actually happens because as we have already seen there are a bunch of teams looking to maneuver.</div></div><div class="thread_post"><div class="thread_post_header"><b>I want Slater. </b><a name="15226812"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=shockeyisthebest8056"> shockeyisthebest8056 </a>  : 11:44 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226812">link</a>   </div></div><div class="thread_post_body">They need to put talent at right guard instead of depending on Hernandez or the guy they signed from Houston. Slater could also be a future RT option in case the Matt Peart move doesn’t go as well as they hope.<br/>
<br/>
I don’t think the Giants need a receiver, but I’d go with Waddle if Slater isn’t available because I think he’s the BPA. I don’t like Micah Parsons and I don’t trust Devonta Smith to stay healthy or to be an elite professional receiver. (Maybe I’ll be wrong on both guys.)<br/>
<br/>
After that, my favorite players are JOK, Zaven Collins, and Jaelan Phillips.</div></div><div class="thread_post"><div class="thread_post_header"><b>Jaylen Waddle </b><a name="15226822"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BlueVinnie"> BlueVinnie </a>  : 11:51 am   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226822">link</a>   </div></div><div class="thread_post_body">None of the cast of characters we see going to the Giants at #11 in mock drafts thrill me and that includes Waddle.<br/>
<br/>
I choose Waddle because he has the best chance to be a true impact player vs. the likes of D. Smith, Paye and Slater. In addition, despite the presence of Golliday, WR is still a need.  I can&#39;t see Devonte Smith becoming a force in the NFL.  I can&#39;t get past the physical stature.</div></div><div class="thread_post"><div class="thread_post_header"><b>Giants trade down with NE </b><a name="15226888"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=George"> George </a>  : 12:19 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226888">link</a>   </div></div><div class="thread_post_body">Pick Paye at 15.<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Paye </b><a name="15226911"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  : 12:29 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226911">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226793" target="_blank">15226793</a> Thegratefulhead said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Will be picked because he the only one that makes me want to throw up if picked at 11. We need someone that can actually sack the QB.  He couldn&#39;t do that in college, I cannot project it to his pro game.  We already do well against the run.  The game has changed folks.  You have to get to the passer.<br/>
<br/>
Yeah, I&#39;m bitter about the draft.<br/>
<br/>
I want one of pass catcher or Parsons.  I would be happy with one of the corner and accept a lineman.<br/>
<br/>
Paye is hot garbage. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
LOL. I&#39;m riding right there with you. <br/>
<br/>
If I hear - &#34;With the 11th pick in the 2021 NFL draft, the New York Football Giants select...Kwity Paye, DE, Michigan...&#34; -  I&#39;m standing up, stepping into the pocket and hitting the wall in stride with my remote...</div></div><div class="thread_post"><div class="thread_post_header"><b>WR DeVonta Smith </b><a name="15226914"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=gidiefor"> gidiefor </a> : <b style="background:darkred;color:white;">Mod</b> : 12:30 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226914">link</a>   </div></div><div class="thread_post_body">Giving Danny Boy the tools NoW!</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Paye </b><a name="15226969"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Thegratefulhead"> Thegratefulhead </a>  : 12:56 pm   : <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226969">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=608126&amp;show_all=1#15226911" target="_blank">15226911</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15226793 Thegratefulhead said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Will be picked because he the only one that makes me want to throw up if picked at 11. We need someone that can actually sack the QB.  He couldn&#39;t do that in college, I cannot project it to his pro game.  We already do well against the run.  The game has changed folks.  You have to get to the passer.<br/>
<br/>
Yeah, I&#39;m bitter about the draft.<br/>
<br/>
I want one of pass catcher or Parsons.  I would be happy with one of the corner and accept a lineman.<br/>
<br/>
Paye is hot garbage. <br/>
                                <br/>
                           <br/>
<br/>
LOL. I&#39;m riding right there with you. <br/>
<br/>
If I hear - &#34;With the 11th pick in the 2021 NFL draft, the New York Football Giants select...Kwity Paye, DE, Michigan...&#34; -  I&#39;m standing up, stepping into the pocket and hitting the wall in stride with my remote... </td>
                                </tr>
                           </tbody></table>I just heard the commissioner in my head when I read that and I threw up a little in my mouth...</div></div><a name="END"></a><a href="index.php"></a><div style="padding-top:25px; padding-bottom:20px;"><a href="index.php"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"/></a></div></div>
<div class="thread_sidebar_2">

<!-- Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-102">
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Corner Forum - Lower 300x250 -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1566320450447229" data-ad-slot="4189314539" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->

</div>

</div>




<div class="footer">


<p style="width:400px;float:left;"><b>Part of the USA Today Sports Media Group</b><br/>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</p>
<p style="width:400px;float:right; text-align:right;">
All contents (unless otherwise specified) copyright ©  1995 - 2020<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br/>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Solutions</a>
</p>
<br clear="all"/>
<div style="float:right;">
<script src="https://sucuri.net/monitoring/badge.js" data-s="19" id="sucuri-s" data-i="7b1b29ae50ae6574f2af3875935246e4fa8a805b26" data-p="o" -="" position="" -="" l(left)="" or="" r(right)="" or="" o(relative)="" data-c="l" data-t="t"></script>
</div>

</div>


<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->



<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolisz.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=194-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=0&cb=3', false, ['/detroitchicago/minneapolisz.js'], true, false, true, false);</script></body></html>