<!DOCTYPE html><html lang="en"><head><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-0&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-0&cb=3', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-0&cb=5', false, [], true, false, true, false);</script>
<title>Sam Beal pleads guilty to gun related charges | Big Blue Interactive </title>

<meta http-equiv="Pragma" content="no-cache"/>
<meta http-equiv="Expires" content="-1"/>

<meta name="keywords" content="ndglbqfkxx"/>

<meta name="description" content="From June 2020. I’m surprised he hasn’t been cut yet Link   - ( New Window )"/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="website"/>
<meta property="og:description" content="From June 2020. I’m surprised he hasn’t been cut yet Link   - ( New Window )"/> 
<meta property="og:title" content="Sam Beal pleads guilty to gun related charges"/> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif"/> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css?v=20200217"/>

<link rel="stylesheet" type="text/css" href="anylink.css"/>


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}


div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" alt="for display only">

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type="text/javascript">
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type="text/javascript" src="https://img.bnqt.com/lib/js/sdpdfphelper.js"></script>
<script type="text/javascript">
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>


<!-- End DFP SETUP -->  

<!-- End USA Today Code -->




<script type="text/javascript">var ezouid = "1";</script><base href="https://corner.bigblueinteractive.com/index.php?mode=2&thread=609748"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"domain_test_group":20210306,"engaged_time_visit":0,"ezcache_level":0,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"0bc1163c-e7ef-4eeb-49e1-3ebf6615547b","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":71773,"response_time_orig":77,"serverid":"54.209.8.143:12792","state":"VA","t_epoch":1623623625,"template_id":126,"time_on_site_visit":0,"url":"https://corner.bigblueinteractive.com/index.php?mode=2\u0026thread=609748","user_id":0,"word_count":5453,"worst_bad_word_level":1};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["0bc1163c-e7ef-4eeb-49e1-3ebf6615547b", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>


<body>




<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tbody><tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"/></a> <img src="images/xpete.gif" alt="The Corner Forum"/>

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic --> 


<!-- Nov 2019 Leaderboard -->

<!-- Ezoic - Forum Leaderboard (USAT) - top_of_page -->
<div id="ezoic-pub-ad-placeholder-118">
<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->
<div id="usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general');
         });
     </script>
</div>
</div>
<!-- End Ezoic - Forum Leaderboard (USAT) - top_of_page -->



</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://www.amazon.com/?_encoding=UTF8&amp;camp=1789&amp;creative=9325&amp;linkCode=ur2&amp;tag=bigblueintera-20">Amazon.com</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW">Standings (NFL.com)</a>
<a href="https://www.giants.com/team/stats/" target="_NEW">Statistics (Giants.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/">Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</tbody></table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;home_view_menu&#39;)">Home</a>  
</li><li><a href="http://corner.bigblueinteractive.com/index.php" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;forum_view_menu&#39;)">Corner Forum</a>
</li><li><a href="http://corner.bigblueinteractive.com/index.php" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;gameday_view_menu&#39;)">Gameday</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_view_menu&#39;)">Team</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_building_view_menu&#39;)">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info & History</a> -->
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_info_view_menu&#39;)">Giants Info &amp; History</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;infolinks_view_menu&#39;)">Info/Links</a>
</li><li><a href="/index.php?mode=10" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;login_menu&#39;)">Log In</a>
</li></ul>

</div><div id="infoline"> </div>

<a name="END"></a><a href="index.php"></a><div style="padding-top:20px; padding-bottom:25px;"><a href="index.php"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"/></a></div><div class="thread_container"><div class="thread_left"><div class="thread_body"><div class="thread_main"><div class="thread_post_header">  <h1 style="font-size:18px;">Sam Beal pleads guilty to gun related charges </h1><div class="thread_info"><a href="index.php?mode=5&amp;handle=bubba0825"> bubba0825 </a>  :  6/11/2021  3:20 pm</div></div><div class="thread_post_body"> From June 2020. I’m surprised he hasn’t been cut yet<br/><a href="https://www.northjersey.com/story/sports/nfl/giants/2021/06/11/new-york-giants-sam-beal-pleads-guilty-gun-related-charges/7657139002/"> Link </a>  - (<a href="https://www.northjersey.com/story/sports/nfl/giants/2021/06/11/new-york-giants-sam-beal-pleads-guilty-gun-related-charges/7657139002/" target="_NEW"> New Window </a>) </div></div></div><div style="margin: 10 10 20 50"><span class="top_pages">Pages:  <a href="index.php?mode=2&amp;thread=609748&amp;thread_page=1">1</a>  <b style="background: darkred;padding: 2px 5px 2px 5px;">2</b>  <a href="index.php?mode=2&amp;thread=609748&amp;thread_page=1">&lt;&lt;Prev </a>| <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1" title="">Show All</a> | </span></div>
</div><div class="thread_right"><div id="ad_side_box">


<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id="usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general');
         });
     </script>
</div>




</div></div><div class="thread_comment_container"><div class="thread_post"><div class="thread_post_header"><b>Always remember T = T in NFL </b><a name="15284843"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=arniefez"> arniefez </a>  :  6/11/2021  4:22 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284843">link</a>   </div></div><div class="thread_post_body">Talent = Tolerance. See Taylor, Lawrence for reference. <br/>
<br/>
Sam Beal is yet another pre Judge, Gettleman special. Hopefully those days are over now.</div></div><div class="thread_post"><div class="thread_post_header"><b>Year 1 and year 2 of gettleman </b><a name="15284849"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Ten+Ton+Hammer"> Ten Ton Hammer </a>  :  6/11/2021  4:26 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284849">link</a>   </div></div><div class="thread_post_body">Looks like among the least effective runs I&#39;ve ever seen from a front office.</div></div><div class="thread_post"><div class="thread_post_header"><b>This must be whar certain guys &#34;in the know&#34; have been alluding to </b><a name="15284850"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=regulator"> regulator </a>  :  6/11/2021  4:26 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284850">link</a>   </div></div><div class="thread_post_body">Chris Bisignano, being one of them.  Intentionally vague, but clearly aware of something significant that goes beyond general work ethic concerns.</div></div><div class="thread_post"><div class="thread_post_header"><b>This is just a continued pattern for Beal </b><a name="15284854"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=PatersonPlank"> PatersonPlank </a>  :  6/11/2021  4:34 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284854">link</a>   </div></div><div class="thread_post_body">This guy doesn&#39;t want to play football, and frankly we don&#39;t need him.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: This is just a continued pattern for Beal </b><a name="15284873"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Mad+Mike"> Mad Mike </a>  :  6/11/2021  4:44 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284873">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284854" target="_blank">15284854</a> PatersonPlank said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> This guy doesn&#39;t want to play football, and frankly we don&#39;t need him. </td>
                                </tr>
                           </tbody></table><br/>
What other incidents make up this &#34;pattern&#34;?<br/>
<br/>
The guy hasn&#39;t played and is a disappointment.  But let&#39;s not be silly and start connecting things that are wholly unrelated.  Plenty of guys have off-field issues.  It has little to do with their ability and desire to play football.</div></div><div class="thread_post"><div class="thread_post_header"><b>I&#39;m going to go out on a limb here, and say the Giants </b><a name="15284881"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Zeke%27s+Alibi"> Zeke&#39;s Alibi </a>  :  6/11/2021  4:47 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284881">link</a>   </div></div><div class="thread_post_body">really, really believe in what he can do between the lines.  It just seems like this guy would have been an easy cut if that weren&#39;t the case.<br/>
<br/>
I&#39;m still holding out hope on the guy. I like the guy we drafted out of UCF better (although his arm size may limit him to slot corner)  If he can&#39;t play on boundary and Adoree or Brasberry go down, what then?  It&#39;s clear that this organization is putting a ton of resources and focus on having a good and deep secondary.</div></div><div class="thread_post"><div class="thread_post_header"><b>Waste of a pick  </b><a name="15284892"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=jeff57"> jeff57 </a>  :  6/11/2021  4:56 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284892">link</a>   </div></div><div class="thread_post_body">Gets even wastier.</div></div><div class="thread_post"><div class="thread_post_header"><b>Beal </b><a name="15284895"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=noro9"> noro9 </a>  :  6/11/2021  4:58 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284895">link</a>   </div></div><div class="thread_post_body">Will be fine</div></div><div class="thread_post"><div class="thread_post_header"><b>We cut Baker for less and he was a 1st rounder that we traded up for  </b><a name="15284896"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=90.Cal"> 90.Cal </a>  :  6/11/2021  4:58 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284896">link</a>   </div></div><div class="thread_post_body">Not a 3rd round comp pick, just saying...<br/>
<br/>
I told people to give up on Beal like 2 offseaons ago so I&#39;m way over Beal at this point. Just sucks how we can&#39;t get a sure fire &#39;hit&#39; in the 3rd round for anything, for shite and for like decades now... seriously we haven&#39;t gotten a good player in the 3rd round since Mario Manningham and Justin Tuck...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: Article States That Giants Are Aware of Situation... </b><a name="15284898"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=loafin"> loafin </a>  :  6/11/2021  5:00 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284898">link</a>   </div></div><div class="thread_post_body">Agree completely, and I think it is exactly what happened.<br/>
<br/>
In comment <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284838" target="_blank">15284838</a> Jim in Tampa said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15284822 loafin said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     I think they know all about it.  The Giants probably told him to opt out and bring your best for 2021.  <br/>
<br/>
In comment 15284813 Jim in Tampa said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     And have no comment.<br/>
<br/>
If they have BEEN aware (for a while) and Beal is still on the team and in camp, then this means nothing.<br/>
<br/>
If the Giants just found out about this, then it&#39;s a different story. <br/>
                                <br/>
                            <br/>
                                <br/>
                           <br/>
This is what I am hoping is the case... that the Giants actually ADVISED Beal to opt out for the 2020 season.<br/>
<br/>
If that&#39;s true then it sheds a different light on the current BBI take that Beal is a lazy guy who doesn&#39;t want to play football, passed up a golden opportunity to prove himself last year, etc. </td>
                                </tr>
                           </tbody></table></div></div><div class="thread_post"><div class="thread_post_header"><b>Bad judgment cornerbacks are killing this team </b><a name="15284924"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=SGMen"> SGMen </a>  :  6/11/2021  5:31 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284924">link</a>   </div></div><div class="thread_post_body">First Stephen Baker whom we moved up into the first round for and now Beal who we took in the third round supplemental.  Premium picks we missed on!<br/>
<br/>
I mean, I hope something is worked out but a guilty plea is not good. I have to believe he will now be cut opening up a little space and some dead money.<br/>
<br/>
As a fan, I had high hopes he showed up at camp a &#34;grown up&#34; who wanted to play but alas it doesn&#39;t look good.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Bad judgment cornerbacks are killing this team </b><a name="15284926"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=81_Great_Dane"> 81_Great_Dane </a>  :  6/11/2021  5:36 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284926">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284924" target="_blank">15284924</a> SGMen said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> First Stephen Baker whom we moved up into the first round for and now Beal who we took in the third round supplemental.  Premium picks we missed on!<br/>
<br/>
I mean, I hope something is worked out but a guilty plea is not good. I have to believe he will now be cut opening up a little space and some dead money.<br/>
<br/>
As a fan, I had high hopes he showed up at camp a &#34;grown up&#34; who wanted to play but alas it doesn&#39;t look good. </td>
                                </tr>
                           </tbody></table>Stephen Baker? You&#39;re dating yourself</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Gettleman was drafting CB&#39;s... </b><a name="15284933"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=adamg"> adamg </a>  :  6/11/2021  5:49 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284933">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284812" target="_blank">15284812</a> Klaatu said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> He was casting for a remake of Reservoir Dogs. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Gives new meaning to the nickname Killer Bs.</div></div><div class="thread_post"><div class="thread_post_header"><b>He&#39;s guilty  </b><a name="15284947"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=David+B."> David B. </a>  :  6/11/2021  6:16 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284947">link</a>   </div></div><div class="thread_post_body">of highway robbery against the Giants for the past 3 years.<br/>
<br/>
<br/>
<br/>
GOODBYE!</div></div><div class="thread_post"><div class="thread_post_header"><b>In the new woke culture, </b><a name="15284958"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Silver+Spoon"> Silver Spoon </a>  :  6/11/2021  6:38 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284958">link</a>   </div></div><div class="thread_post_body">he’ll be just fine.</div></div><div class="thread_post"><div class="thread_post_header"><b>At this point </b><a name="15284959"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=GoDeep13"> GoDeep13 </a>  :  6/11/2021  6:41 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284959">link</a>   </div></div><div class="thread_post_body">I just want him cut so he can no longer be associated with this Team. I said it at the end of last season and I say it now, get rid of loser players with loser mindsets and loser work ethic. Beal is one of those players.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: In the new woke culture, </b><a name="15284960"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Zeke%27s+Alibi"> Zeke&#39;s Alibi </a>  :  6/11/2021  6:42 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284960">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284958" target="_blank">15284958</a> Silver Spoon said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> he’ll be just fine. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
<br/>
Please enlighten us how this is pertinent to woke culture?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: In the new woke culture, </b><a name="15284967"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=SFGFNCGiantsFan"> SFGFNCGiantsFan </a>  :  6/11/2021  7:00 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284967">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284958" target="_blank">15284958</a> Silver Spoon said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> he’ll be just fine. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
WTF?</div></div><div class="thread_post"><div class="thread_post_header"><b>DG&#39;s Drafts </b><a name="15284988"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Bavaro_the_Mafioso"> Bavaro_the_Mafioso </a>  :  6/11/2021  7:28 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284988">link</a>   </div></div><div class="thread_post_body">LOL!! How many corners have we hit on vice burning FA capital. What a bum.</div></div><div class="thread_post"><div class="thread_post_header"><b>unless he&#39;s a problem in the locker room </b><a name="15285003"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=fkap"> fkap </a>  :  6/11/2021  8:12 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285003">link</a>   </div></div><div class="thread_post_body">or they have negative impressions of his talent, there&#39;s no sense cutting him now.<br/>
<br/>
Put him through camp and evaluate how he&#39;s playing.</div></div><div class="thread_post"><div class="thread_post_header"><b>The fact he is still a Giant says everything you need to know  </b><a name="15285069"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=glowrider"> glowrider </a>  :  6/11/2021  9:42 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285069">link</a>   </div></div><div class="thread_post_body">He opted out in late July/Early August. He may have lucked into a career *extension* with the Giants due to Covid. He probably would’ve been cut in any other year. <br/>
<br/>
Whatever nonsense he was dealing with stayed way the hell under the radar for a full year, didn’t blow back on the org AND the Giants didn’t have to pay him his full salary or have it count a year against his contract. <br/>
<br/>
His opt out has to be seen in a new light, if only for a moment.</div></div><div class="thread_post"><div class="thread_post_header"><b>I wonder if that is something the commissioner’s office would be  </b><a name="15285073"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=glowrider"> glowrider </a>  :  6/11/2021  9:47 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285073">link</a>   </div></div><div class="thread_post_body">Interested in investigating - though tricky minefield questioning motives for a Covid opt out, if the Giants or Beal played some games and took advantage, maybe the league would toll his contract, for example.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: He&#39;s guilty  </b><a name="15285085"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=short+lease"> short lease </a>  :  6/11/2021  10:01 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285085">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284947" target="_blank">15284947</a> David B. said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> of highway robbery against the Giants for the past 3 years.<br/>
<br/>
<br/>
<br/>
GOODBYE! </td>
                                </tr>
                           </tbody></table><br/>
<br/>
+1<br/>
<br/>
<br/>
I doesn&#39;t stop with this guy.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Bad judgment cornerbacks are killing this team </b><a name="15285089"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=SGMen"> SGMen </a>  :  6/11/2021  10:08 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285089">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15284926" target="_blank">15284926</a> 81_Great_Dane said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15284924 SGMen said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     First Stephen Baker whom we moved up into the first round for and now Beal who we took in the third round supplemental.  Premium picks we missed on!<br/>
<br/>
I mean, I hope something is worked out but a guilty plea is not good. I have to believe he will now be cut opening up a little space and some dead money.<br/>
<br/>
As a fan, I had high hopes he showed up at camp a &#34;grown up&#34; who wanted to play but alas it doesn&#39;t look good. <br/>
                                <br/>
                           Stephen Baker? You&#39;re dating yourself </td>
                                </tr>
                           </tbody></table>Deandre Baker #1.  Stephen Baker was an OK player in his day.</div></div><div class="thread_post"><div class="thread_post_header"><b>Nothing I see on the web clarifies any details of this case </b><a name="15285173"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=eclipz928"> eclipz928 </a>  :  6/12/2021  7:21 am   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285173">link</a>   </div></div><div class="thread_post_body">but I presume that the gun was properly registered to Beal, but that he didn&#39;t have a conceal permit to keep it stored in his car. If so, it&#39;s clearly bad judgment but I don&#39;t see how it&#39;s something worth cutting him over. <br/>
<br/>
There&#39;s no comparison here with DeAndre Baker who, regardless of his level of participation, was still involved in a high stakes gambling event where an armed robbery took place.</div></div><div class="thread_post"><div class="thread_post_header"><b>Sam Beal </b><a name="15285178"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=johnboyw"> johnboyw </a>  :  6/12/2021  7:31 am   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285178">link</a>   </div></div><div class="thread_post_body">This guy has to be one of the biggest losers the Giants ever wasted their time with. On top of his “I really don’t want to play” attitude which was obvious from the beginning (always seemed to have a boo-boo) we have gun charges coming right after he opted out of the 2020 season. <br/>
<br/>
I think Dave Gettleman is generally pretty good in finding quality talent. When he gave up a 3rd round pick to get Beal in the Supplemental draft I assumed it was a good get for a team that was CB needy and for a guy who some said was a possible late 1st rounder in the next draft. But as we all know, attitude and desire are just as important as talent and Beal scores very poorly in both of those categories.<br/>
<br/>
The Giants should whack him now and be done with it. Just keeping him around is detrimental to the team.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Nothing I see on the web clarifies any details of this case </b><a name="15285180"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Jimmy+Googs"> Jimmy Googs </a>  :  6/12/2021  7:32 am   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285180">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285173" target="_blank">15285173</a> eclipz928 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> but I presume that the gun was properly registered to Beal, but that he didn&#39;t have a conceal permit to keep it stored in his car. If so, it&#39;s clearly bad judgment but I don&#39;t see how it&#39;s something worth cutting him over. <br/>
<br/>
There&#39;s no comparison here with DeAndre Baker who, regardless of his level of participation, was still involved in a high stakes gambling event where an armed robbery took place. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
no comparisons?</div></div><div class="thread_post"><div class="thread_post_header"><b>They&#39;re both cornerbacks. </b><a name="15285186"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=eclipz928"> eclipz928 </a>  :  6/12/2021  7:53 am   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285186">link</a>   </div></div><div class="thread_post_body">That&#39;s about it.  One was charged with a misdemeanor and expected to have his convictions dismissed, and the other was accused of committing felony armed robbery.<br/>
<br/>
Baker&#39;s case was ultimately dismissed, but the accusations were so severe that the Giants were under a lot of pressure to make a decision on him, especially with the potential of him going to prison. Beal plead guilty, but the charges aren&#39;t nearly as severe and there&#39;s no jail time in his future.</div></div><div class="thread_post"><div class="thread_post_header"><b>What would our O-Line look like today </b><a name="15285188"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=M.S."> M.S. </a>  :  6/12/2021  8:03 am   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285188">link</a>   </div></div><div class="thread_post_body"><br/>
if instead of Sam Beal and Deandre Baker, Gettleman devoted those picks to additional lineman?</div></div><div class="thread_post"><div class="thread_post_header"><b>I think if you dig down you can see some more comparisons </b><a name="15285193"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Jimmy+Googs"> Jimmy Googs </a>  :  6/12/2021  8:14 am   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285193">link</a>   </div></div><div class="thread_post_body">of the two...</div></div><div class="thread_post"><div class="thread_post_header"><b>Sam Beal </b><a name="15285211"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BBWreckingCrew"> BBWreckingCrew </a>  :  6/12/2021  8:42 am   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285211">link</a>   </div></div><div class="thread_post_body">what&#39;s wrong with this guy? Opportunity of a lifetime and pissing down the drain. Wake up and grow up! Maybe he should wash dishes at a local restaurant instead of playing pro football. Seems like that is what he wants. Gun in car cut this street gang bs out. It&#39;s ruined so many careers. If you need gun your definitely associated w wrong people. Rely on your toughness w hands instead of hiding behind trigger.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: What would our O-Line look like today </b><a name="15285212"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=SGMen"> SGMen </a>  :  6/12/2021  8:43 am   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285212">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285188" target="_blank">15285188</a> M.S. said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
if instead of Sam Beal and Deandre Baker, Gettleman devoted those picks to additional lineman? </td>
                                </tr>
                           </tbody></table>The Baker pick especially will haunt us as it was a #1, a premium pick and we gave up quite a bit to move up for a guy who reputedly has &#34;practice issues&#34; (as in lazy) in college.<br/>
<br/>
I get taking a chance.  I really do cause if you HIT that is awesome.  But here we blew it.  If we had stood pat and took a starter in the 2nd round who is to say we weren&#39;t a playoff team last year?<br/>
<br/>
Woulda. Coulda. Shoulda.  My hope at this point, honestly, is that Beal matures from this experience and he comes to camp on fire.  You can&#39;t have enough good defensive backs and he does have the physical tools.<br/>
<br/>
If there is no jail time perhaps he learned a hard lesson that will HELP him mature rather than sink him?</div></div><div class="thread_post"><div class="thread_post_header"><b>True if he has learned a lesson I would give him another chance to  </b><a name="15285219"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BBWreckingCrew"> BBWreckingCrew </a>  :  6/12/2021  8:55 am   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285219">link</a>   </div></div><div class="thread_post_body">get his stuff together and be a productive teammate. It&#39;s just frustrating. He definitely has tools as a DB.</div></div><div class="thread_post"><div class="thread_post_header"><b>People here don&#39;t know how to read </b><a name="15285227"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dave+on+the+UWS"> Dave on the UWS </a>  :  6/12/2021  9:08 am   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285227">link</a>   </div></div><div class="thread_post_body">He opted out 9 DAYS before the incident. Thus the team clearly didn&#39;t &#34;tell him to opt out&#34;. <br/>
He got probation, so there&#39;s no risk he goes to jail. It IS possible that the team hasn&#39;t cut him yet waiting for this to play out legally. <br/>
I still think he gets cut on the merits at the end of training camp though.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I think if you dig down you can see some more comparisons </b><a name="15285265"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=eclipz928"> eclipz928 </a>  :  6/12/2021  11:03 am   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285265">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285193" target="_blank">15285193</a> Jimmy Googs said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> of the two... </td>
                                </tr>
                           </tbody></table><br/>
Maybe I&#39;m missing something, why don&#39;t you lay it out?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I think if you dig down you can see some more comparisons </b><a name="15285266"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Jimmy+Googs"> Jimmy Googs </a>  :  6/12/2021  11:09 am   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285266">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285265" target="_blank">15285265</a> eclipz928 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15285193 Jimmy Googs said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     of the two... <br/>
                                <br/>
                           <br/>
Maybe I&#39;m missing something, why don&#39;t you lay it out? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
They are two people who have never been in my kitchen...<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: People here don&#39;t know how to read </b><a name="15285270"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=glowrider"> glowrider </a>  :  6/12/2021  11:19 am   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285270">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285227" target="_blank">15285227</a> Dave on the UWS said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> He opted out 9 DAYS before the incident. Thus the team clearly didn&#39;t &#34;tell him to opt out&#34;. <br/>
He got probation, so there&#39;s no risk he goes to jail. It IS possible that the team hasn&#39;t cut him yet waiting for this to play out legally. <br/>
I still think he gets cut on the merits at the end of training camp though. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I’m not sure this is correct. The article states the incident happened in early June 2020, and his opt out happened right before his indictment, which by that point they would have known was coming the pike. The indictment did happen after his opt-out, again though, they would have had a good idea of the direction this thing was going before that time as they had two months between the event, the opt out and the indictment. <br/>
<br/>
The opt out didn’t occur before the actual event and arrest. I’m open to being corrected here, but I do think your timeline is off.</div></div><div class="thread_post"><div class="thread_post_header"><b>Why when someone says people can&#39;t read they make errors </b><a name="15285500"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Larry+in+Pencilvania"> Larry in Pencilvania </a>  :  6/12/2021  8:46 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285500">link</a>   </div></div><div class="thread_post_body">Beal was arrested 6/2. He opted out the first week of August as repoted by the many beats. He was indicted 8/23. It can only be assumed the team advised him to out out for the cap money and roster spot.<br/>
<br/>
He can go to camp get cut or they can cut him now.... Whatever</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: What would our O-Line look like today </b><a name="15285523"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Leg+of+Theismann"> Leg of Theismann </a>  :  6/12/2021  10:30 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285523">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285212" target="_blank">15285212</a> SGMen said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15285188 M.S. said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
if instead of Sam Beal and Deandre Baker, Gettleman devoted those picks to additional lineman? <br/>
                                <br/>
                           The Baker pick especially will haunt us as it was a #1, a premium pick and we gave up quite a bit to move up for a guy who reputedly has &#34;practice issues&#34; (as in lazy) in college.<br/>
<br/>
I get taking a chance.  I really do cause if you HIT that is awesome.  But here we blew it.  If we had stood pat and took a starter in the 2nd round who is to say we weren&#39;t a playoff team last year?<br/>
<br/>
Woulda. Coulda. Shoulda.  My hope at this point, honestly, is that Beal matures from this experience and he comes to camp on fire.  You can&#39;t have enough good defensive backs and he does have the physical tools.<br/>
<br/>
If there is no jail time perhaps he learned a hard lesson that will HELP him mature rather than sink him? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
The Baker thing will forever have me looking sideways at anything Gettleman does. The move made zero sense and it was clear from the beginning. 1) because he was primarily known for his talent in man coverage in college and DG drafted him for James Bettcher who went on to using him almost exclusively in zone— just no cohesive vision between a GM and coaching staff. 2) Moving up 7 slots for a guy with the issues Baker supposedly had when I thought the whole theme of DG was “clean up the culture.” 3) Not to mention there were 3 or 4 other CBs on the board of similar value so moving up really made no sense anyway. The whole thing was stupid. Meanwhile there were about 4 WRs on the board of 1st round talent due to that draft being a deep WR 1st round prospects. If Gettleman had stayed put, kept his capital, and and drafted AJ Brown or DK Metcalf at #37 think about how much different this team might look today.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: What would our O-Line look like today </b><a name="15285531"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=SGMen"> SGMen </a>  :  6/12/2021  10:39 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285531">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285523" target="_blank">15285523</a> Leg of Theismann said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15285212 SGMen said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15285188 M.S. said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
if instead of Sam Beal and Deandre Baker, Gettleman devoted those picks to additional lineman? <br/>
                                <br/>
                           The Baker pick especially will haunt us as it was a #1, a premium pick and we gave up quite a bit to move up for a guy who reputedly has &#34;practice issues&#34; (as in lazy) in college.<br/>
<br/>
I get taking a chance.  I really do cause if you HIT that is awesome.  But here we blew it.  If we had stood pat and took a starter in the 2nd round who is to say we weren&#39;t a playoff team last year?<br/>
<br/>
Woulda. Coulda. Shoulda.  My hope at this point, honestly, is that Beal matures from this experience and he comes to camp on fire.  You can&#39;t have enough good defensive backs and he does have the physical tools.<br/>
<br/>
If there is no jail time perhaps he learned a hard lesson that will HELP him mature rather than sink him? <br/>
                                <br/>
                           <br/>
<br/>
The Baker thing will forever have me looking sideways at anything Gettleman does. The move made zero sense and it was clear from the beginning. 1) because he was primarily known for his talent in man coverage in college and DG drafted him for James Bettcher who went on to using him almost exclusively in zone— just no cohesive vision between a GM and coaching staff. 2) Moving up 7 slots for a guy with the issues Baker supposedly had when I thought the whole theme of DG was “clean up the culture.” 3) Not to mention there were 3 or 4 other CBs on the board of similar value so moving up really made no sense anyway. The whole thing was stupid. Meanwhile there were about 4 WRs on the board of 1st round talent due to that draft being a deep WR 1st round prospects. If Gettleman had stayed put, kept his capital, and and drafted AJ Brown or DK Metcalf at #37 think about how much different this team might look today. </td>
                                </tr>
                           </tbody></table>Agreed.  Perhaps we had Baker graded higher and saw the opportunity to move up and BOOM history shows we blew it big-time.  Metcalf would have really helped us last year as he is the big WR this team would love to have.</div></div><div class="thread_post"><div class="thread_post_header"><b>Not going to discuss Baker, but the move to go back into the  </b><a name="15285542"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=glowrider"> glowrider </a>  :  6/12/2021  11:42 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285542">link</a>   </div></div><div class="thread_post_body">Bottom of the first for a player at a premium position was not foolhardy. The fifth year option is a *significant* benefit, particularly for such an expensive position. Swapped our second for the first and gave up a late 4th and a 5th in addition in a draft we had like 12 picks.</div></div><div class="thread_post"><div class="thread_post_header"><b>Beal is not a good CB  </b><a name="15285556"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=giantstock"> giantstock </a>  : 12:36 am   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285556">link</a>   </div></div><div class="thread_post_body">IMO he will eventually get cut. He was always considered a stretch to be taken in the supp. draft where he was taken.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Beal is not a good CB  </b><a name="15285604"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Klaatu"> Klaatu </a>  : 8:43 am   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285604">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285556" target="_blank">15285556</a> giantstock said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> IMO he will eventually get cut. <span class="bold">He was always considered a stretch to be taken in the supp. draft where he was taken.</span> </td>
                                </tr>
                           </tbody></table><br/>
<br/>
That&#39;s simply not true.  Stop with the revisionist history.  The vast majority of pundits projected Beal to go for a 3rd round bid, and a handful even said he was worth a 2nd.  <br/>
<br/>
It&#39;s no secret that you despise Gettleman, and you can zing him for a lot of things, but using a 3rd in the Supplemental Draft for Beal isn&#39;t one of them.  Just because Beal looks like a bust now doesn&#39;t mean he was a bad pick at the time it was made.  It wasn&#39;t.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Beal is not a good CB  </b><a name="15285694"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=giantstock"> giantstock </a>  : 1:06 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285694">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285604" target="_blank">15285604</a> Klaatu said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15285556 giantstock said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     IMO he will eventually get cut. He was always considered a stretch to be taken in the supp. draft where he was taken. <br/>
                                <br/>
                           <br/>
<br/>
That&#39;s simply not true.  Stop with the revisionist history.  The vast majority of pundits projected Beal to go for a 3rd round bid, and a handful even said he was worth a 2nd.  <br/>
<br/>
It&#39;s no secret that you despise Gettleman, and you can zing him for a lot of things, but using a 3rd in the Supplemental Draft for Beal isn&#39;t one of them.  Just because Beal looks like a bust now doesn&#39;t mean he was a bad pick at the time it was made.  It wasn&#39;t. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
You know what- I looked up on internet - you&#39;re right - I was wrong. He was projected 2nd or 3rd rd. Maybe as the article mentions below I had confused ineligibility with projected draft pick selection. <br/>
<br/>
https://www.bigblueview.com/2018/7/11/17562116/sam-beal-ny-giants-2018-supplemental-draft-scouting-report-analysis<br/>
<br/>
As far as criticism for DG and I hate him- you&#39;re right and thank you for the point of bringing it up seeing how you felt it such a big deal for a 3rd rd pick (I thought it was just a simple comment I made but seeing how you are putting my hate for him in an implication of an unjustified opinion)- let&#39;s review some of past FA&#39;s prior to last year and 1st rd picks: <br/>
<br/>
1-- I&#39;ve been right about the blundering pick so far of Barkley (a RB in rebuild). <br/>
<br/>
2-- If DG felt he was in rebuild then why spend so much and give up draft picks for Ogeltree? This is the time when many on here were giving the DG excuse about &#34;cap space.&#34; <br/>
<br/>
3-- I criticized the Solder move which I was right.<br/>
<br/>
4--And I thought taking Tate was a very bad move for the money spent which I was right. <br/>
<br/>
5-- And at least last year I thought there were 3 better OT&#39;s than Thomas of the big 4 and he was a consensus 3rd best OT and we ended up taking him 1st. And according to PFF his 1st year he was 3rd in terms of performance. It&#39;s not that this is that bad- just more frustration with DG at the time.    <br/>
<br/>
***--  With that said it should also be known after 2019 season I was on board to keep DG because Jones might work out. I was heavily against Jones at 1st but as of right now I think he can be good enough. Potential kudos to DG. <br/>
Now I want you and others to be fair - and read the link below. The following sentence in the link says it all -<br/>
 <br/>
https://www.si.com/nfl/giants/news/gettleman-admits-that-he-overestimated-the-giants-rebuild-process<br/>
<br/>
-------------------<br/>
&#34;Gettleman also admitted that he overestimated the state of the roster and believing that the team could win while it was rebuilding.&#34;<br/>
----------------<br/>
What if you thought this was what he believed at the time  in some manner and thought this was incredibly stupid? So if you hated this philosophy while you hate the arrogance of the man for a team that has sucked, while you hated both most the FA big signings and 1st rd draft picks while hate the continuous losing in which you think the philosophy is  part of this continuous awful play, then why wouldn’t you hate him? THE HUBRIS OF HIS THOUGHT PROCESS THAT HE COULD DO THIS YET REMAIN SO FREAKIN&#39; ARROGANT WHILE ATTMETPING IT- IS MIND-BOGGLING. <br/>
<br/>
I won&#39;t wear a cheerleading skirt on here like some do. However I do see improvement now - this year 7-10 is an improvement and better for next year when they further address the OL. If I&#39;m right that the OL is the big cause for 7-10 or worse, then both DG and Judge are at fault for this to a degree, right? <br/>
<br/>
In summary. I made a mistake with my comment of draft pick of Beal- that’s all. And I do think he’ll be cut unless injuries pop up. I think he’s a bad CB. We shall see. As SY had said after the season- that Beal certainly “didn’t instill any confidence” with our team. <br/>
<br/>
<br/>
<br/>
<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>As I said, you can zing Gettleman for a lot of things... </b><a name="15285745"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Klaatu"> Klaatu </a>  : 2:25 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285745">link</a>   </div></div><div class="thread_post_body">But the Beal pick isn&#39;t one of them.  <br/>
<br/>
As for your bias showing, it&#39;s clear that pointing it out touched a nerve, hence your need to blather on about Gettleman&#39;s other failings (which, of course, have nothing to do with the Beal pick).  Obviously, the truth hurt, but if your lengthy reply helped alleviate some of that pain, so be it.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: As I said, you can zing Gettleman for a lot of things... </b><a name="15285754"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=giantstock"> giantstock </a>  : 2:38 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285754">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285745" target="_blank">15285745</a> Klaatu said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> But the Beal pick isn&#39;t one of them.  <br/>
<br/>
As for your bias showing, it&#39;s clear that pointing it out touched a nerve, hence your need to blather on about Gettleman&#39;s other failings (which, of course, have nothing to do with the Beal pick).  Obviously, the truth hurt, but if your lengthy reply helped alleviate some of that pain, so be it. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Your blathering need to make a point of my bias imo seemed to touch a nerve with you. There was no need for you to bring up my bias. I said I was wrong. And even now instead of accepting it you further need to make a further blathering comment. <br/>
<br/>
And in terms of my bias, so far has chosen to be correct, has it not?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: As I said, you can zing Gettleman for a lot of things... </b><a name="15285780"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Klaatu"> Klaatu </a>  : 3:01 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285780">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285754" target="_blank">15285754</a> giantstock said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15285745 Klaatu said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     But the Beal pick isn&#39;t one of them.  <br/>
<br/>
As for your bias showing, it&#39;s clear that pointing it out touched a nerve, hence your need to blather on about Gettleman&#39;s other failings (which, of course, have nothing to do with the Beal pick).  Obviously, the truth hurt, but if your lengthy reply helped alleviate some of that pain, so be it. <br/>
                                <br/>
                           <br/>
<br/>
Your blathering need to make a point of my bias imo seemed to touch a nerve with you. <span class="bold">There was no need for you to bring up my bias.</span> I said I was wrong. And even now instead of accepting it you further need to make a further blathering comment. <br/>
<br/>
And in terms of my bias, so far has chosen to be correct, has it not? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Of course there was.  In your zeal to criticize Gettleman you said something that was patently false.  You didn&#39;t bother to check the facts (until you were called on it), because you didn&#39;t care.  All you cared about was sticking it to Gettleman.  Also, I never said you were wrong about him except in this one instance, so everything else you wrote about him is irrelevant.    <br/>
<br/>
Suggestion:  Next time Google first, post second.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: As I said, you can zing Gettleman for a lot of things... </b><a name="15285810"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=giantstock"> giantstock </a>  : 3:46 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285810">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285780" target="_blank">15285780</a> Klaatu said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15285754 giantstock said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15285745 Klaatu said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     But the Beal pick isn&#39;t one of them.  <br/>
<br/>
As for your bias showing, it&#39;s clear that pointing it out touched a nerve, hence your need to blather on about Gettleman&#39;s other failings (which, of course, have nothing to do with the Beal pick).  Obviously, the truth hurt, but if your lengthy reply helped alleviate some of that pain, so be it. <br/>
                                <br/>
                           <br/>
<br/>
Your blathering need to make a point of my bias imo seemed to touch a nerve with you. There was no need for you to bring up my bias. I said I was wrong. And even now instead of accepting it you further need to make a further blathering comment. <br/>
<br/>
And in terms of my bias, so far has chosen to be correct, has it not? <br/>
                                <br/>
                           <br/>
<br/>
Of course there was.  In your zeal to criticize Gettleman you said something that was patently false.  You didn&#39;t bother to check the facts (until you were called on it), because you didn&#39;t care.  All you cared about was sticking it to Gettleman.  Also, I never said you were wrong about him except in this one instance, so everything else you wrote about him is irrelevant.    <br/>
<br/>
Suggestion:  Next time Google first, post second. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
If I think I was right about something why do I need to check? <br/>
<br/>
And again I admit I was wrong yet you keep blathering on about my bias. <br/>
<br/>
Instead of just accepting I made a mistake you keep incorrectly trying to tie in my hate toward DG with my mistake. If you are going to tell me to check- and I didn&#39;t- and admitted I made a mistake- how does that relate to my hate towards DG? -- Further I&#39;ve acknowledged I&#39;m okay with DG not being fired and remain hopeful for Jones. To go to the extreme argument you are taking on with me is a bit over-the-top. <br/>
<br/>
Suggestion: Next time you post get the bug out of your ass.</div></div><div class="thread_post"><div class="thread_post_header"><b>That one is classic... </b><a name="15285843"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Jimmy+Googs"> Jimmy Googs </a>  : 5:34 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285843">link</a>   </div></div><div class="thread_post_body">“If I think I was right about something why do I need to check?”.<br/>
<br/>
Pope giantstock I</div></div><div class="thread_post"><div class="thread_post_header"><b>Just take the L, dude. </b><a name="15285844"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Klaatu"> Klaatu </a>  : 5:34 pm   : <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1#15285844">link</a>   </div></div><div class="thread_post_body">You&#39;re embarrassing yourself.</div></div><div style="margin: 10 10 20 50"><span class="top_pages">Pages:  <a href="index.php?mode=2&amp;thread=609748&amp;thread_page=1">1</a>  <b style="background: darkred;padding: 2px 5px 2px 5px;">2</b>  <a href="index.php?mode=2&amp;thread=609748&amp;thread_page=1">&lt;&lt;Prev </a>| <a href="index.php?mode=2&amp;thread=609748&amp;show_all=1" title="">Show All</a> | </span></div>
<a name="END"></a><a href="index.php"></a><div style="padding-top:25px; padding-bottom:20px;"><a href="index.php"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"/></a></div></div>
<div class="thread_sidebar_2">

<!-- Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-102">
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Corner Forum - Lower 300x250 -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1566320450447229" data-ad-slot="4189314539" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->

</div>

</div>




<div class="footer">


<p style="width:450px;float:left;padding:10px;"><b>Part of the USA Today Sports Media Group</b><br/>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</p>
<p style="width:400px;float:right; text-align:right;padding:10px;">
All contents (unless otherwise specified) copyright ©  1995 - 2021<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br/> <br/><strong>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Solutions</a></strong>
</p>
<br clear="all"/>
 
</div>




<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->



<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=0&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script></body></html>