<!DOCTYPE html><html lang="en"><head><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-0&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-0&cb=4', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-0&cb=5', false, [], true, false, true, false);</script>
<title>Daniel Jones named NFC Offensive Player of the Week | Big Blue Interactive </title>

<meta http-equiv="Pragma" content="no-cache"/>
<meta http-equiv="Expires" content="-1"/>

<meta name="keywords" content="ndglbqfkxx"/>

<meta name="description" content="Just announced...

"/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="website"/>
<meta property="og:description" content="Just announced...

"/> 
<meta property="og:title" content="Daniel Jones named NFC Offensive Player of the Week"/> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif"/> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css?v=20200217"/>

<link rel="stylesheet" type="text/css" href="anylink.css"/>


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}


div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" alt="for display only">

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type="text/javascript">
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type="text/javascript" src="https://img.bnqt.com/lib/js/sdpdfphelper.js"></script>
<script type="text/javascript">
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>


<!-- End DFP SETUP -->  

<!-- End USA Today Code -->




<script type="text/javascript">var ezouid = "1";</script><base href="https://corner.bigblueinteractive.com/index.php?mode=2&thread=613318&show_all=1"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"domain_test_group":20210306,"engaged_time_visit":0,"ezcache_level":0,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"d5986569-2993-4621-600d-5289474b5479","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":147146,"response_time_orig":88,"serverid":"35.173.47.97:18111","state":"VA","t_epoch":1633679736,"template_id":126,"time_on_site_visit":0,"url":"https://corner.bigblueinteractive.com/index.php?mode=2\u0026thread=613318\u0026show_all=1","user_id":0,"word_count":11060,"worst_bad_word_level":1};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["d5986569-2993-4621-600d-5289474b5479", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>


<body>




<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tbody><tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"/></a> <img src="images/xpete.gif" alt="The Corner Forum"/>

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic --> 


<!-- Nov 2019 Leaderboard -->

<!-- Ezoic - Forum Leaderboard (USAT) - top_of_page -->
<div id="ezoic-pub-ad-placeholder-118">
<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->
<div id="usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general');
         });
     </script>
</div>
</div>
<!-- End Ezoic - Forum Leaderboard (USAT) - top_of_page -->



</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://www.amazon.com/?_encoding=UTF8&amp;camp=1789&amp;creative=9325&amp;linkCode=ur2&amp;tag=bigblueintera-20">Amazon.com</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW">Standings (NFL.com)</a>
<a href="https://www.giants.com/team/stats/" target="_NEW">Statistics (Giants.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/">Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</tbody></table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;home_view_menu&#39;)">Home</a>  
</li><li><a href="http://corner.bigblueinteractive.com/index.php" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;forum_view_menu&#39;)">Corner Forum</a>
</li><li><a href="http://corner.bigblueinteractive.com/index.php" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;gameday_view_menu&#39;)">Gameday</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_view_menu&#39;)">Team</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_building_view_menu&#39;)">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info & History</a> -->
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_info_view_menu&#39;)">Giants Info &amp; History</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;infolinks_view_menu&#39;)">Info/Links</a>
</li><li><a href="/index.php?mode=10" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;login_menu&#39;)">Log In</a>
</li></ul>

</div><div id="infoline"> </div>

<a name="END"></a><a href="index.php"></a><div style="padding-top:20px; padding-bottom:25px;"><a href="index.php"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"/></a></div><div class="thread_container"><div class="thread_left"><div class="thread_body"><div class="thread_main"><div class="thread_post_header">  <h1 style="font-size:18px;">Daniel Jones named NFC Offensive Player of the Week </h1><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric from BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  10/6/2021  8:34 am</div></div><div class="thread_post_body"> Just announced...<br/>
<br/>
 </div></div></div></div><div class="thread_right"><div id="ad_side_box">


<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id="usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103,22280986322/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general');
         });
     </script>
</div>


</div></div><div class="thread_comment_container"><div class="thread_post"><div class="thread_post_header"><b>Well </b><a name="15400966"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=M.S."> M.S. </a>  :  10/6/2021  8:38 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400966">link</a>   </div></div><div class="thread_post_body"><br/>
Deserved!</div></div><div class="thread_post"><div class="thread_post_header"><b>Unpossible! </b><a name="15400967"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Johnny5"> Johnny5 </a>  :  10/6/2021  8:39 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400967">link</a>   </div></div><div class="thread_post_body">Daniel Jones is the Suxity!<br/>
<br/>
lol<br/>
<br/>
Congrats DJ! You deserve it... now just keep it going!</div></div><div class="thread_post"><div class="thread_post_header"><b>how&#39;s Haskins </b><a name="15400969"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=KDavies"> KDavies </a>  :  10/6/2021  8:43 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400969">link</a>   </div></div><div class="thread_post_body">doing?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: how&#39;s Haskins </b><a name="15400973"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bluewave"> bluewave </a>  :  10/6/2021  8:45 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400973">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400969" target="_blank">15400969</a> KDavies said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> doing? </td>
                                </tr>
                           </tbody></table><br/>
LOL!!!!</div></div><div class="thread_post"><div class="thread_post_header"><b>Second career </b><a name="15400976"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=JB_in_DC"> JB_in_DC </a>  :  10/6/2021  8:46 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400976">link</a>   </div></div><div class="thread_post_body">NFC OPotW for Daniel.  Keep it up!</div></div><div class="thread_post"><div class="thread_post_header"><b>I look forward to hearing… </b><a name="15400981"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Chris+in+Philly"> Chris in Philly </a>  :  10/6/2021  8:48 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400981">link</a>   </div></div><div class="thread_post_body">from the “fans” who refuse to even admit he had one good game because being right on an anonymous message board is the only thing that matters to them. And likewise, I look forward to the inevitable subsequent twisting of words that leads to “is one good game enough for you?”, which is done to obfuscate away the first point.</div></div><div class="thread_post"><div class="thread_post_header"><b>I heard on BBI that Nick Mullins might be a better QB for the Giants </b><a name="15400982"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=GiantGolfer"> GiantGolfer </a>  :  10/6/2021  8:48 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400982">link</a>   </div></div><div class="thread_post_body">How’d he do this past weekend?</div></div><div class="thread_post"><div class="thread_post_header"><b>LOL </b><a name="15400987"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=DannyDimes"> DannyDimes </a>  :  10/6/2021  8:53 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400987">link</a>   </div></div><div class="thread_post_body">Jones is playing great. Andrew Thomas is playing great. Barkley had his best game of the season. <br/>
<br/>
What will the haters do with all of this?</div></div><div class="thread_post"><div class="thread_post_header"><b>Nice! </b><a name="15400989"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=truebluelarry"> truebluelarry </a>  :  10/6/2021  8:54 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400989">link</a>   </div></div><div class="thread_post_body">Very much deserved. <br/>
Here&#39;s hoping that there are many more to come.</div></div><div class="thread_post"><div class="thread_post_header"><b>Makes sense… </b><a name="15400992"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  :  10/6/2021  8:57 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400992">link</a>   </div></div><div class="thread_post_body">Made big plays on the road trailing by double digits in the 4th.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: LOL </b><a name="15400994"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BSIMatt"> BSIMatt </a>  :  10/6/2021  8:58 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400994">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400987" target="_blank">15400987</a> DannyDimes said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Jones is playing great. Andrew Thomas is playing great. Barkley had his best game of the season. <br/>
<br/>
What will the haters do with all of this? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Jones, Thomas, Barkley, Toney..4 consecutive first rounders, were among the best players on the field for either team Sunday.</div></div><div class="thread_post"><div class="thread_post_header"><b>not bad... </b><a name="15400995"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BillKo"> BillKo </a>  :  10/6/2021  8:59 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400995">link</a>   </div></div><div class="thread_post_body">..considering his performance was both &#34;unimpressive&#34; and typical of the rest of the league....</div></div><div class="thread_post"><div class="thread_post_header"><b>Trevon Diggs of Cowboys win NFC Defensive Player of Week </b><a name="15400996"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=chick310"> chick310 </a>  :  10/6/2021  8:59 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400996">link</a>   </div></div><div class="thread_post_body">setting up a head-to-head showdown this Sunday between these stars.<br/>
<br/>
Jones tests him early with a long TD pass to Golladay.</div></div><div class="thread_post"><div class="thread_post_header"><b>Wow over </b><a name="15400997"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BigBlueJ"> BigBlueJ </a>  :  10/6/2021  8:59 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400997">link</a>   </div></div><div class="thread_post_body">Kyle, so happy for the young man, so much deserved.</div></div><div class="thread_post"><div class="thread_post_header"><b>Great job last week DJ </b><a name="15401000"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Rick+in+Dallas"> Rick in Dallas </a>  :  10/6/2021  9:01 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401000">link</a>   </div></div><div class="thread_post_body">…</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Trevon Diggs of Cowboys win NFC Defensive Player of Week </b><a name="15401005"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  :  10/6/2021  9:04 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401005">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400996" target="_blank">15400996</a> chick310 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> setting up a head-to-head showdown this Sunday between these stars.<br/>
<br/>
Jones tests him early with a long TD pass to Golladay. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Diggs is playing out of his mind. Didn’t see that level of play coming…</div></div><div class="thread_post"><div class="thread_post_header"><b>Well deserved. </b><a name="15401007"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Section331"> Section331 </a>  :  10/6/2021  9:04 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401007">link</a>   </div></div><div class="thread_post_body">Let&#39;s hope the first of many.</div></div><div class="thread_post"><div class="thread_post_header"><b>He finally </b><a name="15401012"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Joey+in+VA"> Joey in VA </a>  :  10/6/2021  9:11 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401012">link</a>   </div></div><div class="thread_post_body">Looked like he did during his rookie year, confident, in command and able to pinpoint the ball. Well deserved, hopefully this is just the beginning.</div></div><div class="thread_post"><div class="thread_post_header"><b>This is always the problem with the Giants </b><a name="15401027"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bradshaw44"> bradshaw44 </a>  :  10/6/2021  9:24 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401027">link</a>   </div></div><div class="thread_post_body">Once an underperforming unit pulls it all together, the previously steady unit falls apart.  Right no Q our defense shows no resemblance to their prior year self.  <br/>
<br/>
Just once I&#39;d like both units to be either firing on all cylinders, or at least one firing and other being serviceable.  <br/>
<br/>
Congrats Daniel, we are gonna need you to put this team on your back for the the season.  And maybe more.</div></div><div class="thread_post"><div class="thread_post_header"><b>Congratulations! </b><a name="15401031"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=x+meadowlander"> x meadowlander </a>  :  10/6/2021  9:25 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401031">link</a>   </div></div><div class="thread_post_body">NOW DO IT IN FEBRUARY!!!</div></div><div class="thread_post"><div class="thread_post_header"><b>Well Done Indeed! </b><a name="15401035"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=SirLoinOfBeef"> SirLoinOfBeef </a>  :  10/6/2021  9:30 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401035">link</a>   </div></div><div class="thread_post_body">Keep it up DJ.</div></div><div class="thread_post"><div class="thread_post_header"><b>Danny is a Gangster </b><a name="15401036"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=TheBlueprintNC"> TheBlueprintNC </a>  :  10/6/2021  9:31 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401036">link</a>   </div></div><div class="thread_post_body">Franchise QB -</div></div><div class="thread_post"><div class="thread_post_header"><b>This isn&#39;t good </b><a name="15401038"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dr.+D"> Dr. D </a>  :  10/6/2021  9:32 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401038">link</a>   </div></div><div class="thread_post_body">for the BBI DJ master haters.</div></div><div class="thread_post"><div class="thread_post_header"><b>So great to see! </b><a name="15401042"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Chris684"> Chris684 </a>  :  10/6/2021  9:35 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401042">link</a>   </div></div><div class="thread_post_body">Here’s to many more!</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: This isn&#39;t good </b><a name="15401045"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Keaton028"> Keaton028 </a>  :  10/6/2021  9:37 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401045">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401038" target="_blank">15401038</a> Dr. D said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> for the BBI DJ master haters. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I don’t get these types of comments. Does anyone really hate DJ? His detractors want to see more of this on a consistent basis. Is that really a terrible ask? We are all rooting for him regardless. It’s better for the Giants if DJ turns out to be that guy.<br/>
<br/>
Aren’t we all Giants fans in the end? This place is so clique-ish.</div></div><div class="thread_post"><div class="thread_post_header"><b>Well deserved. </b><a name="15401050"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dave+in+Hoboken"> Dave in Hoboken </a>  :  10/6/2021  9:42 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401050">link</a>   </div></div><div class="thread_post_body">He was great.</div></div><div class="thread_post"><div class="thread_post_header"><b>Awesome. </b><a name="15401053"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BrettNYG10"> BrettNYG10 </a>  :  10/6/2021  9:44 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401053">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>That can’t be </b><a name="15401058"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=joeinpa"> joeinpa </a>  :  10/6/2021  9:47 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401058">link</a>   </div></div><div class="thread_post_body">A certain poster told us this week, Daniel s performance was not impressive. <br/>
<br/>
Who votes for these honors, must be a bunch of people without the skills of the resident critics here.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: This isn&#39;t good </b><a name="15401062"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=KDavies"> KDavies </a>  :  10/6/2021  9:48 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401062">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401045" target="_blank">15401045</a> Keaton028 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401038 Dr. D said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     for the BBI DJ master haters. <br/>
                                <br/>
                           <br/>
<br/>
I don’t get these types of comments. Does anyone really hate DJ? His detractors want to see more of this on a consistent basis. Is that really a terrible ask? We are all rooting for him regardless. It’s better for the Giants if DJ turns out to be that guy.<br/>
<br/>
Aren’t we all Giants fans in the end? This place is so clique-ish. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Jones&#39; detractors do not merely &#34;want to see more of this on a consistent basis.&#34;  To start off with, the Giants were ripped by &#34;experts&#34; as being racist for selecting him over the immortal Dwayne Haskins.<br/>
<br/>
A large contingent of Giants fans also ripped the pick, and have ripped him for the two years he has been here.  It&#39;s not surprising that those that believe(d) in Jones, and even those who took a more wait-and-see approach are gloating a little bit.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: This isn&#39;t good </b><a name="15401063"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bLiTz+2k"> bLiTz 2k </a>  :  10/6/2021  9:49 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401063">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401045" target="_blank">15401045</a> Keaton028 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401038 Dr. D said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     for the BBI DJ master haters. <br/>
                                <br/>
                           <br/>
<br/>
I don’t get these types of comments. Does anyone really hate DJ? His detractors want to see more of this on a consistent basis. Is that really a terrible ask? We are all rooting for him regardless. It’s better for the Giants if DJ turns out to be that guy.<br/>
<br/>
Aren’t we all Giants fans in the end? This place is so clique-ish. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
There&#39;s a very very small sample that kinda do...and it&#39;s not your typical realists who usually have okay takes. I tend to ignore those one or two other folks</div></div><div class="thread_post"><div class="thread_post_header"><b>Awesome stuff! </b><a name="15401068"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Simms11"> Simms11 </a>  :  10/6/2021  9:51 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401068">link</a>   </div></div><div class="thread_post_body">Keep it going DJ! Hope he gets another one this week!</div></div><div class="thread_post"><div class="thread_post_header"><b>He is also rated as having the best week by Football Outsiders </b><a name="15401072"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=mikeinbloomfield"> mikeinbloomfield </a>  :  10/6/2021  9:58 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401072">link</a>   </div></div><div class="thread_post_body">Impressive. I hope I am wrong about him. As a &#34;DJ Hater,&#34; I don&#39;t hate him. I didn&#39;t think it was the right pick. <br/>
<br/>
There are lots of ways to get a QB. Look at what the Rams did with Stafford, or Denver with Bridgewater. You have to be smart. Which is my main complaint, Gettelman. <br/>
<br/>
I don&#39;t think he&#39;s the GM for the job. If I&#39;m wrong about the DJ pick, great! One less thing to worry about. I still don&#39;t think he&#39;s the right guy to run the team. Look at our cap room, with the talent we have. Look at some of the other decisions, debated ad nauseum, that make very little sense.</div></div><div class="thread_post"><div class="thread_post_header"><b>surprised </b><a name="15401081"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=dlauster"> dlauster </a>  :  10/6/2021  10:06 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401081">link</a>   </div></div><div class="thread_post_body">I would have thought Elliot would have got it.<br/>
<br/>
But I&#39;m very happy for our QB!</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: This isn&#39;t good </b><a name="15401086"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Keaton028"> Keaton028 </a>  :  10/6/2021  10:10 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401086">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401063" target="_blank">15401063</a> bLiTz 2k said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401045 Keaton028 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15401038 Dr. D said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     for the BBI DJ master haters. <br/>
                                <br/>
                           <br/>
<br/>
I don’t get these types of comments. Does anyone really hate DJ? His detractors want to see more of this on a consistent basis. Is that really a terrible ask? We are all rooting for him regardless. It’s better for the Giants if DJ turns out to be that guy.<br/>
<br/>
Aren’t we all Giants fans in the end? This place is so clique-ish. <br/>
                                <br/>
                           <br/>
<br/>
There&#39;s a very very small sample that kinda do...and it&#39;s not your typical realists who usually have okay takes. I tend to ignore those one or two other folks </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I’m like you. There are people with extreme takes on both sides who attack others with differing opinions on a personal level. I’ll never understand it. I hope everyone roots for DJ, even if, like me, they wanna see a bigger sample size before they give full confidence to him. Sunday was a huge and fun win for him, and us as fans. I truly hope no one here was actually upset by him playing well.</div></div><div class="thread_post"><div class="thread_post_header"><b>Keep it up </b><a name="15401089"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Producer"> Producer </a>  :  10/6/2021  10:18 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401089">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>awesome </b><a name="15401097"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=AnnapolisMike"> AnnapolisMike </a>  :  10/6/2021  10:24 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401097">link</a>   </div></div><div class="thread_post_body">everyone likes to play armchair GM.  I did not like the pick of Barkley for the Giants.  But I am certainly going to root for him to play his very best as long as he is a Giant.</div></div><div class="thread_post"><div class="thread_post_header"><b>Congrats to Jones. </b><a name="15401107"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=FStubbs"> FStubbs </a>  :  10/6/2021  10:30 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401107">link</a>   </div></div><div class="thread_post_body">Hope he can build on this and grow into the QB we hope he can be.</div></div><div class="thread_post"><div class="thread_post_header"><b>Awesome!! </b><a name="15401109"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Giants86"> Giants86 </a>  :  10/6/2021  10:32 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401109">link</a>   </div></div><div class="thread_post_body">Happy for him</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: This isn&#39;t good </b><a name="15401111"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dr.+D"> Dr. D </a>  :  10/6/2021  10:35 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401111">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401045" target="_blank">15401045</a> Keaton028 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401038 Dr. D said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     for the BBI DJ master haters. <br/>
                                <br/>
                           <br/>
<br/>
I don’t get these types of comments. Does anyone really hate DJ? His detractors want to see more of this on a consistent basis. Is that really a terrible ask? We are all rooting for him regardless. It’s better for the Giants if DJ turns out to be that guy.<br/>
<br/>
Aren’t we all Giants fans in the end? This place is so clique-ish. </td>
                                </tr>
                           </tbody></table><br/>
Sorry, maybe you missed the many offseason threads where a small group here refused to acknowledge the long list of shit DJ had going against him last year (saying new coaching staff, new offense, rookies on OL, no minicamp, limited training camp, no preseason games, among league&#39;s worst WR corps, etc. were just &#34;excuses&#34;). <br/>
<br/>
They refused to acknowledge DJ ever showed any flashes and they definitively proclaimed him to be a bust (one even said something to the effect that it&#39;s bc he/they know how to evaluate a QB, unlike the rest of us). <br/>
<br/>
Most of us, just wanted to give him a little more time to prove himself (with a normal offseason, better OL and weapons, experience, etc.), one way or another. He&#39;s doing that in a good way, but I wonder if some will ever admit it or if they&#39;re enjoying it. <br/>
<br/>
It&#39;s true this small group probably doesn&#39;t &#34;hate DJ&#34; as a person, but going into this season, they sure hated that he was our QB and that&#39;s of course what I&#39;m referring to. <br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>Awesome </b><a name="15401117"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Danny+Kanell"> Danny Kanell </a>  :  10/6/2021  10:37 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401117">link</a>   </div></div><div class="thread_post_body">Well deserved. <br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: LOL </b><a name="15401120"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=eli4life"> eli4life </a>  :  10/6/2021  10:39 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401120">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400987" target="_blank">15400987</a> DannyDimes said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Jones is playing great. Andrew Thomas is playing great. Barkley had his best game of the season. <br/>
<br/>
What will the haters do with all of this? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
It’s easy all they have to do is look at the defense there’s a whole lot of things over there to bitch about</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: This isn&#39;t good </b><a name="15401124"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Ron+Johnson"> Ron Johnson </a>  :  10/6/2021  10:43 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401124">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401045" target="_blank">15401045</a> Keaton028 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401038 Dr. D said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     for the BBI DJ master haters. <br/>
                                <br/>
                           <br/>
<br/>
I don’t get these types of comments. Does anyone really hate DJ? His detractors want to see more of this on a consistent basis. Is that really a terrible ask? We are all rooting for him regardless. It’s better for the Giants if DJ turns out to be that guy.<br/>
<br/>
Aren’t we all Giants fans in the end? This place is so clique-ish. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
master haters sounds like a joke to me.  Maybe lighten up a bit</div></div><div class="thread_post"><div class="thread_post_header"><b>Congrats to Jones and also to Thomas for beginning to put it all  </b><a name="15401125"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Ira"> Ira </a>  :  10/6/2021  10:45 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401125">link</a>   </div></div><div class="thread_post_body">together at their respective positions.</div></div><div class="thread_post"><div class="thread_post_header"><b>Well deserved... </b><a name="15401126"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=KingBlue"> KingBlue </a>  :  10/6/2021  10:45 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401126">link</a>   </div></div><div class="thread_post_body">Daniel has the right stuff, the right work ethic and finally the right teammates to showcase his talents.<br/>
<br/>
We should all appreciate and enthusiastically support our QB!!</div></div><div class="thread_post"><div class="thread_post_header"><b>Clap clap </b><a name="15401128"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=5BowlsSoon"> 5BowlsSoon </a>  :  10/6/2021  10:47 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401128">link</a>   </div></div><div class="thread_post_body">Great job, Dimes.<br/>
<br/>
I hope you run a bit more though in this upcoming game. Sam Darnold did it nicely.  You are much faster than he is.</div></div><div class="thread_post"><div class="thread_post_header"><b>Great! </b><a name="15401129"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=TheEvilLurker"> TheEvilLurker </a>  :  10/6/2021  10:48 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401129">link</a>   </div></div><div class="thread_post_body">What can we trade him for?<br/>
<br/>
I keed,  I keed.<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: This isn&#39;t good </b><a name="15401130"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  :  10/6/2021  10:48 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401130">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401045" target="_blank">15401045</a> Keaton028 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401038 Dr. D said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     for the BBI DJ master haters. <br/>
                                <br/>
                           <br/>
<br/>
I don’t get these types of comments. Does anyone really hate DJ? His detractors want to see more of this on a consistent basis. Is that really a terrible ask? We are all rooting for him regardless. It’s better for the Giants if DJ turns out to be that guy.<br/>
<br/>
Aren’t we all Giants fans in the end? This place is so clique-ish. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
The problem here has always been expectations of Jones.<br/>
<br/>
Some of us believe he has a major responsibility as the QB - and a high investment - to do more. To carry the load and make chicken salad (even if the supporting cast isn&#39;t the Chiefs).<br/>
<br/>
On the other hand, the majority of posters have viewed Jones as just another piece in the offense and he&#39;ll only be as good as his supporting cast. So they take a much lighter touch with their criticism and expectations.<br/>
<br/>
At the end of the day, everyone wants Jones to be the solution. But the clock is ticking on his contract. And a vital decision is going to have to be made if Jones is indeed that solution. Hopefully, the performance in New Orleans is a sign of more good things to come...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: This isn&#39;t good </b><a name="15401150"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Keaton028"> Keaton028 </a>  :  10/6/2021  11:02 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401150">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401130" target="_blank">15401130</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401045 Keaton028 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15401038 Dr. D said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     for the BBI DJ master haters. <br/>
                                <br/>
                           <br/>
<br/>
I don’t get these types of comments. Does anyone really hate DJ? His detractors want to see more of this on a consistent basis. Is that really a terrible ask? We are all rooting for him regardless. It’s better for the Giants if DJ turns out to be that guy.<br/>
<br/>
Aren’t we all Giants fans in the end? This place is so clique-ish. <br/>
                                <br/>
                           <br/>
<br/>
The problem here has always been expectations of Jones.<br/>
<br/>
Some of us believe he has a major responsibility as the QB - and a high investment - to do more. To carry the load and make chicken salad (even if the supporting cast isn&#39;t the Chiefs).<br/>
<br/>
On the other hand, the majority of posters have viewed Jones as just another piece in the offense and he&#39;ll only be as good as his supporting cast. So they take a much lighter touch with their criticism and expectations.<br/>
<br/>
At the end of the day, everyone wants Jones to be the solution. But the clock is ticking on his contract. And a vital decision is going to have to be made if Jones is indeed that solution. Hopefully, the performance in New Orleans is a sign of more good things to come... </td>
                                </tr>
                           </tbody></table><br/>
<br/>
<br/>
Right. This is where I’m at. I actually posted a thread about the advantage of a QB on a rookie contract before the Saints game, simply because I think it’s an aspect that many fans tend to forget. <br/>
<br/>
I like DJ personally, but am yet to be sold on him as the future. However, I do root for him, and acknowledge how much easier the Giants ascent to contention would be if he IS the guy. I was extremely encouraged by the Saints game. In no way am I rooting against Jones. I think many of us hold this point of view, but I hope we aren’t targeted as being haters because our opinion is still different after 1 excellent game.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I heard on BBI that Nick Mullins might be a better QB for the Giants </b><a name="15401153"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=mfsd"> mfsd </a>  :  10/6/2021  11:02 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401153">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400982" target="_blank">15400982</a> GiantGolfer said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> How’d he do this past weekend? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
About as well as our secret franchise QB of the future Kyle Sloter<br/>
<br/>
Well done Danny, keep it up kid</div></div><div class="thread_post"><div class="thread_post_header"><b>Congrats! </b><a name="15401154"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=ZogZerg"> ZogZerg </a>  :  10/6/2021  11:02 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401154">link</a>   </div></div><div class="thread_post_body">I hope he keeps it up.</div></div><div class="thread_post"><div class="thread_post_header"><b>Excellent  </b><a name="15401162"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=cosmicj"> cosmicj </a>  :  10/6/2021  11:08 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401162">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>That’s awesome </b><a name="15401169"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dukie+Dimes"> Dukie Dimes </a>  :  10/6/2021  11:10 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401169">link</a>   </div></div><div class="thread_post_body">I’m rooting really hard for him.  He had to overcome so much criticism.  Would be amazing if he became a top tier QB.</div></div><div class="thread_post"><div class="thread_post_header"><b>. </b><a name="15401173"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=MOOPS"> MOOPS </a>  :  10/6/2021  11:12 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401173">link</a>   </div></div><div class="thread_post_body"><img src="https://gifimage.net/wp-content/uploads/2017/08/matthew-mcconaughey-alright-alright-alright-gif-11.gif"/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: This isn&#39;t good </b><a name="15401212"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=adamg"> adamg </a>  :  10/6/2021  11:33 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401212">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401045" target="_blank">15401045</a> Keaton028 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401038 Dr. D said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     for the BBI DJ master haters. <br/>
                                <br/>
                           <br/>
<br/>
I don’t get these types of comments. Does anyone really hate DJ? His detractors want to see more of this on a consistent basis. Is that really a terrible ask? We are all rooting for him regardless. It’s better for the Giants if DJ turns out to be that guy.<br/>
<br/>
Aren’t we all Giants fans in the end? This place is so clique-ish. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Sounds like you are one of the master haters.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: This isn&#39;t good </b><a name="15401222"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Keaton028"> Keaton028 </a>  :  10/6/2021  11:39 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401222">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401212" target="_blank">15401212</a> adamg said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401045 Keaton028 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15401038 Dr. D said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     for the BBI DJ master haters. <br/>
                                <br/>
                           <br/>
<br/>
I don’t get these types of comments. Does anyone really hate DJ? His detractors want to see more of this on a consistent basis. Is that really a terrible ask? We are all rooting for him regardless. It’s better for the Giants if DJ turns out to be that guy.<br/>
<br/>
Aren’t we all Giants fans in the end? This place is so clique-ish. <br/>
                                <br/>
                           <br/>
<br/>
Sounds like you are one of the master haters. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Haha, you got me.</div></div><div class="thread_post"><div class="thread_post_header"><b>Does he have escalators for awards like this </b><a name="15401232"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=MotownGIANTS"> MotownGIANTS </a>  :  10/6/2021  11:52 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401232">link</a>   </div></div><div class="thread_post_body">in his contract?</div></div><div class="thread_post"><div class="thread_post_header"><b>Congratulations and well deserved. </b><a name="15401242"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=short+lease"> short lease </a>  :  10/6/2021  12:02 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401242">link</a>   </div></div><div class="thread_post_body">Won&#39;t be his last either.<br/>
<br/>
If the OL keeps improving (does Thomas go to the pro-bowl this year? - I know that question was asked very early) our &#34;bust&#34; of a QB might just have a career with the Giants.<br/>
<br/>
; )<br/>
<br/>
<br/>
And we can use our 2 first round picks on another Olineman and a stud on defense (depending where the talent lies).</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: awesome </b><a name="15401246"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Alan+W"> Alan W </a>  :  10/6/2021  12:06 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401246">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401097" target="_blank">15401097</a> AnnapolisMike said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> everyone likes to play armchair GM.  I did not like the pick of Barkley for the Giants.  But I am certainly going to root for him to play his very best as long as he is a Giant. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Everyone? Not me. I&#39;m for leaving it up to folks with experience, insight and the future in mind.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: LOL </b><a name="15401247"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=short+lease"> short lease </a>  :  10/6/2021  12:06 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401247">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400994" target="_blank">15400994</a> BSIMatt said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15400987 DannyDimes said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Jones is playing great. Andrew Thomas is playing great. Barkley had his best game of the season. <br/>
<br/>
What will the haters do with all of this? <br/>
                                <br/>
                           <br/>
<br/>
Jones, Thomas, Barkley, Toney..4 consecutive first rounders, were among the best players on the field for either team Sunday. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I am shocked ... I heard Gettleman was a moron and these players were busts  ... or in Barkley&#39;s case - to high of a pick (RBs can be had in later rounds).<br/>
<br/>
1 game - must have been a fluke.<br/>
<br/>
<br/>
<br/>
[sarcasm /off]</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: awesome </b><a name="15401248"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=short+lease"> short lease </a>  :  10/6/2021  12:07 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401248">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401246" target="_blank">15401246</a> Alan W said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401097 AnnapolisMike said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     everyone likes to play armchair GM.  I did not like the pick of Barkley for the Giants.  But I am certainly going to root for him to play his very best as long as he is a Giant. <br/>
                                <br/>
                           <br/>
<br/>
Everyone? Not me. I&#39;m for leaving it up to folks with experience, insight and the future in mind. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
<br/>
+1 <br/>
<br/>
Not me either.</div></div><div class="thread_post"><div class="thread_post_header"><b>Well deserved </b><a name="15401270"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=HomerJones45"> HomerJones45 </a>  :  10/6/2021  12:26 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401270">link</a>   </div></div><div class="thread_post_body">He looked like he was in command on Sunday</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Well deserved </b><a name="15401275"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Brown_Hornet"> Brown_Hornet </a>  :  10/6/2021  12:29 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401275">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401270" target="_blank">15401270</a> HomerJones45 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> He looked like he was in command on Sunday </td>
                                </tr>
                           </tbody></table> Something I noticed, when they would give a close up during cadence, is how relax he was.<br/>
The moment is not too big for him.<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: This isn&#39;t good </b><a name="15401357"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dr.+D"> Dr. D </a>  :  10/6/2021  1:35 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401357">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401130" target="_blank">15401130</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
<br/>
On the other hand, the majority of posters have viewed Jones as just another piece in the offense and he&#39;ll only be as good as his supporting cast. So they take a much lighter touch with their criticism and expectations.</td>
                                </tr>
                           </tbody></table><br/>
I don&#39;t think ANYONE thinks Jones or any QB is &#34;just another piece in the offense&#34;. EVERYONE knows that the QB is clearly the most important piece of an offense. But it&#39;s still a team game and plenty of good to great QBs haven&#39;t looked so good on shitty teams, especially in their first year or two in the league when they&#39;re still developing.</div></div><div class="thread_post"><div class="thread_post_header"><b>It&#39;s  </b><a name="15401379"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=mittenedman"> mittenedman </a>  :  10/6/2021  1:53 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401379">link</a>   </div></div><div class="thread_post_body">great to see him stacking good performances and putting the doubters to bed. Must feel good to receive recognition after what he&#39;s been through, starting with draft night.<br/>
<br/>
To me, it looks like he&#39;s &#34;trimmed the fat&#34; from his game and is understanding how to efficiently use his talents to win. When he moves now, he&#39;s not just in a mad dash to the sideline - you can see him methodically stressing the D and knowing when to buy time. He&#39;s likely still learning, and can be a big problem for NFL defenses. <br/>
<br/>
It&#39;s interesting to consider how high his ceiling is. He&#39;s never had a solid group of skill players to grow with. He&#39;s starting to build chemistry with KG, Shepard, Slayton, Barkley &amp; Toney. Also seems to like throwing to Ross. Nice arsenal, if he&#39;s locked in with everybody.</div></div><div class="thread_post"><div class="thread_post_header"><b>I called this in the game thread </b><a name="15401388"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=montanagiant"> montanagiant </a>  :  10/6/2021  2:07 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401388">link</a>   </div></div><div class="thread_post_body">~ twisting my arm while patting myself on the back~</div></div><div class="thread_post"><div class="thread_post_header"><b>Dr. D </b><a name="15401424"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=manh+george"> manh george </a>  :  10/6/2021  2:40 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401424">link</a>   </div></div><div class="thread_post_body">On your list of shitshow parts around Jones, you left out the complete lack of a running game or a rb to throw screens to. And a defense not good enough to give the offense a rest.  It was quite a list of negatives.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Dr. D </b><a name="15401460"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dr.+D"> Dr. D </a>  :  10/6/2021  3:24 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401460">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401424" target="_blank">15401424</a> manh george said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> On your list of shitshow parts around Jones, you left out the complete lack of a running game or a rb to throw screens to. And a defense not good enough to give the offense a rest.  It was quite a list of negatives. </td>
                                </tr>
                           </tbody></table><br/>
yeah, I thought about RB, but thought I listed enough for the point to be made. But then again, I&#39;ve listed this shit quite a few times in these types of threads and the same people still never acknowledged any of it.</div></div><div class="thread_post"><div class="thread_post_header"><b>What i most appreciated about this performance </b><a name="15401514"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=DavidinBMNY"> DavidinBMNY </a>  :  10/6/2021  4:04 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401514">link</a>   </div></div><div class="thread_post_body">Is Jones went from a player who wasn&#39;t causing us to lose, to a player who did cause us to win.   It&#39;s a team sport and Barkely, Ross, Golladay and the OL all had huge parts, but that was a get over the hump moment from my perspective.  As others have said he deserves this and it&#39;s great for the whole franchise too.   Let&#39;s see it again this Sunday!</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: This isn&#39;t good </b><a name="15401516"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dr.+D"> Dr. D </a>  :  10/6/2021  4:07 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401516">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401130" target="_blank">15401130</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
The problem here has always been expectations of Jones.<br/>
<br/>
Some of us believe he has a major responsibility as the QB - and a high investment - to do more.  </td>
                                </tr>
                           </tbody></table><br/>
I don&#39;t think you really understand what the problem has been. Our ultimate expectations are probably not that different. I don&#39;t think any Giants fan would be happy if Jones turned out to be a mid to lower tier QB. <br/>
<br/>
The difference is some of us recognized the flashes he&#39;s showed, especially his rookie year, along with the long list of shit going against him last year (see above), in addition to the fact he&#39;s still developing, etc. and therefore thought it was wise to give him a little more time to prove himself (with a normal offseason, more experience, talent, etc.). <br/>
<br/>
Some didn&#39;t recognize or acknowledge those facts and made up their minds already. That&#39;s the problem; in a nutshell.</div></div><div class="thread_post"><div class="thread_post_header"><b>Congratulations to DJ, it was well deserved </b><a name="15401522"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=csh2z"> csh2z </a>  :  10/6/2021  4:16 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401522">link</a>   </div></div><div class="thread_post_body">I can see a comparison to guys like Stafford. He has had a very difficult career in Detroit that made him look bad for many years. Look how he is doing with a real team around him. What a turnaround.</div></div><div class="thread_post"><div class="thread_post_header"><b>He  </b><a name="15401526"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Les+in+TO"> Les in TO </a>  :  10/6/2021  4:24 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401526">link</a>   </div></div><div class="thread_post_body">Was huge on Sunday and cold blooded in OT. Looked more like the Jedi the Giants needed not a JAG. And he had great chemistry with Ross and Toney despite limited first team reps</div></div><div class="thread_post"><div class="thread_post_header"><b>Kent Graham also won this award twice, </b><a name="15401549"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=State+Your+Name"> State Your Name </a>  :  10/6/2021  4:46 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401549">link</a>   </div></div><div class="thread_post_body">so...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Kent Graham also won this award twice, </b><a name="15401554"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BigBlueShock"> BigBlueShock </a>  :  10/6/2021  4:48 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401554">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401549" target="_blank">15401549</a> State Your Name said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> so... </td>
                                </tr>
                           </tbody></table><br/>
I’ll bet you’re a real blast at parties…</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: This isn&#39;t good </b><a name="15401561"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=section125"> section125 </a>  :  10/6/2021  5:00 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401561">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401130" target="_blank">15401130</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
On the other hand, the majority of posters have viewed Jones as just another piece in the offense and he&#39;ll only be as good as his supporting cast. So they take a much lighter touch with their criticism and expectations.<br/>
<br/>
At the end of the day, everyone wants Jones to be the solution. But the clock is ticking on his contract. And a vital decision is going to have to be made if Jones is indeed that solution. Hopefully, the performance in New Orleans is a sign of more good things to come... </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I will give you credit. At least you showed up even if to shed a little shade.<br/>
One game does not make a franchise QB. It just does not.<br/>
<br/>
However, he made those deep out throws you said he could not. <br/>
<br/>
Now that the line gave him time to set up, read and throw he looked very good. He is not Mahomes, Rodgers or Allen. He is not nor will he ever be a top 5 QB. But he can be a top 10 QB and probably is close to it npw.<br/>
<br/>
What I find fascinating is that in one week, he was able to get on the same page as Golladay, Toney and Ross.<br/>
<br/>
Please dear Lord, let Jason Garrett keep letting him open up the offense.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I look forward to hearing… </b><a name="15401585"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=steve+in+ky"> steve in ky </a>  :  10/6/2021  5:41 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401585">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15400981" target="_blank">15400981</a> Chris in Philly said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> from the “fans” who refuse to even admit he had one good game because being right on an anonymous message board is the only thing that matters to them. And likewise, I look forward to the inevitable subsequent twisting of words that leads to “is one good game enough for you?”, which is done to obfuscate away the first point. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Don’t hold your breath but at least we may have seen the last of the suggestions that perhaps Glennon should start at some point.</div></div><div class="thread_post"><div class="thread_post_header"><b>section 125... </b><a name="15401591"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  :  10/6/2021  5:55 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401591">link</a>   </div></div><div class="thread_post_body"><br/>
When I say deep throws, I mean the throwing the deep out. That is not in Jones&#39;s repertoire. But I have given him credit for throwing a deep ball between the numbers. He&#39;s shown good touch and timing on that.<br/>
<br/>
Look, you have to give Jones credit where credit is due. He did his job Sunday - played like a franchise QB. Hopefully it&#39;s a watershed moment that leads to more of these performances.<br/>
<br/>
My concern for him, though, is what we are seeing is largely a dependent QB. A QB who can play well when he&#39;s surrounded by a large mix of the right talent. <br/>
<br/>
But lots of NFL QBs can look good with more talent to use. When you can&#39;t replenish the talent (free agent departures, injuries, draft struggles, etc), however, can Jones make his surrounding cast better? Because, that to me, is the characteristic/skill you want if you are guying to play a QB big dollars...<br/>
<br/>
<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>Hasn&#39;t this pendulum </b><a name="15401595"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Thegratefulhead"> Thegratefulhead </a>  :  10/6/2021  6:00 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401595">link</a>   </div></div><div class="thread_post_body">Swung enough yet?<br/>
<br/>
I have been all over the place on Jones.<br/>
<br/>
I thought he would have real success this year and then through 3 games he still looked meh.<br/>
<br/>
Stats are better...for sure.<br/>
<br/>
He just wasn&#39;t being the &#34;guy&#34;<br/>
<br/>
He looked the part in New Orleans.<br/>
<br/>
If he keeps doing that, we are in a great spot, those 2 picks early next could turn us into a legit contender.<br/>
<br/>
Potentially great news.<br/>
<br/>
He could fumble against air in the red zone next week and be the reason we lost.<br/>
<br/>
Wait before declaring victory or defeat on your Jones prognostication.<br/>
<br/>
No matter what happens you will not be right because of your football acumen.<br/>
<br/>
If Jones ends up a great and you thought that from the beginning, you were just lucky and vice versa.<br/>
<br/>
I having been reading this forum for over a decade.  All of us are wrong all the fucking time.  The only thing I am certain of is we are all full of shit.<br/>
<br/>
Some more than others, mileage may vary.<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: section 125... </b><a name="15401597"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BigBlueShock"> BigBlueShock </a>  :  10/6/2021  6:09 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401597">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401591" target="_blank">15401591</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
<br/>
My concern for him, though, is what we are seeing is largely a dependent QB. A QB who can play well when he&#39;s surrounded by a large mix of the right talent. <br/>
<br/>
<br/>
<br/>
 </td>
                                </tr>
                           </tbody></table><br/>
Wait. So now Jones is suddenly playing with “a large mix of the right talent”? Wow. That changed quickly.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: section 125... </b><a name="15401604"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Zeke%27s+Alibi"> Zeke&#39;s Alibi </a>  :  10/6/2021  6:20 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401604">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401597" target="_blank">15401597</a> BigBlueShock said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401591 bw in dc said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
<br/>
My concern for him, though, is what we are seeing is largely a dependent QB. A QB who can play well when he&#39;s surrounded by a large mix of the right talent. <br/>
<br/>
<br/>
<br/>
 <br/>
                                <br/>
                           <br/>
Wait. So now Jones is suddenly playing with “a large mix of the right talent”? Wow. That changed quickly. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
It’s almost like he’s doing all this with a line that can block and some all star cast of pass catchers.  Our tight end group is terrible and we have zero run game (which is affecting our ability to score in the red zone).<br/>
<br/>
Right now there’s only one guy we can say for sure is productive with little talent around him.  It’s Aaron Rogers.   Everyone else that is producing has talent around him.<br/>
<br/>
DJs yards and completion percentage vs expected in pass game is top 5-8.   It’s one of those nexgen advanced statistics that uses comparable situations as far as separation and yards down field into account. <br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: section 125... </b><a name="15401609"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  :  10/6/2021  6:33 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401609">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401597" target="_blank">15401597</a> BigBlueShock said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401591 bw in dc said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
<br/>
My concern for him, though, is what we are seeing is largely a dependent QB. A QB who can play well when he&#39;s surrounded by a large mix of the right talent. <br/>
<br/>
<br/>
<br/>
 <br/>
                                <br/>
                           <br/>
Wait. So now Jones is suddenly playing with “a large mix of the right talent”? Wow. That changed quickly. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Compared to last year - yes.<br/>
<br/>
It looks like KG is starting to live up to his billing as a #1, SB is looking healthier, Toney looked the part Sunday, Shep is a terrific slot WR (when healthy), EE/Rudolph, etc.<br/>
<br/>
I mean, that was the plan going into the off-season. Which was clearly stated by John Mara.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: section 125... </b><a name="15401614"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BigBlueShock"> BigBlueShock </a>  :  10/6/2021  6:41 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401614">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401604" target="_blank">15401604</a> Zeke&#39;s Alibi said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401597 BigBlueShock said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15401591 bw in dc said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
<br/>
My concern for him, though, is what we are seeing is largely a dependent QB. A QB who can play well when he&#39;s surrounded by a large mix of the right talent. <br/>
<br/>
<br/>
<br/>
 <br/>
                                <br/>
                           <br/>
Wait. So now Jones is suddenly playing with “a large mix of the right talent”? Wow. That changed quickly. <br/>
                                <br/>
                           <br/>
<br/>
It’s almost like he’s doing all this with a line that can block and some all star cast of pass catchers.  Our tight end group is terrible and we have zero run game (which is affecting our ability to score in the red zone).<br/>
<br/>
Right now there’s only one guy we can say for sure is productive with little talent around him.  It’s Aaron Rogers.   Everyone else that is producing has talent around him.<br/>
<br/>
DJs yards and completion percentage vs expected in pass game is top 5-8.   It’s one of those nexgen advanced statistics that uses comparable situations as far as separation and yards down field into account. <br/>
 </td>
                                </tr>
                           </tbody></table><br/>
It’s absolutely mind boggling. The same guys that want Gettleman fired ASAP because the Giants have a bottom 5 roster (that’s been repeated many times) are now crediting Jones’ success on the talent around him. You simply cannot make this stuff up. The OL is made up of other teams’ failed castoffs and two failed draft picks (according to some posters here). They are on their 4th RG. The TEs are the worst in the league. The starting WR corp were without two of their top 3 WRs. <br/>
<br/>
I’ll bet every QB in the league would be licking their chops to play with the immense talent Jones has gotten to play with. Next thing you know bw in dc will be campaigning for a huge Gettleman extension based on the talent he has covertly surrounded Jones with.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: section 125... </b><a name="15401617"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BigBlueShock"> BigBlueShock </a>  :  10/6/2021  6:44 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401617">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401609" target="_blank">15401609</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401597 BigBlueShock said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15401591 bw in dc said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
<br/>
My concern for him, though, is what we are seeing is largely a dependent QB. A QB who can play well when he&#39;s surrounded by a large mix of the right talent. <br/>
<br/>
<br/>
<br/>
 <br/>
                                <br/>
                           <br/>
Wait. So now Jones is suddenly playing with “a large mix of the right talent”? Wow. That changed quickly. <br/>
                                <br/>
                           <br/>
<br/>
Compared to last year - yes.<br/>
<br/>
It looks like KG is starting to live up to his billing as a #1, SB is looking healthier, Toney looked the part Sunday, Shep is a terrific slot WR (when healthy), EE/Rudolph, etc.<br/>
<br/>
I mean, that was the plan going into the off-season. Which was clearly stated by John Mara. </td>
                                </tr>
                           </tbody></table><br/>
Imagine what he could do with the talent that most of the other top QBs in the league have if you’re suddenly smitten with the Giants talent. Gettleman for GM of the year?</div></div><div class="thread_post"><div class="thread_post_header"><b>.... </b><a name="15401619"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BrettNYG10"> BrettNYG10 </a>  :  10/6/2021  6:45 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401619">link</a>   </div></div><div class="thread_post_body">I think the pieces surrounding Jones are around average. <br/>
<br/>
If this develops into a top ten offense, it&#39;s because Jones is good.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: .... </b><a name="15401622"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Thegratefulhead"> Thegratefulhead </a>  :  10/6/2021  6:51 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401622">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401619" target="_blank">15401619</a> BrettNYG10 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I think the pieces surrounding Jones are around average. <br/>
<br/>
If this develops into a top ten offense, it&#39;s because Jones is good. </td>
                                </tr>
                           </tbody></table>Jones looked great Sunday.  If he does more of that, this discussion goes.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: section 125... </b><a name="15401624"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  :  10/6/2021  6:54 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401624">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401614" target="_blank">15401614</a> BigBlueShock said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
I’ll bet every QB in the league would be licking their chops to play with the immense talent Jones has gotten to play with. Next thing you know bw in dc will be campaigning for a huge Gettleman extension based on the talent he has covertly surrounded Jones with. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
The phrase I used was &#34;right mix of talent&#34;. Not &#34;immense talent&#34;.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: .... </b><a name="15401629"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BigBlueShock"> BigBlueShock </a>  :  10/6/2021  6:57 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401629">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401622" target="_blank">15401622</a> Thegratefulhead said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401619 BrettNYG10 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     I think the pieces surrounding Jones are around average. <br/>
<br/>
If this develops into a top ten offense, it&#39;s because Jones is good. <br/>
                                <br/>
                           Jones looked great Sunday.  If he does more of that, this discussion goes. </td>
                                </tr>
                           </tbody></table><br/>
Apparently not. bw has already laid the groundwork that Jones is only successful because of the “right mix of talent” around him. So if he thrives, we’re gonna have to wait until the talent around him sucks to be able to judge how good he really is.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: section 125... </b><a name="15401630"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  :  10/6/2021  6:57 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401630">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401617" target="_blank">15401617</a> BigBlueShock said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">   <br/>
<br/>
Compared to last year - yes.<br/>
<br/>
It looks like KG is starting to live up to his billing as a #1, SB is looking healthier, Toney looked the part Sunday, Shep is a terrific slot WR (when healthy), EE/Rudolph, etc.<br/>
<br/>
I mean, that was the plan going into the off-season. Which was clearly stated by John Mara. <br/>
                                <br/>
                           <br/>
Imagine what he could do with the talent that most of the other top QBs in the league have if you’re suddenly smitten with the Giants talent. Gettleman for GM of the year? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
We invested in improving the offense from last year. And it looks like we may have. This isn&#39;t some controversial POV. <br/>
<br/>
But we are still only averaging 20PPG, 23rd in the league. So there is much more improvement needed. Which is why Jones needs to make last Sunday more the rule rather than the exception.</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="15401635"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=SFGFNCGiantsFan"> SFGFNCGiantsFan </a>  :  10/6/2021  7:01 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401635">link</a>   </div></div><div class="thread_post_body">Well deserved. He was terrific in NOLA.</div></div><div class="thread_post"><div class="thread_post_header"><b>Such a strange argument </b><a name="15401636"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  :  10/6/2021  7:01 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401636">link</a>   </div></div><div class="thread_post_body">what top QBs play for teams that didn’t invest in weapons? Pretty sure Brady went to Tampa because they were loaded and then they added to it. Mahomes gets whatever he wants. Diggs completely changed the Buffalo offense. Burrow lobbied for his WR over an LT despite blowing his knee out.<br/>
<br/>
This is getting old. Give props to Jones and move on.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: section 125... </b><a name="15401637"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BigBlueShock"> BigBlueShock </a>  :  10/6/2021  7:01 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401637">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401624" target="_blank">15401624</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401614 BigBlueShock said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
I’ll bet every QB in the league would be licking their chops to play with the immense talent Jones has gotten to play with. Next thing you know bw in dc will be campaigning for a huge Gettleman extension based on the talent he has covertly surrounded Jones with. <br/>
                                <br/>
                           <br/>
<br/>
The phrase I used was &#34;right mix of talent&#34;. Not &#34;immense talent&#34;. </td>
                                </tr>
                           </tbody></table> <br/>
I know what you said. And it’s the case for every QB in the league. Are there any top 10 QBs in this league that would willingly swap their OL, WRs and TEs all for what Jones has had?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: section 125... </b><a name="15401639"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=chick310"> chick310 </a>  :  10/6/2021  7:03 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401639">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401614" target="_blank">15401614</a> BigBlueShock said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401604 Zeke&#39;s Alibi said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15401597 BigBlueShock said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15401591 bw in dc said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
<br/>
My concern for him, though, is what we are seeing is largely a dependent QB. A QB who can play well when he&#39;s surrounded by a large mix of the right talent. <br/>
<br/>
<br/>
<br/>
 <br/>
                                <br/>
                           <br/>
Wait. So now Jones is suddenly playing with “a large mix of the right talent”? Wow. That changed quickly. <br/>
                                <br/>
                           <br/>
<br/>
It’s almost like he’s doing all this with a line that can block and some all star cast of pass catchers.  Our tight end group is terrible and we have zero run game (which is affecting our ability to score in the red zone).<br/>
<br/>
Right now there’s only one guy we can say for sure is productive with little talent around him.  It’s Aaron Rogers.   Everyone else that is producing has talent around him.<br/>
<br/>
DJs yards and completion percentage vs expected in pass game is top 5-8.   It’s one of those nexgen advanced statistics that uses comparable situations as far as separation and yards down field into account. <br/>
 <br/>
                                <br/>
                           <br/>
It’s absolutely mind boggling. The same guys that want Gettleman fired ASAP because the Giants have a bottom 5 roster (that’s been repeated many times) are now crediting Jones’ success on the talent around him. You simply cannot make this stuff up. The OL is made up of other teams’ failed castoffs and two failed draft picks (according to some posters here). They are on their 4th RG. The TEs are the worst in the league. The starting WR corp were without two of their top 3 WRs. <br/>
<br/>
 </td>
                                </tr>
                           </tbody></table><br/>
<br/>
For a Bottom 5 roster, someone seems to be making money since we are slammed up against the cap.<br/>
<br/>
And isn&#39;t that Running Back a #2 overall pick? <br/>
Isn&#39;t that Left Tackle a #4 overall pick?  <br/>
Isn&#39;t that free agent WR Golladay like the 7th highest paid WR? <br/>
Isn&#39;t our Tight End group the 4th highest paid in the NFL?<br/>
Didn&#39;t the Giants just add one the top WRs in the entire 2021 draft?<br/>
<br/>
Mind boggling is correct.  And Giant fans suck too, right?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: .... </b><a name="15401641"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  :  10/6/2021  7:05 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401641">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401629" target="_blank">15401629</a> BigBlueShock said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
Apparently not. bw has already laid the groundwork that Jones is only successful because of the “right mix of talent” around him. So if he thrives, we’re gonna have to wait until the talent around him sucks to be able to judge how good he really is. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
So if you owned the team, you wouldn&#39;t consider that variable when deciding whether to pay Jones going forward? <br/>
<br/>
You would just say, &#34;It&#39;s all Jones. He&#39;s the primary difference maker...He can make chicken salad...&#34;</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Such a strange argument </b><a name="15401644"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  :  10/6/2021  7:09 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401644">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401636" target="_blank">15401636</a> UConn4523 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> what top QBs play for teams that didn’t invest in weapons? Pretty sure Brady went to Tampa because they were loaded and then they added to it. Mahomes gets whatever he wants. Diggs completely changed the Buffalo offense. Burrow lobbied for his WR over an LT despite blowing his knee out.<br/>
<br/>
This is getting old. Give props to Jones and move on. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I did give Jones props.<br/>
<br/>
Carve Brady out. His situation as a 44 year old only chasing titles to improve his legend doesn&#39;t really apply.<br/>
<br/>
I agree with what you wrote. But do you have ANY doubt - any - that those aforementioned QBs would be great anywhere?</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="15401645"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=SFGFNCGiantsFan"> SFGFNCGiantsFan </a>  :  10/6/2021  7:11 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401645">link</a>   </div></div><div class="thread_post_body">Eh, didn&#39;t Allen struggle until Buffalo got Diggs? <br/>
<br/>
QBs need weapons. Yes, some QBs would be good wherever...Mahomes comes to mind. But is Patrick Mahomes THE Patrick Mahomes if he&#39;s in Miami &amp; doesn&#39;t have Reid as a coach &amp; all those weapons the Chiefs have? I&#39;d bet no.</div></div><div class="thread_post"><div class="thread_post_header"><b>Not sure </b><a name="15401649"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  :  10/6/2021  7:16 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401649">link</a>   </div></div><div class="thread_post_body">but it also doesn’t matter. If it took Jones 2.5 season and some better players to become good, who cares?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: section 125... </b><a name="15401653"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=chick310"> chick310 </a>  :  10/6/2021  7:18 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401653">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401639" target="_blank">15401639</a> chick310 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401614 BigBlueShock said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15401604 Zeke&#39;s Alibi said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15401597 BigBlueShock said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15401591 bw in dc said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
<br/>
My concern for him, though, is what we are seeing is largely a dependent QB. A QB who can play well when he&#39;s surrounded by a large mix of the right talent. <br/>
<br/>
<br/>
<br/>
 <br/>
                                <br/>
                           <br/>
Wait. So now Jones is suddenly playing with “a large mix of the right talent”? Wow. That changed quickly. <br/>
                                <br/>
                           <br/>
<br/>
It’s almost like he’s doing all this with a line that can block and some all star cast of pass catchers.  Our tight end group is terrible and we have zero run game (which is affecting our ability to score in the red zone).<br/>
<br/>
Right now there’s only one guy we can say for sure is productive with little talent around him.  It’s Aaron Rogers.   Everyone else that is producing has talent around him.<br/>
<br/>
DJs yards and completion percentage vs expected in pass game is top 5-8.   It’s one of those nexgen advanced statistics that uses comparable situations as far as separation and yards down field into account. <br/>
 <br/>
                                <br/>
                           <br/>
It’s absolutely mind boggling. The same guys that want Gettleman fired ASAP because the Giants have a bottom 5 roster (that’s been repeated many times) are now crediting Jones’ success on the talent around him. You simply cannot make this stuff up. The OL is made up of other teams’ failed castoffs and two failed draft picks (according to some posters here). They are on their 4th RG. The TEs are the worst in the league. The starting WR corp were without two of their top 3 WRs. <br/>
<br/>
 <br/>
                                <br/>
                           <br/>
<br/>
For a Bottom 5 roster, someone seems to be making money since we are slammed up against the cap.<br/>
<br/>
And isn&#39;t that Running Back a #2 overall pick? <br/>
Isn&#39;t that Left Tackle a #4 overall pick?  <br/>
Isn&#39;t that free agent WR Golladay like the 7th highest paid WR? <br/>
Isn&#39;t our Tight End group the 4th highest paid in the NFL?<br/>
Didn&#39;t the Giants just add one the top WRs in the entire 2021 draft?<br/>
<br/>
Mind boggling is correct.  And Giant fans suck too, right? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Oh, and does everybody know we are #2 in positional spending at Running Back in the entire league only behind the Titans?<br/>
<br/>
Very glad to see Jones doing well. He has put in his time and now needs to deliver.  And he certainly has some high priced players and top draft picks all around him as noted above.<br/>
<br/>
We need to win something before he becomes another high price tag.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: .... </b><a name="15401661"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BigBlueShock"> BigBlueShock </a>  :  10/6/2021  7:30 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401661">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401641" target="_blank">15401641</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401629 BigBlueShock said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
Apparently not. bw has already laid the groundwork that Jones is only successful because of the “right mix of talent” around him. So if he thrives, we’re gonna have to wait until the talent around him sucks to be able to judge how good he really is. <br/>
                                <br/>
                           <br/>
<br/>
So if you owned the team, you wouldn&#39;t consider that variable when deciding whether to pay Jones going forward? <br/>
<br/>
You would just say, &#34;It&#39;s all Jones. He&#39;s the primary difference maker...He can make chicken salad...&#34; </td>
                                </tr>
                           </tbody></table><br/>
It’s not all Jones. I’ve been a critic of Jones at times too. I just think it’s ludicrous that you’re now giving credit to all the talent around him when the talent he has around him is likely less than league average. Again, you never answered so I’ll ask again. What too 10 QB would willingly change places with Jones right now? Every single one of them plays with talented players around them. Every one. Exactly which QB is rolling out there with zero weapons and a dumpster fire of an OL and leading his team to victories all by himself?<br/>
<br/>
Also again, if you honestly think Jones has all this talent around him, why have I not seen you giving any credit to your nemesis, Dave Gettleman?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Not sure </b><a name="15401662"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  :  10/6/2021  7:30 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401662">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401649" target="_blank">15401649</a> UConn4523 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> but it also doesn’t matter. If it took Jones 2.5 season and some better players to become good, who cares? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
It matters when we reach that pivotal point of a new contract. And we are getting closer to that point with Jones. <br/>
<br/>
The Rams thought they had their solution with Goff based on his production with quality talent. And then they didn&#39;t. <br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>I think McVay knew they didn’t </b><a name="15401663"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  :  10/6/2021  7:37 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401663">link</a>   </div></div><div class="thread_post_body">but was to green to have much say. and it was the run game that helped Goff. Once Gurley got hurt it became a 1 dimensional offense, something Jones is playing in right now to an extent.<br/>
<br/>
Gurley/Woods/Kupp + that OL is much better than what Jones is working with. Completely fine to still be skeptical but should Jones be extended I would want and expect the Giants to still invest in the offense. Just like Buffalo has done and will continue to do with Allen.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: ... </b><a name="15401669"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  :  10/6/2021  7:41 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401669">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401645" target="_blank">15401645</a> SFGFNCGiantsFan said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Eh, didn&#39;t Allen struggle until Buffalo got Diggs? <br/>
<br/>
QBs need weapons. Yes, some QBs would be good wherever...Mahomes comes to mind. But is Patrick Mahomes THE Patrick Mahomes if he&#39;s in Miami &amp; doesn&#39;t have Reid as a coach &amp; all those weapons the Chiefs have? I&#39;d bet no. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I agree that QBs need weapons. <br/>
<br/>
But that&#39;s not really my point. It&#39;s how do evaluate your QB for the next, bigger contract? Are they a real difference maker or a QB that can only be as good as the quality surrounding him?<br/>
<br/>
Do you know why the Chiefs nearly paid Mahomes a half billion dollars? It&#39;s because they are convinced he&#39;s good enough to make his team better. That&#39;s why the Bills just paid Allen a quarter billion dollars. They are convinced he has the skills to make his team better.</div></div><div class="thread_post"><div class="thread_post_header"><b>If Daniel Jones  </b><a name="15401673"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Producer"> Producer </a>  :  10/6/2021  7:45 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401673">link</a>   </div></div><div class="thread_post_body">has 12 more games close to or beyond last week, nobody&#39;s gonna argue about the 5th year and talk of extension. <br/>
<br/>
But if he has 5 clunkers the rest of the way. The argument will continue.</div></div><div class="thread_post"><div class="thread_post_header"><b>Right and I’ve been arguing the whole time </b><a name="15401675"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  :  10/6/2021  7:47 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401675">link</a>   </div></div><div class="thread_post_body">that Jones isn’t worth that nor would he get it. I broke down the extensions on another thread and the best comp when taking into account production + situation is Tannehill and his guaranteed money was low (50% of the contract). He also got that because he got them to the playoffs and won a game. There’s no point of discussing $250m extensions, he isn’t getting close to that unless something completely unforeseen happens and he has a monster season catapulting us to the playoffs.<br/>
<br/>
So I’m not really sure what the question is. He needs better talent to succeed, there’s no shame in that. That doesn’t mean we are now going to pay him $35m per year.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: .... </b><a name="15401677"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  :  10/6/2021  7:48 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401677">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401661" target="_blank">15401661</a> BigBlueShock said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">              <br/>
It’s not all Jones. I’ve been a critic of Jones at times too. I just think it’s ludicrous that you’re now giving credit to all the talent around him when the talent he has around him is likely less than league average. Again, you never answered so I’ll ask again. What too 10 QB would willingly change places with Jones right now? Every single one of them plays with talented players around them. Every one. Exactly which QB is rolling out there with zero weapons and a dumpster fire of an OL and leading his team to victories all by himself?<br/>
<br/>
Also again, if you honestly think Jones has all this talent around him, why have I not seen you giving any credit to your nemesis, Dave Gettleman? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I&#39;m not giving all the credit to the influx of talent Jones has. I really don&#39;t know - yet - how much is Jones and how much is the talent. But Jones looks to be playing better than last year.<br/>
<br/>
Your question is a bit silly because I have no problem seeing a great QB coming into this team and demonstrating the ability to get the absolute most out of the surrounding talent. And then we would hear a cacophony of &#34;Gee, I didn&#39;t realize how good some of our players are...&#34; That&#39;s what great players can do...</div></div><div class="thread_post"><div class="thread_post_header"><b>I think most of us are skeptical still </b><a name="15401679"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BigBlueShock"> BigBlueShock </a>  :  10/6/2021  7:50 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401679">link</a>   </div></div><div class="thread_post_body">We all need to see more. I just don’t understand this talent around him thing. Most Giants fans have gone off the rails about the OL and the Golladay contract and the terrible TEs. So let’s say he’s finally got some talent around him now. Why is the expectation that the talent will only get worse? Where? Golladay and Toney aren’t going anywhere. Neither is Thomas. I would think Barkley isn’t either but who knows. Other than that, is there anyone else in this offense that is irreplaceable and couldn’t/shouldn’t be upgraded in the next couple of seasons? Where is the fall off in talent gonna happen down the road? Every player on the OL besides Thomas can be upgraded. TE can be upgraded. WRs can be upgraded. If Jones is effective playing with this group, where is the talent drop off coming in the next few years to make us concerned? To me, at least, it seems it would be more realistic to add to the talent than the other way, I guess we shall see</div></div><div class="thread_post"><div class="thread_post_header"><b>bw in dc. </b><a name="15401680"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=SFGFNCGiantsFan"> SFGFNCGiantsFan </a>  :  10/6/2021  7:51 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401680">link</a>   </div></div><div class="thread_post_body">Solid retort. <br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>Where’s Googs? </b><a name="15401698"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Bergen346"> Bergen346 </a>  :  10/6/2021  8:34 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401698">link</a>   </div></div><div class="thread_post_body">Been silent recently</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: This isn&#39;t good </b><a name="15401699"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=EricJ"> EricJ </a>  :  10/6/2021  8:39 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401699">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401130" target="_blank">15401130</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
On the other hand, the majority of posters have viewed Jones as just another piece in the offense and he&#39;ll only be as good as his supporting cast.  </td>
                                </tr>
                           </tbody></table><br/>
<br/>
you just described Eli ..</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: This isn&#39;t good </b><a name="15401703"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=joeinpa"> joeinpa </a>  :  10/6/2021  8:48 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401703">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401130" target="_blank">15401130</a> bw in dc said:<br/>
[quote] In comment 15401045 Keaton028 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15401038 Dr. D said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     for the BBI DJ master haters. <br/>
                                <br/>
                           <br/>
<br/>
I don’t get these types of comments. Does anyone really hate DJ? His detractors want to see more of this on a consistent basis. Is that really a terrible ask? We are all rooting for him regardless. It’s better for the Giants if DJ turns out to be that guy.<br/>
<br/>
Aren’t we all Giants fans in the end? This place is so clique-ish. <br/>
                                <br/>
                           <br/>
<br/>
The problem here has always been expectations of Jones.<br/>
<br/>
Some of us believe he has a major responsibility as the QB - and a high investment - to do more. To carry the load and make chicken salad (even if the supporting cast isn&#39;t the Chiefs).<br/>
<br/>
Did you have the same expectation of Eli during the second half of his career when the Giants were mired in losing <br/>
<br/>
Not sure but I think Read your complaints about how the Giants ruin the second half of his career <br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: This isn&#39;t good </b><a name="15401706"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  :  10/6/2021  8:54 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401706">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401699" target="_blank">15401699</a> EricJ said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401130 bw in dc said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
On the other hand, the majority of posters have viewed Jones as just another piece in the offense and he&#39;ll only be as good as his supporting cast.  <br/>
                                <br/>
                           <br/>
<br/>
you just described Eli .. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
That was the Eli version from 2016 on.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: This isn&#39;t good </b><a name="15401726"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BigBlueShock"> BigBlueShock </a>  :  10/6/2021  9:32 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401726">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401706" target="_blank">15401706</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401699 EricJ said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15401130 bw in dc said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
On the other hand, the majority of posters have viewed Jones as just another piece in the offense and he&#39;ll only be as good as his supporting cast.  <br/>
                                <br/>
                           <br/>
<br/>
you just described Eli .. <br/>
                                <br/>
                           <br/>
<br/>
That was the Eli version from 2016 on. </td>
                                </tr>
                           </tbody></table><br/>
Do you have any examples of QBs that made “chicken salad” out of a terrible roster and put the team on his shoulders and single handedly lead them to a title? You seem to have a romanticized idea of what QBs are capable of when they have no talent around them. So who are the guys? Who led a terrible roster through terrible coaching and despite all that, held the Lombardi? You haven’t been able to answer any of my other questions (not surprising) so answer this one. Who has actually done that?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: If Daniel Jones  </b><a name="15401751"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dukie+Dimes"> Dukie Dimes </a>  :  10/6/2021  10:20 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401751">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401673" target="_blank">15401673</a> Producer said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> has 12 more games close to or beyond last week, nobody&#39;s gonna argue about the 5th year and talk of extension. <br/>
<br/>
But if he has 5 clunkers the rest of the way. The argument will continue. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Lol. 12 more games of 400 yards passing and 2 TDs with a comeback victory.  I don’t think you want a QB. I think you want a comics superhero.</div></div><div class="thread_post"><div class="thread_post_header"><b>BigBlueShock... </b><a name="15401753"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  :  10/6/2021  10:21 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401753">link</a>   </div></div><div class="thread_post_body">No QB has taken &#34;a terrible roster and put the team on his shoulders and single handedly lead them to a title...&#34; I have never come close to suggesting that is what I have in mind. Although what Elway did with those Broncos teams in the &#39;80s is pretty damn close. So you are distorting what I am saying.<br/>
<br/>
What I have suggested is there are QBs who can take an average-to-average-plus roster (on offense) and make it much better. See many of those Seattle teams that Wilson has played on, especially on offense, and taken deep into the playoffs. Brees and Rodgers have done similar work. Obviously Brady is the gold standard. <br/>
<br/>
And based on their physical skills, I certainly don&#39;t think it&#39;s a stretch for the Chiefs and Bills to trust their current QBs to do the same.<br/>
<br/>
Obviously you always want to build the best possible team, but these types of players give management so much margin for error in that endeavor because their QBs are force multipliers.<br/>
<br/>
Why you couldn&#39;t think of these on your own is strange...<br/>
<br/>
Which brings me back to Jones. Despite his good performance so far, I don&#39;t know if he&#39;s that force multiplier-type or QB who looks better because his supporting cast is now better. And that&#39;s going to be a very important piece to accurately evaluate him if it&#39;s decided his deserves that critical second contract...</div></div><div class="thread_post"><div class="thread_post_header"><b>really.... </b><a name="15401762"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Brown_Hornet"> Brown_Hornet </a>  :  10/6/2021  10:50 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401762">link</a>   </div></div><div class="thread_post_body">...?</div></div><div class="thread_post"><div class="thread_post_header"><b>The only award I care about is the Giants winning the Lombardi  </b><a name="15401767"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=GeofromNJ"> GeofromNJ </a>  :  10/6/2021  10:59 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401767">link</a>   </div></div><div class="thread_post_body">If DJ wins the SB MVP, I&#39;ll take that too, but it&#39;s not necessary.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: If Daniel Jones  </b><a name="15401774"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Producer"> Producer </a>  :  10/6/2021  11:14 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401774">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401751" target="_blank">15401751</a> Dukie Dimes said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401673 Producer said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     has 12 more games close to or beyond last week, nobody&#39;s gonna argue about the 5th year and talk of extension. <br/>
<br/>
But if he has 5 clunkers the rest of the way. The argument will continue. <br/>
                                <br/>
                           <br/>
<br/>
Lol. 12 more games of 400 yards passing and 2 TDs with a comeback victory.  I don’t think you want a QB. I think you want a comics superhero. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
If he puts up a bunch of stinkers in between good performances I don&#39;t want him, and neither should you.</div></div><div class="thread_post"><div class="thread_post_header"><b>Good to see this piss certain people off. </b><a name="15401779"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dave+in+Hoboken"> Dave in Hoboken </a>  :  10/6/2021  11:17 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401779">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Good to see this piss certain people off. </b><a name="15401783"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Producer"> Producer </a>  :  10/6/2021  11:23 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401783">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401779" target="_blank">15401779</a> Dave in Hoboken said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> . </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Certainly not me. I hope he&#39;s player of the week, or a contender, evwry week. He earned the distinction this week.</div></div><div class="thread_post"><div class="thread_post_header"><b>… </b><a name="15401792"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=christian"> christian </a>  :  10/6/2021  11:46 pm   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401792">link</a>   </div></div><div class="thread_post_body">I’ve always thought and believed Jones has the talent to be good not great.<br/>
<br/>
To me a great QB means any given year your QB gives you a genuine shot at a ring, no matter what else might go wrong. I don’t see that in Jones.<br/>
<br/>
Jones in my view has the ceiling of a Joe Flacco. A few plus qualities a few obvious flaws. That’s a good ceiling. If most things go well, a guy like that can deliver a ring.<br/>
<br/>
I didn’t develop doubts about Jones over a few games. It takes several games for a trend. He’s played some bad football. He’s played much better football this year, but I’m not prepared to call him a good quarterback until he puts up at least a good half of a season.</div></div><div class="thread_post"><div class="thread_post_header"><b>Dave Gettleman still needs to go. </b><a name="15401812"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=joe48"> joe48 </a>  :  10/7/2021  6:54 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401812">link</a>   </div></div><div class="thread_post_body">May have found our next QB but has not built OL. <br/>
DJ has been brutalized weekly by some posters here. Pretty clear that he has had  to play with too many sub par players. He should give Dallas problems but our defense will need to somehow play very good to win. Dallas defense will play aggressive and take chances because they feel the offense will be able to get points.<br/>
Prescott is good but because he plays in Dallas gets media praise . He has had the best supporting cast probably in the league. When Dallas running game was less than stellar he falters. I’ll take Jones on my team. <br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: … </b><a name="15401819"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=joeinpa"> joeinpa </a>  :  10/7/2021  7:23 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401819">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401792" target="_blank">15401792</a> christian said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I’ve always thought and believed Jones has the talent to be good not great.<br/>
<br/>
To me a great QB means any given year your QB gives you a genuine shot at a ring, no matter what else might go wrong. I don’t see that in Jones.<br/>
<br/>
Jones in my view has the ceiling of a Joe Flacco. A few plus qualities a few obvious flaws. That’s a good ceiling. If most things go well, a guy like that can deliver a ring.<br/>
<br/>
I didn’t develop doubts about Jones over a few games. It takes several games for a trend. He’s played some bad football. He’s played much better football this year, but I’m not prepared to call him a good quarterback until he puts up at least a good half of a season. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
<br/>
Jones is so much more athletic than Flacko, don t see that comparison at all. <br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>I don&#39;t think he&#39;s comparing him to Flacco </b><a name="15401830"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  :  10/7/2021  7:50 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401830">link</a>   </div></div><div class="thread_post_body">based on the attributes, but roughly the same amount of attributes. I understand that POV.<br/>
<br/>
That said we got to see 10+ years of Flacco and I see more potential with Jones. His rookie year alone scored more than Flacco did until year 7 and that was with Jones missing 2-3 games. Jones is more accurate as well. Flacco gets the nod in arm strength for sure but the rest is kinda TBD. He got sacked quite a bit and had his share of fumbles too. He definitely showed up in the playoffs, something we won&#39;t know about Jones until we get there, if ever.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: This isn&#39;t good </b><a name="15401956"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dr.+D"> Dr. D </a>  :  10/7/2021  10:33 am   : <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401956">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=613318&amp;show_all=1#15401516" target="_blank">15401516</a> Dr. D said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15401130 bw in dc said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
The problem here has always been expectations of Jones.<br/>
<br/>
Some of us believe he has a major responsibility as the QB - and a high investment - to do more.  <br/>
                                <br/>
                           <br/>
I don&#39;t think you really understand what the problem has been. Our ultimate expectations are probably not that different. I don&#39;t think any Giants fan would be happy if Jones turned out to be a mid to lower tier QB. <br/>
<br/>
The difference is some of us recognized the flashes he&#39;s showed, especially his rookie year, along with the long list of shit going against him last year (see above), in addition to the fact he&#39;s still developing, etc. and therefore thought it was wise to give him a little more time to prove himself (with a normal offseason, more experience, talent, etc.). <br/>
<br/>
Some didn&#39;t recognize or acknowledge those facts and made up their minds already. That&#39;s the problem; in a nutshell. </td>
                                </tr>
                           </tbody></table><br/>
Ok, maybe I was wrong. After reading more of your posts, maybe our expectations are different. I don&#39;t think it&#39;s realistic for a QB to make chicken salad out of chicken shit (especially in their 1st or 2nd seasons). Haven&#39;t seen too many examples of that, ever. <br/>
<br/>
I have seen good to great QBs look bad or mediocre on bad teams (including Eli). And I&#39;ve seen plenty of good to great QBs (even HOFers) not look so good their first year or two in the league (also including Eli). I know, can&#39;t compare... for some reason.</div></div><a name="END"></a><a href="index.php"></a><div style="padding-top:25px; padding-bottom:20px;"><a href="index.php"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"/></a></div></div>
<div class="thread_sidebar_2">

<!-- Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-102">
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Corner Forum - Lower 300x250 -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1566320450447229" data-ad-slot="4189314539" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->

</div>

</div>




<div class="footer">


<p style="width:450px;float:left;padding:10px;"><b>Part of the USA Today Sports Media Group</b><br/>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</p>
<p style="width:400px;float:right; text-align:right;padding:10px;">
All contents (unless otherwise specified) copyright ©  1995 - 2021<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br/> <br/><strong>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Solutions</a></strong>
</p>
<br clear="all"/>
 
</div>




<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->



<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=0&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script></body></html>