<!DOCTYPE html><html lang="en"><head><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-0&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-0&cb=4', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-0&cb=5', false, [], true, false, true, false);</script>
<title>Is the OL excuse a myth? | Big Blue Interactive </title>

<meta http-equiv="Pragma" content="no-cache"/>
<meta http-equiv="Expires" content="-1"/>

<meta name="keywords" content="ndglbqfkxx"/>

<meta name="description" content="I put this together for a reply in the Terps callout thread, but realize that many people may be avoiding what they assume is just a callout thread.

In any case, as we&#39;ve gone through the litany of explanations for DJ&#39;s inconsistent and/or middling performances, it seems that the only one that really remains active is that DJ is hampered by what many fans want to describe as the worst OL in football.

There are a number of metrics that can be used to track OL play, particularly as it relates to the passing game. Here are a few that I&#39;m looking at:

1) Sacks per game (since we&#39;re still in the middle of bye weeks, not every team has played the same amount of games, so per game average is more fair)

2) Sack percentage (this does not need to be altered since it is already adjusted for pass attempts)

3) Pressures per game

4) Pressure percentage

5) Hurries per game

6) Hits per game

7) Average pocket time

----------------------

SACKS PER GAME
1. Vikings (1.36)
2. Buccaneers (1.36)
3. Rams (1.55)
.
.
.
16. Giants (2.09)
.
.
.
30. Ravens (3.27)
31. Seahawks (3.30)
32. Bears (3.36)


SACK PERCENTAGE
1. Buccaneers (3.1%)
2. Vikings (3.5%)
3. Bills (3.9%)
.
.
.
14. Giants (5.6%)
.
.
.
30. Browns (8.6%)
31. Seahawks (10.3%)
32. Bears (10.7%)


PRESSURES PER GAME
1. Rams (4.8)
2. Buccaneers (5.1)
3. Patriots (6.3)
.
.
.
19. Giants (8.8)
.
.
.
30. Vikings (10.3)
31. Jets (10.4)
32. Broncos (10.5)


PRESSURE PERCENTAGE
1. Buccaneers (11.5%)
2. Rams (12.3%)
3. Steelers (16.4%)
.
.
.
16. Giants (22.1%)
.
.
.
30. Panthers (26.2%)
31. Seahawks (27.2%)
32. Broncos (28.4%)


HURRIES PER GAME
1. Patriots (1.25)
2. Rams (1.27)
3. Titans (1.33)
.
.
.
16. Giants (3.45)
.
.
.
30. Broncos (4.54)
31. Bills (4.73)
32. Vikings (4.91)


HITS PER GAME
1. Browns (1.42)
2. Cardinals (1.45)
3. Buccaneers (1.73)
.
.
.
21. Giants (3.27)
.
.
.
30. Vikings (4.00)
31. Colts (4.58)
32. Falcons (5.09)


AVERAGE POCKET TIME (in seconds)
1. Washington (2.5)
2. Eagles (2.4)
3. Seahawks (2.4)
.
.
.
13. Giants (2.2)
.
.
.
30. Texans (2.0)
31. Packers (2.0)
32. Steelers (1.9)

--------------------


If the Giants have the worst OL in football, and if DJ is being so hampered by their poor play, shouldn&#39;t the Giants be the worst in the league in at least one of these categories?

The numbers say that they&#39;re middle of the pack across the board when it comes to pass protection.

all stats drawn from pro-football-reference.
 Link   - ( New Window )"/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="website"/>
<meta property="og:description" content="I put this together for a reply in the Terps callout thread, but realize that many people may be avoiding what they assume is just a callout thread.

In any case, as we&#39;ve gone through the litany of explanations for DJ&#39;s inconsistent and/or middling performances, it seems that the only one that really remains active is that DJ is hampered by what many fans want to describe as the worst OL in football.

There are a number of metrics that can be used to track OL play, particularly as it relates to the passing game. Here are a few that I&#39;m looking at:

1) Sacks per game (since we&#39;re still in the middle of bye weeks, not every team has played the same amount of games, so per game average is more fair)

2) Sack percentage (this does not need to be altered since it is already adjusted for pass attempts)

3) Pressures per game

4) Pressure percentage

5) Hurries per game

6) Hits per game

7) Average pocket time

----------------------

SACKS PER GAME
1. Vikings (1.36)
2. Buccaneers (1.36)
3. Rams (1.55)
.
.
.
16. Giants (2.09)
.
.
.
30. Ravens (3.27)
31. Seahawks (3.30)
32. Bears (3.36)


SACK PERCENTAGE
1. Buccaneers (3.1%)
2. Vikings (3.5%)
3. Bills (3.9%)
.
.
.
14. Giants (5.6%)
.
.
.
30. Browns (8.6%)
31. Seahawks (10.3%)
32. Bears (10.7%)


PRESSURES PER GAME
1. Rams (4.8)
2. Buccaneers (5.1)
3. Patriots (6.3)
.
.
.
19. Giants (8.8)
.
.
.
30. Vikings (10.3)
31. Jets (10.4)
32. Broncos (10.5)


PRESSURE PERCENTAGE
1. Buccaneers (11.5%)
2. Rams (12.3%)
3. Steelers (16.4%)
.
.
.
16. Giants (22.1%)
.
.
.
30. Panthers (26.2%)
31. Seahawks (27.2%)
32. Broncos (28.4%)


HURRIES PER GAME
1. Patriots (1.25)
2. Rams (1.27)
3. Titans (1.33)
.
.
.
16. Giants (3.45)
.
.
.
30. Broncos (4.54)
31. Bills (4.73)
32. Vikings (4.91)


HITS PER GAME
1. Browns (1.42)
2. Cardinals (1.45)
3. Buccaneers (1.73)
.
.
.
21. Giants (3.27)
.
.
.
30. Vikings (4.00)
31. Colts (4.58)
32. Falcons (5.09)


AVERAGE POCKET TIME (in seconds)
1. Washington (2.5)
2. Eagles (2.4)
3. Seahawks (2.4)
.
.
.
13. Giants (2.2)
.
.
.
30. Texans (2.0)
31. Packers (2.0)
32. Steelers (1.9)

--------------------


If the Giants have the worst OL in football, and if DJ is being so hampered by their poor play, shouldn&#39;t the Giants be the worst in the league in at least one of these categories?

The numbers say that they&#39;re middle of the pack across the board when it comes to pass protection.

all stats drawn from pro-football-reference.
 Link   - ( New Window )"/> 
<meta property="og:title" content="Is the OL excuse a myth?"/> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif"/> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css?v=20200217"/>

<link rel="stylesheet" type="text/css" href="anylink.css"/>


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}


div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" alt="for display only">

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type="text/javascript">
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type="text/javascript" src="https://img.bnqt.com/lib/js/sdpdfphelper.js"></script>
<script type="text/javascript">
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>


<!-- End DFP SETUP -->  

<!-- End USA Today Code -->




<script type="text/javascript">var ezouid = "1";</script><base href="https://corner.bigblueinteractive.com/index.php?mode=2&thread=615448&show_all=1"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"domain_test_group":20210306,"engaged_time_visit":0,"ezcache_level":0,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"4b77f1cd-c33c-4477-7886-f4c5d6acf564","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":251442,"response_time_orig":209,"serverid":"18.209.221.132:11421","state":"VA","t_epoch":1638222219,"template_id":126,"time_on_site_visit":0,"url":"https://corner.bigblueinteractive.com/index.php?mode=2\u0026thread=615448\u0026show_all=1","user_id":0,"word_count":21651,"worst_bad_word_level":1};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["4b77f1cd-c33c-4477-7886-f4c5d6acf564", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>


<body>




<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tbody><tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"/></a> <img src="images/xpete.gif" alt="The Corner Forum"/>

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic --> 


<!-- Nov 2019 Leaderboard -->

<!-- Ezoic - Forum Leaderboard (USAT) - top_of_page -->
<div id="ezoic-pub-ad-placeholder-118">
<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->
<div id="usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general');
         });
     </script>
</div>
</div>
<!-- End Ezoic - Forum Leaderboard (USAT) - top_of_page -->



</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://www.amazon.com/?_encoding=UTF8&amp;camp=1789&amp;creative=9325&amp;linkCode=ur2&amp;tag=bigblueintera-20">Amazon.com</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW">Standings (NFL.com)</a>
<a href="https://www.giants.com/team/stats/" target="_NEW">Statistics (Giants.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/">Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</tbody></table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;home_view_menu&#39;)">Home</a>  
</li><li><a href="http://corner.bigblueinteractive.com/index.php" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;forum_view_menu&#39;)">Corner Forum</a>
</li><li><a href="http://corner.bigblueinteractive.com/index.php" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;gameday_view_menu&#39;)">Gameday</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_view_menu&#39;)">Team</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_building_view_menu&#39;)">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info & History</a> -->
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_info_view_menu&#39;)">Giants Info &amp; History</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;infolinks_view_menu&#39;)">Info/Links</a>
</li><li><a href="/index.php?mode=10" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;login_menu&#39;)">Log In</a>
</li></ul>

</div><div id="infoline"> </div>

<a name="END"></a><a href="index.php"></a><div style="padding-top:20px; padding-bottom:25px;"><a href="index.php"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"/></a></div><div class="thread_container"><div class="thread_left"><div class="thread_body"><div class="thread_main"><div class="thread_post_header">  <h1 style="font-size:18px;">Is the OL excuse a myth? </h1><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade Dunk"> Gatorade Dunk </a>  : 11:19 am</div></div><div class="thread_post_body"> I put this together for a reply in the Terps callout thread, but realize that many people may be avoiding what they assume is just a callout thread.<br/>
<br/>
In any case, as we&#39;ve gone through the litany of explanations for DJ&#39;s inconsistent and/or middling performances, it seems that the only one that really remains active is that DJ is hampered by what many fans want to describe as the worst OL in football.<br/>
<br/>
There are a number of metrics that can be used to track OL play, particularly as it relates to the passing game. Here are a few that I&#39;m looking at:<br/>
<br/>
<span class="bold">1) Sacks per game (since we&#39;re still in the middle of bye weeks, not every team has played the same amount of games, so per game average is more fair)<br/>
<br/>
2) Sack percentage (this does not need to be altered since it is already adjusted for pass attempts)<br/>
<br/>
3) Pressures per game<br/>
<br/>
4) Pressure percentage<br/>
<br/>
5) Hurries per game<br/>
<br/>
6) Hits per game<br/>
<br/>
7) Average pocket time</span><br/>
<br/>
----------------------<br/>
<br/>
<span class="bold"><span class="underline">SACKS PER GAME</span></span><br/>
1. Vikings (1.36)<br/>
2. Buccaneers (1.36)<br/>
3. Rams (1.55)<br/>
.<br/>
.<br/>
.<br/>
16. Giants (2.09)<br/>
.<br/>
.<br/>
.<br/>
30. Ravens (3.27)<br/>
31. Seahawks (3.30)<br/>
32. Bears (3.36)<br/>
<br/>
<br/>
<span class="bold"><span class="underline">SACK PERCENTAGE</span></span><br/>
1. Buccaneers (3.1%)<br/>
2. Vikings (3.5%)<br/>
3. Bills (3.9%)<br/>
.<br/>
.<br/>
.<br/>
14. Giants (5.6%)<br/>
.<br/>
.<br/>
.<br/>
30. Browns (8.6%)<br/>
31. Seahawks (10.3%)<br/>
32. Bears (10.7%)<br/>
<br/>
<br/>
<span class="bold"><span class="underline">PRESSURES PER GAME</span></span><br/>
1. Rams (4.8)<br/>
2. Buccaneers (5.1)<br/>
3. Patriots (6.3)<br/>
.<br/>
.<br/>
.<br/>
19. Giants (8.8)<br/>
.<br/>
.<br/>
.<br/>
30. Vikings (10.3)<br/>
31. Jets (10.4)<br/>
32. Broncos (10.5)<br/>
<br/>
<br/>
<span class="bold"><span class="underline">PRESSURE PERCENTAGE</span></span><br/>
1. Buccaneers (11.5%)<br/>
2. Rams (12.3%)<br/>
3. Steelers (16.4%)<br/>
.<br/>
.<br/>
.<br/>
16. Giants (22.1%)<br/>
.<br/>
.<br/>
.<br/>
30. Panthers (26.2%)<br/>
31. Seahawks (27.2%)<br/>
32. Broncos (28.4%)<br/>
<br/>
<br/>
<span class="bold"><span class="underline">HURRIES PER GAME</span></span><br/>
1. Patriots (1.25)<br/>
2. Rams (1.27)<br/>
3. Titans (1.33)<br/>
.<br/>
.<br/>
.<br/>
16. Giants (3.45)<br/>
.<br/>
.<br/>
.<br/>
30. Broncos (4.54)<br/>
31. Bills (4.73)<br/>
32. Vikings (4.91)<br/>
<br/>
<br/>
<span class="bold"><span class="underline">HITS PER GAME</span></span><br/>
1. Browns (1.42)<br/>
2. Cardinals (1.45)<br/>
3. Buccaneers (1.73)<br/>
.<br/>
.<br/>
.<br/>
21. Giants (3.27)<br/>
.<br/>
.<br/>
.<br/>
30. Vikings (4.00)<br/>
31. Colts (4.58)<br/>
32. Falcons (5.09)<br/>
<br/>
<br/>
<span class="bold"><span class="underline">AVERAGE POCKET TIME</span></span> (in seconds)<br/>
1. Washington (2.5)<br/>
2. Eagles (2.4)<br/>
3. Seahawks (2.4)<br/>
.<br/>
.<br/>
.<br/>
13. Giants (2.2)<br/>
.<br/>
.<br/>
.<br/>
30. Texans (2.0)<br/>
31. Packers (2.0)<br/>
32. Steelers (1.9)<br/>
<br/>
--------------------<br/>
<br/>
<br/>
If the Giants have the worst OL in football, and if DJ is being so hampered by their poor play, shouldn&#39;t the Giants be the worst in the league in at least one of these categories?<br/>
<br/>
The numbers say that they&#39;re middle of the pack across the board when it comes to pass protection.<br/>
<br/>
<span class="italics">all stats drawn from pro-football-reference.</span><br/>
<br/><a href="http://pfref.com/pi/share/05kcc"> Link </a>  - (<a href="http://pfref.com/pi/share/05kcc" target="_NEW"> New Window </a>) </div></div></div></div><div class="thread_right"><div id="ad_side_box">


<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id="usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103,22280986322/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general');
         });
     </script>
</div>


</div></div><div class="thread_comment_container"><div class="thread_post"><div class="thread_post_header"><b>I&#39;m </b><a name="15472079"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> : 11:21 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472079">link</a>   </div></div><div class="thread_post_body">not sure how any Giants fan who actually watches these games cannot come away saying the OL is a problem.</div></div><div class="thread_post"><div class="thread_post_header"><b>OL </b><a name="15472084"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=stretch234"> stretch234 </a>  : 11:22 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472084">link</a>   </div></div><div class="thread_post_body">That is a great write up…however, all you have to do is watch them play.  They are clearly the worst OL<br/>
<br/>
Yesterday alone, Barkley is hit behind the LOS on almost every run.  Teams for weeks have been able to rush 3 and pressure the QB<br/>
<br/>
This OL can’t run block and can’t pass block</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I&#39;m </b><a name="15472087"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=ajr2456"> ajr2456 </a>  : 11:23 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472087">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472079" target="_blank">15472079</a> Eric from BBI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> not sure how any Giants fan who actually watches these games cannot come away saying the OL is a problem. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Did anyone say it wasn’t a problem?</div></div><div class="thread_post"><div class="thread_post_header"><b>most of us are realists and can see that jones and barkley </b><a name="15472090"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=japanhead"> japanhead </a>  : 11:23 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472090">link</a>   </div></div><div class="thread_post_body">are bigger problems than the OL, or at least the OL is no bigger a problem than those two are. <br/>
<br/>
i&#39;d honestly like to see jones and barkley replaced with glennon and booker. i don&#39;t think you&#39;d see any drop-off in offensive production and would likely see an uptick.</div></div><div class="thread_post"><div class="thread_post_header"><b>It’s a problem, but Jones still misses too many throws </b><a name="15472091"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Sean"> Sean </a>  : 11:25 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472091">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>… </b><a name="15472092"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=christian"> christian </a>  : 11:25 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472092">link</a>   </div></div><div class="thread_post_body">I don’t think a lot fans on BBI watch much NFL football.<br/>
<br/>
There’s a lot of hyperbole that the Giants have the worst pass blocking and the worst run blocking.<br/>
<br/>
I think the Giants have a bad line, but not the worst. They aren’t in the area of the Bears or Seahawks. Those are teams who basically cannot run their offense because of the constant pressure on the QB.<br/>
<br/>
What the Giants do suffer from, and what really is noticeable, is the number of individual breakdowns that lead to big losses.</div></div><div class="thread_post"><div class="thread_post_header"><b>Easy answer. </b><a name="15472094"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Beezer"> Beezer </a>  : 11:25 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472094">link</a>   </div></div><div class="thread_post_body">No.<br/>
<br/>
Next?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I&#39;m </b><a name="15472096"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> : 11:25 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472096">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472087" target="_blank">15472087</a> ajr2456 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472079 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     not sure how any Giants fan who actually watches these games cannot come away saying the OL is a problem. <br/>
                                <br/>
                           <br/>
<br/>
Did anyone say it wasn’t a problem? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Ummmmm</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: most of us are realists and can see that jones and barkley </b><a name="15472097"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Walker+Gillette"> Walker Gillette </a>  : 11:25 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472097">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472090" target="_blank">15472090</a> japanhead said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> are bigger problems than the OL, or at least the OL is no bigger a problem than those two are. <br/>
<br/>
i&#39;d honestly like to see jones and barkley replaced with glennon and booker. i don&#39;t think you&#39;d see any drop-off in offensive production and would likely see an uptick. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I do not think that sentiment is even close to held by &#34;most of you&#34; Sometimes I wonder how many people come n this site that do not really watch the games.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I&#39;m </b><a name="15472100"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 11:27 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472100">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472079" target="_blank">15472079</a> Eric from BBI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> not sure how any Giants fan who actually watches these games cannot come away saying the OL is a problem. </td>
                                </tr>
                           </tbody></table><br/>
Problem? Absolutely.<br/>
<br/>
Historically bad OL as some fans have described it? We don&#39;t even have the worst OL in the NFL this season when it comes to pass pro. <br/>
<br/>
The OL isn&#39;t doing DJ any favors, but other QBs are doing more with less when it comes to their OLs.</div></div><div class="thread_post"><div class="thread_post_header"><b>These stats are skewed </b><a name="15472102"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=PEEJ"> PEEJ </a>  : 11:27 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472102">link</a>   </div></div><div class="thread_post_body">by the fact that Garrett never threw downfield (where pass pro has to stand up more).  Every passing play was 3-5 yds.<br/>
Garrett cut the balls off the offense</div></div><div class="thread_post"><div class="thread_post_header"><b>OL play is a prob league wide so it&#39;s not a myth but also not uncommon </b><a name="15472103"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  : 11:27 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472103">link</a>   </div></div><div class="thread_post_body">the rule changes, the schematic changes in CFB, and the new CBA all contributed to a massive regression in OL play league wide. <br/>
<br/>
so imo the NYG line play even this year is closer to league average than most fans realize. <br/>
<br/>
but league average is bad. below average is unplayable. and a handful of teams at the top have a huge advantage over everyone else. <br/>
<br/>
not signing Callahan when he was available was the organizations biggest mistake this half decade and possibly full decade.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: I&#39;m </b><a name="15472104"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=ajr2456"> ajr2456 </a>  : 11:27 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472104">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472096" target="_blank">15472096</a> Eric from BBI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472087 ajr2456 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472079 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     not sure how any Giants fan who actually watches these games cannot come away saying the OL is a problem. <br/>
                                <br/>
                           <br/>
<br/>
Did anyone say it wasn’t a problem? <br/>
                                <br/>
                           <br/>
<br/>
Ummmmm </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Gatorade Dunk didn’t say it wasn’t a problem. He said that it’s not as bad as it’s being made out to be by the Jones excuse makers</div></div><div class="thread_post"><div class="thread_post_header"><b>I don&#39;t know how anyone </b><a name="15472106"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dnew15"> Dnew15 </a>  : 11:28 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472106">link</a>   </div></div><div class="thread_post_body">can watch the Giants play and think the Giants don&#39;t have a QB problem....<br/>
<br/>
Along with an O-line problem.</div></div><div class="thread_post"><div class="thread_post_header"><b>It&#39;s hard to  </b><a name="15472107"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=GiantsRage2007"> GiantsRage2007 </a>  : 11:28 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472107">link</a>   </div></div><div class="thread_post_body">Believe we aren&#39;t last in every category, but it must be due to getting the ball out quickly and rolling Jones out so much. We certainly cannot run block and it&#39;s hard to hide that in stats.<br/>
<br/>
Anecdotally I watched the Dallas v Raiders game and the Raiders OL looked every bit as bad as ours, but Carr really moves around well and found receivers open deep. The one difference is they could run the ball... maybe it was the OL or maybe it was their RB vs Barkely, idk... maybe a bit of both? <br/>
<br/>
I would say our OL play is an issue, it&#39;s no myth.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I&#39;m </b><a name="15472109"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Walker+Gillette"> Walker Gillette </a>  : 11:29 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472109">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472100" target="_blank">15472100</a> Gatorade Dunk said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472079 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     not sure how any Giants fan who actually watches these games cannot come away saying the OL is a problem. <br/>
                                <br/>
                           <br/>
Problem? Absolutely.<br/>
<br/>
Historically bad OL as some fans have described it? We don&#39;t even have the worst OL in the NFL this season when it comes to pass pro. <br/>
<br/>
The OL isn&#39;t doing DJ any favors, but other QBs are doing more with less when it comes to their OLs. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
OK who? It&#39;s not Wilson, Fields or Dalton.</div></div><div class="thread_post"><div class="thread_post_header"><b>Statistics tell part of the story </b><a name="15472110"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Biteymax22"> Biteymax22 </a>  : 11:29 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472110">link</a>   </div></div><div class="thread_post_body">But not all of it.  We&#39;ve done everything under the sun to help our offensive line this year and protect them against themselves.  We&#39;ve ran max protect, we&#39;ve ran play action, we&#39;ve booted and rolled Jones to buy more time.<br/>
<br/>
This skews all these stats and helps to band aid the reality which is our offensive line has routinely played horrible all season.</div></div><div class="thread_post"><div class="thread_post_header"><b>The Oline is a big problem </b><a name="15472114"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UberAlias"> UberAlias </a>  : 11:29 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472114">link</a>   </div></div><div class="thread_post_body">But so is Jones. Off target throws, not seeing full field, staring down receivers. Yes, some of this is contributed by Oline play. But when I watch Jones I just don&#39;t get the feel that he&#39;s pushing defense, on the verge of making something happen. When you see good QBs impacted by poor Oline, they may not put up the numbers but you feel like if the Defense slips up just a little, the QB is going to make them pay. I never feel like that with Jones. We&#39;re always in a constant struggle just to move the chains with him where it&#39;s only a matter of time before they&#39;ll fail to convert. The Oline is a a big part of that but anyone who isn&#39;t seeing Jones as part of the problem too, outside of his occasional scramble, where are we seeing him making things happen?  I don&#39;t see that anywhere.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I don&#39;t know how anyone </b><a name="15472115"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=EricJ"> EricJ </a>  : 11:30 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472115">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472106" target="_blank">15472106</a> Dnew15 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> can watch the Giants play and think the Giants don&#39;t have a QB problem....<br/>
<br/>
Along with an O-line problem. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
because two things cannot be true at the same time...per the BBI rulebook.</div></div><div class="thread_post"><div class="thread_post_header"><b>Gatorade Dunk -- One Big Problem </b><a name="15472117"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=M.S."> M.S. </a>  : 11:30 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472117">link</a>   </div></div><div class="thread_post_body"><br/>
The offensive line can&#39;t run block. Full stop. And you can&#39;t divorce the pass game from the run game. They are synergistic and integrally woven into one another.<br/>
<br/>
How miserable is the Giants offensive line?  <br/>
<br/>
26th in rushing yards per game (90.8)<br/>
27th in rushing yards per attempt (3.9)<br/>
28th in rushing TDs (7)<br/>
28th in time of possession (28:54)<br/>
29th in rushing first downs (54)<br/>
<br/>
If this hot mess of a unit isn&#39;t re-built from the ground up, neither the QB, RB or WR positions will ever come close to reaching their full potential.<br/>
<br/>
And neither will our defense.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: I&#39;m </b><a name="15472118"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 11:30 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472118">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472096" target="_blank">15472096</a> Eric from BBI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472087 ajr2456 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472079 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     not sure how any Giants fan who actually watches these games cannot come away saying the OL is a problem. <br/>
                                <br/>
                           <br/>
<br/>
Did anyone say it wasn’t a problem? <br/>
                                <br/>
                           <br/>
<br/>
Ummmmm </td>
                                </tr>
                           </tbody></table><br/>
Eric, I think you&#39;re interpreting my post as saying that the OL is just fine and dandy, no problems, nothing to see here.<br/>
<br/>
That&#39;s not my point at all, and I apologize for not being clearer about that.<br/>
<br/>
I do think the OL is bad. It&#39;s a problem. It&#39;s just not even the worst in football this year (and it&#39;s not even close to the worst, honestly) let alone historically bad. Said another way, if other QBs are producing behind OLs that are worse than ours, it ceases to be an excuse for a QB who will average less than one passing TD per game over a full two season stretch.</div></div><div class="thread_post"><div class="thread_post_header"><b>A lot of that is the function of coaching and playcalling </b><a name="15472121"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=AcesUp"> AcesUp </a>  : 11:31 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472121">link</a>   </div></div><div class="thread_post_body">A lot of 12 and 13 personnel, a lot of moving pockets, a lot of quick-hitting passing with WRs running shallow routes. Eyeball test tells you that they are a complete liability. Unlike some of the discourse here, this isn&#39;t just a Giants problem. Just from watching on Sundays you see similar problems with other teams - the Dolphins, Panthers and Steelers immediately come to mind. <br/>
<br/>
I do think those statistics show how overly conservative they have been in protecting the OL and Jones though. Instead of challenging their young players they seem content to avoid big mistakes at all costs and hope the defense can keep it competitive in the 4th quarter.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I&#39;m </b><a name="15472122"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Essex"> Essex </a>  : 11:31 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472122">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472079" target="_blank">15472079</a> Eric from BBI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> not sure how any Giants fan who actually watches these games cannot come away saying the OL is a problem. </td>
                                </tr>
                           </tbody></table><br/>
More to this point, as I said in another thread, these stats have to be looked in with the context.  The Giants obviously gameplan around this.  They make Jones get rid of the ball almost immediately.  There are few, if any, five-seven step drops.  Very little stepping up in the pocket and no run game to keep the defense honest.  <br/>
<br/>
But nobody who has even a rudimentary understanding of football can watch the Giants and think that blocking (at any level, inside, outside, second level) is something that is middle of the pack in this league.  It is just not.</div></div><div class="thread_post"><div class="thread_post_header"><b>I also think there becomes </b><a name="15472124"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dnew15"> Dnew15 </a>  : 11:32 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472124">link</a>   </div></div><div class="thread_post_body">a point where a player is just wrecked by an organization and needs a change in order to be successful. <br/>
<br/>
I don&#39;t know how the Giants aren&#39;t at that point with Daniel Jones.<br/>
<br/>
Players just don&#39;t come back from where he is now in the same organization.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: I&#39;m </b><a name="15472125"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> : 11:32 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472125">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472118" target="_blank">15472118</a> Gatorade Dunk said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472096 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472087 ajr2456 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472079 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     not sure how any Giants fan who actually watches these games cannot come away saying the OL is a problem. <br/>
                                <br/>
                           <br/>
<br/>
Did anyone say it wasn’t a problem? <br/>
                                <br/>
                           <br/>
<br/>
Ummmmm <br/>
                                <br/>
                           <br/>
Eric, I think you&#39;re interpreting my post as saying that the OL is just fine and dandy, no problems, nothing to see here.<br/>
<br/>
That&#39;s not my point at all, and I apologize for not being clearer about that.<br/>
<br/>
I do think the OL is bad. It&#39;s a problem. It&#39;s just not even the worst in football this year (and it&#39;s not even close to the worst, honestly) let alone historically bad. Said another way, if other QBs are producing behind OLs that are worse than ours, it ceases to be an excuse for a QB who will average less than one passing TD per game over a full two season stretch. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I understand, but are you also factoring in running game productivity by those teams as well as the number of games missed by those teams&#39; primary pass receivers?<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I don&#39;t know how anyone </b><a name="15472127"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dnew15"> Dnew15 </a>  : 11:33 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472127">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472115" target="_blank">15472115</a> EricJ said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472106 Dnew15 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     can watch the Giants play and think the Giants don&#39;t have a QB problem....<br/>
<br/>
Along with an O-line problem. <br/>
                                <br/>
                           <br/>
<br/>
because two things cannot be true at the same time...per the BBI rulebook. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
My bad - I forgot.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I&#39;m </b><a name="15472128"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=madeinstars"> madeinstars </a>  : 11:34 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472128">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472122" target="_blank">15472122</a> Essex said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472079 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     not sure how any Giants fan who actually watches these games cannot come away saying the OL is a problem. <br/>
                                <br/>
                           <br/>
More to this point, as I said in another thread, these stats have to be looked in with the context.  The Giants obviously gameplan around this.  They make Jones get rid of the ball almost immediately.  There are few, if any, five-seven step drops.  Very little stepping up in the pocket and no run game to keep the defense honest.  <br/>
<br/>
But nobody who has even a rudimentary understanding of football can watch the Giants and think that blocking (at any level, inside, outside, second level) is something that is middle of the pack in this league.  It is just not. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
And you think other teams with bad O-lines don&#39;t try to scheme around that?</div></div><div class="thread_post"><div class="thread_post_header"><b>Stats lie in football  </b><a name="15472130"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Sneakers+O%27toole"> Sneakers O&#39;toole </a>  : 11:34 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472130">link</a>   </div></div><div class="thread_post_body">This line is generally as bad as advertised, and any time they approach something looking like cohesion something sets them back. <br/>
<br/>
O line play around the leauge isn&#39;t great in the modern game so the bar is low, the Giants can&#39;t reach that bar yet</div></div><div class="thread_post"><div class="thread_post_header"><b>The Jones hating clownshow is grasping at straws </b><a name="15472132"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Thunderstruck27"> Thunderstruck27 </a>  : 11:34 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472132">link</a>   </div></div><div class="thread_post_body">The entire offense is built around hiding our shitty OLine. Everyone wants to complain about Jones throwing to his first read...OLine.  Why doesn&#39;t Jones take more shots downfield...OLine.  How come we can&#39;t properly execute a screen pass....OLine.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I&#39;m </b><a name="15472133"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BMac"> BMac </a>  : 11:34 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472133">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472087" target="_blank">15472087</a> ajr2456 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472079 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     not sure how any Giants fan who actually watches these games cannot come away saying the OL is a problem. <br/>
                                <br/>
                           <br/>
<br/>
Did anyone say it wasn’t a problem? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Gatorade Dunk believes it&#39;s only &#34;middling.&#34;</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Gatorade Dunk -- One Big Problem </b><a name="15472134"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dnew15"> Dnew15 </a>  : 11:35 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472134">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472117" target="_blank">15472117</a> M.S. said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
The offensive line can&#39;t run block. Full stop. And you can&#39;t divorce the pass game from the run game. They are synergistic and integrally woven into one another.<br/>
<br/>
How miserable is the Giants offensive line?  <br/>
<br/>
26th in rushing yards per game (90.8)<br/>
27th in rushing yards per attempt (3.9)<br/>
28th in rushing TDs (7)<br/>
28th in time of possession (28:54)<br/>
29th in rushing first downs (54)<br/>
<br/>
If this hot mess of a unit isn&#39;t re-built from the ground up, neither the QB, RB or WR positions will ever come close to reaching their full potential.<br/>
<br/>
And neither will our defense. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Sadly - there&#39;s three problems going on at the same time...<br/>
<br/>
B/c Saquon is not going to get a gold jacket. Not after he blew out his knee anyway.<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>The OL needs to upgrade... </b><a name="15472135"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  : 11:36 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472135">link</a>   </div></div><div class="thread_post_body">That seems without dispute to me. But if you watch enough NFL games, as Dunk&#39;s stats suggest, we aren&#39;t alone in having OL struggles. It&#39;s a league wide epidemic. It&#39;s been a league problem for a decade.<br/>
<br/>
Seattle is a great example. They were rolling out some of the worst OLs I have ever seen the last five years. Yet, Wilson still was able lead the team to winning records, playoff spots, and pro bowl production. <br/>
<br/>
Unfortunately, are problems are compounded by an average-below average OL and a QB who is limited in his ability to lift the team up and help offset these OL issues.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: I&#39;m </b><a name="15472136"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Essex"> Essex </a>  : 11:36 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472136">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472128" target="_blank">15472128</a> madeinstars said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472122 Essex said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472079 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     not sure how any Giants fan who actually watches these games cannot come away saying the OL is a problem. <br/>
                                <br/>
                           <br/>
More to this point, as I said in another thread, these stats have to be looked in with the context.  The Giants obviously gameplan around this.  They make Jones get rid of the ball almost immediately.  There are few, if any, five-seven step drops.  Very little stepping up in the pocket and no run game to keep the defense honest.  <br/>
<br/>
But nobody who has even a rudimentary understanding of football can watch the Giants and think that blocking (at any level, inside, outside, second level) is something that is middle of the pack in this league.  It is just not. <br/>
                                <br/>
                           <br/>
<br/>
And you think other teams with bad O-lines don&#39;t try to scheme around that? </td>
                                </tr>
                           </tbody></table><br/>
Yes, they do, but a team like the Steelers with an awful offensive line, still takes plenty of shots down the field (with horrifying results lol), but they try.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: I&#39;m </b><a name="15472139"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 11:36 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472139">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472109" target="_blank">15472109</a> Walker Gillette said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472100 Gatorade Dunk said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472079 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     not sure how any Giants fan who actually watches these games cannot come away saying the OL is a problem. <br/>
                                <br/>
                           <br/>
Problem? Absolutely.<br/>
<br/>
Historically bad OL as some fans have described it? We don&#39;t even have the worst OL in the NFL this season when it comes to pass pro. <br/>
<br/>
The OL isn&#39;t doing DJ any favors, but other QBs are doing more with less when it comes to their OLs. <br/>
                                <br/>
                           <br/>
<br/>
OK who? It&#39;s not Wilson, Fields or Dalton. </td>
                                </tr>
                           </tbody></table><br/>
Wilson has 10 TDs in 7 games. That&#39;s better per game than Jones.<br/>
<br/>
The Bears are a tire fire on the OL, and are doing it in a QB transition year - that&#39;s almost not worth considering, but even so, yes they&#39;re worse. Is that what DJ should be in his 3rd year with a better OL and better weapons? An amalgamation of a rookie and a journeyman?<br/>
<br/>
Kirk Cousins is playing behind one of the lines that shows up a few times below the Giants (Cousins gets sacked way less but pressured, hurried, and hit way more), how&#39;s he doing?  Apparently you can have a mediocre OL and still have 23 TDs and 3 INTs at this point in the season.</div></div><div class="thread_post"><div class="thread_post_header"><b>For Giants, Running Proficiency </b><a name="15472141"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=clatterbuck"> clatterbuck </a>  : 11:37 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472141">link</a>   </div></div><div class="thread_post_body">may be a bigger issue than pass protection. And the stats posted don&#39;t account for adjustments like max pro schemes, limiting pas routes, etc. You just can&#39;t, or imo, it&#39;s wrong to assume Jones and Barkley are the problem, not the O-line.</div></div><div class="thread_post"><div class="thread_post_header"><b>The excuse is a myth </b><a name="15472145"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=averagejoe"> averagejoe </a>  : 11:38 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472145">link</a>   </div></div><div class="thread_post_body">but the reality is the OL does suck. They are not the only reason our playmakers rarely make plays. But they are certainly part of the problem.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: I&#39;m </b><a name="15472146"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 11:38 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472146">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472125" target="_blank">15472125</a> Eric from BBI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472118 Gatorade Dunk said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472096 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472087 ajr2456 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472079 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     not sure how any Giants fan who actually watches these games cannot come away saying the OL is a problem. <br/>
                                <br/>
                           <br/>
<br/>
Did anyone say it wasn’t a problem? <br/>
                                <br/>
                           <br/>
<br/>
Ummmmm <br/>
                                <br/>
                           <br/>
Eric, I think you&#39;re interpreting my post as saying that the OL is just fine and dandy, no problems, nothing to see here.<br/>
<br/>
That&#39;s not my point at all, and I apologize for not being clearer about that.<br/>
<br/>
I do think the OL is bad. It&#39;s a problem. It&#39;s just not even the worst in football this year (and it&#39;s not even close to the worst, honestly) let alone historically bad. Said another way, if other QBs are producing behind OLs that are worse than ours, it ceases to be an excuse for a QB who will average less than one passing TD per game over a full two season stretch. <br/>
                                <br/>
                           <br/>
<br/>
I understand, but are you also factoring in running game productivity by those teams as well as the number of games missed by those teams&#39; primary pass receivers?<br/>
 </td>
                                </tr>
                           </tbody></table><br/>
Now we&#39;re reintroducing other excuses. The premise of this post was that if the last remaining excuse for DJ is the OL, should it be a worthy excuse?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: The OL needs to upgrade... </b><a name="15472147"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Essex"> Essex </a>  : 11:38 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472147">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472135" target="_blank">15472135</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> That seems without dispute to me. But if you watch enough NFL games, as Dunk&#39;s stats suggest, we aren&#39;t alone in having OL struggles. It&#39;s a league wide epidemic. It&#39;s been a league problem for a decade.<br/>
<br/>
Seattle is a great example. They were rolling out some of the worst OLs I have ever seen the last five years. Yet, Wilson still was able lead the team to winning records, playoff spots, and pro bowl production. <br/>
<br/>
Unfortunately, are problems are compounded by an average-below average OL and a QB who is limited in his ability to lift the team up and help offset these OL issues. </td>
                                </tr>
                           </tbody></table><br/>
And how does Seattle gameplan around it?  Their QB runs fifty yards backwards.  Each time handles poor OL play differently, we just have not done it well (whether it be front office in getting us better talent, coaches in coaching the team, and players like Jones in executing).</div></div><div class="thread_post"><div class="thread_post_header"><b>How are our WRs </b><a name="15472153"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dnew15"> Dnew15 </a>  : 11:40 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472153">link</a>   </div></div><div class="thread_post_body">doing on separation rate?<br/>
<br/>
That was the main problem last year w/ being able to evaluate QB play...I think...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: For Giants, Running Proficiency </b><a name="15472156"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=madeinstars"> madeinstars </a>  : 11:40 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472156">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472141" target="_blank">15472141</a> clatterbuck said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> may be a bigger issue than pass protection. And the stats posted don&#39;t account for adjustments like max pro schemes, limiting pas routes, etc. You just can&#39;t, or imo, it&#39;s wrong to assume Jones and Barkley are the problem, not the O-line. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
The right thing to assume is that all three are.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I&#39;m </b><a name="15472159"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=JB_in_DC"> JB_in_DC </a>  : 11:41 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472159">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472079" target="_blank">15472079</a> Eric from BBI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> not sure how any Giants fan who actually watches these games cannot come away saying the OL is a problem. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Eric, there are posters on this forum who have admitted they don&#39;t really watch the games.  Its bizarre.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: It&#39;s hard to  </b><a name="15472163"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 11:42 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472163">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472107" target="_blank">15472107</a> GiantsRage2007 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Believe we aren&#39;t last in every category, but it must be due to getting the ball out quickly and rolling Jones out so much. We certainly cannot run block and it&#39;s hard to hide that in stats.<br/>
<br/>
Anecdotally I watched the Dallas v Raiders game and the Raiders OL looked every bit as bad as ours, but Carr really moves around well and found receivers open deep. The one difference is they could run the ball... maybe it was the OL or maybe it was their RB vs Barkely, idk... maybe a bit of both? <br/>
<br/>
I would say our OL play is an issue, it&#39;s no myth. </td>
                                </tr>
                           </tbody></table>\<br/>
If it were purely about scheming to get the ball out quickly (as the Steelers do with Ben), it would show up in the pocket time metric.<br/>
<br/>
All of these stats are intended to allow any escape hatch from the other stats to be revealed. The Giants start most plays from something that approximates league median when it comes to OL play on pass protection. <br/>
<br/>
No, it doesn&#39;t tell the whole story. It&#39;s almost impossible to do that in football, because of how the pieces fit together. But that goes for excuses as well as rebuttals. If you think that I can&#39;t simply prove that the OL is not at fault, then by definition you can&#39;t simply prove that DJ isn&#39;t at fault either.<br/>
<br/>
QED</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: most of us are realists and can see that jones and barkley </b><a name="15472165"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=TheBlueprintNC"> TheBlueprintNC </a>  : 11:42 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472165">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472090" target="_blank">15472090</a> japanhead said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> are bigger problems than the OL, or at least the OL is no bigger a problem than those two are. <br/>
<br/>
i&#39;d honestly like to see jones and barkley replaced with glennon and booker. i don&#39;t think you&#39;d see any drop-off in offensive production and would likely see an uptick. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Stay off the drugs kids</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I&#39;m </b><a name="15472168"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=madeinstars"> madeinstars </a>  : 11:43 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472168">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472159" target="_blank">15472159</a> JB_in_DC said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472079 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     not sure how any Giants fan who actually watches these games cannot come away saying the OL is a problem. <br/>
                                <br/>
                           <br/>
<br/>
Eric, there are posters on this forum who have admitted they don&#39;t really watch the games.  Its bizarre. </td>
                                </tr>
                           </tbody></table><br/>
Or you could just, you know, read the arguments and see that nobody is saying the O-line isn&#39;t a problem</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: These stats are skewed </b><a name="15472169"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Ira"> Ira </a>  : 11:44 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472169">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472102" target="_blank">15472102</a> PEEJ said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> by the fact that Garrett never threw downfield (where pass pro has to stand up more).  Every passing play was 3-5 yds.<br/>
Garrett cut the balls off the offense </td>
                                </tr>
                           </tbody></table><br/>
<br/>
This.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: These stats are skewed </b><a name="15472172"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 11:45 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472172">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472169" target="_blank">15472169</a> Ira said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472102 PEEJ said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     by the fact that Garrett never threw downfield (where pass pro has to stand up more).  Every passing play was 3-5 yds.<br/>
Garrett cut the balls off the offense <br/>
                                <br/>
                           <br/>
<br/>
This. </td>
                                </tr>
                           </tbody></table><br/>
Then the pocket time would be lower.<br/>
<br/>
Is BBI really this innumerate?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: most of us are realists and can see that jones and barkley </b><a name="15472173"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=M.S."> M.S. </a>  : 11:45 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472173">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472090" target="_blank">15472090</a> japanhead said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> are bigger problems than the OL, or at least the OL is no bigger a problem than those two are. <br/>
<br/>
i&#39;d honestly like to see jones and barkley replaced with glennon and booker. i don&#39;t think you&#39;d see any drop-off in offensive production and would likely see an uptick. </td>
                                </tr>
                           </tbody></table><br/>
Wow.<br/>
<br/>
I disagree with your point of view.</div></div><div class="thread_post"><div class="thread_post_header"><b>The OL is a disaster </b><a name="15472174"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BillT"> BillT </a>  : 11:45 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472174">link</a>   </div></div><div class="thread_post_body">It simply cannot execute any of the functions in either the running game and/or the passing game that are required to have a functioning offense.  You don&#39;t need statistics to know that.</div></div><div class="thread_post"><div class="thread_post_header"><b>No ... it is not a myth ... </b><a name="15472175"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Spider56"> Spider56 </a>  : 11:45 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472175">link</a>   </div></div><div class="thread_post_body">The numbers don’t take into account all the shit the coaching staff tries to do to compensate for the bad OL. Formations that help out a weakness limit flexibility and options.  Trying to cover 1 weakness exposes others. <br/>
And there’s also the possibility that DJ’s play has masked worse shit from happening. <br/>
<br/>
There’s near universal consensus that Solder is done, Hernandez is playing poorly and Price is a stop gap ... yet the sum of these parts is supposed to be ok.   Seriously, get real.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I&#39;m </b><a name="15472176"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=TheBlueprintNC"> TheBlueprintNC </a>  : 11:46 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472176">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472079" target="_blank">15472079</a> Eric from BBI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> not sure how any Giants fan who actually watches these games cannot come away saying the OL is a problem. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Some fans are delusional if they feel this line is less than putrid and not eh worst in the NFL.  Thomas has been the only quality starter.  The Line was decimated in the first 2 games.. we had our back ups retire. and our future starter on RT injured and missing key rep time.  The OL is the number 1 problem for this team since 2011 -its now 2021</div></div><div class="thread_post"><div class="thread_post_header"><b>Did anyone see the Packers  </b><a name="15472177"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Breeze_94"> Breeze_94 </a>  : 11:46 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472177">link</a>   </div></div><div class="thread_post_body">Starting OL this week? Kept the Rams front 7 in check with a bunch of backups.   And yet the Giants can’t do anything up front.  Something tells me this is a lot more than just the players on the OL.<br/>
<br/>
It’s the QB, and his inability to handle pressure, which bottles up the entire offense</div></div><div class="thread_post"><div class="thread_post_header"><b>The poor Offensive Line is clearly negatively </b><a name="15472179"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Jimmy+Googs"> Jimmy Googs </a>  : 11:46 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472179">link</a>   </div></div><div class="thread_post_body">impacting the Offense in producing enough yards and points. The gameplan is reined in so much that it is probably helping a lot of those stats to some degree.<br/>
<br/>
But the so-called &#34;playmakers&#34; on this team aren&#39;t doing their part even in a conservative offense.  There are many other teams with porous OLs too that are able to function better because of higher quality QB/RB/TE/WR play...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: I&#39;m </b><a name="15472181"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Walker+Gillette"> Walker Gillette </a>  : 11:47 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472181">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472139" target="_blank">15472139</a> Gatorade Dunk said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472109 Walker Gillette said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472100 Gatorade Dunk said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472079 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     not sure how any Giants fan who actually watches these games cannot come away saying the OL is a problem. <br/>
                                <br/>
                           <br/>
Problem? Absolutely.<br/>
<br/>
Historically bad OL as some fans have described it? We don&#39;t even have the worst OL in the NFL this season when it comes to pass pro. <br/>
<br/>
The OL isn&#39;t doing DJ any favors, but other QBs are doing more with less when it comes to their OLs. <br/>
                                <br/>
                           <br/>
<br/>
OK who? It&#39;s not Wilson, Fields or Dalton. <br/>
                                <br/>
                           <br/>
Wilson has 10 TDs in 7 games. That&#39;s better per game than Jones.<br/>
<br/>
The Bears are a tire fire on the OL, and are doing it in a QB transition year - that&#39;s almost not worth considering, but even so, yes they&#39;re worse. Is that what DJ should be in his 3rd year with a better OL and better weapons? An amalgamation of a rookie and a journeyman?<br/>
<br/>
Kirk Cousins is playing behind one of the lines that shows up a few times below the Giants (Cousins gets sacked way less but pressured, hurried, and hit way more), how&#39;s he doing?  Apparently you can have a mediocre OL and still have 23 TDs and 3 INTs at this point in the season. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
The Giants line isn&#39;t mediocre and the Bears and the Seahawks have records that are the same or worse than the Giants. When you just look at random stats(especially when you are searching to prove a point) you forget that winning and losing is important. I forgot that you were one of those guys that will do anything to shit on Jones so I&#39;m done here, but really watching the games and winning and losing are important things.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I&#39;m </b><a name="15472183"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 11:47 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472183">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472176" target="_blank">15472176</a> TheBlueprintNC said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472079 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     not sure how any Giants fan who actually watches these games cannot come away saying the OL is a problem. <br/>
                                <br/>
                           <br/>
<br/>
Some fans are delusional if they feel this line is less than putrid and not eh worst in the NFL.  Thomas has been the only quality starter.  The Line was decimated in the first 2 games.. we had our back ups retire. and our future starter on RT injured and missing key rep time.  The OL is the number 1 problem for this team since 2011 -its now 2021 </td>
                                </tr>
                           </tbody></table><br/>
If the Giants&#39; OL is the worst in the NFL, how are other lines giving up more sacks, more hurries, more pressure, more hits, less pocket time, etc.?<br/>
<br/>
Wouldn&#39;t it be easier to just admit that you don&#39;t watch any other games besides the Giants?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: These stats are skewed </b><a name="15472185"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Thunderstruck27"> Thunderstruck27 </a>  : 11:47 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472185">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472172" target="_blank">15472172</a> Gatorade Dunk said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472169 Ira said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472102 PEEJ said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     by the fact that Garrett never threw downfield (where pass pro has to stand up more).  Every passing play was 3-5 yds.<br/>
Garrett cut the balls off the offense <br/>
                                <br/>
                           <br/>
<br/>
This. <br/>
                                <br/>
                           <br/>
Then the pocket time would be lower.<br/>
<br/>
Is BBI really this innumerate? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Does this take into account pocket time that DJ buys and sometimes tucks it and runs?</div></div><div class="thread_post"><div class="thread_post_header"><b>While it’s a problem </b><a name="15472186"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=CMicks3110"> CMicks3110 </a>  : 11:48 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472186">link</a>   </div></div><div class="thread_post_body">It would be less so If Jones could throw on the run. DJ is a mobile QB, but he’s a pocket passer. He needs to be able to step into the throw to get enough on it and to be accurate.</div></div><div class="thread_post"><div class="thread_post_header"><b>how many threads to say the same thing </b><a name="15472187"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  : 11:48 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472187">link</a>   </div></div><div class="thread_post_body">Jones isn&#39;t good enough. Most competent people know that. But the OL also sucks and compounds that fact that we don&#39;t have a very good or even good level of play at QB.<br/>
<br/>
Add on that our run game stinks and our play calling has been vanilla, and there you have it.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: These stats are skewed </b><a name="15472191"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=M.S."> M.S. </a>  : 11:50 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472191">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472172" target="_blank">15472172</a> Gatorade Dunk said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472169 Ira said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472102 PEEJ said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     by the fact that Garrett never threw downfield (where pass pro has to stand up more).  Every passing play was 3-5 yds.<br/>
Garrett cut the balls off the offense <br/>
                                <br/>
                           <br/>
<br/>
This. <br/>
                                <br/>
                           <br/>
Then the pocket time would be lower.<br/>
<br/>
Is BBI really this innumerate? </td>
                                </tr>
                           </tbody></table><br/>
Gatorade Dunk -- if the Giants passing game was turned into dink and donk by Garrett, then that would make just about all of your stats give an inflated view of our O-line&#39;s pass blocking skills. That includes:<br/>
<br/>
Sacks per game <br/>
Sack percentage<br/>
Pressures per game<br/>
Pressure percentage<br/>
Hurries per game<br/>
Hits per game<br/>
<br/>
How can a team look bad on the above stats when they are getting rid of the ball on short to intermediate passes?<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: most of us are realists and can see that jones and barkley </b><a name="15472194"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=japanhead"> japanhead </a>  : 11:50 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472194">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472173" target="_blank">15472173</a> M.S. said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472090 japanhead said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     are bigger problems than the OL, or at least the OL is no bigger a problem than those two are. <br/>
<br/>
i&#39;d honestly like to see jones and barkley replaced with glennon and booker. i don&#39;t think you&#39;d see any drop-off in offensive production and would likely see an uptick. <br/>
                                <br/>
                           <br/>
Wow.<br/>
<br/>
I disagree with your point of view. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
disagree all you want. <br/>
<br/>
we have already seen booker be more productive than barkley behind this same OL. <br/>
<br/>
we have seen toney have 189 yards receiving in one half of one game with glennon throwing him the ball behind this same OL.<br/>
<br/>
there is just no evidence this season that jones and barkely are difference makers at their positions, and there is plenty of evidence to suggest they exacerbate the teams OL problems.  <br/>
<br/>
<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: While it’s a problem </b><a name="15472200"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Thunderstruck27"> Thunderstruck27 </a>  : 11:52 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472200">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472186" target="_blank">15472186</a> CMicks3110 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> It would be less so If Jones could throw on the run. DJ is a mobile QB, but he’s a pocket passer. He needs to be able to step into the throw to get enough on it and to be accurate. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
While it&#39;s a problem DJ is better throwing out of the pocket, throwing on the run would be easier if our WRs got open</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: OL </b><a name="15472203"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=k2tampa"> k2tampa </a>  : 11:53 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472203">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472084" target="_blank">15472084</a> stretch234 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> That is a great write up…however, all you have to do is watch them play.  They are clearly the worst OL<br/>
<br/>
Yesterday alone, Barkley is hit behind the LOS on almost every run.  Teams for weeks have been able to rush 3 and pressure the QB<br/>
<br/>
This OL can’t run block and can’t pass block </td>
                                </tr>
                           </tbody></table><br/>
<br/>
When all you are throwing are the shortest passes possible, those numbers won&#39;t tell the tale. Look at what happens when the Giants HAVE to throw he ball. The more telling stat is yards per carry. The Giants are averaging 3.8 yards a carry, tied for fifth worst in the league, and 90.8 yards a game, tied for seventh worst. Take out Jones&#39; 298 yards and it&#39;s 3.5 yards a carry and 63 yards a game.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: most of us are realists and can see that jones and barkley </b><a name="15472205"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Thunderstruck27"> Thunderstruck27 </a>  : 11:53 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472205">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472194" target="_blank">15472194</a> japanhead said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472173 M.S. said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472090 japanhead said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     are bigger problems than the OL, or at least the OL is no bigger a problem than those two are. <br/>
<br/>
i&#39;d honestly like to see jones and barkley replaced with glennon and booker. i don&#39;t think you&#39;d see any drop-off in offensive production and would likely see an uptick. <br/>
                                <br/>
                           <br/>
Wow.<br/>
<br/>
I disagree with your point of view. <br/>
                                <br/>
                           <br/>
<br/>
disagree all you want. <br/>
<br/>
we have already seen booker be more productive than barkley behind this same OL. <br/>
<br/>
we have seen toney have 189 yards receiving in one half of one game with glennon throwing him the ball behind this same OL.<br/>
<br/>
there is just no evidence this season that jones and barkely are difference makers at their positions, and there is plenty of evidence to suggest they exacerbate the teams OL problems.  <br/>
<br/>
<br/>
 </td>
                                </tr>
                           </tbody></table><br/>
<br/>
You left out the part where Glennon threw 2 INTs....one for a defensive Touchdown</div></div><div class="thread_post"><div class="thread_post_header"><b>if </b><a name="15472213"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> : 11:54 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472213">link</a>   </div></div><div class="thread_post_body">you are going to react to results, Jones clearly isn&#39;t having the season he need to have. It looks like he is part of the problem.<br/>
<br/>
But this stuff is all interrelated.<br/>
<br/>
Unless you really believe Eli Manning went from arguably league MVP at the age of 30 to bum for the entire second half of his career, then you need know other evidence that the team&#39;s OL has been horrific for a decade.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: I&#39;m </b><a name="15472216"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 11:55 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472216">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472181" target="_blank">15472181</a> Walker Gillette said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472139 Gatorade Dunk said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472109 Walker Gillette said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472100 Gatorade Dunk said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472079 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     not sure how any Giants fan who actually watches these games cannot come away saying the OL is a problem. <br/>
                                <br/>
                           <br/>
Problem? Absolutely.<br/>
<br/>
Historically bad OL as some fans have described it? We don&#39;t even have the worst OL in the NFL this season when it comes to pass pro. <br/>
<br/>
The OL isn&#39;t doing DJ any favors, but other QBs are doing more with less when it comes to their OLs. <br/>
                                <br/>
                           <br/>
<br/>
OK who? It&#39;s not Wilson, Fields or Dalton. <br/>
                                <br/>
                           <br/>
Wilson has 10 TDs in 7 games. That&#39;s better per game than Jones.<br/>
<br/>
The Bears are a tire fire on the OL, and are doing it in a QB transition year - that&#39;s almost not worth considering, but even so, yes they&#39;re worse. Is that what DJ should be in his 3rd year with a better OL and better weapons? An amalgamation of a rookie and a journeyman?<br/>
<br/>
Kirk Cousins is playing behind one of the lines that shows up a few times below the Giants (Cousins gets sacked way less but pressured, hurried, and hit way more), how&#39;s he doing?  Apparently you can have a mediocre OL and still have 23 TDs and 3 INTs at this point in the season. <br/>
                                <br/>
                           <br/>
<br/>
The Giants line isn&#39;t mediocre and the Bears and the Seahawks have records that are the same or worse than the Giants. When you just look at random stats(especially when you are searching to prove a point) you forget that winning and losing is important. I forgot that you were one of those guys that will do anything to shit on Jones so I&#39;m done here, but really watching the games and winning and losing are important things. </td>
                                </tr>
                           </tbody></table><br/>
These aren&#39;t random stats. They&#39;re literally every stat that reflects pass protection rates. If you can find even a single OL pass pro stat that I omitted, I&#39;ll gladly accept that this was somehow cherry picked. But I don&#39;t think you can.<br/>
<br/>
And they&#39;re intentionally assembled. If a team is scheming around a poor OL they may be artificially inflated on sacks/hurries/pressures/hits, but that will show up in pocket time. And if they are doing poorly in sacks/hurries/pressures/hits, that should show up in pocket time (as a function of a poor internal clock from the QB) or not (in which case the OL is just so bad that it&#39;s a jailbreak every time).<br/>
<br/>
That&#39;s not what shows up the Giants&#39; OL metrics. They&#39;re not good. I&#39;m not trying to make that case. But they&#39;re basically toward the low end of the middle-third, which is to say that OL play around the league is not especially good, but more than a handful of teams have it worse than the Giants. Meanwhile, QB play around the league isn&#39;t necessarily suffering. <br/>
<br/>
This isn&#39;t entirely to excuse the OL. I would love to have the Suburbanites up front right now. But I think our OL is bearing more than their fair share of blame at the moment for those fans who really, really want DJ to not be a weakness on this roster.</div></div><div class="thread_post"><div class="thread_post_header"><b>Not all pressure is the same  </b><a name="15472218"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=mako+J"> mako J </a>  : 11:55 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472218">link</a>   </div></div><div class="thread_post_body">Edge pressure can be mitigated. A/B gap pressure wrecks possessions and games. <br/>
<br/>
Smoke and mirrors are deployed on first and second downs and on standard possessions, however this OL cannot consistently protect when it matters most. This OL cannot force defenses to have to rely on sending pressure. It’s the opposite. This OL consistently allows defenses to win by only rushing 4 or even 3 and maximize coverage on the back end. <br/>
<br/>
Improvement is needed across the board. Coaching, blocking, running, receiving, and throwing.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: most of us are realists and can see that jones and barkley </b><a name="15472223"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=M.S."> M.S. </a>  : 11:56 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472223">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472194" target="_blank">15472194</a> japanhead said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472173 M.S. said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472090 japanhead said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     are bigger problems than the OL, or at least the OL is no bigger a problem than those two are. <br/>
<br/>
i&#39;d honestly like to see jones and barkley replaced with glennon and booker. i don&#39;t think you&#39;d see any drop-off in offensive production and would likely see an uptick. <br/>
                                <br/>
                           <br/>
Wow.<br/>
<br/>
I disagree with your point of view. <br/>
                                <br/>
                           <br/>
<br/>
disagree all you want. <br/>
<br/>
we have already seen booker be more productive than barkley behind this same OL. <br/>
<br/>
we have seen toney have 189 yards receiving in one half of one game with glennon throwing him the ball behind this same OL.<br/>
<br/>
there is just no evidence this season that jones and barkely are difference makers at their positions, and there is plenty of evidence to suggest they exacerbate the teams OL problems.  <br/>
<br/>
<br/>
 </td>
                                </tr>
                           </tbody></table><br/>
Do you really want to stand on the conviction that QBs and RBs enhance the play of the offensive line MORE THAN the reverse?<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>I don&#39;t think it&#39;s a myth </b><a name="15472228"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=pjcas18"> pjcas18 </a>  : 11:58 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472228">link</a>   </div></div><div class="thread_post_body">but I do think like most things it&#39;s not one thing.<br/>
<br/>
it&#39;s a combination of poor OL play, the play calling not really matching the OL capabilities or strengths, QB issues, skill position issues, etc.<br/>
<br/>
I think the Giants have the longest streak in the NFL for not scoring 30 points in a game (on offense) or one of the longest. December 22, 2019 vs Washington. and OL play has a big part in that ineptitude.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: if </b><a name="15472229"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 11:58 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472229">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472213" target="_blank">15472213</a> Eric from BBI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> you are going to react to results, Jones clearly isn&#39;t having the season he need to have. It looks like he is part of the problem.<br/>
<br/>
But this stuff is all interrelated.<br/>
<br/>
Unless you really believe Eli Manning went from arguably league MVP at the age of 30 to bum for the entire second half of his career, then you need know other evidence that the team&#39;s OL has been horrific for a decade. </td>
                                </tr>
                           </tbody></table><br/>
I get that and I agree with it. The OL was worse in some of those years than it is now. Not exactly a high bar to beat, but still. And I think Eli had some PTSD in the final few years because of the bad OL play in front of him.<br/>
<br/>
The point isn&#39;t whether DJ has a good OL in front of him; it&#39;s really how good of an OL will he need before he&#39;s not a liability. Because right now (and this is a reflection of the NFL at large), our OL is closer to league average than it is to the bottom.</div></div><div class="thread_post"><div class="thread_post_header"><b>You guys are all freaking nuts minus Wilson who plays often behind  </b><a name="15472234"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Four+Aces"> Four Aces </a>  : 11:59 am   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472234">link</a>   </div></div><div class="thread_post_body">a bad line and wanted to be traded btw of that... <br/>
Please name the good/great/elite NFL QBs who play behind shitty lines?!<br/>
<br/>
Mayfield, Josh Allen, Lamar Jackson, Brady, ARod, Mahomes, Stafford, Dak, Herbert, etc?!<br/>
<br/>
You guys think good line play is a coincidence to good QB play?! We can&#39;t run the ball effectively behind this line so play action is almost non-existent and plays cant consistently develop down the field, and our WRs are dropping like flies.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: RE: I&#39;m </b><a name="15472237"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Section331"> Section331 </a>  : 12:00 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472237">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472216" target="_blank">15472216</a> Gatorade Dunk said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
                           <br/>
These aren&#39;t random stats. They&#39;re literally every stat that reflects pass protection rates. If you can find even a single OL pass pro stat that I omitted, I&#39;ll gladly accept that this was somehow cherry picked. But I don&#39;t think you can.<br/>
<br/>
And they&#39;re intentionally assembled. If a team is scheming around a poor OL they may be artificially inflated on sacks/hurries/pressures/hits, but that will show up in pocket time. And if they are doing poorly in sacks/hurries/pressures/hits, that should show up in pocket time (as a function of a poor internal clock from the QB) or not (in which case the OL is just so bad that it&#39;s a jailbreak every time).<br/>
<br/>
That&#39;s not what shows up the Giants&#39; OL metrics. They&#39;re not good. I&#39;m not trying to make that case. But they&#39;re basically toward the low end of the middle-third, which is to say that OL play around the league is not especially good, but more than a handful of teams have it worse than the Giants. Meanwhile, QB play around the league isn&#39;t necessarily suffering. <br/>
<br/>
This isn&#39;t entirely to excuse the OL. I would love to have the Suburbanites up front right now. But I think our OL is bearing more than their fair share of blame at the moment for those fans who really, really want DJ to not be a weakness on this roster. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Thanks for doing this GD, but no stats you can post will convince the Jones dead-enders that anything is his fault. Since you&#39;ve posted about every relevant stat to show that Giants&#39; pass pro is middle of the pack, not historically bad, they&#39;ll pivot to the ESPN pass block win rate, which is about as subjective a stat as you can get.<br/>
<br/>
Look, the Giant OL isn&#39;t good, and every spot to the right of Andrew Thomas needs to be upgraded, but they aren&#39;t the reason for Jones&#39;s inconsistent play.</div></div><div class="thread_post"><div class="thread_post_header"><b>Cannot the </b><a name="15472239"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BigBlueJ"> BigBlueJ </a>  : 12:01 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472239">link</a>   </div></div><div class="thread_post_body">whole entire roster be bad? Why try to pinpoint to one symptom. When the root cause is this roster built by this current organization is a underwhelming, injury prone mess.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: most of us are realists and can see that jones and barkley </b><a name="15472242"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=japanhead"> japanhead </a>  : 12:01 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472242">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472205" target="_blank">15472205</a> Thunderstruck27 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">         <br/>
                           <br/>
<br/>
You left out the part where Glennon threw 2 INTs....one for a defensive Touchdown </td>
                                </tr>
                           </tbody></table><br/>
<br/>
and jones threw 2 ints and for 167 total passing yards just 13 days ago v tampa bay. <br/>
<br/>
i&#39;m not saying glennon is the answer at QB going forward, just that he wouldn&#39;t be significantly worse than jones, who has been one of the worst starting QBs in football.<br/>
<br/>
ditto booker for barkley. but at least barkley has the excuse that inuries derailed his potential. jones has no such excuse.</div></div><div class="thread_post"><div class="thread_post_header"><b>Gatorade Dunk </b><a name="15472244"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> : 12:02 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472244">link</a>   </div></div><div class="thread_post_body">Again, running game and quality of targets matters.<br/>
<br/>
The Giants can&#39;t run the ball and all of the primary receiving targets (Golladay, Toney, Smith, Barkley, Engram, etc.) have all missed significant time.<br/>
<br/>
Jones may suck, but he&#39;s also cursed.</div></div><div class="thread_post"><div class="thread_post_header"><b>If you look at Jones stats </b><a name="15472245"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=AnnapolisMike"> AnnapolisMike </a>  : 12:02 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472245">link</a>   </div></div><div class="thread_post_body">He is decidedly a middle tier QB this season.  He ranks about 15th in QBR with QB&#39;s who have played almost every game.  Yesterday his QBR had him ranked 12th for the weekend.  Jones did what he needed to do to win a low scoring defensive game...and that was to not fuck it up.  <br/>
<br/>
Jones glaring weakness in my opinion is that he has a tendancy to have bad nationally televised games.  He has lost them all even though he has played well in some.  <br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>A huge issue for me with the OL is depth. </b><a name="15472252"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Matt+M."> Matt M. </a>  : 12:04 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472252">link</a>   </div></div><div class="thread_post_body">I know we do not have 2 expected opening day starters in the lineup. But, look back to the summer. Lemieux was hurt. They seemed to just assume he would be ready for the season and did nothing to address depth/a replacement until the eve of the season. The same goes for Gates, which became a necessity early in the season. Given how inexperienced their OL was to begin with and that really at least 3 of the 5 spots were still question marks, having no dependable depth was egregious.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: These stats are skewed </b><a name="15472253"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 12:04 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472253">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472191" target="_blank">15472191</a> M.S. said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472172 Gatorade Dunk said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472169 Ira said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472102 PEEJ said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     by the fact that Garrett never threw downfield (where pass pro has to stand up more).  Every passing play was 3-5 yds.<br/>
Garrett cut the balls off the offense <br/>
                                <br/>
                           <br/>
<br/>
This. <br/>
                                <br/>
                           <br/>
Then the pocket time would be lower.<br/>
<br/>
Is BBI really this innumerate? <br/>
                                <br/>
                           <br/>
Gatorade Dunk -- if the Giants passing game was turned into dink and donk by Garrett, then that would make just about all of your stats give an inflated view of our O-line&#39;s pass blocking skills. That includes:<br/>
<br/>
Sacks per game <br/>
Sack percentage<br/>
Pressures per game<br/>
Pressure percentage<br/>
Hurries per game<br/>
Hits per game<br/>
<br/>
How can a team look bad on the above stats when they are getting rid of the ball on short to intermediate passes? </td>
                                </tr>
                           </tbody></table><br/>
True. And that&#39;s why pocket time is included as the catch-all reverse metric.<br/>
<br/>
If a team is purely dink-and-dunk to protect themselves from a poor OL, they&#39;ll see their pocket time average decline. But the Giants aren&#39;t at the bottom of the league there, either.<br/>
<br/>
Their offensive scheme may suck, but it&#39;s not because they don&#39;t have enough time to execute something that at least resembles a 2021 NFL offense.</div></div><div class="thread_post"><div class="thread_post_header"><b>Im not seeing </b><a name="15472256"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=dlauster"> dlauster </a>  : 12:05 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472256">link</a>   </div></div><div class="thread_post_body">the &#34;opening running lanes per game&#34; stat. That&#39;s the one we&#39;d be at the league bottom on.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: RE: I&#39;m </b><a name="15472257"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Brown_Hornet"> Brown_Hornet </a>  : 12:05 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472257">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472146" target="_blank">15472146</a> Gatorade Dunk said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
 <br/>
                                <br/>
                           <br/>
Now we&#39;re reintroducing other excuses. The premise of this post was that if the last remaining excuse for DJ is the OL, should it be a worthy excuse? </td>
                                </tr>
                           </tbody></table>Dunk, the Rushing issue is a big part of the protection issue. Because the team cannot run there is no reason to bring a S up into the box. Because the team cannot pass block, there is no reason to blitz.<br/>
<br/>
It is possible that DJ has a bit more time to throw than some because of this...it also means that there are more defenders in coverage.<br/>
<br/>
Statistics are good for peer review but they are generally not something on which you might base a theory.<br/>
<br/>
my $0.02</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: RE: RE: I&#39;m </b><a name="15472269"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=christian"> christian </a>  : 12:09 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472269">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472257" target="_blank">15472257</a> Brown_Hornet said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">Dunk, the Rushing issue is a big part of the protection issue. Because the team cannot run there is no reason to bring a S up into the box. Because the team cannot pass block, there is no reason to blitz.<br/>
<br/>
It is possible that DJ has a bit more time to throw than some because of this...it also means that there are more defenders in coverage.<br/>
<br/>
Statistics are good for peer review but they are generally not something on which you might base a theory.<br/>
<br/>
my $0.02 </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Jones is the 5th most blitzed QB in the NFL this year.</div></div><div class="thread_post"><div class="thread_post_header"><b>Also keep in mind  </b><a name="15472277"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Matt+M."> Matt M. </a>  : 12:10 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472277">link</a>   </div></div><div class="thread_post_body">rollouts, whether designed or out of necessity to extend plays both increase the time to throw, while not really indicating a lack of protection.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Gatorade Dunk </b><a name="15472283"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 12:11 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472283">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472244" target="_blank">15472244</a> Eric from BBI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Again, running game and quality of targets matters.<br/>
<br/>
The Giants can&#39;t run the ball and all of the primary receiving targets (Golladay, Toney, Smith, Barkley, Engram, etc.) have all missed significant time.<br/>
<br/>
Jones may suck, but he&#39;s also cursed. </td>
                                </tr>
                           </tbody></table><br/>
I agree with you on that last point. He may suck, he may be cursed, it may be both.<br/>
<br/>
But as we head toward an offseason where his 5y option is due to be decided upon, I don&#39;t think it would be wise to invest bigger dollars in him while he&#39;s still a question mark.<br/>
<br/>
Maybe that&#39;s unfair to him (it probably is, on some level), and maybe that could be a mistake if all of the excuses are true. But I know that if we need to rebuild much of this roster yet again, it will be easier to do so in 2023 without a $21M QB on the books who can&#39;t seem to even average a single passing TD per game.<br/>
<br/>
I just want the Giants to be consistently in the hunt again. I don&#39;t want our wins to feel like a surprise party anymore. I don&#39;t see how we get there without a lot of work on the roster, which has been built outside-in despite the very vocal plan of DG when he was hired. And it doesn&#39;t make any sense to carry DJ into a second contract for that rebuild unless it&#39;s crystal clear that he&#39;s a stud and the roster around him is the issue.<br/>
<br/>
I just don&#39;t think anyone can claim that with a straight face or functioning brain.</div></div><div class="thread_post"><div class="thread_post_header"><b>I get the argument </b><a name="15472287"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UberAlias"> UberAlias </a>  : 12:12 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472287">link</a>   </div></div><div class="thread_post_body">Considering the issues you can&#39;t say with certainty that Jones is NOT the guy. But my issues is when you look at it from the other end, where are the signs that he IS the guy?  I know when you watch really good QBs when they aren&#39;t producing because of Oline or WR issues, I feel like they&#39;re always at least on the verge of busting a big play on you. Like you can hold them back for so long but as soon as the defnese slips just a little, he&#39;s going to make them pay.  Does anyone honestly feel like that when you watch Jones plan?  I know I don&#39;t.</div></div><div class="thread_post"><div class="thread_post_header"><b>The OL issues aren&#39;t even worthy quantifying  </b><a name="15472292"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=AcesUp"> AcesUp </a>  : 12:12 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472292">link</a>   </div></div><div class="thread_post_body">It&#39;s a liability. That&#39;s all there really is to it. Whether 5-10 other NFL teams are running into a similar issue is largely irrelevant to the Giants. It is a bad enough unit that it will completely derail your production without high end QB play and/or coaching. The Giants aren&#39;t getting those either. I believe Jones has legitimate excuses in his OL and playing in what I believe is a broken offensive scheme that puts too much pressure on the QB and skill players to be perfect. That said, it&#39;s not like the Giants have the 20th best offense in the NFL, they&#39;ve been among the 2-3 worst over the past couple of seasons with basically zero eruption games. Jones is responsible for a lot of that regardless of his situation. He&#39;s the QB, the ball is in his hands on every play.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Im not seeing </b><a name="15472295"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 12:12 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472295">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472256" target="_blank">15472256</a> dlauster said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> the &#34;opening running lanes per game&#34; stat. That&#39;s the one we&#39;d be at the league bottom on. </td>
                                </tr>
                           </tbody></table><br/>
I&#39;m not seeing how that has a fucking thing to do with pass protection. But hey, I guess maybe we both suck at reading comprehension.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: RE: RE: RE: I&#39;m </b><a name="15472304"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Brown_Hornet"> Brown_Hornet </a>  : 12:13 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472304">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472269" target="_blank">15472269</a> christian said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472257 Brown_Hornet said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                    Dunk, the Rushing issue is a big part of the protection issue. Because the team cannot run there is no reason to bring a S up into the box. Because the team cannot pass block, there is no reason to blitz.<br/>
<br/>
It is possible that DJ has a bit more time to throw than some because of this...it also means that there are more defenders in coverage.<br/>
<br/>
Statistics are good for peer review but they are generally not something on which you might base a theory.<br/>
<br/>
my $0.02 <br/>
                                <br/>
                           <br/>
<br/>
Jones is the 5th most blitzed QB in the NFL this year. </td>
                                </tr>
                           </tbody></table>If you say so.<br/>
<br/>
I stand by my post. If your team is one dimensional and is poor at that thing, you&#39;re in trouble.<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: RE: RE: RE: RE: I&#39;m </b><a name="15472326"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 12:18 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472326">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472304" target="_blank">15472304</a> Brown_Hornet said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472269 christian said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472257 Brown_Hornet said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                    Dunk, the Rushing issue is a big part of the protection issue. Because the team cannot run there is no reason to bring a S up into the box. Because the team cannot pass block, there is no reason to blitz.<br/>
<br/>
It is possible that DJ has a bit more time to throw than some because of this...it also means that there are more defenders in coverage.<br/>
<br/>
Statistics are good for peer review but they are generally not something on which you might base a theory.<br/>
<br/>
my $0.02 <br/>
                                <br/>
                           <br/>
<br/>
Jones is the 5th most blitzed QB in the NFL this year. <br/>
                                <br/>
                           If you say so.<br/>
<br/>
I stand by my post. If your team is one dimensional and is poor at that thing, you&#39;re in trouble.<br/>
 </td>
                                </tr>
                           </tbody></table><br/>
There&#39;s no &#34;if you say so.&#34;<br/>
<br/>
All of you have access to the same insight that anyone else does. You just choose to not actually observe it.</div></div><div class="thread_post"><div class="thread_post_header"><b>This link actually says so.  Giants have been blitzed 3rd most </b><a name="15472343"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Jimmy+Googs"> Jimmy Googs </a>  : 12:22 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472343">link</a>   </div></div><div class="thread_post_body">times in NFL thus far as shown in the Pressure tab under Advanced Passing.<br/>
<br/>
<a href="https://www.pro-football-reference.com/years/2021/advanced.htm" target="_blank">https://www.pro-football-reference.com/years/2021/advanced.htm</a><br/>
<br/>
<br/>
so there&#39;s that...<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>Correct... </b><a name="15472346"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Brown_Hornet"> Brown_Hornet </a>  : 12:22 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472346">link</a>   </div></div><div class="thread_post_body">...that&#39;s why I said &#34;if you say so.&#34;<br/>
<br/>
It wasn&#39;t snarky, it was honest. I believe him.<br/>
<br/>
The OL stinks, it&#39;s not a myth.</div></div><div class="thread_post"><div class="thread_post_header"><b>I think those ancillary stats actually bear out.  </b><a name="15472365"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Ten+Ton+Hammer"> Ten Ton Hammer </a>  : 12:26 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472365">link</a>   </div></div><div class="thread_post_body">Middle of the road OL pass pro numbers, middle of the road QB numbers. Jones isn&#39;t so talented that he can rise above it without help.</div></div><div class="thread_post"><div class="thread_post_header"><b>..... </b><a name="15472368"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=CoughlinHandsonHips"> CoughlinHandsonHips </a>  : 12:26 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472368">link</a>   </div></div><div class="thread_post_body">The stats only tell part of the story.<br/>
<br/>
How would these stats look if the Giants ran an average number of plays that required time for the WRs to get downfield?<br/>
<br/>
That being said, while the offensive line is bad, I think we&#39;re seeing enough that Jones doesn&#39;t have it on the rare occasion he&#39;s given time (especially in the red zone)</div></div><div class="thread_post"><div class="thread_post_header"><b>A bad QB magnifies the issues with the OL </b><a name="15472372"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Producer"> Producer </a>  : 12:28 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472372">link</a>   </div></div><div class="thread_post_body">period and full stop. We have OL guys who failed here and worked out on teams with so-called *better* OLs.<br/>
<br/>
Jones is the main problem here. Which is not to say the OL doesn&#39;t need to be improved, but the QB needs to help the OL gel. This guy can&#39;t do it.</div></div><div class="thread_post"><div class="thread_post_header"><b>According to Papa yesterday, </b><a name="15472379"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dave+in+Hoboken"> Dave in Hoboken </a>  : 12:30 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472379">link</a>   </div></div><div class="thread_post_body">there were at least a few plays where the Eagles were generating pressure while only rushing 3.<br/>
<br/>
The OL is pathetic.  Maybe Thomas is a good player, but that&#39;s it.</div></div><div class="thread_post"><div class="thread_post_header"><b>… </b><a name="15472380"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=christian"> christian </a>  : 12:30 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472380">link</a>   </div></div><div class="thread_post_body">Seems like there is a subset of Giants fans who aren’t interested in debating the facts/new information. That’s cool, add another name to the list of <span class="italics">too boring to have an interesting exchange with</span>.<br/>
<br/>
I posted several times before the year started, and it’s even more true now. The development of the offense is all about odds. <br/>
<br/>
I felt it was low odds Solder, Peart, Lemieux and Hernandez would all be better than their last year on the field. I felt it was low odds the Giants would repeat the health along the line they had in 2020.<br/>
<br/>
So now keep in mind 4 of the 5 starters yesterday are not under contract next year, and Gates and Lemieux are coming off major injuries.<br/>
<br/>
What are the odds the Giants upgrade 4 offensive line positions next year?<br/>
<br/>
I think the better odds are with upgrading the QB talent.</div></div><div class="thread_post"><div class="thread_post_header"><b>What do those in the pro Jones camp </b><a name="15472382"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UberAlias"> UberAlias </a>  : 12:30 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472382">link</a>   </div></div><div class="thread_post_body">See in him that makes them believe he is the guy? Having a bad Oline doesn&#39;t make someone a good QB. So what are you seeing that convinces you he&#39;s be any good with a better Oline?</div></div><div class="thread_post"><div class="thread_post_header"><b>Forget the stats  </b><a name="15472388"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Lines+of+Scrimmage"> Lines of Scrimmage </a>  : 12:31 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472388">link</a>   </div></div><div class="thread_post_body">and use your eye.  It has not been good.  What I see is it comes from both the outside and the interior and that is the death trap.  QB can&#39;t step up and maneuver in the pocket.<br/>
<br/>
The biggest issue is they don&#39;t get consistent rush yards on 1st down.  Too many 2nd and 9&#39;s or worse.  Hard to keep a defense of guard.  What we do not know is what Jones role is in it.  Eli who was exceptional at changing out of bad plays couldn&#39;t overcome the OL so I think it is probably still a OL issue.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: A bad QB magnifies the issues with the OL </b><a name="15472394"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  : 12:33 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472394">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472372" target="_blank">15472372</a> Producer said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> period and full stop. We have OL guys who failed here and worked out on teams with so-called *better* OLs.<br/>
<br/>
Jones is the main problem here. Which is not to say the OL doesn&#39;t need to be improved, but the QB needs to help the OL gel. This guy can&#39;t do it. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I echoed the same thing above. But I&#39;m not sure how to allocate the %s between OL and QB. My instinct is to say it mostly Jones. And that&#39;s driven by my theory that he isn&#39;t good at going to the LOS and getting us into a better play that would help the OL. I would love to know how many times he checks out of the called play. My guess is he runs that play well over 90% of the time...<br/>
<br/>
Which brings into question Jones&#39;s football IQ. I just don&#39;t think it&#39;s that good for the position.</div></div><div class="thread_post"><div class="thread_post_header"><b>The OL sucks. </b><a name="15472395"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BrettNYG10"> BrettNYG10 </a>  : 12:34 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472395">link</a>   </div></div><div class="thread_post_body">But I don&#39;t think it&#39;s absolutely the &#39;worst in the NFL&#39;. OL play league wide is pretty poor.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Im not seeing </b><a name="15472397"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=dlauster"> dlauster </a>  : 12:34 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472397">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472295" target="_blank">15472295</a> Gatorade Dunk said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472256 dlauster said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     the &#34;opening running lanes per game&#34; stat. That&#39;s the one we&#39;d be at the league bottom on. <br/>
                                <br/>
                           <br/>
I&#39;m not seeing how that has a fucking thing to do with pass protection. But hey, I guess maybe we both suck at reading comprehension. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Like many here I’m simply stating that they are related…</div></div><div class="thread_post"><div class="thread_post_header"><b>I don&#39;t need pass protection and rushing stats to tell me this OL suck </b><a name="15472403"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Rick+in+Dallas"> Rick in Dallas </a>  : 12:35 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472403">link</a>   </div></div><div class="thread_post_body">My eyes don&#39;t deceive what I see every game.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: if </b><a name="15472409"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BrettNYG10"> BrettNYG10 </a>  : 12:37 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472409">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472213" target="_blank">15472213</a> Eric from BBI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> you are going to react to results, Jones clearly isn&#39;t having the season he need to have. It looks like he is part of the problem.<br/>
<br/>
But this stuff is all interrelated.<br/>
<br/>
Unless you really believe Eli Manning went from arguably league MVP at the age of 30 to bum for the entire second half of his career, then you need know other evidence that the team&#39;s OL has been horrific for a decade. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Eli had pretty good 2014/2015 seasons behind very poor OLs.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: A bad QB magnifies the issues with the OL </b><a name="15472414"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Section331"> Section331 </a>  : 12:38 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472414">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472394" target="_blank">15472394</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
I echoed the same thing above. But I&#39;m not sure how to allocate the %s between OL and QB. My instinct is to say it mostly Jones. And that&#39;s driven by my theory that he isn&#39;t good at going to the LOS and getting us into a better play that would help the OL. I would love to know how many times he checks out of the called play. My guess is he runs that play well over 90% of the time...<br/>
<br/>
Which brings into question Jones&#39;s football IQ. I just don&#39;t think it&#39;s that good for the position. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I tend to agree with this. The announcers mentioned yesterday that with Kitchens, Jones would be given more autonomy at the LOS. It appears that at the least, Garrett restricted his ability to make changes. He didn&#39;t do that with Romo or Dak, so maybe he was concerned about what Jones was seeing?<br/>
<br/>
And it&#39;s not only playcalling. The QB is a check on the OC&#39;s line calls. He has to ID the Mike and try to determine where the pressure is going to come from. If Jones isn&#39;t doing that properly, he could be one of the reasons for the OL struggles.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: most of us are realists and can see that jones and barkley </b><a name="15472416"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Thegratefulhead"> Thegratefulhead </a>  : 12:38 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472416">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472194" target="_blank">15472194</a> japanhead said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472173 M.S. said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472090 japanhead said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     are bigger problems than the OL, or at least the OL is no bigger a problem than those two are. <br/>
<br/>
i&#39;d honestly like to see jones and barkley replaced with glennon and booker. i don&#39;t think you&#39;d see any drop-off in offensive production and would likely see an uptick. <br/>
                                <br/>
                           <br/>
Wow.<br/>
<br/>
I disagree with your point of view. <br/>
                                <br/>
                           <br/>
<br/>
disagree all you want. <br/>
<br/>
we have already seen booker be more productive than barkley behind this same OL. <br/>
<br/>
we have seen toney have 189 yards receiving in one half of one game with glennon throwing him the ball behind this same OL.<br/>
<br/>
there is just no evidence this season that jones and barkely are difference makers at their positions, and there is plenty of evidence to suggest they exacerbate the teams OL problems.  <br/>
<br/>
<br/>
 </td>
                                </tr>
                           </tbody></table>Solid post.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Correct... </b><a name="15472421"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Jimmy+Googs"> Jimmy Googs </a>  : 12:40 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472421">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472346" target="_blank">15472346</a> Brown_Hornet said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> ...that&#39;s why I said &#34;if you say so.&#34;<br/>
<br/>
It wasn&#39;t snarky, it was honest. I believe him.<br/>
<br/>
The OL stinks, it&#39;s not a myth. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
right, the myth is the comment that Jones has more time to throw because he isn&#39;t being blitzed and that there are more guys in coverage...</div></div><div class="thread_post"><div class="thread_post_header"><b>This is a great thread </b><a name="15472428"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=The+Jake"> The Jake </a>  : 12:42 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472428">link</a>   </div></div><div class="thread_post_body">educational and entertaining. It&#39;s sort of a microcosm of all the &#34;bickering&#34; on BBI - there&#39;s a contingent of posters who are interested in investigating the data generated by what&#39;s happening on the field, and there&#39;s a contingent of posters who say to &#34;trust your eyes&#34; and that data can be skewed in any direction.<br/>
<br/>
Both groups are right. And wrong! And it&#39;s probably similar to the arguments happening within the Giants organization itself. I would say the &#34;trust your eyes&#34; folks have been winning those arguments for the last decade - to the detriment of the franchise - but that&#39;s just my opinion. <br/>
<br/>
As for the data analysis, yeoman&#39;s work here by GD, but I think even he would admit that it&#39;s incomplete as there are other data points that are relevant, yet missing. WR separation is one that comes to mind for me - maybe Jones is getting the ball out quicker to avoid the rush, but not actually connecting often enough because the receivers aren&#39;t open. Passes defended would be another one. And both of those would be a symptom of lack of talent and/or poor play calling and coaching.</div></div><div class="thread_post"><div class="thread_post_header"><b>I am not qualified to offer anything more than </b><a name="15472434"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=arniefez"> arniefez </a>  : 12:44 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472434">link</a>   </div></div><div class="thread_post_body">an opinion based on 50+ years of watching NFL football from the stands and the couch. <br/>
<br/>
Daniel Jones is the biggest problem the Giants have, followed closely by the lack of a pass rush, followed closely by the Giants OGs and C. <br/>
<br/>
We&#39;ve heard Judge say Jones is his guy, Jones can be a very good NFL QB etc. But those are words. When it came time to win the game yesterday after Scott fumbled what did the Giants do? They ran 3 give up plays to try and get the Eagles to burn their TOs and punted without even making an attempt to get a first down and end the game with the ball. Some of that might be not trusting the horrible OL but it&#39;s a clear indication of what the coaching staff thinks of the QB. They don&#39;t trust hi to protect the ball and protect the lead. <br/>
<br/>
As bad as the Eagles QB played yesterday they win the game if their receiver doesn&#39;t drop two very catchable balls at the end of the game.<br/>
<br/>
I can&#39;t believe that Solder is still starting over Peart at RT so maybe Judge really thinks Jones is his QB and it wasn&#39;t a trust thing. Maybe that&#39;s just how Judge will evaluate and coach until he&#39;s fired. Which will be at the end of next year the latest IMO if he keeps playing players like Solder and playing not to lose.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: While it’s a problem </b><a name="15472438"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Batenhorst7"> Batenhorst7 </a>  : 12:45 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472438">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472186" target="_blank">15472186</a> CMicks3110 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> It would be less so If Jones could throw on the run. DJ is a mobile QB, but he’s a pocket passer. He needs to be able to step into the throw to get enough on it and to be accurate. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
You are right on there<br/>
Rodgers and Wilson are Masters of moving up in the pocket and throwing accurately on the run<br/>
<br/>
Jones (much like Phil Simms) has not mastered this very important dynamic<br/>
<br/>
Phil won a few games and a Trophy though</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I don&#39;t need pass protection and rushing stats to tell me this OL suck </b><a name="15472456"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 12:49 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472456">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472403" target="_blank">15472403</a> Rick in Dallas said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> My eyes don&#39;t deceive what I see every game. </td>
                                </tr>
                           </tbody></table><br/>
The OL does suck! But a dozen other OLs around the league also suck, some much worse! And some QBs who work behind those lesser OLs are still performing at a higher level than DJ.<br/>
<br/>
This is not intended to absolve the OL of ANY blame here; after all, they were hand-chosen by the same dimwit who built the rest of the roster, but that it is possible to perform at least adequately behind a mediocre OL, because we&#39;re seeing it happen for other teams.<br/>
<br/>
But OL play in general is in decline across the league, yet I think many Giants fans only watch our games and thus are comparing our OL to past years instead of what is actually happening in the NFL right now. <br/>
<br/>
Our OL needs to be improved, drastically. But so does our QB.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: … </b><a name="15472470"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Thegratefulhead"> Thegratefulhead </a>  : 12:51 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472470">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472380" target="_blank">15472380</a> christian said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Seems like there is a subset of Giants fans who aren’t interested in debating the facts/new information. That’s cool, add another name to the list of too boring to have an interesting exchange with.<br/>
<br/>
I posted several times before the year started, and it’s even more true now. The development of the offense is all about odds. <br/>
<br/>
I felt it was low odds Solder, Peart, Lemieux and Hernandez would all be better than their last year on the field. I felt it was low odds the Giants would repeat the health along the line they had in 2020.<br/>
<br/>
So now keep in mind 4 of the 5 starters yesterday are not under contract next year, and Gates and Lemieux are coming off major injuries.<br/>
<br/>
What are the odds the Giants upgrade 4 offensive line positions next year?<br/>
<br/>
I think the better odds are with upgrading the QB talent. </td>
                                </tr>
                           </tbody></table>I agree with you. I was a Jones guy, the objective evidence become overwhelming though. He makes some beautiful passes with touch that are elite. He is too inconsistent for the position and he has done nothing to give hope it will ever change.  Too many wild passes on 3rd and six.<br/>
<br/>
We beat Seattle last year with McCoy and we won a game with Glennon this year. When Jones was hurt this year, it would have been nice to sit him for a few weeks to see what the offense would look like with different QB getting all the practice reps and a couple of weeks to get him used to the system. <br/>
<br/>
It was an important piece of information we failed to acquire in the midst of another lost season.</div></div><div class="thread_post"><div class="thread_post_header"><b>NFL stats are the worst stats in all of sports </b><a name="15472476"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=USAF+NYG+Fan"> USAF NYG Fan </a>  : 12:52 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472476">link</a>   </div></div><div class="thread_post_body">People pigeon pick to make their point.  Perhaps I am old school but I believe you still win in the trenches and it&#39;s very clear to those who watch the games and have watched for decades that the Giants OL is, and has been, absolute trash.<br/>
<br/>
However, you want stats so how about we simply google OL rankings for 2021?<br/>
<br/>
<a href="https://www.pff.com/news/nfl-week-10-offensive-line-rankings-2021" target="_blank">https://www.pff.com/news/nfl-week-10-offensive-line-rankings-2021</a><br/>
31st in the league according to PFF after week 10<br/>
<br/>
<a href="https://www.pff.com/news/nfl-ranking-all-32-nfl-offensive-line-units-entering-2021-season" target="_blank">https://www.pff.com/news/nfl-ranking-all-32-nfl-offensive-line-units-entering-2021-season</a><br/>
PFF again before the season started, dead last.<br/>
<br/>
<a href="https://www.sharpfootballanalysis.com/analysis/2021-nfl-offensive-line-rankings-by-positional-unit/" target="_blank">https://www.sharpfootballanalysis.com/analysis/2021-nfl-offensive-line-rankings-by-positional-unit/</a><br/>
Never heard of this site before but Giants rank 2nd to last again.<br/>
<br/>
<a href="https://www.sportingnews.com/us/fantasy/news/2021-nfl-offensive-line-rankings-fantasy-football-sleepers-busts/1a383cwxkyin71wj5ggqcs1gdz" target="_blank">https://www.sportingnews.com/us/fantasy/news/2021-nfl-offensive-line-rankings-fantasy-football-sleepers-busts/1a383cwxkyin71wj5ggqcs1gdz</a><br/>
Sporting News<br/>
<br/>
I could easily keep going but the point is that of the people that get paid to report on stuff like this, NOBODY has the Giants&#39; OL as the &#34;middle of the pack&#34;.  NOBODY!<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>So Dunk is this thread about the OL or our QB??? </b><a name="15472495"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Rick+in+Dallas"> Rick in Dallas </a>  : 12:57 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472495">link</a>   </div></div><div class="thread_post_body">I agree DJ is not a franchise QB but like I said this OL sucks. Right now 4 of the 5 starters on our OL are backups on other teams(maybe?).<br/>
Why not put Brederson in at LG(since we burned a 4th round draft choice) move Skura to center and start Peart at RT. Can it be any worse??? <br/>
Just a thought!!!</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: A bad QB magnifies the issues with the OL </b><a name="15472516"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Producer"> Producer </a>  : 1:01 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472516">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472394" target="_blank">15472394</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472372 Producer said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     period and full stop. We have OL guys who failed here and worked out on teams with so-called *better* OLs.<br/>
<br/>
Jones is the main problem here. Which is not to say the OL doesn&#39;t need to be improved, but the QB needs to help the OL gel. This guy can&#39;t do it. <br/>
                                <br/>
                           <br/>
<br/>
I echoed the same thing above. But I&#39;m not sure how to allocate the %s between OL and QB. My instinct is to say it mostly Jones. And that&#39;s driven by my theory that he isn&#39;t good at going to the LOS and getting us into a better play that would help the OL. I would love to know how many times he checks out of the called play. My guess is he runs that play well over 90% of the time...<br/>
<br/>
Which brings into question Jones&#39;s football IQ. I just don&#39;t think it&#39;s that good for the position. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
yes. but it&#39;s not just checking to a different play. His post-snap movement helps with the protections. But yes he is bad at the LOS. He doesn&#39;t move protections. He doesn&#39;t do anything other than what is scripted. <br/>
<br/>
Jones is a badly performing robot.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: So Dunk is this thread about the OL or our QB??? </b><a name="15472539"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 1:06 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472539">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472495" target="_blank">15472495</a> Rick in Dallas said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I agree DJ is not a franchise QB but like I said this OL sucks. Right now 4 of the 5 starters on our OL are backups on other teams(maybe?).<br/>
Why not put Brederson in at LG(since we burned a 4th round draft choice) move Skura to center and start Peart at RT. Can it be any worse??? <br/>
Just a thought!!! </td>
                                </tr>
                           </tbody></table><br/>
I&#39;m not sure if this is unclear, but several posters seem to think that the OL is a viable excuse for DJ&#39;s mediocrity. And if that&#39;s the case, then the OL should be overwhelmingly bad, right? But if the OL is middle of the pack, and DJ is still mediocre, then maybe he&#39;s just mediocre.<br/>
<br/>
I guess that that was not especially clear with the thread title or the OP?</div></div><div class="thread_post"><div class="thread_post_header"><b>Some of those teams at the bottom </b><a name="15472542"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Simms11"> Simms11 </a>  : 1:07 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472542">link</a>   </div></div><div class="thread_post_body">of Oline statistics categories actually have winning records or close. They also have QBs that can overcome poor Oline play. Jones still has and appears like he always will have a slow ability to process things and get the ball to the right receiver. If play breaks down, forget it, he seems to panic. He’s a good kid, with a decent arm and ability to run, but if you can’t process quickly, what’s happening, then you’re already sunk. He also locks onto his receivers and that’s a very poor habit as well. I just have not seen it consistently from him. I think we will have one more year with him and then all bets are off.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: NFL stats are the worst stats in all of sports </b><a name="15472543"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 1:07 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472543">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472476" target="_blank">15472476</a> USAF NYG Fan said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> People pigeon pick to make their point.  Perhaps I am old school but I believe you still win in the trenches and it&#39;s very clear to those who watch the games and have watched for decades that the Giants OL is, and has been, absolute trash.<br/>
<br/>
However, you want stats so how about we simply google OL rankings for 2021?<br/>
<br/>
https://www.pff.com/news/nfl-week-10-offensive-line-rankings-2021<br/>
31st in the league according to PFF after week 10<br/>
<br/>
https://www.pff.com/news/nfl-ranking-all-32-nfl-offensive-line-units-entering-2021-season<br/>
PFF again before the season started, dead last.<br/>
<br/>
https://www.sharpfootballanalysis.com/analysis/2021-nfl-offensive-line-rankings-by-positional-unit/<br/>
Never heard of this site before but Giants rank 2nd to last again.<br/>
<br/>
https://www.sportingnews.com/us/fantasy/news/2021-nfl-offensive-line-rankings-fantasy-football-sleepers-busts/1a383cwxkyin71wj5ggqcs1gdz<br/>
Sporting News<br/>
<br/>
I could easily keep going but the point is that of the people that get paid to report on stuff like this, NOBODY has the Giants&#39; OL as the &#34;middle of the pack&#34;.  NOBODY! </td>
                                </tr>
                           </tbody></table><br/>
Ah, one of the days that BBI likes PFF.<br/>
<br/>
Try running PFF metrics around these parts when they&#39;re not favorable, see how that goes.<br/>
<br/>
Also, those are not isolated to pass pro.</div></div><div class="thread_post"><div class="thread_post_header"><b>Dunk... </b><a name="15472560"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Brown_Hornet"> Brown_Hornet </a>  : 1:12 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472560">link</a>   </div></div><div class="thread_post_body">... I thought I saw enough in the 1st 2 years That made me think Maybe it&#39;s the surrounding cast.<br/>
Now I believe the giants need to move on at QB.<br/>
<br/>
I don&#39;t believe that that excuses the OL and I don&#39;t believe that they are middle of the pack.<br/>
<br/>
Clearly this team has a multitude of issues that need to be addressed in the draft. At this point with a little bit of knowledge I don&#39;t believe that any of the quarterbacks will be worthy of 1 of our 1st round selections based on the other talent that will be available... I guess I just don&#39;t like the idea of reaching for a quarterback.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: So Dunk is this thread about the OL or our QB??? </b><a name="15472564"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=M.S."> M.S. </a>  : 1:16 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472564">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472539" target="_blank">15472539</a> Gatorade Dunk said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472495 Rick in Dallas said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     I agree DJ is not a franchise QB but like I said this OL sucks. Right now 4 of the 5 starters on our OL are backups on other teams(maybe?).<br/>
Why not put Brederson in at LG(since we burned a 4th round draft choice) move Skura to center and start Peart at RT. Can it be any worse??? <br/>
Just a thought!!! <br/>
                                <br/>
                           <br/>
I&#39;m not sure if this is unclear, but several posters seem to think that the OL is a viable excuse for DJ&#39;s mediocrity. And if that&#39;s the case, then the OL should be overwhelmingly bad, right? But if the OL is middle of the pack, and DJ is still mediocre, then maybe he&#39;s just mediocre.<br/>
<br/>
I guess that that was not especially clear with the thread title or the OP? </td>
                                </tr>
                           </tbody></table><br/>
Your stats don&#39;t prove mediocrity. If the Giants have purposefully shortened their passing game due to their scary pass blocking, then the stats you opened with are not relevant.<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>it&#39;s weird that people ignore the pocket time number </b><a name="15472567"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=PerpetualNervousness"> PerpetualNervousness </a>  : 1:16 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472567">link</a>   </div></div><div class="thread_post_body">as GD keeps pointing out, it&#39;s middle of the pack. it&#39;s not artificially inflated by roll outs.  the Giants are not the only team in the NFL that tries to compensate for poor OL play by moving the QB. the fact that the OL is also bad at run blocking doesn&#39;t change the pocket time number.  it&#39;s pretty simple -   on an average pass play, DJ has about the league average amount of time to make a read and get rid of the ball. that doesn&#39;t mean the OL is good.  but it does suggest as the OP has pointed out that they are not somehow the worst pass blocking OL in the league, let alone the worst OL the NFL has seen in a decade, as may on this board seem to suggest. now, you can fairly argue that Garrett&#39;s play designs were so bad at scheming guys open that there&#39;s no one for Jones to throw the ball too half the time. and the running game has been so bad that he&#39;s often in third and longs and so holds the ball longer to try to make a play (I&#39;d bet there&#39;s  a stat on this too)  but the evidence is also that he&#39;s not a good processor - he misses reads and therefore doesn&#39;t make plays that are there to be made.</div></div><div class="thread_post"><div class="thread_post_header"><b>Giants 2005 </b><a name="15472573"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Lines+of+Scrimmage"> Lines of Scrimmage </a>  : 1:19 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472573">link</a>   </div></div><div class="thread_post_body">2nd year Eli.<br/>
<br/>
Rushing stats.  ave. att/game 29 avypg. 138 ave/rush 4.7<br/>
<br/>
I will stay just in division but take a look at the same stats for Dak and Wentz with their respective teams.  They actual exceed the numbers above.  Both were Pro Bowl in within the first two years.<br/>
<br/>
Patriots with Mac Jones average 28 rushes 116 yards 4.1 <br/>
<br/>
2021 Giants 23 attempts per game.  90 yards per game.  3.8<br/>
<br/>
I am pretty sure they will be moving on from Jones.  I can&#39;t say how much of a impact Jones has on the stats above.  What I will say until the Giants fix the ability to run it is highly likely the next QB is going to struggle as well.  They do not run enough and the average is not consistent where they are winning down and distance.  How much that is Jones, the OL or the skill players is the debate at hand imv.  Don&#39;t forget a lot of the running yards come from a couple bigger gainers and a whole lot of nothing or negative plays.<br/>
<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>Dunk is being extremely polite to some pretty poor responses here </b><a name="15472579"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=cosmicj"> cosmicj </a>  : 1:22 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472579">link</a>   </div></div><div class="thread_post_body">So I’ll come out and say it:<br/>
<br/>
Your subjective impressions of the Giants relative OL performance are worthless.  OL play has deteriorated as defensive player athleticism has improved.  The NFL can’t find enough quality o-lineman.  So your frame of reference, based on amateur viewing of selected other teams from this season and past, are inadequate to the task of ranking the Giants OL.  Just admit it.</div></div><div class="thread_post"><div class="thread_post_header"><b>Their are obvious holes in Daniel Jones&#39; and Saquon Barkley&#39;s game </b><a name="15472582"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=M.S."> M.S. </a>  : 1:23 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472582">link</a>   </div></div><div class="thread_post_body"><br/>
But there are a ton of BBIers who focus in on those holes without ever asking: What do these players look like behind a decent offensive line.<br/>
<br/>
Yesterday, Barkley was given one chance to get through the line untouched and he turned it into a 34-yard run. <br/>
<br/>
Yesterday, I think Daniel Jones threw the ball way downfield ONCE even though there&#39;s a new O.C. And the reason why is obvious: he has no time in the pocket to allow deep routes to develop.<br/>
<br/>
And last but not least, some BBIers seem to think that the QB and RB should make the o-line look at least as good as the O-line making the QB and RB look good.<br/>
<br/>
That is ass backwards.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: it&#39;s weird that people ignore the pocket time number </b><a name="15472593"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=M.S."> M.S. </a>  : 1:25 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472593">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472567" target="_blank">15472567</a> PerpetualNervousness said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> as GD keeps pointing out, it&#39;s middle of the pack. it&#39;s not artificially inflated by roll outs.  the Giants are not the only team in the NFL that tries to compensate for poor OL play by moving the QB. the fact that the OL is also bad at run blocking doesn&#39;t change the pocket time number.  it&#39;s pretty simple -   on an average pass play, DJ has about the league average amount of time to make a read and get rid of the ball. that doesn&#39;t mean the OL is good.  but it does suggest as the OP has pointed out that they are not somehow the worst pass blocking OL in the league, let alone the worst OL the NFL has seen in a decade, as may on this board seem to suggest. now, you can fairly argue that Garrett&#39;s play designs were so bad at scheming guys open that there&#39;s no one for Jones to throw the ball too half the time. and the running game has been so bad that he&#39;s often in third and longs and so holds the ball longer to try to make a play (I&#39;d bet there&#39;s  a stat on this too)  but the evidence is also that he&#39;s not a good processor - he misses reads and therefore doesn&#39;t make plays that are there to be made. </td>
                                </tr>
                           </tbody></table><br/>
Please describe how &#34;pocket time&#34; is being defined? Is it how much time a QB has before someone hits him? Or is it the amount of time the QB takes before he throws the ball? Or, something else?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: it&#39;s weird that people ignore the pocket time number </b><a name="15472622"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 1:35 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472622">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472593" target="_blank">15472593</a> M.S. said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472567 PerpetualNervousness said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     as GD keeps pointing out, it&#39;s middle of the pack. it&#39;s not artificially inflated by roll outs.  the Giants are not the only team in the NFL that tries to compensate for poor OL play by moving the QB. the fact that the OL is also bad at run blocking doesn&#39;t change the pocket time number.  it&#39;s pretty simple -   on an average pass play, DJ has about the league average amount of time to make a read and get rid of the ball. that doesn&#39;t mean the OL is good.  but it does suggest as the OP has pointed out that they are not somehow the worst pass blocking OL in the league, let alone the worst OL the NFL has seen in a decade, as may on this board seem to suggest. now, you can fairly argue that Garrett&#39;s play designs were so bad at scheming guys open that there&#39;s no one for Jones to throw the ball too half the time. and the running game has been so bad that he&#39;s often in third and longs and so holds the ball longer to try to make a play (I&#39;d bet there&#39;s  a stat on this too)  but the evidence is also that he&#39;s not a good processor - he misses reads and therefore doesn&#39;t make plays that are there to be made. <br/>
                                <br/>
                           <br/>
Please describe how &#34;pocket time&#34; is being defined? Is it how much time a QB has before someone hits him? Or is it the amount of time the QB takes before he throws the ball? Or, something else? </td>
                                </tr>
                           </tbody></table><br/>
As defined by PFR, pocket time is the &#34;average time the QB had in the pocket between the snap and throwing the ball or pressure collapses the pocket, in seconds.&#34;<br/>
<br/>
So QBs who get rid of the ball quickly have a low pocket time metric, as do QBs who are pressured quickly (so if they&#39;re forced out of the pocket due to pressure, that also would knock down their pocket time metric). It&#39;s unclear how designed rollouts factor in here, but since most accept that DJ&#39;s mobility is a strength, I don&#39;t think designed rollouts should be viewed as discrediting the data, since intended rollouts should be considered a utilization of one of DJ&#39;s primary skills.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: So Dunk is this thread about the OL or our QB??? </b><a name="15472641"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 1:41 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472641">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472564" target="_blank">15472564</a> M.S. said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472539 Gatorade Dunk said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472495 Rick in Dallas said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     I agree DJ is not a franchise QB but like I said this OL sucks. Right now 4 of the 5 starters on our OL are backups on other teams(maybe?).<br/>
Why not put Brederson in at LG(since we burned a 4th round draft choice) move Skura to center and start Peart at RT. Can it be any worse??? <br/>
Just a thought!!! <br/>
                                <br/>
                           <br/>
I&#39;m not sure if this is unclear, but several posters seem to think that the OL is a viable excuse for DJ&#39;s mediocrity. And if that&#39;s the case, then the OL should be overwhelmingly bad, right? But if the OL is middle of the pack, and DJ is still mediocre, then maybe he&#39;s just mediocre.<br/>
<br/>
I guess that that was not especially clear with the thread title or the OP? <br/>
                                <br/>
                           <br/>
Your stats don&#39;t prove mediocrity. If the Giants have purposefully shortened their passing game due to their scary pass blocking, then the stats you opened with are not relevant.<br/>
 </td>
                                </tr>
                           </tbody></table><br/>
Yes, they do. If the &#34;scary pass blocking&#34; was worse than the league, that would show up somewhere - pressures, hurries, hits, sacks... it doesn&#39;t appear in any of those metrics as being even near the bottom of the league. And so you shift to pocket time, but that&#39;s not really favorable to your argument either, so the question becomes about rollout passes. That&#39;s literally the only exception you&#39;re down to. I did my homework. You tell me how many designed rollouts the Giants ran yesterday. Tell me how many they&#39;ve run this season.<br/>
<br/>
It&#39;s not zero, obviously. It&#39;s part of the scheme and it does protect DJ from a troublesome OL. But other NFL teams have even worse lines. And many of them have QBs that somehow produce more points than DJ.<br/>
<br/>
If the argument is about to shift back to the rest of the offense yet again, I have to repeat the question that no one ever seems to answer: if the entire offense is so bad, and they were all assembled by DG, why do you have faith that he got this one particular draft pick correct when there&#39;s no data to support it?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Their are obvious holes in Daniel Jones&#39; and Saquon Barkley&#39;s game </b><a name="15472645"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 1:42 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472645">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472582" target="_blank">15472582</a> M.S. said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
But there are a ton of BBIers who focus in on those holes without ever asking: What do these players look like behind a decent offensive line.<br/>
<br/>
Yesterday, Barkley was given one chance to get through the line untouched and he turned it into a 34-yard run. <br/>
<br/>
Yesterday, I think Daniel Jones threw the ball way downfield ONCE even though there&#39;s a new O.C. And the reason why is obvious: he has no time in the pocket to allow deep routes to develop.<br/>
<br/>
And last but not least, some BBIers seem to think that the QB and RB should make the o-line look at least as good as the O-line making the QB and RB look good.<br/>
<br/>
That is ass backwards. </td>
                                </tr>
                           </tbody></table><br/>
No, I don&#39;t think anyone expects the QB and RB to make the OL look good. I think some fans understand that the QB and RB are making the OL look worse than they are.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Their are obvious holes in Daniel Jones&#39; and Saquon Barkley&#39;s game </b><a name="15472646"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=ajr2456"> ajr2456 </a>  : 1:43 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472646">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472582" target="_blank">15472582</a> M.S. said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
But there are a ton of BBIers who focus in on those holes without ever asking: What do these players look like behind a decent offensive line.<br/>
<br/>
Yesterday, Barkley was given one chance to get through the line untouched and he turned it into a 34-yard run. <br/>
<br/>
Yesterday, I think Daniel Jones threw the ball way downfield ONCE even though there&#39;s a new O.C. And the reason why is obvious: he has no time in the pocket to allow deep routes to develop.<br/>
<br/>
And last but not least, some BBIers seem to think that the QB and RB should make the o-line look at least as good as the O-line making the QB and RB look good.<br/>
<br/>
That is ass backwards. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
It’s not backwards, we see QBs and RBs rise above bad olines on a weekly basis. Nobody is asking for them to be Rodgers and Barry Sanders, but at least show something.<br/>
<br/>
What has Jones shown on a consistent basis that leads you to believe a good oline will make him a franchise QB?</div></div><div class="thread_post"><div class="thread_post_header"><b>when presented with Brady v Jones in terms of pressure </b><a name="15472655"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Producer"> Producer </a>  : 1:45 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472655">link</a>   </div></div><div class="thread_post_body">Jones apologists said, well Brady gets rid of the ball quickly by design. <br/>
<br/>
So Tom Brady commands his offense and hits his marks faster than the time it takes Daniel Jones to drop back, look confused, and feel pressure. <br/>
<br/>
I think that is a plain indictment of Jones&#39; play. And lets remember Tom Brady is 44 and Daniel Jones is supposed to be entering his prime. <br/>
<br/>
The excuses are mind-numbing.</div></div><div class="thread_post"><div class="thread_post_header"><b>O-Line </b><a name="15472694"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=RHPeel"> RHPeel </a>  : 1:58 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472694">link</a>   </div></div><div class="thread_post_body">Some quick thoughts on this:<br/>
<br/>
1. In practice, when Andrew Thomas is playing, the Giants&#39; pass blocking is... passable. I don&#39;t think it&#39;s the worst in the league. When Thomas is out it&#39;s a train wreck.<br/>
2. They protect the line by keeping in extra guys, running fewer guys on routes, and running short passing plays. When was the last time they were able to go deep? Even Freddie Kitchens--who LOVES the deep ball--stayed pretty short with his passes yesterday.<br/>
3. PFF&#39;s grades are worthwhile here. I know, no one likes them and they&#39;re not gospel, whatever. They match the eye-test. The Giants have mediocre to below average blocking. No one is the worst in the league but a lot of them are on the cusp. <br/>
- Thomas ranks 28/81 among tackles.<br/>
- Solder ranks 68/81 among tackles.<br/>
- Skura ranks 64/81 among guards.<br/>
- Hernandez ranks 71/81 among guards.<br/>
- Price is 26/38 of centers.<br/>
So only one of five even in the &#34;above average&#34; tier, and four of five in the bottom quartile, or close. And that interior line is *very* weak. Which matches what we saw against Tampa, when the Giants had no answers for the interior pass rush. (In its defense, it has two backups and a third player who ought to be. But Lemieux wasn&#39;t good last year either.)<br/>
<br/>
I also think that the line is particularly weak at run blocking. Just watch yesterday&#39;s game: the Eagles had holes ALL DAY, and Barkley gets hit behind the line almost every play.<br/>
<br/>
Here&#39;s another way I&#39;ve been looking at it. The Eagles were minus-4 in turnovers yesterday, and they were a dropped pass at the goal line from winning the game anyway. That&#39;s what good line play gives you.<br/>
<br/>
With all of that said... I think Jones can be a successful QB if he had a line that was actually *good*, rather than barely mediocre. But a lot of quarterbacks could be successful with a good line, and Jones is about to get expensive.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: RE: RE: I&#39;m </b><a name="15472695"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 1:58 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472695">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472257" target="_blank">15472257</a> Brown_Hornet said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472146 Gatorade Dunk said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
 <br/>
                                <br/>
                           <br/>
Now we&#39;re reintroducing other excuses. The premise of this post was that if the last remaining excuse for DJ is the OL, should it be a worthy excuse? <br/>
                                <br/>
                           Dunk, the Rushing issue is a big part of the protection issue. Because the team cannot run there is no reason to bring a S up into the box. Because the team cannot pass block, there is no reason to blitz.<br/>
<br/>
It is possible that DJ has a bit more time to throw than some because of this...it also means that there are more defenders in coverage.<br/>
<br/>
Statistics are good for peer review but they are generally not something on which you might base a theory.<br/>
<br/>
my $0.02 </td>
                                </tr>
                           </tbody></table><br/>
This is an interesting counter. But it&#39;s worth noting that one of DJ&#39;s purported strengths is his running ability. So if a team fails to respect that by dropping an extra man into coverage rather than keeping a spy or blitzer in on any given play, he should be able to make them pay with his legs, right? And if he&#39;s unable to because he&#39;s facing pressure, that should show up in any of these metrics, right?</div></div><div class="thread_post"><div class="thread_post_header"><b>At this point it doesn&#39;t matter if Jones is the guy. </b><a name="15472705"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=jsuds"> jsuds </a>  : 2:01 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472705">link</a>   </div></div><div class="thread_post_body">Until whoever the eff is behind center for the Giants has a decent O-line in front of them this offense will continue to suck. If the draft next year can fill out the holes up front, at least enough of them to make this line halfway decent, Jones is the best/only option. Why draft another deer in the headlights in the making now? And some of those stats above can be attributed to Jones throwing it as fast as possible to avoid getting killed.</div></div><div class="thread_post"><div class="thread_post_header"><b>Gatorade Dunk </b><a name="15472709"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=M.S."> M.S. </a>  : 2:03 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472709">link</a>   </div></div><div class="thread_post_body"><br/>
You seem to want to force the Daniel Jones argument into a simple dichotomy: The BBIers who think he is fine vs the BBIers who think he needs to be discarded or is only a back-up talent at best. <br/>
<br/>
You are obvious the latter, otherwise you would not have hauled out all these PFF stats.<br/>
<br/>
But there’s a more nuanced view that goes like this:<br/>
<br/>
The current O-line with one legit NFL starter doesn’t really allow us to plant our flag on either side of the Daniel Jones dichotomy.<br/>
<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>It’s entirely possible to say you don’t think Daniel Jones is good </b><a name="15472712"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=shockeyisthebest8056"> shockeyisthebest8056 </a>  : 2:04 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472712">link</a>   </div></div><div class="thread_post_body">without the stupidity of pretending this offensive line is good, adequate, or even marginally professional.<br/>
<br/>
The Athletic had an article last week ranking pass blocking and had the Giants as a middle of the pack (18th, I think). The problem was all of their best individual pass protectors were the three guys who’ve played the least… Lemieux, Gates, and Thomas.<br/>
<br/>
There’s more than enough people on BBI who know no other words than Jones sucks. Nonsense like this is completely unnecessary.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Gatorade Dunk </b><a name="15472721"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 2:08 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472721">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472709" target="_blank">15472709</a> M.S. said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
You seem to want to force the Daniel Jones argument into a simple dichotomy: The BBIers who think he is fine vs the BBIers who think he needs to be discarded or is only a back-up talent at best. <br/>
<br/>
You are obvious the latter, otherwise you would not have hauled out all these PFF stats.<br/>
<br/>
But there’s a more nuanced view that goes like this:<br/>
<br/>
The current O-line with one legit NFL starter doesn’t really allow us to plant our flag on either side of the Daniel Jones dichotomy.<br/>
<br/>
 </td>
                                </tr>
                           </tbody></table><br/>
A) NONE of these are PFF stats. Their data is subjective an relies upon their own contextualization of each play as they assume it was intended to occur; these are from PFR, which is more like a genuine database.<br/>
<br/>
B) I don&#39;t necessarily think that DJ is only a backup or should be discarded, at least not purely on merit. But I do despise the DJ acolytes who want to extend his scholarship at a higher price, into yet another rebuild, simply because they haven&#39;t run out of excuses for him yet.<br/>
<br/>
At a certain point - before his rookie contract expires, he either needs to be really good or be really gone. That&#39;s the only way to get this rebuild done.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: RE: RE: RE: I&#39;m </b><a name="15472725"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Brown_Hornet"> Brown_Hornet </a>  : 2:09 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472725">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472695" target="_blank">15472695</a> Gatorade Dunk said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472257 Brown_Hornet said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472146 Gatorade Dunk said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
 <br/>
                                <br/>
                           <br/>
Now we&#39;re reintroducing other excuses. The premise of this post was that if the last remaining excuse for DJ is the OL, should it be a worthy excuse? <br/>
                                <br/>
                           Dunk, the Rushing issue is a big part of the protection issue. Because the team cannot run there is no reason to bring a S up into the box. Because the team cannot pass block, there is no reason to blitz.<br/>
<br/>
It is possible that DJ has a bit more time to throw than some because of this...it also means that there are more defenders in coverage.<br/>
<br/>
Statistics are good for peer review but they are generally not something on which you might base a theory.<br/>
<br/>
my $0.02 <br/>
                                <br/>
                           <br/>
This is an interesting counter. But it&#39;s worth noting that one of DJ&#39;s purported strengths is his running ability. So if a team fails to respect that by dropping an extra man into coverage rather than keeping a spy or blitzer in on any given play, he should be able to make them pay with his legs, right? And if he&#39;s unable to because he&#39;s facing pressure, that should show up in any of these metrics, right? </td>
                                </tr>
                           </tbody></table>I think that you&#39;re trying way too hard to support your argument. <br/>
The simple answer is, no. Nothing is automatic. <br/>
<br/>
The OP started a good conversation because it posed a question that was never going to have a simple answer, with the exception that the issues on the OL are a myth...clearly they are not.<br/>
<br/>
IMO, DJ has been subpar, the OL has been far worse.<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Gatorade Dunk </b><a name="15472731"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Brown_Hornet"> Brown_Hornet </a>  : 2:11 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472731">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472721" target="_blank">15472721</a> Gatorade Dunk said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472709 M.S. said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
You seem to want to force the Daniel Jones argument into a simple dichotomy: The BBIers who think he is fine vs the BBIers who think he needs to be discarded or is only a back-up talent at best. <br/>
<br/>
You are obvious the latter, otherwise you would not have hauled out all these PFF stats.<br/>
<br/>
But there’s a more nuanced view that goes like this:<br/>
<br/>
The current O-line with one legit NFL starter doesn’t really allow us to plant our flag on either side of the Daniel Jones dichotomy.<br/>
<br/>
 <br/>
                                <br/>
                           <br/>
A) NONE of these are PFF stats. Their data is subjective an relies upon their own contextualization of each play as they assume it was intended to occur; these are from PFR, which is more like a genuine database.<br/>
<br/>
B) I don&#39;t necessarily think that DJ is only a backup or should be discarded, at least not purely on merit. But I do despise the DJ acolytes who want to extend his scholarship at a higher price, into yet another rebuild, simply because they haven&#39;t run out of excuses for him yet.<br/>
<br/>
At a certain point - before his rookie contract expires, he either needs to be really good or be really gone. That&#39;s the only way to get this rebuild done. </td>
                                </tr>
                           </tbody></table>This is the defining post...again, IMO.<br/>
<br/>
All of the statistical information, used to form a nice neat answer, regardless of the sources, is subjective</div></div><div class="thread_post"><div class="thread_post_header"><b>Very difficult to take people seriously when they say &#34;eye test&#34; </b><a name="15472735"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Ten+Ton+Hammer"> Ten Ton Hammer </a>  : 2:13 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472735">link</a>   </div></div><div class="thread_post_body">while also not watching teams other than the Giants. There is no context with a fan eye test. That&#39;s how we get to &#34;The giants OL is the worst in the league, give jones a pass&#34;.<br/>
<br/>
If you&#39;re predisposed to believe what you want to believe, you&#39;re going to skew what you see, either intentionally or subconsciously. <br/>
<br/>
Unconscious Bias is a thing. <br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Very difficult to take people seriously when they say  </b><a name="15472739"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Producer"> Producer </a>  : 2:14 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472739">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472735" target="_blank">15472735</a> Ten Ton Hammer said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> while also not watching teams other than the Giants. There is no context with a fan eye test. That&#39;s how we get to &#34;The giants OL is the worst in the league, give jones a pass&#34;.<br/>
<br/>
If you&#39;re predisposed to believe what you want to believe, you&#39;re going to skew what you see, either intentionally or subconsciously. <br/>
<br/>
Unconscious Bias is a thing. <br/>
 </td>
                                </tr>
                           </tbody></table><br/>
<br/>
truly.. OLs are in crisis around the league. Many here refuse to acknowledge this fact.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: NFL stats are the worst stats in all of sports </b><a name="15472745"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=USAF+NYG+Fan"> USAF NYG Fan </a>  : 2:18 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472745">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472543" target="_blank">15472543</a> Gatorade Dunk said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472476 USAF NYG Fan said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     People pigeon pick to make their point.  Perhaps I am old school but I believe you still win in the trenches and it&#39;s very clear to those who watch the games and have watched for decades that the Giants OL is, and has been, absolute trash.<br/>
<br/>
However, you want stats so how about we simply google OL rankings for 2021?<br/>
<br/>
https://www.pff.com/news/nfl-week-10-offensive-line-rankings-2021<br/>
31st in the league according to PFF after week 10<br/>
<br/>
https://www.pff.com/news/nfl-ranking-all-32-nfl-offensive-line-units-entering-2021-season<br/>
PFF again before the season started, dead last.<br/>
<br/>
https://www.sharpfootballanalysis.com/analysis/2021-nfl-offensive-line-rankings-by-positional-unit/<br/>
Never heard of this site before but Giants rank 2nd to last again.<br/>
<br/>
https://www.sportingnews.com/us/fantasy/news/2021-nfl-offensive-line-rankings-fantasy-football-sleepers-busts/1a383cwxkyin71wj5ggqcs1gdz<br/>
Sporting News<br/>
<br/>
I could easily keep going but the point is that of the people that get paid to report on stuff like this, NOBODY has the Giants&#39; OL as the &#34;middle of the pack&#34;.  NOBODY! <br/>
                                <br/>
                           <br/>
Ah, one of the days that BBI likes PFF.<br/>
<br/>
Try running PFF metrics around these parts when they&#39;re not favorable, see how that goes.<br/>
<br/>
Also, those are not isolated to pass pro. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
First, as I said in my post I simply googled OL rankings. Second, there are 5 links and only 2 of the 5 are from PFF.  Third, feel free to find an &#39;expert&#39; to say the OL is &#34;middle of the pack&#34;.  Lastly, I didn&#39;t pigeon pick stats to support my argument.  I simply googled OL rankings.<br/>
<br/>
But sure, you&#39;re right random guy pushing stats that support your argument.  The people that get paid to report on this stuff (and I) are wrong.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: Gatorade Dunk </b><a name="15472747"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 2:18 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472747">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472731" target="_blank">15472731</a> Brown_Hornet said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472721 Gatorade Dunk said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472709 M.S. said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
You seem to want to force the Daniel Jones argument into a simple dichotomy: The BBIers who think he is fine vs the BBIers who think he needs to be discarded or is only a back-up talent at best. <br/>
<br/>
You are obvious the latter, otherwise you would not have hauled out all these PFF stats.<br/>
<br/>
But there’s a more nuanced view that goes like this:<br/>
<br/>
The current O-line with one legit NFL starter doesn’t really allow us to plant our flag on either side of the Daniel Jones dichotomy.<br/>
<br/>
 <br/>
                                <br/>
                           <br/>
A) NONE of these are PFF stats. Their data is subjective an relies upon their own contextualization of each play as they assume it was intended to occur; these are from PFR, which is more like a genuine database.<br/>
<br/>
B) I don&#39;t necessarily think that DJ is only a backup or should be discarded, at least not purely on merit. But I do despise the DJ acolytes who want to extend his scholarship at a higher price, into yet another rebuild, simply because they haven&#39;t run out of excuses for him yet.<br/>
<br/>
At a certain point - before his rookie contract expires, he either needs to be really good or be really gone. That&#39;s the only way to get this rebuild done. <br/>
                                <br/>
                           This is the defining post...again, IMO.<br/>
<br/>
All of the statistical information, used to form a nice neat answer, regardless of the sources, is subjective </td>
                                </tr>
                           </tbody></table><br/>
How is that subjective?<br/>
<br/>
This is a salary cap league. DJ&#39;s price tag is going to increase dramatically with his option and then his next contract. If our knowledge of his likelihood to win hasn&#39;t also increased at the same rate - EVEN IF IT&#39;S NOT HIS FAULT - then we&#39;re absorbing unnecessary risk. Essentially, we&#39;d be extending the risk of a rookie QB but at a veteran QB price tag. How does that make any sense?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: NFL stats are the worst stats in all of sports </b><a name="15472751"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 2:21 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472751">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472745" target="_blank">15472745</a> USAF NYG Fan said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472543 Gatorade Dunk said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472476 USAF NYG Fan said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     People pigeon pick to make their point.  Perhaps I am old school but I believe you still win in the trenches and it&#39;s very clear to those who watch the games and have watched for decades that the Giants OL is, and has been, absolute trash.<br/>
<br/>
However, you want stats so how about we simply google OL rankings for 2021?<br/>
<br/>
https://www.pff.com/news/nfl-week-10-offensive-line-rankings-2021<br/>
31st in the league according to PFF after week 10<br/>
<br/>
https://www.pff.com/news/nfl-ranking-all-32-nfl-offensive-line-units-entering-2021-season<br/>
PFF again before the season started, dead last.<br/>
<br/>
https://www.sharpfootballanalysis.com/analysis/2021-nfl-offensive-line-rankings-by-positional-unit/<br/>
Never heard of this site before but Giants rank 2nd to last again.<br/>
<br/>
https://www.sportingnews.com/us/fantasy/news/2021-nfl-offensive-line-rankings-fantasy-football-sleepers-busts/1a383cwxkyin71wj5ggqcs1gdz<br/>
Sporting News<br/>
<br/>
I could easily keep going but the point is that of the people that get paid to report on stuff like this, NOBODY has the Giants&#39; OL as the &#34;middle of the pack&#34;.  NOBODY! <br/>
                                <br/>
                           <br/>
Ah, one of the days that BBI likes PFF.<br/>
<br/>
Try running PFF metrics around these parts when they&#39;re not favorable, see how that goes.<br/>
<br/>
Also, those are not isolated to pass pro. <br/>
                                <br/>
                           <br/>
<br/>
First, as I said in my post I simply googled OL rankings. Second, there are 5 links and only 2 of the 5 are from PFF.  Third, feel free to find an &#39;expert&#39; to say the OL is &#34;middle of the pack&#34;.  Lastly, I didn&#39;t pigeon pick stats to support my argument.  I simply googled OL rankings.<br/>
<br/>
But sure, you&#39;re right random guy pushing stats that support your argument.  The people that get paid to report on this stuff (and I) are wrong. </td>
                                </tr>
                           </tbody></table><br/>
I mean, there&#39;s only four links in your post, but I guess that&#39;s close enough.<br/>
<br/>
And we don&#39;t need an expert. That&#39;s the point of what I collected. If the Giants&#39; OL is at the bottom of the league in pass protection, it would show up in literally ANY of the metrics I provided; it doesn&#39;t.<br/>
<br/>
But since you can&#39;t even count to five, that might have flown above your head.</div></div><div class="thread_post"><div class="thread_post_header"><b>… </b><a name="15472756"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=christian"> christian </a>  : 2:23 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472756">link</a>   </div></div><div class="thread_post_body">Questions I’d ask myself about Jones, knowing “fix the line” will be a huge task.<br/>
<br/>
1) Has Jones improved his ability to sense the pass rush, use his feet to buy time, and make his own life easier?<br/>
2) Do the coaches trust him to change the plays at the line and use his brain to put his line in better matchups?<br/>
3) Does he use his eyes and arm to punish defenses when they over pursue<br/>
4) Does he take advantage of the times he does receive good protection at a high clip<br/>
<br/>
If the answer isn’t yes to all the above, I’d upgrade QB.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: Gatorade Dunk </b><a name="15472794"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Brown_Hornet"> Brown_Hornet </a>  : 2:38 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472794">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472747" target="_blank">15472747</a> Gatorade Dunk said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"><br/>
                           <br/>
How is that subjective?<br/>
<br/>
 </td>
                                </tr>
                           </tbody></table>Not sure where you went with that one. I&#39;m referring to using several sets of statistical information and coming to a conclusion knowing that there are a multitude of factors not accounted for in the games. <br/>
The statistics used by everyone, when used as a group to determine &#34;how good&#34; the OL may be, is subjective.<br/>
<br/>
I don&#39;t have a problem keeping DJ for yr 4, I can also get behind making a decision to move on.<br/>
When I watch the games, I generally focus on the OL/DL. This team is not middle of any pack...if the argument is that the  entire bottom 50% of the pack is poor...ok?<br/>
That has no relevance to the notion that the OL needs to be greatly improved.<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: NFL stats are the worst stats in all of sports </b><a name="15472795"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=USAF+NYG+Fan"> USAF NYG Fan </a>  : 2:38 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472795">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472751" target="_blank">15472751</a> Gatorade Dunk said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472745 USAF NYG Fan said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472543 Gatorade Dunk said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472476 USAF NYG Fan said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     People pigeon pick to make their point.  Perhaps I am old school but I believe you still win in the trenches and it&#39;s very clear to those who watch the games and have watched for decades that the Giants OL is, and has been, absolute trash.<br/>
<br/>
However, you want stats so how about we simply google OL rankings for 2021?<br/>
<br/>
https://www.pff.com/news/nfl-week-10-offensive-line-rankings-2021<br/>
31st in the league according to PFF after week 10<br/>
<br/>
https://www.pff.com/news/nfl-ranking-all-32-nfl-offensive-line-units-entering-2021-season<br/>
PFF again before the season started, dead last.<br/>
<br/>
https://www.sharpfootballanalysis.com/analysis/2021-nfl-offensive-line-rankings-by-positional-unit/<br/>
Never heard of this site before but Giants rank 2nd to last again.<br/>
<br/>
https://www.sportingnews.com/us/fantasy/news/2021-nfl-offensive-line-rankings-fantasy-football-sleepers-busts/1a383cwxkyin71wj5ggqcs1gdz<br/>
Sporting News<br/>
<br/>
I could easily keep going but the point is that of the people that get paid to report on stuff like this, NOBODY has the Giants&#39; OL as the &#34;middle of the pack&#34;.  NOBODY! <br/>
                                <br/>
                           <br/>
Ah, one of the days that BBI likes PFF.<br/>
<br/>
Try running PFF metrics around these parts when they&#39;re not favorable, see how that goes.<br/>
<br/>
Also, those are not isolated to pass pro. <br/>
                                <br/>
                           <br/>
<br/>
First, as I said in my post I simply googled OL rankings. Second, there are 5 links and only 2 of the 5 are from PFF.  Third, feel free to find an &#39;expert&#39; to say the OL is &#34;middle of the pack&#34;.  Lastly, I didn&#39;t pigeon pick stats to support my argument.  I simply googled OL rankings.<br/>
<br/>
But sure, you&#39;re right random guy pushing stats that support your argument.  The people that get paid to report on this stuff (and I) are wrong. <br/>
                                <br/>
                           <br/>
I mean, there&#39;s only four links in your post, but I guess that&#39;s close enough.<br/>
<br/>
And we don&#39;t need an expert. That&#39;s the point of what I collected. If the Giants&#39; OL is at the bottom of the league in pass protection, it would show up in literally ANY of the metrics I provided; it doesn&#39;t.<br/>
<br/>
But since you can&#39;t even count to five, that might have flown above your head. </td>
                                </tr>
                           </tbody></table><br/>
My mistake, I thought I decided to only post the first 5 links that came up but I guess I forgot the 5th.  I was reading through around the 8th link when I decided to only do 5.  All saying the same thing by the way.  Giants&#39; OL is trash.<br/>
<br/>
Again, feel free to find an &#34;expert&#34; that agrees with you.  Perhaps a Mathematician would agree with you instead?  I&#39;ll stick with people that actually know football.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: NFL stats are the worst stats in all of sports </b><a name="15472804"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 2:41 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472804">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472795" target="_blank">15472795</a> USAF NYG Fan said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472751 Gatorade Dunk said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472745 USAF NYG Fan said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472543 Gatorade Dunk said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472476 USAF NYG Fan said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     People pigeon pick to make their point.  Perhaps I am old school but I believe you still win in the trenches and it&#39;s very clear to those who watch the games and have watched for decades that the Giants OL is, and has been, absolute trash.<br/>
<br/>
However, you want stats so how about we simply google OL rankings for 2021?<br/>
<br/>
https://www.pff.com/news/nfl-week-10-offensive-line-rankings-2021<br/>
31st in the league according to PFF after week 10<br/>
<br/>
https://www.pff.com/news/nfl-ranking-all-32-nfl-offensive-line-units-entering-2021-season<br/>
PFF again before the season started, dead last.<br/>
<br/>
https://www.sharpfootballanalysis.com/analysis/2021-nfl-offensive-line-rankings-by-positional-unit/<br/>
Never heard of this site before but Giants rank 2nd to last again.<br/>
<br/>
https://www.sportingnews.com/us/fantasy/news/2021-nfl-offensive-line-rankings-fantasy-football-sleepers-busts/1a383cwxkyin71wj5ggqcs1gdz<br/>
Sporting News<br/>
<br/>
I could easily keep going but the point is that of the people that get paid to report on stuff like this, NOBODY has the Giants&#39; OL as the &#34;middle of the pack&#34;.  NOBODY! <br/>
                                <br/>
                           <br/>
Ah, one of the days that BBI likes PFF.<br/>
<br/>
Try running PFF metrics around these parts when they&#39;re not favorable, see how that goes.<br/>
<br/>
Also, those are not isolated to pass pro. <br/>
                                <br/>
                           <br/>
<br/>
First, as I said in my post I simply googled OL rankings. Second, there are 5 links and only 2 of the 5 are from PFF.  Third, feel free to find an &#39;expert&#39; to say the OL is &#34;middle of the pack&#34;.  Lastly, I didn&#39;t pigeon pick stats to support my argument.  I simply googled OL rankings.<br/>
<br/>
But sure, you&#39;re right random guy pushing stats that support your argument.  The people that get paid to report on this stuff (and I) are wrong. <br/>
                                <br/>
                           <br/>
I mean, there&#39;s only four links in your post, but I guess that&#39;s close enough.<br/>
<br/>
And we don&#39;t need an expert. That&#39;s the point of what I collected. If the Giants&#39; OL is at the bottom of the league in pass protection, it would show up in literally ANY of the metrics I provided; it doesn&#39;t.<br/>
<br/>
But since you can&#39;t even count to five, that might have flown above your head. <br/>
                                <br/>
                           <br/>
My mistake, I thought I decided to only post the first 5 links that came up but I guess I forgot the 5th.  I was reading through around the 8th link when I decided to only do 5.  All saying the same thing by the way.  Giants&#39; OL is trash.<br/>
<br/>
Again, feel free to find an &#34;expert&#34; that agrees with you.  Perhaps a Mathematician would agree with you instead?  I&#39;ll stick with people that actually know football. </td>
                                </tr>
                           </tbody></table><br/>
The stats know football.<br/>
<br/>
If DJ was behind the worst line in the NFL, he&#39;d be sacked the most, or be hurried the most, or be pressured the most, or be hit the most, or have the least time to throw.<br/>
<br/>
Literally none of those things are what is actually happening.<br/>
<br/>
You don&#39;t need an expert to decipher that.</div></div><div class="thread_post"><div class="thread_post_header"><b>I&#39;d  </b><a name="15472837"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Toth029"> Toth029 </a>  : 2:56 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472837">link</a>   </div></div><div class="thread_post_body">Love to see who&#39;s actually worse than Solder as a starting OT.</div></div><div class="thread_post"><div class="thread_post_header"><b>Their run blocking </b><a name="15472848"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=jeff57"> jeff57 </a>  : 3:00 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472848">link</a>   </div></div><div class="thread_post_body">Is even worse than their pass blocking.  And that adversely affects the passing game as well.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I&#39;d  </b><a name="15472850"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 3:04 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472850">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472837" target="_blank">15472837</a> Toth029 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Love to see who&#39;s actually worse than Solder as a starting OT. </td>
                                </tr>
                           </tbody></table><br/>
So Solder&#39;s poor play is his own, but DJ&#39;s poor play is a reflection of others&#39; poor play?<br/>
<br/>
This is a fun game.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I&#39;d  </b><a name="15472855"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Toth029"> Toth029 </a>  : 3:06 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472855">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472850" target="_blank">15472850</a> Gatorade Dunk said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472837 Toth029 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Love to see who&#39;s actually worse than Solder as a starting OT. <br/>
                                <br/>
                           <br/>
So Solder&#39;s poor play is his own, but DJ&#39;s poor play is a reflection of others&#39; poor play?<br/>
<br/>
This is a fun game. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Let&#39;s try to stop putting words in others mouth and use some facts first. Is Solder absolutely terrible? There&#39;s a drastic cause and effect in a lineman constantly getting disrupted on the snap or beaten by a bull rush. And this is via pass pro and run blocking. He&#39;s straight up the worst starter on the team by far. Shelton is really bad too, but he&#39;s at least part time.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: I&#39;d  </b><a name="15472867"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 3:12 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472867">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472855" target="_blank">15472855</a> Toth029 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472850 Gatorade Dunk said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15472837 Toth029 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Love to see who&#39;s actually worse than Solder as a starting OT. <br/>
                                <br/>
                           <br/>
So Solder&#39;s poor play is his own, but DJ&#39;s poor play is a reflection of others&#39; poor play?<br/>
<br/>
This is a fun game. <br/>
                                <br/>
                           <br/>
<br/>
Let&#39;s try to stop putting words in others mouth and use some facts first. Is Solder absolutely terrible? There&#39;s a drastic cause and effect in a lineman constantly getting disrupted on the snap or beaten by a bull rush. And this is via pass pro and run blocking. He&#39;s straight up the worst starter on the team by far. Shelton is really bad too, but he&#39;s at least part time. </td>
                                </tr>
                           </tbody></table><br/>
I agree that Solder is terrible. And I can freely acknowledge that, even if he has an awful guard next to him who probably makes him look even worse than he is. And no one tries to make excuses for him, he&#39;s universally accepted as a liability on this roster.<br/>
<br/>
Meanwhile, DJ can also be shown to be a liability, but blind optimism creates this need to provide a laundry list of excuses for his mediocrity.</div></div><div class="thread_post"><div class="thread_post_header"><b>The answer to the question in the OP is </b><a name="15472869"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=eclipz928"> eclipz928 </a>  : 3:13 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472869">link</a>   </div></div><div class="thread_post_body">kinda yes. <br/>
<br/>
The stats that were posted reveal what I&#39;ve always thought to be true - which is that the Giants do have a poor Oline, but other teams do as well and are still able to navigate their offense to some level of success.<br/>
<br/>
The Giants have a bad OLine AND don&#39;t know how to, or aren&#39;t able to, compensate for it.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Their run blocking </b><a name="15472871"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Lines+of+Scrimmage"> Lines of Scrimmage </a>  : 3:14 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472871">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472848" target="_blank">15472848</a> jeff57 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Is even worse than their pass blocking.  And that adversely affects the passing game as well. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Lot of people have a hard time understanding this.  Even our so called &#34;QB experts&#34; on BBI.  Be in 2nd and 5/6 yards and like magic the pass blocking improves.</div></div><div class="thread_post"><div class="thread_post_header"><b>It&#39;s a bad OL </b><a name="15472986"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Greg+from+LI"> Greg from LI </a>  : 4:08 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472986">link</a>   </div></div><div class="thread_post_body">But there are a lot of bad OLs in the NFL today.  It&#39;s not so singularly awful to support the notion that Jones fans like to voice, that you can&#39;t expect any more from him because the blocking is so atrocious.</div></div><div class="thread_post"><div class="thread_post_header"><b>I have not read the whole thread </b><a name="15473010"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=crick+n+NC"> crick n NC </a>  : 4:21 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15473010">link</a>   </div></div><div class="thread_post_body">Is it possible that Jones even with a good OL wouldn&#39;t be a quarterback worth building around? Certainly. I would say it is looking more and more likely that he is not what the team is looking for even with the right pieces in place.<br/>
<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>So, who on this thread IS NOT cutting Daniel Jones very much slack </b><a name="15473024"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=M.S."> M.S. </a>  : 4:30 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15473024">link</a>   </div></div><div class="thread_post_body"><br/>
because of his atrocious O-Line, but in the past has gone on record saying that Dak Prescot has benefitted quite a lot from an excellent offensive line?<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: Gatorade Dunk </b><a name="15473029"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=The+Jake"> The Jake </a>  : 4:33 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15473029">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15472794" target="_blank">15472794</a> Brown_Hornet said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">When I watch the games, I generally focus on the OL/DL. This team is not middle of any pack...if the argument is that the  entire bottom 50% of the pack is poor...ok?<br/>
That has no relevance to the notion that the OL needs to be greatly improved. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
So you acknowledge that it could be as much as half the league has an OL that is as bad or worse than the Giants, but you aren’t at all curious as to why those teams are able to score more points than us?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: So, who on this thread IS NOT cutting Daniel Jones very much slack </b><a name="15473036"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Producer"> Producer </a>  : 4:37 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15473036">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15473024" target="_blank">15473024</a> M.S. said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
because of his atrocious O-Line, but in the past has gone on record saying that Dak Prescot has benefitted quite a lot from an excellent offensive line?<br/>
 </td>
                                </tr>
                           </tbody></table><br/>
<br/>
This is a logical fallacy. You can do better.</div></div><div class="thread_post"><div class="thread_post_header"><b>Also </b><a name="15473050"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=crick+n+NC"> crick n NC </a>  : 4:42 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15473050">link</a>   </div></div><div class="thread_post_body">Even with the poor situation Jones has been put in, I feel he would have shown more by now if he was a qb that significantly elevates those around him. I can&#39;t imagine the Giants are trying to hold out for the next Brady, Rodgers, Mahomes because they are extremely rare, so finding that quarterback who is good enough to invest in while not putting the team in a bind financially is likely the goal. The problem is when you insert a new quarterback into a poor situation it can slow down evaluation time in my view.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: RE: Gatorade Dunk </b><a name="15473053"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Brown_Hornet"> Brown_Hornet </a>  : 4:43 pm   : <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15473053">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=615448&amp;show_all=1#15473029" target="_blank">15473029</a> The Jake said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15472794 Brown_Hornet said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                    When I watch the games, I generally focus on the OL/DL. This team is not middle of any pack...if the argument is that the  entire bottom 50% of the pack is poor...ok?<br/>
That has no relevance to the notion that the OL needs to be greatly improved. <br/>
                                <br/>
                           <br/>
<br/>
So you acknowledge that it could be as much as half the league has an OL that is as bad or worse than the Giants, but you aren’t at all curious as to why those teams are able to score more points than us? </td>
                                </tr>
                           </tbody></table>No, I didn&#39;t acknowledge that.<br/>
I said that if it were true, it doesn&#39;t change the fact that the Giants OL stinks.<br/></div></div><a name="END"></a><a href="index.php"></a><div style="padding-top:25px; padding-bottom:20px;"><a href="index.php"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"/></a></div></div>
<div class="thread_sidebar_2">

<!-- Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-102">
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Corner Forum - Lower 300x250 -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1566320450447229" data-ad-slot="4189314539" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->

</div>

</div>




<div class="footer">


<p style="width:450px;float:left;padding:10px;"><b>Part of the USA Today Sports Media Group</b><br/>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</p>
<p style="width:400px;float:right; text-align:right;padding:10px;">
All contents (unless otherwise specified) copyright ©  1995 - 2021<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br/> <br/><strong>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Solutions</a></strong>
</p>
<br clear="all"/>
 
</div>




<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->



<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=0&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script></body></html>