<!DOCTYPE html><html lang="en"><head><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-0&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-0&cb=4', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-0&cb=5', false, [], true, false, true, false);</script>
<title>NYG to pick 5 and 7 | Big Blue Interactive </title>

<meta http-equiv="Pragma" content="no-cache"/>
<meta http-equiv="Expires" content="-1"/>

<meta name="keywords" content="ndglbqfkxx"/>

<meta name="description" content="1. JAC
2. DET
3. HOU
4. NYJ
5. NYG
6. CAR
7. NYG

Thanks everybody!"/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="website"/>
<meta property="og:description" content="1. JAC
2. DET
3. HOU
4. NYJ
5. NYG
6. CAR
7. NYG

Thanks everybody!"/> 
<meta property="og:title" content="NYG to pick 5 and 7"/> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif"/> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css?v=20200217"/>

<link rel="stylesheet" type="text/css" href="anylink.css"/>


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}


div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" alt="for display only">

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type="text/javascript">
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type="text/javascript" src="https://img.bnqt.com/lib/js/sdpdfphelper.js"></script>
<script type="text/javascript">
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>


<!-- End DFP SETUP -->  

<!-- End USA Today Code -->




<script type="text/javascript">var ezouid = "1";</script><base href="https://corner.bigblueinteractive.com/index.php?mode=2&thread=617498"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"domain_test_group":20210306,"engaged_time_visit":0,"ezcache_level":0,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"4936440e-9498-444a-5ecb-2771c7697132","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":68179,"response_time_orig":101,"serverid":"50.19.132.158:25055","state":"VA","t_epoch":1641839116,"template_id":126,"time_on_site_visit":0,"url":"https://corner.bigblueinteractive.com/index.php?mode=2\u0026thread=617498","user_id":0,"word_count":4335,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["4936440e-9498-444a-5ecb-2771c7697132", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>


<body>




<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tbody><tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"/></a> <img src="images/xpete.gif" alt="The Corner Forum"/>

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic --> 


<!-- Nov 2019 Leaderboard -->

<!-- Ezoic - Forum Leaderboard (USAT) - top_of_page -->
<div id="ezoic-pub-ad-placeholder-118">
<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->
<div id="usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general');
         });
     </script>
</div>
</div>
<!-- End Ezoic - Forum Leaderboard (USAT) - top_of_page -->



</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://www.amazon.com/?_encoding=UTF8&amp;camp=1789&amp;creative=9325&amp;linkCode=ur2&amp;tag=bigblueintera-20">Amazon.com</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW">Standings (NFL.com)</a>
<a href="https://www.giants.com/team/stats/" target="_NEW">Statistics (Giants.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/">Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</tbody></table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;home_view_menu&#39;)">Home</a>  
</li><li><a href="http://corner.bigblueinteractive.com/index.php" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;forum_view_menu&#39;)">Corner Forum</a>
</li><li><a href="http://corner.bigblueinteractive.com/index.php" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;gameday_view_menu&#39;)">Gameday</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_view_menu&#39;)">Team</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_building_view_menu&#39;)">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info & History</a> -->
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_info_view_menu&#39;)">Giants Info &amp; History</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;infolinks_view_menu&#39;)">Info/Links</a>
</li><li><a href="/index.php?mode=10" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;login_menu&#39;)">Log In</a>
</li></ul>

</div><div id="infoline"> </div>

<a name="END"></a><a href="index.php"></a><div style="padding-top:20px; padding-bottom:25px;"><a href="index.php"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"/></a></div><div class="thread_container"><div class="thread_left"><div class="thread_body"><div class="thread_main"><div class="thread_post_header">  <h1 style="font-size:18px;">NYG to pick 5 and 7 </h1><div class="thread_info"><a href="index.php?mode=5&amp;handle=ray in arlington"> ray in arlington </a>  :  1/9/2022  7:35 pm</div></div><div class="thread_post_body"> 1. JAC<br/>
2. DET<br/>
3. HOU<br/>
4. NYJ<br/>
5. NYG<br/>
6. CAR<br/>
7. NYG<br/>
<br/>
Thanks everybody! </div></div></div><div style="margin: 10 10 20 50"><span class="top_pages">Pages:  <a href="index.php?mode=2&amp;thread=617498&amp;thread_page=1">1</a>  <b style="background: darkred;padding: 2px 5px 2px 5px;">2</b>  <a href="index.php?mode=2&amp;thread=617498&amp;thread_page=1">&lt;&lt;Prev </a>| <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1" title="">Show All</a> | </span></div>
</div><div class="thread_right"><div id="ad_side_box">


<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id="usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103,22280986322/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general');
         });
     </script>
</div>


</div></div><div class="thread_comment_container"><div class="thread_post"><div class="thread_post_header"><b>Ooops. </b><a name="15539766"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Pepe+LePugh"> Pepe LePugh </a>  :  1/9/2022  8:06 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539766">link</a>   </div></div><div class="thread_post_body">Sorry for duplicate post.</div></div><div class="thread_post"><div class="thread_post_header"><b>Stupid Ben Bredeson trade </b><a name="15539768"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  1/9/2022  8:07 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539768">link</a>   </div></div><div class="thread_post_body">cost us a #4.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Hopefully No Hamilton or Stingley or Williams  </b><a name="15539770"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=DonnieD89"> DonnieD89 </a>  :  1/9/2022  8:08 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539770">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539762" target="_blank">15539762</a> giantstock said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Hopefully Giants go with 1sttwo picks of combo of OL and Edge.<br/>
<br/>
Trade down if need be. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Agree</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: If the Giants hadn&#39;t lost two games by FGs in the final seconds </b><a name="15539877"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=k2tampa"> k2tampa </a>  :  1/9/2022  8:25 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539877">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539753" target="_blank">15539753</a> GeofromNJ said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> they would be picking a whole lot lower despite the abysmal condition of this team. Let&#39;s hope the next GM knows how to recognize talent. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
And if the Bears had not won two of their last six on last play field goals the Giants would be picking 4 and 5.</div></div><div class="thread_post"><div class="thread_post_header"><b>Will be interesting to see what the new GM decides </b><a name="15539886"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=beatrixkiddo"> beatrixkiddo </a>  :  1/9/2022  8:27 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539886">link</a>   </div></div><div class="thread_post_body">But you have to figure they move down with one of those picks, question is which one will return greater value. Can make an argument that any t am in front of us would be looking to sell, of course this cost will be greater so maybe the 5 slot is the perfect place for a team that likes a QB to jump ahead of Carolina to get one. WhT could we reasonably return? A 1st this year and next and a day 2 pick this year? If so I would 100% do that. Especially if we are going to miss out on the blue chip Edge players. Gives us more ammo to grab quality depth for the OL later on. Just have to hope they have the right guy in here and get the FO cleaned up, if not trade both picks back for the future when you have a better plan in place. Right now, the Giants are a hot mess and no draft pick unless LT is cloned and enters is changing the outcome for this team.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Stupid Ben Bredeson trade </b><a name="15539902"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Beer+Man"> Beer Man </a>  :  1/9/2022  8:30 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539902">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539768" target="_blank">15539768</a> Eric from BBI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> cost us a #4. </td>
                                </tr>
                           </tbody></table>Given that 4 of the OL positions are unsettle for next season, the Giants may have to start Bredeson at one of the OGs</div></div><div class="thread_post"><div class="thread_post_header"><b>Our 36 and 67 would land us in the 21 area </b><a name="15539904"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=stoneman"> stoneman </a>  :  1/9/2022  8:30 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539904">link</a>   </div></div><div class="thread_post_body">you could do alot of damage with 5, 7, and 21 (along with 80).</div></div><div class="thread_post"><div class="thread_post_header"><b>This is better than where I thought it would be... </b><a name="15539944"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=EricJ"> EricJ </a>  :  1/9/2022  8:37 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539944">link</a>   </div></div><div class="thread_post_body">that said... the decisions that are made prior to the draft will have the greatest impact on the future of this team.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: It&#39;s very possible that the Football Giants will get the third best OT </b><a name="15539958"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=M.S."> M.S. </a>  :  1/9/2022  8:39 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539958">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539643" target="_blank">15539643</a> Anakim said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> in the Draft at Pick #5. The Jaguars could pick Evan Neal first overall (they need OL help and they need to protect their franchise QB) and the Jets&#39; O-Line is as bad as ours (and they need to protect their franchise QB). They could opt for either Ickey or Charles Cross at fourth overall, leaving the remainder of those two for the Football Giants at 5.<br/>
<br/>
<br/>
Just spitballing&#39; (assuming no trades:)<br/>
<br/>
Jaguars - Evan Neal<br/>
Lions - Hutchinson<br/>
Texans - Thibodeaux<br/>
Jets - Ickey or Cross<br/>
Giants - Ickey or Cross<br/>
Panthers - maybe a QB? Kenny Pickett?<br/>
Giants - here I would take either Derek Stingley Jr. or Kyle Hamilton, depending on their health </td>
                                </tr>
                           </tbody></table><br/>
Who is Ickey?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Will be interesting to see what the new GM decides </b><a name="15539968"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=k2tampa"> k2tampa </a>  :  1/9/2022  8:42 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539968">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539886" target="_blank">15539886</a> beatrixkiddo said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> But you have to figure they move down with one of those picks, question is which one will return greater value. Can make an argument that any t am in front of us would be looking to sell, of course this cost will be greater so maybe the 5 slot is the perfect place for a team that likes a QB to jump ahead of Carolina to get one. WhT could we reasonably return? A 1st this year and next and a day 2 pick this year? If so I would 100% do that. Especially if we are going to miss out on the blue chip Edge players. Gives us more ammo to grab quality depth for the OL later on. Just have to hope they have the right guy in here and get the FO cleaned up, if not trade both picks back for the future when you have a better plan in place. Right now, the Giants are a hot mess and no draft pick unless LT is cloned and enters is changing the outcome for this team. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Carolina didn&#39;t trade a 2, 4 in this draft and 6 last year for Darnold to give up on him this fast. Offensive line is the glaring need in Carolina. Trade down from 7 if you are going to trade down.</div></div><div class="thread_post"><div class="thread_post_header"><b>The fuck-ups  drafting </b><a name="15539969"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=SomeFan"> SomeFan </a>  :  1/9/2022  8:42 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539969">link</a>   </div></div><div class="thread_post_body">better not mess this draft or we are in for long term hurt. I don’t want to hear any excuses either.  At 5 and 7, they better choose long-term impact players.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Stupid Ben Bredeson trade </b><a name="15539977"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=M.S."> M.S. </a>  :  1/9/2022  8:44 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539977">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539768" target="_blank">15539768</a> Eric from BBI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> cost us a #4. </td>
                                </tr>
                           </tbody></table><br/>
You had to remind us!</div></div><div class="thread_post"><div class="thread_post_header"><b>Isn&#39;t the CURRENT scouting staff data </b><a name="15539982"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=M.S."> M.S. </a>  :  1/9/2022  8:45 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539982">link</a>   </div></div><div class="thread_post_body"><br/>
the foundation for the 2022 Draft Board?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: It&#39;s very possible that the Football Giants will get the third best OT </b><a name="15540000"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=GFAN52"> GFAN52 </a>  :  1/9/2022  8:49 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540000">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539958" target="_blank">15539958</a> M.S. said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15539643 Anakim said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     in the Draft at Pick #5. The Jaguars could pick Evan Neal first overall (they need OL help and they need to protect their franchise QB) and the Jets&#39; O-Line is as bad as ours (and they need to protect their franchise QB). They could opt for either Ickey or Charles Cross at fourth overall, leaving the remainder of those two for the Football Giants at 5.<br/>
<br/>
<br/>
Just spitballing&#39; (assuming no trades:)<br/>
<br/>
Jaguars - Evan Neal<br/>
Lions - Hutchinson<br/>
Texans - Thibodeaux<br/>
Jets - Ickey or Cross<br/>
Giants - Ickey or Cross<br/>
Panthers - maybe a QB? Kenny Pickett?<br/>
Giants - here I would take either Derek Stingley Jr. or Kyle Hamilton, depending on their health <br/>
                                <br/>
                           <br/>
Who is Ickey? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Ikem Ekwonu, G, NC State 6&#39;4&#34; 320</div></div><div class="thread_post"><div class="thread_post_header"><b>GFAN52 </b><a name="15540023"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=M.S."> M.S. </a>  :  1/9/2022  8:55 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540023">link</a>   </div></div><div class="thread_post_body"><br/>
Much thanks!</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: We should trade </b><a name="15540042"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=LakeGeorgeGiant"> LakeGeorgeGiant </a>  :  1/9/2022  8:59 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540042">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539699" target="_blank">15539699</a> BigBlueJ said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> on of those picks and really clean up and get something for next year as well. That is how you start building. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
You start building by picking good players.<br/>
<br/>
They have plenty of picks they do t need to trade premium picks for crap.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: It&#39;s annoying that arguably the worst Giants team in 40 yrs </b><a name="15540057"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=dpinzow"> dpinzow </a>  :  1/9/2022  9:03 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540057">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539707" target="_blank">15539707</a> BH28 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Is picking 5th. I find it hard to believe that there are 4 worse teams than the Giants right now. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
And there&#39;s no QB worth either pick</div></div><div class="thread_post"><div class="thread_post_header"><b>Definitely no QB&#39;s.  Take the best lineman, OL or DL with the 5th pick </b><a name="15540074"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Jim+in+Hoboken"> Jim in Hoboken </a>  :  1/9/2022  9:07 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540074">link</a>   </div></div><div class="thread_post_body">and then trade down with the 7th, to grab another lineman.  <br/>
<br/>
Hamilton and Stingley are luxuries we cannot afford.  All the secondary talent in the world won&#39;t matter if we can&#39;t get to the QB.  Coming into the season, the secondary was lauded as the most talented in a long while, well, they struggled except for maybe Xavier McKinley because the front seven were so poor.  <br/>
<br/>
All the talent we had on offense produced zilch because we couldn&#39;t block.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Stupid Ben Bredeson trade </b><a name="15540100"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Jimmy+Googs"> Jimmy Googs </a>  :  1/9/2022  9:15 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540100">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539977" target="_blank">15539977</a> M.S. said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15539768 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     cost us a #4. <br/>
                                <br/>
                           <br/>
You had to remind us! </td>
                                </tr>
                           </tbody></table><br/>
<br/>
More of a whatever.  Bredeson isn’t all that worse than any of our other Guards.  <br/>
<br/>
Giants should go sign a middle priced free agent Guard and then have him compete with Bredeson and Lemieux next season for the starting jobs and relegate the other to be the swing Guard.<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Definitely no QB&#39;s.  Take the best lineman, OL or DL with the 5th pick </b><a name="15540109"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=dpinzow"> dpinzow </a>  :  1/9/2022  9:19 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540109">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540074" target="_blank">15540074</a> Jim in Hoboken said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> and then trade down with the 7th, to grab another lineman.  <br/>
<br/>
Hamilton and Stingley are luxuries we cannot afford.  All the secondary talent in the world won&#39;t matter if we can&#39;t get to the QB.  Coming into the season, the secondary was lauded as the most talented in a long while, well, they struggled except for maybe Xavier McKinley because the front seven were so poor.  <br/>
<br/>
All the talent we had on offense produced zilch because we couldn&#39;t block. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Cross or Ekwonu at 5 (Neal is probably unavailable) and Linderbaum with the Bears pick, or trade the Bears pick down and see if you can get an OL and pass rusher with two more premium picks</div></div><div class="thread_post"><div class="thread_post_header"><b>trading back into the 1st with 67 and 80 </b><a name="15540116"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=stoneman"> stoneman </a>  :  1/9/2022  9:22 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540116">link</a>   </div></div><div class="thread_post_body">would net something like Karlaftis/Ekwana and one of Green/Linderbaum. If they don&#39;t make a quality move via FA, I would forfeit the 2 3s for the OLine quality at 16-20.  Will see how the OLine targets in the 3rd round shakes out leading up to the draft.  Gotta get 2 quality OLine in the off season (minimum).</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: trading back into the 1st with 67 and 80 </b><a name="15540135"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=dpinzow"> dpinzow </a>  :  1/9/2022  9:26 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540135">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540116" target="_blank">15540116</a> stoneman said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> would net something like Karlaftis/Ekwana and one of Green/Linderbaum. If they don&#39;t make a quality move via FA, I would forfeit the 2 3s for the OLine quality at 16-20.  Will see how the OLine targets in the 3rd round shakes out leading up to the draft.  Gotta get 2 quality OLine in the off season (minimum). </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I don&#39;t think you can trade two 3rd round picks (67 and 80) to get back in the first round. The draft values on those two picks equal a mid-2nd round pick. We&#39;d have to trade the 2nd round pick (37) and 80 to get a third 1st round pick</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: trading back into the 1st with 67 and 80 </b><a name="15540154"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=stoneman"> stoneman </a>  :  1/9/2022  9:31 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540154">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540135" target="_blank">15540135</a> dpinzow said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15540116 stoneman said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     would net something like Karlaftis/Ekwana and one of Green/Linderbaum. If they don&#39;t make a quality move via FA, I would forfeit the 2 3s for the OLine quality at 16-20.  Will see how the OLine targets in the 3rd round shakes out leading up to the draft.  Gotta get 2 quality OLine in the off season (minimum). <br/>
                                <br/>
                           <br/>
<br/>
I don&#39;t think you can trade two 3rd round picks (67 and 80) to get back in the first round. The draft values on those two picks equal a mid-2nd round pick. We&#39;d have to trade the 2nd round pick (37) and 80 to get a third 1st round pick </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I was inferring that you have to forfeit 67 and 80 to move the 36 pick up to the 16-20 range.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I say we trade both our picks </b><a name="15540156"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Festina+Lente"> Festina Lente </a>  :  1/9/2022  9:31 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540156">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539732" target="_blank">15539732</a> Jersey Heel said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> For future number 1’s. We should keep doing that until 2030, when we’ll have the entire first round all to ourselves. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Hahaha</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: It&#39;s very possible that the Football Giants will get the third best OT </b><a name="15540202"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Anakim"> Anakim </a>  :  1/9/2022  9:51 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540202">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539694" target="_blank">15539694</a> Milton said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15539643 Anakim said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     in the Draft at Pick #5. The Jaguars could pick Evan Neal first overall (they need OL help and they need to protect their franchise QB) and the Jets&#39; O-Line is as bad as ours (and they need to protect their franchise QB). They could opt for either Ickey or Charles Cross at fourth overall, leaving the remainder of those two for the Football Giants at 5.<br/>
                                <br/>
                           It&#39;s also possible that the three top OL are so evenly graded that getting the third one off the board is no worse than getting the first one.  </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Could be, sure. But any GM would like his pick of the litter.</div></div><div class="thread_post"><div class="thread_post_header"><b>In 5 years of drafts  </b><a name="15540218"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Scooter185"> Scooter185 </a>  :  1/9/2022  9:57 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540218">link</a>   </div></div><div class="thread_post_body">The Giants will have picked at almost every spot in the top 7, just missing #1 and 3</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Isn&#39;t the CURRENT scouting staff data </b><a name="15540224"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BillKo"> BillKo </a>  :  1/9/2022  9:58 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540224">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539982" target="_blank">15539982</a> M.S. said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
the foundation for the 2022 Draft Board? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Yes it is. <br/>
<br/>
But I&#39;d have to think you can still run a draft with a new FO and also use other sources for evaluating players. <br/>
<br/>
Hell, just call Sy!</div></div><div class="thread_post"><div class="thread_post_header"><b>Brederson </b><a name="15540227"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=stretch234"> stretch234 </a>  :  1/9/2022  9:59 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540227">link</a>   </div></div><div class="thread_post_body">I think you give him a shot next year at either guard spot.  Baltimore is usually very solid on drafting interior OL and had a glut as you can only keep so many OL on the roster. He was a 4th rd pick 2 years ago<br/>
<br/>
Anything is better than the tandem of Skura/Hernandez as the G</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: In 5 years of drafts  </b><a name="15540229"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Anakim"> Anakim </a>  :  1/9/2022  9:59 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540229">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540218" target="_blank">15540218</a> Scooter185 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> The Giants will have picked at almost every spot in the top 7, just missing #1 and 3 </td>
                                </tr>
                           </tbody></table><br/>
<br/>
<br/>
And look how well we&#39;ve used those top-10 picks! Flowers, Apple, Saquon, DJ...<br/>
<br/>
The only good one was Andrew Thomas</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Brederson </b><a name="15540238"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Mark+from+Jersey"> Mark from Jersey </a>  :  1/9/2022  10:03 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540238">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540227" target="_blank">15540227</a> stretch234 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I think you give him a shot next year at either guard spot.  Baltimore is usually very solid on drafting interior OL and had a glut as you can only keep so many OL on the roster. He was a 4th rd pick 2 years ago<br/>
<br/>
Anything is better than the tandem of Skura/Hernandez as the G </td>
                                </tr>
                           </tbody></table>Its been a while since he saw the field but I remember him being at least serviceable when he was in there...cannot say that about pretty much anyone else on the OL not named Thomas</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Trade Jones and Barkley  </b><a name="15540242"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BillKo"> BillKo </a>  :  1/9/2022  10:06 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540242">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539737" target="_blank">15539737</a> Jim in Forest Hills said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Keep accumulating picks. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I see zero market for Barkley. <br/>
<br/>
Jones could bring some value and I think a new GM will entertain just about anything. Only a handful of players you&#39;d really want to keep around that have real trade value.</div></div><div class="thread_post"><div class="thread_post_header"><b>They need </b><a name="15540248"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Les+in+TO"> Les in TO </a>  :  1/9/2022  10:09 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540248">link</a>   </div></div><div class="thread_post_body">To land these picks - no more Engrams Barkley’s Joneses or Apples. If this ship is going to turn these need to be hits.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Our 36 and 67 would land us in the 21 area </b><a name="15540265"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=giantstock"> giantstock </a>  :  1/9/2022  10:18 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540265">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539904" target="_blank">15539904</a> stoneman said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> you could do alot of damage with 5, 7, and 21 (along with 80). </td>
                                </tr>
                           </tbody></table><br/>
<br/>
You could also do a lot of damage by trading both picks back.  <br/>
<br/>
At the very least before 80 you get<br/>
<br/>
1-- A Starting OT.<br/>
2-- A Starting Guard<br/>
3-- A Starting Edge.<br/>
4-- A Starting ILB<br/>
5-- A Starting TE.<br/>
6-- A Starting WR.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: In 5 years of drafts  </b><a name="15540300"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=FStubbs"> FStubbs </a>  :  1/9/2022  10:33 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540300">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540218" target="_blank">15540218</a> Scooter185 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> The Giants will have picked at almost every spot in the top 7, just missing #1 and 3 </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Consider in the DG era we&#39;ve spent a #2,4,6, and 20 overall on offense, and our offense is a disaster.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Our 36 and 67 would land us in the 21 area </b><a name="15540303"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BleedBlue"> BleedBlue </a>  :  1/9/2022  10:34 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540303">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540265" target="_blank">15540265</a> giantstock said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15539904 stoneman said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     you could do alot of damage with 5, 7, and 21 (along with 80). <br/>
                                <br/>
                           <br/>
<br/>
You could also do a lot of damage by trading both picks back.  <br/>
<br/>
At the very least before 80 you get<br/>
<br/>
1-- A Starting OT.<br/>
2-- A Starting Guard<br/>
3-- A Starting Edge.<br/>
4-- A Starting ILB<br/>
5-- A Starting TE.<br/>
6-- A Starting WR. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
If msrtinez comes back healthy and we retain smith we are fine at ILB. <br/>
<br/>
Wr we are good eith golladay toney andbmaybe we bring back slayton for cheap. Shep gone.<br/>
<br/>
Te, OL and edge <br/>
<br/>
We need 5 new starters. 3 on OL, te and edge</div></div><div class="thread_post"><div class="thread_post_header"><b>Let’s get a completely clean slate. New GM, new coach and new QB </b><a name="15540333"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Mike+in+NJ"> Mike in NJ </a>  :  1/9/2022  10:45 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540333">link</a>   </div></div><div class="thread_post_body">Take Pickett and the best OL available to protect him.</div></div><div class="thread_post"><div class="thread_post_header"><b>No one picking before us should want a QB top 5 </b><a name="15540360"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Debaser"> Debaser </a>  :  1/9/2022  11:04 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540360">link</a>   </div></div><div class="thread_post_body">Texas maybe?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: Our 36 and 67 would land us in the 21 area </b><a name="15540387"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=giantstock"> giantstock </a>  :  1/9/2022  11:15 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540387">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540303" target="_blank">15540303</a> BleedBlue said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15540265 giantstock said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15539904 stoneman said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     you could do alot of damage with 5, 7, and 21 (along with 80). <br/>
                                <br/>
                           <br/>
<br/>
You could also do a lot of damage by trading both picks back.  <br/>
<br/>
At the very least before 80 you get<br/>
<br/>
1-- A Starting OT.<br/>
2-- A Starting Guard<br/>
3-- A Starting Edge.<br/>
4-- A Starting ILB<br/>
5-- A Starting TE.<br/>
6-- A Starting WR. <br/>
                                <br/>
                           <br/>
<br/>
If msrtinez comes back healthy and we retain smith we are fine at ILB. <br/>
<br/>
Wr we are good eith golladay toney andbmaybe we bring back slayton for cheap. Shep gone.<br/>
<br/>
Te, OL and edge <br/>
<br/>
We need 5 new starters. 3 on OL, te and edge </td>
                                </tr>
                           </tbody></table><br/>
<br/>
We need 5 new starters. 3 on OL, te and edge [/quote]<br/>
1—ILB I hope you are right about Smith but there still is question how good he is. Just because he is better than what we have doesn&#39;t mean he is any good.<br/>
<br/>
2a—ILB The Giants are in rebuild. Where does Blake Martinez fit in?<br/>
2b—ILB How effective will Blake be after his injury? Again just because he is better than what we currently have doesn&#39;t mean Giants should have him beyond 2022. <br/>
<br/>
3a—WR Toney is always hurt.   Slayton is a number 4 WR not a starter.<br/>
<br/>
3b—WR Golladay was hurt last year and he was hurt this year. Even today it looked like one of his catches he came up gimpy a bit. He can&#39;t be reoiled upon to be 100%. <br/>
Considering 3A and 3B - our two top receivers have shown to be injury prone so far at Slayton is at best a bottom tier number 3 WR but actually he is a 4. <br/>
<br/>
The Giants could use a WR that could limit the impact for injuries on a given Sunday for Golladay and Toney. Right now when one is out, the opposing team either has an elite corner that will minimize one or they can double the one whenever the other is hurt. Which so far has been often.<br/>
<br/>
Another top flight WR alleviated this concern drastically and allows Slayton to be more effective at a more suitable number 4 WR.  . <br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: No one picking before us should want a QB top 5 </b><a name="15540414"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=allstarjim"> allstarjim </a>  :  1/9/2022  11:28 pm   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540414">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540360" target="_blank">15540360</a> Debaser said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Texas maybe? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Very rral possibility. That said, Davis Mills has earned himself a chance to at least compete. <br/>
<br/>
I really believe the Giants are going to love Karlaftis. Him and Ekwonu or Cross makes a lot of sense. <br/>
<br/>
I think Hutch, Neal, Thibodeaux, Stingily are your top 4 unless someone moves up for Corral.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: No one picking before us should want a QB top 5 </b><a name="15540577"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eman11"> Eman11 </a>  : 12:27 am   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540577">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540414" target="_blank">15540414</a> allstarjim said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15540360 Debaser said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Texas maybe? <br/>
                                <br/>
                           <br/>
<br/>
Very rral possibility. That said, Davis Mills has earned himself a chance to at least compete. <br/>
<br/>
I really believe the Giants are going to love Karlaftis. Him and Ekwonu or Cross makes a lot of sense. <br/>
<br/>
I think Hutch, Neal, Thibodeaux, Stingily are your top 4 unless someone moves up for Corral. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
If that’s the top 4, I’m taking Hamilton at 5 and one of those two OL at 7. I also wouldn’t hate it if we took Dean at 7 if we got an OL in FA, and then some more OL help in our next three picks.</div></div><div class="thread_post"><div class="thread_post_header"><b>Giants should grab tge 2 best oline available.  They have high picks  </b><a name="15540583"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Jack+Stroud"> Jack Stroud </a>  : 12:30 am   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540583">link</a>   </div></div><div class="thread_post_body">in the later rounds to get pass rushers, WR, DT.  They must fix that oline, get a pass rush, and a run stuffer DT.</div></div><div class="thread_post"><div class="thread_post_header"><b>Chart is fairly even for all 3 which would you rather have……? </b><a name="15540591"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Carl+in+CT"> Carl in CT </a>  : 12:33 am   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540591">link</a>   </div></div><div class="thread_post_body">A) Giants # 5 &amp; #7<br/>
<br/>
B) Jets #4 &amp; #10<br/>
<br/>
C) Eagles #15, #16, #21<br/>
<br/>
<br/>
Choice and why?</div></div><div class="thread_post"><div class="thread_post_header"><b>So now we know draft 1-18 </b><a name="15540598"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=ray+in+arlington"> ray in arlington </a>  : 12:36 am   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540598">link</a>   </div></div><div class="thread_post_body"><br/>
1. JAC<br/>
2. DET<br/>
3. HOU<br/>
4. NYJ<br/>
5. NYG<br/>
6. CAR<br/>
7. NYG<br/>
8. ATL<br/>
9. DEN<br/>
10. NYJ<br/>
11. WAS<br/>
12. MIN	 <br/>
13. CLE<br/>
14. BAL<br/>
15. PHI<br/>
16. PHI<br/>
17. LAC<br/>
18. NO	 <br/>
<br/>
<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Chart is fairly even for all 3 which would you rather have……? </b><a name="15540606"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=ray+in+arlington"> ray in arlington </a>  : 12:39 am   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540606">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540591" target="_blank">15540591</a> Carl in CT said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> A) Giants # 5 &amp; #7<br/>
<br/>
B) Jets #4 &amp; #10<br/>
<br/>
C) Eagles #15, #16, #21<br/>
<br/>
<br/>
Choice and why? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
PHI can&#39;t be 21.  They can be 19, 25, 29, 31 or 32</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Chart is fairly even for all 3 which would you rather have……? </b><a name="15540608"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=ray+in+arlington"> ray in arlington </a>  : 12:40 am   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540608">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540591" target="_blank">15540591</a> Carl in CT said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> A) Giants # 5 &amp; #7<br/>
<br/>
B) Jets #4 &amp; #10<br/>
<br/>
C) Eagles #15, #16, #21<br/>
<br/>
<br/>
Choice and why? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
But still a fun question...</div></div><div class="thread_post"><div class="thread_post_header"><b>I don’t know what the chart says </b><a name="15540870"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=giantBCP"> giantBCP </a>  : 9:17 am   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15540870">link</a>   </div></div><div class="thread_post_body">but in the real world, picks 5 and 7 have more value than the other two options.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Hopefully No Hamilton or Stingley or Williams  </b><a name="15541220"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Highlander"> Highlander </a>  : 10:12 am   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15541220">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539762" target="_blank">15539762</a> giantstock said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Hopefully Giants go with 1sttwo picks of combo of OL and Edge.<br/>
<br/>
Trade down if need be. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Absolutely agree.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Will be interesting to see what the new GM decides </b><a name="15541312"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=VinegarPeppers"> VinegarPeppers </a>  : 10:30 am   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15541312">link</a>   </div></div><div class="thread_post_body">Depth for the OL?   We need 4 new starters for the OL.  70% of our problems on offense is the OL.  They suck.  Injuries to WRs and DJs struggles make up the rest.  We cannot go into this draft thinking anything but STARTING OL.  Plug and play.  Go top shelf with the two first rounders and finally start locking-in a 10 year OL. <br/>
<br/>
n comment <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15539886" target="_blank">15539886</a> beatrixkiddo said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> But you have to figure they move down with one of those picks, question is which one will return greater value. Can make an argument that any t am in front of us would be looking to sell, of course this cost will be greater so maybe the 5 slot is the perfect place for a team that likes a QB to jump ahead of Carolina to get one. WhT could we reasonably return? A 1st this year and next and a day 2 pick this year? If so I would 100% do that. Especially if we are going to miss out on the blue chip Edge players. Gives us more ammo to grab quality depth for the OL later on. Just have to hope they have the right guy in here and get the FO cleaned up, if not trade both picks back for the future when you have a better plan in place. Right now, the Giants are a hot mess and no draft pick unless LT is cloned and enters is changing the outcome for this team. </td>
                                </tr>
                           </tbody></table></div></div><div class="thread_post"><div class="thread_post_header"><b>The GM, whomever it may be, </b><a name="15541327"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Simms11"> Simms11 </a>  : 10:32 am   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15541327">link</a>   </div></div><div class="thread_post_body">will have to have a draft like the ‘74 Steelers in order to get this ship righted!!</div></div><div class="thread_post"><div class="thread_post_header"><b>Why wouldn&#39;t Detroit be thinking QB? </b><a name="15541348"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=chick310"> chick310 </a>  : 10:37 am   : <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1#15541348">link</a>   </div></div><div class="thread_post_body">Goff has a decent cap hit this year but can easily be shed in 2023.  The Lions could grab a rookie QB and start putting him into games by end of 2022 season.<br/>
<br/></div></div><div style="margin: 10 10 20 50"><span class="top_pages">Pages:  <a href="index.php?mode=2&amp;thread=617498&amp;thread_page=1">1</a>  <b style="background: darkred;padding: 2px 5px 2px 5px;">2</b>  <a href="index.php?mode=2&amp;thread=617498&amp;thread_page=1">&lt;&lt;Prev </a>| <a href="index.php?mode=2&amp;thread=617498&amp;show_all=1" title="">Show All</a> | </span></div>
<a name="END"></a><a href="index.php"></a><div style="padding-top:25px; padding-bottom:20px;"><a href="index.php"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"/></a></div></div>
<div class="thread_sidebar_2">

<!-- Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-102">
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Corner Forum - Lower 300x250 -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1566320450447229" data-ad-slot="4189314539" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->

</div>

</div>




<div class="footer">


<p style="width:450px;float:left;padding:10px;"><b>Part of the USA Today Sports Media Group</b><br/>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</p>
<p style="width:400px;float:right; text-align:right;padding:10px;">
All contents (unless otherwise specified) copyright ©  1995 - 2021<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br/> <br/><strong>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Solutions</a></strong>
</p>
<br clear="all"/>
 
</div>




<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->



<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=0&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script><script type="text/javascript" onload="__ezcl.handle(true);" async src="/utilcave_com/inc/ezcl.webp?cb=4"></script></body></html>