<!DOCTYPE html><html lang="en"><head><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
if(typeof isOrig==='undefined'){isOrig=false;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){if((impId!=="0"||isOrig===true)&&adUnit!==""){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-1&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-1&cb=4', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-1&cb=5', false, [], true, false, true, false);</script>
<title>Blake Martinez to remain a Giant in 2022 | Big Blue Interactive </title>

<meta http-equiv="Pragma" content="no-cache"/>
<meta http-equiv="Expires" content="-1"/>

<meta name="keywords" content="ndglbqfkxx"/>

<meta name="description" content="new deal. Link   - ( New Window )"/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="website"/>
<meta property="og:description" content="new deal. Link   - ( New Window )"/> 
<meta property="og:title" content="Blake Martinez to remain a Giant in 2022"/> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif"/> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css?v=20200217"/>

<link rel="stylesheet" type="text/css" href="anylink.css"/>


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}


div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" alt="for display only">

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type="text/javascript">
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type="text/javascript" src="https://img.bnqt.com/lib/js/sdpdfphelper.js"></script>
<script type="text/javascript">
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>


<!-- End DFP SETUP -->  

<!-- End USA Today Code -->




<script type="text/javascript">var ezouid = "1";</script><base href="https://corner.bigblueinteractive.com/index.php?mode=2&thread=620051"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"domain_test_group":20210306,"engaged_time_visit":0,"ezcache_level":0,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"223a0b38-35c6-4186-51b4-0955d89f666e","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":90488,"response_time_orig":109,"serverid":"54.224.34.18:2006","state":"VA","t_epoch":1647239302,"template_id":126,"time_on_site_visit":0,"url":"https://corner.bigblueinteractive.com/index.php?mode=2\u0026thread=620051","user_id":0,"word_count":7484,"worst_bad_word_level":3};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["223a0b38-35c6-4186-51b4-0955d89f666e", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>


<body>




<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tbody><tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"/></a> <img src="images/xpete.gif" alt="The Corner Forum"/>

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic --> 


<!-- Nov 2019 Leaderboard -->

<!-- Ezoic - Forum Leaderboard (USAT) - top_of_page -->
<div id="ezoic-pub-ad-placeholder-118">
<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->
<div id="usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general');
         });
     </script>
</div>
</div>
<!-- End Ezoic - Forum Leaderboard (USAT) - top_of_page -->



</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://www.amazon.com/?_encoding=UTF8&amp;camp=1789&amp;creative=9325&amp;linkCode=ur2&amp;tag=bigblueintera-20">Amazon.com</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW">Standings (NFL.com)</a>
<a href="https://www.giants.com/team/stats/" target="_NEW">Statistics (Giants.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/">Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</tbody></table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;home_view_menu&#39;)">Home</a>  
</li><li><a href="http://corner.bigblueinteractive.com/index.php" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;forum_view_menu&#39;)">Corner Forum</a>
</li><li><a href="http://corner.bigblueinteractive.com/index.php" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;gameday_view_menu&#39;)">Gameday</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_view_menu&#39;)">Team</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_building_view_menu&#39;)">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info & History</a> -->
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_info_view_menu&#39;)">Giants Info &amp; History</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;infolinks_view_menu&#39;)">Info/Links</a>
</li><li><a href="/index.php?mode=10" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;login_menu&#39;)">Log In</a>
</li></ul>

</div><div id="infoline"> </div>

<a name="END"></a><a href="index.php"></a><div style="padding-top:20px; padding-bottom:25px;"><a href="index.php"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"/></a></div><div class="thread_container"><div class="thread_left"><div class="thread_body"><div class="thread_main"><div class="thread_post_header">  <h1 style="font-size:18px;">Blake Martinez to remain a Giant in 2022 </h1><div class="thread_info"><a href="index.php?mode=5&amp;handle=Jolly Blue Giant"> Jolly Blue Giant </a>  :  3/11/2022  5:46 pm</div></div><div class="thread_post_body"> new deal.<br/><a href="https://twitter.com/Schultz_Report/status/1502415167153483782?s=20&amp;t=RXHEPq0KnZkBS_aDVIqjUg"> Link </a>  - (<a href="https://twitter.com/Schultz_Report/status/1502415167153483782?s=20&amp;t=RXHEPq0KnZkBS_aDVIqjUg" target="_NEW"> New Window </a>) </div></div></div><div style="margin: 10 10 20 50"><span class="top_pages">Pages:  <a href="index.php?mode=2&amp;thread=620051&amp;thread_page=1">1</a>  <a href="index.php?mode=2&amp;thread=620051&amp;thread_page=2">2</a>  <b style="background: darkred;padding: 2px 5px 2px 5px;">3</b>  <a href="index.php?mode=2&amp;thread=620051&amp;thread_page=2">&lt;&lt;Prev </a>| <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1" title="">Show All</a> | </span></div>
</div><div class="thread_right"><div id="ad_side_box">


<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id="usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103,22280986322/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general');
         });
     </script>
</div>


</div></div><div class="thread_comment_container"><div class="thread_post"><div class="thread_post_header"><b>RE: ... </b><a name="15628277"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=christian"> christian </a>  :  3/12/2022  10:07 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628277">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628256" target="_blank">15628256</a> gidiefor said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Tom Rock<br/>
@TomRock_Newsday<br/>
·<br/>
12m<br/>
I&#39;m told both Sterling Shepard and Blake Martinez agreed to base salaries of roughly $2.25m with a chance to double that ($5m or so) in total with incentives in new deals.</td>
                                </tr>
                           </tbody></table><br/>
<br/>
I’m not surprised Shepard got a little more than the minimum when thinking it through. He had a little bit of leverage. If the Giants cut him outright his 2023 bonus money would accelerate and he’d count ~8M in dead money against the 2022 cap. If they designated him a June 1 cut, he’d count ~4M against each of 22 &amp; 23, but the Giants couldn’t spend the saving until June. And they clearly need it now.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: More dead cap added to 2023 </b><a name="15628278"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=clatterbuck"> clatterbuck </a>  :  3/12/2022  10:07 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628278">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15627953" target="_blank">15627953</a> Anakim said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15627950 JoeyBigBlue said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Yay. <br/>
                                <br/>
                           <br/>
<br/>
Not necessarily It could be a Shep type of restructure/pay cut where the last year is removed or it could be an incentive-based contract. That&#39;s why I said I&#39;m waiting for the numbers to be released. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Duggan (Athletic) says its a &#34;reworked&#34; contract, a.k.a., a pay cut.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: christian </b><a name="15628279"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=christian"> christian </a>  :  3/12/2022  10:09 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628279">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628273" target="_blank">15628273</a> Eric from BBI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> If Martinez was cut,  there would have been $5.5 million in dead money against the 2023 cap.<br/>
<br/>
If Shepard was cut, there would have been $8 million in dead money against the 2023 cap. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
That’s incorrect Eric. Those are the dead money figures for 2022, if they were both designated as pre-June 1 cuts.</div></div><div class="thread_post"><div class="thread_post_header"><b>christian </b><a name="15628280"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  3/12/2022  10:10 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628280">link</a>   </div></div><div class="thread_post_body">OK, so it reduces dead money in 2022. Same point.<br/>
<br/>
I believe there comes a point that if you can arrange the contract in a certain fashion, it makes more financial sense to keep the player than cut him. That assume the player takes a significant pay cut.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: Not </b><a name="15628283"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=clatterbuck"> clatterbuck </a>  :  3/12/2022  10:13 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628283">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628056" target="_blank">15628056</a> Straw Hat said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15627988 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15627927 Straw Hat said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     A fan.  Slow old school player.  Not fast enough for todays game. <br/>
                                <br/>
                           <br/>
<br/>
Odd take. He was a heck of a football player for the Giants before he got hurt.<br/>
<br/>
If this is similar to the Shep deal, financially this may make more sense. <br/>
                                <br/>
                           <br/>
<br/>
He’s overrated because he makes a shit ton of tackles.  Tae crowder made a shit ton of tackles too.  I’ll admit he was good in 2020, but he was playing like dog shit in 2021 prior to the injury.  <br/>
 </td>
                                </tr>
                           </tbody></table><br/>
<br/>
He was injured in the 3rd game of the season.</div></div><div class="thread_post"><div class="thread_post_header"><b>… </b><a name="15628286"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=christian"> christian </a>  :  3/12/2022  10:17 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628286">link</a>   </div></div><div class="thread_post_body">The Giants save significant money from directly cutting their salary. That’s the bottom line and the smart move. They shouldn’t be investing any more than minimal cash in players coming off major injuries.<br/>
<br/>
What year they park bonus money already paid is a balance sheet exercise. Gettleman left them in such a mess, the 3.95M that would accelerate if they cut Shepard is a big deal because they have no space.<br/>
<br/>
If the Giants had the room to absorb that hit, or the room to wait for the savings until June, Shepard wouldn’t be a Giant.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Would like to see a clean break with more guys. </b><a name="15628287"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=clatterbuck"> clatterbuck </a>  :  3/12/2022  10:17 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628287">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628247" target="_blank">15628247</a> NYGgolfer said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Martinez is a tackling machine but concerns new vision/change will get blurred by bringing backs guys like Shep, him and probably a few others. TBD. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
You think maybe Martindale had some thoughts on this before decision was made?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: NYGgolfer  </b><a name="15628288"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=NYGgolfer"> NYGgolfer </a>  :  3/12/2022  10:19 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628288">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628275" target="_blank">15628275</a> Eric from BBI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> If the Giants had cut Martinez, they would have been seeking a veteran like him in free agency to fill the void until some rookie was brought in this year or next and brought up to speed. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Yes, but I am not looking the Giants are to be fixed or need to win anything in 2022.  <br/>
<br/>
A key goal should be to find new players and give them opportunities, hopefully uninjured younger ones too.  In some cases, replace non-core guys with other non-core guys that are at least cheaper and let&#39;s see if they develop. Many of them won&#39;t, some of them will and you continue to churn the roster until is continues to improve.<br/>
<br/>
Giants should be able to trade some current players for extra picks or different players.  Maybe even a young MLB with some talents on a team that needs a RB or CB more.</div></div><div class="thread_post"><div class="thread_post_header"><b>Amazing </b><a name="15628289"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Jay+on+the+Island"> Jay on the Island </a>  :  3/12/2022  10:20 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628289">link</a>   </div></div><div class="thread_post_body">Blake Martinez is the best ILB the Giants have had since Antonio Pierce and some fans are mad he took a paycut and wasn&#39;t released.  The Giants have no cap room plus holes at LG, C, RG, RT, S, ILB, NT, TE(they need 3 TE&#39;s!), RB, WR, and QB.  <br/>
<br/>
The Giants only have 9 draft picks to fill those numerous holes but if they are very lucky they will land 4 starters with those picks.  Also if Martinez returns to form the Giant might be able to trade him before the deadline for another 2023 draft pick.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: christian </b><a name="15628292"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=NYGgolfer"> NYGgolfer </a>  :  3/12/2022  10:25 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628292">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628280" target="_blank">15628280</a> Eric from BBI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> OK, so it reduces dead money in 2022. Same point.<br/>
<br/>
I believe there comes a point that if you can arrange the contract in a certain fashion, it makes more financial sense to keep the player than cut him. That assume the player takes a significant pay cut. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
But it&#39;s not the same point.  Not winning anything at all in 2022, so clean up the balance sheet now within reason.<br/>
<br/>
There should be little attachment to these two players, especially with recent injuries.  They can easily be seen as reasonable cuts now.</div></div><div class="thread_post"><div class="thread_post_header"><b>NYGgolfer </b><a name="15628297"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  3/12/2022  10:30 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628297">link</a>   </div></div><div class="thread_post_body">How was the balance sheet in 2023 made worse? Details please.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Would like to see a clean break with more guys. </b><a name="15628299"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=NYGgolfer"> NYGgolfer </a>  :  3/12/2022  10:31 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628299">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628287" target="_blank">15628287</a> clatterbuck said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15628247 NYGgolfer said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Martinez is a tackling machine but concerns new vision/change will get blurred by bringing backs guys like Shep, him and probably a few others. TBD. <br/>
                                <br/>
                           <br/>
<br/>
You think maybe Martindale had some thoughts on this before decision was made? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Bringing back Martinez is a construct I could live with, as there are at least some pros with the cons although they are not compelling.  The Shepard return makes no sense.<br/>
<br/>
Worried some what happens with other player decisions as this rebuild needs a better kick start by breaking some more bad foundation and leveling out before constructing things in a better fashion going forward.</div></div><div class="thread_post"><div class="thread_post_header"><b>NYGgolfer </b><a name="15628303"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  3/12/2022  10:34 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628303">link</a>   </div></div><div class="thread_post_body">You are acting like Shepard can&#39;t still be cut.<br/>
<br/>
And if he is cut in August, it&#39;s cheaper to do so.</div></div><div class="thread_post"><div class="thread_post_header"><b>nyggolfer a question for you  </b><a name="15628306"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  :  3/12/2022  10:35 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628306">link</a>   </div></div><div class="thread_post_body">which outcome would you prefer:<br/>
<br/>
1. cutting martinez/shepard now<br/>
2. trading them for a 7th round pick (or better) at the deadline <br/>
<br/>
having players take paycuts to the minimum makes them very easily tradable to any team in the league. <br/>
<br/>
being on expiring contracts gives the acquiring team an opportunity to get back whatever pick they give up via a comp pick. <br/>
<br/>
even if you rate the probability of outcome #2 low - let&#39;s say 10-20% - isn&#39;t that better than 0%? <br/>
<br/>
and even if you consider the few million in future dead money an opportunity cost, isn&#39;t the chance for extra draft picks well worth a few million $?<br/>
<br/>
if they can get good future picks right now for a veteran, trade away (ex. bradberry). if not there is no downside to carrying those players into the season and hoping to get better value in October. only upside.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: NYGgolfer </b><a name="15628308"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=NYGgolfer"> NYGgolfer </a>  :  3/12/2022  10:37 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628308">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628297" target="_blank">15628297</a> Eric from BBI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> How was the balance sheet in 2023 made worse? Details please. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Apologies if I got this wrong, but dead hits to the cap that could be taken fully this year with cutting these players are now also affecting 2023. Less room in 2023 by keeping an injured non-core player for this season.</div></div><div class="thread_post"><div class="thread_post_header"><b>… </b><a name="15628309"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=christian"> christian </a>  :  3/12/2022  10:37 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628309">link</a>   </div></div><div class="thread_post_body">The Giants aren’t brining back the 2020 version of Martinez. They are bringing back the 2022 version coming off a torn ACL. <br/>
<br/>
This fan base should be sufficiently familiar with how long it takes to return to form from an ACL injury.<br/>
<br/>
The Giants are punching a 2.5M lottery ticket on Martinez. But no one should hold their breath or assume the same player suits up. If Martinez was confident in that, he would have declined the pay cut and taken his chances in UFA.</div></div><div class="thread_post"><div class="thread_post_header"><b>I&#39;ll leave it at this </b><a name="15628314"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  3/12/2022  10:40 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628314">link</a>   </div></div><div class="thread_post_body">Everyone here knows that I&#39;m not a huge fan of Shepard. Not because he&#39;s a bad guy or player, but I think he&#39;s been over-hyped for years.<br/>
<br/>
But if you can bring him back to camp on relatively cheap, 1-year deal, what&#39;s the issue? He&#39;s not being handed anything. He has to prove he is healthy and can beat out the competition.<br/>
<br/>
Regarding Martinez, people around here know I&#39;m a fan of his. The ACL injury somewhat clouds his future, but if he recovers, he&#39;s still the best ILB on this team by a mile and now he&#39;s relatively cheap too (and also easier to cut).<br/>
<br/>
So what&#39;t the issue? These contracts were not restructured, they were pay cuts. That&#39;s a huge difference.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: NYGgolfer </b><a name="15628316"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  :  3/12/2022  10:41 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628316">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628308" target="_blank">15628308</a> NYGgolfer said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15628297 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     How was the balance sheet in 2023 made worse? Details please. <br/>
                                <br/>
                           <br/>
<br/>
Apologies if I got this wrong, but dead hits to the cap that could be taken fully this year with cutting these players are now also affecting 2023. Less room in 2023 by keeping an injured non-core player for this season. </td>
                                </tr>
                           </tbody></table><br/>
you are correct.<br/>
<br/>
the counter argument is however that next year they have 100m+ in room, and some other contracts entering their final season will become much easier moved to create more room (golladay, jackson, ryan specifically). <br/>
<br/>
if you remove those 3 players from next year&#39;s roster they have $135m free, including the dead $ charges.<br/>
<br/>
the concept people never learn about future cap room is that in the NFL there&#39;s really on 2 ways to spend it.<br/>
<br/>
1. extensions to players already on the roster, drafted 3+ years ago. <br/>
<br/>
2. free agency. which almost always leads to the exact bad contracts getting jettisoned for cap room in the first place.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: NYGgolfer </b><a name="15628317"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  3/12/2022  10:42 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628317">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628308" target="_blank">15628308</a> NYGgolfer said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15628297 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     How was the balance sheet in 2023 made worse? Details please. <br/>
                                <br/>
                           <br/>
<br/>
Apologies if I got this wrong, but dead hits to the cap that could be taken fully this year with cutting these players are now also affecting 2023. Less room in 2023 by keeping an injured non-core player for this season. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
These guys are both now on one year deals. If they make the team, there is no dead money. <br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: nyggolfer a question for you  </b><a name="15628318"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=NYGgolfer"> NYGgolfer </a>  :  3/12/2022  10:42 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628318">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628306" target="_blank">15628306</a> Eric on Li said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> which outcome would you prefer:<br/>
<br/>
1. cutting martinez/shepard now<br/>
2. trading them for a 7th round pick (or better) at the deadline <br/>
<br/>
having players take paycuts to the minimum makes them very easily tradable to any team in the league. <br/>
<br/>
being on expiring contracts gives the acquiring team an opportunity to get back whatever pick they give up via a comp pick. <br/>
<br/>
even if you rate the probability of outcome #2 low - let&#39;s say 10-20% - isn&#39;t that better than 0%? <br/>
<br/>
and even if you consider the few million in future dead money an opportunity cost, isn&#39;t the chance for extra draft picks well worth a few million $?<br/>
<br/>
if they can get good future picks right now for a veteran, trade away (ex. bradberry). if not there is no downside to carrying those players into the season and hoping to get better value in October. only upside. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Trade them now for a 7th round pick or better.</div></div><div class="thread_post"><div class="thread_post_header"><b>NYGgolfer </b><a name="15628319"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+from+BBI"> Eric from BBI </a> : <b style="background:darkred;color:white;">Admin</b> :  3/12/2022  10:43 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628319">link</a>   </div></div><div class="thread_post_body">Both would not pass a physical now. Different story in early September.</div></div><div class="thread_post"><div class="thread_post_header"><b>it&#39;s a coin flip christian </b><a name="15628321"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  :  3/12/2022  10:47 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628321">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628309" target="_blank">15628309</a> christian said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> The Giants aren’t brining back the 2020 version of Martinez. They are bringing back the 2022 version coming off a torn ACL. <br/>
<br/>
This fan base should be sufficiently familiar with how long it takes to return to form from an ACL injury.<br/>
<br/>
The Giants are punching a 2.5M lottery ticket on Martinez. But no one should hold their breath or assume the same player suits up. If Martinez was confident in that, he would have declined the pay cut and taken his chances in UFA. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
none of us know his medical outlook and unlike barkley last year i haven&#39;t seen it reported that he had a more complicated ACL injury. <br/>
<br/>
the average recovery time is 9-11 months for an ACL and plenty of players come back just fine. Jeffrey Simmons tore his ACL and still got drafted mid-round 1 and has been an excellent player for TEN. Jameson Williams and John Metchie and George Pickens will be day 1 or day 2 picks.  <br/>
<br/>
Frank Gore tore his acl 3x at miami and went on to an incredibly durable NFL career. <br/>
<br/>
the cowboys drafted taco charlton over tj watt because TJ watt had been the more injury prone player with injuries to both his knees at Wisconsin.<br/>
<br/>
if the NYG are eating into any potential saved $ to bring back Martinez - which they are - it would lead me to believe they feel confident about the current medical outlook.</div></div><div class="thread_post"><div class="thread_post_header"><b>as Eric said you can&#39;t trade either right now but in Sept maybe </b><a name="15628323"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  :  3/12/2022  10:52 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628323">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628318" target="_blank">15628318</a> NYGgolfer said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">            <br/>
Trade them now for a 7th round pick or better. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
but let&#39;s play out another hypothetical and pretend you could get a 7th round pick right now. <br/>
<br/>
or you evaluate that there&#39;s a:  <br/>
<br/>
60% chance at a 6th round pick or better in October (melvin ingram, jakeem grant, and even flacco returned 6ths in &#39;21)<br/>
<br/>
30% chance at a 5th round pick or better in October (ertz returned a 5th and a roster player)<br/>
<br/>
15% chance at an even better return than those.<br/>
<br/>
which would you choose? <br/>
<br/>
imo the opportunity cost is so minimal why not try to maximize the asset as much as possible?</div></div><div class="thread_post"><div class="thread_post_header"><b>2 known players </b><a name="15628326"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Joe+Beckwith"> Joe Beckwith </a>  :  3/12/2022  10:55 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628326">link</a>   </div></div><div class="thread_post_body">on cheaper contracts, that opted to help the teams $$$$ issues, IF they make the team, and IF they can play.<br/>
Under the mess Shoen was left with, this was good negotiating.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: NYGgolfer </b><a name="15628327"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=NYGgolfer"> NYGgolfer </a>  :  3/12/2022  10:58 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628327">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628316" target="_blank">15628316</a> Eric on Li said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15628308 NYGgolfer said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15628297 Eric from BBI said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     How was the balance sheet in 2023 made worse? Details please. <br/>
                                <br/>
                           <br/>
<br/>
Apologies if I got this wrong, but dead hits to the cap that could be taken fully this year with cutting these players are now also affecting 2023. Less room in 2023 by keeping an injured non-core player for this season. <br/>
                                <br/>
                           <br/>
you are correct.<br/>
<br/>
the counter argument is however that next year they have 100m+ in room, and some other contracts entering their final season will become much easier moved to create more room (golladay, jackson, ryan specifically). <br/>
<br/>
if you remove those 3 players from next year&#39;s roster they have $135m free, including the dead $ charges.<br/>
<br/>
the concept people never learn about future cap room is that in the NFL there&#39;s really on 2 ways to spend it.<br/>
<br/>
1. extensions to players already on the roster, drafted 3+ years ago. <br/>
<br/>
2. free agency. which almost always leads to the exact bad contracts getting jettisoned for cap room in the first place. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
It&#39;s also not a requirement to spend the room just because you have it. Garnering more and more picks allows the team to find cheaper talent in the draft which at some point will become more expensive talent that you may want to retain.  Or trade away veteran players now for young players with some promise that may be expensive in the same fashion. And if it is done correctly, that saved space allows for adding one or two free agent prizes down the road when the team sees an exponential chance to winning. <br/>
<br/>
Rebuild in its essence shouldn&#39;t mean recycling older injured players in the same roles they had before.  Move players for picks or new players, or cut them if it saves money, or at least cut them if it accelerates the future pain.</div></div><div class="thread_post"><div class="thread_post_header"><b>… </b><a name="15628328"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=christian"> christian </a>  :  3/12/2022  10:59 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628328">link</a>   </div></div><div class="thread_post_body">I’m not sure what any of has to do with my post. Who knows what Martinez’s medium and long term health prospects are.<br/>
<br/>
My very simple observation, is the year following an ACL tear is a wildcard, and the prospects of Martinez returning to his 2020 form next year are not high odds. <br/>
<br/>
If he or the Giants believed it was a high odds proposition next year, he wouldn’t be taken a 75% pay cut.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: NYGgolfer </b><a name="15628330"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  :  3/12/2022  11:03 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628330">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628327" target="_blank">15628327</a> NYGgolfer said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">     <br/>
<br/>
It&#39;s also not a requirement to spend the room just because you have it. Garnering more and more picks allows the team to find cheaper talent in the draft which at some point will become more expensive talent that you may want to retain.  Or trade away veteran players now for young players with some promise that may be expensive in the same fashion. And if it is done correctly, that saved space allows for adding one or two free agent prizes down the road when the team sees an exponential chance to winning. <br/>
<br/>
Rebuild in its essence shouldn&#39;t mean recycling older injured players in the same roles they had before.  Move players for picks or new players, or cut them if it saves money, or at least cut them if it accelerates the future pain. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
you are talking in abstractions. there is $100m+ free next year, and 200m+ free in 2024. <br/>
<br/>
what specifically is: <br/>
<br/>
carrying Martinez @$2.5m this year <br/>
carrying forward $4m of dead cap for Shep next year<br/>
<br/>
in your worst case scenario what does that cost them? not in the abstract (&#34;future flexibility!&#34;) but in reality? <br/>
<br/>
Which player on the roster due to hit FA (now or next year) will they not be able to extend?<br/>
<br/>
Which player(s) set to hit UFA now or next year will they not be able to go after?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: as Eric said you can&#39;t trade either right now but in Sept maybe </b><a name="15628331"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=NYGgolfer"> NYGgolfer </a>  :  3/12/2022  11:04 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628331">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628323" target="_blank">15628323</a> Eric on Li said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15628318 NYGgolfer said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                                <br/>
Trade them now for a 7th round pick or better. <br/>
                                <br/>
                           <br/>
<br/>
but let&#39;s play out another hypothetical and pretend you could get a 7th round pick right now. <br/>
<br/>
or you evaluate that there&#39;s a:  <br/>
<br/>
60% chance at a 6th round pick or better in October (melvin ingram, jakeem grant, and even flacco returned 6ths in &#39;21)<br/>
<br/>
30% chance at a 5th round pick or better in October (ertz returned a 5th and a roster player)<br/>
<br/>
15% chance at an even better return than those.<br/>
<br/>
which would you choose? <br/>
<br/>
imo the opportunity cost is so minimal why not try to maximize the asset as much as possible? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I would choose the pick now.  Because I don&#39;t really subscribe to your percentages and would take the known today. Especially for two guys with injury rehabs that would not pass of physical in the near future. And certainly aren&#39;t going to be playing any better in future.<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>there is an answer to the bolded question - the nyg medical team (HSS) </b><a name="15628333"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  :  3/12/2022  11:05 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628333">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628328" target="_blank">15628328</a> christian said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I’m not sure what any of has to do with my post.<span class="bold"> Who knows what Martinez’s medium and long term health prospects are.</span><br/>
<br/>
My very simple observation, is the year following an ACL tear is a wildcard, and the prospects of Martinez returning to his 2020 form next year are not high odds. <br/>
<br/>
If he or the Giants believed it was a high odds proposition next year, he wouldn’t be taken a 75% pay cut. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
and your closing premise cuts 2 ways. if the giants believe it was a high odds proposition that he&#39;d deliver no value this year due to injury, they wouldn&#39;t have given him 2.5m more than they had to.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: NYGgolfer </b><a name="15628338"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=NYGgolfer"> NYGgolfer </a>  :  3/12/2022  11:12 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628338">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628330" target="_blank">15628330</a> Eric on Li said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15628327 NYGgolfer said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                         <br/>
<br/>
It&#39;s also not a requirement to spend the room just because you have it. Garnering more and more picks allows the team to find cheaper talent in the draft which at some point will become more expensive talent that you may want to retain.  Or trade away veteran players now for young players with some promise that may be expensive in the same fashion. And if it is done correctly, that saved space allows for adding one or two free agent prizes down the road when the team sees an exponential chance to winning. <br/>
<br/>
Rebuild in its essence shouldn&#39;t mean recycling older injured players in the same roles they had before.  Move players for picks or new players, or cut them if it saves money, or at least cut them if it accelerates the future pain. <br/>
                                <br/>
                           <br/>
<br/>
you are talking in abstractions. there is $100m+ free next year, and 200m+ free in 2024. <br/>
<br/>
what specifically is: <br/>
<br/>
carrying Martinez @$2.5m this year <br/>
carrying forward $4m of dead cap for Shep next year<br/>
<br/>
in your worst case scenario what does that cost them? not in the abstract (&#34;future flexibility!&#34;) but in reality? <br/>
<br/>
Which player on the roster due to hit FA (now or next year) will they not be able to extend?<br/>
<br/>
Which player(s) set to hit UFA now or next year will they not be able to go after? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
We should want every singe free dollar that we can get. Are NFL salaries going down?  Is it not reasonable to believe the Giants will have better drafts and free agents than Gettleman brought in and want to keep those player albeit at a higher cost?  What if the team starts getting better sooner and a veteran QB opportunity becomes available but he&#39;s expensive?<br/>
<br/>
Again, this isn&#39;t a difficult decision because the players being debated are not core to this rebuild going forward.  Trade them or cut them.  The calculus might be different if we were discussing a valuable non-injured player but we aren&#39;t.</div></div><div class="thread_post"><div class="thread_post_header"><b>these are more abstractions (false ones too) </b><a name="15628340"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  :  3/12/2022  11:18 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628340">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628338" target="_blank">15628338</a> NYGgolfer said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
                                <br/>
                           <br/>
<br/>
We should want every singe free dollar that we can get. Are NFL salaries going down?  Is it not reasonable to believe the Giants will have better drafts and free agents than Gettleman brought in and want to keep those player albeit at a higher cost?  What if the team starts getting better sooner and a veteran QB opportunity becomes available but he&#39;s expensive?<br/>
 </td>
                                </tr>
                           </tbody></table><br/>
<br/>
if they have better drafts, when is the first day those players will be eligible for extensions? 2026 or 2027? <br/>
<br/>
what if a veteran QB is available? you mean like how they are allegedly going after Trubisky? <br/>
<br/>
or how they could easily maneuver the cap to have traded for Wilson or trade for Watson right now? <br/>
<br/>
worrying about about Martinez&#39; 2.5m this year and Shepard&#39;s 8m dead money this year or 4m/4m this year is literally worrying about deck chairs on the titanic. and in this case they are deck chairs that may be able to double as life rafts with some low probability positive value in the future.</div></div><div class="thread_post"><div class="thread_post_header"><b>… </b><a name="15628341"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=christian"> christian </a>  :  3/12/2022  11:20 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628341">link</a>   </div></div><div class="thread_post_body">Martinez is effectively on a prove-it deal. He’s reportedly making less money than the Giants signed Markus Golden for in 2019.<br/>
<br/>
Makes sense, adjusted for cap inflation, and the fact Golden was a year removed his ACL tear — the Giants value Martinez less.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: these are more abstractions (false ones too) </b><a name="15628347"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=NYGgolfer"> NYGgolfer </a>  :  3/12/2022  11:27 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628347">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628340" target="_blank">15628340</a> Eric on Li said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15628338 NYGgolfer said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
                                <br/>
                           <br/>
<br/>
We should want every singe free dollar that we can get. Are NFL salaries going down?  Is it not reasonable to believe the Giants will have better drafts and free agents than Gettleman brought in and want to keep those player albeit at a higher cost?  What if the team starts getting better sooner and a veteran QB opportunity becomes available but he&#39;s expensive?<br/>
 <br/>
                                <br/>
                           <br/>
<br/>
if they have better drafts, when is the first day those players will be eligible for extensions? 2026 or 2027? <br/>
<br/>
what if a veteran QB is available? you mean like how they are allegedly going after Trubisky? <br/>
<br/>
or how they could easily maneuver the cap to have traded for Wilson or trade for Watson right now? <br/>
<br/>
worrying about about Martinez&#39; 2.5m this year and Shepard&#39;s 8m dead money this year or 4m/4m this year is literally worrying about deck chairs on the titanic. and in this case they are deck chairs that may be able to double as life rafts with some low probability positive value in the future. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I wouldn&#39;t worry about it at all. Get as many picks as you can with little risk via treades, cut players you don&#39;t see as core and can&#39;t trade or that free up dollars.<br/>
<br/>
Find new players. And if you are good at it, they will be expensive so free up every dollar.<br/>
<br/>
The Giants have already proven themselves to be the Titantic.  You are the one that wants to preserve two broken down chairs on it because you think they will accrete value, not me.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: … </b><a name="15628349"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  :  3/12/2022  11:27 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628349">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628341" target="_blank">15628341</a> christian said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Martinez is effectively on a prove-it deal. He’s reportedly making less money than the Giants signed Markus Golden for in 2019.<br/>
<br/>
Makes sense, adjusted for cap inflation, and the fact Golden was a year removed his ACL tear — the Giants value Martinez less. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
different positions but i agree, they paid within the market rate range. <br/>
<br/>
just noting that they didn&#39;t have to, they chose to. they may not add more than 1 or 2 external FA above $2.5m this year, so that&#39;s not an insignificant amount in the narrow lens of this season and the FA period over the next few weeks. <br/>
<br/>
that could be the eventual cost of feliciano just as an example.</div></div><div class="thread_post"><div class="thread_post_header"><b>actually Schoen/Daboll chose to preserve the deck chairs (not me) </b><a name="15628354"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  :  3/12/2022  11:32 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628354">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628347" target="_blank">15628347</a> NYGgolfer said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
<br/>
I wouldn&#39;t worry about it at all. Get as many picks as you can with little risk via treades, cut players you don&#39;t see as core and can&#39;t trade or that free up dollars.<br/>
<br/>
Find new players. And if you are good at it, they will be expensive so free up every dollar.<br/>
<br/>
The Giants have already proven themselves to be the Titantic.  You are the one that wants to preserve two broken down chairs on it because you think they will accrete value, not me. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
i see the argument for their decisions - and since they are the ones tasked with &#34;finding the new players&#34; as you say, and it&#39;s entirely to their own personal/occupational benefit to do so i assume they didn&#39;t make these moves in lieu of better alternatives. <br/>
<br/>
you are the one who disagrees with them but cant name any actual alternative, just abstractions.</div></div><div class="thread_post"><div class="thread_post_header"><b>… </b><a name="15628357"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=christian"> christian </a>  :  3/12/2022  11:39 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628357">link</a>   </div></div><div class="thread_post_body">I’m surprised the Giants didn’t agree to a team friendly extension. Say he proves it — now the Giants either lose him or pay market.<br/>
<br/>
If they lose him, best case they get a comp in the 100s. But not likely, as the Giants will presumably be big players in UFA next offseason.<br/>
<br/>
I fully expect the Giants to make significant changes to both Bradberry’s and Ryan’s contracts by the end of the week, and the Giants to be players in the mid-range UFA market. So I’m not convinced 2.5M is as material ultimately as it feels today.<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: … </b><a name="15628365"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BigBlueShock"> BigBlueShock </a>  :  3/12/2022  11:50 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628365">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628357" target="_blank">15628357</a> christian said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I’m surprised the Giants didn’t agree to a team friendly extension. Say he proves it — now the Giants either lose him or pay market.<br/>
<br/>
If they lose him, best case they get a comp in the 100s. But not likely, as the Giants will presumably be big players in UFA next offseason.<br/>
<br/>
I fully expect the Giants to make significant changes to both Bradberry’s and Ryan’s contracts by the end of the week, and the Giants to be players in the mid-range UFA market. So I’m not convinced 2.5M is as material ultimately as it feels today.<br/>
 </td>
                                </tr>
                           </tbody></table><br/>
Martinez has a say in that scenario too and I don’t see why he would accept that. He’s going to want one more pay day as long as he proves he’s healthy and productive this season</div></div><div class="thread_post"><div class="thread_post_header"><b>I&#39;ve been impressed with how Schoen  </b><a name="15628367"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dave+on+the+UWS"> Dave on the UWS </a>  :  3/12/2022  11:52 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628367">link</a>   </div></div><div class="thread_post_body">has handled the finances so far in the moves made. They analyzed what would be the best financial outcome for the cap this year AND next year, and negotiated from that standpoint. In the end, they got what they were asking of Shep and Martinez, and are now under the cap, having ADDED a decent OL already. My thoughts at this point is we finally have management here that knows what its doing. That bodes well as we go forward.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: … </b><a name="15628377"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  :  3/12/2022  11:59 am   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628377">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628357" target="_blank">15628357</a> christian said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I’m surprised the Giants didn’t agree to a team friendly extension. Say he proves it — now the Giants either lose him or pay market.<br/>
<br/>
If they lose him, best case they get a comp in the 100s. But not likely, as the Giants will presumably be big players in UFA next offseason.<br/>
<br/>
I fully expect the Giants to make significant changes to both Bradberry’s and Ryan’s contracts by the end of the week, and the Giants to be players in the mid-range UFA market. So I’m not convinced 2.5M is as material ultimately as it feels today.<br/>
 </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I agree. I kind of think if you make the decision that Martinez is a piece you want, which they apparently did, the better use of leverage was a team friendly 1 year extension (that would have still cut his pay but given the team future options). <br/>
<br/>
that likely would have cost them some actual guaranteed money against the future (signing bonus) and added risk to the lotto ticket, so i get why they didn&#39;t. but i think that risk would have been minimal. ex. a 4m signing bonus with 1 extra year of control = 2m of future dead money risk.<br/>
<br/>
it seems they viewed it as better to have no future risk, with a willingness to pay more in the future if he performs well. or to your point if he commands a bigger $ and walks there&#39;s a comp pick consideration. but i tend to agree with u that the cost of getting a team friendly extra year may have been worth the risk. it&#39;s also possible martinez didn&#39;t care about a few million right now and prioritized the upside of max&#39;ing his market value for what will likely be his last chance to get a multi-year deal in FA next year.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: … </b><a name="15628387"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=christian"> christian </a>  :  3/12/2022  12:05 pm   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628387">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628365" target="_blank">15628365</a> BigBlueShock said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">Martinez has a say in that scenario too and I don’t see why he would accept that. He’s going to want one more pay day as long as he proves he’s healthy and productive this season </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Sure, but with little leverage I am surprised the Giants couldn’t get a year of additional control from Martinez.<br/>
<br/>
If the Giants gave him a restructure bonus of say 5M, and a roster bonus next year that becomes guaranteed if he hits incentives this year, I bet he would take that. <br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>… </b><a name="15628388"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=christian"> christian </a>  :  3/12/2022  12:06 pm   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628388">link</a>   </div></div><div class="thread_post_body">Or exactly what Eric just said : )</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: actually Schoen/Daboll chose to preserve the deck chairs (not me) </b><a name="15628392"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=NYGgolfer"> NYGgolfer </a>  :  3/12/2022  12:08 pm   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628392">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628354" target="_blank">15628354</a> Eric on Li said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15628347 NYGgolfer said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
<br/>
I wouldn&#39;t worry about it at all. Get as many picks as you can with little risk via treades, cut players you don&#39;t see as core and can&#39;t trade or that free up dollars.<br/>
<br/>
Find new players. And if you are good at it, they will be expensive so free up every dollar.<br/>
<br/>
The Giants have already proven themselves to be the Titantic.  You are the one that wants to preserve two broken down chairs on it because you think they will accrete value, not me. <br/>
                                <br/>
                           <br/>
<br/>
i see the argument for their decisions - and since they are the ones tasked with &#34;finding the new players&#34; as you say, and it&#39;s entirely to their own personal/occupational benefit to do so i assume they didn&#39;t make these moves in lieu of better alternatives. <br/>
<br/>
you are the one who disagrees with them but cant name any actual alternative, just abstractions. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
No need to be a smart-ass with your abstract nonsense. Don&#39;t think your hypothesis on picks and probability %s gets you a medal in all the various ways to think through this and where people place importance.<br/>
<br/>
And I don&#39;t need to name new players to make the point how a prudent rebuild could be orchestrated. Just as I hope don&#39;t want to take the position that better players cannot be had almost everywhere on this current Giants roster, whethe r that be this year or 2023 or even later. Besides my alternative is too shed the non-value players, obtain picks and/or every dollar of cap space you can and start rebuilding it all with a different mindset.  Some with lower risk quality knowns and good bets and maybe even some with higher risk but younger unknowns as long as injuries aren&#39;t a factor.<br/>
<br/>
Investing in many (not all) existing players that are declining, injured knowns is a waste of time and money in rebuilding this. They can obviously still be successful in doing it, but should stay as efficient as possible to shorten the timeline to improvement.<br/>
<br/>
You can have the last word if you need it.</div></div><div class="thread_post"><div class="thread_post_header"><b>neither of us have the last word </b><a name="15628400"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  :  3/12/2022  12:13 pm   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628400">link</a>   </div></div><div class="thread_post_body">Schoen and Daboll did and they chose to keep Martinez/Shepard. <br/>
<br/>
we react to that and either see their viewpoint or not.</div></div><div class="thread_post"><div class="thread_post_header"><b>Schoen loves DG players </b><a name="15628423"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Spiciest+Memelord"> Spiciest Memelord </a>  :  3/12/2022  12:53 pm   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628423">link</a>   </div></div><div class="thread_post_body">more than DG.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: … </b><a name="15628432"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=ColHowPepper"> ColHowPepper </a>  :  3/12/2022  1:10 pm   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628432">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628377" target="_blank">15628377</a> Eric on Li said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15628357 christian said:....If they lose him, best case they get a comp in the 100s. But not likely, as the Giants will presumably be big players in UFA next offseason.<br/>
<br/>
I fully expect the Giants to make significant changes to both Bradberry’s and Ryan’s contracts by the end of the week, and the Giants to be players in the mid-range UFA market. So I’m not convinced 2.5M is as material ultimately as it feels today.///////<br/>
                                       <br/>
<span class="bold">it seems they viewed it as better to have no future risk, with a willingness to pay more in the future</span> if he performs well. or to your point if he commands a bigger $ and walks there&#39;s a comp pick consideration. but i tend to agree with u that the cost of getting a team friendly extra year may have been worth the risk....</td>
                                </tr>
                           </tbody></table><br/>
<br/>
Great reading the exchanges between you two, drilling down deeper than I ever would on my own. thanks<br/>
<br/>
I think that Eric&#39;s language that I bolded to me defines what I believe must be the Schoen/Daboll big picture overview: wipe as much of the dreck and cap sinkholes that Gettleman left behind in order to set a new course as soon as practically possible: i.e., &#39;practically&#39; meaning the team has to start the &#39;22 season with a 53 man roster, in theory most of them capable of playing at something approximating NFL caliber. To christian&#39;s point on Bradberry/Ryan, I wonder if our new FO was as dismayed by the latter&#39;s mailing it in last part of the season as I was.</div></div><div class="thread_post"><div class="thread_post_header"><b>chp i think christian is right that those 2 will be next and soon </b><a name="15628463"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  :  3/12/2022  1:58 pm   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628463">link</a>   </div></div><div class="thread_post_body">i don&#39;t think anyone knows the exact specifics but both have guarantees coming due next week. <br/>
<br/>
if the nyg cut logan ryan they may not save much $, but he could lose several million. so they have more leverage there than people realize right now. <br/>
<br/>
they could also in theory trade him in a cap dump to a team that has a lot of cap room, even if that team doesn&#39;t want to keep him they can just cut him. if a team with cap room wants slayton, maybe the cost of that is taking on ryan&#39;s contract (and then cutting him)?<br/>
<br/>
otc says they will save $6.3m by trading him now, or 9.25m by trading him post-june 1st with just 2m in dead money (though the team taking him on would be on the hook for money so they&#39;d need a bigger inducement to get him). so while it&#39;s a long shot if Ryan survives now there&#39;s always a chance he&#39;s gone later to create room for the draft class.<br/>
<br/>
that one will be interesting to watch bc the limited info re: his guarantees this year means anything could happen and the beats don&#39;t seem to have any info.</div></div><div class="thread_post"><div class="thread_post_header"><b>Ryan ^ </b><a name="15628500"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=ColHowPepper"> ColHowPepper </a>  :  3/12/2022  2:28 pm   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628500">link</a>   </div></div><div class="thread_post_body">Yes, that intrigues, and you made a similar comment on YANKEES28&#39;s thread.<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">for Ryan I expect a pay cut. Yes there may not be a ton of cap savings to leverage if he were to get released, <span class="bold">but there is a real cash loss for Ryan if they cut him</span>. It is probably in his interest to take a base salary reduction of say 3-5m from 9.25m to 5m or so because that&#39;s still more than he is likely to get if he goes to the open market.</td>
                                </tr>
                           </tbody></table><br/>
<br/>
I&#39;m confused by the cash mechanics/balance sheet aspect of this, because as you say above any team trading him would have to take on his contractual salary obligation. It&#39;s likely that another team assesses him the same as Schoen does, not worth nearly that kind of money. But if the Giants only realize a small cap savings by releasing him as vs a salary cut, where the savings would be greater, why is the cap savings attributable to an outright cut not at least equivalent to an agreed salary reduction? As you say, he stands to have a big cash loss if he is cut. Why doesn&#39;t that cash reality translate to cap reduction reality?<br/>
<br/>
Is it that the latter (agreed reduction) in effect voids the existing salary commitment, wipes it clean? Obviously it cannot be guaranteed dollars. Murky the way these contracts can sap cap dollars, which become fictitious if the two sides agree anew..<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Ryan ^ </b><a name="15628508"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  :  3/12/2022  2:39 pm   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628508">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628500" target="_blank">15628500</a> ColHowPepper said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Yes, that intrigues, and you made a similar comment on YANKEES28&#39;s thread.<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                    for Ryan I expect a pay cut. Yes there may not be a ton of cap savings to leverage if he were to get released, but there is a real cash loss for Ryan if they cut him. It is probably in his interest to take a base salary reduction of say 3-5m from 9.25m to 5m or so because that&#39;s still more than he is likely to get if he goes to the open market.<br/>
                                <br/>
                           <br/>
<br/>
I&#39;m confused by the cash mechanics/balance sheet aspect of this, because as you say above any team trading him would have to take on his contractual salary obligation. It&#39;s likely that another team assesses him the same as Schoen does, not worth nearly that kind of money. But if the Giants only realize a small cap savings by releasing him as vs a salary cut, where the savings would be greater, why is the cap savings attributable to an outright cut not at least equivalent to an agreed salary reduction? As you say, he stands to have a big cash loss if he is cut. Why doesn&#39;t that cash reality translate to cap reduction reality?<br/>
<br/>
Is it that the latter (agreed reduction) in effect voids the existing salary commitment, wipes it clean? Obviously it cannot be guaranteed dollars. Murky the way these contracts can sap cap dollars, which become fictitious if the two sides agree anew.. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
You are correct there is likely a way to manipulate his cap hit down since the prorated signing bonus isn’t that high, the devil lies in these unknown details (this is from otc’s contract notes):<br/>
<br/>
Contract Notes<br/>
Logan Ryan signed a 3 year extension with the New York Giants on December 25, 2020. Details courtesy of Dan Duggan of The Athletic. Ryan&#39;s 3 year extension is valued at $30 million with $11.5 million fully guaranteed at signing, and additional $8.5 million injury guarantee in 2022. Ryan&#39;s 2020 cash increases by $6 million and cap charge increases by $1.5 due to the $6 million signing bonus.   <span class="bold">  Details are unknown if the 2022 injury guarantee vests into a full guarantee or not. </span></div></div><div class="thread_post"><div class="thread_post_header"><b>bizzarro world </b><a name="15628514"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=ColHowPepper"> ColHowPepper </a>  :  3/12/2022  2:49 pm   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628514">link</a>   </div></div><div class="thread_post_body">Even more than his shoddy drafting, Gettleman&#39;s FA signings, as often noted on the board, the injury prone history of the guys he signed, the dubious values assigned to these players in the negotiated contracts, as well as contract structures, was ownership oblivious to repeated GM malpractice afoot here? And in tandem with the obvious lack of improvement on the field...quite extraordinary.</div></div><div class="thread_post"><div class="thread_post_header"><b>It&#39;s ALL about the money ... </b><a name="15628555"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Manny+in+CA"> Manny in CA </a>  :  3/12/2022  3:53 pm   : <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1#15628555">link</a>   </div></div><div class="thread_post_body"><br/>
With Martinez ^&amp; Shep. <br/>
<br/>
Pay them and put them on the shelf, thank them for their dedication, then focus on on giving the guys who are now here and the new the experience they need.</div></div><div style="margin: 10 10 20 50"><span class="top_pages">Pages:  <a href="index.php?mode=2&amp;thread=620051&amp;thread_page=1">1</a>  <a href="index.php?mode=2&amp;thread=620051&amp;thread_page=2">2</a>  <b style="background: darkred;padding: 2px 5px 2px 5px;">3</b>  <a href="index.php?mode=2&amp;thread=620051&amp;thread_page=2">&lt;&lt;Prev </a>| <a href="index.php?mode=2&amp;thread=620051&amp;show_all=1" title="">Show All</a> | </span></div>
<a name="END"></a><a href="index.php"></a><div style="padding-top:25px; padding-bottom:20px;"><a href="index.php"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"/></a></div></div>
<div class="thread_sidebar_2">

<!-- Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-102">
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Corner Forum - Lower 300x250 -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1566320450447229" data-ad-slot="4189314539" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->

</div>

</div>




<div class="footer">


<p style="width:450px;float:left;padding:10px;"><b>Part of the USA Today Sports Media Group</b><br/>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</p>
<p style="width:400px;float:right; text-align:right;padding:10px;">
All contents (unless otherwise specified) copyright ©  1995 - 2021<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br/> <br/><strong>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Solutions</a></strong>
</p>
<br clear="all"/>
 
</div>




<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->



<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=1&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=1&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-1");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=1&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script></body></html>