<!DOCTYPE html><html lang="en"><head><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
if(typeof isOrig==='undefined'){isOrig=false;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){if((impId!=="0"||isOrig===true)&&adUnit!==""){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}}
function AddPixelById(impFullId,pixelData,isOrig,revenue){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];var pix={type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig};if(typeof revenue!=='undefined'){pix.revenue=revenue;}
pixels.push(pix);}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}});}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false;}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-1&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-1&cb=4', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-1&cb=5', false, [], true, false, true, false);</script>
<title>Peter Schrager to share &#34;what he is hearing&#34; | Big Blue Interactive </title>

<meta http-equiv="Pragma" content="no-cache"/>
<meta http-equiv="Expires" content="-1"/>

<meta name="keywords" content="ndglbqfkxx"/>

<meta name="description" content="About the draft coming up after the break. I will try to transcribe as much as possible."/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="website"/>
<meta property="og:description" content="About the draft coming up after the break. I will try to transcribe as much as possible."/> 
<meta property="og:title" content="Peter Schrager to share " what="" he="" is="" hearing""=""/> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif"/> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css?v=20200217"/>

<link rel="stylesheet" type="text/css" href="anylink.css"/>


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}


div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" alt="for display only">

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type="text/javascript">
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type="text/javascript" src="https://img.bnqt.com/lib/js/sdpdfphelper.js"></script>
<script type="text/javascript">
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>


<!-- End DFP SETUP -->  

<!-- End USA Today Code -->




<script type="text/javascript">var ezouid = "1";</script><base href="https://corner.bigblueinteractive.com/index.php?mode=2&thread=621267&show_all=1"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"domain_test_group":20210306,"engaged_time_visit":0,"ezcache_level":0,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"9615f76b-5a8c-4485-4aa0-177e4e7ab8dd","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":140006,"response_time_orig":132,"serverid":"35.170.198.239:21841","state":"VA","t_epoch":1650321306,"template_id":126,"time_on_site_visit":0,"url":"https://corner.bigblueinteractive.com/index.php?mode=2\u0026thread=621267\u0026show_all=1","user_id":0,"word_count":11063,"worst_bad_word_level":3};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["9615f76b-5a8c-4485-4aa0-177e4e7ab8dd", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>


<body>




<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tbody><tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"/></a> <img src="images/xpete.gif" alt="The Corner Forum"/>

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic --> 


<!-- Nov 2019 Leaderboard -->

<!-- Ezoic - Forum Leaderboard (USAT) - top_of_page -->
<div id="ezoic-pub-ad-placeholder-118">
<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->
<div id="usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general');
         });
     </script>
</div>
</div>
<!-- End Ezoic - Forum Leaderboard (USAT) - top_of_page -->



</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://www.amazon.com/?_encoding=UTF8&amp;camp=1789&amp;creative=9325&amp;linkCode=ur2&amp;tag=bigblueintera-20">Amazon.com</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW">Standings (NFL.com)</a>
<a href="https://www.giants.com/team/stats/" target="_NEW">Statistics (Giants.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/">Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</tbody></table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;home_view_menu&#39;)">Home</a>  
</li><li><a href="http://corner.bigblueinteractive.com/index.php" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;forum_view_menu&#39;)">Corner Forum</a>
</li><li><a href="http://corner.bigblueinteractive.com/index.php" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;gameday_view_menu&#39;)">Gameday</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_view_menu&#39;)">Team</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_building_view_menu&#39;)">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info & History</a> -->
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_info_view_menu&#39;)">Giants Info &amp; History</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;infolinks_view_menu&#39;)">Info/Links</a>
</li><li><a href="/index.php?mode=10" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;login_menu&#39;)">Log In</a>
</li></ul>

</div><div id="infoline"> </div>

<a name="END"></a><a href="index.php"></a><div style="padding-top:20px; padding-bottom:25px;"><a href="index.php"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"/></a></div><div class="thread_container"><div class="thread_left"><div class="thread_body"><div class="thread_main"><div class="thread_post_header">  <h1 style="font-size:18px;">Peter Schrager to share &#34;what he is hearing&#34; </h1><div class="thread_info"><a href="index.php?mode=5&amp;handle=jvm52106"> jvm52106 </a>  : 7:14 am</div></div><div class="thread_post_body"> About the draft coming up after the break. I will try to transcribe as much as possible. </div></div></div></div><div class="thread_right"><div id="ad_side_box">


<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id="usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103,22280986322/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general');
         });
     </script>
</div>


</div></div><div class="thread_comment_container"><div class="thread_post"><div class="thread_post_header"><b>The Draft Whisperer </b><a name="15669271"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=jvm52106"> jvm52106 </a>  : 7:21 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669271">link</a>   </div></div><div class="thread_post_body">What he is hearing:<br/>
<br/>
1) first overall, usually a QB, Jags still unsure who they are taking but media thinks Hutchinson but Jags are not sure yet who they are taking as Travon Walker is neck and neck with Hutchinson. Balke tends to take physical specimen over pure production.<br/>
<br/>
2) Big meeting Friday happened with Thibs and Jets and according to reports the meeting went very well. Jets need to know he isn&#39;t a new me me guy. Thibs is a serious option and Jets about Pass Rush. <br/>
<br/>
3) Everyone talks Sauce and Stingley but by all reports Horn and Surtain we&#39;re better prospects than both of them. Top of draft 2022 not nearly as strong as top of 2021 draft.</div></div><div class="thread_post"><div class="thread_post_header"><b>Brandt asked Schrager </b><a name="15669273"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=jvm52106"> jvm52106 </a>  : 7:26 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669273">link</a>   </div></div><div class="thread_post_body">About why Thibs wouldn&#39;t be in play at number 1? Schrags says since it isn&#39;t set yet Jags could go there but he hasn&#39;t heard a thing about This that high.<br/>
<br/>
Brandt thinks Thibs is going to be awesome and that just a few bad sound bites are what is holding him back.<br/>
<br/>
Schrager said Ikey could be a Jags option but his top 3 for jags- Walker /Hutchinson and Ikey.<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>Stingley is better than all of those CBs </b><a name="15669274"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Doubledeuce22"> Doubledeuce22 </a>  : 7:26 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669274">link</a>   </div></div><div class="thread_post_body">If medical check out which who knows at this point.</div></div><div class="thread_post"><div class="thread_post_header"><b>Do we hear that </b><a name="15669276"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=giantBCP"> giantBCP </a>  : 7:30 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669276">link</a>   </div></div><div class="thread_post_body">this year’s draft is not as strong as last year’s draft every year? Seems like it. <br/>
<br/>
I think that making a statement like that makes it seem like you’re knowledgeable without actually saying anything of substance.</div></div><div class="thread_post"><div class="thread_post_header"><b>Not according to Sy </b><a name="15669279"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=ZogZerg"> ZogZerg </a>  : 7:38 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669279">link</a>   </div></div><div class="thread_post_body"><table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"><br/>
 Everyone talks Sauce and Stingley but by all reports Horn and Surtain we&#39;re better prospects than both of them. Top of draft 2022 not nearly as strong as top of 2021 draft.<br/>
</td>
                                </tr>
                           </tbody></table><br/>
<br/>
He has BOTH Sauce and Stingley rated higher than both of the guys from last year.</div></div><div class="thread_post"><div class="thread_post_header"><b>Schrager is hearing this from whom? </b><a name="15669280"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=George+from+PA"> George from PA </a>  : 7:44 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669280">link</a>   </div></div><div class="thread_post_body">I doubt he is hearing directly from teams unless it&#39;s dis-i formation</div></div><div class="thread_post"><div class="thread_post_header"><b>At the time </b><a name="15669283"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=giantBCP"> giantBCP </a>  : 7:45 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669283">link</a>   </div></div><div class="thread_post_body">everyone said that if Stingley was draft eligible, he was a better prospect than Horn and Surtain. <br/>
<br/>
“ The best cornerback in college football is neither Surtain nor Horn. It’s Derek Stingley Jr. out of LSU. Unfortunately, he’s not in this draft class. Other than him, Surtain has been the best cornerback in college football.”<br/><br/><a href="https://boltbeat.com/2021/04/12/la-chargers-draft-patrick-surtain-jaycee-horn/4/"> Link </a> - (<a href="https://boltbeat.com/2021/04/12/la-chargers-draft-patrick-surtain-jaycee-horn/4/" target="_NEW"> New Window </a>)</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Do we hear that </b><a name="15669293"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=RHPeel"> RHPeel </a>  : 8:08 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669293">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669276" target="_blank">15669276</a> giantBCP said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> this year’s draft is not as strong as last year’s draft every year? Seems like it. <br/>
<br/>
I think that making a statement like that makes it seem like you’re knowledgeable without actually saying anything of substance. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Agreed.<br/>
<br/>
I really don&#39;t think that either of the corner prospects from last year was a better prospect than Gardner, and there&#39;s absolutely no chance that any of them have the upside of Stingley.</div></div><div class="thread_post"><div class="thread_post_header"><b>You could make a case for Surtain  </b><a name="15669294"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=JoeyBigBlue"> JoeyBigBlue </a>  : 8:09 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669294">link</a>   </div></div><div class="thread_post_body">But there is no way in hell that Jaycee Horn was a better prospect than Sauce Gardner.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Do we hear that </b><a name="15669298"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=jvm52106"> jvm52106 </a>  : 8:18 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669298">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669276" target="_blank">15669276</a> giantBCP said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> this year’s draft is not as strong as last year’s draft every year? Seems like it. <br/>
<br/>
I think that making a statement like that makes it seem like you’re knowledgeable without actually saying anything of substance. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
That isn&#39;t what I posted. The top half isn&#39;t as strong. People like Slater, parsons, Surtain, Smith, Waddle all would be ahead of anyone in this years draft (by things Schrager is hearing from Scouts and teams.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Stingley is better than all of those CBs </b><a name="15669299"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=jvm52106"> jvm52106 </a>  : 8:19 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669299">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669274" target="_blank">15669274</a> Doubledeuce22 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> If medical check out which who knows at this point. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
That is an opinion only. The guy hasn&#39;t done anything since 2019.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: You could make a case for Surtain  </b><a name="15669301"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=jvm52106"> jvm52106 </a>  : 8:20 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669301">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669294" target="_blank">15669294</a> JoeyBigBlue said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> But there is no way in hell that Jaycee Horn was a better prospect than Sauce Gardner. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
The question on Sauce is tackling apparently.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Schrager is hearing this from whom? </b><a name="15669304"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=jvm52106"> jvm52106 </a>  : 8:25 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669304">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669280" target="_blank">15669280</a> George from PA said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I doubt he is hearing directly from teams unless it&#39;s dis-i formation </td>
                                </tr>
                           </tbody></table><br/>
<br/>
He has some serious connections with a lot of coaches and GM&#39;s. It is really interesting to listen to him and you can tell when he is &#34;hinting<br/>
&#34; at knowing more than he can share. <br/>
<br/>
Like most things it could be dis-information but since it comes in as more general info, I think it truly is what he is hearing (collectively).<br/>
<br/>
The biggest take away I got this morning is there is NO consensus on #1 WR, no consensus on #1 QB and that it is quite possible NO QB&#39;s are taken until mid point in RD 1 (though Detroit could blink and snag a QB at 2). Willis is an enigma and could go in RD 1 or even slide to 2 as none of the QB&#39;s have teams excited to the point of giddy- QB selections early will be made more out of desperation that opportunity!</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Do we hear that </b><a name="15669306"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=k2tampa"> k2tampa </a>  : 8:30 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669306">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669276" target="_blank">15669276</a> giantBCP said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> this year’s draft is not as strong as last year’s draft every year? Seems like it. <br/>
<br/>
I think that making a statement like that makes it seem like you’re knowledgeable without actually saying anything of substance. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Note that he said the TOP of the draft isn&#39;t as strong as last year. Virtually all evaluators say there is more NFL talent in the draft than last year. But he is right. You would easily win an argument that the top 7 picks last year would all be within the top 10 this year - who doesn&#39;t make the top 10 among the three QBs, Pitts, Waddle, Chase and Sewell, and that doesn&#39;t even include 8-12 Horn, Surtain, Smith, Fields and Parsons. Those 12 might have all been in the top 15 this year.</div></div><div class="thread_post"><div class="thread_post_header"><b>no chance those 7-10 players </b><a name="15669314"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  : 8:38 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669314">link</a>   </div></div><div class="thread_post_body">just bump everyone this year back 10+ slots. Waddle was a reach (which many called at that time), Sewell &#34;fell&#34; and it looks like for good reason. Pitts still goes high but we all know taking the TE 4 was dumb.<br/>
<br/>
We also have revisionist history on Parsons falling due to character concerns (KT?). Then the flawed QB class where Fields looked terrible as a rookie, Wilson was terrible as a rookie, and prized QB Lawrence looking terrible as well.<br/>
<br/>
We don&#39;t have the #1 pick so not picking in a blue chip draft doesn&#39;t matter to me.</div></div><div class="thread_post"><div class="thread_post_header"><b>Ive felt all along that Thibs </b><a name="15669318"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=blueblood"> blueblood </a>  : 8:42 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669318">link</a>   </div></div><div class="thread_post_body">and possibly NONE of the pass rushers reach the Giants. Ive figured it was going to be an OT and the a CB if they stay put for a while.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: no chance those 7-10 players </b><a name="15669328"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=KDavies"> KDavies </a>  : 8:51 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669328">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669314" target="_blank">15669314</a> UConn4523 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> just bump everyone this year back 10+ slots. Waddle was a reach (which many called at that time), Sewell &#34;fell&#34; and it looks like for good reason. Pitts still goes high but we all know taking the TE 4 was dumb.<br/>
<br/>
We also have revisionist history on Parsons falling due to character concerns (KT?). Then the flawed QB class where Fields looked terrible as a rookie, Wilson was terrible as a rookie, and prized QB Lawrence looking terrible as well.<br/>
<br/>
We don&#39;t have the #1 pick so not picking in a blue chip draft doesn&#39;t matter to me. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Agreed.  This seems like playing the results on Slater/Parsons.</div></div><div class="thread_post"><div class="thread_post_header"><b>IMO this class is getting a bad wrap </b><a name="15669335"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  : 8:57 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669335">link</a>   </div></div><div class="thread_post_body">because there isn&#39;t a Trevor Lawrence or Joe Burrow in it. Everything else is right around the same give/take. The only non-QB from the last couple drafts that I think is head and shoulders better than the prospects this year is Jamar Chase.</div></div><div class="thread_post"><div class="thread_post_header"><b>It’s good  </b><a name="15669348"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Giants"> Giants </a>  : 9:16 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669348">link</a>   </div></div><div class="thread_post_body">To see some here don’t buy into every word from the talking heads. Many say the same thing Schrager says. Doesn’t mean it’s 100% true. Many of these GM and scouts are going to put out disinformation. They all have their jobs to protect. The only thing I want is what every Giants fan wants. A great draft for the Giants</div></div><div class="thread_post"><div class="thread_post_header"><b>This class isn&#39;t getting a bad rap... </b><a name="15669352"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  : 9:23 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669352">link</a>   </div></div><div class="thread_post_body">It&#39;s been praised for the amount of quantity, particularly at Edge, WR, and corner. I know the BPA Lords detest the word need, but if you need more talent at any of the aforementioned positions those aisles are full this year.<br/>
<br/>
The ding in this class is the uncertainty at QB. That is fair, but it could be overstated because that position is so difficult to project.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: IMO this class is getting a bad wrap </b><a name="15669354"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=sb+from+NYT+Forum"> sb from NYT Forum </a>  : 9:27 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669354">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669335" target="_blank">15669335</a> UConn4523 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> because there isn&#39;t a Trevor Lawrence or Joe Burrow in it. Everything else is right around the same give/take. The only non-QB from the last couple drafts that I think is head and shoulders better than the prospects this year is Jamar Chase. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Not disagreeing that this class might be getting undersold, but I think the idea that the top of the 2021 class is better than 2022 might have something to do with the amount of incredibly high performances by the 2021 rookies:<br/>
<br/>
Chase - 2nd team All Pro<br/>
Waddle - 100 yards and 6 TDs with a limited QB<br/>
Smith - 900 yards and 5 TDs with a bad QB <br/>
Parsons - 1st Team All Pro<br/>
Slater - 2nd Team All Pro<br/>
<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>sure, players have had really good seasons </b><a name="15669358"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  : 9:34 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669358">link</a>   </div></div><div class="thread_post_body">although Waddle/Smith weren&#39;t impact players, particularly Waddle where much of his stats were fairly empty. They were no where near Chase, or Jefferson before him.<br/>
<br/>
As for QB it wouldn&#39;t shock me at all if a couple of the guys from the 2022 draft end up being better than Wilson/Lance/Fields. Jones is a bit of a wildcard since he&#39;s with the Pats and they will do their best to hide his warts.</div></div><div class="thread_post"><div class="thread_post_header"><b>2021 Draft was very strong at top end because of so many </b><a name="15669359"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=chick310"> chick310 </a>  : 9:34 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669359">link</a>   </div></div><div class="thread_post_body">talented offensive players and a few QBs.  But it lacked top end defensive prospects.<br/>
<br/>
This 2022 draft doesn&#39;t have same level of offensive playmakers but certainly many more defensive ones.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Schrager is hearing this from whom? </b><a name="15669362"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=nochance"> nochance </a>  : 9:39 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669362">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669280" target="_blank">15669280</a> George from PA said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I doubt he is hearing directly from teams unless it&#39;s dis-i formation </td>
                                </tr>
                           </tbody></table><br/>
<br/>
<br/>
At this time of year it is all disinformation</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Schrager is hearing this from whom? </b><a name="15669371"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=GFAN52"> GFAN52 </a>  : 9:46 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669371">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669362" target="_blank">15669362</a> nochance said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669280 George from PA said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     I doubt he is hearing directly from teams unless it&#39;s dis-i formation <br/>
                                <br/>
                           <br/>
<br/>
<br/>
At this time of year it is all disinformation </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Exactly.  Everyone in the media is just throwing enough darts on the wall hoping something hits.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: sure, players have had really good seasons </b><a name="15669377"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=sb+from+NYT+Forum"> sb from NYT Forum </a>  : 9:56 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669377">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669358" target="_blank">15669358</a> UConn4523 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> although Waddle/Smith weren&#39;t impact players, particularly Waddle where much of his stats were fairly empty. They were no where near Chase, or Jefferson before him.<br/>
<br/>
As for QB it wouldn&#39;t shock me at all if a couple of the guys from the 2022 draft end up being better than Wilson/Lance/Fields. Jones is a bit of a wildcard since he&#39;s with the Pats and they will do their best to hide his warts. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Again, I wasn&#39;t arguing with you, I was just pointing out that the talking heads will look at the players I mentioned as the reason 2021 was maybe better, and not just the lack of top QB prospects.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Do we hear that </b><a name="15669383"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 10:04 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669383">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669298" target="_blank">15669298</a> jvm52106 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669276 giantBCP said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     this year’s draft is not as strong as last year’s draft every year? Seems like it. <br/>
<br/>
I think that making a statement like that makes it seem like you’re knowledgeable without actually saying anything of substance. <br/>
                                <br/>
                           <br/>
<br/>
That isn&#39;t what I posted. The top half isn&#39;t as strong. People like Slater, parsons, Surtain, Smith, Waddle all would be ahead of anyone in this years draft (by things Schrager is hearing from Scouts and teams. </td>
                                </tr>
                           </tbody></table><br/>
There&#39;s some bias baked into that, though. Slater had a great rookie year, so that&#39;s absolutely being factored in. If Slater was more highly regarded than the top OT prospects this year, he would have been drafted earlier than 13th overall. Part of that, of course is that the QB and WR prospects were pushing other top prospects down last year, but you could say the same (to a slightly lesser degree) for this year&#39;s EDGE class.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: You could make a case for Surtain  </b><a name="15669387"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=allstarjim"> allstarjim </a>  : 10:10 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669387">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669301" target="_blank">15669301</a> jvm52106 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669294 JoeyBigBlue said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     But there is no way in hell that Jaycee Horn was a better prospect than Sauce Gardner. <br/>
                                <br/>
                           <br/>
<br/>
The question on Sauce is tackling apparently. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Who is questioning that?  Because they haven&#39;t seen him play.  Question Stingley on that, sure.  But Sauce?  GTFO.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: You could make a case for Surtain  </b><a name="15669390"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=allstarjim"> allstarjim </a>  : 10:14 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669390">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669301" target="_blank">15669301</a> jvm52106 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669294 JoeyBigBlue said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     But there is no way in hell that Jaycee Horn was a better prospect than Sauce Gardner. <br/>
                                <br/>
                           <br/>
<br/>
The question on Sauce is tackling apparently. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Look at this.<br/>
<br/>
<a href="https://youtu.be/GPIAlV39ZsI?t=179" target="_blank">https://youtu.be/GPIAlV39ZsI?t=179</a></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: sure, players have had really good seasons </b><a name="15669392"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Section331"> Section331 </a>  : 10:16 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669392">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669358" target="_blank">15669358</a> UConn4523 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"><br/>
As for QB it wouldn&#39;t shock me at all if a couple of the guys from the 2022 draft end up being better than Wilson/Lance/Fields. Jones is a bit of a wildcard since he&#39;s with the Pats and they will do their best to hide his warts. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
This is a good point, put Jones on JAX and see how he does. Lawrence will be the best QB in that class. Look at what he had to deal with last year. We all knew JAX had talent limitations, but then they went out and hired a complete boob as a HC. Talk about setting your blue chip QB up for failure.</div></div><div class="thread_post"><div class="thread_post_header"><b>it seems like a lock 3 or 4 edges are going ahead of NYG  </b><a name="15669396"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  : 10:23 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669396">link</a>   </div></div><div class="thread_post_body">with Ekwonu being the likeliest non-edge. <br/>
<br/>
the Sauce/Surtain/horn thing sounds ridiculous. Horn was a late riser anyway since he opted out of most of 2020 and then had a remarkable combine. even Surtain had some of the bama doubts about how good of a prospect he was, until he had a great combine and put a lot of those fears to rest. <br/>
<br/>
Stingley has the most intangible concerns out of those 4 and the medical alone may knock him off some boards. That&#39;s the biggest question with him relative to the other 3. <br/>
<br/>
Horn/Sauce/Surtain are 3 very comparable CB prospects with size, long arms, a lot of snaps played, and all 3 surprised with 40 times right around 4.4 with good 10 yard splits.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: sure, players have had really good seasons </b><a name="15669398"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  : 10:28 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669398">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669377" target="_blank">15669377</a> sb from NYT Forum said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669358 UConn4523 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     although Waddle/Smith weren&#39;t impact players, particularly Waddle where much of his stats were fairly empty. They were no where near Chase, or Jefferson before him.<br/>
<br/>
As for QB it wouldn&#39;t shock me at all if a couple of the guys from the 2022 draft end up being better than Wilson/Lance/Fields. Jones is a bit of a wildcard since he&#39;s with the Pats and they will do their best to hide his warts. <br/>
                                <br/>
                           <br/>
<br/>
Again, I wasn&#39;t arguing with you, I was just pointing out that the talking heads will look at the players I mentioned as the reason 2021 was maybe better, and not just the lack of top QB prospects. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I hear you, not arguing either. Just think we can do this for most, if not all drafts. I think its &#34;sexy&#34; to make claims about classes year to year and they largely don&#39;t mean much.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: sure, players have had really good seasons </b><a name="15669403"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=allstarjim"> allstarjim </a>  : 10:33 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669403">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669358" target="_blank">15669358</a> UConn4523 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> although Waddle/Smith weren&#39;t impact players, particularly Waddle where much of his stats were fairly empty. They were no where near Chase, or Jefferson before him.<br/>
<br/>
As for QB it wouldn&#39;t shock me at all if a couple of the guys from the 2022 draft end up being better than Wilson/Lance/Fields. Jones is a bit of a wildcard since he&#39;s with the Pats and they will do their best to hide his warts. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
This take is laughable.  Yeah, Waddle&#39;s and Smith&#39;s stats weren&#39;t near Chase&#39;s, because no one&#39;s is.  For a rookie year, Chase&#39;s was Randy Moss-level.  <br/>
<br/>
Chase and Jefferson, that&#39;s a near impossible standard.  And some of that is due to much better QB play in Minnesota and Cincinatti as opposed to Miami and Philly.  <br/>
<br/>
That doesn&#39;t mean Smith and Waddle weren&#39;t impact players, they were.  Waddle with empty stats?  Come on.  He was a mismatch problem from about game 4 IIRC.  I remember a slow start but he was beating good corners, even in the red zone. Waddle is a GREAT player.  No, he&#39;s not as good as Chase or Jefferson, but he&#39;d be the best receiver on the Giants by a wide margin.  There&#39;s a lot of teams he&#39;d be the best receiver on.</div></div><div class="thread_post"><div class="thread_post_header"><b>Starting </b><a name="15669406"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=joeinpa"> joeinpa </a>  : 10:35 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669406">link</a>   </div></div><div class="thread_post_body">to get the feeling more than 1 of the three tackles will be there at 5, and that Cross will be the pick if he s one of them</div></div><div class="thread_post"><div class="thread_post_header"><b>healthy jameson williams is competitive with waddle as a prospect </b><a name="15669410"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  : 10:39 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669410">link</a>   </div></div><div class="thread_post_body">and possibly even better. both were lights out game breakers with toughness at bama. <br/>
<br/>
even with the ACL I buy the hype that jameson williams is in the top 10 because he was just that explosive. he had 11 touchdowns over 30 yards last year. on 79 receptions he averaged 20 ypc, which is near Waddle&#39;s best even though the most receptions he had in a year was 45 (due to injury but still). <br/>
<br/>
the average ACL timeline is 9-11 months so it&#39;s possible he&#39;s back in September/October, and since rookies generally get brought along their rookie year that&#39;s really no big deal. He&#39;s an extra spot on PUP or more likely a short term IR trip so he can practice with the team until he&#39;s 100%.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: sure, players have had really good seasons </b><a name="15669411"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  : 10:39 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669411">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669392" target="_blank">15669392</a> Section331 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669358 UConn4523 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                    <br/>
As for QB it wouldn&#39;t shock me at all if a couple of the guys from the 2022 draft end up being better than Wilson/Lance/Fields. Jones is a bit of a wildcard since he&#39;s with the Pats and they will do their best to hide his warts. <br/>
                                <br/>
                           <br/>
<br/>
This is a good point, put Jones on JAX and see how he does. Lawrence will be the best QB in that class. Look at what he had to deal with last year. We all knew JAX had talent limitations, but then they went out and hired a complete boob as a HC. Talk about setting your blue chip QB up for failure. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Lawrence is getting 2021 erased from his record by most people but i&#39;m not that willing to do that. His accuracy wasn&#39;t there, he turned it over, and didn&#39;t score. He will get the benefit of the doubt since that franchise is/was a mess but its a red flag for me until it isn&#39;t. I would have thought he would have shown something of note as a rookie based on his ability along but it was extremely disappointing.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: sure, players have had really good seasons </b><a name="15669413"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  : 10:41 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669413">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669403" target="_blank">15669403</a> allstarjim said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669358 UConn4523 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     although Waddle/Smith weren&#39;t impact players, particularly Waddle where much of his stats were fairly empty. They were no where near Chase, or Jefferson before him.<br/>
<br/>
As for QB it wouldn&#39;t shock me at all if a couple of the guys from the 2022 draft end up being better than Wilson/Lance/Fields. Jones is a bit of a wildcard since he&#39;s with the Pats and they will do their best to hide his warts. <br/>
                                <br/>
                           <br/>
<br/>
This take is laughable.  Yeah, Waddle&#39;s and Smith&#39;s stats weren&#39;t near Chase&#39;s, because no one&#39;s is.  For a rookie year, Chase&#39;s was Randy Moss-level.  <br/>
<br/>
Chase and Jefferson, that&#39;s a near impossible standard.  And some of that is due to much better QB play in Minnesota and Cincinatti as opposed to Miami and Philly.  <br/>
<br/>
That doesn&#39;t mean Smith and Waddle weren&#39;t impact players, they were.  Waddle with empty stats?  Come on.  He was a mismatch problem from about game 4 IIRC.  I remember a slow start but he was beating good corners, even in the red zone. Waddle is a GREAT player.  No, he&#39;s not as good as Chase or Jefferson, but he&#39;d be the best receiver on the Giants by a wide margin.  There&#39;s a lot of teams he&#39;d be the best receiver on. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
You can call it laughable all you want doesn&#39;t make it true. Waddle ran 5 yard routes and caught the ball. That isn&#39;t what the #6 player taken does. There could be many reasons for that but its what happened and that&#39;s what I&#39;m judging. He was great for fantasy PPR but he wasn&#39;t this dynamic game breaker he was drafted to be. Can certainly still happen but it didn&#39;t in 2021.<br/>
<br/>
Smith had a good rookie year. But nothing top tier, certainly not a performance I&#39;d look back on as a defining player of a draft class.<br/>
<br/>
Nothing at all laughable about that.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Starting </b><a name="15669414"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=RCPhoenix"> RCPhoenix </a>  : 10:42 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669414">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669406" target="_blank">15669406</a> joeinpa said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> to get the feeling more than 1 of the three tackles will be there at 5, and that Cross will be the pick if he s one of them </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I tend to agree that Cross will be the pick at #5, he fits what Daboll wants for an OT when it comes to pass blocking.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: sure, players have had really good seasons </b><a name="15669415"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=RCPhoenix"> RCPhoenix </a>  : 10:48 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669415">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669413" target="_blank">15669413</a> UConn4523 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669403 allstarjim said:<br/>
  <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15669358 UConn4523 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
<br/>
You can call it laughable all you want doesn&#39;t make it true. Waddle ran 5 yard routes and caught the ball. That isn&#39;t what the #6 player taken does. There could be many reasons for that but its what happened and that&#39;s what I&#39;m judging. He was great for fantasy PPR but he wasn&#39;t this dynamic game breaker he was drafted to be. Can certainly still happen but it didn&#39;t in 2021.<br/>
<br/>
Smith had a good rookie year. But nothing top tier, certainly not a performance I&#39;d look back on as a defining player of a draft class.<br/>
<br/>
Nothing at all laughable about that. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I seem to recall Chase also running short routes and catching the ball - the difference between him and Waddle is that several times he took it to the house after that catch. Chase far outperformed Waddle and it&#39;s not close.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: sure, players have had really good seasons </b><a name="15669419"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=allstarjim"> allstarjim </a>  : 10:56 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669419">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669413" target="_blank">15669413</a> UConn4523 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669403 allstarjim said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15669358 UConn4523 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     although Waddle/Smith weren&#39;t impact players, particularly Waddle where much of his stats were fairly empty. They were no where near Chase, or Jefferson before him.<br/>
<br/>
As for QB it wouldn&#39;t shock me at all if a couple of the guys from the 2022 draft end up being better than Wilson/Lance/Fields. Jones is a bit of a wildcard since he&#39;s with the Pats and they will do their best to hide his warts. <br/>
                                <br/>
                           <br/>
<br/>
This take is laughable.  Yeah, Waddle&#39;s and Smith&#39;s stats weren&#39;t near Chase&#39;s, because no one&#39;s is.  For a rookie year, Chase&#39;s was Randy Moss-level.  <br/>
<br/>
Chase and Jefferson, that&#39;s a near impossible standard.  And some of that is due to much better QB play in Minnesota and Cincinatti as opposed to Miami and Philly.  <br/>
<br/>
That doesn&#39;t mean Smith and Waddle weren&#39;t impact players, they were.  Waddle with empty stats?  Come on.  He was a mismatch problem from about game 4 IIRC.  I remember a slow start but he was beating good corners, even in the red zone. Waddle is a GREAT player.  No, he&#39;s not as good as Chase or Jefferson, but he&#39;d be the best receiver on the Giants by a wide margin.  There&#39;s a lot of teams he&#39;d be the best receiver on. <br/>
                                <br/>
                           <br/>
<br/>
You can call it laughable all you want doesn&#39;t make it true. Waddle ran 5 yard routes and caught the ball. That isn&#39;t what the #6 player taken does. There could be many reasons for that but its what happened and that&#39;s what I&#39;m judging. He was great for fantasy PPR but he wasn&#39;t this dynamic game breaker he was drafted to be. Can certainly still happen but it didn&#39;t in 2021.<br/>
<br/>
Smith had a good rookie year. But nothing top tier, certainly not a performance I&#39;d look back on as a defining player of a draft class.<br/>
<br/>
Nothing at all laughable about that. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
QB play, UCONN.  Tua isn&#39;t getting a bunch of balls downfield to Waddle.  The fact that Waddle got a 1000 yards with Tua as his QB is pretty good.  He made plays with the ball in his hands and you can still see the separation he gets in the NFL.  <br/>
<br/>
Same with Smith/Hurts.  I mean, there&#39;s going to be a difference when your QB is throwing the ball 100-150 or so fewer times than say a Kirk Cousins or Joe Burrow, and doesn&#39;t have the ability to make the dynamic throws.<br/>
<br/>
I mean, it really factors in to how much of the field I have to defend as a corner with Hurts/Tua at QB as opposed to a guy like Burrow.  I know I have to defend the WHOLE field against a guy like Burrow.  But I&#39;m not worried about sideline throws from the opposite hash against Tua and Hurts, that&#39;s not going to happen.  <br/>
<br/>
But if you watch Waddle in particular, kid can BALL OUT.  He&#39;s a much better receiver than you&#39;re giving credit for, absolutely a top 5 talent.  He just doesn&#39;t have the right QB to maximize his talent right now.</div></div><div class="thread_post"><div class="thread_post_header"><b>Right </b><a name="15669421"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  : 10:57 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669421">link</a>   </div></div><div class="thread_post_body">my post wasn&#39;t even to shit on Waddle/Smith, they are good players, could be really good. But looking back at 2021 they aren&#39;t guys i&#39;m saying &#34;yes, they would have gone ahead of most of the 2022 class&#34; which was the original point I was contending.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: sure, players have had really good seasons </b><a name="15669423"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=allstarjim"> allstarjim </a>  : 11:02 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669423">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669415" target="_blank">15669415</a> RCPhoenix said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669413 UConn4523 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15669403 allstarjim said:<br/>
  <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15669358 UConn4523 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
<br/>
You can call it laughable all you want doesn&#39;t make it true. Waddle ran 5 yard routes and caught the ball. That isn&#39;t what the #6 player taken does. There could be many reasons for that but its what happened and that&#39;s what I&#39;m judging. He was great for fantasy PPR but he wasn&#39;t this dynamic game breaker he was drafted to be. Can certainly still happen but it didn&#39;t in 2021.<br/>
<br/>
Smith had a good rookie year. But nothing top tier, certainly not a performance I&#39;d look back on as a defining player of a draft class.<br/>
<br/>
Nothing at all laughable about that. <br/>
                                <br/>
                           <br/>
<br/>
I seem to recall Chase also running short routes and catching the ball - the difference between him and Waddle is that several times he took it to the house after that catch. Chase far outperformed Waddle and it&#39;s not close. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Yeah as mentioned, Chase was the #1 receiver in his draft class and he would be the #1 receiver in almost any draft class.  His rookie year was on the Randy Moss level. I don&#39;t know what the point of this comparison is.  Because Chase is amazing doesn&#39;t mean Waddle isn&#39;t great.  Chase is one of the top receivers in the game already.  He&#39;s in the conversation with Davante Adams, Stefon Diggs, DeAndre Hopkins, Cooper Kupp.<br/>
<br/>
In no way does that mean Waddle isn&#39;t a great player.  Waddle is a terrific player.  Dude caught a 100+ balls and over a 1000 yards with noodle arm Tua.  Put him with a Patrick Mahomes he&#39;d probably lead the NFL in receiving yards.  He&#39;d be up there at the top.  Hell, put him with Daniel Jones he&#39;d be top 8.</div></div><div class="thread_post"><div class="thread_post_header"><b>Schrager doesn&#39;t say much here, and I doubt he has any connections </b><a name="15669428"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=PatersonPlank"> PatersonPlank </a>  : 11:04 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669428">link</a>   </div></div><div class="thread_post_body">Just sounds like more speculation to me. I&#39;d rather listen to Kay</div></div><div class="thread_post"><div class="thread_post_header"><b>Wasn’t Tua the QB for Waddle at Alabama? </b><a name="15669431"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=TDTONEY"> TDTONEY </a>  : 11:08 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669431">link</a>   </div></div><div class="thread_post_body">And is now?  Jeudy had no problem with Tua and nor did Waddle.<br/>
<br/>
I’m confused<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>Isn’t it a good thing when your production increases in the NFL? </b><a name="15669434"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=TDTONEY"> TDTONEY </a>  : 11:10 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669434">link</a>   </div></div><div class="thread_post_body">Like Waddles did?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Right </b><a name="15669436"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=allstarjim"> allstarjim </a>  : 11:10 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669436">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669421" target="_blank">15669421</a> UConn4523 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> my post wasn&#39;t even to shit on Waddle/Smith, they are good players, could be really good. But looking back at 2021 they aren&#39;t guys i&#39;m saying &#34;yes, they would have gone ahead of most of the 2022 class&#34; which was the original point I was contending. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Ok right on, bud.  I took it as they are like, really mediocre that didn&#39;t deserve to be drafted anywhere close to where they were.<br/>
<br/>
My bad.  In terms of comparing them to this class, yeah, I think I would drop them both a little with the talent here.  In terms of where they would stack in this receiver class, they&#39;d still be pretty high up there.  I might have Garrett Wilson above them both.  <br/>
<br/>
For that class I had it as Chase, Waddle, then Smith, the same order they went in.  <br/>
<br/>
If I combined both receiver classes (and I&#39;m only doing this for the sake of discussion), I think it&#39;d look something like this:<br/>
<br/>
Chase<br/>
Wilson<br/>
Waddle<br/>
Jameson Williams<br/>
Drake London<br/>
DeVonta Smith<br/>
George Pickens</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Wasn’t Tua the QB for Waddle at Alabama? </b><a name="15669440"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=allstarjim"> allstarjim </a>  : 11:12 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669440">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669431" target="_blank">15669431</a> TDTONEY said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> And is now?  Jeudy had no problem with Tua and nor did Waddle.<br/>
<br/>
I’m confused </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I&#39;m going to ask you to engage in a little bit of critical thinking on that one and get back to me.  What&#39;s different with Tua when he was throwing passes to Jeudy to today, hmmm?</div></div><div class="thread_post"><div class="thread_post_header"><b>TDTONEY </b><a name="15669441"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=allstarjim"> allstarjim </a>  : 11:13 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669441">link</a>   </div></div><div class="thread_post_body">Sorry man, that came off as overly douche-y, needlessly.<br/>
<br/>
Obviously I&#39;m talking about the devastating injury that Tua went through.  He basically had to have his body put back together.  I don&#39;t think he&#39;s the passer he was pre-injury, and we&#39;ll see if his overall throwing ability downfield improves.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Wasn’t Tua the QB for Waddle at Alabama? </b><a name="15669442"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=TDTONEY"> TDTONEY </a>  : 11:15 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669442">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669440" target="_blank">15669440</a> allstarjim said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669431 TDTONEY said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     And is now?  Jeudy had no problem with Tua and nor did Waddle.<br/>
<br/>
I’m confused <br/>
                                <br/>
                           <br/>
<br/>
I&#39;m going to ask you to engage in a little bit of critical thinking on that one and get back to me.  What&#39;s different with Tua when he was throwing passes to Jeudy to today, hmmm? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
You tell me because he’s not his QB anymore like Waddle is and Jeudy had much better production in college under Tua.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: TDTONEY </b><a name="15669445"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=TDTONEY"> TDTONEY </a>  : 11:18 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669445">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669441" target="_blank">15669441</a> allstarjim said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Sorry man, that came off as overly douche-y, needlessly.<br/>
<br/>
Obviously I&#39;m talking about the devastating injury that Tua went through.  He basically had to have his body put back together.  I don&#39;t think he&#39;s the passer he was pre-injury, and we&#39;ll see if his overall throwing ability downfield improves. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Right but Waddles numbers actually improved with him at the pro level.  It’s not like Tua was throwing him 40 yard bombs on a consistent basis in college pre injury</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: TDTONEY </b><a name="15669454"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=allstarjim"> allstarjim </a>  : 11:26 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669454">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669445" target="_blank">15669445</a> TDTONEY said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669441 allstarjim said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Sorry man, that came off as overly douche-y, needlessly.<br/>
<br/>
Obviously I&#39;m talking about the devastating injury that Tua went through.  He basically had to have his body put back together.  I don&#39;t think he&#39;s the passer he was pre-injury, and we&#39;ll see if his overall throwing ability downfield improves. <br/>
                                <br/>
                           <br/>
<br/>
Right but Waddles numbers actually improved with him at the pro level.  It’s not like Tua was throwing him 40 yard bombs on a consistent basis in college pre injury </td>
                                </tr>
                           </tbody></table><br/>
<br/>
The last year that Tua was there was Waddle&#39;s sophomore year.  He was like 4th in the pecking order behind Jeudy, Smith, and Ruggs, and then there was Najee Harris getting 200+ totes.  I don&#39;t think you can draw anything from that.<br/>
<br/>
I mean, that&#39;s a lot of talented receivers and a lot of mouths to feed.  But Tua had some decent deep ball tape pre-injury.</div></div><div class="thread_post"><div class="thread_post_header"><b>Waddle&#39;s numbers didn&#39;t get better in the pros  </b><a name="15669465"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  : 11:37 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669465">link</a>   </div></div><div class="thread_post_body">in his final year at bama he was averaging 150 yards per game, on 21 ypc, and had like 6 tds in 4 games. Had he not gotten hurt he likely would have had an equally impressive season to Smith - neither of them having the heisman season Smith had because they were splitting more targets/tds. <br/>
<br/>
It very likely would have looked like the split this year between Jameson Williams and Metchie.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Waddle&#39;s numbers didn&#39;t get better in the pros  </b><a name="15669470"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=allstarjim"> allstarjim </a>  : 11:44 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669470">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669465" target="_blank">15669465</a> Eric on Li said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> in his final year at bama he was averaging 150 yards per game, on 21 ypc, and had like 6 tds in 4 games. Had he not gotten hurt he likely would have had an equally impressive season to Smith - neither of them having the heisman season Smith had because they were splitting more targets/tds. <br/>
<br/>
It very likely would have looked like the split this year between Jameson Williams and Metchie. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Oh he was talking about from Mac Jones to Tua?  Well yeah, Waddle missed a lot of games.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Waddle&#39;s numbers didn&#39;t get better in the pros  </b><a name="15669475"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=TDTONEY"> TDTONEY </a>  : 11:49 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669475">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669465" target="_blank">15669465</a> Eric on Li said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> in his final year at bama he was averaging 150 yards per game, on 21 ypc, and had like 6 tds in 4 games. Had he not gotten hurt he likely would have had an equally impressive season to Smith - neither of them having the heisman season Smith had because they were splitting more targets/tds. <br/>
<br/>
It very likely would have looked like the split this year between Jameson Williams and Metchie. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I was only talking about Tua as I mentioned. And I see 591 yards in 6 games?</div></div><div class="thread_post"><div class="thread_post_header"><b>All that matters is what Rico hears </b><a name="15669481"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Big+Blue+%2756"> Big Blue &#39;56 </a>  : 11:53 am   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669481">link</a>   </div></div><div class="thread_post_body">and he’s running the Boston Marathon as I type this..😎</div></div><div class="thread_post"><div class="thread_post_header"><b>no doubt Tua is limiting </b><a name="15669487"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  : 12:00 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669487">link</a>   </div></div><div class="thread_post_body">I&#39;m just kinda shocked Waddle didn&#39;t take a single pass on a screen to the house - not 1. He&#39;s longest TD reception was 9 yards. Just very strange considering what he was billed as and having over 100 catches you&#39;d think it would happen atleast once.</div></div><div class="thread_post"><div class="thread_post_header"><b>Thibs not getting past Jets </b><a name="15669492"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UberAlias"> UberAlias </a>  : 12:06 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669492">link</a>   </div></div><div class="thread_post_body">I don&#39;t see any of the top3 edge making it to us.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: no doubt Tua is limiting </b><a name="15669493"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=allstarjim"> allstarjim </a>  : 12:08 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669493">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669487" target="_blank">15669487</a> UConn4523 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I&#39;m just kinda shocked Waddle didn&#39;t take a single pass on a screen to the house - not 1. He&#39;s longest TD reception was 9 yards. Just very strange considering what he was billed as and having over 100 catches you&#39;d think it would happen atleast once. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
He did have quite a few big chunk plays off of short passes.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Waddle&#39;s numbers didn&#39;t get better in the pros  </b><a name="15669497"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  : 12:11 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669497">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669475" target="_blank">15669475</a> TDTONEY said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669465 Eric on Li said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     in his final year at bama he was averaging 150 yards per game, on 21 ypc, and had like 6 tds in 4 games. Had he not gotten hurt he likely would have had an equally impressive season to Smith - neither of them having the heisman season Smith had because they were splitting more targets/tds. <br/>
<br/>
It very likely would have looked like the split this year between Jameson Williams and Metchie. <br/>
                                <br/>
                           <br/>
<br/>
I was only talking about Tua as I mentioned. And I see 591 yards in 6 games? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Not sure if you are talking about Tua @ Bama in 2019 or Tua in Mia last year. <br/>
<br/>
but either way in 2019 Jeudy was the lead guy at bama. And Ruggs was there. And Devonta Smith was a junior. Waddle was a Sophmore. He actually matched Ruggs&#39; production that year but I don&#39;t think there&#39;s too much shame in having been back in the pecking order behind 2 top 15 picks that year and a future heisman winner with seniority on him. he competed with those same 4 for targets his freshman year too and outperformed both Devonta and Ruggs. <br/>
<br/>
by the end of 2019 he had become the biggest threat of the 4, and to start 2020 he was on pace for the best season of the 4 until he got hurt. then Devonta slid into that and won a heisman.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Waddle&#39;s numbers didn&#39;t get better in the pros  </b><a name="15669499"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=allstarjim"> allstarjim </a>  : 12:14 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669499">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669475" target="_blank">15669475</a> TDTONEY said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669465 Eric on Li said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     in his final year at bama he was averaging 150 yards per game, on 21 ypc, and had like 6 tds in 4 games. Had he not gotten hurt he likely would have had an equally impressive season to Smith - neither of them having the heisman season Smith had because they were splitting more targets/tds. <br/>
<br/>
It very likely would have looked like the split this year between Jameson Williams and Metchie. <br/>
                                <br/>
                           <br/>
<br/>
I was only talking about Tua as I mentioned. And I see 591 yards in 6 games? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
That season was with Mac Jones.  He got injured. Almost all of that production was in his first 4 games.  His 5th game he got hurt really early, didn&#39;t record a catch yet, might&#39;ve gotten hurt on the opening kickoff.<br/>
<br/>
The 6th game was his return from injury in the bowl game, and he was really limited, both in reps and physically.  <br/>
<br/>
First 4 games he had 557 yards receiving and 5 total TDs.<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>Sorry </b><a name="15669502"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=allstarjim"> allstarjim </a>  : 12:16 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669502">link</a>   </div></div><div class="thread_post_body">4 TDs in those first 4 games.</div></div><div class="thread_post"><div class="thread_post_header"><b>just to expand a bit on the bama 2018-2019 receiver room </b><a name="15669507"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  : 12:21 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669507">link</a>   </div></div><div class="thread_post_body">here are the cumulative stats over those 2 seasons (each played roughly 28 games).<br/>
<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">1. Jeudy - 145 receptions, 2500 yards, 24 tds, 17 ypc<br/>
2. Smith - 110 receptions, 1900 yards, 20 tds, 17.5 ypc<br/>
3. Ruggs - 86 receptions, 1500 yards, 18 tds, 17 ypc<br/>
4. Waddle - 78 receptions, 1400 yards, 13 tds, 18 ypc </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Waddle was the youngest in that group with it being his freshman/sophmore years. the other 3 were 1 class ahead of him. <br/>
<br/>
now let&#39;s also use those numbers to contextualize what Jameson Williams did just this year in 15 games. <br/>
<br/>
5. Williams - 79 receptions, 1600 yards, 15 tds, 19.9 ypc<br/>
<br/>
that&#39;s basically the season Waddle was on pace for in 2020 pre-injury.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: Waddle&#39;s numbers didn&#39;t get better in the pros  </b><a name="15669513"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=TDTONEY"> TDTONEY </a>  : 12:35 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669513">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669499" target="_blank">15669499</a> allstarjim said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669475 TDTONEY said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15669465 Eric on Li said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     in his final year at bama he was averaging 150 yards per game, on 21 ypc, and had like 6 tds in 4 games. Had he not gotten hurt he likely would have had an equally impressive season to Smith - neither of them having the heisman season Smith had because they were splitting more targets/tds. <br/>
<br/>
It very likely would have looked like the split this year between Jameson Williams and Metchie. <br/>
                                <br/>
                           <br/>
<br/>
I was only talking about Tua as I mentioned. And I see 591 yards in 6 games? <br/>
                                <br/>
                           <br/>
<br/>
That season was with Mac Jones.  He got injured. Almost all of that production was in his first 4 games.  His 5th game he got hurt really early, didn&#39;t record a catch yet, might&#39;ve gotten hurt on the opening kickoff.<br/>
<br/>
The 6th game was his return from injury in the bowl game, and he was really limited, both in reps and physically.  <br/>
<br/>
First 4 games he had 557 yards receiving and 5 total TDs.<br/>
 </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Yes I know as I said in all my posts I was only talking about Waddle in regards to his numbers when working with Tua then and now.  With Jones after Jeudy and Riggs left doesn’t really apply.  Tua and Waddle together then and now is all was referring to.  <br/>
<br/>
I mean if Tua can’t throw a deep ball to Waddle like you mentioned why would they bother to get Hill ?</div></div><div class="thread_post"><div class="thread_post_header"><b>Waddle to me came with the most risk </b><a name="15669516"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  : 12:39 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669516">link</a>   </div></div><div class="thread_post_body">when you rely completely on speed in a juggernaut offense it’s presents questions at the pro level. Smith was an elite route runner and could get open without elite speed. Most of the others have the size that waddle doesn’t.<br/>
<br/>
I don’t hate waddle but I’m glad Miami took him since I can see that being us minus the top 5 pick this year.</div></div><div class="thread_post"><div class="thread_post_header"><b>you guys are missing the biggest difference &#34;then and now&#34;  </b><a name="15669520"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  : 12:42 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669520">link</a>   </div></div><div class="thread_post_body">college defense <br/>
vs<br/>
nfl defenses <br/>
<br/>
none of those bama guys have been onfield busts, and pretty much all 4 were their team&#39;s #1 target pretty quickly, but obviously none of them have come all that close to the statistical success they had at bama. and that&#39;s because NFL defenses know how to take away opposing teams #1 targets. <br/>
<br/>
if smith or waddle were in this draft im pretty sure most would consider them in play for 5 or 7. and rightfully so because both stepped in as #1 receivers on teams with winning records right away. they are good players with the talent to be very good if circumstances around them improve.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: Waddle&#39;s numbers didn&#39;t get better in the pros  </b><a name="15669523"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=TDTONEY"> TDTONEY </a>  : 12:43 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669523">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669497" target="_blank">15669497</a> Eric on Li said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669475 TDTONEY said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15669465 Eric on Li said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     in his final year at bama he was averaging 150 yards per game, on 21 ypc, and had like 6 tds in 4 games. Had he not gotten hurt he likely would have had an equally impressive season to Smith - neither of them having the heisman season Smith had because they were splitting more targets/tds. <br/>
<br/>
It very likely would have looked like the split this year between Jameson Williams and Metchie. <br/>
                                <br/>
                           <br/>
<br/>
I was only talking about Tua as I mentioned. And I see 591 yards in 6 games? <br/>
                                <br/>
                           <br/>
<br/>
Not sure if you are talking about Tua @ Bama in 2019 or Tua in Mia last year. <br/>
<br/>
but either way in 2019 Jeudy was the lead guy at bama. And Ruggs was there. And Devonta Smith was a junior. Waddle was a Sophmore. He actually matched Ruggs&#39; production that year but I don&#39;t think there&#39;s too much shame in having been back in the pecking order behind 2 top 15 picks that year and a future heisman winner with seniority on him. he competed with those same 4 for targets his freshman year too and outperformed both Devonta and Ruggs. <br/>
<br/>
by the end of 2019 he had become the biggest threat of the 4, and to start 2020 he was on pace for the best season of the 4 until he got hurt. then Devonta slid into that and won a heisman. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Waddle had 7 yards receiving the final game on 2019 Jeudy had over 200</div></div><div class="thread_post"><div class="thread_post_header"><b>REGULAR season </b><a name="15669526"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=TDTONEY"> TDTONEY </a>  : 12:44 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669526">link</a>   </div></div><div class="thread_post_body">Sorry</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Waddle to me came with the most risk </b><a name="15669529"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  : 12:47 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669529">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669516" target="_blank">15669516</a> UConn4523 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> when you rely completely on speed in a juggernaut offense it’s presents questions at the pro level. Smith was an elite route runner and could get open without elite speed. Most of the others have the size that waddle doesn’t.<br/>
<br/>
I don’t hate waddle but I’m glad Miami took him since I can see that being us minus the top 5 pick this year. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
what your saying was true about Ruggs coming out but not Waddle. he was able to succeed all over the field and had a lot more toughness than receivers his size usually do. the risk was the injury and the fact that he didn&#39;t get a bigger opportunity to show it in his final year. He was and is in the Tyreek Hill/Santana Moss mold, which is a lot more than a one trick pony despite the size. i think what he showed in Miami this year is actually more impressive than if he went to a good offense like KC and caught a bunch of deep balls as a 3rd option. He showed he can produce as the #1 guy all over the field. Ruggs was starting to come on but he was more of the one trick pony, both at bama and with the raiders.<br/>
<br/>
i didn&#39;t have a strong preference smith vs. waddle last year - they were both excellent prospects so it was more which flavor you were looking for. and i think that kind of played out. <br/>
<br/>
jameson williams is sort of a hybrid between the 2 so where he gets picked will be fascinating. if the injury progress is good i think he gets picked somewhere in between.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: REGULAR season </b><a name="15669535"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  : 12:51 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669535">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669526" target="_blank">15669526</a> TDTONEY said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Sorry </td>
                                </tr>
                           </tbody></table><br/>
<br/>
he scored 5 of his 6 touchdowns that year in the last 3 games (including 3 in the SEC Champ game).</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Waddle to me came with the most risk </b><a name="15669556"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  : 1:15 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669556">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669529" target="_blank">15669529</a> Eric on Li said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669516 UConn4523 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     when you rely completely on speed in a juggernaut offense it’s presents questions at the pro level. Smith was an elite route runner and could get open without elite speed. Most of the others have the size that waddle doesn’t.<br/>
<br/>
I don’t hate waddle but I’m glad Miami took him since I can see that being us minus the top 5 pick this year. <br/>
                                <br/>
                           <br/>
<br/>
what your saying was true about Ruggs coming out but not Waddle. he was able to succeed all over the field and had a lot more toughness than receivers his size usually do. the risk was the injury and the fact that he didn&#39;t get a bigger opportunity to show it in his final year. He was and is in the Tyreek Hill/Santana Moss mold, which is a lot more than a one trick pony despite the size. i think what he showed in Miami this year is actually more impressive than if he went to a good offense like KC and caught a bunch of deep balls as a 3rd option. He showed he can produce as the #1 guy all over the field. Ruggs was starting to come on but he was more of the one trick pony, both at bama and with the raiders.<br/>
<br/>
i didn&#39;t have a strong preference smith vs. waddle last year - they were both excellent prospects so it was more which flavor you were looking for. and i think that kind of played out. <br/>
<br/>
jameson williams is sort of a hybrid between the 2 so where he gets picked will be fascinating. if the injury progress is good i think he gets picked somewhere in between. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Ruggs was straight line speed. Waddle was much shiftier and more explosive - definitely a difference. My contention is that he needs that elite speed and movement to be successful while others don&#39;t, they play the position better. I wanted to avoid Waddle last year, spending a high 1st on trying to get the next Tyreek Hill didn&#39;t seem wise. I also am a bit skeptical in general from speeders from elite programs, he just wasn&#39;t tested enough at the college level.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: REGULAR season </b><a name="15669566"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=TDTONEY"> TDTONEY </a>  : 1:28 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669566">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669535" target="_blank">15669535</a> Eric on Li said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669526 TDTONEY said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Sorry <br/>
                                <br/>
                           <br/>
<br/>
he scored 5 of his 6 touchdowns that year in the last 3 games (including 3 in the SEC Champ game). </td>
                                </tr>
                           </tbody></table><br/>
<br/>
That was 2018 not 2019</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: sure, players have had really good seasons </b><a name="15669571"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  : 1:38 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669571">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669419" target="_blank">15669419</a> allstarjim said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
QB play, UCONN.  Tua isn&#39;t getting a bunch of balls downfield to Waddle.  The fact that Waddle got a 1000 yards with Tua as his QB is pretty good.  He made plays with the ball in his hands and you can still see the separation he gets in the NFL.  <br/>
<br/>
But if you watch Waddle in particular, kid can BALL OUT.  He&#39;s a much better receiver than you&#39;re giving credit for, absolutely a top 5 talent.  He just doesn&#39;t have the right QB to maximize his talent right now. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I agree with this. Tua&#39;s limitations permeated that entire offense. Despite that, however, Waddle still finished 12th among WRs in YAC. But it was fairly obvious that Miami was using the super-short passing game as their de facto running game.<br/>
<br/>
With McDaniel now in the pilot&#39;s chair, I fully expect to see greater production from Waddle. McDaniel is super-bright and will find different ways to exploit Waddle&#39;s gifts. For example, Waddle only had two carries last year. Which is beyond dumb. I fully expect that number to bump up to 30+.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: sure, players have had really good season </b><a name="15669582"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=TDTONEY"> TDTONEY </a>  : 1:54 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669582">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669571" target="_blank">15669571</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669419 allstarjim said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
QB play, UCONN.  Tua isn&#39;t getting a bunch of balls downfield to Waddle.  The fact that Waddle got a 1000 yards with Tua as his QB is pretty good.  He made plays with the ball in his hands and you can still see the separation he gets in the NFL.  <br/>
<br/>
But if you watch Waddle in particular, kid can BALL OUT.  He&#39;s a much better receiver than you&#39;re giving credit for, absolutely a top 5 talent.  He just doesn&#39;t have the right QB to maximize his talent right now. <br/>
                                <br/>
                           <br/>
<br/>
I agreeh with this. Tua&#39;s limitations permeated that entire offense. Despite that, however, Waddle still finished 12th among WRs in YAC. But it was fairly obvious that Miami was using the super-short passing game as their de facto running game.<br/>
<br/>
With McDaniel now in the pilot&#39;s chair, I fully expect to see greater production from Waddle. McDaniel is super-bright and will find different ways to exploit Waddle&#39;s gifts. For example, Waddle only had two carries last year. Which is beyond dumb. I fully expect that number to bump up to 30+. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I’m still confused why they would bother to get Hill with all of Tuas limitations.  I guess the vertical threat helps the running game but they were clear to dead last.  Waddle and Parker couldn’t open it up?</div></div><div class="thread_post"><div class="thread_post_header"><b>Waddle should definitely run more </b><a name="15669597"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  : 2:09 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669597">link</a>   </div></div><div class="thread_post_body">he will be more productive that way, although likely banged up more. Miami is going to be a fascinating team to watch this year.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: RE: sure, players have had really good season </b><a name="15669609"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  : 2:24 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669609">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669582" target="_blank">15669582</a> TDTONEY said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669571 bw in dc said:<br/>
<br/>
      <br/>
I agree with this. Tua&#39;s limitations permeated that entire offense. Despite that, however, Waddle still finished 12th among WRs in YAC. But it was fairly obvious that Miami was using the super-short passing game as their de facto running game.<br/>
<br/>
With McDaniel now in the pilot&#39;s chair, I fully expect to see greater production from Waddle. McDaniel is super-bright and will find different ways to exploit Waddle&#39;s gifts. For example, Waddle only had two carries last year. Which is beyond dumb. I fully expect that number to bump up to 30+. <br/>
                                <br/>
                           <br/>
<br/>
I’m still confused why they would bother to get Hill with all of Tuas limitations.  I guess the vertical threat helps the running game but they were clear to dead last.  Waddle and Parker couldn’t open it up? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
New regime that is offensive oriented v Flores I&#39;m sure has something to do with adding Hill. More is better routine, especially speed. They are going to force the defense to cover a lot more real estate.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Schrager doesn&#39;t say much here, and I doubt he has any connections </b><a name="15669617"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gman11"> Gman11 </a>  : 2:35 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669617">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669428" target="_blank">15669428</a> PatersonPlank said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Just sounds like more speculation to me. I&#39;d rather listen to Kay </td>
                                </tr>
                           </tbody></table><br/>
<br/>
What Shrager is hearing is probably what he likes best - the sound of his own voice.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: RE: RE: sure, players have had really good season </b><a name="15669619"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=TDTONEY"> TDTONEY </a>  : 2:37 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669619">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669609" target="_blank">15669609</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669582 TDTONEY said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15669571 bw in dc said:<br/>
<br/>
      <br/>
I agree with this. Tua&#39;s limitations permeated that entire offense. Despite that, however, Waddle still finished 12th among WRs in YAC. But it was fairly obvious that Miami was using the super-short passing game as their de facto running game.<br/>
<br/>
With McDaniel now in the pilot&#39;s chair, I fully expect to see greater production from Waddle. McDaniel is super-bright and will find different ways to exploit Waddle&#39;s gifts. For example, Waddle only had two carries last year. Which is beyond dumb. I fully expect that number to bump up to 30+. <br/>
                                <br/>
                           <br/>
<br/>
I’m still confused why they would bother to get Hill with all of Tuas limitations.  I guess the vertical threat helps the running game but they were clear to dead last.  Waddle and Parker couldn’t open it up? <br/>
                                <br/>
                           <br/>
<br/>
New regime that is offensive oriented v Flores I&#39;m sure has something to do with adding Hill. More is better routine, especially speed. They are going to force the defense to cover a lot more real estate. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Makes sense but with no running game it’s hard to fathom that’s going to be effective.  But enter McDaniel who was a  running back coach at one point and that will be a priority so a lot of things will be different</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Starting </b><a name="15669641"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Payasdaddy"> Payasdaddy </a>  : 3:03 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669641">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669414" target="_blank">15669414</a> RCPhoenix said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669406 joeinpa said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     to get the feeling more than 1 of the three tackles will be there at 5, and that Cross will be the pick if he s one of them <br/>
                                <br/>
                           <br/>
<br/>
I tend to agree that Cross will be the pick at #5, he fits what Daboll wants for an OT when it comes to pass blocking. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I can see Cross at 5 too<br/>
His feet and pass blocking seem superb  1 offseason in NFL weightroom should give him the added pop needed in run game<br/>
if ickey or neal is there at 7 also, still have to think hard about double dipping oline based and how BPA and need     I think saquon might look like a different player if he actually had a few runs where 3 guys arent 5 yards into the backfield</div></div><div class="thread_post"><div class="thread_post_header"><b>tdtoney - no it wasn&#39;t 2018, i&#39;m talking 2019 </b><a name="15669681"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  : 4:12 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669681">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669566" target="_blank">15669566</a> TDTONEY said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669535 Eric on Li said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15669526 TDTONEY said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Sorry <br/>
                                <br/>
                           <br/>
<br/>
he scored 5 of his 6 touchdowns that year in the last 3 games (including 3 in the SEC Champ game). <br/>
                                <br/>
                           <br/>
<br/>
That was 2018 not 2019 </td>
                                </tr>
                           </tbody></table><br/>
<br/>
by the end of 2019 Waddle emerged as the home run hitter over Ruggs. Jeudy was still getting the targets and Smith was a chain mover. Ruggs ran the fast 40 and got overdrafted but Waddle had already looked like he was going to be the better player (and solidified that when he went to another level in 2020). <br/>
<br/>
<img src="https://nimbus-screenshots.s3.amazonaws.com/s/9bea23304875b0d995164adfbd8bf715.png"/></div></div><div class="thread_post"><div class="thread_post_header"><b>The talking heads get their information </b><a name="15669682"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Ten+Ton+Hammer"> Ten Ton Hammer </a>  : 4:14 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669682">link</a>   </div></div><div class="thread_post_body">From GMs, who lie, and people close to the lying GMs. <br/>
<br/>
It is lying season.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: The talking heads get their information </b><a name="15669685"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  : 4:18 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669685">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669682" target="_blank">15669682</a> Ten Ton Hammer said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> From GMs, who lie, and people close to the lying GMs. <br/>
<br/>
It is lying season. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
yes but a lot of connections get drawn every year that end up correct. it&#39;s lying season but these guys are all looking at the same tape and as much as we think there are big differences / big secrets out there, the teams i think are very tapped into what the others are doing.<br/>
<br/>
im sure there are a few big surprises each year, but by and large i think a lot more is solidified than we realize. <br/>
<br/>
this could be very wrong but the nyg for example are acting very much like they expect to get sauce gardner (or stingley).</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: tdtoney - no it wasn&#39;t 2018, i&#39;m talking 2019 </b><a name="15669689"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=TDTONEY"> TDTONEY </a>  : 4:22 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669689">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669681" target="_blank">15669681</a> Eric on Li said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669566 TDTONEY said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15669535 Eric on Li said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15669526 TDTONEY said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Sorry <br/>
                                <br/>
                           <br/>
<br/>
he scored 5 of his 6 touchdowns that year in the last 3 games (including 3 in the SEC Champ game). <br/>
                                <br/>
                           <br/>
<br/>
That was 2018 not 2019 <br/>
                                <br/>
                           <br/>
<br/>
by the end of 2019 Waddle emerged as the home run hitter over Ruggs. Jeudy was still getting the targets and Smith was a chain mover. Ruggs ran the fast 40 and got overdrafted but Waddle had already looked like he was going to be the better player (and solidified that when he went to another level in 2020). <br/>
<br/>
 </td>
                                </tr>
                           </tbody></table><br/>
<br/>
8 more yards than Ruggs in those 4 games…8<br/>
<br/>
But Ok</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: tdtoney - no it wasn&#39;t 2018, i&#39;m talking 2019 </b><a name="15669700"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  : 4:38 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669700">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669689" target="_blank">15669689</a> TDTONEY said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669681 Eric on Li said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15669566 TDTONEY said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15669535 Eric on Li said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15669526 TDTONEY said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Sorry <br/>
                                <br/>
                           <br/>
<br/>
he scored 5 of his 6 touchdowns that year in the last 3 games (including 3 in the SEC Champ game). <br/>
                                <br/>
                           <br/>
<br/>
That was 2018 not 2019 <br/>
                                <br/>
                           <br/>
<br/>
by the end of 2019 Waddle emerged as the home run hitter over Ruggs. Jeudy was still getting the targets and Smith was a chain mover. Ruggs ran the fast 40 and got overdrafted but Waddle had already looked like he was going to be the better player (and solidified that when he went to another level in 2020). <br/>
<br/>
 <br/>
                                <br/>
                           <br/>
<br/>
8 more yards than Ruggs in those 4 games…8<br/>
<br/>
But Ok </td>
                                </tr>
                           </tbody></table><br/>
<br/>
on a much higher ypc with 4 more TDs. <br/>
<br/>
And again, he was a class behind 3 top 15 picks at that point. his talent demanded targets and over time it eclipsed all of the, which is why he ended up being the highest drafted of the 4.</div></div><div class="thread_post"><div class="thread_post_header"><b>I don&#39;t agree that  </b><a name="15669719"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=mittenedman"> mittenedman </a>  : 5:21 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669719">link</a>   </div></div><div class="thread_post_body">Horn &amp; Surtain are clearly better prospects than Stingley and Gardner.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I don&#39;t agree that  </b><a name="15669734"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  : 5:48 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669734">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669719" target="_blank">15669719</a> mittenedman said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Horn &amp; Surtain are clearly better prospects than Stingley and Gardner. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Surtain is a high-end two-way corner. He tied for 3rd on the Broncos in total tackles his rookie year. Stingley and Gardner aren&#39;t on the same planet as him with their physicality.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I don&#39;t agree that  </b><a name="15669741"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 6:00 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669741">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669734" target="_blank">15669734</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669719 mittenedman said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Horn &amp; Surtain are clearly better prospects than Stingley and Gardner. <br/>
                                <br/>
                           <br/>
<br/>
Surtain is a high-end two-way corner. He tied for 3rd on the Broncos in total tackles his rookie year. Stingley and Gardner aren&#39;t on the same planet as him with their physicality. </td>
                                </tr>
                           </tbody></table><br/>
Surtain is a really good, ascending CB.<br/>
<br/>
Gardner has better cover skills. You know better than to use tackle stats on a crumbling defensive unit.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I don&#39;t agree that  </b><a name="15669754"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  : 6:13 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669754">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669734" target="_blank">15669734</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669719 mittenedman said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Horn &amp; Surtain are clearly better prospects than Stingley and Gardner. <br/>
                                <br/>
                           <br/>
<br/>
Surtain is a high-end two-way corner. He tied for 3rd on the Broncos in total tackles his rookie year. Stingley and Gardner aren&#39;t on the same planet as him with their physicality. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
in 3 years (40g) at Bama surtain had 116 tackles (2.9 per game), 82 solo (2.05 per game). <br/>
in 3 years (33g) at Cincy gardner had 99 tackles (3 per game), 68 solo (2.06 per game). <br/>
<br/>
neither player was ranked top 10 because of their run d, though their run D grades on PFF were both very good and their overall physicality among their top traits. in games i saw Gardner had a bunch of good hits including the bama game (link below is open field vs. jameson williams) and none of the scouting reports i&#39;ve read, including sy&#39;s, questioned his toughness or physicality nearly to the degree of Stingley. He is right there as a prospect with Horn/Surtain last year. <br/>
<br/>
<img src="https://c.tenor.com/Evz3OZL5dyYAAAAC/sauce-gardner.gif"/><br/><a href="https://twitter.com/i/status/1477032636426108929"> https://twitter.com/i/status/1477032636426108929 </a> - (<a href="https://twitter.com/i/status/1477032636426108929" target="_NEW"> New Window </a>)</div></div><div class="thread_post"><div class="thread_post_header"><b>So much of this is subjective and eye test that it&#39;s exhausting.  </b><a name="15669758"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Ten+Ton+Hammer"> Ten Ton Hammer </a>  : 6:16 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669758">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: So much of this is subjective and eye test that it&#39;s exhausting.  </b><a name="15669759"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=TDTONEY"> TDTONEY </a>  : 6:16 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669759">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669758" target="_blank">15669758</a> Ten Ton Hammer said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> . </td>
                                </tr>
                           </tbody></table><br/>
<br/>
BUT TRUST ME BRO</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: I don&#39;t agree that  </b><a name="15669763"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  : 6:24 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669763">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669741" target="_blank">15669741</a> Gatorade Dunk said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15669734 bw in dc said:<br/>
<br/>
Surtain is a high-end two-way corner. He tied for 3rd on the Broncos in total tackles his rookie year. Stingley and Gardner aren&#39;t on the same planet as him with their physicality. <br/>
                                <br/>
                           <br/>
Surtain is a really good, ascending CB.<br/>
<br/>
Gardner has better cover skills. You know better than to use tackle stats on a crumbling defensive unit. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Denver was third in the league in PPG allowed at 18.9. I thought they were pretty good when I caught them. And the excellent run support/tackling skills Surtain demonstrated at Bama conveyed to the pros.<br/>
<br/>
I&#39;m neutral on Gardner. Not strong opinion one way or the other. The best corners I watched in college were McCreary and probably Elam.<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: So much of this is subjective and eye test that it&#39;s exhausting.  </b><a name="15669767"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Eric+on+Li"> Eric on Li </a>  : 6:29 pm   : <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669767">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=621267&amp;show_all=1#15669758" target="_blank">15669758</a> Ten Ton Hammer said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> . </td>
                                </tr>
                           </tbody></table><br/>
<br/>
yes and no. i think comparing prospects to each other has never been more accessible in terms of non-subjective metrics. there&#39;s more stats and more measurement than ever before, including GPS data which isn&#39;t as publicized but i&#39;d imagine infinitely more interesting to the real decision makers. and even high quality testing numbers from these players dating back to when they were high school prospects (or track athletes). for the public though it&#39;s also more accessible to find footage of those players against other top players as a reference point. <br/>
<br/>
go back through the BBI mock draft history and some of the more knowledgeable posters on this site have extended track records better the pros.</div></div><a name="END"></a><a href="index.php"></a><div style="padding-top:25px; padding-bottom:20px;"><a href="index.php"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"/></a></div></div>
<div class="thread_sidebar_2">

<!-- Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-102">
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Corner Forum - Lower 300x250 -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1566320450447229" data-ad-slot="4189314539" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->

</div>

</div>




<div class="footer">


<p style="width:450px;float:left;padding:10px;"><b>Part of the USA Today Sports Media Group</b><br/>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</p>
<p style="width:400px;float:right; text-align:right;padding:10px;">
All contents (unless otherwise specified) copyright ©  1995 - 2021<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br/> <br/><strong>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Solutions</a></strong>
</p>
<br clear="all"/>
 
</div>




<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->



<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=1&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=1&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-1");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=1&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script></body></html>