<!DOCTYPE html><html lang="en"><head><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
if(typeof isOrig==='undefined'){isOrig=false;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){if((impId!=="0"||isOrig===true)&&adUnit!==""){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}}
function AddPixelById(impFullId,pixelData,isOrig,revenue){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];var pix={type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig};if(typeof revenue!=='undefined'){pix.revenue=revenue;}
pixels.push(pix);}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}});}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false;}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-1&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-1&cb=4', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-1&cb=6', false, [], true, false, true, false);</script>
<title>Worse: Gettleman or Handley | Big Blue Interactive </title>

<meta http-equiv="Pragma" content="no-cache"/>
<meta http-equiv="Expires" content="-1"/>

<meta name="keywords" content="ndglbqfkxx"/>

<meta name="description" content="I know one was a GM and one the head coach. But I gotta say, I think Getts was so so bad. Handley was just not suited for teh NY Media, and came after Parcells. Albeit I was young for Handley, so maybe some of the older posters can weigh in."/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="website"/>
<meta property="og:description" content="I know one was a GM and one the head coach. But I gotta say, I think Getts was so so bad. Handley was just not suited for teh NY Media, and came after Parcells. Albeit I was young for Handley, so maybe some of the older posters can weigh in."/> 
<meta property="og:title" content="Worse: Gettleman or Handley"/> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif"/> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css?v=20200217"/>

<link rel="stylesheet" type="text/css" href="anylink.css"/>


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}


div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" alt="for display only">

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type="text/javascript">
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type="text/javascript" src="https://img.bnqt.com/lib/js/sdpdfphelper.js"></script>
<script type="text/javascript">
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>


<!-- End DFP SETUP -->  

<!-- End USA Today Code -->




<script type="text/javascript">var ezouid = "1";</script><base href="https://corner.bigblueinteractive.com/index.php?mode=2&thread=623777"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"domain_test_group":20210306,"engaged_time_visit":0,"ezcache_level":0,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"d5f9f224-b82a-4563-6591-aa59e343b0b3","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":59969,"response_time_orig":90,"serverid":"75.101.235.132:11718","state":"VA","t_epoch":1658321127,"template_id":126,"time_on_site_visit":0,"url":"https://corner.bigblueinteractive.com/index.php?mode=2\u0026thread=623777","user_id":0,"word_count":3793,"worst_bad_word_level":3};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["d5f9f224-b82a-4563-6591-aa59e343b0b3", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>


<body>




<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tbody><tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"/></a> <img src="images/xpete.gif" alt="The Corner Forum"/>

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic --> 


<!-- Nov 2019 Leaderboard -->

<!-- Ezoic - Forum Leaderboard (USAT) - top_of_page -->
<div id="ezoic-pub-ad-placeholder-118">
<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->
<div id="usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general');
         });
     </script>
</div>
</div>
<!-- End Ezoic - Forum Leaderboard (USAT) - top_of_page -->



</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://www.amazon.com/?_encoding=UTF8&amp;camp=1789&amp;creative=9325&amp;linkCode=ur2&amp;tag=bigblueintera-20">Amazon.com</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW">Standings (NFL.com)</a>
<a href="https://www.giants.com/team/stats/" target="_NEW">Statistics (Giants.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/">Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</tbody></table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;home_view_menu&#39;)">Home</a>  
</li><li><a href="http://corner.bigblueinteractive.com/index.php" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;forum_view_menu&#39;)">Corner Forum</a>
</li><li><a href="http://corner.bigblueinteractive.com/index.php" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;gameday_view_menu&#39;)">Gameday</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_view_menu&#39;)">Team</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_building_view_menu&#39;)">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info & History</a> -->
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_info_view_menu&#39;)">Giants Info &amp; History</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;infolinks_view_menu&#39;)">Info/Links</a>
</li><li><a href="/index.php?mode=10" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;login_menu&#39;)">Log In</a>
</li></ul>

</div><div id="infoline"> </div>

<a name="END"></a><a href="index.php"></a><div style="padding-top:20px; padding-bottom:25px;"><a href="index.php"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"/></a></div><div class="thread_container"><div class="thread_left"><div class="thread_body"><div class="thread_main"><div class="thread_post_header">  <h1 style="font-size:18px;">Worse: Gettleman or Handley </h1><div class="thread_info"><a href="index.php?mode=5&amp;handle=CMicks3110"> CMicks3110 </a>  :  7/18/2022  8:02 pm</div></div><div class="thread_post_body"> I know one was a GM and one the head coach. But I gotta say, I think Getts was so so bad. Handley was just not suited for teh NY Media, and came after Parcells. Albeit I was young for Handley, so maybe some of the older posters can weigh in. </div></div></div><div style="margin: 10 10 20 50"><span class="top_pages">Pages:  <a href="index.php?mode=2&amp;thread=623777&amp;thread_page=1">1</a>  <b style="background: darkred;padding: 2px 5px 2px 5px;">2</b>  <a href="index.php?mode=2&amp;thread=623777&amp;thread_page=1">&lt;&lt;Prev </a>| <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1" title="">Show All</a> | </span></div>
</div><div class="thread_right"><div id="ad_side_box">


<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id="usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103,22280986322/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general');
         });
     </script>
</div>


</div></div><div class="thread_comment_container"><div class="thread_post"><div class="thread_post_header"><b>Can’t Compare! </b><a name="15757016"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=CV36"> CV36 </a>  :  7/18/2022  9:19 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757016">link</a>   </div></div><div class="thread_post_body">Handley, JJ and Dave all sucked at different things. Ore than the other two.  They were all terrible.</div></div><div class="thread_post"><div class="thread_post_header"><b>Handley </b><a name="15757017"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=US1+Giants"> US1 Giants </a>  :  7/18/2022  9:21 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757017">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>Not even a discussion. </b><a name="15757018"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=redwhiteandbigblue"> redwhiteandbigblue </a>  :  7/18/2022  9:21 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757018">link</a>   </div></div><div class="thread_post_body">Handley by a mile</div></div><div class="thread_post"><div class="thread_post_header"><b>Gettleman in a landslide... </b><a name="15757025"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  :  7/18/2022  9:40 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757025">link</a>   </div></div><div class="thread_post_body">Handley was only here for two years. GY was picking the players. And he was clearly on the downside. <br/>
<br/>
Gettleman was here for four years with the chief responsibility to rebuild the team, especially post-Eli. And he drove the team further into the ditch with detestable arrogance.</div></div><div class="thread_post"><div class="thread_post_header"><b>Firing squad….. </b><a name="15757028"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=thrunthrublue"> thrunthrublue </a>  :  7/18/2022  9:46 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757028">link</a>   </div></div><div class="thread_post_body">Or hanging…….pick your poison.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: ... </b><a name="15757042"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=FStubbs"> FStubbs </a>  :  7/18/2022  10:05 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757042">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15756985" target="_blank">15756985</a> SFGFNCGiantsFan said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In my lifetime, I&#39;d argue Millen &amp; DG are the two worst NFL GMs. Both were God awful. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Millen is the single worst I&#39;ve ever seen.<br/>
<br/>
Gettleman was awful, but there have been others at his level or worse. <br/>
<br/>
In our own division, Vinny Cerrato was worse than Gettleman.</div></div><div class="thread_post"><div class="thread_post_header"><b>Why does it matter? </b><a name="15757044"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Giant+John"> Giant John </a>  :  7/18/2022  10:10 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757044">link</a>   </div></div><div class="thread_post_body">It doesn’t. Bad is bad.</div></div><div class="thread_post"><div class="thread_post_header"><b>Gettleman </b><a name="15757046"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Matt+in+SGS"> Matt in SGS </a>  :  7/18/2022  10:14 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757046">link</a>   </div></div><div class="thread_post_body">took a bad team and just made it bad differently.  So the net was 0.<br/>
<br/>
I&#39;ve written about Handley before. His failure was a failure on Parcells and George Young. Young gave him the OC job to keep him from going to law school and pushed Erhardt aside. Parcells loved Handley&#39;s analytical mind and called him &#34;a computer on my staff&#34;.  Both wanted him over Belichick.  But Handley also was inheriting an aging team.<br/>
<br/>
However, the more I posted stuff about him on the BigBlueVCR account, I&#39;ve had many former players (Banks, Pepper, Collins, Leonard Marshall, etc) have responded to my posts and said the team Handley took over still had talent to make another run and he screwed it up.  They pointed to the fact that even in the down times, they beat playoff teams along the way.  Now, in some cases, maybe they are hitting too close to home and not as objective about it.  However, since they literally were the ones there, they&#39;d be in a much better spot to give their view point. <br/>
<br/>
So I lean Handley.</div></div><div class="thread_post"><div class="thread_post_header"><b>The real question is who was the best dressed?  </b><a name="15757053"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Rico"> Rico </a>  :  7/18/2022  10:27 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757053">link</a>   </div></div><div class="thread_post_body"><img src="https://alchetron.com/cdn/ray-handley-26fb568d-5bc7-4eb8-a41d-3da516c610b-resize-750.jpeg"/><br/>
<br/>
<img src="https://nypost.com/wp-content/uploads/sites/2/2022/01/david-gettleman-giants-failures.jpg?quality=90&amp;strip=all"/></div></div><div class="thread_post"><div class="thread_post_header"><b>Very similar  </b><a name="15757063"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=RetroJint"> RetroJint </a>  :  7/18/2022  10:58 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757063">link</a>   </div></div><div class="thread_post_body">Both men were promoted to the level of their incompetence .   Both went for the  coffee for the true talents in the organization .   One difference :  Handley was HC for 2 seasons when George Young II was basically dismantling the team because he refused to comply with the realities of the modern era of free agency .  Gettleman had a dismal run as VP -GM, during which he got all of his original presumptions wrong , forcing him to play a never -ending game of catch -up .    In that sense I think Gettleman was more destructive to the team’s overall well being .</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: JJ was worse than Handley. </b><a name="15757064"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Blue+Dream"> Blue Dream </a>  :  7/18/2022  11:03 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757064">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15756981" target="_blank">15756981</a> No Where Man said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> . </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Judge had the support of the fanbase until year 2. The knives were out for Handley after week 2 of his 1st season (loss to a terrible Rams team)</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: H****ley </b><a name="15757067"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=upnyg"> upnyg </a>  :  7/18/2022  11:26 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757067">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757012" target="_blank">15757012</a> PatersonPlank said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> He took over a good team and cross dressed it into the ground </td>
                                </tr>
                           </tbody></table><br/>
This!</div></div><div class="thread_post"><div class="thread_post_header"><b>Recency bias says Gettleman </b><a name="15757072"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BlackLight"> BlackLight </a>  :  7/18/2022  11:44 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757072">link</a>   </div></div><div class="thread_post_body">but Handley was coaching against a bit of a stacked deck.</div></div><div class="thread_post"><div class="thread_post_header"><b>Gettleman hands down </b><a name="15757076"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=.McL."> .McL. </a>  :  7/19/2022  1:45 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757076">link</a>   </div></div><div class="thread_post_body">Handley was only here for 2 years.  The Giants recovered quickly under Reeves (only to fail again for different reasons)...<br/>
We will have to live with the mess Gettleman made for quite some time still.  So 4 years wasted with him there, plus however many it takes to scrub off the stink.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: H****ley </b><a name="15757080"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Big+Blue+%2756"> Big Blue &#39;56 </a>  :  7/19/2022  6:18 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757080">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757012" target="_blank">15757012</a> PatersonPlank said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> He took over a good team and cross dressed it into the ground </td>
                                </tr>
                           </tbody></table><br/>
<br/>
This. 😂<br/>
<br/>
And DG was bad</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: H****ley </b><a name="15757081"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=mfsd"> mfsd </a>  :  7/19/2022  6:48 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757081">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757012" target="_blank">15757012</a> PatersonPlank said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> He took over a good team and cross dressed it into the ground </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Lol well done</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: H****ley </b><a name="15757082"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Bubba"> Bubba </a>  :  7/19/2022  7:05 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757082">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757081" target="_blank">15757081</a> mfsd said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15757012 PatersonPlank said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     He took over a good team and cross dressed it into the ground <br/>
                                <br/>
                           <br/>
<br/>
Lol well done </td>
                                </tr>
                           </tbody></table><br/>
<br/>
This.  I was at a training camp and LT was talking with some fans at start of practice.  Handley comes over and dresses him down in front of the fans for not getting in there.  The look on LT&#39;s face made he think he was going to pop Handley&#39;s head like a pimple.  I was embarrassed for LT.</div></div><div class="thread_post"><div class="thread_post_header"><b>They&#39;re both... </b><a name="15757088"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Brown_Hornet"> Brown_Hornet </a>  :  7/19/2022  7:53 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757088">link</a>   </div></div><div class="thread_post_body">...in the rearview.<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>For me, it&#39;s DG </b><a name="15757091"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=JonC"> JonC </a>  :  7/19/2022  7:58 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757091">link</a>   </div></div><div class="thread_post_body">He literally blew every big decision, the high draft picks he was granted along the way, setting a franchise back as far as you possibly could.  Instead of accepting Eli&#39;s decline and setting a course of action accordingly, he doubled on and tried to build around him.  The doubling down on the wrong decisions is a core theme of DG&#39;s tenure.</div></div><div class="thread_post"><div class="thread_post_header"><b>doubled </b><a name="15757092"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=JonC"> JonC </a>  :  7/19/2022  7:58 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757092">link</a>   </div></div><div class="thread_post_body">down</div></div><div class="thread_post"><div class="thread_post_header"><b>I think they are honestly parallel incompetent.  </b><a name="15757093"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BLUATHRT"> BLUATHRT </a>  :  7/19/2022  7:59 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757093">link</a>   </div></div><div class="thread_post_body">Handley took a team that just won a Super Bowl and emasculated them and destroyed a team built on toughness into a shell of itself. <br/>
<br/>
DG was an outright disaster, from failed draft picks to mind-blowingly bad FA decisions and position neglect. <br/>
<br/>
They both made their mark in historic fashion, but both essentially ruined the NYG brand.</div></div><div class="thread_post"><div class="thread_post_header"><b>Ray Handley </b><a name="15757094"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=cjohn2979"> cjohn2979 </a>  :  7/19/2022  8:00 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757094">link</a>   </div></div><div class="thread_post_body">Ray Handley was the RB coach. In the spring of 1991 Bill Parcells promoted him to OC. Shortly thereafter Parcells retired. George Young then promoted Handley to HC. Handley went from RB coach to HC in the span of a few weeks. It&#39;s not surprising he failed. He was in way over his head. Thats on George Young.</div></div><div class="thread_post"><div class="thread_post_header"><b>Who Cares? </b><a name="15757098"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=It%27s+a+New+Day"> It&#39;s a New Day </a>  :  7/19/2022  8:21 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757098">link</a>   </div></div><div class="thread_post_body">Ancient history</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Who Cares? </b><a name="15757099"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=BLUATHRT"> BLUATHRT </a>  :  7/19/2022  8:22 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757099">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757098" target="_blank">15757098</a> It&#39;s a New Day said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Ancient history </td>
                                </tr>
                           </tbody></table><br/>
<br/>
DG is far from ancient history. This roster is stacked with his failures.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Who Cares? </b><a name="15757105"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Brown_Hornet"> Brown_Hornet </a>  :  7/19/2022  8:26 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757105">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757099" target="_blank">15757099</a> BLUATHRT said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15757098 It&#39;s a New Day said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Ancient history <br/>
                                <br/>
                           <br/>
<br/>
DG is far from ancient history. This roster is stacked with his failures. </td>
                                </tr>
                           </tbody></table>The past is the past.<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>Gettleman </b><a name="15757109"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Biteymax22"> Biteymax22 </a>  :  7/19/2022  8:35 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757109">link</a>   </div></div><div class="thread_post_body">Inherited a franchise QB but still couldn&#39;t build a decent team around him, burned through multiple head coaches and signed some of the worst FA contracts in franchise history.<br/>
<br/>
We had so many &#34;not NFL players&#34; that wound up starting games for us under his tenure that its not even funny.  That&#39;s all on him.</div></div><div class="thread_post"><div class="thread_post_header"><b>Which is worse, cancer or smallpox? </b><a name="15757111"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Greg+from+LI"> Greg from LI </a>  :  7/19/2022  8:41 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757111">link</a>   </div></div><div class="thread_post_body">It&#39;s ultimately a silly debate.  Both of them were awful at their jobs, both are blessedly gone.  No point in hashing out which one was worse.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Dave </b><a name="15757115"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Victor+in+CT"> Victor in CT </a>  :  7/19/2022  8:45 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757115">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757011" target="_blank">15757011</a> djm said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15756987 The_Boss said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Not even close. The guy couldn’t build a Turkey club sandwich or a professional football team. He likely set the franchise back 3-5 years. <br/>
                                <br/>
                           <br/>
<br/>
No way. Handley took over a great team and they went to shit. DG took over a bad team and they are still bad, but cmon. Not even close?<br/>
<br/>
The HC impacts things more than the GM. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Exactly. the Giants were loaded in 1991-1992</div></div><div class="thread_post"><div class="thread_post_header"><b>Gettleman was far worse than Handley because  </b><a name="15757117"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=mikeinbloomfield"> mikeinbloomfield </a>  :  7/19/2022  8:46 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757117">link</a>   </div></div><div class="thread_post_body">he is responsible for more of the things teams need to win. I don&#39;t care how good a coach you are, if you have crap players you are not going to win a Super Bowl.<br/>
<br/>
Handley was in over his head but if Parcells decided to un-retire halfway through the season, how would the team have been hurt? <br/>
<br/>
Gettleman&#39;s tenure set this team back years. If Jones isn&#39;t the guy and Schoen doesn&#39;t make any mistakes whatsoever, we still won&#39;t be ready to really compete until 2024 at the earliest.<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Gettleman  </b><a name="15757122"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Sec+103"> Sec 103 </a>  :  7/19/2022  8:54 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757122">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15756992" target="_blank">15756992</a> Joe Beckwith said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15756990 Joe Beckwith said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Handles ruined a team.<br/>
Gettleman ruined an organization. <br/>
                                <br/>
                           <br/>
Handley. Spellcheck , uggghh. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
AS much as I hated Handjob, the above is true AF....</div></div><div class="thread_post"><div class="thread_post_header"><b>Gettleman for certain. </b><a name="15757135"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Jimmy+Googs"> Jimmy Googs </a>  :  7/19/2022  9:03 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757135">link</a>   </div></div><div class="thread_post_body">He inherited a team that was bad and was picking overall #2 in the Draft, but he couldn&#39;t recognize it.  And then after he realized what he had, he spent 4 excruciating long years making bad decision after bad decision in turning over the entire roster, and still only got us to picking #5 overall at the end of his term. He accomplished really nothing.<br/>
<br/>
And ultimately left us a team that is devoid of talent, very little at the core positions and with a bloated cap position that it needs to be rebuilt again basically from scratch.<br/>
<br/>
The only real positive thing that Gettleman provided, as well as the gaggle of fans on BBI that defended him, was comic relief for the rest of us.  That I miss...<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>This thread is emblematic </b><a name="15757140"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=gidiefor"> gidiefor </a> : <b style="background:darkred;color:white;">Mod</b> :  7/19/2022  9:08 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757140">link</a>   </div></div><div class="thread_post_body">of how bad the last six years actually was - that we would embrace a discussion on who sux worse<br/>
<br/>
<br/>
Blah!<br/>
Make it Stop!<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>Handley and IMO its not even close </b><a name="15757145"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Essex"> Essex </a>  :  7/19/2022  9:14 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757145">link</a>   </div></div><div class="thread_post_body">Gettleman failed spectacularly at rebuilding a team.  Building a team is always hard and many people fail at doing it.  Ray Handley inherited a super bowl winning team with all time greats of this organization and burnt it to the ground.  And, if you don&#39;t think the two years of 91-92 were years we could win, well look what happened when Simms was back in 93 and we won 11 games and then a playoff game.  Those two years were valuable years that Handley really messed up.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Gettleman hands down </b><a name="15757151"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=PatersonPlank"> PatersonPlank </a>  :  7/19/2022  9:23 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757151">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757076" target="_blank">15757076</a> .McL. said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Handley was only here for 2 years.  The Giants recovered quickly under Reeves (only to fail again for different reasons)...<br/>
We will have to live with the mess Gettleman made for quite some time still.  So 4 years wasted with him there, plus however many it takes to scrub off the stink. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Yes but to me this just shows how bad H***ley was. He took over a good team. That is shown with their records. He took over a 13-3 SB winning team, and immediately turned it into a 4th place team, going 6-10 in his last season. Then Reeves comes in and magically goes 11-5 in his first season, basically the same team. DG sucks, but he took over a pile of crap too. W are talking about who sucks more at their job.</div></div><div class="thread_post"><div class="thread_post_header"><b>Giants in &#39;91-92 </b><a name="15757161"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=JonC"> JonC </a>  :  7/19/2022  9:27 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757161">link</a>   </div></div><div class="thread_post_body">were aging and GY was preparing to wind it down as he failed to adjust and adapt to free agency and the salary cap.  1990 was likely the last SB winning caliber team it had in it.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Giants in &#39;91-92 </b><a name="15757166"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Essex"> Essex </a>  :  7/19/2022  9:33 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757166">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757161" target="_blank">15757161</a> JonC said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> were aging and GY was preparing to wind it down as he failed to adjust and adapt to free agency and the salary cap.  1990 was likely the last SB winning caliber team it had in it. </td>
                                </tr>
                           </tbody></table><br/>
I think it is unlikely we would have won in 91 or 92, but we would have had a shot. Handley ruined that shot.  Take GS, many people thought they were through, had an aging and injured roster, and they won this year.  Would the Giants have likely won in 91 or 92? No, but I am convinced if Parcells was back in 91 and 92 or we got a competent successor, we would have made the playoffs and had a shot.  I think 91 was a down year.  Washington dominated that year and I did not think that they were particularly good.</div></div><div class="thread_post"><div class="thread_post_header"><b>Even Parcells knew it was time to go </b><a name="15757169"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=JonC"> JonC </a>  :  7/19/2022  9:35 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757169">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>It’s like choosing between getting kicked  </b><a name="15757181"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Mattman"> Mattman </a>  :  7/19/2022  9:52 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757181">link</a>   </div></div><div class="thread_post_body">In the left nut or right nut</div></div><div class="thread_post"><div class="thread_post_header"><b>Handley took over a Super Bowl team </b><a name="15757244"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gman11"> Gman11 </a>  :  7/19/2022  10:37 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757244">link</a>   </div></div><div class="thread_post_body">Granted some of the players were getting on their careers, but they were still good and Handley couldn&#39;t win with them.<br/>
<br/>
Gettleman took over a shitty team and made them shittier. <br/>
<br/>
You decide.</div></div><div class="thread_post"><div class="thread_post_header"><b>1991 was a different scenario than 2017 </b><a name="15757519"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=arniefez"> arniefez </a>  :  7/19/2022  2:04 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757519">link</a>   </div></div><div class="thread_post_body">but both were a disaster for Giant fans. I will say this though IMO the replacements for the 2017 disaster are far superior to the replacements for the 1992 disaster.<br/>
<br/>
In 1993 the Giants had the fumes of a 2 time Super Bowl winner on the field, a new older HC and a GM that were at each others throats almost immediately and past their primes. <br/>
<br/>
In 2022 the new guys inherited arguably one of the bottom 5 rosters in the NFL for  a young GM, a young assistant GM, a young HC and young OC all promoted one level up with long time College and NFL experience from multiple progressive teams. As far as we can see they are all on the same page. They also added an experienced DC who is a far from read and react as you can get.<br/>
<br/>
If you&#39;re a Giant fan and not excited about the future right now I don&#39;t know what to tell you.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Who Cares? </b><a name="15757532"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Ten+Ton+Hammer"> Ten Ton Hammer </a>  :  7/19/2022  2:17 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757532">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757098" target="_blank">15757098</a> It&#39;s a New Day said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Ancient history </td>
                                </tr>
                           </tbody></table><br/>
<br/>
You can learn from the gettleman years.</div></div><div class="thread_post"><div class="thread_post_header"><b>Handley </b><a name="15757644"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Thegratefulhead"> Thegratefulhead </a>  :  7/19/2022  3:35 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757644">link</a>   </div></div><div class="thread_post_body">I think I could have got that team to the superbowl.  All you needed to do was get out of the way.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Giants in &#39;91-92 </b><a name="15757687"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=FStubbs"> FStubbs </a>  :  7/19/2022  4:24 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757687">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757166" target="_blank">15757166</a> Essex said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15757161 JonC said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     were aging and GY was preparing to wind it down as he failed to adjust and adapt to free agency and the salary cap.  1990 was likely the last SB winning caliber team it had in it. <br/>
                                <br/>
                           <br/>
I think it is unlikely we would have won in 91 or 92, but we would have had a shot. Handley ruined that shot.  Take GS, many people thought they were through, had an aging and injured roster, and they won this year.  Would the Giants have likely won in 91 or 92? No, but I am convinced if Parcells was back in 91 and 92 or we got a competent successor, we would have made the playoffs and had a shot.  I think 91 was a down year.  Washington dominated that year and I did not think that they were particularly good. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
The leftovers from that team were an Emmitt Smith career quarter away from home field advantage throughout the playoffs, against arguably the best of the Cowboys 90s teams.<br/>
<br/>
With a real coach instead of Handley for &#39;91-&#39;92, who knows. Washington&#39;s greatest team was &#39;91, and that team smoked almost everyone they played, but the Giants had them down 13-0 at the half in one game before they quit.</div></div><div class="thread_post"><div class="thread_post_header"><b>Gettleman </b><a name="15757757"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Ron+from+Ninerland"> Ron from Ninerland </a>  :  7/19/2022  6:42 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757757">link</a>   </div></div><div class="thread_post_body">Not only did Gettleman take a bad team and made it worse but he left it buried with Cap problems. Some of the mistakes he made were mind boggling. Trading up for a 1, then wasting on on DeAndre Baker, the failure to do anything to improve the OL, and the money he wasted on Golloday just to name a few.  As for Leonard Marshall, IMHO he botched that.  Marshall is one of the few legitimately  good players he brought in, but he gave up to much. <br/>
After giving up an unconditional 3rd for a player that wasn&#39;t even signed, Marshall&#39;s agent knew he had the Giants by the balls resulting in another overpay.<br/>
<br/>
As for Handley, he was a bad coach, but not in the class of Gettleman. He was hamstrung by injuries to both his QB&#39;s and his DC was an asshole.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Gettleman </b><a name="15757771"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Angel+Eyes"> Angel Eyes </a>  :  7/19/2022  6:55 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757771">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757757" target="_blank">15757757</a> Ron from Ninerland said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Not only did Gettleman take a bad team and made it worse but he left it buried with Cap problems. Some of the mistakes he made were mind boggling. Trading up for a 1, then wasting on on DeAndre Baker, the failure to do anything to improve the OL, and the money he wasted on Golloday just to name a few.  As for Leonard Marshall, IMHO he botched that.  Marshall is one of the few legitimately  good players he brought in, but he gave up to much. <br/>
After giving up an unconditional 3rd for a player that wasn&#39;t even signed, Marshall&#39;s agent knew he had the Giants by the balls resulting in another overpay.<br/>
<br/>
As for Handley, he was a bad coach, but not in the class of Gettleman. He was hamstrung by injuries to both his QB&#39;s and his DC was an asshole. </td>
                                </tr>
                           </tbody></table><br/>
Do you mean Leonard Williams instead of Marshall? Admittedly they fill a similar role in the Giants&#39; defense.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Gettleman </b><a name="15757777"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Ron+from+Ninerland"> Ron from Ninerland </a>  :  7/19/2022  7:04 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757777">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757771" target="_blank">15757771</a> Angel Eyes said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15757757 Ron from Ninerland said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Not only did Gettleman take a bad team and made it worse but he left it buried with Cap problems. Some of the mistakes he made were mind boggling. Trading up for a 1, then wasting on on DeAndre Baker, the failure to do anything to improve the OL, and the money he wasted on Golloday just to name a few.  As for Leonard Marshall, IMHO he botched that.  Marshall is one of the few legitimately  good players he brought in, but he gave up to much. <br/>
After giving up an unconditional 3rd for a player that wasn&#39;t even signed, Marshall&#39;s agent knew he had the Giants by the balls resulting in another overpay.<br/>
<br/>
As for Handley, he was a bad coach, but not in the class of Gettleman. He was hamstrung by injuries to both his QB&#39;s and his DC was an asshole. <br/>
                                <br/>
                           <br/>
Do you mean Leonard Williams instead of Marshall? Admittedly they fill a similar role in the Giants&#39; defense. </td>
                                </tr>
                           </tbody></table>Sorry about that. The KO of Montana is probably the sweetest football memory I have.</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="15757787"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=SFGFNCGiantsFan"> SFGFNCGiantsFan </a>  :  7/19/2022  7:29 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757787">link</a>   </div></div><div class="thread_post_body">If Parcells sticks around in &#39;91, the Giants are probably better than 8-8 &amp; probably a playoff team, but they aren&#39;t winning it all.</div></div><div class="thread_post"><div class="thread_post_header"><b>... </b><a name="15757788"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=SFGFNCGiantsFan"> SFGFNCGiantsFan </a>  :  7/19/2022  7:30 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757788">link</a>   </div></div><div class="thread_post_body">The highlight of the Handley years-were there any?-was his debut win vs. SF on MNF where he wore that ridiculous shirt. God, what a clusterfuck those two seasons were.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: ... </b><a name="15757798"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  :  7/19/2022  7:42 pm   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757798">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757787" target="_blank">15757787</a> SFGFNCGiantsFan said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> If Parcells sticks around in &#39;91, the Giants are probably better than 8-8 &amp; probably a playoff team, but they aren&#39;t winning it all. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Spot on. Handley was a bad hire, but that team was old with a lot of major players deep on the back nine of their careers.<br/>
<br/>
I&#39;m pretty shocked how many posters chose Handley over Gettleman. It really should be a landslide as GY was assembling the roster, building the evaluation systems, and integrally involved in selecting the HC. That allows for far more damage to an organization than anything Handley did.</div></div><div class="thread_post"><div class="thread_post_header"><b>Good post cjohn </b><a name="15757941"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Lines+of+Scrimmage"> Lines of Scrimmage </a>  : 6:58 am   : <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1#15757941">link</a>   </div></div><div class="thread_post_body">That is a exceptionally difficult set of circumstances to be thrown into on top of some other points made.  <br/>
<br/>
&#34;Run the ball, stop the run and get after the passer.  Have a QB that can throw from the pocket.&#34;  I think Dave did have the mandate of Eli to start and inherited a terrible roster but in four years we are still hoping to do these things.  Seems like a easy choice.<br/>
<br/>
In some ways it may be a blessing.  The Giants have made very significant front office changes,  Hopefully they execute far better.</div></div><div style="margin: 10 10 20 50"><span class="top_pages">Pages:  <a href="index.php?mode=2&amp;thread=623777&amp;thread_page=1">1</a>  <b style="background: darkred;padding: 2px 5px 2px 5px;">2</b>  <a href="index.php?mode=2&amp;thread=623777&amp;thread_page=1">&lt;&lt;Prev </a>| <a href="index.php?mode=2&amp;thread=623777&amp;show_all=1" title="">Show All</a> | </span></div>
<a name="END"></a><a href="index.php"></a><div style="padding-top:25px; padding-bottom:20px;"><a href="index.php"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"/></a></div></div>
<div class="thread_sidebar_2">

<!-- Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-102">
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Corner Forum - Lower 300x250 -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1566320450447229" data-ad-slot="4189314539" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->

</div>

</div>




<div class="footer">


<p style="width:450px;float:left;padding:10px;"><b>Part of the USA Today Sports Media Group</b><br/>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</p>
<p style="width:400px;float:right; text-align:right;padding:10px;">
All contents (unless otherwise specified) copyright ©  1995 - 2021<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br/> <br/><strong>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Solutions</a></strong>
</p>
<br clear="all"/>
 
</div>




<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->



<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=1&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=1&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-1");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=1&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script>
<script>__ez.queue.addFile('/beardeddragon/drake.js', '/beardeddragon/drake.js?gcb=1&cb=4', false, [], true, false, true, false);</script></body></html>