<!DOCTYPE html><html lang="en"><head><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>!function(){function e(i){return e="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e(i)}__ez.pel=function(){var i=[];function t(t,o,_,d,n,r,a,s){if(__ez.dot.isDefined(t)&&0!=__ez.dot.isAnyDefined(t.getSlotElementId,t.ElementId)){void 0===s&&(s=!1);var p=parseInt(__ez.dot.getTargeting(t,"ap")),f=__ez.dot.getSlotIID(t),u=__ez.dot.getAdUnit(t,s),g=parseInt(__ez.dot.getTargeting(t,"compid")),c=0,l=0,z=function(i){if("undefined"==typeof _ezim_d)return!1;var t=__ez.dot.getAdUnitPath(i).split("/").pop();if("object"===("undefined"==typeof _ezim_d?"undefined":e(_ezim_d))&&_ezim_d.hasOwnProperty(t))return _ezim_d[t];for(var o in _ezim_d)if(o.split("/").pop()===t)return _ezim_d[o];return!1}(t);"object"==e(z)&&(void 0!==z.creative_id&&(l=z.creative_id),void 0!==z.line_item_id&&(c=z.line_item_id)),__ez.dot.isDefined(f,u)&&__ez.dot.isValid(o)&&("0"===f&&!0!==s||""===u||i.push({type:"impression",impression_id:f,domain_id:__ez.dot.getDID(),unit:u,t_epoch:__ez.dot.getEpoch(0),revenue:_,est_revenue:d,ad_position:p,ad_size:"",bid_floor_filled:n,bid_floor_prev:r,stat_source_id:a,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:g,line_item_id:c,creative_id:l,data:__ez.dot.dataToStr(o),is_orig:s||__ez.template.isOrig}))}}function o(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(i)&&i.length>0&&[i.filter((function(e){return e.is_orig})),i.filter((function(e){return!e.is_orig}))].forEach((function(e){for(;e.length>0;){var i=e[0].is_orig||!1,t=5;t>e.length&&(t=e.length);var o=e.splice(0,t),_=__ez.dot.getURL("/porpoiseant/army.gif")+"?orig="+(!0===i?1:0)+"&sts="+btoa(JSON.stringify(o));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(_+="&visit_uuid="+_ezaq.visit_uuid),__ez.dot.Fire(_)}})),i=[])}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),o()},AddAndFireOrig:function(e,i){t(e,i,0,0,0,0,0,!0),o()},AddById:function(e,t,o,_){var d=e.split("/");if(__ez.dot.isDefined(e)&&3===d.length&&__ez.dot.isValid(t)){var n=d[0],r={type:"impression",impression_id:d[2],domain_id:__ez.dot.getDID(),unit:n,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(t),is_orig:o||__ez.template.isOrig};void 0!==_&&(r.revenue=_),i.push(r)}},Fire:o,GetPixels:function(){return i}}}()}();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-1&cb=6', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-1&cb=6', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-1&cb=7', false, [], true, false, true, false);</script>
<title>Chris Simms on DJ | Big Blue Interactive </title>

<meta http-equiv="Pragma" content="no-cache"/>
<meta http-equiv="Expires" content="-1"/>

<meta name="keywords" content="ndglbqfkxx"/>

<meta name="description" content="I swore to myself I wouldn&#39;t start a DJ thread, but I think this is a good listen.

Chris nails it on all points.

Regardless of your opinion of DJ, I think we all need to take a deep breath and let it play out.


 Giants&#39; Daniel Jones has promising preseason outing vs. Bengals | Pro Football Talk | NFL on NBC   - ( New Window )"/>
<meta name="robots" content="noodp"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="website"/>
<meta property="og:description" content="I swore to myself I wouldn&#39;t start a DJ thread, but I think this is a good listen.

Chris nails it on all points.

Regardless of your opinion of DJ, I think we all need to take a deep breath and let it play out.


 Giants&#39; Daniel Jones has promising preseason outing vs. Bengals | Pro Football Talk | NFL on NBC   - ( New Window )"/> 
<meta property="og:title" content="Chris Simms on DJ"/> 
<meta property="og:image" content="http://corner.bigblueinteractive.com/images/bbi-corner-forum.gif"/> 

<link rel="stylesheet" type="text/css" href="big-blue-003.css?v=20200217"/>

<link rel="stylesheet" type="text/css" href="anylink.css"/>


<script type="text/javascript" src="anylink.js"></script>
<style>

html{
font-size:100%;
}


div.thread_info{
font-size:.9em;

}

div#forum_promo_1{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

div#forum_promo_2{
margin: 5px 0px 5px 0px;
padding: 0px;
text-align: center;

}

.thread-post-body img { max-width: 100%; }

</style>



 <!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" alt="for display only">

</noscript>

<!-- End comScore Tag -->

<!-- Begin YES header tag -->

<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag -->




<!-- Begin USA Today Code -->

<!-- Start DFP SETUP -->
<script type="text/javascript">
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type="text/javascript" src="https://img.bnqt.com/lib/js/sdpdfphelper.js"></script>
<script type="text/javascript">
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>


<!-- End DFP SETUP -->  

<!-- End USA Today Code -->




<script type="text/javascript">var ezouid = "1";</script><base href="https://corner.bigblueinteractive.com/index.php?mode=2&thread=624695"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"domain_test_group":20210306,"engaged_time_visit":0,"ezcache_level":0,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"082d65ee-2fab-443f-4823-c7df356fa65e","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":93260,"response_time_orig":116,"serverid":"54.226.132.57:6850","state":"VA","t_epoch":1661283998,"template_id":126,"time_on_site_visit":0,"url":"https://corner.bigblueinteractive.com/index.php?mode=2\u0026thread=624695","user_id":0,"word_count":6976,"worst_bad_word_level":3};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["082d65ee-2fab-443f-4823-c7df356fa65e", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>


<body>




<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->


<table border="0" cellspacing="0" cellpadding="0" width="100%" style="margin-top:20px;">
<tbody><tr>
<td width="500">


<a href="http://www.bigblueinteractive.com"> <img src="images/bbi-120.gif" width="240" height="120" alt="Big Blue Interactive" border="0"/></a> <img src="images/xpete.gif" alt="The Corner Forum"/>

</td>

<td align="center">
<!--Placeholder - Right of BBI Graphic --> 


<!-- Nov 2019 Leaderboard -->

<!-- Ezoic - Forum Leaderboard (USAT) - top_of_page -->
<div id="ezoic-pub-ad-placeholder-118">
<!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general -->
<div id="usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.general', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.general');
         });
     </script>
</div>
</div>
<!-- End Ezoic - Forum Leaderboard (USAT) - top_of_page -->



</td>
</tr>
<tr>
<td colspan="2">

<!--Drop Down Menus -->
 
<div id="forum_view_menu" class="anylinkcss">

<a href="/index.php?show=1">All Threads</a>
<a href="/index.php?show=2">Football Threads</a>
<a href="/index.php?show=3">Non Football Threads</a>
<a href="/index.php?show=5">Forum Archives</a>
<a href="/index.php?show=6">Old Forum Archives</a>
<a href="/index.php?mode=6">Forum Stats</a>
</div>


<div id="home_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms of Use</a>
<a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a>
<a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a>
<a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a>
<a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a>
<a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a>
</div>

<div id="shop_view_menu" class="anylinkcss">

<a href="http://www.amazon.com/?_encoding=UTF8&amp;camp=1789&amp;creative=9325&amp;linkCode=ur2&amp;tag=bigblueintera-20">Amazon.com</a>
</div>

<div id="team_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a>
</div>

<div id="team_info_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a>
<a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a>
<a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a>
</div>


<div id="gameday_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">Previews/Reviews</a>
<a href="http://www.nfl.com/standings" target="_NEW">Standings (NFL.com)</a>
<a href="https://www.giants.com/team/stats/" target="_NEW">Statistics (Giants.com)</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/">Historical Stats</a>
</div>

<div id="team_building_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">The Draft</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a>


</div>

<div id="infolinks_view_menu" class="anylinkcss">

<a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a>
<a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant Of The Year Award</a>
<a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a>
<a href="http://www.bigblueinteractive.com/information-pages/glossary/">Glossary</a>
<a href="http://www.bigblueinteractive.com/information-pages/links/">Links</a>
</div>



<div id="login_menu" class="anylinkcss">
<a href="/index.php?mode=10">Login</a>
<a href="/index.php?mode=12">Register</a>
<a href="/index.php?mode=13">Activate User</a>
<a href="/index.php?mode=14/">Forgot Login Info</a>
</div>


 

</td>

</tr>
</tbody></table>

<div id="navcontainer">
<ul id="navlist">
<li><a href="http://www.bigblueinteractive.com/" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;home_view_menu&#39;)">Home</a>  
</li><li><a href="http://corner.bigblueinteractive.com/index.php" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;forum_view_menu&#39;)">Corner Forum</a>
</li><li><a href="http://corner.bigblueinteractive.com/index.php" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;gameday_view_menu&#39;)">Gameday</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_view_menu&#39;)">Team</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_building_view_menu&#39;)">Team Building</a>
<!-- <li><a href="" onClick="return dropdownmenu(this, event, 'team_info_view_menu', '')" onMouseout="delayhidemenu()">Giants Info & History</a> -->
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;team_info_view_menu&#39;)">Giants Info &amp; History</a>
</li><li><a href="" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;infolinks_view_menu&#39;)">Info/Links</a>
</li><li><a href="/index.php?mode=10" onclick="return clickreturnvalue()" onmouseover="dropdownmenu(this, event, &#39;login_menu&#39;)">Log In</a>
</li></ul>

</div><div id="infoline"> </div>

<a name="END"></a><a href="index.php"></a><div style="padding-top:20px; padding-bottom:25px;"><a href="index.php"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"/></a></div><div class="thread_container"><div class="thread_left"><div class="thread_body"><div class="thread_main"><div class="thread_post_header">  <h1 style="font-size:18px;">Chris Simms on DJ </h1><div class="thread_info"><a href="index.php?mode=5&amp;handle=Tom from LI"> Tom from LI </a>  : 8:54 am</div></div><div class="thread_post_body"> I swore to myself I wouldn&#39;t start a DJ thread, but I think this is a good listen.<br/>
<br/>
Chris nails it on all points.<br/>
<br/>
Regardless of your opinion of DJ, I think we all need to take a deep breath and let it play out.<br/>
<br/>
<br/>
<br/><a href="https://www.youtube.com/watch?v=RnY8jKlmPEk&amp;ab_channel=NFLonNBC"> Giants&#39; Daniel Jones has promising preseason outing vs. Bengals | Pro Football Talk | NFL on NBC </a>  - (<a href="https://www.youtube.com/watch?v=RnY8jKlmPEk&amp;ab_channel=NFLonNBC" target="_NEW"> New Window </a>) </div></div></div><div style="margin: 10 10 20 50"><span class="top_pages">Pages:  <a href="index.php?mode=2&amp;thread=624695&amp;thread_page=1">1</a>  <a href="index.php?mode=2&amp;thread=624695&amp;thread_page=2">2</a>  <b style="background: darkred;padding: 2px 5px 2px 5px;">3</b>  <a href="index.php?mode=2&amp;thread=624695&amp;thread_page=2">&lt;&lt;Prev </a>| <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1" title="">Show All</a> | </span></div>
</div><div class="thread_right"><div id="ad_side_box">


<!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general -->
<div id="usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103,22280986322/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.general', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.general');
         });
     </script>
</div>


</div></div><div class="thread_comment_container"><div class="thread_post"><div class="thread_post_header"><b>The preseason game heard round the world </b><a name="15789036"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Greg+from+LI"> Greg from LI </a>  : 12:37 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789036">link</a>   </div></div><div class="thread_post_body">.</div></div><div class="thread_post"><div class="thread_post_header"><b>Don’t you have to pay the average </b><a name="15789037"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Debaser"> Debaser </a>  : 12:38 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789037">link</a>   </div></div><div class="thread_post_body">Of the top five QB salaries to franchise tag him? So this guy is going to play like Kirk cousins a top ten qb and then make Mahomes / D Watson / Kirk Cousins etc  kind of money to do it again?<br/>
<br/>
Sounds like it would have been better just to pick up his option if they really believe it would work. <br/>
<br/>
This is dumb Jones is pretty much done here. He will walk after this year</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Daboll is being vindicated </b><a name="15789040"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=speedywheels"> speedywheels </a>  : 12:40 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789040">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789015" target="_blank">15789015</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15789009 Rod in St Cloud said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Daboll has previously stated he was purposely making practices hard to put stress on some of the practices. During that time it allowed observers to believe Jones was doing poorly and Taylor outplaying Jones during these practices despite Daboll and the coaches saying Jones was doing fine.<br/>
<br/>
Now that the offensive line was giving the QBs time to throw, Jones to everyone&#39;s great surprise except for the coaches played exceedingly well, and Taylor looked comparatively inaccurate.<br/>
<br/>
Maybe it&#39;s time to give Daboll credit for employing practices that were not designed to make the offense look great, but to improve them. The point of preseason practices was not to pile up astounding stats to impress the reporters. Those practices were often designed to let the QB find out what plays were successful and the ones which were not. Interceptions were necessary though not desired. Now that Jones looked good in this preseason game, Daboll&#39;s practice methods are proving to be beneficial to the success of the team. <br/>
                                <br/>
                           <br/>
<br/>
So, when Sy - who was at the practices - said Jones looked bad, he was fooled, too? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
And what about when Sy said this:<br/>
<br/>
&#34;A very encouraging performance for Jones. Of the practices I have been to and the two preseason games we have under our belt, this was the best I have seen of him. Take the stats out of it and do not consider the fact he has only played against backups (he does not control that, and he wasn’t exactly playing with a first-string offense to say the least), Jones played the position great. He was on time, he played with great tempo, and he was accurate to all levels of the route tree with good touch.&#34;<br/>
<br/>
You conveniently ignored that.  But I can understand why - that messes with your narrative...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: bw in bc </b><a name="15789047"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Rod+in+St+Cloud"> Rod in St Cloud </a>  : 12:44 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789047">link</a>   </div></div><div class="thread_post_body">I have no complaint with Sy saying Jones looked bad in practice. He did look bad. So how do you explain looking good in the preseason game? Perhaps it&#39;s playing against 2nd teamers. But could it also be due to Daboll&#39;s strategy to create practices that are designed to put the offense in pressure situations that are not expected to have a high degree of success? Iron sharpens iron!</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: Daboll is being vindicated </b><a name="15789051"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  : 12:46 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789051">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789040" target="_blank">15789040</a> speedywheels said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
And what about when Sy said this:<br/>
<br/>
&#34;A very encouraging performance for Jones. Of the practices I have been to and the two preseason games we have under our belt, this was the best I have seen of him. Take the stats out of it and do not consider the fact he has only played against backups (he does not control that, and he wasn’t exactly playing with a first-string offense to say the least), Jones played the position great. He was on time, he played with great tempo, and he was accurate to all levels of the route tree with good touch.&#34;<br/>
<br/>
You conveniently ignored that.  But I can understand why - that messes with your narrative... </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Ron in St Cloud was specifically talking practice. <br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: Daboll is being vindicated </b><a name="15789055"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Now+Mike+in+MD"> Now Mike in MD </a>  : 12:47 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789055">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789040" target="_blank">15789040</a> speedywheels said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15789015 bw in dc said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15789009 Rod in St Cloud said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Daboll has previously stated he was purposely making practices hard to put stress on some of the practices. During that time it allowed observers to believe Jones was doing poorly and Taylor outplaying Jones during these practices despite Daboll and the coaches saying Jones was doing fine.<br/>
<br/>
Now that the offensive line was giving the QBs time to throw, Jones to everyone&#39;s great surprise except for the coaches played exceedingly well, and Taylor looked comparatively inaccurate.<br/>
<br/>
Maybe it&#39;s time to give Daboll credit for employing practices that were not designed to make the offense look great, but to improve them. The point of preseason practices was not to pile up astounding stats to impress the reporters. Those practices were often designed to let the QB find out what plays were successful and the ones which were not. Interceptions were necessary though not desired. Now that Jones looked good in this preseason game, Daboll&#39;s practice methods are proving to be beneficial to the success of the team. <br/>
                                <br/>
                           <br/>
<br/>
So, when Sy - who was at the practices - said Jones looked bad, he was fooled, too? <br/>
                                <br/>
                           <br/>
<br/>
And what about when Sy said this:<br/>
<br/>
&#34;A very encouraging performance for Jones. Of the practices I have been to and the two preseason games we have under our belt, this was the best I have seen of him. Take the stats out of it and do not consider the fact he has only played against backups (he does not control that, and he wasn’t exactly playing with a first-string offense to say the least), Jones played the position great. He was on time, he played with great tempo, and he was accurate to all levels of the route tree with good touch.&#34;<br/>
<br/>
You conveniently ignored that.  But I can understand why - that messes with your narrative... </td>
                                </tr>
                           </tbody></table><br/>
<br/>
He also said, and Im paraphrasing, that this was reason Number 150 why you do not overreact to what happens in practice.  But people will ignore that comment as well.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: bw in bc </b><a name="15789059"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  : 12:49 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789059">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789047" target="_blank">15789047</a> Rod in St Cloud said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> I have no complaint with Sy saying Jones looked bad in practice. He did look bad. So how do you explain looking good in the preseason game? Perhaps it&#39;s playing against 2nd teamers. But could it also be due to Daboll&#39;s strategy to create practices that are designed to put the offense in pressure situations that are not expected to have a high degree of success? Iron sharpens iron! </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Jones looked good against Cincinnati&#39;s backups who played a Vanilla 2. To his credit, he completed some straightforward throws and completed on high level throw - the back shoulder fade to Sills. <br/>
<br/>
Do you want me to post highlights thus far of Mahomes in preseason? And the throws he has made?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: The lengths posters go... </b><a name="15789063"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  : 12:52 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789063">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789033" target="_blank">15789033</a> speedywheels said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
And the length some posters go to heap criticism unfairly - and without taking into account the ridiculously bad talent/coaching around him - is equally amusing... </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I don&#39;t feel any criticism I have leveled hasn&#39;t been fair and reasonable.<br/>
<br/>
Of course, that assumes you are able to separate my comments from others.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Daboll is being vindicated </b><a name="15789078"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=ajr2456"> ajr2456 </a>  : 1:13 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789078">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789009" target="_blank">15789009</a> Rod in St Cloud said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Daboll has previously stated he was purposely making practices hard to put stress on some of the practices. During that time it allowed observers to believe Jones was doing poorly and Taylor outplaying Jones during these practices despite Daboll and the coaches saying Jones was doing fine.<br/>
<br/>
Now that the offensive line was giving the QBs time to throw, Jones to everyone&#39;s great surprise except for the coaches played exceedingly well, and Taylor looked comparatively inaccurate.<br/>
<br/>
Maybe it&#39;s time to give Daboll credit for employing practices that were not designed to make the offense look great, but to improve them. The point of preseason practices was not to pile up astounding stats to impress the reporters. Those practices were often designed to let the QB find out what plays were successful and the ones which were not. Interceptions were necessary though not desired. Now that Jones looked good in this preseason game, Daboll&#39;s practice methods are proving to be beneficial to the success of the team. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
So what happens when he faces hard defenses in the regular season? Or is the practice defense going to be the hardest he faces, when they can’t even hit the QB?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: The preseason game heard round the world </b><a name="15789082"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=mfsd"> mfsd </a>  : 1:20 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789082">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789036" target="_blank">15789036</a> Greg from LI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> . </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I&#39;m surprised they haven&#39;t given him a contract extension after that performance<br/>
<br/>
I&#39;m glad Jones looked good. Hope he keeps it up. Let&#39;s be honest, moving the ball against backups in the preseason was too much for the Giants of recent vintage to handle. At least we can do that now.<br/>
<br/>
As for Chris Simms, he&#39;s usually a good listen, but it would be easier to take him seriously if he didn&#39;t look like a door to door bible salesman</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Daboll is being vindicated </b><a name="15789085"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  : 1:23 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789085">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789078" target="_blank">15789078</a> ajr2456 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15789009 Rod in St Cloud said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Daboll has previously stated he was purposely making practices hard to put stress on some of the practices. During that time it allowed observers to believe Jones was doing poorly and Taylor outplaying Jones during these practices despite Daboll and the coaches saying Jones was doing fine.<br/>
<br/>
Now that the offensive line was giving the QBs time to throw, Jones to everyone&#39;s great surprise except for the coaches played exceedingly well, and Taylor looked comparatively inaccurate.<br/>
<br/>
Maybe it&#39;s time to give Daboll credit for employing practices that were not designed to make the offense look great, but to improve them. The point of preseason practices was not to pile up astounding stats to impress the reporters. Those practices were often designed to let the QB find out what plays were successful and the ones which were not. Interceptions were necessary though not desired. Now that Jones looked good in this preseason game, Daboll&#39;s practice methods are proving to be beneficial to the success of the team. <br/>
                                <br/>
                           <br/>
<br/>
So what happens when he faces hard defenses in the regular season? Or is the practice defense going to be the hardest he faces, when they can’t even hit the QB? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
That he isn&#39;t good enough. This whole Jones thing is pretty cut and dry, but these threads make it seem like anything but.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: Daboll is being vindicated </b><a name="15789090"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=ajr2456"> ajr2456 </a>  : 1:34 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789090">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789085" target="_blank">15789085</a> UConn4523 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> <br/>
<br/>
So what happens when he faces hard defenses in the regular season? Or is the practice defense going to be the hardest he faces, when they can’t even hit the QB? <br/>
                                <br/>
                           <br/>
<br/>
That he isn&#39;t good enough. This whole Jones thing is pretty cut and dry, but these threads make it seem like anything but. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Bingo. If they believed the excuses that have been made they would have picked up the option</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: The preseason game heard round the world </b><a name="15789092"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Greg+from+LI"> Greg from LI </a>  : 1:35 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789092">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789082" target="_blank">15789082</a> mfsd said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">I&#39;m surprised they haven&#39;t given him a contract extension after that performance</td>
                                </tr>
                           </tbody></table><br/>
<br/>
Tells you how desperate people are for any positive signs from Jones at all.<br/>
<br/>
If he plays well in regular season games, his critics (like me) will give him credit.  Crowing about two drives in an exhibition game against a second team defense just seems desperate.  Yes, it is better than he didn&#39;t play poorly against the Bengals.  Agreed.</div></div><div class="thread_post"><div class="thread_post_header"><b>That I do not agree with </b><a name="15789098"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  : 1:40 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789098">link</a>   </div></div><div class="thread_post_body">Why can&#39;t 2 things be true? I think its both reasonable and probable that 3 years of Jones hasn&#39;t warranted an auto investment of the $22m+ 5th year option, while also acknowledging that the horrific roster and coaching played a part and why he&#39;s not better.<br/>
<br/>
There&#39;s what, a $9m difference between the 5th year option and the tag? Absolute worst case scenario financially is Jones is good to great and we overspend by that amount to franchise him.</div></div><div class="thread_post"><div class="thread_post_header"><b>Is anyone really... </b><a name="15789102"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Brown_Hornet"> Brown_Hornet </a>  : 1:44 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789102">link</a>   </div></div><div class="thread_post_body">...Crowing about DJ&#39;s 2 drives?<br/>
<br/>
Other than to say it was nice to see?<br/>
<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Is anyone really... </b><a name="15789103"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=UConn4523"> UConn4523 </a>  : 1:49 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789103">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789102" target="_blank">15789102</a> Brown_Hornet said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> ...Crowing about DJ&#39;s 2 drives?<br/>
<br/>
Other than to say it was nice to see?<br/>
 </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Nope.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Thankfully, it doesn&#39;t matter what we think </b><a name="15789114"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 1:58 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789114">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15788789" target="_blank">15788789</a> Tom from LI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15788780 George from PA said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     Daboll, Kafka and the Giants matter.<br/>
<br/>
Still scary to pay him a longterm, big money deal....<br/>
If things go well.<br/>
<br/>
I wish they can get him for a few more years on the cheap <br/>
                                <br/>
                           <br/>
<br/>
and I agree. That is why I wanted to give him the 5th year. Make him do it 2 years in a row.<br/>
<br/>
It is what it is. I agree with Chris on the bashing. We don&#39;t know what we are looking at. <br/>
<br/>
Just let it play out. </td>
                                </tr>
                           </tbody></table><br/>
Or guarantee him $22.4M next year to watch him NOT do it two more years in a row. The 5th year option isn&#39;t cheap. It&#39;s just cheaper than full market value for a good (or better) QB. It would require a substantial improvement by DJ this year to even have that 5th year option price tag be close to a value, let alone a bargain.<br/>
<br/>
The way the Giants handled it is appropriate. You can&#39;t do it two years in a row until you&#39;ve done it one year in a row, and the Giants won&#39;t have to decide on next year until after this year. To have guaranteed DJ a 200% pay raise without even seeing him in this system would be foolish.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Is anyone really... </b><a name="15789120"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bw+in+dc"> bw in dc </a>  : 2:04 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789120">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789102" target="_blank">15789102</a> Brown_Hornet said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> ...Crowing about DJ&#39;s 2 drives?<br/>
<br/>
Other than to say it was nice to see?<br/>
 </td>
                                </tr>
                           </tbody></table><br/>
<br/>
There was some crowing on Sunday&#39;s game thread, which was amusing.<br/>
<br/>
The most interesting angle to me was that because Jones played better than Taylor, the debate was settled - Jones is clearly better than TT.<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>There’s Montana in the 1988 Super Bowl drive </b><a name="15789122"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=cosmicj"> cosmicj </a>  : 2:04 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789122">link</a>   </div></div><div class="thread_post_body">Dan Marion’s second season.  Mahomes’ 5000 yard season.  And those 5 good games Dan Jones played against pretty lousy defenses in 2019.<br/>
<br/>
The Mt Rushmore of NFL quarterbacking.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: why do the fans have to let it play out </b><a name="15789123"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 2:05 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789123">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15788793" target="_blank">15788793</a> Tom from LI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15788784 Mook80 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     if fans didn&#39;t say anything and just simply let the games play out message boards wouldnt exist.    Sports radio wouldnt exist.   hours and hours of programming on NFL Network and other networks wouldnt exist.   Hell at that point the NFL might not exist.      <br/>
<br/>
Fans don&#39;t need to let it play out.   They arent making the decision to bench or play him.     What the fans say doesn&#39;t matter <br/>
                                <br/>
                           <br/>
<br/>
That&#39;s your opinion and I respect that. I have come to peace that it is just a game played by millionaires for their billionaire team owners. My vote of not liking what they do is stop watching and buying their gear. I will spend time doing other things in life that bring me joy.<br/>
<br/>
I am a very positive guy by nature, and learned all the bitching in the world won&#39;t change a damn thing unless you have control over it.<br/>
<br/>
Hence let it play out.<br/>
<br/>
<br/>
 </td>
                                </tr>
                           </tbody></table><br/>
Cool, so you can let it play out. And those who would prefer to have opinions and engage in discussions in real time, can do that while you let it play out. I think your point of view is valid, because it works for you. And for others (myself included), the experience of being a sports fan would be less enjoyable if all it included was a passive approach without the debates and discussions along the way.<br/>
<br/>
I can understand how you prefer to let it play out because you know that your opinion doesn&#39;t actually change the outcome. And I hope you can understand how others prefer to engage in critical discourse even though their opinions don&#39;t actually change the outcome, but they find the discourse itself an essential part of being a sports fan. See how simple that was?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: interesting </b><a name="15789125"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=cjac"> cjac </a>  : 2:08 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789125">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15788950" target="_blank">15788950</a> Ron Johnson said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15788795 Dr. D said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
<br/>
... the piling on Daniel Jones by idiot Giant fans. Shut up. You don&#39;t know what you&#39;re looking at... I don&#39;t like that from my fellow Giants fans and wish they would back the hell off....” <br/>
                                <br/>
                           <br/>
<br/>
<br/>
Ouch </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I know i&#39;ve been looking at quite a few turnovers and quite a few losses.  <br/>
<br/>
Chris Simms can shill for Daniel Jones all he wants, he can suggest fans are ignorant, but until the team starts winning, and Daniel Jones starts turning the ball over.  He can kiss my ass</div></div><div class="thread_post"><div class="thread_post_header"><b>bw in bc </b><a name="15789126"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Rod+in+St+Cloud"> Rod in St Cloud </a>  : 2:09 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789126">link</a>   </div></div><div class="thread_post_body">All you say is true. The point being missed here is Daboll&#39;s practices are looking like he knows what he&#39;s doing. Granted as I said, Jones&#39;s improvement might just be going up against 2nd stringers. But it also could be true that Jones is showing legitimate improvement due to hard and difficult practices designed by Daboll. <br/>
<br/>
If that is the case, which isn&#39;t proven yet, then I look forward to seeing continued improvement. I would credit that to Daboll&#39;s influence and to Jones&#39;s hard work. As Sy said, it was encouraging to see. <br/>
<br/>
One exhibition game is not enough evidence to draw final conclusions on whether this will continue into the real season. As for me, I am not writing off Jones just yet!</div></div><div class="thread_post"><div class="thread_post_header"><b>Eh &#34;letting it play out&#34; </b><a name="15789127"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Spiciest+Memelord"> Spiciest Memelord </a>  : 2:10 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789127">link</a>   </div></div><div class="thread_post_body">Is asking too much and giving too much credit to the bbi Jones haters.  I just want ridiculousness of Jones haters spamming threads because he missed a pass in 7 on 7 non padded practice in July.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: interesting </b><a name="15789129"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=cjac"> cjac </a>  : 2:10 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789129">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789125" target="_blank">15789125</a> cjac said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15788950 Ron Johnson said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15788795 Dr. D said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
<br/>
... the piling on Daniel Jones by idiot Giant fans. Shut up. You don&#39;t know what you&#39;re looking at... I don&#39;t like that from my fellow Giants fans and wish they would back the hell off....” <br/>
                                <br/>
                           <br/>
<br/>
<br/>
Ouch <br/>
                                <br/>
                           <br/>
<br/>
I know i&#39;ve been looking at quite a few turnovers and quite a few losses.  <br/>
<br/>
Chris Simms can shill for Daniel Jones all he wants, he can suggest fans are ignorant, but until the team starts winning, and Daniel Jones starts turning the ball over.  He can kiss my ass </td>
                                </tr>
                           </tbody></table><br/>
<br/>
and Daniel Jones STOPS turning the ball over that is</div></div><div class="thread_post"><div class="thread_post_header"><b>The ongoing debate about Jones... </b><a name="15789134"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=lax+counsel"> lax counsel </a>  : 2:13 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789134">link</a>   </div></div><div class="thread_post_body">Is borderline insane at this point.  We know these things with near certainty about Jones:<br/>
<br/>
(1) He cannot be productive in an NFL offense without being a major turnover risk (see 2019);<br/>
<br/>
(2) He struggles to read defenses and adjust in real time to find open receivers; and<br/>
<br/>
(3) He cannot elevate the team around him to be better than currently situated.<br/>
<br/>
Will he be better with an improved oline and skill positions.  Of course, any qb would improve under those circumstances.  Will he make a bad team decent, or a good team great?  No, we know that, the proof is in the play.  Playing a vanilla second team defense with a better oline, he was &#34;better&#34;, but still struggled to lead a consistent scoring offense, because that&#39;s who he is,  that&#39;s his M.O. and will always be. <br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: bw in bc </b><a name="15789140"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Producer"> Producer </a>  : 2:19 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789140">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789059" target="_blank">15789059</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15789047 Rod in St Cloud said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     I have no complaint with Sy saying Jones looked bad in practice. He did look bad. So how do you explain looking good in the preseason game? Perhaps it&#39;s playing against 2nd teamers. But could it also be due to Daboll&#39;s strategy to create practices that are designed to put the offense in pressure situations that are not expected to have a high degree of success? Iron sharpens iron! <br/>
                                <br/>
                           <br/>
<br/>
Jones looked good against Cincinnati&#39;s backups who played a Vanilla 2. To his credit, he completed some straightforward throws and completed on high level throw - the back shoulder fade to Sills. <br/>
<br/>
Do you want me to post highlights thus far of Mahomes in preseason? And the throws he has made? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Almost entirely checkdowns from a clean pocket with time. If he couldn&#39;t kill in that scenario he has no business on a football field, to be perfectly honest.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: ... </b><a name="15789148"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dr.+D"> Dr. D </a>  : 2:27 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789148">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15788946" target="_blank">15788946</a> christian said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> If the definition of the guy means someone who is good enough to win the Super Bowl, and Daniel Jones shows that this year -- I don&#39;t believe you&#39;ll find a single poster on this site who would argue that&#39;s not a good thing.<br/>
 </td>
                                </tr>
                           </tbody></table><br/>
Of course I don&#39;t think Jones is going to lead us to a super bowl this year (I hope he does lead us to a playoff spot). <br/>
<br/>
Obviously, if Jones sucks this year, he&#39;s gone. But if he has a really good year, we have to trust Schoen and Daboll to extrapolate/project and decide if Jones continues to develop and the team continues to add talent, is DJ good enough to EVENTUALLY (say 2-4 years from now) win the Super Bowl. <br/>
<br/>
If the answer is yes, then tagging him could be prudent. See if he can do it again and continue to improve.<br/></div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: ... </b><a name="15789155"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Producer"> Producer </a>  : 2:32 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789155">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789148" target="_blank">15789148</a> Dr. D said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15788946 christian said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     If the definition of the guy means someone who is good enough to win the Super Bowl, and Daniel Jones shows that this year -- I don&#39;t believe you&#39;ll find a single poster on this site who would argue that&#39;s not a good thing.<br/>
 <br/>
                                <br/>
                           <br/>
Of course I don&#39;t think Jones is going to lead us to a super bowl this year (I hope he does lead us to a playoff spot). <br/>
<br/>
Obviously, if Jones sucks this year, he&#39;s gone. But if he has a really good year, we have to trust Schoen and Daboll to extrapolate/project and decide if Jones continues to develop and the team continues to add talent, is DJ good enough to EVENTUALLY (say 2-4 years from now) win the Super Bowl. <br/>
<br/>
If the answer is yes, then tagging him could be prudent. See if he can do it again and continue to improve. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Anything less than elite performance,  he should be gone.</div></div><div class="thread_post"><div class="thread_post_header"><b>For a whole lot of posters that say there really is nothing  </b><a name="15789157"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Jimmy+Googs"> Jimmy Googs </a>  : 2:32 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789157">link</a>   </div></div><div class="thread_post_body">worth discussing regarding Daniel Jones and think the whole situation is cut and dry, they sure seem to post a good bit on these type of threads...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: bw in bc </b><a name="15789163"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Now+Mike+in+MD"> Now Mike in MD </a>  : 2:34 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789163">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789140" target="_blank">15789140</a> Producer said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15789059 bw in dc said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15789047 Rod in St Cloud said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     I have no complaint with Sy saying Jones looked bad in practice. He did look bad. So how do you explain looking good in the preseason game? Perhaps it&#39;s playing against 2nd teamers. But could it also be due to Daboll&#39;s strategy to create practices that are designed to put the offense in pressure situations that are not expected to have a high degree of success? Iron sharpens iron! <br/>
                                <br/>
                           <br/>
<br/>
Jones looked good against Cincinnati&#39;s backups who played a Vanilla 2. To his credit, he completed some straightforward throws and completed on high level throw - the back shoulder fade to Sills. <br/>
<br/>
Do you want me to post highlights thus far of Mahomes in preseason? And the throws he has made? <br/>
                                <br/>
                           <br/>
<br/>
Almost entirely checkdowns from a clean pocket with time. If he couldn&#39;t kill in that scenario he has no business on a football field, to be perfectly honest. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
The fact that you are calling those passes checkdowns shows you know precisely d$ck about football.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: The ongoing debate about Jones... </b><a name="15789164"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Now+Mike+in+MD"> Now Mike in MD </a>  : 2:36 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789164">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789134" target="_blank">15789134</a> lax counsel said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> Is borderline insane at this point.  We know these things with near certainty about Jones:<br/>
<br/>
(1) He cannot be productive in an NFL offense without being a major turnover risk (see 2019);<br/>
<br/>
(2) He struggles to read defenses and adjust in real time to find open receivers; and<br/>
<br/>
(3) He cannot elevate the team around him to be better than currently situated.<br/>
<br/>
Will he be better with an improved oline and skill positions.  Of course, any qb would improve under those circumstances.  Will he make a bad team decent, or a good team great?  No, we know that, the proof is in the play.  Playing a vanilla second team defense with a better oline, he was &#34;better&#34;, but still struggled to lead a consistent scoring offense, because that&#39;s who he is,  that&#39;s his M.O. and will always be.  </td>
                                </tr>
                           </tbody></table><br/>
<br/>
You cannot know point (1) with any level of certainty.  Most rookie QBs struggle with turnovers.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: bw in bc </b><a name="15789165"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Producer"> Producer </a>  : 2:38 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789165">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789163" target="_blank">15789163</a> Now Mike in MD said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15789140 Producer said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15789059 bw in dc said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15789047 Rod in St Cloud said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     I have no complaint with Sy saying Jones looked bad in practice. He did look bad. So how do you explain looking good in the preseason game? Perhaps it&#39;s playing against 2nd teamers. But could it also be due to Daboll&#39;s strategy to create practices that are designed to put the offense in pressure situations that are not expected to have a high degree of success? Iron sharpens iron! <br/>
                                <br/>
                           <br/>
<br/>
Jones looked good against Cincinnati&#39;s backups who played a Vanilla 2. To his credit, he completed some straightforward throws and completed on high level throw - the back shoulder fade to Sills. <br/>
<br/>
Do you want me to post highlights thus far of Mahomes in preseason? And the throws he has made? <br/>
                                <br/>
                           <br/>
<br/>
Almost entirely checkdowns from a clean pocket with time. If he couldn&#39;t kill in that scenario he has no business on a football field, to be perfectly honest. <br/>
                                <br/>
                           <br/>
<br/>
The fact that you are calling those passes checkdowns shows you know precisely d$ck about football. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
The fact that you don&#39;t understand what a check down is shows you don&#39;t know what you&#39;re looking at. I praised elsewhere the high fade to Sills. That was his best throw.  The rest were unexceptional.  He executed well, for sure, but they were check downs and safety valve ays for the most part.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: ... </b><a name="15789169"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Jimmy+Googs"> Jimmy Googs </a>  : 2:40 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789169">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789148" target="_blank">15789148</a> Dr. D said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15788946 christian said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     If the definition of the guy means someone who is good enough to win the Super Bowl, and Daniel Jones shows that this year -- I don&#39;t believe you&#39;ll find a single poster on this site who would argue that&#39;s not a good thing.<br/>
 <br/>
                                <br/>
                           <br/>
Of course I don&#39;t think Jones is going to lead us to a super bowl this year (I hope he does lead us to a playoff spot). <br/>
<br/>
Obviously, if Jones sucks this year, he&#39;s gone. But if he has a really good year, we have to trust Schoen and Daboll to extrapolate/project and decide if Jones continues to develop and the team continues to add talent, is DJ good enough to EVENTUALLY (say 2-4 years from now) win the Super Bowl. <br/>
<br/>
If the answer is yes, then tagging him could be prudent. See if he can do it again and continue to improve. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Well they can tag him twice.  And in the meanwhile, petition the NFL League Office to change the rules regarding franchise tags and ask to extend it to 4 years. That should only cost about $150M over that time frame.<br/>
<br/>
Maybe by then DJ will have developed and the team around him will be good enough to bring that 5th Lombardi home.<br/>
<br/>
championship...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: RE: RE: bw in bc </b><a name="15789180"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Now+Mike+in+MD"> Now Mike in MD </a>  : 2:48 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789180">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789165" target="_blank">15789165</a> Producer said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15789163 Now Mike in MD said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15789140 Producer said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15789059 bw in dc said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     In comment 15789047 Rod in St Cloud said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     I have no complaint with Sy saying Jones looked bad in practice. He did look bad. So how do you explain looking good in the preseason game? Perhaps it&#39;s playing against 2nd teamers. But could it also be due to Daboll&#39;s strategy to create practices that are designed to put the offense in pressure situations that are not expected to have a high degree of success? Iron sharpens iron! <br/>
                                <br/>
                           <br/>
<br/>
Jones looked good against Cincinnati&#39;s backups who played a Vanilla 2. To his credit, he completed some straightforward throws and completed on high level throw - the back shoulder fade to Sills. <br/>
<br/>
Do you want me to post highlights thus far of Mahomes in preseason? And the throws he has made? <br/>
                                <br/>
                           <br/>
<br/>
Almost entirely checkdowns from a clean pocket with time. If he couldn&#39;t kill in that scenario he has no business on a football field, to be perfectly honest. <br/>
                                <br/>
                           <br/>
<br/>
The fact that you are calling those passes checkdowns shows you know precisely d$ck about football. <br/>
                                <br/>
                           <br/>
<br/>
The fact that you don&#39;t understand what a check down is shows you don&#39;t know what you&#39;re looking at. I praised elsewhere the high fade to Sills. That was his best throw.  The rest were unexceptional.  He executed well, for sure, but they were check downs and safety valve ays for the most part. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
WIthout knowing the read progression on a particular play, you have no idea whether any of those throws were checkdowns or whether they were the first option.  Simply  because a pass is short, does not mean it was a checkdown.  So unless you are privy to the Giants playbook, any statement that any throw was a checkdown is nothing more than supposition on your part</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: RE: Daboll is being vindicated </b><a name="15789181"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Dr.+D"> Dr. D </a>  : 2:49 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789181">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789090" target="_blank">15789090</a> ajr2456 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15789085 UConn4523 said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     <br/>
<br/>
So what happens when he faces hard defenses in the regular season? Or is the practice defense going to be the hardest he faces, when they can’t even hit the QB? <br/>
                                <br/>
                           <br/>
<br/>
That he isn&#39;t good enough. This whole Jones thing is pretty cut and dry, but these threads make it seem like anything but. <br/>
                                <br/>
                           <br/>
<br/>
Bingo. If they believed the excuses that have been made they would have picked up the option </td>
                                </tr>
                           </tbody></table><br/>
That&#39;s just not true. Why is it so f*ing hard to believe that they don&#39;t know if he&#39;s the guy or not? That they recognize the ton of shit he&#39;s had going against him that was out of his control (just like Chris Simms, Mike Florio and a bunch of others recognize). <br/>
<br/>
That&#39;s basically what Daboll and Schoen have been saying. Why assume they&#39;re lying and that they&#39;ve resigned themselves to having a shitty year and drafting another QB in &#39;23?<br/>
<br/>
I&#39;m sure they also know how hard it is to find a franchise QB and how many assets might be needed to draft another (who most likely also won&#39;t be a sure thing) and they simply want to give him one last year (under MUCH better conditions) to prove one way or another. And based on his performance this year, they&#39;ll decide to tag him or whatever. Why is that scenario such an impossibility?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Is anyone really... </b><a name="15789188"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Brown_Hornet"> Brown_Hornet </a>  : 2:56 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789188">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789120" target="_blank">15789120</a> bw in dc said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15789102 Brown_Hornet said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     ...Crowing about DJ&#39;s 2 drives?<br/>
<br/>
Other than to say it was nice to see?<br/>
 <br/>
                                <br/>
                           <br/>
<br/>
There was some crowing on Sunday&#39;s game thread, which was amusing.<br/>
<br/>
The most interesting angle to me was that because Jones played better than Taylor, the debate was settled - Jones is clearly better than TT. </td>
                                </tr>
                           </tbody></table>Well...gamethreads are filled with all sorts of emotional outbursts.<br/>
<br/>
I believe that it is settled. DJ is QB1, TT is the QB2.<br/>
I don&#39;t believe that it has anything to do with Sunday&#39;s game.</div></div><div class="thread_post"><div class="thread_post_header"><b>These threads go the same way </b><a name="15789191"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Lines+of+Scrimmage"> Lines of Scrimmage </a>  : 3:00 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789191">link</a>   </div></div><div class="thread_post_body">I am looking beyond Jones and just let it play out.<br/>
<br/>
The bigger underlying story of this season is a new HC and two critical areas that just may be showing signs of coming out of the great destruction (2012-17).  Some good news on the OL front recognizing some more work is needed.  The surprise may be we could have a really good D pretty quick around here with a elite front 7 in the making.  <br/>
<br/>
Whatever happens with Jones will be settled.  Whoever is starting in 2023 if what I wrote above materializes will be far better off.</div></div><div class="thread_post"><div class="thread_post_header"><b>Whatever </b><a name="15789192"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Debaser"> Debaser </a>  : 3:00 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789192">link</a>   </div></div><div class="thread_post_body">I would have liked to see him throw down the field more. That should have been batting practice for him.<br/>
<br/>
And I get the suspicion that no matter how mediocre Jones is ; we will have to hear relentlessly about how great Jones is; and how Eli or Simms did this or that in their 4th year; or how they should franchise tag him. LOL!<br/>
<br/>
This is an option not even used by the majority of teams who need extra time to evaluate a star players long term deal in some cases. Not to keep some guy that fans just like because he is a clean nose kid or because they predicted star in the making his rookie year and can&#39;t face the fact they are dead wrong.</div></div><div class="thread_post"><div class="thread_post_header"><b>And said star player is a proven star </b><a name="15789194"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Debaser"> Debaser </a>  : 3:02 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789194">link</a>   </div></div><div class="thread_post_body">not some guy  you hope just becomes a kirk COusins</div></div><div class="thread_post"><div class="thread_post_header"><b>All these negative comments about DJ reminds me of Giant fan history  </b><a name="15789206"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=plato"> plato </a>  : 3:09 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789206">link</a>   </div></div><div class="thread_post_body">re qb’s. My early years as a preteen left me puzzled why Giant fans reacted to the announcement of Charlie Conerley with a barrage of boos aimed at “chucking Charlie”<br/>
<br/>
After suffering the “dark years” I was an adult who remembers the boos from Giant fans over the selection of unknown Phil Simms as qb. This continued throughout his first 3-4 years through injury and misplay. He earned respect after winning a super bowl.<br/>
<br/>
Then came Eli. How many Giant fans shouted and laughed to “We got the wrong  <br/>
brother” Some Giant fans seemed to enjoy watching reruns of Eli getting smacked by a line backer, an Eagle if I remember.  How many fans and writers questioned his athleticism, arm strength, ability to make tough throws, etc seemingly for years but at least first three.<br/>
<br/>
So fans are not good judges of football prowess. George Young got abuse for drafting LT where he did. Such is the nature of fandom. I am not saying DJ can or should be compared to any mentioned here. What I am saying is that DJ needs a chance to be evaluated by football competent people.<br/>
Hopefully he can look like he did at times in is first year and move above all this “fandom” hatred.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: All these negative comments about DJ reminds me of Giant fan history  </b><a name="15789212"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Greg+from+LI"> Greg from LI </a>  : 3:16 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789212">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789206" target="_blank">15789206</a> plato said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">I am not saying DJ can or should be compared to any mentioned here.</td>
                                </tr>
                           </tbody></table><br/>
<br/>
And, yet, that is exactly what you did.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: All these negative comments about DJ reminds me of Giant fan history  </b><a name="15789221"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Johnny5"> Johnny5 </a>  : 3:22 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789221">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789212" target="_blank">15789212</a> Greg from LI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15789206 plato said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                    I am not saying DJ can or should be compared to any mentioned here.<br/>
                                <br/>
                           <br/>
<br/>
And, yet, that is exactly what you did. </td>
                                </tr>
                           </tbody></table><br/>
Is he wrong in the way he compared them? Not hardly.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: All these negative comments about DJ reminds me of Giant fan history  </b><a name="15789224"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=bigblue5611"> bigblue5611 </a>  : 3:25 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789224">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789212" target="_blank">15789212</a> Greg from LI said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15789206 plato said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                    I am not saying DJ can or should be compared to any mentioned here.<br/>
                                <br/>
                           <br/>
<br/>
And, yet, that is exactly what you did. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
But not really...  Comparing the situations is not the same as comparing the players themselves...</div></div><div class="thread_post"><div class="thread_post_header"><b>Bad enough that Eli and Phil Simms get brought up  </b><a name="15789226"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Jimmy+Googs"> Jimmy Googs </a>  : 3:26 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789226">link</a>   </div></div><div class="thread_post_body">in a non-sensical fashion when posters feel they need to defend Jones.<br/>
<br/>
But now we have to reach back to the days of Charlie Connerly to get the full picture?<br/>
<br/>
good lord...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: RE: All these negative comments about DJ reminds me of Giant fan history  </b><a name="15789228"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Greg+from+LI"> Greg from LI </a>  : 3:26 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789228">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789221" target="_blank">15789221</a> Johnny5 said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody">                           <br/>
Is he wrong in the way he compared them? Not hardly. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
Comparing Jones to Simms or Manning is ludicrous and beyond played out.</div></div><div class="thread_post"><div class="thread_post_header"><b>I see that we&#39;re talking about Jones </b><a name="15789230"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Producer"> Producer </a>  : 3:29 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789230">link</a>   </div></div><div class="thread_post_body">and some of you guys are talking about us. Let&#39;s stick to Jones, ok? You don&#39;t agree, state why. Don&#39;t lash out at Giants fans because we scrutinize the play of the Giants QB.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: I see that we&#39;re talking about Jones </b><a name="15789237"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Now+Mike+in+MD"> Now Mike in MD </a>  : 3:34 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789237">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789230" target="_blank">15789230</a> Producer said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> and some of you guys are talking about us. Let&#39;s stick to Jones, ok? You don&#39;t agree, state why. Don&#39;t lash out at Giants fans because we scrutinize the play of the Giants QB. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
But if you&#39;re making inane, unspoorted statements in analyzing DJ, are those not supposed to be identified?</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: Bad enough that Eli and Phil Simms get brought up  </b><a name="15789240"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Gatorade+Dunk"> Gatorade Dunk </a>  : 3:38 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789240">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789226" target="_blank">15789226</a> Jimmy Googs said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> in a non-sensical fashion when posters feel they need to defend Jones.<br/>
<br/>
But now we have to reach back to the days of Charlie Connerly to get the full picture?<br/>
<br/>
good lord... </td>
                                </tr>
                           </tbody></table><br/>
Look at the bright side - at least Grizz&#39;s new handle learned how to spell.</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: I see that we&#39;re talking about Jones </b><a name="15789241"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Jimmy+Googs"> Jimmy Googs </a>  : 3:39 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789241">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789237" target="_blank">15789237</a> Now Mike in MD said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15789230 Producer said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     and some of you guys are talking about us. Let&#39;s stick to Jones, ok? You don&#39;t agree, state why. Don&#39;t lash out at Giants fans because we scrutinize the play of the Giants QB. <br/>
                                <br/>
                           <br/>
<br/>
But if you&#39;re making inane, unspoorted statements in analyzing DJ, are those not supposed to be identified? </td>
                                </tr>
                           </tbody></table><br/>
<br/>
No, that would make it even...</div></div><div class="thread_post"><div class="thread_post_header"><b>RE: RE: Bad enough that Eli and Phil Simms get brought up  </b><a name="15789243"> </a><div class="thread_info"><a href="index.php?mode=5&amp;handle=Jimmy+Googs"> Jimmy Googs </a>  : 3:41 pm   : <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789243">link</a>   </div></div><div class="thread_post_body">In comment <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1#15789240" target="_blank">15789240</a> Gatorade Dunk said:<br/>
<table border="0" cellpadding="3" cellspacing="0">
                                <tbody><tr>
                                    <td class="quotecodeheader"> Quote:</td>
                                </tr>
                                <tr>
                                    <td class="quotebody"> In comment 15789226 Jimmy Googs said:<br/>
<br/>
                                <br/>
                                     Quote:<br/>
                                <br/>
                                <br/>
                                     in a non-sensical fashion when posters feel they need to defend Jones.<br/>
<br/>
But now we have to reach back to the days of Charlie Connerly to get the full picture?<br/>
<br/>
good lord... <br/>
                                <br/>
                           <br/>
Look at the bright side - at least Grizz&#39;s new handle learned how to spell. </td>
                                </tr>
                           </tbody></table><br/>
<br/>
I just saw another guy posting that was a grizz look-a-like.  <br/>
<br/>
Let me find it and get back to you...</div></div><div style="margin: 10 10 20 50"><span class="top_pages">Pages:  <a href="index.php?mode=2&amp;thread=624695&amp;thread_page=1">1</a>  <a href="index.php?mode=2&amp;thread=624695&amp;thread_page=2">2</a>  <b style="background: darkred;padding: 2px 5px 2px 5px;">3</b>  <a href="index.php?mode=2&amp;thread=624695&amp;thread_page=2">&lt;&lt;Prev </a>| <a href="index.php?mode=2&amp;thread=624695&amp;show_all=1" title="">Show All</a> | </span></div>
<a name="END"></a><a href="index.php"></a><div style="padding-top:25px; padding-bottom:20px;"><a href="index.php"><img src="/images/back_corner.gif" class="thread_link" alt="Back to the Corner" border="0"/></a></div></div>
<div class="thread_sidebar_2">

<!-- Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-102">
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Corner Forum - Lower 300x250 -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1566320450447229" data-ad-slot="4189314539" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - Forum In-Thread Lower Box (AdSense) - sidebar_middle -->

</div>

</div>




<div class="footer">


<p style="width:450px;float:left;padding:10px;"><b>Part of the USA Today Sports Media Group</b><br/>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. This site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.
</p>
<p style="width:400px;float:right; text-align:right;padding:10px;">
All contents (unless otherwise specified) copyright ©  1995 - 2021<br/>
Big Blue Interactive, LLC. All Rights Reserved.<br/> <br/><strong>Site Managed by <a href="http://www.pcqb.com/" target="new" rel="nofollow">PCQB WordPress Solutions</a></strong>
</p>
<br clear="all"/>
 
</div>




<!-- Begin Google Analytics Code -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script>

<!-- End Google Analytics Code -->



<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=1&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=1&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-1");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=1&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script>
<script>__ez.queue.addFile('/beardeddragon/drake.js', '/beardeddragon/drake.js?gcb=1&cb=4', false, [], true, false, true, false);</script></body></html>